Topic: NCache

NCache 4.4
Next page >
Welcome to NCache version 4.4. NCache is a caching solution that provides high performance and scalability. NCache provides a set of services and API's that incorporates various user needs of caching.
NCache package contains samples, tutorials, and tools designed to help you incorporate NCache in your applications. Package also provides a documentation that includes an extensive class library reference, conceptual overviews and step-by-step illustrations to assist you in understanding NCache more effectively.
In NCache Documentation
Introduction to NCache
Presents a brief introduction to NCache, with an emphasis on new and old features, editions and requirements of NCache.
Caching Concepts
Discusses important caching concepts to enable you to understand the later sections in a better way.
Installation Guide
Discusses step by step details for installation and activation of NCache using interactive Windows installer and command line installer. It also explains NCache network install with Powershel and NCache Java client installation for UNIX.
Getting Started
Familiarizes you with the fundamentals of NCache and offers help to use NCache quickly and efficiently.
Administrator's Guide
Provides a guide to perform administrative tasks and configuring settings of caches and bridges using NCache Manager, command line tools and configuration files.
Programmer's Guide
Focuses on what is essential to become skilled at developing with NCache. It includes programmer's guide, sample applications, hands on tutorials and extensive help on API reference.
Troubleshooting
Helps in troubleshooting different problems that may arise while using NCache.
How to's
Provides the answers to some of the most commonly asked questions regarding NCache.
Send comments on this topic.
Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Introduction to NCache

< Previous page Next page >

Introduction to NCache

NCache is a clustered caching solution that makes sharing and managing data in a cluster as simple as on a single server. It accomplishes this by coordinating updates to the data using cluster wide concurrency control and replicating and distributing data modifications across the cluster using the highest performing clustered protocol available. The primary purpose of NCache is to help improve performance of .NET applications that would otherwise make expensive trips to database systems, web services, mainframes, or other systems across the network.
In This Section
What's New in 4.4?
Updates you with new features in the latest version of NCache.
Dynamic Clustering
Gives an overview of dynamic clustering in NCache.
Caching Topologies
Gives an overview of various topologies.
Feature Highlight
Describes various features that NCache provides.
Support for .NET & ASP.NET Apps
Describes .NET and ASP.NET application support in NCache.
Support for Java & JSP Apps
Describes Java & JSP application support in NCache.
Copyright ©
Gives the copyright statement for NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: What's New in NCache 4.4?

< Previous page Next page >

What's New in NCache 4.4?

NCache 4.4 brings many new features and enhances graphical user interface to the next level. Here is a brief overview of what's new in NCache 4.4:
Visual Studio Integration
NCache can now be integrated with Visual Studio 2010/2012/2013 (Enterprise & Community). Basic management and configuration operations can now be performed within the Visual Studio. NCache 4.4 SP1 Developer installation now comes with an ‘NCache Manager’ extension which helps developers manage NCache from Visual Studio.
Entity Framework 6.0 Support
Entity Framework 6.0 and 6.1 integration is provided in NCache 4.4 Service Pack 1 (SP1). In SP1, NCache also provides caching extensions for Entity Framework 6.0 which allows developers more control over which entities to cache. This is available for developers who want greater control over the entities being cached, as an alternate to the ‘no-code-change configuration’ option.
Windows Server 2012 R2 Certification
NCache 4.4 SP1 is certified for Windows Server 2012 R2. It has been tested by Microsoft’s approved tester and passed all compatibility tests. Microsoft validated that NCache works in accordance with Microsoft’s standards.
NCache SDK NuGet Package
NuGet is a package manager for Microsoft Visual Studio development in .NET. The NuGet Gallery is a central repository of all NuGet packages.
A NuGet package is provided for developers to build applications using NCache without installing NCache on their machines. With this package, developers can write their applications using an NCache API and test them with InProc cache. This gives you full control to use NCache SDK without installing it.
NCache in Azure Marketplace
NCache can be deployed in Microsoft Azure Virtual Machines with all its features. Additionally, the following features are available in Microsoft’s Azure environment exclusively for NCache and not provided by any other caching solution:
  1. Sharing ASP.NET Sessions across regions
  2. WAN replication of cache across regions
  3. Memcached Wrapper for NCache
NCache is available in Azure Marketplace.
NCache in Amazon Web Services (AWS)
NCache can be deployed in Amazon Web Services (AWS) as Virtual Machines with all its features. In AWS, NCache can either reside on the same Virtual Machine as the applications that are using it, or on separate Virtual Machines. The following caching features are available in AWS:
  1. Sharing ASP.NET Sessions across regions
  2. WAN replication of cache across regions
  3. Memcached Wrapper for NCache
NCache is available at AWS.
NCache is Now Open Source
NCache is also available as Open Source. NCache Open Source is released under the Apache 2.0 Open Source license. This provides the .NET developer community with unrestricted access to a truly elastic native .NET Distributed Cache. For more details please refer to the Edition Comparison page.
NCache Switching to an Annual Subscription Based Pricing Model
In Version 4.4 NCache will be switching to an annual subscription based pricing model. Upon expiration the customer will need to renew the subscription to continue using NCache. Provision will also be provided for the purchase of a multi-year subscription. For more details please refer to the Pricing page.
Memcached Wrapper for NCache
Memcached Wrapper for NCache provides a no-code-change way for migrating Memcached applications to a powerful elastic distributed cache. See more details on the NCache vs. Memcached comparison page.
The Memcached Wrapper for NCache can be used in the following two ways:
  1. Memcached Plug-In (for .NET apps)
  2. Memcached Gateway
The Memcached plug-in option is for .NET applications. Alachisoft has taken all the popular Open Source Memcached client libraries and implemented them for NCache. These libraries for .NET are:
  1. enyim
  2. BeIT
  3. More…
The Memcached Gateway implements Memcached Protocols and supports all types of Memcached applications. Applications are directed to the Memcached Gateway and they start using NCache behind the scenes.
Read-Through and Write-Through Providers
Develop multiple Read-Through/Write-Through providers and register it with NCache. You can use a specific provider from each of your Java application. You are also facilitated to use NCache Manager to deploy your Read-Through/Write-Through handlers even at runtime. Your assemblies are automatically copied to all the cache servers.
Data Sharing between .NET and Java
With Data Sharing you can share cache content among NCache .NET and NCache Java editions. This sharing can be achieved through binary compact serialization. To use this feature user must have both NCache .NET and NCache Java editions installed.
Class Versioning in Same Platform
Using Class Versioning you can share class data among various versions of a class with in a same platform. Here mapping of attributes is done at run time.
Support for Dynamic Compact Serialization
Use a faster and more compact serialization than regular Java serialization and without writing any custom code for it. NCache generated serialization code at runtime and even lets you serialize objects that are otherwise not serializable.
Support for Named Tags in .NET
NCache can associate a dictionary of named tags with cache items. Items can be objects or text data. Named Tags helps in indexing the data on the basis of tags and you can query indexed data using tags.
Cache Startup Option
Using Cache Startup option if the cache is specified to be a startup cache, it will get started automatically on service startup. No manual start is required for the cache.
Support for Continuous Query in .NET
NCache provides Continuous Query support for both .Net and Java clients. It notifies about the changes occur in query result set and therefore client applications need not to re-query the data for updates.
Bridge (Enhanced):
An enhanced bridge feature is introduced having support for multiple topologies. It performs an asynchronous replication of data from one on-site cache to one/multiple on-site/off-site disaster recovery cache(s) across the WAN.
Bridge Conflict Resolver for .NET
Bridge Conflict Resolver resolves the conflict occur while replicating the data from bridge to cache.
See Also
Dynamic Clustering | Caching Topologies | Copyright ©
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Self Healing Dynamic Clustering

< Previous page Next page >

Self Healing Dynamic Clustering

NCache has a self-healing dynamic clustering capability based on a peer-to-peer cluster architecture. NCache does not use Windows Clustering or any other OS-based clustering but instead creates its own TCP based dynamic cluster of cache servers. The purpose of this dynamic cluster is to provide you 100% uptime by allowing you to add or remove cache servers from the cluster at runtime without stopping the dynamic cluster.
With dynamic clustering you can get the following capabilities:
  • 100% uptime for the cluster due to peer to peer architecture
  • Add or remove cache servers at runtime without stopping the cache
  • Can perform load balancing for client connections to cache servers (at connection time)
  • Clients automatically reconnect to a different cache server if their server goes down
NCache provides a dynamic clustering capability with 100% uptime for the cluster. This is due to a peer to peer architecture of the cluster where there is no single point of failure.
A cache cluster is a collection of one or more cache servers with every server connected to every other server in the cluster. When a cache cluster is formed, it contains a cluster coordinator that manages all membership to the cluster. The coordinator is the oldest server in the cluster (meaning the first server that started). If the coordinator ever goes down, this role passes on to the next senior-most server in the cluster. This removes any single point of failure in cluster membership management.
You can find out more detail on our website for Self Healing Dynamic Clustering .
See Also
Caching Topologies
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Caching Topologies

< Previous page Next page >

Caching Topologies

A caching topology is essentially data storage strategy in a clustered cache. NCache provides a rich set of caching topologies to let you choose the one that suits your environment best. The goal of this is to cater from very small two-server caches to very large cache clusters consisting of hundreds of cache servers. Below are the main caching topologies provided to you:
  • Mirrored Cache (2-server active/passive)
  • Replicated Cache
  • Partitioned Cache
  • Partitioned-Replica Cache (Asynchronous and Synchronous)
  • Client Cache (a Local Cache connected to a Clustered Cache)
A short explanation of each of these caching topologies is given below.
Reference Data versus Transactional Data:
Reference data use means you cache something once and read it over and over again. So, there are a lot more reads than writes. On the other hand, transactional data use means that you're updating the data as frequently as you're reading it (or fairly close to it). Originally, cache was considered good only for reference data but distributed caches have proven to be faster and more scalable than databases even for transactional data.
Caching a product catalog where prices change maybe once a day or so is reference use. On the other hand, ASP.NET Session State and JSP Servlet session storage is considered a transactional use.
All topologies are good for reference data but only some topologies are good for transactional data. You need to determine how many updates you'll be doing to figure out which topology is best for you. Below is a list.
Mirrored Cache
A Mirrored Cache is a 2-server active/passive cache cluster. In mirrored cache there is one active and one passive node only and no client can connect with passive unless it is active. Primarily passive node is used to keep asynchronous backup of data. A mirrored cache has no clustering cost, besides it gives data reliability through backup. By default, ImportHashmap flag will be false as in this topology client is not aware of data distribution between servers.
  • Reference data : Good. Max 30000 reads/sec (1k size).
  • Transactional data : Good. Max 20000 writes/sec (1k size).
Replicated Cache
A Replicated Cache consists of two or more cache servers in a cluster (there is no limit for number of nodes however, recommendation is for maximum three). It is suitable for situations where transactional data usage is lesser than reference data usage. Performance can slow down in transactional data because updates are applied synchronously on all the other servers in the cluster. Moreover, performance can diminish when more nodes are added in cluster. By default, ImportHashmap flag will be false.
  • Reference data : Good. 30000 reads/sec per server. Grow linearly by adding servers.
  • Transactional data : Not so good. Max 2500 writes/sec. Drops if you add 3rd server.
Partitioned Cache (no replication):
A Partitioned Cache is intended for larger cache clusters as it is a very scalable caching topology. It is suitable in cases where performance is your major concern but without reliability of data. If any cache server goes down, data will be lost of that node as there is no replication/backup of data. Client gets connected with each server and request is sent to the targeted server only because client is aware of data distribution flanked by servers. By default, ImportHashmap flag will be true as client is data aware.
  • Reference data : Good. 30000 reads/sec per server. Grow linearly by adding servers.
  • Transactional data : Good. 25000 writes/sec per server. Grow linearly by adding servers.
Partition-Replica Cache (with replication):
Partitioned-Replica topology is combination of Partitioned topology and Replicated topology. It gives high performance with Reliability of data through replication and scalability through partitioning. It is suitable in cases where performance is major concern without fear of data loss. Partitioned-Replica provides both sync and async replication whereas, async replication is the default option. Async replication is quick for the reason that user doesn’t have to wait for operation to be done on replica as well. By default, ImportHashmap flag will be true.
  • Reference data : Good. 30000 reads/sec per server. Grow linearly by adding servers.
  • Transactional data : Good. 20000 writes/sec per server. Grow linearly by adding servers.
There is some overlap between Mirrored Cache and Partitioned-Replica Cache for 2-server clusters because both provide similar performance with replication. But, Mirrored Cache accommodates situations where you only have one dedicated cache server and the mirror server is being shared with other apps. But, if you have a need for 3 or more cache servers, then Partition-Replica Cache is the best choice for transactional use.
It is recommended to create a cache of at least 20% greater size than the actual data size.
For more details, either see Caching Concepts - Cache Topologies or visit Caching Topologies on our website.
See Also
Dynamic Clustering
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Features Highlights

< Previous page Next page >

Features Highlights

Below are some features of NCache. Have a look at them:
Light-weight .NET Client
NCache now has a light-weight client that is more scalable and faster than 3.0. This light-weight client uses our own socket level protocol to talk to NCache server (either locally or remotely).
Light-weight Java Client
NCache does not rely on any Java-to-.NET interoperability bridge and instead uses its own socket level protocol to talk to the NCache server (just like the .NET light-weight client). Now you can have your Java applications use NCache as a clustered object cache. This protects your investment in NCache and allows you to keep one cache deployed and used by multiple applications. Java client works the same way as .NET client. The Java client can run on any Java compatible platform.
Failover in Remote Light-weight Clients
Both Java and .NET light-weight clients have fail over capability. This means that if the primary server they're connected to goes down, they'll automatically connect to another server in the cluster. And, you can specify the priority of these servers for each client differently. Additionally, when new servers are added or removed at runtime, this information is passed on to the remote clients so they can use them for failover as well.
Security
NCache now provides security with authentication and authorization built into the product. Authentication is done through LDAP. NCache allows you to specify administrators and users. Administrators can manage the cluster while the users can only make runtime API calls to a specific cache. NCache allows you to save data in encrypted form in order to secure your data. For this 3DES Encryption algorithm is used.
Application Connects to Multiple Caches
NCache client applications can now connect to multiple caches simultaneously. This allows you to keep multiple caches for different purposes and share them across applications more effectively.
Multi-key Event Notifications
Applications can register interest into multiple items in the cache to be notified when they're updated or removed. Then, whenever these items are updated or removed, the client application is notified anywhere in the cluster.
Synchronize Items in Multiple Caches
A new cache dependency called CacheSyncDependency is added that allows items in one cache to be dependent on items in another cache. This way, for example, you can have a Local Cache that keeps items frequently used by your application and a Clustered Cache that keeps a larger number of items being shared with other applications. And, your local items are kept synchronized with the clustered cache so you never have any data integrity problems while improving your app performance even further.
Cluster Management Events
NCache fires events whenever a node joins or leaves the cluster or when a client finds that its server has gone down and it now needs to connect with another server. You can write hooks for these events and take appropriate actions when these events occur.
Cache Management API
You can now manage the cache through API (in addition to NCache Manager and command line tools). You can start or stop a cache from an API now.
Multiple Cache Instances on same Server (TCP Port Range)
You can now run multiple cache instances (as InProc) on the same server without any port conflict. Now, you can specify a range of TCP ports to be used for cache clustering instead of only one port previously. This way, multiple instances of the cache can run with each instance using one port.
Callbacks for Async operations
You can now specify a callback for AddAsync, InsertAsync, and RemoveAsync operations. This callback is called when the operation completes either successfully or with a failure.
Performance Improvement to Partitioned Cache with Replicas
NCache has now optimized communication in the cluster for this topology.
Native .NET Clustering
  • NCache developed natively in .NET
  • Truly scalable peer-to-peer multicasting clustering
  • Automatic and transparent node failure recovery
  • On the fly addition and removal of servers
Caching
  • Easy to understand API
  • Same API for Local or Clustered environments
  • Cache configuration through a graphical tool (NCache Manager)
  • Fixed or variable sized cache
  • Time-to-live expiration of cache entries
  • Fixed-time expiration of cache entries
  • Idle-time expiration of cache entries
  • Least-Recently-Used (LRU), Least-Frequently-Used (LFU), and Priority based Eviction Policies
  • Expired Items Resynchronization
  • SQL and OleDB Cache Dependency
  • Support for custom dependencies
  • Event Notifications in Local and Clustered environments
  • In-process and out-of-process cache configurations
  • Heap, raw memory, memory mapped file, and file based storage options.
  • Intelligent relationship management through File and Key based dependencies
  • Read-through and Write-through caching
  • High performance Write-behind caching
  • Clustered Location Transparency
  • Clustered Lock Management
Clustering Options
  • Replicated Cache
  • Partitioned Cache
  • Client Cache
  • Data-less Nodes
  • UDP and TCP based Cluster
HTTP Clustered Session Management
  • Maintain and synchronize session state throughout a server farm
  • Users can now move from server to server on each http request
  • Achieve optimum load-balancing (no more sticky sessions needed)
  • No single-point-of-failure due to sophisticated clustering topologies
  • Built on top of NCache clustering to true in-memory performance
  • Same API as Clustered Session State
GUI Based Cache Configuration
  • NCache Manager is a Windows GUI
  • Create and manage Local Cache or Clustered Cache from it
  • View rich statistics on the entire clustered cache from a single point
  • Change clustering topology without affecting the client application
  • Add or remove nodes from the cluster at run-time
See Also
What's New in NCache 4.4? | Caching Topologies | Copyright ©
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Support for .NET & ASP.NET Apps

< Previous page Next page >

Support for .NET & ASP.NET Apps

NCache has been developed completely in .NET with C#. Therefore, unlike other products that are either developed in Java or C/C++ and only provide a .NET client API, NCache is a 100% native .NET product that fits very nicely in your .NET application environments.
You can use NCache from any .NET application including ASP.NET, WCF and web services, Grid Computing applications, and any other server-type applications with high transactions. So, whether you're making client-side API calls to NCache or developing server-side code for Read-through/Write-through, rest assured that you will always be in native .NET environment.
NCache provides support for the following:
  • ASP.NET Session State Storage for web farms
  • ASP.NET Content Acceleration: This includes caching View State and Minify and Merge of JavaScript.
  • ADO.NET Entity Framework 4.0 Cache
  • NHibernate second level Cache
  • EntLib Caching Block Provider
  • .NET 4.0 Cache Provider
Please visit our website for more detail on Support for .NET .
See Also
Support for Java & JSP
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Support for Java/J2EE & JSP Apps

< Previous page Next page >

Support for Java/J2EE & JSP Apps

NCache provides 100% native Java API support for Java applications. You can use NCache from any Java applications including JSP Servlet, web services, Grid Computing applications, and any other server-type applications with high transactions.
NCache Java client uses the same proprietary socket-level protocol to talk to the cache server that the .NET client does. So, the performance and scalability from Java is the same as .NET.
NCache provides the following support for Java:
  • 100% Native Java API
  • JSP Servlet Session Storage
  • Windows & UNIX Support
  • Java SE and Java EE Support
  • Hibernate and Spring Support
See Also
Support for .NET & ASP.NET
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Server Backward Compatibility

< Previous page Next page >

Cache Server Backward Compatibility

NCache provides backward compatibility protocol for its older clients. NCache 3.8 onward versions will give you the facility to work with your older clients without re-deploying or re-referencing them with upgraded servers. Backward compatibility will be for onward versions only, any client earlier than 3.8 will not be supported by this protocol. With this feature a client should work with both an older and an upgraded version of the server; otherwise with each updates on server, clients are supposed to be upgraded accordingly.
Upgrading a server for new version involves adding new features of NCache while the existing features remains unchanged. For example an upgraded server can only add new features without changing the older ones. In this way it will not break the compatibility with its older clients.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Copyright ©

< Previous page Next page >

Copyright ©

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the written permission of Alachisoft. Alachisoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Alachisoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property. 2015 Alachisoft. All rights reserved. The names of actual companies and products mentioned herein may be the trademarks of their respective owners.
See Also
What's New in NCache 4.4? | Dynamic Clustering | Caching Topologies | Copyright ©
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Caching Concepts

< Previous page Next page >

Caching Concepts

This section explains basic caching concepts that will help you understand NCache in a better way.
In This Section
Caching Topologies
Explains what is a caching topology. It also discusses the four types of cache topologies in NCache.
Cache Cluster
Explains the concept of cache cluster and its main features.
Local Cache
Explains local cache and its two isolation levels.
Cache Client
Explains the concept of cache client and its basic features.
Client Cache
Explains cache client and its main features.
Data Load Balancing
Explains the concept of data load balancing and the two load balancing options that NCache provides.
Client Backward Compatibility
Explains the concept of client backward compatibility.
Eviction
Explains the concept of eviction and different options for eviction provided by NCache.
Indexing
Explains different type of indexing provided by NCache.
Runtime Data Sharing
Explains the concept of runtime data sharing in distributed caches.
Portable Data Types (.NET & JAVA)
Explains data types portablity feature provided by NCache.
Class Versioning
Explains the concept of class versioning provided by NCache.
Graceful Node Down
Explains the graceful node down feature provided by NCache to avoid losing any background operations.
IP Binding
Explains the concept of IP Binding provided by NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Topologies

< Previous page Next page >

Cache Topologies

Caching topology defines the strategy for data storage in a clustered cache. It refers to the behavior of cache cluster under different scenarios. These behavior specifications help in choosing the cache topology which suites best to an
application’s environment.
NCache provides the following set of topologies for cluster caches.
  • Mirrored Cache (Two-Server Active/Passive)
  • Replicated Cache
  • Partitioned Cache
  • Partitioned-Replica Cache (Asynchronous and Synchronous)
Reference Data VS Transactional Data:
Cached data can be differentiated into two broad types i.e. Reference and Transactional. Reference refers to the type of data that has a high ratio of reads than writes e.g. product catalog prices may change after one or few days . On the other hand, transactional refers to the data that has almost the same ratio of reads and writes e.g. each ASP.NET
Sessions is updated with all the activities of each application user.
In This Section
Mirror Cache
Describes mirror cache and its main features.
Replicated Cache
Describes replicated cache and its main features.
Partitioned Cache
Describes partitioned cache and its main features.
Partitioned-Replica Cache
Describes partitioned-replica cache and its main features.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Mirror Cache

< Previous page Next page >

Mirror Cache

Mirror cache consists of two server active/passive nodes. One server node is active node which is basically the coordinator node . The coordinator node is the oldest server node in any cache cluster having membership management
authorities. The other node is passive/mirror node.
Clients Connection: All cache client can only connect with the active node. Passive node is added for creating the exact backup of active node.
Backup Support: Mirror cache provides data reliability by creating a backup through asynchronous replication of all updates on mirror/passive node. Due to asynchronous replication between active and passive node, cache clients get
better performance. Active and passive servers can be interchanged at any time.
Failure Recovery: If active node goes down due to any reason, then passive node automatically becomes active without any intervention. All the cache clients connect to the new active node and can perform operations without any
performance degradation and downtime.
Runtime Scalability: As there is a single active node in this topology, its scalability is the same as that of a local
cache. But due to mirroring of data, it also provides fault tolerance which lacks in local cache.
State Transfer: Mirror node always replicates the state from active node when it joins the cache cluster.
See Also
Replicated Cache | Partitioned Cache | Partitioned-Replica Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Replicated Cache

< Previous page Next page >

Replicated Cache

Multiple Server Nodes: In replicated cache, there can be two or more server nodes. Each node is replica of the cache, i.e., all server nodes contain the same set of cached data.
More than One Backups: It has more than one backup of the cached data. With an increase of server nodes in cluster, the number of backups also increase.
Replication Mode: Replications are performed synchronously on all other nodes of the cache. In synchronous parallel replication, there is a chance that two parallel requests for updating the same data may result in different state on different replica nodes. But using a global token performs updates on all nodes in a sequenced fashion to avoid data integrity issues.
Clients Load Balancing: Cache clients are load balanced automatically by the cluster for an even distribution of load
on the cache nodes. This ensures that any one node is not overwhelmed by the cache client requests. Client load balancing is configurable and can be turned off.
High Performance in Reference Data: Replicated cache is suitable when data read are more than data writes. For any cache client, reads are local to the server which means that cache client have direct access to all data.
Runtime Scalability: Server nodes can be added or removed in replicated cache like other topologies at run time.
Low Performance in Transactional Data: As more server nodes are added to scale the replicated cache, write overhead increases. So this topology is not suitable for applications having transactional type of data.
Storage Limitation to Each Server Node: Adding more nodes does not increase the storage capacity because every node has same data set.
High Availability: Replicated topology is best for applications where high availability and reliability with zero down time is the priority. This is because this topology contains multiple backups of cached data set.
State Transfer: Every server node replicates the state from the coordinator node (the senior most node in terms of cluster joining) when it joins the cache cluster.
See Also
Mirror Cache | Partitioned Cache | Partitioned-Replica Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Partitioned Cache

< Previous page Next page >

Partitioned Cache

Multiple Server Nodes: This topology has two or more servers. When any cache item is added in the cache it is saved
only to the relevant server node which means that every server node has a unique set of data.
Data Distribution: Data is distributed/partitioned among all server nodes on the basis of the hash code of cache key. A hash based distribution map is generated which is then distributed to all server nodes.
Clients Connections: Cache clients establish connections with every server node of the cluster. Data distribution maps are also shared with cache clients and cache clients are aware of the actual data distribution. When a cache client wants to send a request to cache servers, it first determines to which server node that key belongs to and sends the request accordingly on the basis of the distribution map.
One Hop Reads and Writes: Based on the distribution map, cache client adds/fetches cached item to/from the exact server node. In this manner cache reads and writes both become one hop operation and there are no delays.
No Backups/Fault Tolerance: When any server node leaves the cluster, then data residing on that node is lost because there is no replica for any node. That's why there is no fault tolerance in terms of cached data.
Runtime Scalability: Server nodes can be added or removed at runtime whenever needed.
High Performance: Scaling the cache will not affect the performance of cluster cache for both reference and transactional data because read/write is one hop operation in this topology. It will result in high performance in reads/writes without affecting the performance of cluster cache.
Storage Scalability: When more nodes are added in partitioned cache, storage capacity is increased because each partition in the cluster has a unique set of data.
Reliability: This topology is not fault tolerant because there is no backup of data and if any server node goes down, then data belonging to that partition is permanently lost.
State Transfer: When a node joins the cache cluster in Partitioned topology, existing nodes sacrifice a portion of their data, according to hash based distribution, for the newly joined node. Newly joined node transfers its data share from existing nodes which results in an even distribution of the cached data among all cluster nodes. State transfer occurs in background. Therefore during state transfer, user cache operation does not suffer.
See Also
Mirror Cache | Replicated Cache | Partitioned-Replica Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Partitioned-Replica Cache

< Previous page Next page >

Partitioned-Replica Cache

Multiple Server Nodes: This topology has two or more servers. When any cache item is added in the cache it is saved
only to the relevant server node which means that every server node has a unique set of data.
Data Distribution: Data is distributed/partitioned among all server nodes on the basis of the hash code of cache key. A hash base distribution map is generated which is then distributed to every server node.
Fault Tolerance: It provides fault tolerance up to one node replica. Each server node in the cluster has one active partition and its passive/mirror replica on the other node. Thus when one node is down data can be restored from its replica.
Double Memory Consumption: Each server node consumes double memory than the configured size because that node contains one active partition and one replica. Both active and replica has the same size as configured for cache.
Clients Connections: Cache clients are connected to all server nodes in this topology. Data distribution maps are also shared with cache clients and cache clients are aware of the actual data distribution. Operations are directly sent to the node containing data with the help of distribution map on the basis of cache key.
Runtime Scalability: Server nodes can be added or removed at runtime when ever needed.
Storage Scalability: When more nodes are added in partitioned-replica cache, storage capacity is increased because each partition in the cluster has a unique set of data.
High Performance: Scaling the cache will not affect the performance of cluster cache for both reference and transactional data because read/write is one hop operation in this topology. It will give high performance in reads/writes without affecting the performance of cluster cache. Addition of new nodes to the cache cluster results in load distribution of existing members resulting in more throughput.
State Transfer: When a node joins the cache cluster in partitioned-replica topology, existing nodes sacrifice a portion of their data, according to hash based distribution, for the newly joined node. Newly joined node gets its data share transfered from existing nodes which results in an even distribution of the cached data among all cluster nodes. Similarly when a node leaves the cache cluster, data from its backup node is distributed among existing partitions. State transfer also occur between active and passive nodes. State transfer occurs in background. Therefore during state transfer, user cache operation does not suffer.
Replication strategy/modes: Following are the data replication modes provided in this topology.
  • Synchronous Replication
Cache clients have to wait for replication to the backup partition as part of the cache operation. Due to synchronous replication it can be assured that if cache client request is executed successfully, then data is already stored to the backup node.
  • Asynchronous Replication
Cache clients request returns immediately after operation is performed on active partition node. Operations are replicated asynchronously to the replica node. If any node goes down disgracefully, then operations that remain in the replicator queue could be lost.
See Also
Mirror Cache | Replicated Cache | Partitioned Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Cluster

< Previous page Next page >

Cache Cluster

A cache cluster is a set of interconnected server nodes forming a cluster of servers which behave as a single cache unit from outside. Cache clusters are usually preferred in scenarios where performance and scalability are needed. With additions of more server nodes in a cluster cache, more storage space and high availability of cached data can be gained for large applications.
Fault Tolerance: Due to their interconnected nature, cluster caches can tolerate runtime failure of any node in the cluster. In cluster topologies where replica of each server node is maintained on other node, if any node failure occurs, data can be resumed from replica which provides high fault tolerance and availability without affecting any client request.
Runtime Scalability: Cluster caches are horizontally scalable in terms of server node any time. Server nodes can be added or removed even at runtime whenever needed without losing data and downtime.
Single Unit View to Clients: While knowing the fact that there are many peer to peer server nodes in one cache cluster, cache client views the cache as a single unit. It doesn’t matter if any server node is removed or added to the cache, cache client deals with the cache in a homogenous manner. Connections are established with other running nodes at runtime.
TCP Based Connection: All server nodes in a cache cluster are connected through a highly reliable TCP based channel. TCP based connections use combination of IP and Port for forming and differentiating a cache cluster.
Coordinator: The first or senior most running node of the cluster is declared as coordinator node. A coordinator node has the ownership of controlling the management of membership across the cluster.
Cluster Messaging: Each server in the cache cluster can send message to any or all servers in a cache cluster. Messages can be sent in broadcast, multicast or unicast mode.
Data Distribution Strategy: Data distribution in cache cluster is done according to specified topology of the cluster, e.g., in partitioned cache, data is distributed among each partition.
Retries on Connection Breakage: Cache cluster has the ability to tolerate connection breakages for shorter period of time. If any connection breakage between server nodes occurs, then retries for establishing connection are done for configured amount of time.
Leave Detection: Cache cluster is flexible in terms of adding and removing server nodes. It can detect at runtime when any node leaves the cluster by heart beat mechanism without affecting cache clients.
Message Nagling: Message nagling is used to get the best performance over the TCP connections. This means that the cluster tries to avoid the network trip for each single message, instead it combines multiples messages together. This option is configurable through NCache service exe configuration.
See Also
Creating Cache Clusters | Configuring Cache Cluster Settings | Cache Topologies | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Local Cache

< Previous page Next page >

Local Cache

NCache supports a standalone, non-clustered cache which resides on a single node. Local cache is similar in features with other clustered caches, i.e., it has all the caching features provided in any other caching topology, but it is not scalable or fault tolerant like clustered caches. As it is a single server cache, so its transactional capacity can’t be increased by adding multiple servers. Also, it creates a single cache instance (no backup or replica) thus if it goes down, all cached data is lost. Local cache is suitable for applications having a small number of clients with low activity or where applications don't need to cache large amount of data.
Isolation Levels
A local cache has the following two isolation levels.
  • InProc
This isolation level means that cache resides inside the memory space of client application. As this type of cache exists inside the application process, so the response time is faster. In InProc, NCache keeps cached data as live objects (not in serialized form) which reduces the serialization/de-serialization cost. However, memory limitations can be faced since application and cache share the same memory. Also cached data in this case can’t be shared with applications running outside this process.
  • OutProc
This isolation level means that cache resides in a separate process (NCache service process) than client application. Multiple clients (local and remote) can connect to the same cache to share data. Latency in this case is more than InProc cache because of communication cost outside the process.
OutProc local cache is suitable for situations when multiple clients application needs to access the same cached data. For example, in a web garden where each ASP.NET application runs in a separate worker process, OutProc cache should be used. Also in ASP.NET applications, using an InProc cache instance is not considered as the best option due process memory limitation. However, note that there will be an overhead of transferring data between application process and the cache itself.
Local Cache is the only cache available in developer edition of NCache, but remote clients for local cache are not supported in this edition.
See Also
Creating Local Cache | Configuring Basic Cache Settings | Cache Topologies | Cache Cluster | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Client

< Previous page Next page >

Cache Client

Cache clients are light weight modules through which cache applications can connect to hosted caches servers.
TCP Based communication: Cache client connects to the cache server using TCP sockets. Cache client opens a persistent connection with the cache server so when it is disconnected due to network failure, it always reconnects with the cache server.
No Change in API: For both local and remote connections, API for cache operations does not change.
Data Serialization: Data to be added needs to be serializable, serialization is performed in cache client.
Data Compression: Compression is configurable. If enabled, serialized data is compressed in cache client.
Data Encryption: Encryption is also configurable. If enabled, data is encrypted after compression in cache client. NCache supports AES and 3DES encryption.
Request Timeout: Timeout for synchronous cache operations like Add/Insert can be configured, if no response is received within configured time, exception will be thrown. Default operation timeout is 60 seconds. This request timeout should always be higher than cluster operation timeout.
Cache Server Information: Cache clients require server information in order to establish connection. This cache server information can be provided in two ways, either through CacheInitParams or through client configurations (client.ncconf).
Add/Remove Node: If any node is added or removed in cache cluster, cache client will also add/ remove server information to its server list. In case of fail over, client will automatically connect to the newly joined node.
Fail Over: In case a server goes down, cache client seamlessly establishes connection with the next available server. if none of the server is available, e.g., due to network failure, cache client keeps on trying to establish connection with the server in background. When a server again becomes available, it immediately connects to it and application can resume its activity with the cache. In partition and partitioned-replica cache topology, cache client maintains connection with every cache server. In case cache client is unable to connect with some of the server(s), it executes cache requests through other available cache servers. Meanwhile, it keeps trying to establish connection with the server in background.
Connection Retry Interval and Retry Count: When an application executes any cache operation through cache client and no connection is available, then cache client tries to establish the connection. The connection establishment process tries to establish connection for a configurable number of retries. The interval between two consecutive retries can be configured. Meanwhile, application thread waits for connection establishment. When retires are over and cache client is unable to connect to any of the cache servers, then application request is considered as failed and an exception is thrown to the client application.
Load Balancing: Cache client is topology aware and it behaves according to topology. In replicated cache cluster, clients are load balanced among cache servers, if any node joins/leaves the existing replicated cluster, load is re shuffled.
Awareness of Data Distribution: In partition and partitioned-replica cache, client is aware of data distribution and establishes connection with all cache servers.
Advantages of Data Distribution Approach:
  1. Operation is one hop which results in higher throughput
  2. Cache requests are truly balanced among cache servers and no single server is overwhelmed.
Compatibility between NCache and JvCache: NCache and JvCache are fully compatible with each other, NCache cache client can communicate with JvCache Sever and JvCache client can communicate with NCache server.
See Also
Creating Caches | Configuring Cache Clients | Cache Topologies | Cache Cluster | Local Cache | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Cache

< Previous page Next page >

Client Cache

A client cache is a local cache synchronized with a remote clustered cache. It always synchronizes with remote cache through notifications that are triggered whenever changes are made into the state of data. Because of synchronized nature of client cache, it provides maximum boost in performance and scalability of application for read operations without compromising data integrity.
Since the client cache resides on the same box where client application is running, it saves the network roundtrip every time data is served from the client cache. Therefore, data retrieval in this case is much faster as compared to fetching the same data from the remote server.
Client cache can either be InProc (resides within the application process) or OutProc (resides locally or on remote box). By default, cache is initialized as OutProc, however, from NCache Manager, it can be configured to start as InProc. Client applications can initialize the cache as InProc by specifying the initialization mode as ‘InProc’ while calling NCache.InitializeCache(). Client cache cannot be directly initiated using Client API Initialize method. It's always used with some remote clustered cache such as Mirrored, Partitioned, and Partition-Replica Cache.
Synchronization Modes
There can be multiple client cache instances running on different client nodes that simultaneously interact with remote clustered caches. Also, client cache has a subset of data residing in remote clustered cache. It means that there is a small window of time for client caches to sync their state. To solve this problem, client cache provides data synchronization with the clustered cache. Data synchronization is performed between client cache and remote clustered cache and is inevitable. Client cache provides two synchronization modes.
  • Optimistic Synchronization
In optimistic mode, application fetches data from client cache despite the fact that data is updated or not. It assumes that data is newer in client cache however, there are possibilities that data may be older than that on the clustered cache because event notifications might not have yet been received during get operations. In optimistic synchronization, updates are propagated to the client cache using event notifications. Synchronization mechanism is explained later in this chapter.
  • Pessimistic Synchronization
Pessimistic mode is used when applications are handling sensitive data. On data fetch request, if data is found in client cache, its version is matched with item on remote cache. If both versions are same, then item is returned otherwise updated item is fetched from remote cache and is updated back to client cache. This is done to make sure that client application always gets the latest data. However, get operations are slower in pessimistic mode than in optimistic, but it ensures data consistency and takes extra care that the retrieved data is always updated. Notification based updates work similar to optimistic mode.
How Client Cache Works
Whenever the client application using client cache adds/updates data into the cache, it's first updated to second level (remote clustered cache) then on the successfully completed operation, data is updated to client cache. Whereas in the case of data retrieval, it's first looked into client cache; if found, the data is returned to client, otherwise it is fetched from the remote cache and inserted into client cache to make it available for next access. By doing this, client cache reduces unwanted trips to clustered cache, thus increasing performance while fetching data. The figure below explains the internal working of client cache for update and fetch operations on data.
Data Synchronization in Client Cache
While an an item is added to client cache, client cache registers an item level notification with the remote server for any updates or removal of that very item. Whenever this item is updated on the server node, client cache receives a notification which then fetches the updated data from remote cache and updates it locally too. This way, it is made sure that client cache is always synchronized with cache servers even when items are being updated from clients running on other machines. The remote servers propagate these changes only to the clients who have shown interest in the specific items instead of propagating these changes to all client caches. This synchronization mechanism is used for both optimistic and pessimistic client cache. The following figure demonstrates data synchronized with clustered cache and client cache.
InProc client cache stores items in object form, therefore if object is modified by the application, it should be updated back to the cache so that other remote clustered cache and other client caches have no data integrity issues.
See Also
Creating Client Cache | Configuring Cache Clients | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Data Load Balancing in Partitioned and Partitioned-Replica Topologies

< Previous page Next page >

Data Load Balancing in Partitioned and Partitioned-Replica Topologies

Data distribution in partitioned and partitioned-replica cluster caches is based on hash code of cache keys. Data is almost evenly distributed among all server nodes.
Each node knows about the data load of every other node in the cluster. There can be scenarios when data load on any one node becomes high depending upon the pattern of cache keys inserted in the cache.
NCache provides the following load balancing options:
Auto Load Balancing Task
  • Configurable: Auto load balancing is a configurable feature which automatically balances data load on each and every server node.
  • Automatic: It continuously monitors data load on all servers of the cluster after configurable interval and detects uneven data load.
  • Turning Off: This feature can be turned off if the user doesn’t want load balancing among cluster nodes.
Manual Load Balancing
  • Manual: Data load can be balanced any time by manual load balancing feature through NCache Manager.
  • Balance Data on Overloaded Server: Data balancing can be triggered through selecting option on the server node on which the data load is more than other server nodes.
  • No Threshold: There is no threshold. Data balancing can be started whenever required.
See Also
Creating Caches | Data Load Balancing | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Client Backward Compatibility | Eviction | Indexing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Backward Compatibility

< Previous page Next page >

Client Backward Compatibility
NCache version 3.8 and onwards support this feature.
In context of computing products, new updates and releases are launched very frequently. In these newer versions, it is desirable that it is able to work with older version, it can work with the input generated by an older version.
Here NCache provides backward compatibility for its older clients. If the user upgrades his/her cache server for using new features of version or for some fixes of older version, older clients can communicate seamlessly with newer versions of cache server without re-deploying, upgrading the clients.
Protocol Buffers: For backward compatibility, NCache uses protocol buffers. With these protocols it keeps its structured data in efficient yet extensible formats. Thus by using these protocols, backward client compatibility is ensured and cache clients can communicate with both the upgraded and older version of cache server. In new versions of cache servers, new features are added, existing are updated without breaking the compatibility of older clients.
See Also
Creating Caches | Data Load Balancing | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Eviction | Indexing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Eviction

< Previous page Next page >

Eviction

For every cache, cache size should be estimated in advance with careful consideration of data usage by client application. But cache has storage limitation and if data resides in cache forever, then it will eventually become full. To handle this, NCache's Eviction feature can be utilized. In Eviction, when cache gets full, NCache decides to evict its existing data on the basis of usage or priority to accommodate new incoming data. Eviction will smooth cache operations while keeping cache size limited by removing a configured percentage of data.
NCache provides different polices for eviction. These policies decide which data would be evicted when cache is full. Following eviction policies are provided by NCache:
1. Priority Based Eviction
This eviction policy lets cache evict less important data first.This policy should be used if the cached data can be categorized with respect to its importance. NCache has defined the following levels of priority to categorize the cached data. These priorities are assigned while adding data to the cache.
  • Low
  • Below Normal
  • Normal
  • Above Normal
  • High
  • Not Removable
This priority level specifies that cache item should not be evicted.
2. Least Recently Used (LRU)
In this eviction policy, the data which is no longer in use is evicted. Similar to priority based policy; cached item indexes are also maintained in least recently used policy. Items are indexed on their last access time; these indexes are maintained for each cached item. When cache becomes full and there is a need for eviction, selection of data for eviction is based on these indexes. The data which was accessed a long time ago is a more suitable candidate for eviction than the data which is accessed recently. The access time is updated each time the data is fetched or updated in the cache.
3. Least Frequently Used (LFU)
In this eviction policy, data is evicted based on its frequency of usage i.e. how many times a particular data is accessed by the client application(s). Using least frequently used policy, cache maintains index on the basis of the frequency of usage of each item. When a cache is full and requires eviction, selection of the prospect items for eviction is based upon these indexes maintained by cache. Cache removes the least frequently used data first.
Do not Evict: Along with different policies there is another option to turn off eviction. In this case, when cache gets full, cache does not evict any data instead it rejects all incoming data addition requests.
Eviction Ratio: Eviction ratio can also be specified, i.e., by what percentage data should be evicted from cache. Eviction removes only the configured percentage of data from cache once eviction is triggered.
Warn User when Cache is Near Full: When cache is about 80% full and needs eviction, NCache logs events to both event viewer in windows and also in cache logs files.
Bulk Removal of Data: The number of cache items to be removed during eviction can be huge, depending on cache size and eviction ratio. So eviction removes data in bulk. Size of the bulk operation is configurable through Service.exe.config . Similarly the delay between two bulk removal operations can be configured with the help of server.properties file.
Eviction in Cluster Environment: In Partition and Partitioned-Replica topologies, data distribution is based on hashing algorithm. Each node has divided data thus each node is responsible to evict its own data. However, replica node in partitioned-replica does not evict data themselves; rather data is automatically removed on replica when removed from active node. In replicated topology, every node has the same set of data, only cluster coordinator is responsible for eviction. Mirror Cache has only two nodes, one active and other passive. Thus active node is responsible to carry out eviction on the entire cache.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Runtime Data Sharing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Indexing

< Previous page Next page >

Indexing

The purpose of using an index is to optimize speed and performance in finding relevant data for a search. For searching purposes, all searchable attributes should be indexed. Without an index, the search would scan every data, which would require considerable time and computing power. The additional computer storage required to store the index, as well as the considerable increase in the time required for an update to take place, are traded off for the time saved during information retrieval.
NCache internally use indexing in different modules to boost searching on cache performance and keeps track of it for different purposes.
Cache Searching Index
NCache provide Cache Searching Index in order to boost the execution of queries on cache. For searching purpose, all that is needed to be done is to just index all the searchable attributes. NCache will not search the non indexed attribute from the cache because it has to traverse through whole cache to find related data which will affect the cache performance.
Also indexes are defined against the actual data types of the cached items. Through indexing NCache knows what kind of data will be stored and it will store it in searchable way.
NCache provides two ways to define indexes.
  • Pre-Defined Index (Static Index)
  • Runtime Index (Dynamic Index)
1. Pre-Defined Index (Static Index)
To search custom class objects like Product in a cluster cache, these indexes need to be defined in advance. In this way, cache will save that type of data in the form where it can be easily fetched through queries. Indexes can be configured for public, private and protected primitive data members (including string).
These kind of indexes are defined before cache start. To define new indexes, the cache needs to be stopped first and restarted after modifications for deploying changes. On insertion of the indexed type of data in cache, NCache automatically detects its type and it can be used in searching queries afterwards.
2. Runtime Index (Dynamic Index)
If there are attributes in an application that are defined and used at runtime, then runtime indexing should be used. For example there may be some calculated values assigned to a product related to its sales. When any product is purchased by any customer, the sale details is saved in cache for generating daily report of sales trend through cached values later. This value is defined at runtime so it’s the runtime attribute of the product.
NCache will automatically create indexes for data that is added by the cache client. It means that indexes don’t need to be configured before using them for runtime attributes.
Runtime index can be further categorized into following types:
  • Tag Index
  • Named Tag Index
i. Tag Index
One or more identification marks can be associated with cache items. These identification marks are called tags. Through tags, the user can associate keywords(s) with cache items. Collection of cached items can be found and removed from the cache by specifying tags too. Tags are only allowed in string format. For every new tag, a new tag entry will be created in the tag index and all related cached items will be associated with that index.
ii. Named Tag Index
If there is a need to use high level of tagging where tags can have different data types or names and the requirement is to query data related to specific type of tag, then Named Tags should be used.
Named Tags" is the enhancement of "Tags". Named tags allows the user to store additional information (of any type) required to query the object stored as string. For example, "Highest-Sale-Time" named tag with value of time can be stored when any product sale is the highest in whole day. Named tags allow indexing the data according to required attributes at runtime. Later on, a query can be constructed using named tags to fetch the desired result set. . Multiple named tags can be associated with one cached item and vice versa.
When a data is added with a named tag that does not exist in cache, a new index is created for this new named tag. All the related data will be assigned to that index for searching. Unlike Tag, named tag index can be defined for all primitive types, string and date time. So there is more flexibility to add wide range of searchable data with different data types.
If there are multiple applications that are sharing the same cache and all of them are supposed to add named tags, then make sure that the same named tags have homogenous data types, e.g., if one client is adding named tag "ProductID" with String data type, then all other clients should add values of "ProductID" in String format not in Integer or other for the same cache.
Eviction Index
Eviction is a useful feature in NCache, where when cache is full it decides to evict its existing data so as to accommodate incoming data. In this scenario, eviction can smooth cache operations while keeping cache size limit by removing a configured percentage of data.
NCache provides different polices for eviction. These policies decide which data would be evicted when cache is full. NCache provides the following policies for eviction.
  • Priority Based Eviction
  • Least Recently Used (LRU)
  • Least Frequently Used (LFU)
In order to perform Eviction, NCache keeps the index of eviction for cache data for eviction.
For Priority Based Eviction, index is kept for priority from high to low and when cache is full, eviction thread selects keys from index with low priority and evicts them from cache.
For Least Recently Used (LRU), eviction index is kept for time of usage of keys and when cache is full, eviction thread selects keys from index which are least recently used and evicts them cache.
For Least Frequently Used (LFU), eviction index is kept for the number of usage of keys and when cache is full, eviction thread selects keys from index which are least frequently used and evicts them cache.
Expiration Index
Expiration is a property attached with each item which is being cached. This property is attached with each object so that each cache object can be evaluated upon its age, this age of object will decide upon its expiration time. When that expiration object invalidates, the associated item is removed from the cache.
NCache Keep DateTime Expiration index for cache keys in order to remove them efficiently on expiration.Expiration manager expired items after Clean Interval.
Clean interval is the periodic interval after which the expired items are removed from the cache. The clean interval for a cache can be changed in configuration settings.
After clean interval has elapsed, expiration manager get keys from index and expired items are removed from cache. After removing expired items from cache, expiration thread sleeps for “clean interval duration” specified in cache configuration.
NCache provides with two types of expirations
  • Absolute Expiration
  • Sliding Expiration
Indexing Object Attributes for Search
This feature is not available in NCache Express and Professional edition.
NCache requires all searchable attributes to be indexed. This is because, without indexing, NCache would have to traverse the entire cache in order to find items. This could be very costly operation with potential of slowing down the entire cache processes.
NCache provides its own indexing mechanism. The user can select objects in .NET assemblies that he/she wants to index. NCache uses .NET Reflection to extract data from the indexed attributes and builds its internal index. When data to be indexed is inserted in cache, NCache creates an index tree and adds those associated keys in them. These indexes than later on contain all the keys from cache associated to them. When cache is queried, NCache uses these indexes to quickly find the desired objects and returns all related keys or items.
Indexing Attributes of the Cached Item
NCache Manager provides a user friendly interface for defining indexes. The following example demonstrates procedure of defining indexes on attributes.
Suppose that cache contains Customer object where the definition of Customer is as below:
[Serializable]
public class Customer
{
public string CustomerID;
public string Country;
public Customer(string id, string country)
{
this.CustomerID = id;
this.Country = country;
}
}
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Runtime Data Sharing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Runtime Data Sharing

< Previous page Next page >

Runtime Data Sharing

Runtime data sharing has become an important use for distributed caches. More and more applications today need to share data with other applications at runtime in an asynchronous fashion.
Previously, relational databases were used to share data among multiple applications but that required constant polling by the applications wanting to consume data. Then, message queues became popular because of their asynchronous features and their persistence of events. And although message queues are great, they lack performance and scalability as required by applications nowadays.
As a result, more and more applications are using in-memory distributed caches for event driven runtime data sharing. This data sharing should be between multiple .NET applications or between .NET and Java applications. NCache provides very powerful features to facilitate runtime data sharing that make use of notifications to keep cache clients updated about cache status.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Portable Data Types (.NET & Java)

< Previous page Next page >

Portable Data Types (.NET & Java)

To share data among heterogeneous applications, most messaging solutions require building application based on message text which is self-descriptive. It becomes the responsibility of the application to use a format for the data so that it can be decoded by the receiving application coding. If XML data format is used, it encounters performance problems.
In addition, a highly concurrent application environment with several publishers has a greater chance of race conditions causing problems with data integrity. Messaging systems have no inherent relationship between process control messages or messages to multiple destinations messaging (queues or topics) capabilities.
Most messaging solutions are actually designed to support multiple protocols, flexibility in terms of message reliability, and more. But when it comes to opposing applications like .NET wishing to share data with Java, heavy heads or interpretation of payloads based message encoding / decoding / text message delivery settings, message correlation, research data bases related background information can be build before acting.
NCache provides with the feature of data types portability for heterogeneous applications through cache, with binary protocol which boost the performance by reducing traffic and data size with help of compact serialization. To explain this feature, let’s take example of product entity having attributes as ID, name, quantity, category etc.
The Data type portability feature will allow .NET client applications to fetch objects of product class from cache which is inserted by Java client applications and will successfully deserialize to .NET product class and vice versa. The only thing to do is to configure both product classes as shared types from administrative tools of NCache and map one or more attributes of class to other which we want to be shared across platform, non-mapped attributes will contain default value while receiving on other side.
The underlying architecture of this feature use compact serialization framework which create dynamic serialization code for product class on both side. Query Indexes are also shared among shared data types if added in query index list.
Class Attributes Mapping
Product Class (C#) | Product Class (Java)
ID | _ID
name | _name
price | _price
quantity |
 | _category
In above mentioned table attributes of class has been mapped with each other, quantity and category has no mapping attribute in target class so they are left unmapped.
Query Indexes are also shared among shared data types if added in query index list.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Class Versioning
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Class Versioning (Same Platform)

< Previous page Next page >

Class Versioning (Same Platform)

In a distributed environment, multiple applications are connected with cache. Let’s say client applications need to be upgraded. Now all the applications can’t be upgraded at the same time. Meanwhile if some classes get upgraded in some applications, how can they share data with other old ones? Here comes the concept of Class Versioning.
If a class is serializable and the objects of the class are written to a data source and then later they are read back in, the versions of the objects that were written and read must be the same. If the object of one version of the class is saved in the database and later on that class is changed (new version), then a read operation will read the old version from database.
NCache provides the feature of Class Versioning Compatibility for the same platform. This class versioning feature can be used by configuring it through administrative NCache Data Sharing Tool and providing mapping for attributes with target class.
Class Attributes Mapping
ProductV2 Class (C#) | ProductV1 Class (C#)
ID | ID
name | name
price | price
quantity | quantity
Discount |
In above mentioned table, the attributes of class have been mapped with each other, discount is a new attribute added in product class so it is left unmapped.
Mapping ProductV2 with ProductV1will allow storing ProductV2 and getting it in ProductV1 and vice versa.
NCache uses compact serialization and creates dynamic serialization code for both classes for compatibility and as a result, reduces size of data and boosts performance of client applications.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Portable Data Types (.NET & JAVA)
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Graceful Node Down

< Previous page Next page >

Graceful Node Down

With client operations there are many operations that are performed in background of cluster cache. When any server node in cluster cache is stopped, then all those background operations are lost which result in data lost. To avoid operation lost, the user should always gracefully down any node. Server node is not stopped until all the background operations are completed or graceful down time out is elapsed.
If any task takes a longer time than shut down timeout, like in write-behind, database transactions can take longer than expected time, then count of the remaining operations will be written in cache server logs but those operations will be lost.
Configurable Time Outs: Shutdown timeouts are configurable in NCache's service configuration file by the following tags:
  • CacheServer.GracefullShutdownTimeout: Total timeout of graceful shutdown. Default value is 180 seconds.
  • CacheServer.BlockingActivityTimeout: Timeout of wait for operations completion which are started before blocking activity.  Default value is 3 seconds.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Portable Data Types (.NET & JAVA) | IP Binding
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: IP Binding

< Previous page Next page >

IP Binding

By using multiple network interface cards, the network load can be distributed and thus can increase bandwidth throughput. NCache being a network intensive solution, allows the use of dual NIC's and thus network load for cache communication will be distributed on two NICs which will enhance the overall performance.
NCache involves two kinds of network communication in a cache cluster.
  • Communication between cache server nodes (server-to-server communication).
  • Communication between cache client and cache server (client-to-server communication).
Different NIC cards can be configured for each type of network communication in NCache. One NIC will be dedicated for server-to-server communication inside the cache cluster and the second NIC will be reserved only for client-to-server communication. BindToClusterIP will be specified for cluster-wide(server-to-server) communication, and through BindToClientServerIP, NCache can be informed which interface to use for client communication with cache server.
In this way, network load for cache communication is distributed on two NICs and resources will be utilized more efficiently, thus increasing the overall performance.
NCache can detect all Network Interface Cards (NICs) on a server node and allows the user to choose any of them. Selected NIC will be used by NCache for cluster wide communication. If there are two NICs available on a cache server, then it is highly recommended to use both NICs for these NCache communications. NCache will start utilizing both Network Interface Cards (NICs) on cache servers, once dual NIC interface is configured. Using dual NICs will enhance the overall bandwidth throughput by distributing load on two NICs, thus increasing the performance immensely.
Dual NICs can be configured for NCache through NCManager. NCache service config file in installation directory can be manually updated for this purpose.
Command line tools provided by NCache communicate with NCache server on BindToClusterIP.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Portable Data Types (.NET & JAVA) | Graceful Node Down
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Installation Guide

< Previous page Next page >

Installation Guide

The Installation Guide provides you the most comprehensive information about installation, prerequisites and system configuration. It also provides a detailed, step-by-step guide about how to install NCache using command line installer and interactive window installer.
In This Section
Installation Guide for .NET
Describes comprehensive information about installation, prerequisites and system configuration for NCache installation for .NET.
NCache Java Client Installation Guide for UNIX
Explains the process of installation, licensing and uninstallation of NCache Java client for UNIX.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: .NET Installation Guide

< Previous page Next page >

.NET Installation Guide

The Installation Guide provides you the most comprehensive information about installation, prerequisites and system configuration. It also provides a detailed, step-by-step guide about how to install NCache using command line installer and interactive window installer.
In This Section
Getting Started
Describes the pre-requisites for NCache installation.
Command Line Install
Describes how NCache provides a command line installation that can either run from a Command Prompt or add to a script files (.bat files).
Network Install with PowerShell
Describes how to manage NCache remote installation and un-installation tasks on your network through a single computer with the help PowerShell scripts.
Interactive Windows Installer
Describes, how to install NCache using interactive Windows Installer.
Evaluation Period Expiration & Extension
Describes the procedure for extending NCache evaluation period.
Activate NCache Purchased License
Describes how to activate NCache license.
Command Line Activation
Describes how NCache can be activated via command line.
Deactivate NCache Purchased License
Describes how to deactivate NCache License.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Getting Started

< Previous page Next page >

Getting Started

NCache provides a Windows Installer Package (.msi) to let you easily install NCache. However, before you install NCache, keep the following points in mind.
What to Install during Evaluation?
NCache Enterprise: Regardless of which NCache edition you ultimately end up using, you should do your evaluation with NCache Enterprise. This is because you will be able to see all the features that NCache offers in full and then decide whether you need to downgrade to NCache Professional or stay with NCache Enterprise.
Installation Options
Whether you install NCache Enterprise or Professional, you're given the following installation options when you run the .msi file.
  • Cache Server: This is a full install of NCache and contains everything that the other two options provide plus cache clustering capability. You must install this on any server where you're going to host the cache, regardless of whether you have dedicated or shared cache servers.
  • Remote Client: This installs the remote client libraries and client cache on all your web/app servers so you can access the cache across the network. Please note that you need remote client libraries to access the cache across the network.
  • Developer: This installs the NCache API, online help/documentation, and a local stand-alone cache without any clustering capability. Please note that you cannot access a remotely hosted cache from a developer install machine. You can access only a local cache.
Where to Install NCache?
Production, Staging, QA, or Dev Servers: Install NCache Enterprise Edition on the following:
  • Cache Servers (dedicated or shared): If you have 4 or more web/app servers in your environment hosting your application, then we recommend a dedicated caching tier of 2 servers. A dedicated cache cluster should have a minimum of 2 servers for replication and then a ratio of 5:1 between your web/app servers and the cache servers. For smaller environments, even using your web/app servers as cache servers is fine, as long as you have enough memory available on these machines.
  • NCache Remote Clients (App or Web Servers): Any web/app server that is not hosting the cache server but instead will access it remotely across the network is considered an NCache remote client. You need to install the "remote client" portion of NCache on these machines.
  • Developer Workstations: If you're using NCache for object caching, you will be making NCache API calls within your application. Therefore, you need to install NCache "Developer" portion on all the developer machines. A developer install includes all the NCache API's, online help, and a local stand-alone cache. Please note that you cannot access any cache remotely from a developer install .
System Recommendations
  • Windows 2003/2008 Server (64-bit) as Cache Servers: It is highly recommended that you use 64-bit Windows 2008 or 2012 Server platform for cache servers.
  • Adequate RAM in cache servers: NCache puts a minimum of 15% overhead on top of your data. However, this overhead may grow to be a lot more than 15% if you’re using indexes since each index uses memory. Please keep this in mind while deciding how much memory to have in your cache servers. The total memory you need depends on how much data you plan to store in cache.
  • Two 1Gbit NIC's in cache servers: If you have two NIC's in cache servers, it allows you to configure NCache so that it uses one of the NIC's for cache clustering and the second one for client/server communication. This improves your throughput greatly.
  • Dual-CPU, Quad-Core or higher: NCache is a highly multi-threaded software and takes full advantage of extra cores and CPUs. The most common configuration for NCache is a dual-CPU quad-core machine. You may need stronger processing power if you have higher transaction loads and/or larger amount of data being stored in NCache. Please consult NCache technical support to get a specific recommendation for your needs.
  • Disk: NCache does not make heavy use of disk space. Hence you don't need any extra disk space in your cache server machines.
See Also
Command Line Install | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Activate NCache Purchased License
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Command Line Install

< Previous page Next page >

Command Line Install

NCache provides a command line installation that you can either run from a Command Prompt or add to your script files (.bat files). To install NCache form Command Prompt you use the msiexec.exe utility. Below is the syntax for using
msiexec.exe to install NCache.
Install NCache
Msiexec.exe
/I <Installation Package Path>
EDITION ="0|2|3"
KEY ="EVAL_KEY_EMAILED_TO_YOU"
USERFIRSTNAME ="John"
USERLASTNAME ="Smith"
COMPANYNAME ="Alachisoft"
EMAILADDRESS ="john@alachisoft.com"
INSTALLDIR ="<Target Dir>"
SETPERMISSION ="0|1"
/qn
#
Switch/Properties
Purpose
Default Value
01
EDITION
Specifies the installation option. Possible values are
• 0 (Cache Server)
• 2 (Developer)
• 3 (Remote Client)
0
(Cache Server)
02
KEY ( required )
Installation Key must be provided by you. You will receive this via email from Alachisoft when you downloaded NCache. If not, then visit http://www.alachisoft.com/download.html to register and obtain one.
Empty
03
USERFIRSTNAME
Your first name
Empty
04
USERLASTNAME
Your last name
Empty
05
COMPANYNAME
Your company name
Alachisoft
06
EMAILADDRESS
(required)
Your email address
Empty
07
INSTALLDIR
Directory where you want NCache to be installed. Most commonly, this should be "C:\program files\NCache".
Local Directory
08
SETPERMISSION
NCache requires your permission to configure system permissions for PerfMon with NCache. Possible values are
  • 0 (No)
  • 1 (Yes)
1
(Yes)
09
/I <Installation Package Path>
(required)
Path where you have kept NCache.clr20.msi file. You must specify this.
Empty
10
/qn
Quiet mode. If you want to run the install silently without any user intervention, use this switch.
Empty
Examples
Installing a Cache Server:
msiexec.exe /I "C:\NCacheSetup\NCache.clr20.msi" EDITION=0 KEY=INSTALL_KEY_EMAILED_TO_YOU USERFIRSTNAME="John" USERLASTNAME="Smith" COMPANYNAME="Alachisoft" EMAILADDRESS="john@alachisoft.com" INSTALLDIR="C:\Program Files\NCache" SETPERMISSION="1" /qn
Installing NCache on a Developer work station:
msiexec.exe /I "C:\NCacheSetup\NCache.clr20.msi" EDITION=2 KEY=INSTALL_KEY_EMAILED_TO_YOU USERFIRSTNAME="John" USERLASTNAME="Smith" COMPANYNAME="Alachisoft" EMAILADDRESS="john@alachisoft.com" INSTALLDIR="C:\Program Files\NCache" SETPERMISSION="1" /qn
Installing a Remote Client:
msiexec.exe /I "C:\NCacheSetup\NCache.clr20.msi" EDITION=3 KEY=INSTALL_KEY_EMAILED_TO_YOU USERFIRSTNAME="John" USERLASTNAME="Smith" COMPANYNAME="Alachisoft" EMAILADDRESS="john@alachisoft.com" INSTALLDIR="C:\Program Files\NCache" SETPERMISSION="1" /qn
Uninstall NCache
To uninstall NCache through command line, use the following syntax:
msiexec.exe> /x <Installation Package Path> /qn
An example is given below:
C:\> msiexec.exe /x "C:\NCacheSetup\NCache.clr20.msi" \qn
See Also
Getting Started | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Activate NCache Purchased License
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Network Install with PowerShell

< Previous page Next page >

Network Install with PowerShell

NCache provides integration with Windows PowerShell so that you can easily automate NCache processes on your network. You can manage NCache remote installation/un-installation tasks on your network through a single computer using PowerShell scripts. NCache also allows you to automate the activation process on all your cache servers and cache clients by using NCache PowerShell scripts. There are few PowerShell scripts that comes with NCache installation and we'll be discussing those in this section.
In This Section
Configuring PowerShell Environment
Describes how to configure environment for PowerShell.
Remote Installation/Uninstallation
Describes how to install/uninstall NCache on remote machines.
Activate NCache
Describes how to Activate NCache license on remote machine.
Troubleshooting problems occurring in Scripts
Describes solutions to common problems when using PowerShell scripts.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring PowerShell Environment

< Previous page Next page >

Configuring PowerShell Environment

In order to run the NCache PowerShell scripts, PowerShell V2 or higher must be installed. Also, you need to enable script execution permissions in PowerShell. Here is how you can enable script execution in PowerShell.
  1. Go to PowerShell Administration console. You may simply go to command prompt and type/> PowerShell
  2. Set the script execution policy to unrestricted so that you can do remote installations. Here is how you can do this PS C:/Users> set-executionpolicy unrestricted
  3. Also, make sure that WinRM listener is configured and running on all remote machines where you'll do the configuration or installation remotely through our PowerShell Scripts. Here is how you can check the configuration status
    C:/Users/qa>winrm get winrm/config
    If the WinRM is listener is not already configured then type the following command to configure it.
    C:/Users/qa>winrm qc
See Also
Remote Installation/Uninstallation | Activate NCache | Troubleshooting problems occurring in Scripts
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Remote Installation/Uninstallation

< Previous page Next page >

Remote Installation/Uninstallation

Installing NCache using PowerShell Script
NCache provides a PowerShell script called InstallNCache.ps1 for installing NCache on remote machines. Please refer to the Troubleshooting Install script section if you have any issue in executing this script.
You should find the InstallNCache.ps1 script at the NCache installation path in the integration folder
%INSTALLPATH%/NCache/Integration/PowerShell/InstallNCache.ps1
PS C:/Users> IntallNCache.ps1 /k key /file msi-file-name /file-path complete-file-path-of-msi [option[...]]
Argument | Description
/file file-name | Allows the user to specify the name of the setup file along with the file extension.
/file-path complete-file-path | Allows the user to specify the complete file-path/file-location of the setup file.
/k key | Allows the user to specify a valid license key.
Option | Description
/servers server-names | Allows the user to specify a comma separated list of Server Names or IP Addresses of machines where NCache is going to be installed.
/f first-name | Allows the user to specify first name.
/l last-name | Allows the user to specify last name.
/e edition | Allows the user to specify the NCache installation. Use "0" Cache Server installation, “2” is for Developer and “3” for Remote Client installation. Default is “0”.
/email email-address | Allows the user to specify the email address.
/company company-name | Allows the user to specify the company name.
/install-dir installation-path | Allows the user to specify the path where to install NCache. Default is "C:/Program Files/".
/set-per permissions | Allows the user to specify the permissions for quite mode. Default is "1".
/? | Displays command syntax and options for the utility.
Example of NCache Remote Installation:
In this example we will install NCache Cache Server on three computers (Test1, Test2, and Test3) using the PowerShell script InstallNCache.ps1. It is assumed that the NCache setup file “NCache.clr20.msi” is available on C Drive root and also that NCache is installed on the default path “C:/program files”.
PS C:/Program Files/ncache/integration/PowerShell> ./installNCache.ps1 /e 0 /k 7B1JYKITFRERLEIIE /file “NCache.clr20.msi” /file-path “C:/” /s Test1, Test2, Test3
This will install NCache Cache Server on all remote machines Test1, Test2 and Test3. Please replace the server “Test1, Test2, Test3” with your own server names. Upon successful installation you will see a message with “Return Value : 0”.
Uninstall NCache
NCache provides another PowerShell script called UninstallNCache.ps1 which helps to uninstall NCache from remote machine in silent mode. Please refer to the Troubleshooting Install script section if you have any issue in executing this script.
You should find the UninstallNCache .ps1 script at the NCache installation path in the integration folder
%INSTALLPATH%/NCache/Integration/PowerShell/ UninstallNCache .ps1
PS C:/Users>./UninstallNCache.ps1 ServerName1 ServerName2 ... n
Note: Server names must be separated with by BLANK Space. The names can be computer names or IP address of System.
Example of NCache Remote Un-Installation:
In this example we will uninstall NCache Cache Server from three computers (Test1, Test2, and Test3) using the PowerShell script UninstallNCache.ps1. It is assumed that that NCache is installed on the default path “C:/program files”
PS C:/Program Files/ncache/integration/PowerShell> ./UninstallNCache.ps1 Test1 Test2 Test3
This will uninstall NCache from all Cache servers Test1, Test2 and Test3. Please replace the server “Test1, Test2, Test3” with your own server names. Upon successful un-installation you should see a message with “Return Value : 0 ” Or 1614.
See Also
Configuring PowerShell Environment | Activate NCache | Troubleshooting problems occurring in Scripts
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Activate NCache Purchased License

< Previous page Next page >

Activate NCache Purchased License

This PowerShell script lets you activate NCache license on remote machines. It makes your administrative tasks easy when you have many servers to activate because you don't have to manually activate the license on each server.
You should have internet access on all the machines where you want to activate NCache through the PowerShell script. Internally, this script uses command line tool NActivate.exe of NCache. You must have to provide valid admin user id and password that has the permissions to execute commands on remote machine.
Please refer to the Troubleshooting Install script section if you have any issue in executing this script. You should find the UninstallNCache .ps1 script at the NCache installation path in the integration folder:
%INSTALLPATH%/NCache/Integration/PowerShell/ ActivateNCache.ps1
PS C:/Users>./ ActivateNCache.ps1 /k key /f first-name /l last-name /email email-address /uid server-username /pwd server-password [ options[...] ].
Argument | Description
/k key | Allows users to specify a valid license key .
/f first-name | Allows users to specify first name.
/l last-name | Allows users to specify last name .
/email email-address | Allows users to specify email address.
/uid | Specify a valid user name that has permissions to execute the command on remote machine.
/pwd | Specify a valid password.
Option | Description
/servers server-names | Allows the user to specify a comma separated list of names or IPs of the machines on which NCache is to be activated .
/a address | Allows users to specify the company's address
/city city-name | Allows users to specify the edition of NCache. Default is "0".
/s state | Allows users to specify state name
/c country-name | Allows users to specify the country name.
/p phone-number | Allows users to specify the company's phone number.
/z zip-code | Allows users to specify the zip code
/? | Displays command syntax and options for the utility.
Remarks
In the following examples we will activate NCache License key on three machines Test1, Test2, and Test3 using the PowerShell script ActivateNCache.ps1. It is assumed that NCache is installed on the default path “C:/program files”.
Example of Activating NCache License Remotely:
PS C:/Program Files/ncache/integration/PowerShell>./ ActivateNCache.ps1 /k xxxxxxxx-xxxxxx-xxxxxxxx /f Paul /l Jones /email paul.jones@alachisoft.com /servers Test1, Test2, Test3 /uid Administrator /pwd 123pwd
This will activate NCache on three machines Test1, Test2 and Test3. Please replace the server “Test1, Test2, Test3” with your own server names.
See Also
Configuring PowerShell Environment | Remote Installation/Uninstallation | Troubleshooting problems occurring in Scripts
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Interactive Windows Installation

< Previous page Next page >

Interactive Windows Installation

Another way by which you can install NCache is to double click on NCache.clr20.msi from the Windows Explorer. This launches the interactive Windows Installer. Below are the screen snapshots of the installation process.
  • After you click on NCache.clr20.msi, you will see the following as your first screen. Click Next.
  • The next screen asks you to accept the license agreement. By clicking I accept the terms in the License Agreement, you are making a legal commitment to abide by the Alachisoft Software License Agreement for NCache. You cannot proceed without accepting the license agreement.
  • The next screen is an important one. It asks you to choose the edition of NCache which you want to install. The basic rule of thumb is that except for your developer work stations where you have Visual Studio 2005, 2008 or 2010 installed, you should install NCache Enterprise everywhere else. Click Next.
  • Evaluation Information dialog appears which asks you for the installation key. This is the key which you have received from Alachisoft. If you do not have an Installation key, please click on Get Installation Key button which takes you to Alachisoft web site to register and obtain an Installation key.
Please note that even when you have purchased NCache and have a license key, you must provide the INSTALL KEY here (and not the purchased license key). You'll get an opportunity later to specify your purchased license key when you activate your licenses.
Below is the screen showing the page on Alachisoft website where you can register and obtain an Installation key. You have two options here. If you’re already registered, just enter your email address and an Installation key will be emailed to you. Otherwise, register by specifying information and an Installation key will be emailed to you.
  • In User Information dialog, you need to enter your name, company name, and email address. This information will be displayed as part of NCache to indicate your identity. Click Next.
  • By default, NCache is installed in "C:\program files\NCache" folder. However, if you want to change this location, you can specify a different one below. Click Next.
  • In the next dialog box, you can see all the components that will be installed automatically. You can unselect some of the components if you wish. But, it is strongly recommended that you keep everything as default. After selection, click Next.
  • You will then be prompted to start installation process by pressing the Install button.
  • Installation process will begin.
  • After everything is done, a final screen appears indicating a successful finish of NCache installation.
  • Click Finish to exit the installation setup.
See Also
Getting Started | Command Line Install | Network Install with PowerShell | Evaluation Period Expiration & Extension | Activate NCache Purchased License
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Evaluation Period Expiration & Extension

< Previous page Next page >

Evaluation Period Expiration & Extension

By default, when you install NCache, it is installed as an Evaluation Copy and is valid for 60 days only. At the end of this period, NCache will stop working.
Indications of NCache Being Expired
You will be able to notice that NCache evaluation period has expired from the following indications:
• NCache API will no longer work. You won't be able to add or fetch items from cache.
• NCache Manager splash screen will show NCache evaluation period expired.
• NCache Manager window title will show “Expired”.
• NCache Manager HELP -> ABOUT dialog will show NCache has expired.
• You won't be able to add an expired cache server to a cache cluster from NCache Manager.
• You won't be able to start cache on an expired cache server.
Extending Evaluation Period
If any of the above happens, then it's time for you to either purchase NCache licenses or if you need an extension to your evaluation period, you can get an Extension Key from Alachisoft Sales. Please send an email to sales@alachisoft.com (or to your account manager if you're already in touch with him/her) and ask for an extension key. You will be provided a 30-day extension key.
Once you have obtained the extension key, please follow the steps given below to extend your evaluation period.
  • Run NActivate Wizard from "%Install Directory%/NCache/bin/NActivate" path. Below is a screenshot for the screen to be displayed. Please select Extend evaluation period option and then click Next button.
  • A new dialog box will appear. Here, enter the extension key provided to you by Alachisoft Sales and then press Finish. If this key is valid, you will be prompted with a Success message. If the key is not valid, you will be prompted accordingly.
A 30-day extension is valid from the original installation date and not from the day you are trying to extend. So, if you have been waiting for 15 extra days after the initial 60 day evaluation period to extend it, you'll only get 15 extra days extension.
See Also
Getting Started | Command Line Install | Network Install with PowerShell | Interactive Windows Installer | Activate NCache Purchased License
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Activate NCache Purchased License

< Previous page Next page >

Activate NCache Purchased License

If you have purchased NCache licenses, you can activate them by following the steps given below:
  • Run the NActivateWizard Tool from "%Install Directory%/NCache/bin/NActivate" path.
  • NCache License Manager will open. Please check Activate Purchased License Key and click Next.
  • You will see the following screen.
Please note that if you have installed Enterprise Edition of NCache, you'll only get the "Production License" option here. Similarly, if you have installed Developer Edition, you'll get the "Developer License" option. Click Next button and you'll see the following screen.
  • In this dialog box, there are two different options to choose from. If your computer has Internet access, just select the Online (Recommended) option. It will ask you to enter a license key and will activate NCache license for you immediately.
Online Activation
Online activation is the fastest way to activate but requires that your machine has Internet access.
Online activation is the fastest way to activate but requires that your machine has Internet access.
  • Please enter the required information in this form. License Key, First Name, Last Name and Email are compulsory fields. Enter your purchased license key to proceed. Click Next.
  • You will see the final screen for activating your license. Just press Activate Now and it will activate NCache license for you immediately.
If for some reason you're unable to activate, it will display an error message. Your license activation can fail for a number of reasons as following:
• Your firewall does not allow HTTP POST from Activation Program to the Alachisoft License Server.
• You do not have Internet access
• Your license key is invalid
• You have already used up the purchased CPUs or nodes. If this happens, then please review your NCache license usage and then contact Alachisoft Sales.
Manual Activation
However, if your computer does not have Internet access (which is the case in many production servers behind the firewall), then you should opt for manual activation.
  • Select Manual and click Next.
  • The following screen will appear.
This dialog box shows two options. If you already have the activation code, then check Step2 - Proceed with activation. Let's say you don't have the activation code. Check Step1 - Generate activation code info and click Next. The following dialog box will appear.
  • Please enter the required information in this form. License Key, First Name, Last Name and Email are compulsory fields. Enter your purchased license key to proceed. Click Next.
  • A screen showing a long encrypted text appears. Press Copy to copy this text to the clipboard. Paste this in an email and send that email to Alachisoft Support ( support@alachisoft.com ). This is an Activation Request Code that you need to obtain an Activation Authentication Key. Or you can also obtain the Activation Key directly by clicking on the link given below:
NCache Email Activation .
  • Paste the Activate Request Code into the text box on this page and then press Verify.
  • Activation Data Verification form will appear.
  • There will be an Activate button at the bottom of the page shown above. Click this button and it displays a page with the Activation Authentication key as shown below.
  • The Generated Activation Key is shown as a long encrypted string. Copy this key to your clipboard. Then, go back to NActivate Wizard select Manual activation option. Click Next.
  • Check Step2 - Proceed with activation. Click Next.
  • Paste the Activation Key that you received from Alachisoft and paste in the box below.
  • Click Finish. You will be prompted with a success message and NCache will be activated on your machine.
See Also
Getting Started | Command Line Install | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Deactivate NCache License
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Command Line Activation

< Previous page Next page >

Command Line Activation

NCache can also be activated via command line. This will help the users to automate the process of NCache Activation. The tool NActivate.exe is a console application and can be found inside %INSTALLATION_PATH%/NCache/bin/NActivate folder.
nactivate /k R4179Gba-b1f296-78F6U590 /f Paul /l Jones /e paul@alachisoft.com [option[...]]
Argument | Description
/k key | Specifies the license key got from Alachisoft.
/f first name
Specifies the user's first name.
/l last name
Specifies the user's last name.
/e email address
Specifies the user's email address.
Option | Description
/comp[any] company | Specifies the user's company name.
/a address | Specifies the user's address.
/city city | Specifies the name of city.
/s state | Specifies the name of state.
/c[ountry] country | Specifies the name of country.
/z zip | Specifies the postal or zip code.
/p phone | Specifies the phone number.
/nologo | Suppresses display of the logo banner.
/? | Displays command syntax and options for the utility.
Remarks
You must supply the license key that you got from Alachisoft.
Examples
  • The following command activates the NCache on a machine.
nactivate /k R4179Gba-b1f296-78F6U590 /f Paul /l Jones /e paul@alachisoft.com
  • The following command displays command syntax and options for the utility. Logo banner is displayed as a part.
nactivate /?
  • The following command displays command syntax and options for the utility suppressing the display of logo banner.
nactivate /? /nologo
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Deactivate NCache Purchased License

< Previous page Next page >

Deactivate NCache Purchased License

NCache license can be deactivated by following the steps given below:
  • Run the NActivateWizard Tool from "%Install Directory%/NCache/bin/NActivate" path.
  • NCache License Manager will open. Please check Deactivate NCache License and click Next.
  • The following screen appears. Enter the deactivation code provided to you by Alachisoft and click Next.
  • The next dialog box shows two options for deactivation.
  • If your computer has Internet access, just select the Online (Recommended) option. It will contact Alachisoft activation server and deactivate NCache license for you immediately.
Online Deactivation
Online deactivation is the fastest way to deactivate but requires that your machine has Internet access.
  • Click Deactivate Now.
  • Your license will be deactivated and you will be prompted with a success message as follows:
  • Click Finish to exit NCache License Manager.
Manual Deactivation
However, if your computer does not have Internet access (which is the case in many production servers behind the firewall), then you should opt for manual deactivation.
  • Select Manual and click Next.
  • The following screen appears.
  • Click Yes to continue.
  • A screen showing a long encrypted text appears. This is Deactivate Request Code Press Copy to copy this text to the clipboard. Paste it on the link given below to proceed.
NCache Manual Deactivation .
  • Paste the Deactivate Request Code into the text box on this page and then press Verify.
  • Deactivation Data Verification form will appear.
  • There will be a Deactivate! button at the bottom of the page shown above. Click this button and it displays a page with Deactivation Confirmation as shown below.
  • NCache is now deactivated on your machine.
See Also
Getting Started | Command Line Install | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Activate NCache License |
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Java Client Installation Guide for UNIX

< Previous page Next page >

NCache Java Client Installation Guide for UNIX

This section provides you information about installing NCache Java Client in UNIX environment. It provides the system and software requirements, along with information about the administrative privileges you need in order to install NCache Java client.
In This Section
What is NCache Java Client?
Explains what is NCache Java Client and its primary purpose.
Getting Started
Describes the prerequisites for NCache Java Client installation.
Installation Steps for UNIX
Describes Includes step by step instruction for NCache Java Client installation in UNIX.
Post Installation License Management for UNIX
Explains the steps to extend the evaluation period and activate NCache license.
Post Installation Client/Server Configuration for UNIX
Explains the configuration of NCache for client/server communication in UNIX.
Uninstall NCache Java Client from UNIX
Includes step by step instructions on how to uninstall NCache Java Client from UNIX.
Troubleshooting Common Install/Uninstall Problems
Explains how to deal with commonly occurring exception while running some command tool.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: What is NCache Java Client?

< Previous page Next page >

What is NCache Java Client?

NCache Java Client is an NCache client written in Java that makes sharing and managing data in a cluster as simple as on a single server. It accomplishes this by coordinating updates to the data using cluster-wide concurrency control, and replicating and distributing data modifications across the cluster using the highest performing clustered protocol available. The primary purpose of NCache Java Client is to help improve performance of Java/J2EE & JSP applications that would
otherwise make expensive trips to database systems, web services, mainframes, or other systems across the network.
Connecting with NCache Java Clients
Accessing NCache Java Client Resources: You can subscribe to a variety of NCache Java Client resources including newsletters, webinars etc. Please visit Alachisoft Website .
  • Accessing NCache Java Client Documentation: You can access all NCache Java Client documentation at
Online Documentation .
  • Contacting NCache Java Client Support: For comments/feedback and any problems related to NCache Java Client or this manual you can contact NCache support. Simply send an email to support@alachisoft.com or visit Alachisoft Support Page .
See Also
Getting Started | Installation Steps for UNIXl | Post Installation License Management for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Getting Started

< Previous page Next page >

Getting Started

This section provides you information about installing NCache Java Client in UNIX environment. It provides the system and software requirements, along with information about the administrative privileges you need in order to install NCache Java Client.
Installation
On the UNIX platform you can install NCache Java Client only in Command Line Mode through Custom Installation (.tar.gz) installation mode. In custom installation, you can specify customized parameters for installing NCache Java Client. Without customization, NCache Java Client is installed according to default values and in the /opt/ncache/ directory. To view the complete installation steps please see Installation .
Installation Types
When you install NCache Java Client Enterprise, you are only given the remote client installation option. This option installs the remote client libraries and client cache on all your web/app servers so you can access the cache across the network. Please note that you need remote client libraries to access the cache across the network.
Installer Account Privileges
Installing NCache Java Client on your system requires special user privileges.
  • In order to install NCache Java Client on your machine, you need to have “root” privileges.
  • You can specify a user at the time of installation and NCache Java Client service process runs under this user’s identity. You can also set a password for the specified user, though it is optional. In case you don’t specify a user, a default user “NCache” is created.
Installation Requirements
  • System Requirements
  • UNIX OS as Clients: NCache Java Client is officially supported on RedHat Enterprise Linux Server (v 6.4), Fedora (v 18), CentOS (6.3) and Ubuntu Server (12.10).
  • Adequate RAM in Cache Clients: Each NCache Java Client server uses around 40-50MB memory as a JVM process and will not use further memory until unless you are using client cache. If you are using client cache then it puts 15-20% overhead on whatever you cache. Please keep this in mind when deciding how much memory to have in your cache clients. The total memory you need depends on how much data you plan to store in the client cache. If you’re storing JSP Servlet Sessions, then figure out your average session size and maximum number of sessions you will ever have in the cache. You can do the same for application data caching.
  • Dual-CPU, Multi-core: NCache Java Client is a highly multi-threaded application and takes full advantage of extra cores and CPUs. The most common configuration for NCache Java Client is a dual-CPU machine where each CPU is either dual-core or quad-core.
  • Disk: NCache Java Client does not make heavy use of the disk space so you don’t need any extraordinary disk space in your cache server machines.
  • Software Requirements
JRE/JDK 1.5 or above
Where to Install NCache Java Client
Any web/app server that is not hosting the cache server but instead accesses it remotely across the network is considered an NCache Java Client Remote Client. You need to install the Remote Client portion of NCache on these machines.
See Also
What is NCache Java Client? | Installation Steps for UNIXl | Post Installation License Management for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Installation Steps for UNIX

< Previous page Next page >

Installation Steps for UNIX

This section describes step-by-step instructions for installing NCache Java Client on UNIX.
Installation
In installation, you can make use of the .tar.gz file to install NCache Java Client on your UNIX machine. You can specify some customized parameters such as install directory, a user under which NCache Java Client service will run, network IP to be used by NCache Java Client etc. If you don’t customize any parameters, NCache Java Client is installed according to default values. It is installed in the /opt/ncache/ directory and NCache service runs under a default user called “NCache”.
In order to install NCache Java Client on your machine, you need to have “root” privileges.
In order to install NCache Java Client on you UNIX system, please follow these steps:
  • Please log in as root user.
  • In UNIX terminal, enter the following command in order to navigate to the directory where you have placed the .tar.gz file of NCache Java Client you downloaded from the Alachisoft website.
[root@servername]# cd [NCache_Java_Client_setup_path]
  • Uncompress the .tar.gz file through the following command:
[root@servername]# tar –zxvf NCache.Java.Client.tar.gz
  • Uncompress the .tar.gz file through the following command:
[root@servername]# tar –zxvf NCache.Java.Client.tar.gz
The extracted files can be found in the directory named ncache-enterprise-4.4-sp1-javaclient.
  • Navigate to the directory where .tar.gz has been extracted, through the following command:
[root@servername]# cd ncache-enterprise-4.4-sp1-javaclient
  • Now is the time to run installation. Use the following command (as root):
[root@servername]# ./install –f John –l Smith –e john@alachisoft.com -u Jenny –k EVAL-KEY –j JAVA_HOME_PATH –I 20.200.20.202
EVAL-KEY is emailed to you when you register at Alachisoft website. And, please specify JDK/JRE 1.6 or later.
NCache Java Client is now successfully installed on your UNIX machine!
After successful installation, you will get the following output message:
Starting NCache service
jvmargument: -Xmx816000m -Dcom.sun.management.jmxremote -Dcom.sun.management.jmx
remote.port=1501 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.man agement.jmxremote.ssl=false -Xdebug -Xrunjdwp:server=y,transport=dt_socket,address=4000, suspend=n -Djava.library.path=/opt/NCache/lib/resources/sigar/ -server
CacheServer.BindToClientServerIP =20.200.20.202
CacheServer.BindToClusterIP=20.200.20.202
CacheManagementServer.Port=8250
CacheServer.Port=9800
Checking service status ...
NCache service started.
  • You can customize your installation through the following flags:
Flag |  | Purpose
-f | --firstname | First name of the user to which NCache Java Client is licensed.
-l | --lastname | Last name of the user to which NCache Java Client is licensed.
-e | --email | Email address of the user to which NCache Java Client is licensed.
-j | --javahome | It points to the directory where Java Runtime Environment (JRE) or Java Development Kit (JDK) is installed on your system. If no or invalid path is specified, it will search for the Java location itself. Recommended Java version is 1.6. It will first look for version 1.6; if it is not found, it will search for any greater version available.
-i | --ipaddress | IP address to be used by NCache Java Client, if no IP is specified it will use the first network interface card it finds.
-p | --installpath | Location where NCache Java Client will be installed, by default it will be installed on current location.
-k | --evalkey | You receive this via email from Alachisoft when you downloaded NCache Java Client. If not, then visit Alachisoft Download Center to register and obtain one. It is mandatory for you to specify this.
Verify NCache Java Client Installation
After installation you can verify NCache Java Client installation by any of the following ways:
  • In UNIX terminal, enter the following command:
[root@servername]# chkconfig
This command lists system services. If the NCache Java Client service NCached is also listed as follows you can be sure that NCache Java Client has been successfully installed.
NCached 0:off 1:off 2:on 3:on 4:on 5:on 6:off
OR
Set NCHOME to the location where you have installed NCache Java Client through the command:
[root@servername] export NCHOME=/opt/ncache
Then run the following commands:
[root@servername] cd /opt/ncache/bin
[root@servername] ./NCached status
If your installation was successful, you should be able to see the following output:
NCache Java Client Server Status: Running
CacheServer.BindToClientServerIP =20.200.20.202
CacheServer.BindToClusterIP=20.200.20.202
CacheManagementServer.Port=8250
CacheServer.Port=9800
  • Navigate to the config folder of NCache Java Client. The server.properties file is placed in this folder. server.properties file can be found in installation directory. This directory is the one you specified through the “-p” flag. In order to verify your connection, please look up for this file through the following command:
[root@servername]# cd ~/NCache_install_dir/ncache/config
After locating the file server.properties, open it in editor. In case of successful installation, you should be able to see your system IP used by property values as follows:
CacheServer.BindToClusterIP=20.200.20.202
CacheServer.BindToClientServerIP=20.200.20.202
What has been Installed?
NCache Java Client is installed in the directory you mentioned at the time of installation. In custom .tar.gz installation, this directory will either be the default directory that is /opt/ncache/, or it will be the directory you mentioned at the time of installation using –p parameter.
After installation, you will find the following files in this directory:
  • Configuration Files: The following configuration files are provided in order to configure and run NCache Java Client:
  1. config.ncconf
  2. client.ncconf
  • Libraries: Various .jar assembly files are provided for you to refer to when developing with NCache Java Client. These libraries are also used by NCache service.
  • Tools: The following NCache Java Client Tools are provided:
  • addclientnode
  • addnode
  • addtestdata
  • clearcache
  • verifylicense
  • removecache
  • createcache
  • createclientcache
  • dumpcache
  • getcachecount
  • ncached
  • listcaches
  • removeclientnode
  • removenode
  • startcache
  • stopcache
  • stresstesttool
  • removeclientcache
  • Documents: Help files and reference documents are provided for you to work with NCache Java Client.
  • Integrations: Some integrations (hibernate, hibernate 3.5) are provided along with the installation. These are used while integrating NCache as second level cache in many provider based frameworks.
  • Samples: NCache Java Client basic samples are provided on installation, they vary from basic API tests to samples for using integrations.
  • Logs: This folder will contains client and server related logs.
See Also
What is NCache Java Client? | Getting Startedl | Post Installation License Management for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Post Installation License Management for UNIX

< Previous page Next page >

Post Installation License Management for UNIX

When you install NCache Java Client on your system, it is installed as an “Evaluation Copy” by default. You can use this evaluation copy for 60 days after which it expires and NCache Java Client stops working. You can either Activate NCache Java Client License (for a purchased copy) or Extend Evaluation Period (for a trial version).
If you are using a purchased copy of NCache Java Client, we recommend you to activate its license right after installation in order to avoid inconvenience.
Activate NCache Java Client License
After you have purchased NCache Java Client licenses and installed NCache Java Client, you can activate your copy of NCache Java Client. Activating NCache Java Client saves you from the trouble of NCache Java Client expiration and you can use it for as long as you want. If you have internet connection on your machine, follow the Online Activation process to activate your license, otherwise, follow the process Manual Activation.
If your computer has Internet access, we will suggest you to follow the simple and one-step Online Activation process .
Online Activation
Online activation is the fastest way to activate NCache Java Client but requires your machine to have Internet access. In order to activate your NCache Java Client copy through online activation, follow the steps given below:
  • In UNIX terminal of your server machine, go to the location where you have installed NCache Java Client.
  • Navigate to the bin\activation folder to access the activate-cmd tool:
[root@servername]# cd ~/NCache_install_dir/bin/activation
  • Run the activate-NCache Java Client-cmd tool as follows:
[root@servername]# ./activate-cmd -k key -f first-name -l last-name -e email [option[…]].
You get the following output on successful license activation:
Thank you for registering your copy of NCache Java Client.
  • You can customize the license activation process through the following properties:
Switch/Properties |  | Purpose
-k(Required) | --licensekey | Specifies the License key you received from Alachisoft
-f(Required) | --firstname | Specifies first name of the user
-l(Required) | --lastname | Specifies last name of the user
-e(Required) | --email | Specifies last name of the user
-m | --manual | Enables manual mode
-a | --authcode | Specifies the Activation Authorization Code that you received in an email or generated through the Alachisoft website.
-c | --company | Specifies user’s company name
-r | --address | Specifies address of the user
-t | --city | Specifies city name of the user
-s | -state | Specifies state of the user
-y | --country | Specifies country of the user
-z | --zip | Specifies postal/zip code of the user
-p | --phone | Specifies phone number of the user
-h | --help | Displays a detailed help screen
-G | --nologo | Suppresses displaying the logo banner
Manual Activation
Manual activation means you manually activate your copy of NCache Java Client through the following process:
  • In UNIX terminal of your server machine, go to the location where you have installed NCache Java Client.
  • Navigate to the bin\activation folder to access the activate-cmd tool:
[root@servername]# cd ~/NCache_install_dir/bin/activation
  • First generate an Activation Request Code through the command:
[root@servername]# ./activate-cmd -k key -f first-name -l last-name -e email -m
The output of this command is an encrypted text. This encrypted text is called Activation Request Code. You will use this code later to request an Activation Authorization Code which is required to activate NCache Java Client.
  • There are two ways to generate Activation Authorization Code.
  1. Send an Email to support@alachisoft.com to request an Activation Authorization Code. In your email, please copy the Activation Request Code you generated through the pervious step.
  2. Generate Activation authorization Code from Alachisoft website.
  • Once you have the Activation Authorization Code, run the following command:
[root@servername]# ./activate-cmd –a activation-authorization-code
  • Your copy of NCache Java Client is successfully activated. You will get the following output on successful activation:
Thank you for registering your copy of NCache Java Client.
  • You can customize the license activation process through the following properties:
Switch/Properties |  | Purpose
-a (required) | --authcode | Specifies the Activation Authorization Code that you received in an email or generated through the Alachisoft website.
-G | --nologo | Suppresses displaying the logo banner
-h | --help | Displays a detailed help screen
Generate Activation authorization Code from Alachisoft website.
An alternative to sending an email to receive the Activation Authorization Code is to directly generate an Activation Authorization Code from the Alachisoft website. This method is less time consuming than as it saves you from sending an email and waiting for a reply. Please follow these steps to get the Activation Authorization code:
  • Open Customer License Console .
  • Enter the License Key and click Find and then click the Activate NCache link. NCache Java Client Email Activation page is displayed.
  • On the Email Activation page, enter the Activation Requested Code you generated through the –m flag in activate-cmd tool.
  • Click Verify. The Activation Data Verification page appears.
  • Verify the information displayed on this page and click Activate! The next page that opens shows you the required Activation Authorization Key.
  • Once you have generated this key, please follow the steps described in Manual Activation to complete your registration process.
Extend Evaluation Period
When you install NCache Java Client on your system, it is installed as an “Evaluation Copy” by default. You can use this evaluation copy for 60 days after which it expires and NCache Java Client stops working. When NCache Java Client expires, it is time for you to either purchase NCache Java Client licenses or if you need an extension to your evaluation period, you can obtain an “Extension Key” from Alachisoft Sales. Please send an email to sales@alachisoft.com (or to your account manager if you’re in touch with him/her already) and ask for an extension key. You are provided with a 30-day extension key.
You can extend your trial version only 4 times; after that you will have to purchace NCache Java Client licenses in order to use NCache Java Client.
Once you have obtained the extension key, please follow the following steps to extend your evaluation period:
  • In the UNIX terminal of your server machine, go to the location where you have installed NCache Java Client.
  • Navigate to the bin\activation folder to access the activate-cmd tool:
[root@servername]# cd ~/NCache_install_dir/bin/activation
  • Run the extend-evaluation-cmd tool through the following command:
[root@servername]# ./extend-evaluation-cmd –e evaluation-key
You will see the following output message on successful extension of your evaluation period:
NCache Java Client Evaluation period has been extended.
  • You can customize the license activation process through the following properties:
Switch/Properties |  | Purpose
-e(required) | --extensionkey | Specifies the evaluation extension key you received from Alachisoft
-h | --help | Displays a detailed help screen
-G | --nologo | Suppresses displaying the logo banner.
See Also
What is NCache Java Client? | Getting Startedl | Installation Steps for UNIX | Post Installation License Management for UNIX | Uninstall NCache Java Client from UNIX
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Post Installation Client/Server Configuration for UNIX

< Previous page Next page >

Post Installation Client/Server Configuration for UNIX

Configure Multiple Network Interface Cards
NCache Java Client, being a network intensive solution, has mainly two kinds of communication going on in a cache cluster:
  • Communication between different cache servers
  • Communication between cache client(s) and cache server(s)
For these communications, you need to configure Network Interface Cards, available on your cache server(s), to ensure optimal load sharing. If you have two NICs, NCache Java Client starts utilizing both of them, once “Dual NIC” interface is configured. Using Dual NICs means that you enhance the overall bandwidth throughput by distributing load on two NICs, thus immensely increasing performance. One NIC is dedicated for server-to-server communication inside the cache cluster and second NIC being reserved only for client-to-cache server communication. In this way, network load for cache communication is distributed on two NICs and resources will be utilized more efficiently.
If you have two NICs available on a cache server, it is highly recommended to use both NICs for Cache server-to-server and Cache slient-to-server communications.
You can specify which NICs to use for your server to server communications and client to server communication. For this purpose you have to make some modifications in the file: server.properties.
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
CacheServer.BindToClusterIP=20.200.20.202
CacheServer.BindToClientServerIP=20.200.20.202
BindtoClusterIP: You can inform NCache Java Client which interface to use for cluster-wide communication. In order to do so, provide the IP Address you want the cluster server to bind with.
BindtoClientServerIP: You can inform NCache Java Client which interface to use for client communication. In order to do so, please provide the IP Address you want the client's server to bind with.
Example
<cache id="MyCache" client-cache-id="" client-cache-syncmode="optimistic" default-readthru-provider="" default-writethru-provider="" load-balance="True">
<server name="20.200.20.59"/>
Please note that you must use the same IP address while creating your clustered cache to which you have bound your cache server. If you want to use a host-name at the time of defining your cache, then please make sure that the host-name resolves to the same IP address as the one you have bound it to.
  • Restart NCache service for these changes to take effect.
Client/Server TCP Port
By default, all clients communicate with NCache Java Client server on TCP port 9800. If this TCP Port is reserved for any of your other applications or you want to change it for some other reason, you can change it through the property file: server.properties .You will also have to modify the file: client.ncconf.
1. Modify Server Properties
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
CacheServer.Port=9800
Here you can specify a different client/server TCP port.
Please make sure that you specify the same port in all your cache servers.
  • Restart NCache Java Client service for these changes to take effect.
2. Modify client.ncconf for all clients (remote/local)
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
<configuration bind-ip="20.200.20.36">
< server port="9800" connection-retries="5" retry-interval="1" retry-connection-delays="0" client-request-timeout="90" connection-timeout="5" local-server-ip=""/>
</configuration>
Here you can specify a different TCP port.
Please make sure that all Port values in client.ncconf and server.properties are consistent.
  • Restart NCache Java Client service for these changes to take effect.
3. Change SNMP/JMX Counters Port
NCache Java Client uses SNMP and JMX servers to publish performance counters. If the default SNMP/JMX Counter Port is reserved for any of your other application, you are not able to view the counters due to IP conflict. To resolve the IP conflict, you will have to make some modifications in the file: server.properties.
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
JmxServer.Port=1617
JmxSnmp.Port=1618
Here you can specify different SNMP and JMX ports.
  • Restart NCache Java Client service for these changes to take effect.
4. Change the Cache Management Port
Cache Management Port port is used while performing management operations on caches. If the default Cache Management Port is reserved any of your other application or you want to change it for some other reason, you have to make some modifications in the file: server.properties
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
CacheManagementServer.Port=8250
Here you can specify different SNMP and JMX ports.
  • Restart NCache Java Client service for these changes to take effect.
5. Change JDK/JRE Version
At the time of installation, NCache Java Client automatically picks the version information of JDK/JRE installed on your system. If at a later stage, you switch to a different version of JDK/JRE, you need to manually change Java path in the file env.properties in order to configure the JDK/JRE version. Please follow these steps:
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/opt/NCache/config
  • Open the file env.properties and provide Java path through the following property:
JAVA_HOME=/
  • After you have modified Java path, save/write and quit the service file from editor.
  • Restart NCache Java Client service for these changes to take effect.
See Also
What is NCache Java Client? | Getting Startedl | Installation Steps for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Uninstall NCache Java Client from UNIX

< Previous page Next page >

Uninstall NCache Java Client from UNIX

This section describes step-by-step instructions for uninstalling NCache Java Client from UNIX.
In order to uninstall NCache Java Client from your machine, you need to be logged in as root user or as an authorized user like “NCache Java Client”.
Steps
In order uninstall NCache Java Client from your UNIX machine, please follow these steps:
  • Open the terminal and navigate to the directory where you extracted NCache Java Client. Use the command:
[root@servername]# cd ~/NCache-enterprise-4.4-sp1-javaclient
  • In order to uninstall NCache Java Client, enter the following command:
[root@servername]# ./uninstall -p /opt/NCache_install_dir
NCache Java Client is successfully uninstalled from your system. You see the following output:
Stopping Service ...
Removing Service ...
NCache Java Client uninstalled.
User ‘NCache’ created at install time is not deleted. Please use userdel command to remove the user.
For support please feel free to contact support@alachisoft.com
For complete documentation visit the website <http://www.alachisoft.com/resources/docs/index.html>
See Also
What is NCache Java Client? | Getting Started | Installation Steps for UNIX | Post Installation Client/Server Configuration UNIX | Troubleshooting Common Install/Uninstall Problems
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Troubleshooting Common Install/Uninstall Problems

< Previous page Next page >

Troubleshooting Common Install/Uninstall Problems

While running some command line tools, you might encounter the following exception:
"NCache Java Client unable to fetch network usage: Sigar Native libraries not found, please provide java.library.path to JVM pointing to NCHOME/lib/resources/Sigar"
NCache Java Client uses some external resources such as Sigar. When the Path variable is not set to the location of Sigar, you get the above exception as the required library files cannot be found.
Workaround
You can set the path to Sigar resources through the following command:
export PATH=/opt/ncache/lib/resources/Sigar/
See Also
What is NCache Java Client? | Getting Startedl | Installation Steps for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Getting Started

< Previous page Next page >

Getting Started

Familiarizes you with the fundamentals of NCache and offers help to use NCache quickly and efficiently.
In This Section
Quickly Configure and Use NCache
Describes basic steps for smooth installation, configuration and use of NCache.
Quickly Use Cache API in .NET
Describes most common API's provided by NCache with examples for .NET users.
Quick Start Guides for .NET
Provides quick start guides to use .NET features with NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Quickly Configure and use NCache

< Previous page Next page >

Quickly Configure and use NCache

Here are some basic steps you should follow to ensure a smooth installation, configuration, and use of NCache.
Add Reference issue of Visual Studio 2010
If your development environment is Visual Studio 2010, you may not be able to see the NCache .NET assemblies in the "Add Reference" dialog box under ".NET" tab. However, you can add reference to the NCache assemblies by using the "Browse" tab. You can find all these assembly files in [NCache Installed folder]/bin/assembly/
1. Install NCache on Cache Server and Remote Client Machines
Install NCache on all remote client and cache server machines. If you have a separate caching tier, you'll have remote clients. Otherwise, cache will be hosted on your application server.
You can install either 32-bit or 64-version of NCache. 64-bit cache servers work fine with 32-bit clients.
2. Configure Servers for Multiple Network Cards (optional)
If your cache servers (including your app servers if you're hosting cache on them) have multiple network cards, then you must bind NCache to a specific card. You need to specify the following in "Alachisoft.NCache.Service.exe.config" in "NCache/bin/service" folder:
<appSettings>
...
<add key="NCacheServer.BindToClusterIP" value="20.200.20.200" />
<add key="NCacheServer.BindToClientServerIP" value="20.200.20.200" />
...
</appSettings>
Anytime you modify "Alachisoft.NCache.Service.exe.config", you must restart NCache Service. You can do this through following commands:
C:/Users/Administrator>net stop ncachesvc
C:/Users/Administrator>net start ncachesvc
You can also bind Client/Server communication to a different network card than the Clustering network card, if you have multiple network cards. Or, you can bind both to the same card (as shown above).
3. Open Firewall TCP Port for Clients (optional)
If there is a firewall between your remote clients and the cache servers, then you must open a TCP port (default 9800) for the remote clients to talk to the cache servers. If you want to change this from 9800 to another port, then you must make changes in all remote client and all cache server machines. On the remote clients, you need to change the "port" value in "client.ncconf" as following:
<configuration>
<ncache-server port = "9800" client-request-timeout = "90" connection-retries = "1" retry-interval = "0" connection-timeout = "5"/>
</configuration>
And, you need to change the "NCacheServer.Port" value in "Alachisoft.NCache.Service.exe.config" file located in "NCache/bin/service" folder on all cache servers as following:
<appSettings>
...
<add key="NCacheServer.Port" value="9800" />
...
</appSettings>
Anytime you modify "Alachisoft.NCache.Service.exe.config", you must restart NCache Service (as described above).
All remote clients by default talk to NCache servers on TCP port 9800. So, if there is a firewall between the remote clients and the cache server, then you must open TCP port 9800 in your firewall.
4. Open Firewall TCP Port for Cache Cluster (optional)
If you have a situation where there is a firewall between the cache servers and the cluster must be formed across this firewall, then you must open at least two TCP ports (bi-directional) in this firewall. This port is the Cluster Port specified by you while creating a new clustered cache. For example:
Cluster Port: 7800
Port Range: 1
Open ports 7800. If Port Range is 2, then open 7800 and 7801.
5. Create New Clustered Cache
Run NCache Manager from ONLY ONE location (preferably from one of your cache servers), and create a new clustered cache. You can choose to create one of the following types of caches:
  1. Mirrored Cache
  2. Partitioned Cache
  3. Partitioned Cache with Replicas (recommended)
  4. Replicated Cache
For starters, we recommend to create a Replicated Cache. Later on, you can decide whether a different caching topology meets your requirements better or not. For now, we want to go through the entire process quickly.
6. Test Cache Cluster from Statistics Window
Once you have created a clustered cache, you should test to make it sure that it works fine. Here are the steps to test the cluster from within NCache Manager.
  1. Start the cache
  2. View Statistics of the cache (right-click menu)
  3. Press Add button on top of the Statistics window. It should add "10" dummy items to the cache. And, the "Count" counter should reflect this. If you have a Replicated Cache, then all cache servers should show the same "Count" value and if Count value is same, then cluster is working fine.
7. Remote Client Machines
NCache provides remote client management through NCache Manager. By right click on the Client Nodes, context menu will appear having "Add Node" option as shown in figure. Using this option you can add and configure a single or multiple client nodes in a clustered cache.
8. Ensure All Objects are Serializable
Whether you're using NCache for ASP.NET Sessions or for object caching, you must ensure that all .NET objects are serializable. This is true even for those .NET objects which are being stored in your Session. Here is how to ensure that:
[Serializable]
class Product
{
...
}
9. Modify "web.config" for ASP.NET Sessions
If you're using NCache for ASP.NET Sessions, you need to modify your "web.config". For .NET 1.1, you need to specify an HttpModule (see online help and "samples" for example). And, for .NET 2.0 or later, you need to add a custom Session State Provider (SSP) to your "web.config" as following:
For Enterprise and Professional Edition:-
<compilation defaultLanguage ="C#" debug="true" >
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider,
Version=x.x.x.x,Culture=neutral,
PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
</compilation>
For Open Source Edition:-
<compilation defaultLanguage ="C#" debug="true" >
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider,
Version=x.x.x.x,Culture=neutral,
PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
</compilation>
Replace version “x.x.x.x” with the actual NCache version that you have.
<sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom" customProvider = "NCacheSessionProvider" timeout = "20">
<providers>
<add name = "NCacheSessionProvider" type = "Alachisoft.NCache.Web.SessionState.NSessionStoreProvider" sessionAppId = "NCacheTest" cacheName = "myTestCache" writeExceptionsToEventLog = "false"/>
</providers>
</sessionState>
Please read online help for more details on each of the above properties. For now, just make sure that cacheName="myTestCache" reflects name of the cache you've created.
10. Configure Visual Studio Project for Object Caching
If you're using NCache for ASP.NET Sessions only, then you do not need to do anything here. However, if you're using NCache for object caching where you'll be making NCache API calls, then you need to do the following in your Visual Studio project and also your C# or VB.NET source code.
  1. Reference "Alachisoft.NCache.Web" assembly in your project.
  2. Use "using Alachisoft.NCache.Web.Caching;" in your C# files and its equivalent in your VB.NET files.
You can test NCache using the following code example:
Cache cache = NCache.InitializeCache("myCache");
cache.Add("Customer:David:1001","Data");
cache.Get("Customer:David:1001");
cache.Dispose();
11. Run Application and Monitor from NCache Manager
You're now ready to run your application. Once you do, you can watch the cache performance from the Statistics window in NCache Manager. Below is an example:
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Quickly use Cache API in .NET

< Previous page Next page >

Quickly use Cache API in .NET

In this section, you will learn to utilize NCache API designed to provide a super rich set of caching features that facilitate you to store/retrieve data for faster access.
In This Section
Initialize Cache
Describes initializing a cache to start working with it.
Adding Items
Explains adding items to the cache.
Finding items
Explains using Cache API to find items from the cache.
Removing Items
Gives procedure to remove items from the cache.
Deleting Items
Gives procedure to delete items from the cache.
Dispose Cache
Illustrates procedure of disposing cache once you are done using it.
Start Cache
Describes starting cache from your application through API.
Stop Cache
Instructs you about stopping cache using Cache API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Initialize Cache

< Previous page Next page >

Initialize Cache

After you have configured the cache, embed NCache API calls in your application to use it. The first thing you need to do is to initialize the cache. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
The code for initializing the cache is as follows:
// Initialize the cache.
Cache _cache = NCache.InitializeCache("myCache");
Initializing Cache in ASP.NET Applications
If you're developing ASP.NET application, the best place to put InitializeCache call is in your Application_Start() functions in Global.asax.cs file. Additionally, instead of hard-coding, we recommend keeping the cache-name in Web.Config and then accessing it from your code. This way, if you will be required to change your cache name at any stage, you won't have to recompile the code.
// Pick up the cache-name from Web.Config
public override void Init()
{
string cacheName = ConfigurationSettings.AppSettings["CacheName"];
Cache _cache = NCache.InitializeCache(cacheName);
}
And, in your Web.Config, you can specify cache name as follows:
<appSettings>
<add key = "CacheName" value = "myCache"/>
</appSettings>
See Also
Adding Items | Finding items | Removing Items | Dispose Cache | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Cache

< Previous page Next page >

Start Cache

You need to include following namespace in your application to start the cache using Cache API.
using Alachisoft.NCache.Web.Management;
Starting a local cache
//start the local cache
CacheManager.StartCache("CacheID","Server_Name");
Starting a remote cache
//start the remote cache
CacheManager.StartCache("CacheID","Server_Name");
See Also
Initialize Cache | Adding Items | Finding items | Removing Items | Dispose Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding Items

< Previous page Next page >

Adding Items

Once you have a valid cache handle, you can do the "Add" operations. The Add operation has many overloads and the basic overload takes two parameters "key" as string and "value" as object. The value must be a .NET serializable object otherwise NCache will throw a serialization exception if .NET serialization or NCache compact serialization is not being used.
Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Add Method
An "Add" method will add item to the cache only if that item does not already exist in the cache. Otherwise, it will throw an exception.
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    static void Main( string [] args)
    {
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Add Item to Cache
    _cache.Add( "Customer:David:1001", customer);
    Object object_Customer = _cache.Get("Customer:David:1001");
    Customer customerInformation = ( Customer )object_Customer;
    Console.WriteLine("Customer ID: " + customerInformation.customerID);
    Console.WriteLine("Name: " + customerInformation.name);
    Console.WriteLine("City: " + customerInformation.City);
    Console.WriteLine("Contact Number: " + customerInformation.ContactNumber);
    Console.WriteLine("Order placed: " + customerInformation.IsOrderInProcess);
    }
  4. Start the Local Cache 'myCache'.
  5. Run the project.
Using Insert Method
Additionally, you can use "Insert" method to either add or update the item in the cache. Insert method adds item only if it does not already exist in the cache. Otherwise, it updates the item.
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    static void Main( string [] args){
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Insert Item to Cache
    _cache.Insert("Customer:David:1001", customer);
    Object objectCustomer = _cache.Get("Customer:David:1001");
    Customer customerInformation = (Customer)objectCustomer;
    Console.WriteLine("Customer ID: " + customerInformation.customerID);
    Console.WriteLine("Name: " + customerInformation.name);
    Console.WriteLine("City: " + customerInformation.City);
    Console.WriteLine("Contact Number: " + customerInformation.ContactNumber);
    Console.WriteLine("Order placed: " + customerInformation.IsOrderInProcess);
    }
  4. Start the Local Cache 'myCache'.
  5. Run the project.
See Also
Initialize Cache | Finding items | Removing Items | Dispose Cache | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Removing Items

< Previous page Next page >

Removing Items

You can remove items from the cache from anywhere in your application using Remove and RemoveAsync methods. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Remove Method
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Add Item to Cache
    _cache.Add("Customer:David:1001" , customer);
    // Removes key from Cache and returns the attached object with it
    Object removedObject = _cache.Remove("Customer:David:1001");
    Customer customerInformation = (Customer)removedObject;
    Console.WriteLine("Customer ID: " + customerInformation.customerID);
    Console.WriteLine("Name: " + customerInformation.name);
    Console.WriteLine("City: " + customerInformation.City);
    Console.WriteLine("Contact Number: " + customerInformation.ContactNumber);
    Console.WriteLine("Order placed: " + customerInformation.IsOrderInProcess);
  4. Start the Local Cache 'myCache'.
  5. Run the project.
See Also
Initialize Cache | Adding Items | Finding items | Dispose Cache | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Deleting Items

< Previous page Next page >

Deleting Items

Once you have a valid cache handle, you can perform "Delete" operations on cache. This operation has many overloads and the basic overload takes only one parameter i.e. "key" as string.
Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Delete Method
A "Delete" method will delete item from the cache only if that item already exist in the cache. Exception will be thrown if the method is unable to delete the key from the cache.
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    static void Main( string [] args)
    {
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Add Item to the Cache
    _cache.Add("Customer:David:1001", customer);
    // Delete the above Item from the Cache
    _cache.Delete("Customer:David:1001");
    }
  4. Start the Local Cache 'myCache'.
  5. Run the project.
See Also
Initialize Cache | Finding items | Removing Items | Dispose Cache | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Finding Items

< Previous page Next page >

Finding Items

Items can be retrieved from cache either by using Get method or the cache indexer. Both methods are explained below with examples.
Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Get Method
Here is how items can be retrieved fom the cache.
Cache _cache = NCache.Caches["myCache"];
// Returns null if item not found
object myObject = _cache.Get("Customer:David:1001");
if (myObject == null)
{
// Item not found
}
Using Cache["key"]
Here is another way to retrieve items from the cache.
Cache _cache = NCache.Caches["myCache"];
// Returns null if item not found
object myObject = _cache["Customer:David:1001"];
if (myObject == null)
{
// Item not found
}
Using Contains Method
You can also check whether an item exists in the cache or not.
Cache _cache = NCache.Caches["myCache"];
// Returns true or false
if (_cache.Contains("Customer:David:1001") == false)
{
// Item found
}
See Also
Initialize Cache | Adding Items | Removing Items | Dispose Cache | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Dispose Cache

< Previous page Next page >

Dispose Cache

After you are done using cache, you can dispose it. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
The code for disposing the cache is as follows:
Cache _cache = NCache.InitializeCache("myCache");
// Dispose the cache
_cache.Dispose();
Disposing the cache in ASP.NET Applications
If you're developing ASP.NET application, the best place to put Dispose() call is in your HttpApplication's Dispose() method. This method is called when the instance of your HttpApplication is destroyed.
public virtual void Dispose()
{
Cache_cache = NCache.InitializeCache("myCache");
// Dispose the cache
_cache.Dispose();
}
See Also
Initialize Cache | Adding Items | Finding items | Removing Items | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Cache

< Previous page Next page >

Stop Cache

To stop a cache using Cache API, you need to include the following namespace in your application.
using Alachisoft.NCache.Web.Management;
Stopping a local cache
//stop the local cache
CacheManager.StopCache("CacheID","Server_Name");
Stopping a remote cache
//stop the remote cache
CacheManager.StopCache("CacheID","Server_Name");
See Also
Initialize Cache | Adding Items | Finding items | Removing Items | Dispose Cache | Start Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Quick Start Guide for .NET

< Previous page Next page >

Quick Start Guide for .NET

In this section, you will see quick start guides to use NCache.
In This Section
Store ASP.NET 1.1 Sessions
Gives quick steps to use Session State Module.
Store ASP.NET 2.0+ Sessions
Presents a step by step guide to use Session State Store Provider.
Use as ASP.NET Output Cache
Lets you start quickly with Output Caching.
Use as NHibernate Second Level Cache
Instructions to setup NCache to work seamlessly with NHibernate.
Use Dynamic Compact Serialization
Lets you get start with Compact Serialization.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Store ASP .NET 1.1 Sessions

< Previous page Next page >

Quick Start with Session State HTTP Module

NCache Session State Module allows you to transparently save and retrieve ASP.NET session-state objects within a web farm. As compared to ASP.NET Session State Module which is centralized in nature, NCache Session State Module is truly distributed. It benefits from clustered caching and thus, implicitly avoids single point of failure. Also, when running cache as InProc, no extra cost is involved in retrieving session-state objects. The steps below ensure that you easily start using clustered session HTTP Module in your ASP.NET applications.
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 1: Configure the Cache

< Previous page Next page >

Step 1: Configure the Cache

To use Session State HTTP Module in your application, follow the steps mentioned below. You can either choose to create a Local Cache that resides only on your computer or a Clustered Cache involving multiple computers. For now, we'll create a clustered cache.
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Create a new cluster . Select following options from the New Cluster Wizard:
  • Cluster Name: myQSReplicatedCache
  • Cluster Type: Replicated
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least one node.
  • Cluster Port: Any available port
  • Maximum Size: 250MB (default)
  • Eviction: Priority Based (default)
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of sessions, we recommend to turn off eviction)
  • Clean Interval (sec.): 15(default)
  • Start the cluster .
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear the cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop the cluster
  • Go to Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply the changes to the cluster . You will notice that you no longer have the 'myReplicatedCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Edit Web.Config or Machine.Config | Start/Restart ASP.NET Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 2: Edit web.config or machine.config

< Previous page Next page >

Step 2: Edit web.config or machine.config

After you have configured the cache and have named it 'myQSReplicatedCache', you now need to configure your ASP.NET application to use the Clustered Session HTTP Module that is provided with NCache installation. To do so, you must edit web.config file.
Please follow these steps for enabling NCache Session State Module to transparently save and retrieve ASP.NET session-state objects.
  1. Edit your application's web.config file to add <appSettings> entry under <configuration> section.
    <appSettings>
    <add key = "CacheName" value = "myQSReplicatedCache "/>
    <add key = "sessionAppId " value = " 1234 "/>
    <add key = "exceptionsEnabled " value = " true "/>
    <add key = "enableLogs " value = " false " />
    <add key = "enableDetailLogs " value = " false "/>
    <add key = "clearASPSession " value = " false "/>
    <add key = "writeExceptionsToEventLog " value = " false "/>
    <add key = "operationRetries" value = "0"/>
    <add key = "operationRetryInterval" value = "0"/>
    </appSettings>
    For detailed description of different key-value pairs specified above, please see Using NCache Session State Module .
  2. Add <httpmodules> entry under <system.web> section in web.config.
    For Enterprise and Professional Edition:-
    <httpModules>
    <add name = "NCacheWebSessionState" type = "Alachisoft.NCache.Web.SessionState.NSessionStateModule,
    Alachisoft.NCache.SessionState, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
    </httpModules>

    For Open Source Edition:-
    <httpModules>
    <add name = "NCacheWebSessionState" type = "Alachisoft.NCache.Web.SessionState.NSessionStateModule,
    Alachisoft.NCache.SessionState, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</httpModules>
Replace version “x.x.x.x” with the actual NCache version that you have.
  1. Add <machinekey> entry under <system.web > section in the web.config. It is required to generate ASP.NET session IDs in the same manner on all nodes.
    <machineKey validationKey = "A01D6E0D1A5D2A22E0854CA612FE5C5EC4AECF24" decryptionKey = "ACD8EBF87C4C8937" validation = "SHA1"/>
Enable Location Affinity for HttpModule
1. Add following section in web.config.
For Enterprise and Professional Edition:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</configSections>
<ncache>
<sessionLocation >
<primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
<secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
<secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
</sessionLocation>
</ncache>
For Open Source Edition:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</configSections>
<ncache>
<sessionLocation >
<primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
<secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
<secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
</sessionLocation>
</ncache>
For detailed description of different key-value pairs specified above, please see Using Location Affinity for Sessions .
Please keep the followinf points in mind:
  • Replace version “x.x.x.x” with the actual NCache version that you have.
  • The sid-prefix is a unique identifier that is appended by custom session-ID manager in the beginning of session-ID. sid-prefix length must be equal to 4.
  • When Location Affinity is enabled, "CacheName" specified in <appSettings> section of web.config will be ignored.
2. Enable custom session-ID manager using the sessionIDManagerType attribute of the sessionState element in web.config.
<sessionState mode = "InProc" cookieless = "true" timeout = "20" sessionIDManagerType = "Alachisoft.NCache.Web.SessionStateManagement.CustomSessionIdManager, Alachisoft.NCache.SessionStateManagement"/>
Custom session-ID manager is only supported for .NET 2.0 and later. Thus, for any applications build with earlier versions of .NET, Custom session-ID manager is not required.
See Also
Configure the Cache | Start/Restart ASP.NET Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 3: Start/Restart ASP.NET Application

< Previous page Next page >

Step 3: Start/Restart ASP.NET Application

Now that you have configured a Replicated Cluster through NCache Manager and have edited web.config to add NCache Clustered Session HTTP Module, you're ready to start or restart your ASP.NET application. To restart your ASP.NET application, unload App domain first. This can be done by saving web.config.
See Also
Configure the Cache | Edit Web.Config or Machine.Config
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Store ASP .NET 2.0+ Sessions

< Previous page Next page >

Using Session State Store Provider

NCache Session State Provider is a custom SessionStateStoreProviderBase implementation for an ASP.NET application. This implementation reads and writes ASP.NET session data from and to the cache. This allows you to transparently save and retrieve ASP.NET session-state objects within a webfarm NCache also provides the Session State Module which can be used for applications that are intended to run on older .NET frameworks like 1.1.
The steps below are to ensure that you quickly start using Custom Session Store Provider with ease.
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET App
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 1: Configure the Cache

< Previous page Next page >

Step 1: Configure the Cache

To use Session State Store Provider in your application, follow the steps written below. You can either choose to create a Local Cache that resides only on your computer or a Clustered Cache involving multiple computers. For now, we'll create a clustered cache.
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Create a new cluster . Select following options from the New Cluster Wizard:
  • Cluster Name: myQSReplicatedCache
  • Cluster Type: Replicated
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least one node
  • Cluster Port: Any available port
  • Maximum Size: 250MB (default)
  • Eviction: Priority Based (default)
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of sessions, we recommend to turn off eviction)
  • Clean Interval (sec.): 15 (default)
  • Start the cluster .
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from .
  • Clear the cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop the cluster.
  • Go to Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply the changes to the cluster . You will notice that you no longer have the 'myCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Edit Web.Config or Machine.Config | Start/Restart ASP.NET App
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 2: Edit web.config or machine.config

< Previous page Next page >

Step 2: Edit web.config or machine.config

After you have configured the cache and have named it "myQSReplicatedCache", you now need to configure your ASP.NET application to use the Custom Session Store Provider that is provided with NCache installation. To do so, you must edit web.config file.
Please follow these steps for enabling NCache Session Store Provider to transparently save and retrieve ASP.NET session state:
  • Edit your application's web.config file and modify the <sessionState> section as given below.
    For Enterprise and Professional Edition:-
    <assemblies>
    <add assembly = "Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
    </assemblies>
    <sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom" customProvider = "NCacheSessionProvider" timeout = "10">
    <providers>
    <add name = "NCacheSessionProvider" type = "Alachisoft.NCache.Web.SessionState.NSessionStoreProvider"
    sessionAppId = "1234" cacheName = "myQSReplicatedCache" writeExceptionsToEventLog = "false"
    enableLogs = "false" enableDetailLogs = "false" exceptionsEnabled = "false" operationRetry = "0" operationRetryInterval = "0" />
    </providers>
    </sessionState>
    For Open Source Edition:-
    <assemblies>
    <add assembly = "Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
    </assemblies>
    <sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom" customProvider = "NCacheSessionProvider" timeout = "10">
    <providers>
    <add name = "NCacheSessionProvider" type = "Alachisoft.NCache.Web.SessionState.NSessionStoreProvider"
    sessionAppId = "1234" cacheName = "myQSReplicatedCache" writeExceptionsToEventLog = "false"
    enableLogs = "false" enableDetailLogs = "false" exceptionsEnabled = "false" operationRetry = "0" operationRetryInterval = "0" />
    </providers>
    </sessionState>
Replace version “x.x.x.x” with the actual NCache version that you have.
For detailed description of different key-value pairs specified above, please see Using Session State Store Provider .
  • Add <machinekey> entry under <system.web> section of web.config. It is required, so that ASP.NET session IDs are generated in the same manner on all nodes. You can use genmackeys utility available with NCache installation to generate the keys.
    <machineKey validationKey = "A01D6E0D1A5D2A22E0854CA612FE5C5EC4AECF24" decryptionKey = "ACD8EBF87C4C8937"
    validation = "SHA1"/>
Enable Location Affinity for SessionStoreProvider
  • Add following section in web.config.
    For Enterprise and Professional Edition:-
    <configSections>
    <section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
    Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
    </configSections>
    <ncache >
    <sessionLocation >
    <primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
    <secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
    <secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
    </sessionLocation>
    </ncache>
    For Open Source Edition:-
    <configSections>
    <section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
    Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
    </configSections>
    <ncache >
    <sessionLocation >
    <primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
    <secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
    <secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
    </sessionLocation>
    </ncache>
    For detailed description of different key-value pairs specified above, please see Using Location Affinity for Sessions .
    Please keep the following points in mind:
  • Replace version “x.x.x.x” with the actual NCache version that you have.
  • The sid-prefix is a unique identifier that is appended by custom session-ID manager in the beginning of session-ID. sid-prefix length must be equal to 4.
  • When Location Affinity is enabled, "CacheName" specified in <providers> section of web.config will be ignored.
  • Enable custom session-ID manager using the sessionIDManagerType attribute of the sessionState element in web.config.
    <sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom"customProvider = "NCacheSessionProvider" timeout = "60" sessionIDManagerType = "Alachisoft.NCache.Web.SessionStateManagement.CustomSessionIdManager, Alachisoft.NCache.SessionStateManagement">
See Also
Configure the Cache | Start/Restart ASP.NET App
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 3: Start/Restart ASP.NET Application

< Previous page Next page >

Step 3: Start/Restart ASP.NET Application

Now that you have configured a clustered cache through NCache Manager and have edited web.config to add NCache Session Store Provider, you're ready to start or restart your ASP.NET application. To restart your ASP.NET application, unload App domain first. This can be done by saving web.config.
See Also
Configure the Cache | Edit Web.Config or Machine.Config
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Use as ASP.NET Output Cache

< Previous page Next page >

Quick Start with Output Caching
This feature is not available in NCache Express and Professional edition.
NCache provides extremely fast and reliable output caching feature for ASP.NET applications running in web farm environment, where regular output caching fails. Once a page is rendered by any of the web server in the web farm, it is available to the all other servers due to cluster cache created by NCache. Your cached pages are highly available because clustered cache allows no single point of failure. The steps below are to ensure that you quickly start using Output Caching.
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 1: Configure the Cache

< Previous page Next page >

Step 1: Configure the Cache
This feature is not available in NCache Express and Professional edition.
To use Output Cache in your web application, follow the steps mentioned below. You can either choose to create a Local Cache that resides only on your computer or a Clustered Cache involving multiple computers. For now, we'll create a clustered cache.
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Select following options from the New Cluster Wizard:
  • Cluster Name: myQSPartitionedCache
  • Cluster Type: Partitioned
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least one node.
  • Cluster Port: Create a new cluster on any available port.
  • Maximum Size: 250MB (default)
  • Eviction: Priority Based (default)
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of session it is recommended that turn off eviction)
  • Clean Interval (sec): 15 (default)
  • Start the cluster.
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear the cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop the cluster.
  • Go to Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply the changes to the cluster .
You will notice that you no longer have the 'myPartitionedCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Edit Web.Config or Machine.Config | Start/Restart ASP.NET Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 2: Edit Web.Config or Machine.Config

< Previous page Next page >

Step 2: Edit Web.Config or Machine.Config
This feature is not available in NCache Express and Professional edition.
After you have configured the cache and have named it "myQSPartitionedCache", you now need to configure your ASP.NET application to use the Output Cache Module that is provided with NCache installation. To do so, you must edit web.config file.
Please follow these steps for enabling NCache Output Caching Module to transparently save and retrieve rendered pages.
  1. Register NOutputCache as httpmodule inside <system.web> in web.config file.
    For Enterprise and Professional Edition:-
    <httpModules>
    <add name = "Alachisoft.NCache.Web.NOutputCache" type = "Alachisoft.NCache.Web.NOutputCache.NOutputCache,
    Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
    </httpModules>
    For Open Source Edition:-
    <httpModules>
    <add name = "Alachisoft.NCache.Web.NOutputCache" type = "Alachisoft.NCache.Web.NOutputCache.NOutputCache,
    Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
    </httpModules>
Replace version “x.x.x.x” with the actual NCache version that you have.
2. Register 'ncache' configuration section in the <configSections> of the web.config as follows:
For Enterprise and Professional Editions:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.NOutputCache.NCacheSection, Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
</configSections>
For Open Source Edition:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.NOutputCache.NCacheSection, Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</configSections>
Replace version “x.x.x.x” with the actual NCache version that you have.
3. Then add actual <ncache> section in <configuration> section of web.config holding information of pages to be cached.
<ncache>
<outputCacheSettings cacheName = "myQSPartitionedCache" clientCacheName = "" exceptionsEnabled = "true" enableLogs = "false" enableClientCacheSync = "false">
<outputCachePages>
<add name = "/NOutputCacheSample/main.aspx" enabled = "true" requestType = "post" duration = "20" varyByParam = "cbxCustomerName" varyByHeader = "Connection" varyByCustom = "browser"/>
</outputCachePages>
</outputCacheSettings>
</ncache>
For detailed description of different key-value pairs specified above, please see Using Output Cache .
See Also
Configure the Cache | Start/Restart ASP.NET Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 3: Start/Restart ASP.NET Application

< Previous page Next page >

Step 3: Start/Restart ASP.NET Application
This feature is not available in NCache Express and Professional edition.
Now that you have configured a cache through NCache Manager and have edited web.config to add NCache Output Caching, you're ready to start or restart your ASP.NET application. To restart your ASP.NET application, kill your ASP.NET process through Task Manager first.
See Also
Configure the Cache | Edit Web.Config or Machine.Config
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Use as NHibernate Second Level Cache

< Previous page Next page >

Quick Start with NHibernate

NCache provides a second level or process level distributed cache for NHibernate by implementing ICacheProvider and ICache interfaces. You can plug-in NCache to your existing NHibernate application without any code change. Just change your NHibernate configuration file to plug-in NCache as your cache provider and you're all set to start using distributed caching.
This section allows you to get start with NHibernate.
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 1: Configure the Cache

< Previous page Next page >

Step 1: Configure the Cache

Create a Clustered Cache named 'myQSReplicatedCache' as follows:
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Create a new cluster . Select following options from the New Cluster Wizard:
  • Cluster name: myQSReplicatedCache
  • Cluster Type: Replicated
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least your current computer and maybe others if you want.
  • Cluster Port: 8714
  • Cache Name: Provide a unique identifier for the cache.
  • Maximum Size: 250MB (default)
  • Eviction: Priority based
  • Default Priority: Normal
  • Eviction Percentage: 5 (default)(In case of sessions it is recommended that turn off eviction)
  • Clean Interval (sec.): 15 (default)
  • Start cluster.
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop cluster
  • Go to Main tab
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply changes to the cluster . You will notice that you no longer have the 'myQSReplicatedCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Register NCache with NHibernate | Enable DBCacheDependency in NHibernate | Run your NHibernate based Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 2: Register NCache with NHibernate

< Previous page Next page >

Step 2: Register NCache with NHibernate

To register NCache with NHibernate, edit app.config or web.config as follows:
  1. Register 'nhibernate' configuration sections in the <configSections> of the web.config or app.config as follows:
    <configSections>
<section name="hibernate-configuration" type="NHibernate.Cfg.ConfigurationSectionHandler,
NHibernate"/>
</configSections>
2. Define section details for <nhibernate> as follows:
<hibernate-configuration xmlns = "urn:nhibernate-configuration-2.2">
<bytecode-provider type="lcg"/>
<reflection-optimizer use="true"/>
<session-factory>
<property name="connection.provider"> NHibernate.Connection.DriverConnectionProvider
</property>
<property name="connection.isolation">ReadCommitted</property>
<property name="dialect">NHibernate.Dialect.MsSql2008Dialect</property>
<property name="connection.driver_class">NHibernate.Driver.OleDbDriver</property>
<property name="connection.connection_string">Provider=SQLOLEDB; Data Source=20.200.20.54;
Initial Catalog=Northwind;User ID=sp; Password=4Islamabad</property>
<property name="cache.provider_class">
Alachisoft.NCache.Integrations.NHibernate.Cache.NCacheProvider,
Alachisoft.NCache.Integrations.NHibernate.Cache </property>
<property name="proxyfactory.factory_class">
NHibernate.Bytecode.DefaultProxyFactoryFactory, NHibernate </property>
<property name="cache.use_second_level_cache">true</property>
<property name="cache.use_query_cache" >true</property>
<property name="show_sql">true</property>
</session-factory>
</hibernate-configuration>
3. Add following section in NCacheNHibernate.xml file you can place this file in the config folder of NCache or in bin folder of your application:
<configuration>
<application-config application-id="myapp" enable-cache-exception="true" default-region-name="default"
key-case-sensitivity="false">
<cache-regions>
<region name="AbsoluteExpirationRegion" cache-name="myCache" priority="Default" expiration-type="sliding"
expiration-period="180" />
<region name="default" cache-name="myCache" priority="default" expiration-type="none"
expiration-period="0" />
</cache-regions>
</application-config>
</configuration>
The above example of app.config or web.config contains the following options for you to configure. Each of them is explained below as well.
cache.provider_class: This option lets you specify that NCache is your second level cache provider. You need to mention two classes which implement NHibernate.Cache.ICacheProvider and NHibernate.Cache.ICache interfaces respectively. This is how NHibernate knows how to call this second level cache.
ncache.application_id: This option lets you specify application id of current NHibernate application for NCache. This id will be than used to select configurations for current application from NCacheNhibernate.xml.
NCacheNHibernate.xml contains all the configurations used by NCache provider for NHibernate. NCacheNHibernate.xml contains following configurable options:
application-config:
This section lets you specify configuration for NCache use for a particular application.
Multiple application configurations can be specified in NCacheNHibernate.xml. Any NHibernate application will use one of the specified configuration based on the application-id specified in applications app.config/web.config file.
Following are the configurable options in application-config section.
application-id: This options let you specify the unique id for current application-config. This id is used to select appropriate configuration for a particular application.
enable-cache-exception: Identifies whether the exceptions if occurred in NCache will be propagated to NHibernate provider.
default-region-name: Allows to specify a default region for the application. If a particular region's configurations are not fount default region's configurations will be used. Specified default region's configuration must exist in cache-regions section.
key-case-sensitivity: This option allows to specify whether cache keys will be case sensitive or not. This option has to be configured according to database used. If database is case-sensitive set this option true, otherwise false.
cache-regions:
This sections lets you configure multiple cache regions for NHibernate application. Each region's configuration is specified in region tag.
region:
This tag contains the configurations for one particular region. Following options can be configured for any particular region.
name: Each region is identified by its name. Name of the region should be unique.
cache-name: This option allows to specify NCache's cache name to be used for this region.
priority: The priority you want to use for items cached. The possible values are :
  • Default
  • Low
  • BelowNormal
  • Normal
  • AboveNormal
  • High
  • NotRemovable
expiration-type: This options allows to specify type of expiration for any item in this region. Possible values are absolute/sliding/none.
expiraion-period: Allows to specify expiration period if absolute/sliding expiration is configured. Its value should be greater than 0.
database-dependencies:
This section lets you specify database dependencies for current NHibernate application.
dependency: Each dependency is configured in dependency tag. Multiple tags can be configured for multiple dependencies. Following options can be configured for each dependency.
entity-name: Dependencies are added based on the fully qualified name of classes. This option allows to specify name of class for which current dependency is to be added.
type: Allows to specify database dependency type. Possible values are sql/oracle/oledb.
sql-statement: Allows to specify sql statement to be used for building NCache's database dependency.
cache-key-format: This option is used to configure cache key format for any item of current entity type. Cache key format should include "[pk]" in it, which will be replaced with the primary key of record. cache-key-format may also include "[en]" which will be replaced with entity name. Default value of cache key format is "NHibernateNCache:[en] #[pk]".
composite-key-separator: If the records of current entity have composite key as primary key, cache-key can be formed by combining all keys separated by this composite-key-separator. composite-key-separator must be of one character length. Its default value is "$".
Note:
  • Calling new Configuration() only reads the <nhibernate> section.
  • Calling no-parameter version of cfg.Configure() configures NHibernate from app.config if it contains <nhibernate-configuration>, otherwise hibernate.cfg.xml is used.
See Also
Configure the Cache | Enable DBCacheDependency in NHibernate | Run your NHibernate based Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 3: Enable DBCacheDependency in NHibernate

< Previous page Next page >

Step 3: Enable DBCacheDependency in NHibernate

To enable Database Cache Dependency in nhibernate items, you need to define <database-dependencies> configuration section in the application's configuration file (it could be app.config file if its a desktop application or web.config file if its a web application) and enable database notifications in the database.
To enable DBCacheDependency in NHibernate, do the following:
  1. Provide dbSync type in <database-dependencies> section as follows:
<configuration>
<application-config application-id="myapp" enable-cache-exception="true" default-region-name="default"
key-case-sensitivity="false">
<cache-regions>
<region name="AbsoluteExpirationRegion" cache-name="myCache" priority="Default" expiration-type="sliding"
expiration-period="180"/>
<region name="default" cache-name="myCache" priority="default" expiration-type="none"
expiration-period="0" />
</cache-regions>
<database-dependencies>
<dependency entity-name="nhibernator.BLL.Customer" type="oledb" sql-statement="select ContactName from
dbo.Customers where CustomerID =?" cache-key-format="depdency.customer:[pk]"/>
</database-dependencies>
</application-config>
</configuration>
The type of database dependency is either "sql", "oracle", "oledb". sql is a mechanism for synchronizing your cache with SQL Server 2005 database through .NET events. oledb allows you to synchronize your cache with any OLEDB compliant database through a configurable polling interval. If you specify "sql" value, then you must also specify the sql-statement="...". You specify a "select" SQL statement to identify a row in SQL Server 2005 database that corresponds to this cached item. Then, whenever that row is updated or removed, this cached item is also removed.
2. Enable database notifications on the database except when you are using SQL Server 2005. For further details see Enabling Database Notifications for SQL Server , Enabling Database Notifications for Oracle and Enabling Database Notifications for DB2.
See Also
Configure the Cache | Register NCache with NHibernate | Run your NHibernate based Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 4: Run your NHibernate based Application

< Previous page Next page >

Step 4: Run your NHibernate based Application

Before running your application make sure that the cache is running if it is configured as OutProc cache. You may see the statistics of the cache through statistics window.
See Also
Configure the Cache | Register NCache with NHibernate | Enable DBCacheDependency in NHibernate
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Use Dynamic Compact Serialization

< Previous page Next page >

Quick Start with Compact Serialization
This feature is not available in NCache Express and Professional edition.
This quick start allows you to get start with NCache using Compact Serializable Objects.
Step 1: Register your Compact types with NCache
Step 2: Run your Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 1: Register Compact Types with NCache

< Previous page Next page >

Step 1: Register Compact Types with NCache
This feature is not available in NCache Express and Professional edition.
Configure the Cache
Create a Local Cache named "myCache" as follows:
  • Run NCache Manager.
  • Create a new project.
  • Create a new cache . Select following options from New Cache Wizard:
  • Cache Node: It may be the current computer and may be some other if you want.
  • Cache name: myCache
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Cluster Port: 8714
  • Maximum Size: 250 MB (default)
  • Eviction Policy: Priority based
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of session it is recommended that turn off eviction)
  • Clean interval (sec.): 15
  • Start the cache.
  • Verify that cache is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear the cache to make it ready for your application.
Registering Compact Serializable Types
You can register types one by one through 'add types' button. Perform following steps to register types with the configured cache:
  • Stop the Cache if it is running.
  • Click on the 'Compact Serialization' tab which will open up the following screen.
  • Click 'Add Types' button. A 'Select Compact Classes' dialog box will appear.
  • Browse for the assembly file that contains the compact types by clicking 'Browse' button as shown in the figure.
  • Select the classes you want to register with the cache from the loaded classes list.
  • Press 'Add Class' button to add classes in selected classes list.
  • Click 'OK'.
  • Newly added types will start appearing in the list box under the 'Compact Serialization' tab having Compact Type and Platform information.
  • 'Remove' will delete the selected type from the registered types list.
  • This shows all the added types. Now arguments can be added with generic types by clicking on 'Add <T>' button.
Registering Generic Compact Types Through Generic Type Handler
There is another way for registering generic compact types through Generic Type Handler. With Generic Type Handler user can add all the Generic types at once by implementing our interface. This is time saving, convenient and gives you option of re-usability. Here is a sample code for this.
public class CustomGenericType<T,K,V>
{
}
public class SetGenerics: IGenericTypeProvider
{
Type[] types = new Type[6];
#region IGenericTypeProvider Members
Type[] IGenericTypeProvider.GetGenericTypes()
{
types[0]=typeof(Dictionary<string, Customer>);
types[1]=typeof(List<int>);
types[2]=typeof(CustomGenericType<Employee, Product, Customer>);
types[3]=typeof(CustomGenericType<Employee, Product, int>);
types[4]=typeof(CustomGenericType<Employee, string, byte>);
types[5]=typeof(CustomGenericType<string, Customer, bool>);
return types;
}
#endregion
}
For registering types follow steps given below.
  • Click on 'Generic Type Handler' button. A 'Select Compact Classes' dialog box will appear.
  • Browse for the assembly file that contains the compact types by clicking the 'Browse' button as shown in the figure.
  • Click 'OK' button.
  • Apply changes to the cache.
Specifying InProc or OutProc Access Mode
Please note that this cache has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cache details window. If you want to change Isolation Level, do the following:
  • Stop the cache .
  • Go to the Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply configuration changes to the cache . You will notice that you no longer have the 'myCSCache node->Start' menu enabled. This is because, the cache is now supposed to start as part of your application process.
See Also
Run your Application
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Step 2: Run Your Application

< Previous page Next page >

Step 2: Run Your Application
This feature is not available in NCache Express and Professional edition.
Before running your application, make it sure that you have deployed the assembly containing compact types. Also, make sure compact types are registered with the cache and cache is running if it is configured as OutProc cache. You may see the statistics of the cache through statistics window.
See Also
Register Compact Types with NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Administrator's Guide

< Previous page Next page >

Administrator's Guide

This section provides a guide to perform administrative tasks on caches and bridges using NCache Manager, command line tools and configuration files.
In This Section
Configuring Caches
Discusses how to create caches and configure settings of both local caches and cache clusters.
Management Operations
Describes how to perform different cache management operations like start cache, stop cache, apply configuration etc.
Configuring Cache Clients
Explains the procedure to add/remove node in client cache, create client cache and configure its basic settings.
Configuring Security
Discusses how to configure appropriate security and encryption for cache.
Configuring Bridge for WAN Replication
Discusses bridges in NCache and its configurations. It also explains how to perform different bridge management operations.
Monitoring NCache
Describes cache counters provided by NCache. It also explains how to oversee the performance of caches and bridges using NCache Manager, Monitor and Perfmon Tool.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Caches

< Previous page Next page >

Configuring Caches

This section of the documentation discusses configuration options that NCache provides for local and clustered caches. It helps you configure cache through NCache Manager and configuration files.
In This Section
Creating Caches
Discusses how to create local and clustered caches.
Adding Server Node in a Cache Cluster
Describes configuring local and clustered caches and their operations through NCache Manager.
Configuring Basic Cache settings
This section explains how to configure basic cache settings.
Configuring Cache Cluster Settings
This section discusses how to configure basic clustered cache settings.
Configuring Query Indexes
This section discusses how to configure query indexes for a cache.
Registering Classes for Compact Serialization
This section describes how to register classes for compact serialization.
Registering Classes for Portable Data Sharing
This section describes how to register classes for portable data sharing.
Configuring Data Source Providers
This section explains how to configure data source providers like read-through, write-through and write-behind.
Configuring Cache Start-up Loader
This section explains how to configure cache start up loader through which a user can preload the cache with given data at the time of cache start-up.
Configuring Cache Level Events
This section describes how to configure cache level events for addition, update and removal of an item.
Configuring Eviction Policy
This section explains how to configure eviction policy for a cache.
Configuring Compression
This section explains how to configure data compression for a cache.
Configuring Email Notifications
This section explains how to configure email notifications for events occurring in a cache.
Binding Cluster and Client/server for a Dedicated IP
This section explains how to bind a cluster, client/server or both (cluster and client/server) with dedicated IP addresses.
Configuring Heart Beat
This section explains what is heart beat, the way to enable/disable it and its basic configuration settings.
Auto Start Cache at Boot
This section explains the auto start cache at boot option and how to configure it.
Nagling
This section explains what is nagling and how to configure its settings using service's config file.
Dual Sockets
This section explains the concept of dual sockets and how to enable/disable it.
Error Logging
This section explains how to enable/disable error logging and where these logs are generated.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating Caches

< Previous page Next page >

Creating Caches

In NCache, you can create two main types of caches.
  • Local Cache
  • Clustered Cache
This section provides step by step details on creating these caches using both the NCache manager and command line tools.
In This Section
Creating Local Cache
Explains how to create local cache using the NCache manager and command line tools.
Creating Cache Clusters
Explains how to create clustered cache using the NCache manager and command line tools.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating Local Cache

< Previous page Next page >

Creating Local Cache

Local cache can be created in two ways:
  • Using NCache Manager
  • Using Command Line Tools
Using NCache Manager
  • To create a new Local Cache through NCache Manager, from the 'File' menu select 'New' -> 'Cache'.
  • A 'New Cache Wizard' will appear. In New Cache Wizard, specify the server IP address and click Next.
  • Specify the name of the cache in text box and click Next.
  • Change the cache size if required and click Next.
  • In Advanced options dialog, you can configure the following settings:
Eviction Policy: Specifies the eviction policy to determine which items are to be removed from cache, if it is full, to accommodate new items. You can change the eviction policy. Eviction policy will be configured but if you want this feature, then you have to turn it on after cache creation.
Eviction percentage: Specifies the percentage of items to be removed on each eviction. It can also be changed. Items will be evicted from cache using this percentage value if eviction is enabled.
Clean Interval: The periodic interval after which the expired items are removed from the cache. Its default value is 15 sec.
Start this cache on finish: If this check box is checked then this new cache will start automatically as you click the finish. Using “Auto start this cache on service startup” option, user will be able to mark the cache as a startup cache which will be started on cache service startup.
  • Click Finish. Created cache will be appeared in Cache Explorer under Local Caches node hierarchy.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createcache.exe, provide the required information:
createcache.exe Cache /s test1 /S 250
  • Hit ENTER key, it will create Cache of local topology of size 250mb on test1 node.
See Also
Creating Cache Clusters | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating Cache Clusters

< Previous page Next page >

Creating Cache Clusters

A cache cluster is a set of interconnected server nodes forming a cluster of servers which behave as a single cache unit from outside. Cache clusters are usually preferred in scenarios where performance and scalability are needed. With additions of more server nodes in a cluster cache, more storage space and high availability of cached data can be gained
for large applications.
A cache cluster can be Mirrored, Partitioned, Partitioned Replica or Replicated. This section describes two ways of creating a clustered cache.
  • Create a new clustered cache
  • Add an existing clustered cache
In This Section
Creating a New Cache Cluster
Explains how to create a new cache cluster using the NCache manager and command line tools.
Add an Existing Cache Cluster
Explains how to use already created cache clusters.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating a New Cache Cluster

< Previous page Next page >

Creating a New Cache Cluster

Clustered Cache can be created in the following two ways:
Using NCache Manager
  • From the 'File' menu select 'New' -> 'Clustered Cache'.
  • A New Clustered Cache Wizard will appear. Specify the name of cache and click Next.
  • In Select caching topology dialog, select the required cache topology.
Cluster Caching Topologies: Mirrored cache is a cluster of two nodes (Active and passive), where all operations are performed on active node while the passive node is updated asynchronously. Passive node is promoted to active node as soon as the active node goes down. The Partitioned scheme partitions the data across the cluster, whereas the Replicated scheme provides data replication on all the nodes. Partitioned Replica scheme is same as a regular partitioned cache but it allows you to have replicas for each partition, replication can be done either synchronously or asynchronously.
Operation timeout (sec): The maximum time in seconds during which a clustered operation must be completed, otherwise the operation will fail.
Statistics replication interval (sec.): The time interval in seconds after which a node sends its statistics to all the other nodes in the cluster.
  • In case of Partitioned Replica cache you can have the choice to select the replication strategy for your cache using the screen shown below. Replication Strategy screen will only be encountered in case of POR.
Replication Strategy: Replication Strategy is defines as how the data is replicated to the backup node. It can be Synchronous or Asynchronous.
  • Asynchronous replication: In Asynchronous replication data operations are replicated asynchronously to the backup node.
  • Synchronous replication: In Synchronous replication data operations are replicated synchronously to the backup node.
  • Specify the node IP address in text box or select from the Network Neighborhood and click on the ‘>’ button to add it in the Selected Nodes list. Click Next once all the required nodes are added.
  • Change the Cluster Port if required. Click Next.
  • In the next dialog, you can change the cache size if required. Click Next.
  • In Advanced options dialog, you can configure the following settings:
Eviction Policy: Specifies the eviction policy to determine which items are to be removed from cache, if it is full, to accommodate new items. You can change the eviction policy. Eviction policy will be configured but if you want this feature, then you have to turn it on after cache creation.
Eviction percentage: Specifies the percentage of items to be removed on each eviction. It can also be changed. Items will be evicted from cache using this percentage value if eviction is enabled.
Clean Interval: The periodic interval after which the expired items are removed from the cache. Its default value is 15 sec.
Start this cache on finish: If this check box is checked then this new cache will start automatically as you click the finish. Using “Auto start this cache on service startup” option, user will be able to mark the cache as a startup cache which will be started on cache service startup.
  • Click on the Finish button. Created cache will appear in Cache Explorer under Clustered Caches section.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createcache.exe, provide the required information:
createcache.exe ClusteredCache /s test3 /S 250 /t replicated /C 7818
  • Hit ENTER key, it will create ClusteredCache of replicated topology on server test3 with size 250mb using 7817 port.
See Also
Creating Local Cache | Adding an Existing Cache Cluster | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding an Existing Cache Cluster

< Previous page Next page >

Adding an Existing Cache Cluster

An already created cache cluster can also added in your project. this can be done as follows:
Using NCache Manager
  • Right click on Clustered Caches in Cache Explorer and select Add Existing Clustered Cache.
  • Add Clustered Cache Wizard will appear. Specify the Node Name/IP Address on which the cache cluster is registered and click Next.
  • A list of cache clusters registered on the node you specified will appear. Select the cluster and press Finish.
  • The selected cache cluster will appear in Cache Explorer under Clustered Caches section.
See Also
Creating Local Cache | Creating a New Cache Cluster | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding Server Node in a Cache Cluster

< Previous page Next page >

Adding Server Node in a Cache Cluster

A Server Node can be added in cluster any time. After adding a server node in a cluster, you need to start that node so that it can join the cluster.
Using NCache Manager
  • Right click on a cache name in Cache Explorer and select Add Server Node option.
  • Add Node Wizard will open. Specify the server IP which you want to add in text box and click Finish.
  • Added node will appear in Server Nodes list under this cache name.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addnode.exe, provide the required information:
addnode.exe demoClusteredCache /x 20.200.21.95 /N 20.200.21.107
  • Hit ENTER key, , it will add 20.200.22.107 node in demoLocalCache.
See Also
Creating Caches Clusters | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Removing Server Node from Clustered Cache

< Previous page Next page >

Removing Server Node from Clustered Cache

You can remove a Server Node from a cache cluster at any time in the following ways.
Using NCache Manager
  • To remove a Server Node, right click on the Node in the 'NCache Management' tree and select 'Remove' from the context menu.
l
  • A dialog box will appear asking to confirm the removal of node. Press Yes to continue. The server node will be removed.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use removenode.exe, provide the required information:
removenode.exe demoClusteredCache /s 20.200.20.107
  • Hit ENTER key, it will remove node 20.200.20.107 from demoClusteredCache.
See Also
Creating Cache Clusters | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Basic Cache Settings

< Previous page Next page >

Configuring Basic Cache Settings

This section describes how to configure the following basic cache settings.
  • Cache Size
  • Isolation Levels (InProc/OutProc)
  • Clean up Interval
Cache settings can be configured by using NCache manager or command line tools. These settings can also be specified in client.ncconf file.
In This Section
Cache Size
Explains how to configure the size of cache.
Isolation Levels
Explains what are isolation levels and how can they be configured for a cache.
Expiration Clean Up Interval
Explains clean up interval and the procedure to configure it for your cache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Size

< Previous page Next page >

Cache Size

Through this configuration option, you can specify an upper limit on the size of the cache in MB. The number of items in the cache are limited by maximum size of the cache and amount of free system memory (virtual or physical). If some eviction policy is specified, whenever total data size in cache reaches maximum size or when less than 10% of memory is left in the system, items are removed from the cache as per eviction policy. Maximum size of a cache can be specified by one of following two ways.
Using NCache manager
Default cache size is 250 MB but it can be changed as follows.
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Main tab.
  • Change the Cache Max. Size as per your needs.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
The size of the cache is also specified at the time of creating cache using S option in the definition using command line tool as follows.
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createcache.exe, provide the required information:
createcache.exe Cache /s test1 /S 250
  • Hit ENTER key, it will create Cache of local topology of size 250mb on test1 node. Here, instead of 250, any size can be mentioned.
Through Config.ncconf
You can specify the cache max size through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<storage type="heap" cache-size="250mb"/>
</cache-config>
See Also
Creating Caches | Configuring Isolation Levels | Configuring Expiration Clean Up Interval | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Isolation Levels

< Previous page Next page >

Isolation Levels

If your application is running on a server node (the node that is participating in the cluster), you can access the cache either as InProc or OutProc. For InProc, cache lives inside your application process and performs all the clustering operations from there. For OutProc, you have to start the cache independently and then connect to it. Both access modes have their own pros and cons.
InProc mode in a replicated cache can give you really fast GET operations since you're accessing all the data from within your own memory space. However, since your application and the cache are sharing the same memory, you may face memory size limitation (in terms of how much you can cache).
Similarly, OutProc has benefit that multiple applications on the same machine can share a common cache. Additionally, since the cache lives in its own memory, you have more memory available to you. But, there is an overhead of transferring data between your application process and the NCache process.
OutProc requires that your .NET Assemblies (the ones that contain the objects you're going to add into NCache) are either registered in GAC or are located at $INSTALL/NCache/bin/service folder. Otherwise, NCache will not find your object definitions which it requires for .NET Serialization. And, this will result in NCache throwing an exception when you do Add, Insert, Get, or Remove operations.
If you're running NCache in a clustered configuration, you must ensure this on all machines in the cluster. By default, all caches are outproc but isolation level can be changed for caches of local topology. It can be done in the following way:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Main tab.
  • Change the Isolation Level to Low (InProc) or High (OutProc) as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through Config.ncconf
In Config.ncconf , you can specify the attribute value of inproc as true (for inproc) or false (for outproc).
<!-- myreplicatedcache will start in inproc mode -->
<cache-config name="myreplicatedcache" inproc="true" config-id="8" last-modified="7/31/2010 3:53:53 PM">
<!-- mypartitionedcache will start in outproc mode -->
<cache-config name="mypartitionedcache" inproc="false" config-id="1" last-modified="6/20/2010 3:50:34 PM">
InProc mode is only available for Replicated and Local cache.
See Also
Creating Caches | Configuring Cache Size | Configuring Expiration Clean Up Interval | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Expiration Clean Up Interval

< Previous page Next page >

Expiration Clean Up Interval

Clean interval is the periodic interval after which the expired items are removed from the cache. By default, its value is 15 sec. You can change the it by one of following two ways.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Policies tab.
  • Change the Clean Interval as per your needs.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through Config.ncconf
Clean interval of a cache can also be specified through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<eviction-policy enabled="True" default-priority="normal" policy="priority" eviction-ratio="0.25"/>
<cleanup interval="15sec"/>
</cache-config>
See Also
Creating Caches | Configuring Isolation Levels | Configuring Cache Sizel | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Cache Cluster Settings

< Previous page Next page >

Configuring Cache Cluster Settings

This section describes different cache cluster settings and ways to configure them. These cache settings can be configured by using NCache manager or config.ncconf.
In This Section
Ports
Explains how to configure ports that NCache uses for communication.
Operation Timeout
Explains what is operation timeout and how to configure it.
Statistic Replication Interval
Explains statistic replication interval and the procedure to configure it for your cache cluster.
Connection Retries
Explains connection retries and the procedure to configure it.
Retry Interval
Explains retry interval and how to configure it for your cache cluster.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Ports

< Previous page Next page >

Ports

NCache uses TCP ports for communication. Default TCP port is 8250. These ports can be changed, if required, by changing the values of the registry key (TCP.PORT) written upon the installation of NCache.
This key can be found under the following path:
HKEY_LOCAL_MACHINE/SOFTWARE/ALACHISOFT/NCACHE
Please note that NCache Manager application assumes the default port. Therefore, upon changing the values of this port, LocalCache/Cluster can not be administered through NCache Manager application. However, NCache command line utilities and tools provide the option to address the LocalCaches/Clusters on other ports
In This Section
Cluster Port
Explains cluster port and how to change its value.
Port Range
Explains how to change the range of cluster port.
Server Port
Describes server port and ways to customize it.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cluster Port

< Previous page Next page >

Cluster Port

Cluster ports are the ports at which NCache clusters start. You can change the default value of these ports from NCache Manager. For installed caches (myReplicatedCache, myPartitionedCache), NCache looks for ports starting from 7800 onwards and allot the available ports to these caches in the available Port Range .
Port of a cluster can be changed in the following ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Change the value of Cluster Port if required.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
Port of a cluster can be changed using config.ncconf as follows:
<cluster-connection-settings cluster-port="8706" port-range="2"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Port Range | Server Port
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Port Range

< Previous page Next page >

Port Range

Sets the port range for each node in the cluster. If the current port is unavailable, then the server will automatically pick the next available port in the pool. Port Range of a cluster can be changed in the following two ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Set the Port Range as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
The value of port range can also be set using config.ncconf as follows;
<cluster-connection-settings cluster-port="8706" port-range="2"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Cluster Port | Server Port
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Server Port

< Previous page Next page >

Server Port

At the NCache Server Port, NCache Server starts and accepts different client connections. Default value of this port is "9800". You can change the default value through Alachisoft.NCache.Service.exe.config file as follows:
<add key="NCacheServer.Port" value="9800" />
This will change the value at Server side. This change must also be made in client.nconf to make client aware of this change, as follows:
<ncache-server port="9800" connection-retries="60" retry-interval="1"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Port Range | Cluster Port
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Operation Timeout

< Previous page Next page >

Operation Timeout

Operation Timeout is the maximum time in seconds during which a clustered operation must be completed, otherwise the operation will fail. Default Timeout value is 60 seconds and can not be less than that. To specify Timeout for a Clustered Cache operation, do one of the following two.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Change the Operation timeout (sec.).
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through Config.ncconf:
You can specify the operation timeout through Config.ncconf as follows.
<cluster topology="partition-replica" op-timeout="120sec" stats-repl-interval="60sec" use-heart-beat="False">
</cluster>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Statistic Replication Interval

< Previous page Next page >

Statistic Replication Interval

This option is available for Clustered Cache only. Statistics replication interval is the time interval in seconds after which a node sends its statistics to all other nodes in a cluster. Replication Interval for Statistics can be specified by one of the following ways.
Using NCache Manager:
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Set the Statistic replication interval (sec.) as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf:
You can specify the statistics replication interval through Config.ncconf as follows.
<cluster topology="partition-replica" op-timeout="120sec" stats-repl-interval="60sec" use-heart-beat="False">
</cluster>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Connection Retries

< Previous page Next page >

Connection Retries

Nodes participating in a clusterare connected with each other through TCP connections which may break up due to network failure. In that case, a client node tries to reestablish the connection. It goes through all the servers in the list once and if none are available, then sleeps for the Retry Interval seconds and then scans the list again. This is done Connection Retries times. In other words, Connection Retries specifies how many times the node should try to restore the connection. It can be configured in the following ways.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Set the Connection Retries as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
Connection retries can also be configured in config.ncconf file as follows.
<ncache-server port="9800" connection-retries="60" retry-interval="1"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Retry Interval

< Previous page Next page >

Retry Interval

Retry Interval specifues the time between two successive connection retries.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Change the Retry Interval (sec.) as required.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
Connection retries can also be configured in config.ncconf file as follows.
<ncache-server port="9800" connection-retries="60" retry-interval="1"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Query Indexes

< Previous page Next page >

Configuring Query Indexes

Indexes are used in query for efficiency.Indexes are based on the type of a class. The user may further specify the attributes of the class on which indexes are required. Query Indexes can be configured as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Query Indexes tab.
  • Click Add.
  • Select Query Indices wizard will open. Click Browse to browse for the required assembly. Select the assembly.
  • Assembles and all its classes will be listed in Selected Assemblies section.
  • Select the required classes by checking the check box and clicking Add Class button.
  • List of selected classes and its attributes will be listed in List of selected Classes section. Select the attributes you want to add indexes for and click OK. Select Query Indexes wizard will close and selected classes along with their attributes will appear in Selected classes and their attributes section.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addqueryindex.exe, provide the required information:
addqueryindex.exe demoLocalCache /a C:\temp\Data.dll /c NCache.Sample.Data.Product /L ProductID$ProductName$Category$Supplier$UnitsAvailable
addqueryindex.exe demoLocalCache /a C:\temp\Data.dll /c NCache.Sample.Data.Customer /L CustomerID$CompanyName
  • Hit ENTER key, it will add ProductID, ProductName, Category, Supplier and UnitsAvailable attributes from the class NCache.Sample.Data.Product and NCache.Sample.Data.Customer of Data.dll in query indexes for demoLocalCache.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Registering Classes for Compact Serialization

< Previous page Next page >

Registering Classes for Compact Serialization

Each custom class must be serialized before adding any of its objects into cache. NCache compact serialization is used to dynamically serialize classes on the fly.
These classes can be
  • Generic
  • Non-Generic
In This Section
Registering Non-Generic Classes
Explains how to register non-generic classes for compact serialization.
Registering Generic Classes
Explains how to register generic classes for compact serialization.
Registering Generic Classes using Generic Type Handler
Explains how to register generic classes for compact serialization using generic type handler.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Registering Non-Generic Classes

< Previous page Next page >

Registering Non-Generic Classes

You can use either of the two ways described below to register your generic classes for compact serialization.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Compact Serialization tab.
  • Click Add Types button. A new Select Compact Classes dialogue box will open up.
  • Click on Browse button. It will open a windows Open dialog. Using this dialog you can select .exe, .dll or .jar file.
  • Select your required file (.exe, .dll or .jar) and click on Open. It lists classes from the selected assembly in Loaded Class list box. Select desired classes which you want to register with NCache for compact serialization and click Add Class.
  • Compact Serialization works on attribute level. In the lower pane, attributes of all your selected classes get listed; from
here you can select attributes which you do not want to be compact serialized.
  • Click OK to add classes. It lists fully qualified names of all selected classes in Compact Serialization tab.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addcompacttype.exe, provide the required information:
addcompacttype.exe /id demoLocalCache /a C:\Data.dll /c NCache.Sample.Data.Compact.Engineer
addcompacttype.exe /id demoLocalCache /a C:\Data.dll /c NCache.Sample.Data.Compact.Manager /al hireDate
  • Hit ENTER key, it defines a compact type for demoLocalCache. You can define further types one by one repeating the step
for other types.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Generic Classes | Registering Generic Classes using Generic Type Handler
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Registering Generic Classes

< Previous page Next page >

Registering Generic Classes

NCache also supports generic classes to be compact serialized. Generic classes are configured in the same way as other
classes. In addition we also need to specify <T> types for each Generic class. Generic classes can be configured as folows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Compact Serialization tab.
  • Click on the Add Type button. Select Compact Classes dialog appears.
  • Click on the Show Default Generics button. It lists default generic types. Select the desired type and click Add Class.
  • It adds selected classes in the lower pane. Click OK to add classes for compact serialization.
  • All of the selected classes are now listed at Compact Serialization tab in NCache Manager.
  • Now you need to specify the classes which you expect to be assigned to the selected generic classes. When you select any of the added generic class, the Add<T> button becomes enabled. Click Add<T>.
  • Select Compact Cllasses dialog appears. Click Browse to select assembly. All classes will be loaded in Loaded Classes list box. Select your class and click Add Class.
  • Click OK. It adds generic <T> type under the select generic class.
  • This way you can specify as many <T> types for a generic class as needed.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Non-Generic Classes | Registering Generic Classes using Generic Type Handler
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Registering Generic Classes using Generic Type Handler

< Previous page Next page >

Registering Generic Classes using Generic Type Handler

NCache also gives you the facility to configure all required generic classes at once using Generic Type Handler. For this, first of all, you have to implement IGenericTypeProvider interface. Write the code for all the required combinations for all data types that can be used in your application. This can be done as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Compact Serialization tab.
  • Click the Generic Type handler button.
  • In the Select Compact Classes dialog, click Browse to select the assembly that contains your generic type provider
class, for which you have implemented the IGenericTypeProvider interface.
  • All of the classes that had the implementation of the IGenericTypeProvider interface will get listed in Class Name drop
down menu. Select the required generic type provider class from the drop down list.
  • Click OK. It loads all of the generic classes with their generic types.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Generic Classes | Registering Non-Generic Classes
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Registering Classes for Portable Data Sharing

< Previous page Next page >

Registering Classes for Portable Data Sharing

There are situations when applications form the same/different platforms are interested to share cached data among them. For this purpose, dynamic data sharing can be used. It shares the data between various versions of an object, either from the same platforms or different platforms at runtime. Classes for portable data sharing can be registered in following ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Data Sharing tab.
  • Click the Add Shared Types button.
  • Select Data Sharing Classes dialog will open. Specify the name of data sharing type.
  • Click Browse to browse for required assembly (.exe, .dll or .jar file).
  • Selected Assembly and all its classes will appear in Loaded Classes section. Select the required class and add it in List of selected Classes section using Add Class button.
  • Repeat step 5 and 6 to select jar file and Java class.
  • Click OK after adding classes of .NET and Java. The opened wizard will close and selected classes of both platforms will appear in Shared Types section under your given data type name.
  • Now map the attributes of both platforms classes. Click on the added data share type ‘Customer’, all of its attributes will be listed in Common Attributes section.
  • Click on a class listed under ‘Customer’ data type. Its attributes will be listed down in Selected Class Attributes section.
  • A drop down will appear in the Selected Class Attributes section in front of each attribute of common attributes list. If .NET class is selected, select the required Java attribute of the Java class to map it against .NET attribute. Data types of attributes to be mapped should be same or compatible. The compatible .NET and Java data types mapping tables are given below:
  • Map all the attributes using the drop down list.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Import/Export Data Share Configuration
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Import/Export Data Share Configuration

< Previous page Next page >

Import/Export Data Share Configuration

Data sharing configurations can be imported and exported using the following method.
Using NCache Manager
Export Data Share Configurations
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Data Sharing tab.
  • Click on the Export button and save the data sharing configuration in an xml file.
  • Provide a file name and click Save.
Import Data Share Configurations
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Data Sharing tab.
  • Click on the Import button to get the data sharing configuration from an XMLl file.
  • Browse the saved data share configuration file and click Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use adddatashare tool, provide the required information:
adddatashare demoLocalcache -T C:/temp/SharedTypes.xml
  • Hit ENTER key, it will configure shared types from the provided xml file.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Classes for Portable Data Sharing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Data Source Providers

< Previous page Next page >

Configuring Data Source Providers

While working with cache, client applications may need to perform operations on master data source. For this purpose, NCache supports transparent read/write operations to any type of back-end data source through read-through and write-through caching. Using this feature, client application can fetch or write data to master data source using the following providers.
  • Read Through
  • Write-Through
  • Write-Behind
In This Section
Read-Through Provider
Explains how to enable and configure read-through provider on a cacha.
Write-Through Provider
Explains how to enable and configure write-through provider on a cacha.
Write-Through Provider for Write-Behind Operations
Explains how to configure write-through provider for write-behind operations.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Read-Through Provider

< Previous page Next page >

Read-Through Provider

A requested value not present in the cache can be automatically obtained from the main data source by the cache and provided to the user in such a manner that it seems to the caller that it came from the cache. This is known as Read Through Cache. The gain from it is that the application can depend on the cache for both cached data as well as for transparent data loading instead of adding data loading logic at the point where it requires the data. Read-through caching can be configured using the following methods.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Baking Source tab.
  • Check Enable Read-Through on this cache check box to enable it. After enabling it, other options will get enabled as well.
  • Cllick Add to select assembly that has IReadThruProvider implementation.
  • A new dialog box Add New Provider will open. Enter Provider Name and click on ‘…’ button to browse for assembly implementing IReadThruProvider interface.
  • Browse for the required assembly and select Open. Name of selected assembly will be appeared in Assembly Name and its classes implementing the interface will be listed down in Class Name list box.
  • Select the required read-through provider. You can also provide the values to your read-through provider class, if required. Just write the parameter name in Parameter field and its value against it under the Value field. Click OK.
  • Selected provider class will be listed in Read-Through provider list at Backing Source tab.
  • Now deploy the read-through provider assembly along with its dependency assemblies, if any. Click on the Deploy Provider button at the left bottom of the Backing Source tab. Browse for required assemblies. Select all the required assemblies and click Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addbackingsource.exe tool, provide the required information as:
addbackingsource.exe demoLocalCache /path C:\Users\Administrator\Downloads\Providers\Providers.dll/cNCache.Sample.Providers.Readers.Reader1 /pnreader1/R
  • Hit ENTER key, it will configure Reader1 read-through provider on demoLocalcache.
  • Now depoly all of the required assemblies (assembly in which you have implemented the read-through provider and all of its dependency assemblies) using deployprovider.exe. Use following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Write-Through Provider | Write-Through Provider for Write-Behind Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Write-Through Provider

< Previous page Next page >

Write-Through Provider

NCache supports write-through caching. The idea behind write-through cache is that when an application updates a piece of data in the cache, the operation is not completed until the changed data has been successfully stored in the underlying data source. Though this enhances data integrity but affects the performance negatively in terms of the latency involved in writing to the data store. This latency can be overcomed by write-behind caching.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Baking Source tab.
  • Check Enable Write-Through on this cache check box to enable it. After enabling it, other options will get enabled as well.
  • Cllick Add to select assembly that has IWriteThruProvider implementation.
  • A new dialog box Add New Provider will open. Enter Provider Name and click on ‘…’ button to browse for assembly implementing IWriteThruProvider interface.
  • Browse for the required assembly and select Open. Name of selected assembly will be appeared in Assembly Name and its classes implementing interface will be listed down in Class Name list box.
  • Select the required read-through provider. You can also provide the values to your read-through provider class, if required. Just write the parameter name in Parameter field and its value against it under the Value field. Click OK.
  • Selected provider class will be listed in Write-Through provider list at Backing Source tab.
  • Now deploy the write-through provider assembly along with its dependency assemblies, if any. Click on the Deploy Provider button at the left bottom of the Backing Source tab. Browse for required assemblies. Select all the required assemblies and click Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addbackingsource.exe tool, provide the required information as:
addbackingsource.exe demoLocalCache /path C:\Downloads\Providers.dll /cNCache.Sample.Providers.Writers.Writer1 /pnwriter1/W
  • Hit ENTER key, it will configure Writer1 write-through provider on demoLocalcache.
  • Now depoly all of the required assemblies (assembly in which you have implemented the write-through provider and all of its dependency assemblies) using deployprovider.exe. Use following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Read-Through Provider | Write-Through Provider for Write-Behind Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Write-Through Provider for Write-Behind Operations

< Previous page Next page >

Write-Through Provider for Write-Behind Operations

If write-behind option is enabled, then all of the data source operations are queued up and performed in the background.
There are multiple settings which can be used to optimize the write-through provider to fulfill the user requirements. These settings can be configured as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Baking Source tab.
  • Configure Write-Through provider for the cache.
  • Batching, Throttling and Re-Queue Operations settings are given below the Write-Through list box.
  • Change the settings as per your application requirements.
  • Check the Enable Batching checkbox to perform all write-behind operations on data source in bulk/batches.You can also configure the Batch-interval(s) and Operation-delay (ms) for the batching mode.
  • Change the value for Operations per second, to control how many write-behind operations will be performed on data source in a second.
  • You can also configure the Failed operations queue limit. This queue is used to re-queue the failed oprations and will be retired on data source.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addbackingsource.exe tool, provide the required information as:
addbackingsource.exe demoLocalCache /path C:\Users\Administrator\Downloads\Providers.dll /cNCache.Sample.Providers.Writers.Writer1 /pnwriter1/W /b true /ops 500
  • Hit ENTER key, it will configure Writer1 write-through provider on demoLocalcache with write-behind enabled and with throttling limit of 500 operations per second.
Deploy required assemblies using deployprovider.exe. Use the following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Read-Through Provider | Write-Through Provider
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Cache Start-Up Loader

< Previous page Next page >

Configuring Cache Start-Up Loader

NCache supports cache start-up loader through which a user can preload the cache with given data at the time of cache start-up. This feature can be configured in the following ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Cache Loader tab.
  • Check Enable Cache Startup Loader check box to enable it. After enabling it, other options will get enabled as well.
  • Click on the ‘…’ button to select the assembly implementing ICacheLoader interface.
  • Browse for the required assembly and click Open after selecting the required assembly.
  • Name of selected assembly will be appeared in Assembly Name and its classes implementing interface will be listed down in Class Name list box at Cache Loader tab. Select the required class
  • You can also add the parameters for your cache loader implementation, if required. Click New; provide the Parameter Name and Parameter Value in the New Parameter dialog box.
  • Deploy the required assemblies using Deploy Cache Loader button at the lower left corner of Cache Loader tab. Browse for the required assemblies and select Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addstartuploader.exe tool, provide the required information as:
addstartuploader demoLocalCache /a C:\Downloads\Providers.dll/cNCache.Sample.Providers.Loaders.Loader1
  • Hit ENTER key, it will add Loader1 as startup loader on demoLocalCache.
  • Now depoly all of the required assemblies (assembly in which you have implemented the write-through provider and all of its dependency assemblies) using deployprovider.exe. Use following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Cache Level Events

< Previous page Next page >

Configuring Cache Level Events

NCache event notifications let you design applications that react to various cache events. These notifications are disabled by default to save precious CPU and network resources. Events are fired upon addition, update and removal of an object or when cache is cleared. These notifications are off by default but can be turned on, for Clustered or Local Caches, as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Options tab.
  • Check Item add notification, Item remove notification and Item update notification check boxes.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Eviction Policy

< Previous page Next page >

Configuring Eviction Policy

There is a storage limit, maximum size is the capacity to which a cache can add objects in it. If cache reaches its maximum size and eviction is turned on, the specified ratio of items will be evicted to make space for new objects. On the other hand, if cache reaches its maximum storage limit and eviction is turned off, items are neither evicted nor added to the cache any further.
An eviction scheme is used to select the objects that need to be removed from cache. A particular eviction policy can be selected at the creation time but once it is set it cannot be altered in the running cache. User can change eviction policy after creating a cache only if it is not running. Three types of Eviction Policies are provided by NCache.
  • Least Frequently Used
  • Least Recently Used
  • Priority Based Eviction
Least Frequently Used
In this scheme a counter that counts the access made to an object is used. At the time of eviction objects with lowest counter number are evicted first. Here too a random selection is made between two objects with same counter.
Least Recently Used
This eviction scheme associates a timestamp with all objects. This timestamp is updated each time the object is accessed. When evicting, objects with the oldest timestamp are picked first. In case of two objects with the same time stamp, a random selection is made.
Priority Based Eviction
This is the default eviction policy and has the same mechanism as LFU with the addition of a relative cost that is associated with an object at the time of its addition to cache. Objects with lower cost are removed before objects with higher cost. Client application can choose from a list of priorities that is predefined (Low, Below Normal, Normal, Above Normal, High and Not Removable). In case a priority is not chosen, it is set by default as Normal.
These eviction policies for a cache can be specified in one of the following two ways.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Policies tab.
  • Uncheck the Turn off Eviction check box.
  • Select the Eviction Policy from drop down list.
  • If you have selected the Priority based eviction, then Default Priority can also be changed in the drop down list.
Change the Eviction Percentage if required. Eviction percentage is the percentage of items to be removed on each eviction.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf:
You can select the Eviction Policy for a cache through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<eviction-policy enabled="True" default-priority="normal" policy="priority" eviction-ratio="0.05"/>
</cache-config>
Eviction-ratio=0.05 is equal to 5% of total cache size. Eviction is not recommended in case of sessions.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Compression

< Previous page Next page >

Configuring Compression

To minimize data traffic between cluster and client nodes, NCache provides GZip Compression for objects of size greater than the specified threshold value. Objects greater than the specified threshold size will be compressed /decompressed by NCache. Average compression gains are higher for objects of greater size. By default, data compression is off. You can enable/disable data compression by one of following methods.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Options tab.
  • Check Enable Compression check box.
  • Change the Threshhold Size as per your requirment.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf:
You can enable/disable data compression option for a cache through config.ncconf as follows.
<compression enabled="true" threshold="500kb"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Email Notifications

< Previous page Next page >

Configuring Email Notifications

You can configure email notifications in NCache. NCache will send you an email automatically when a selected event occurs in cache for which you have enabled notification. You can configure email notification for a cache in the following way:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Alerts tab.
  • Check the Enable Email Notifications checkbox to enable this feature.
  • Enter sender email in the Sender Email text box.
  • Enter SMPT server in the SMTP Server text box.
  • Enter port in the Port text box.
  • Check SSL Required check box, if your email server requires SSL authentication.
  • Check the Authentication Required check box if required and enter login and password in Login text box and Password text box respectively.
  • Specify recipients’ email addresses in To text box.
  • Check the the cache events for which you want to receive notications from NCache.
  • Apply configuration by right clicking on the cache name in Cache Explorer and selecting Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Binding Cluster and Client/Server with a Dedicated IP for Performance

< Previous page Next page >

Binding Cluster and Client/Server with a Dedicated IP for Performance

NCache provides you with the opportunity to bind cluster, client/server or both (cluster and client/server) with dedicated IP addresses. Binding cluster and client with different dedicated IP addresses is only useful if server machine have multiple addresses.
In This Section
Binding Cluster with a Dedicated IP
Explains how to bind cache cluster with a dedicated IP address.
Binding Client Server with a Dedicated IP
Explains how to bind Client/Server or both with a dedicated IP address.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Binding Cluster with a Dedicated IP

< Previous page Next page >

Binding Cluster with a Dedicated IP

A cache cluster can be bound with a dedicated IP address in the following way:
Using NCache Manager
  • Right click on a server IP address under Server Nodes in Cache Explorer and click on Select Network Interface Card option.
  • Available Network Interface Cards dialog will open. It will contain all network cards available on that node with drop down list. By default, IP is used for both client-server and inter cluster communications.
  • Select the Cluster option from the drop down list in front of the IP address with which you want to bind the cluster.
  • Click Apply.
  • NCache will ask for confirmation to apply configuration and restart service. Click Yes.
This restarts the NCache service to use the selected IP addresses for the specified communication (inter-cluster).
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Binding Client/Server with a Dedicated IP
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Binding Client/Server with a Dedicated IP

< Previous page Next page >

Binding Client/Server with a Dedicated IP

Client/Server can also be bound with a dedicated IP address. This can be done as folloes:
Using NCache Manager
  • Right click on a server IP address under Server Nodes in Cache Explorer and click on Select Network Interface Card option.
  • Available Network Interface Cards dialog will open. It will contain all network cards available on that node with drop down list. By default IP is used for both client-server and inter cluster communications.
  • Select Client/Server option from drop down in front of the IP with which you want to bind the client and server.
  • Click Apply.
  • NCache will ask for confirmation to apply configuration and restart service. Click Yes.
This restarts the NCache service to use the selected IP addresses for the client/server communication.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Binding Cluster with a Dedicated IP
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Heart Beat

< Previous page Next page >

Configuring Heart Beat

Communication between Cluster nodes is critical for smooth cluster operations. Therefore, NCache provides an option called Heart Beat for the clusters to detect connection breakage with any node of the cluster. Connection breakage may occur due to an unplugged network cable or disabling of a network connection. When this option is enabled, a node of a cluster sends some dummy packets to other nodes and waits for acknowledgment. Therefore, if live nodes do not receive acknowledgments from any idle node after specific duration, they will consider it dead and will update their views by excluding it from the cluster. There will be no overhead of heart beat messages when all nodes are active and sending messages to each other. You can enable/disable heart beat through following methods.
Using NCache Manager
You can enable or disable heartbeat option from Cluster Settings Tab of Cluster view window.
Through config.ncconf
You can enable heart beat option through configuration file, config.ncconf . Heart beat interval can also be specified inside service's config file as follows
<add key="NCacheServer.HeartbeatInterval" value="30"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Auto Start Cache at Boot

< Previous page Next page >

Auto Start Cache at Boot

You can automatically start cache(s) at system startup. By default, Auto-start cache option is off. You can enable/disable this option by one of the following ways.
Using NCache Manager
  • In NCache Manager see under Main tab and select the option Auto start this cache on service startup. Select this option for each cache you want to automatically start at NCache service startup. This is the recommended way for enabling auto-startup option.
  • After configuring you have to Apply Configurations as well. See how to apply .
Through config.ncconf
You can enable\disable auto start cache option from config.ncconf file.
By default auto-start tag is "False". In order to enable this option, set this tag to "True" for each cache you want to automatically start on service startup.
auto-start="True"
Moreover, you can add some delay time in auto-startup. To add delay time you have to add following tag in NCache service config file. Value is specified in minutes.
<add key="NCacheSrver.AutoStartDelay" value="5"/>
Whenever NCache service will be restarted, all caches which are set to auto start will automatically start after specified delay time interval.
Restart NCache Service after adding AutoStartDelay tag.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Nagling

< Previous page Next page >

Nagling

Nagling refers to concatenating a number of small buffer messages. It increases the efficiency of a network application system by decreasing the number of packets that must be sent. Nagling can be thought of as bulk operation on the network. By default Nagling is enabled. You can turn it off in your service's config file as follows:
<add key="NCacheServer.EnableNagling" value="false"/>
Nagling combines all the available messages present in a queue whose combine size is less than Nagling threshold. Size is specified in terms of Kilo bytes. By default it is 500Kb. You can specify it in service's config file as follows:
<add key="NCacheServer.NaglingSize" value="500"/>
If you are using cache as InProc, you need to specify the above lines of code in config.exe of your application.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Dual Socket

< Previous page Next page >

Dual Socket

Each node participating in cluster can establish two connections with every other node. Purpose of increasing the number of connections is to increase throughput by maximizing the network usage. As network I/O is a slow process, therefore, opening multiple connections improve the performance. By default, dual connections are disabled. You can enable or disable this feature by specifying following options in <appSettings> of NCache service's config file . If you are using cache as InProc, you need to specify this in config.exe of your application.
<appSettings>
<add key="NCache.EnableDualSocket" value="true"/>
</appSettings>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Error Logging

< Previous page Next page >

Error Logging

When running a cache, error messages can be helpful. These messages can be saved to a log file if required. NCache Manager can be used to enable logging. You will find this option on Options Tab of Cluster/Local Cache view window. Each time user enables error logging a new trace file is created in the "log-files" folder under NCache installation directory with current time stamp.
Enabling error logging generates fatal and normal logs, while enabling detailed error logging generates log file containing info, debug and warning logs. By default, logging is disabled. Enabling "Detail error logging" generates logs very frequently, which may affect the performance of cache/cluster. In case of an error, it is reported in the application's event log in system.
Enable logs for Java Client
Logging in the NCache Java client can be controlled by setting enableNCLogs property before initializing the cache. This is how you can enable error logging for Java Client.
[Java]
System.setProperty("enableNCLogs", Level.INFO.toString());
Log file is generated in the application home directory. The above property will enable logging of all INFO messages. It will also enable logging of SEVERE and WARNING messages.
The Level class (Java.util.logging) defines a set of standard logging levels that can be used to control logging output. The logging Level objects are ordered and are specified by ordered integers. Enabling logging at a given level also enables logging at all higher levels. Clients should use the predefined Level constants such as Level.SEVERE. The levels in descending order are as follows:
  • SEVERE (highest value)
  • WARNING
  • INFO
  • CONFIG
  • FINE
  • FINER
  • FINEST (lowest value)
In addition, there is a level OFF that can be used to turn off logging, and a level ALL that can be used to enable logging of all messages.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuration Files

< Previous page Next page >

Configuration Files

This section discusses various configuration files provided by NCache for both client end and server end.
In This Section
Overview
Explains various configuration files and their use.
Client Side Configurations
Describes client side configuration files required for the connection establishment with cache server.
Server Side Configurations
Describes server side configuration files required for cache, security and bridge configurations.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

This section of the documentation discusses configuration files that NCache provides for client end and server end. This section helps you to understand how to configure these configuration files. All config files are installed with NCache and is located at " %Install Directory%/NCache/config". Five different config files are installed with NCache which are used to configure the client and server end, i.e.
Client End:
  • Client Configuration File (Client.ncconf)
  • EFCaching Configuration File (Efcaching.ncconf)
Server End:
  • Cache Configuration File (Config.ncconf)
  • Bridge Configuration File (Bridge.ncconf)
  • Security Configuration File (Security.ncconf)
Client configuration file is used by NCache client API to get initial information for establishing connection with server. Modules that need to read the configurations first try to find client.ncconf in application folder. If it doesn't fins client.ncconf in application folder, it then reads the configuration from installation folder. EFCaching configuration file contains information regarding Entity Framework provider which helps in integrating NCache with Entity Framework application.
Cache configuration file contains information regarding all registered caches/clusters. It is used to configure all levels of caches. Modules that need to read the configurations first try to find config.ncconf in application folder. If it doesn't find config.ncconf in application folder, it then reads the configuration from installation folder.
Bridge configuration file contains information regarding all registered bridges. The configuration of all created bridges are store in a single bridge.ncconf file. User can change the configuration of a bridge either from settings of the bridge in NCache Manger or from bridge.ncconf file.
Security configuration file keeps security information that is used by a server node for calling clients. Alachisoft.NCache.NCSecurity.dll at server node is required to provide security services to all clients. Whatever information is required by this assembly, for managing security related issues, is present in security.ncconf file.
See Also
Client Config | Efcaching Config | Cache Config | Security Config | Bridge Config
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Side

< Previous page Next page >

Client Side

This section is intended to help you in configuring .NET and Java Clients. It also gives you an overview of client configuration file (client.ncconf) required for the connection establishment with cache server and EFCaching configuration file for enabling EFCaching with NCache.
In This Section
Client Config
Describes configuring NCache light-weight Clients through client.ncconf file.
EF Caching Config
Describes configuring EFCaching with NCache through efcaching.ncconf file.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Config

< Previous page Next page >

Client Config

Client configuration file is used by NCache client API to get initial information for establishing connection with server. It is located at "%Install Directory%/NCache/config". Modules that need to read the configurations, first try to find client.ncconf in application folder. If client.ncconf is not found in application folder, it then reads the configuration from installation folder.
Client configuration file is used by client to connect to out-proc caches. Light weight client also uses this configuration file to connect to the remote caches. This file is automatically generated each time a new cache/cluster is created or cache/cluster configuration settings are applied. Additionally security information can be provided for each cache in this file.
Client configuration file is explained below:
<configuration>
<ncache-server port="9800" client-request-timeout="90" connection-retries="5" retry-connection-delay="0" retry-interval="1" connection-timeout="5" />
<cache id ="myreplicatedcache" client-cache-id="" client-cache-syncmode="optimistic" load-balance="true">
<server name="server-1"/>
</cache>
<cache id ="mypartitionedcache" client-cache-id="" client-cache-syncmode="optimistic"load-balance="true">
<server name="server-2"/>
</cache>
</configuration>
Client-request-Timeout:
Client-request-timeout is the period for which client API waits for a response for a command from the server. After this period is elapsed an "OperationFailedException" is thrown. By default it is 90 seconds and minimum value could be 60 seconds. Time span specified less than minimum value will automatically be reset to minimum value i.e. 60 seconds.
Connection-retries:
connection-retries are the number of retries the client makes on the whole list of servers mentioned in the client.ncconf at the time of connection establishment. It is the same for connection break scenario.
Retry-interval
If connection with cache server is dropped then client tries to reconnect with the server and retry connection delay flag introduces the delay between each retry. Flag is specified in seconds.
Connection-timeout:
connection-timeout is the period threads wait before throwing OperationFailedException during connection-break, while one thread tries to establish connection with cache server. If the connection is successfully established then, all threads will complete their respective operations. Otherwise, they will throw OperationFailedException.
Retry-connection-delay:
retry-connection-delay is the time when client API waits before going through another iteration of connection-retries. Delay is specified in seconds.
See Also
Client Nodes | EFCaching Config | Server Side Configuration Files
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: EFCaching Config

< Previous page Next page >

EFCaching Config
This feature is not available in NCache Express and Professional edition.
EFCaching configuration file contains information regarding Entity Framework provider. It is installed with NCache and is located at "%Install Directory%/NCache/config". efcaching.ncconf is used for enabling NCache in Entity Framework applications. The configurations are stored in an efcaching.ncconf file.
EFCaching configuration file is explained below:
  • Provider Configuration contains cache and caching policy related information. Below are the changes required in efcaching.ncconf.
    <configuration>
    <app-config app-id = "PersonNameApp" mode = "analysis|caching">
  • App-id: Is an identifier for an application. The configuration can contain multiple configuration settings for different applications. App-id for efcaching.ncconf should be same as in application otherwise it will prompt an error.
  • Mode: Can either be "analysis" or "caching". (Hot Applicable)
  • Default = 'caching'
  • "Analysis" mode is used for monitoring the number of times each query executes and then it generates a report. Report contains the Query text and the call count for each query. This report can be used in Custom policy. No caching is done at this mode.
    <analysis-policy log-path = "" analysis-time = "60" cache-enable-threshold = "5" default-expiration-type = "absolute|sliding" default-expiration-time = "180" dbsyncdependency = "true"/>
  • Log-path: Path at which analysis log files will be generated.
Default = < install-dir > /log-files/efcaching-analysis-logs/
  • Analysis-time: Time for which the analysis will run.
  • Default = 60 min
  • Cache-enable-threshold: Caching will automatically be enabled for queries whose call-count exceeds this threshold.
  • Default = 5
  • Default-expiration-type: Default expiration type for analyzed queries.
  • Default = absolute
  • Default-expiration-time: Default expiration time for analyzed queries.
  • Default = 180 sec (3 min)
  • dbsyncdependency: Determine whether to enable database-dependency or not.
  • Default = "true"
  • For "Caching" mode, wrapping provider will cache the results of all the specified queries. Caching mode works on either cacheall policy or custom policy. Both policies have their own specifications. Whenever update is detected (either UPDATE, INSERT or DELETE) in a respective database, the provider invalidates affected cache entries by evicting all cached queries which were dependent on any of the updated tables.
<cache-policy default-policy = "cacheall|custom" database = "none|oracle10i2|sqlserver" cache-id = "mycache" enabled = "true">
  • Default-policy: The default policy for caching. (Hot Applicable)
  • Default = 'cacheall'
  • Database: Database information is collected to create database sync dependency. (Hot Applicable)
  • Default = 'none'
  • Cache-id:
  • Default = 'mycache'
  • Enabled: Determine whether the policy is in effect or not. (Hot Applicable)
  • Default = 'true'
  • For cacheall policy, it caches all the queries and their results.
    <cacheall-policy expiration-type = "absolute|sliding" expiration-time = "1800" dbsyncdependency = "true"/>
  • Expiration-type: Type of expiration, it can be 'sliding' or 'absolute'.
  • Default = 'absolute'.
  • Expiration-time: Default = 180 sec (3 min)
dbsyncdependency: Determine whether to enable the database-dependency or not.
  • Default = 'true'
  • For custom policy, it includes user-configurable list of queries that should be cached with their results. When custom policy is selected, only those queries results will be cached for which the caching is enabled. You can also specify custom caching policy for all queries.
    <custom-policy>
    <query query-text = "" ["SELECT FROM Products"] | stored-procedure-name = "" ] caching = "true" expiration-type = "absolute"| sliding = "" expiration-time = "180" dbsyncdependency = "true"/>
    </custom-policy>
    </cache-policy>
    </app-config>
    </configuration>
  • Query-text: Text of the query whose result is to be cached OR name of a stored procedure whose output is to be cached.
  • Caching: Determines whether caching is enabled for this query or not.
  • Default = 'true'
  • Expiration-type: Type of expiration, it can be 'absolute' or 'sliding'.
  • Default = 'absolute'.
  • Expiration-time: Default = 180 sec (3 min)
  • dbsyncdependency: Determine whether to enable database-dependency for analyzed queries.
  • Default = " true"
  • In case of stored procedures, query text will be the name of a stored procedure, and there will be no default policy or database sync dependency. User can cache stored procedures result with expiration only, no database dependency is needed here.
See Also
EF Caching Integration | Client Config
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Server Side

< Previous page Next page >

Server Side

This section will help you in configuring .NET and Java Servers. Three types of configuration files are present at server side, which are:
In This Section
Cache Config
Explains config.ncconf file that contains information regarding all registered caches/clusters.
Security Config
Helps enabling NCache security as well as to manage Node and API level security through security.ncconf file.
Bridge Config
Explains bridge.ncconf file that contains information regarding bridges.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Config

< Previous page Next page >

Cache Config

Cache configuration file contains information regarding all registered caches/clusters. It is installed with NCache and is located at "%Install Directory%/NCache/config". Modules that need to read the configurations first try to find config.ncconf in application folder i.e. along side web.config. If config.ncconf is not found in application folder, it then reads the configuration from installation folder.
config.ncconf file is explained below:
<!--
Configuration file (config.ncconf) contains the details of all the registered caches. All caches configurations are enclosed in <configuration></configuration> tag. Whereas each cache detail is enclosed in <cache-config></cache-config>.
-->
<cache-config name="cachepor" inproc="False" config-id="0" last-modified="" type="local-cache" auto-start ="True|False">
Name: Is the cache identifier. Cache will be known by whatever name you will specify here. This is the same name as you specify while initializing cache.
Inproc: Determine whether the cache will run as in-proc (in your application process) or out-proc (in NCache Service process). If set to "False" cache will run as out-proc or if set to "True" then cache will run as in-proc.
Config-id: Is used to determine whether the configuration is modified or not.
Last-modifed: Contains information related to last modification in cache configuration.
Type: Specifies whether the cache is clustered or local cache. This attribute can any of the following:
  • "clustered-cache" means the cache is any of the clustered cache type. i.e; Partition of Replica, Replicated, Partitioned and Mirror.
  • "local-cache" means the cache is a stand-alone cache.
  • "client-cache" means the cache a Local Cache connected to a Clustered Cache.
Auto-Start: This xml tag specifies the auto start status of cache.
<log enabled="True" trace-errors="True" trace-notices="False" trace-warnings="False" trace-debug="False"/>
NCache maintains a log file to write traces for information and debugging purpose. NCache is providing different type of traces as shown in the above xml tag. Using these tags user can enable\disable the various traces. By default only “Error” trace is enabled, rest of the traces are disabled. Error trace does not affect the cache performance but for other traces we recommend not to enable them in a production environment as they affect the performance of NCache. Here log files for each cache will be created at "%Install Directory%/NCache/log-files" location which contains information related to the enabled traces.
<perf-counters enabled="True"/>
Using this xml tag you can enable/disable the publishing of data as perfmon counters:
Enabled: If this attribute is set to "True" NCache will updated the published perfmon counters. If set to "False" then Ncache will not update any of the published perfmon counter.
<replication-strategy synchronous="False"/>
In case of Partition of Replica the you will find this tag in cache configuration. Replication strategy defines how data is replicated to backup node.
Synchronous: This attribute can be set to True/False. If set to "False" then data operation will be replicated asynchronously on the backup node. If set to "True" then data operation will be replicated synchronously on the backup node.
<compression enabled="False" threshold="500kb"/>
This xml tag specifies whether the items greater then specified threshold should be compressed/decompressed at client side.
Enabled: To enable compression set this attribute to "True" otherwise set it to "False"
Threshold: Item greater than the value specified in threshold attribute will only be compressed/decompressed at client side if compression is enabled.
As per above mentioned compression tag example only item greater than 100kb of size will be compressed/decompressed at client side.
<notifications item-remove="False" item-add="False" item-update="False" cache-clear="False"/>
Notification xml tag specifies the registered event with Cache.
Item-add: This attribute can be set to "True" or "False". If set to "True" will notify when an item is added to the cache and similarly if set to "False" no notification will be fired if item is added in cache.
Item-remove: This attribute can be set to "True" or "False". If set to "True" will notify when an item is removed from the cache and similarly if set to "False" no notification will be fired if item is removed in cache.
Item-update: This attribute can be set to "True" or "False". If set to "True" will notify when an item is updated in the cache and similarly if set to "False" no notification will be fired if item is updated in cache.
Item-clear: This attribute can be set to "True" or "False". If set to "True" will notify when cache is cleared and similarly if set to "False" no notification will be fired if the cache is cleared.
<cleanup interval="15sec"/>
Cleanup xml tag specify the periodic interval after which item for expiration will be checked:
Interval: attribute specify the periodic clean up interval. If set to "15sec" this means the expiration check will be performed after every 15sec.
<storage type="heap" cache-size="250mb"/>
Storage xml tag specifies the storage related details for cache:
Type: this attribute can only be set to "heap" as currently ncache only supports heap based storage.
Cache-size: this attribute specifies the upper limit of cache size in MB.
<eviction-policy enabled="True" default-priority="normal" policy="priority" eviction-ratio="5%"/>
This xml tag specifies whether to perform the eviction or not. If eviction is enabled then cache will remove the existing item to accommodate new ones. Exiting items will be removed based on eviction strategy.
Enabled: To enable eviction set this attribute to "True" otherwise set it to "False"
Policy: attribute the eviction policy to be used. Eviction policy can be one of the following:
  • Lru (Least recently used)
  • Lfu (Least frequently used)
  • Priority based
Default-priority: specifies default priority that is associated with an item if no priority is specified for that item. This attribute can be set to following:
  • High
  • Above-normal
  • Normal
  • Below-normal
  • Low
This is only applicable in case of priority based eviction.
Eviction-ratio: specifies how much percentage of data should be evicted when eviction is performed.
<cluster topology="partition-replica" op-timeout="60sec" stats-repl-interval="60sec" use-heart-beat="False">
This xml tag is used for specifying the in-cluster communication details, it also contains a sub tag, channel, which further defines the communication details of the cluster:
Please Note, this tag will not be present in Local Cache.
Topology: Specifies which topology does the cluster follow, it can be either one of the following as provided by NCache
  • Partition Replica Topology
  • Replicated Topology
  • Partitioned Topology
  • Mirror Topology
Op-timeout: (Operation Time Out) Determines the timeout of a connection among the servers if a server in the cluster fails to respond
Stats-repl-interval: (Statistics Replication Interval) the interval provided to the cluster at which to synchronize their information among its servers
Use-heart-beat: Heart Beat is used to monitor the connectivity between nodes
Active-mirror-node: in Mirror topology, only two server nodes are allowed, of which one is active i.e. the one which handles all the request made by the client, here the ip of the active node is provided
<channel tcp-port="8011" port-range="2" connection-retries="0" connection-retry-interval="0secs" initial-hosts="sanfransisco[8011],sanramon[8011]" num-initial-hosts="2"/>
Channel xml tag specifies the details of port connectivity and and other communication options among the cluster servers:
Tcp-port: connection is channeled through a TCP port, this value defines the port which it occupies
Port-range: when initializing, if the port provided is taken by some other application then it will try to establish its connection on port incremented by 1, for this the range is provided i.e. to what range should it search for an available TCP port
Connection-retries: if connection among the node(s) is failed, then this defines how many retries should be done to consider it a permanent faliure
Connection-retry-interval: the interval between connection retries is defined in this value
Initial-hosts: Specifies the server IPs making up the cluster and with their starting port number
Num-initial-hosts: (Number of Initial Hosts) specifies the number of Server Nodes
<alerts>
<email-notification email-notification-enabled="False" sender="" smtp-server="" smtp-port="0" ssl="False" authentication="False" sender-login="" sender-password=""/>
<alerts-types cache-stop="False" cache-start="False" node-left="False" node-joined="False" state-transfer-started="False" state-transfer-stop="False" state-transfer-error="False" cache-size="False"/>
</alerts>
If Event notifications through email is required then information for its setup is configured here:
Email-notification: contains all the information related to the email address
Email-notification-enabled: enables notification through email
Sender : specify the email account from whom the email notifications are sent
Smtp -server: specify the gateway to send email notifications
Smtp -port: The port number used to forward emails
SSL : (Secure Socket Layer) To enable SSL security
Authentication : If any authentication is required, this is to be True
Sender-login : if Authentication is required, specify the login name
Sender-password : Authentication password is entered here
Alert-Types: Specifies at which event an automated email is to be generated
Cache-stop : if the cache is stopped at any moment
Cache-start : at start of cache, email notification is generated
Node-left : when a server node leaves the cluster or if a server node is inaccessible for any reason, email notification will be sent if this is enabled
Node-joined : At joining of any server node
State-Transfer - started : To notify whenever a state transfer is occurred which happens when Load balancing is performed
Cache-size : whenever cache size is changed (Hot Apply-able)
<sql-dependency use-default="False"/>
This xml tag specifies the queuing and service SQL notification architecture.
Use-default: The attribute can be set to True/False. If the attribute is set to "True" then default SQL Dependency service and queue will be created at run time. If the attribute is set to "False" then the custom define SQL Dependency service and queue will be created and used by NCache.
See Also
Configuring Security | Configuring Bridge | Client Side Configuration Files | Configure Basic Cache Settings
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Bridge

< Previous page Next page >

Configuring Bridge
This feature is not available in NCache Express and Professional edition.
Bridge configuration file contains information regarding all registered bridges. It is installed with NCache and is located at "%Install Directory%/NCache/config". bridge.ncconf is used whenever you add an existing bridge in NCache Manager. All bridge related configurations are stored in a single bridge.ncconf file. User can change the configuration of a bridge either from NCache Manger or from bridge.ncconf file.
Bridge.ncconf file is explained below:
<bridge-config id="b1799_AP" bridge-nodes="20.200.20.35,20.200.20.32" num-bridge-nodes="2" bridge-active="20.200.20.35" bridge-port="10029" opt-timeout="60" src-cache="" topology="active-passive" replicator-virtual-queue-size="10MB">
Bridge-config Id: Is the bridge identifier. Bridge cache will be known by whatever name you will specify here. This is the same name as you specify while initializing bridge.
Bridge-nodes: IP's of Server nodes involved in making up of this bridge.
Num-bridge-nodes: Number of servers involved in making up of the bridge node.
Bridge-active: This represents the active node in the bridge.
Bridge-port: Port number on which the bridge is hosted.
Opt-timeout: (Operation Timeout) Timeout time after which the bridge will consider itself disconnected from the connected cache(s).
Topology: Specifies which topology does the bridge follow, it can be either one of the following as provided by NCache:
  • Active-Active Topology
  • Active-Passive Topology
  • Hub-Spoke Topology
  • Star Topology
Replicator-virtual-queue-size: It is the size of a virtual queue for the replicator that replicates data from bridge to target cache.
<log enabled="True" trace-errors="True" trace-notices="False" trace-warnings="False" trace-debug="False"/>
NCache maintains a log file to write traces for information and debugging purpose. NCache is providing different type of traces as shown in the above xml tag. Using these tags user can enable\disable the various traces. By default only “Error” trace is enabled, rest of the traces are disabled. Error trace does not affect the cache performance but for other traces we recommend not to enable them in a production environment as they affect the performance of NCache. Here log files for each cache will be created at "%Install Directory%/NCache/log-files" location which contains information related to the enabled traces.
<queue optimized="False" size="500"/>
Size: Specifies the upper limit of queue size in MB. The amount of items in queue is limited by the maximum queue size and amount of free memory.
<perf-counter enabled="True"/>
Perf-counter: It is used to enable Performance counters.
<cache cache-id="replicated cache" status="active|passive" servers-list="20.200.20.35, 20.200.20.20" bulk-operation-size="500" enable-compression="False" connection-retry-interval="3" clear-target-cache="True" heart-beat-enabled="True" replicator-virtual-queue-size="10MB"/>
</bridge-config>
Cache-Id: Is the cache identifier.
Status: Is the status of the cache connected to the bridge. It can either be an active or passive depending on the selected topology.
Servers-List: Server nodes comprising up of the cache clusters.
Bulk-operation-size: Specify an upper limit on the size of the bundled operation that is to be replicated on target cache.
Enable-compression: To enable compression while sending operations on its Target Cache.
Connect-retry-interval: Specifies interval between the two consecutive retries to connect with target cache, if not already connected.
Clear-target-cache: If "true" it will clear the target cache on bridge service startup.
Replicator-virtual-queue-size: It is the size of a virtual queue for the replicator that replicates data from bridge to target cache.
See Also
Cache Config | Configuring Security | Client Side Configuration Files | Configure Basic Cache Settings | Configure Bridge Settings Using NCache Manager
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Security

< Previous page Next page >

Configuring Security
This feature is not available in NCache Express and Professional edition.
Every Server node keeps security information that it has to provide to calling clients. Alachisoft.NCache.NCSecurity.dll at server node is required to provide security services to all clients. Whatever information is required by this assembly, for managing security related issues, is present in security.ncconf file. security.ncconf file helps enabling NCache security as well as to manage Node and API level security. You will find security.ncconf file at "%Install Directory%/NCache/config".
Security.ncconf file is explained below:
<!-- Security Configuration file for NCache 4.4 and later versions -->
<cache-security>
<!-- Change the value true/false to enable or disable security
feature in NCache -->
<enabled>false</enabled>
<!-- LDAP path is required to log-on to domain. -->
<ldap>LDAP://Pdc-america</ldap>
<!-- Following users are Administrators and are allowed to add 'THIS' node
into their clusters and also allowed to perform Cache operations at
API level for all Caches. -->
<ncache-administrators>
<uid>Administrator</uid>
</ncache-administrators>
</cache-security>
  • <enabled> tells users if security is enabled or not (true/false)
  • <ldap> specifies ldap path for active directory server provider. It is the domain controller. NCache uses Microsoft Active Directory Service for authentication of user. User should exist under given domain in LDAP. For more information, see https://msdn.microsoft.com/en-us/library/aa746384.aspx
  • <ncache-administrators> keeps list of users having rights on all node-based and API-based operations.
See Also
Cache Config | Configuring Bridge | Client Side Configuration Files | Configure Basic Cache Settings | Configure Security Using NCache Manager
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Server Configuration

< Previous page Next page >

Cache Server Configuration

This section explains various cache server configuration in "Alachisoft.NCache.Service.exe.config" file. All configurations in Alachisoft.NCache.Service.exe file will be needed at the start of NCache service.
In This Section
Overview
Gives you and overview of NCache.Service.exe.config file.
Cache Server Configurations in Service Config File
Explains how to configure different cache settings in NCache.Service.exe.config file. These settings are:
Bind Multiple NIC's
Explains Bind Multiple NIC's, its uses and its default values.
Auto Start Cache on Reboot
Explains Auto Start Cache, its uses and its default values.
Client/Server TCP Port
Explains Client/Server TCP Port its default values.
Configure Windows Events Logging
Explains Windows Events Logging, its uses and its default values.
Configure .NET Garbage Collection
Explains .NET Garbage Collection, its uses and its default values.
Configure Expiration Cleanup
Explains Expiration Cleanup, its uses and its default values.
Configure Eviction Cleanup
Explains Eviction Cleanup, its uses and its default values.
Enable Debug PerfMon Counters
Explains Debug PerfMon Counters, its uses and its default values.
Enable License Logging
Explains License Logging, its uses and its default values.
Configure SQL Dependency
Explains SQL Dependency and its modes.
Configure Response Data Size
Explains the Response Data Size and its various parameters.
Configure Max Response Length
Explains the Response Data Size and its various parameters.
Configure Enumeration
Explains the process of Enumeration and its various parameters.
Cache Startup Loader Delay
Explains how to introduce delay in Cache Startup Loader.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

"Alachisoft.NCache.Service.exe.config " file hosts all cache related configurations. For any change in cache configuration, you can either manually update this file or use NCache Manager to update it. This file updates with every change made at NCache Manager. Here you can specify the port at which cache server will listen for the incoming connection requests. Send/receive buffer size of connected client sockets is also given here. You can also identify cache (es) that you want to start at boot in Alachisoft.NCache.Service.exe.config file. This file is located at "%Install Directory%/NCache/bin/service".
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Cache Server Configurations in Service Config File | Configuration Files
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Server Configurations in Service Config File

< Previous page Next page >

Cache Server Configurations in Service Config File

Client/Server TCP Port
Client/Server TCP Port in service config will specify the port at which Cache Server will listen for incoming connection requests.
<add key = "NCacheServer.Port" value = "9800"/>
Enable License Logging
Enable License Logging in service config will specify whether this service will log license information for clients or not.
<add key = "NCacheServer.LicenseLogging" value = "false"/>
Bind Multiple NIC's
When your machine has more than one network cards, you can inform NCache which interface to use for cluster-wide communication. In order to do so, provide IP Address you want the cluster server to bind with in service config.
<add key = "NCacheServer.BindToClusterIP" value = "20.200.20.39"/>
You can follow the above procedure for client communication. Provide the IP Address you want the client's (NCache client) server to bind with.
<add key = "NCacheServer.BindToClientServerIP" value = "20.200.20.39"/>
Auto Start Cache on Reboot
You can configure caches to start with the start of NCache service. As, by default NCache service starts at the system startup so these settings are useful incase you want some caches to auto start at the system startup.
<add key = "NCacheServer.AutoStartCache" value = "mycache,myreplicatedcache,mypartitionedcache"/>
<add key = "NCacheServer.CacheUser" value = "domain/userId"/>
<add key = "NCacheServer.CachePassword" value = "password"/>
Enable Debug PerfMon Counters
Some performance counters are disabled by default but they can be really helpful to see NCache behavior over the network. These counters include:
  • Socket send time (time taken for the last send operation)
  • Socket receive time (time taken for the last receive operation)
  • Bytes sent/second
  • Bytes received/second
  • Naggling message count (number of messages bundled together in the last socket send operation)
  • TcpUpQueueCount: Number of items in TCP up queue.
  • TcpDownQueueCount: Number of items in TCP down queue.
  • BCastQueueCount: Number of items in BCast Queue.
  • MCastQueueCount: Number of items in MCast Queue.
These counters help find the source of the problem incase we see the cluster is not performing as expected.
<add key = "NCacheServer.EnableDebuggingCounters" value = "true"/>
Configure Expiration Cleanup
Expired items are removed in bulk. Specify the size of the bulk operation i.e. how many items should be removed in one bulk operation.
<add key = "NCacheServer.ExpirationBulkRemoveSize" value = "10"/>
Expired items are removed in bulk. This may affect the performance of user operations during expirations. This delay specified (in milliseconds) causes a delay between two consecutive bulk remove operations.
<add key = "NCacheServer.ExpirationBulkRemoveDelay" value = "0"/>
Configure Eviction Cleanup
During eviction items are removed in bulk. Specify the size of the bulk operation i.e. how many items should be removed in one bulk operation. EvictionBulkRemoveSize should be specified in multiple of 300.
<add key = "NCacheServer.EvictionBulkRemoveSize" value = "10"/>
During eviction items are removed in bulk. This may affect the performance of user operations during expirations. This delay specified (in seconds) causes a delay between two consecutive bulk remove operations.
<add key = "NCacheServer.EvictionBulkRemoveDelay" value = "0"/>
Configure Windows Events Logging
CacheSizeThreshold is the size of cache in percentage of total cache size. When this threshold is reached a warning message is logged into system event log. No warning message is logged if the following line is commented.
<add key = "NCacheServer.CacheSizeThreshold" value = "80"/>
CacheSizeReportInterval is the interval in minutes during which CacheSizeThreshold warning is issued once. If cache size falls below CacheSizeThreshold due to eviction and again crosses the CacheSizeThreshold limit during this interval no warning is generated. The minimum value is 5 minutes.
<add key = "NCacheServer.CacheSizeReportInterval" value = "15"/>
Enables/Disables the logging of client connectivity events into event viewer. By default these events are disabled.
<add key = "NCacheServer.LogClientEvents" value = "false"/>
Specifies the level of events which are logged into event viewer. There are three levels of events
  • Error : Only errors will be logged
  • Warning : Errors and Warnings will be logged
  • All : all events will be logged
<add key = "NCacheServer.EventLogLevel" value = "all"/>
Configure .NET Garbage Collection
Enables/Disables forced garbage collection when using Server GC. Applicable on server operating systems only. Possible values are 'true' or 'false'. If value is true, a forced GC.Collect( ) is called after system memory usage reaches a specific threshold. This threshold is specified under property 'NCacheServer.ForcedGCThreshold'. Default value for this property is 'true'.
<add key = "NCacheServer.EnableForcedGC" value = "true"/>
%age Memory usage threshold that is used to call forced garbage collection. This property depends on property 'NCacheServer.EnableForcedGC'. If the property is set 'true', given threshold value is used to call explicit Garbage collection. Default value is 80. This implies that an explicit GarbageCollection should be called when system memory usage reached 80% of the total memory.
<add key = "NCacheServer.ForcedGCThreshold" value = "80"/>
Value of seconds after which service should check if it needs to do a forced garbage collection. This property dictates how frequent you want to check if a forced Garbage Collection is required or not. Default value is 20 seconds. Minimum possible value is 5 seconds.
<add key = "NCacheServer.ForcedGCInterval" value = "20"/>
Configure SQL Dependency
SQL Dependency can be used in two modes i.e. Default mode or Custom mode. In default mode, SQL Dependency creates a default service and queue at run time. In case of Custom mode, a customer defined SQL Dependency service and queue will be created and used by NCache. In this case, NCache will connect with the pre-created service and queue with following naming convention:
  • "NCacheDBService-[IP-Address]"
  • "NCacheDBQueue-[IP-Address]"
You can change the SQL Dependency service and queue name prefix by specifying it against the NCacheServer.NCacheDBService key/NCacheServer.NCacheDBQueue key.
<add key = "NCacheServer.NCacheSQLNotificationService" value = "NCacheSQLService"/>
<add key = "NCacheServer.NCacheSQLNotificationQueue" value = "NCacheSQLQueue"/>
Configure Response Data Size
NCache introduces "Response Data Size" to limit the large result sets returned in response to bulk Search, Tags and Groups operations. .NET framework does not support the serialization of large result sets which exceeds the size of 1.9Gb. To solve this problem NCache splits the large result sets into smaller chunks of data.
NCacheServer.ResponseDataSize can be used to specify the size of a response. It will help in limiting a response size by dividing the bigger response into multiple responses each containing the data approximately equal to the specified limit. These multiple responses will be merged by the NCache Client as a single response. Here it takes value in MB’s. Default size is 1024MB.
<add key = "NCacheServer.ResponseDataSize" value = "1024"/>
At least one object must be sent in response even if the data size of an object exceeds the specified limit for data.
Configure Max Response Length
NCache introduces "Max Response Length" to limit the large result sets returned in response to all operations whether bulk or not .NET framework does not support the serialization of large result sets which exceeds the size of 1.9Gb. To solve this problem NCache splits the large result sets into smaller chunks of data.
NCacheServer.MaxResponseLength can be used to specify the size of a response. It will help in limiting a response size by dividing the bigger response into multiple responses each containing the data approximately equal to the specified limit. These multiple responses will be merged by the NCache Client as a single response. Here it takes value in KB’s. Default size is 512KB.
<add key = "NCacheServer.MaxResponseLength" value = "512"/>
At least one object must be sent in response even if the data size of an object exceeds the specified limit for data.
Configure Enumeration
The purpose of introducing enumeration is to keep cache free from locking while enumerating the cache data. This process eventually increases the cache performance and its availability for clients. NCache is following the technique of taking snapshots of cache data and send it to the client for enumeration which keeps the cache free from being locked during the process of enumeration. Four attributes are defined for enumeration, which are:
NCacheServer.SnapshotPoolingCacheSize can be used to specify the size of the cache (in terms of number of items) for enabling enumeration on cache. It will help in deciding whether to create a pool of snapshots for enumeration or not. A complete snapshot of cache is returned to the enumerator until the threshold reaches its limit. Once the threshold value is crossed, cache will create a pool of snapshots that will hold those snapshots based on time slicing. These snapshots will be provided to the enumerator on demand from client by the cache server. Default Size is 100000 items in cache.
<add key = "NCacheServer.EnableSnapshotPoolingCacheSize" value = "100000"/>
NCacheServer.SnapshotPoolSize can be used to specify the number of snapshots allowed in the pool for enumeration. Once the pool reaches its maximum limit, it won’t allow more snapshots to be added to the pool. It will wait till any existing snapshot in the pool has been removed. Default Size is 10 snapshots in cache snapshot pool.
<add key = "NCacheServer.SnapshotPoolSize" value = "10"/>
NCacheServer.SnapshotCreationThreshold can be used to specify after how many seconds a new snapshot will be added to pool for enumeration purpose. Same cache snapshot from the pool is provided to all enumerators on cache until the threshold time is elapsed. Any enumerator that requests a snapshot after that will get a new snapshot from the pool. Default size is 30 seconds.
<add key = "NCacheServer.SnapshotCreationThreshold" value = "30"/>
NCacheServer.EnumeratorChunkSize can be used to specify the chunk size for enumeration. Chunk size is the number of cache items returned to the enumerator from cache server. Once the enumerator is done enumerating through a chunk of data it will get the next chunk from the cache server for enumeration. Default size is 1000 items returned in each chunk.
<add key = "NCacheServer.EnumeratorChunkSize" value = "1000"/>
Cache Startup Loader Delay
User can introduce a delay in Cache Startup Loader in order to avoid some data loss problems which may occur while the cache is still in process of member joining. This is done by setting the following property:
<add key = "NCacheServer.CacheLoaderStartupDelay" value = "20"/>
The value of this property is set in seconds. By default, this value is 20 while minimum value is 10 seconds.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Configuration Files
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Management Operations

< Previous page Next page >

Management Operations

This section of the documentation discusses different cache management operations in NCache and explains how these operations can be performed in NCache.
In This Section
Start Cache
Explains how to start a cache in NCache.
Stop Cache
Explains how to start a cache in NCache.
Manage Cache Service on a Server Node
Explains how to start, stop and reset a cache service on a server node in NCache.
Apply Configuration
This section discusses how to successfully configure settings of caches in NCache using Apply Configuration.
Hot Apply Configuration
This section discusses how to successfully configure settings of caches in NCache using Hot Apply Configuration.
Reset Configuration
This section discusses how to reset configuration settings of caches in NCache.
Data Load Balancing
This section describes how to balance data load among different nodes in partitioned clusters.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Cache

< Previous page Next page >

Start Cache

A cache can be started either on a particular server node or on all server nodes of a cluster. This section includes the step by step procedure of starting cache using both the NCache manager and command tools.
In This Section
Start Cache on all Server Nodes
This section explains how to start cache on all server nodes of a clustered cache.
Start Cache on a Particular Server Node
This section explains how to start cache on a specific server node.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Cache on all Server Nodes

< Previous page Next page >

Start Cache on all Server Nodes

A cache can be started on all server nodes of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the cache name which you want to start.
  • Click on the Start option in the right click context menu.
  • This starts the demoClusteredCache on all the server nodes listed under the Server Nodes tree view. Server node icon color turns to sky blue if cache is started successfully.
See Also
Create Caches | Configuring Basic Cache Settings | Start Cache on a Particular Server Node | Stop Cache | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Cache on a Particular Server Node

< Previous page Next page >

Start Cache on a Particular Server Node

A cache can be started on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to start the cache on.
  • Click on the Start option in the right click context menu.
  • This starts the demoClusteredCache on the selected server node. Server node icon color turns to sky blue if cache is started successfully.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use startcache.exe, provide the required information:
startcache.exe demoClusteredCache /s 20.200.21.95 /p 8250
  • Hit ENTER key, it starts the demoClusteredCache on server node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Start Cache on all Server Nodes | Stop Cache | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Cache

< Previous page Next page >

Stop Cache

A cache can be stopped either on a particular server node or on all server nodes of a cluster. This section explains how to stop cache using both the NCache manager and command tools.
In This Section
Stop Cache on all Server Nodes
This section explains how to start cache on all server nodes of a clustered cache.
Stop Cache on a Particular Server Node
This section explains how to start cache on a specific server node.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Cache on all Server Nodes

< Previous page Next page >

Stop Cache on all Server Nodes

A cache can be stopped on all server nodes of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the clustered cache that you want to stop.
  • Click on the Stop option in the right click context menu.
  • This stops the demoClusteredCache on all the server nodes listed under the Server Nodes tree view. The coloe of all the server nodes icons turns to black if cache is stopped successfully.
See Also
Create Caches | Configuring Basic Cache Settings | Start Cache | Stop Cache on a Particular Server Node | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Cache on a Particular Server Node

< Previous page Next page >

Stop Cache on a Particular Server Node

A cache can be stopped on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to stop the cache.
  • Click on the Stop option in the right click context menu.
  • This stops the demoClusteredCache on the selected server node. Server node icon color turns to black if cache is stopped successfully.
You can stop a node gracefully using Graceful Stop option. The graceful stop option makes sure that all of the queued operations are performed before cache is stopped.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use stopcache.exe, provide the required information:
stopcache.exe demoClusteredCache /s 20.200.21.95 /p 8250
  • Hit ENTER key, it stops the demoClusteredCache on server node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache on all Server Nodes | Start Cache | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Manage Cache Service on a Server Node

< Previous page Next page >

Manage Cache Service on a Server Node

NCache service can be started, stopped or restarted on a paticular server node added in the clustered cache using the NCache manager.
In This Section
Start Cache Service on a Server Node
This section explains how to start cache service on a server node of a clustered cache.
Stop Cache Service on a Particular Server Node
This section explains how to stop cache service on a specific server node.
Restart Cache Service on a Particular Server Node
This section explains how to restart cache service on a particular server node.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Cache Service on a Server Node

< Previous page Next page >

Start Cache Service on a Server Node

A cache service can be can be started on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to start the cache service.
  • Click on the Start Cache Service option in the right click context menu.
This will start the cache service on node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing | Stop Cache Service on a Server Node | Restart Cache Service on a Server Node
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Cache Service on a Server Node

< Previous page Next page >

Stop Cache Service on a Server Node

A cache service can be can be stopped on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to stop the cache service.
  • Click on the Stop Cache Service option in the right click context menu.
This will start the NCache service on node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing | Start Cache Service on a Server Node | Restart Cache Service on a Server Node
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Restart Cache Service on a Server Node

< Previous page Next page >

Restart Cache Service on a Server Node

A cache service can be can be restarted on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to restart the cache service.
  • Click on the Restart Cache Service option in the right click context menu.
This will restart the NCache service on the selected node.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing | Start Cache Service on a Server Node | Start Cache Service on a Server Node
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Apply Configuration

< Previous page Next page >

Apply Configuration

Settings of a cache can be changed while it is stopped. For these settings to be successfully configured, it is important to apply configuration as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to apply the configuration settings.
  • Click on the Apply Configuration option in the right click context menu.
Your changes will be applied on all of the nodes of this clustered cache.
  • You can also apply configuration using tool bar buttons in the manager.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Hot Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Hot Apply Configuration

< Previous page Next page >

Hot Apply Configuration

Settings of a cache that are changed while it is running can be successfully configured using hot apply configuration as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to apply the configuration settings.
  • Click on the Hot Apply Configuration option in the right click context menu.
Your changes will be applied on all of the nodes of this clustered cache.
  • You can also apply configuration using tool bar buttons in the manager.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Reset Configuration

< Previous page Next page >

Reset Configuration

Resetting configuration will change all configuration changes to the last saved configuration values for the current cache. This can be done as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to reset the configuration settings.
  • Click on the Reset Configuration option in the right click context menu.
Cache settings are reset to the last saved configuration for this cache.
  • You can also apply configuration using tool bar buttons in the manager.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Hot Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Data Load Balancing

< Previous page Next page >

Data Load Balancing

You can request to balance a node in a partitioned cluster without waiting for the automatic load balancing task to trigger it. This brings data load on the node near to average data per node while rest of the data is distributed across other nodes in the cluster. Candidate nodes for accepting the load are selected on the bases of the amount of data currently present on them. A node having less data gets a larger share from the load. This can be done as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the server node of a cache cluster.
  • Click on the Balance Data Load option in the right click context menu.
Data will be evenly distributed across the nodes of the cluster.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Cache Clients

< Previous page Next page >

Configuring Cache Clients

This section describes step-by-step instructions on how to add or remove client nodes in a clustered cache, create or remove client cache and configure client specific settings. A client node is the one from where clustered cache can be initialized to make API calls.
In This Section
Adding Client Node
Explains how to add client node in a clustered cache.
Configuring Client Node Settings
Explains how to configure the settings of a client node.
Creating Client Cache
Describes how to create client cache on a client node.
Disable Client Cache on Client Node
Describes how to disable client cache on client node.
Enable Client Cache on Client Node
Describes the process to enable client cache on client node
Configuring Client Cache Settings
Describes how to configure basic client cache settings such as synchronization modes, size and isolation levels.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding Client Node in a Cache Cluster

< Previous page Next page >

Adding Client Node in a Cache Cluster

Each clustered cache tree in Cache Explorer contains a node known as Client Nodes. Any number of client nodes can be added in a clustered cache.
This can be done as follows:
Using NCache Manager
  • Right click on Client Nodes in Cache Explorer for a cache and then click on the Add Node option.
  • Provide the client machine name/IP by expending Network Neighborhood or you can manually enter client Node
Name/IP Address in text box.
  • Click on the Finish button, newly added client node appears under Client Nodes in Cache Explorer tree view.
If you have more than one IP address on a client machine, then enter the IP address on which NCache service is running.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addclientnode.exe, provide the required information:
addclientnode.exe demoClusteredCache /s 20.200.21.95 /e 20.200.21.144
  • Hit ENTER key, it adds 20.200.21.144 as client node in cache named demoClusteredCache.
See Also
Configuring Caches | Create Caches | Configuring Client Node Settings | Configuring Client Cache Settings | Creating Client Cache | Disable Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Client Node Settings

< Previous page Next page >

Configuring Client Node Settings

There are some configuration settings related to client node. These settings can be configured as follows:
Using NCache Manager
  • Click on a client machine IP address in Cache Explorer for a cache to open client related settings of this client node.
  • On Main tab you can configure Connection Timeout, Connection Retries, Retry Interval and Client Request Timeout. All values are in seconds. A brief description of each attribute is given is given in NCache Manager alongside each attribute.
  • Using the Settings tab, you can enable/disable client load balancing using the checkbox Enable Client Load Balancing, specify Server Priority for this client, and change Sync Mode of client cache to either Optimistic or Pessimistic.
  • Using the Security tab you can specify Primary and Secondary user credentials, i.e., User Id and Password. These
credentials will be used when this cache is initialized from this client node.
  • At the Backing Source tab, you can select the default Read-Thru and/or Write-Thru providers, only if these providers are
configured for the cache.
  • Apply configuration changes by right clicking on the cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Cache Settings | Creating Client Cache | Disable Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating Client Cache

< Previous page Next page >

Creating Client Cache

Client Cache is a cache that exists on client node. You can create client cache in either of the two ways described below:
Using NCache Manager
  • Right click Client Cache tree node in Cache Explorer for a cache. Click on the Create New Cache option in the right click menu.
  • Enter Enter client cache Name, select client cache Sync Mode and choose the Isolation Level. And then click on the Next button.
  • Change the cache size if require and click Next.
  • In Advanced options dialog, you can configure followings:
  • You can change the Eviction policy and Eviction percentage; items will be evicted from cache using the selected policy and percentage value, if eviction is enabled.
  • You can change Clean interval value. Its default value is 15 sec.
  • You can make the cache to start automatically after service restart by checking checkbox Auto start this cache on service startup.
  • This will create client cache on all client nodes and Client cache Creation Status window is displayed showing client cache creation status for each client node.
  • Click Close and the newly created client cache will appear under Client Cache in the Cache Explorer.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createclientcache.exe, provide the required information:
createclientcache.exe demoClusteredCache /c demoClientCache /s 20.200.21.95 /N 20.200.21.144 /S 250
  • Hit ENTER key, it will create a client cache demoClientCache for cache demoClusteredCache on node 20.200.21.144.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Configuring Client Cache Settings | Disable Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Disable Client Cache on Client Nodes

< Previous page Next page >

Disable Client Cache on Client Nodes

In some cases when you create client cache but do not want to use it, then you can disable client cache for a particular client node or for all client nodes.
Each client node has an indicator showing whether client cache is enabled or disabled. A red square sign indicates that client cache is enabled and grey square sign indicates that client cache is disabled, as shown in screen shots below.
Using NCache Manager
  • Right click on Client Nodes in Cache Explorer for a cache.
  • Click on Disable Client Cache option in the right click menu. Client cache becomes disabled for all the client nodes, currently listed under Client nodes in Cache Explorer. Grey square sign on client node indicates a disabled client cache.
Please note that you can also disable client cache by right clicking on a particular client node instead of Client Nodes. In this way, client cache will be enabled for the selected client node only.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Configuring Client Cache Settings | Creating Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Enable Client Cache on Client Nodes

< Previous page Next page >

Enable Client Cache on Client Nodes

If a client cache is already created but currently is disabled, you can enable this client cache at any time as follows:
Using NCache Manager
  • Right click on Client Nodes in Cache Explorer for a cache.
  • Click on Enable Client Cache option in the right click menu. Client cache becomes disabled for all the client nodes, currently listed under Client nodes in Cache Explorer. Grey square sign on client node indicates a disabled client cache.
  • Client cache becomes enabled for this cache in Cache Explorer. Red square sign on client node indicates that client cache is enabled now.
Please note that you can also enable client cache by right clicking on particular client node instead of Client Nodes in Cache Explorer. In this way, client cache will be enabled for the selected client node only.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Configuring Client Cache Settings | Disable Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Client Cache Settings

< Previous page Next page >

Configuring Client Cache Settings

There are some settings which specific to client cache. These settings can be configured by using the tabs
  • Main
  • Policies
  • Options
on the right side of the manager when client cache is clicked.
This sections explains how to configure some basic settings of the client cache.
In This Section
Configuring Synchronization Mode
Explains how to select the required synchronization mode for the client cache.
Configuring Client Cache Size
Explains how to change the size of the client cache.
Configuring Isolation Level
Describes how to configure the required isolation level (inproc or outproc) for the client cache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Synchronization Mode

< Previous page Next page >

Synchronization Mode

There are two synchronization modes for a client cahe.
  • Optimistic
  • Pessimistic
Optimistic Synchronization
In optimistic mode, application fetches data from client cache despite the fact that data is updated or not. It assumes that data is newer in client cache. In optimistic synchronization, updates are propagated to the client cache using event notifications.
Pessimistic Synchronization
Pessimistic mode is used when applications are handling sensitive data. On data fetch request, if data is found in client cache, its version is matched with item on remote cache. If both versions are same, then item is returned otherwise updated item is fetched from remote cache and is updated back to client cache.
These modes can be configured as follows:
Using NCache Manager
  • Click client node IP under Client Nodes in Cache Explorer. Client specific settings in tabbed view shown in right pane.
  • Go to Settings tab and select any one option Optimistic or Pessimistic from Sync Mode Drop Down list.
  • Click on Enable Client Cache option in the right click menu. Client cache becomes disabled for all the client nodes, currently listed under Client nodes in Cache Explorer. Grey square sign on client node indicates a disabled client cache.
  • Right click on cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Client Cache Size | Isolation Level | Creating Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Cache Size

< Previous page Next page >

Client Cache Size

Size of client cache is also configurable and can be changed as follows:
Using NCache Manager
  • Click on the client cache and go to the Main tab in the right pane. Under this tab, Cache Max. Size can be changed.
  • Right click on client cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Synchronization Mode | Isolation Level | Creating Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Isolation Level

< Previous page Next page >

Isolation Level

The client cache can either be inproc or outproc. Please see Isolation Levels to learn more about it.
These levels can be configured as follows:
Using NCache Manager
  • Click on the client cache under Client Cache tree view in Cache Explorer and go to the MAIN tab in the right pane.
  • In Main tab, a drop down list labeled as Isolation Level is available. The levels can be changed to either High (OutProc) or Low (InProc).
  • Right click on client cache name in Cache Explorer and select Apply Configuration option.
To change the isolation levels, the client cache must be disabled first.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Synchronization Mode | Client Cache Size | Creating Client Cache | Enable Client Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Security

< Previous page Next page >

Configuring Security
This feature is not available in NCache Express and Professional edition.
Every Server node keeps security information that it has to provide to calling clients. Alachisoft.NCache.NCSecurity.dll at server node is required to provide security services to all clients. Whatever information is required by this assembly, for managing security related issues, is present in security.ncconf file. security.ncconf file helps enabling NCache security as well as to manage Node and API level security. You will find security.ncconf file at "%Install Directory%/NCache/config".
security.ncconf file is as shown below:
<!-- Security Configuration file for NCache 4.3 and later versions -->
<cache-security>
<!-- Change the value true/false to enable or disable security
feature in NCache -->
<enabled>false</enabled>
<!-- LDAP path is required to log-on to domain. -->
<ldap>LDAP://DomainControllerName</ldap>
<!-- Following users are Administrators and are allowed to add 'THIS' node
into their clusters and also allowed to perform Cache operations at
API level for all Caches. -->
<ncache-administrators>
<uid>Administrator</uid>
</ncache-administrators>
</cache-security>
  • <enabled> tells users if security is enabled or not (true/false)
  • <ldap> specifies ldap path for active directory server provider. It is the domain controller. NCache uses Microsoft Active Directory Service for authentication of user. User should exist under given domain in LDAP. For more information, see LDAP ADsPath
  • <ncache-administrators> keeps list of users having rights on all node-based and API-based operations.
In This Section
Configuring Security for Cache Management
Explains how to configure security for cache managerial tasks.
Configuring Security for Cache
Explains how to configure the security for cache.
Configuring Encryption for Cache
Describes how to enable and configure encryption for cache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Security for Cache Management

< Previous page Next page >

Configuring Security for Cache Management

After you have created cache, security for management operations can be configured in following ways:
Using NCache Manager
  • Open NCache Manager.
  • Go to Security menu option and select Security Credentials option.
  • Security Credentials dialog will open.
  • Provide the valid credentials for your active directory like name of Domain Controller, Port (optional), User Name and Password.
  • Click on the Verify Credentials button. It will prompt success or failure messages. If provided security credentials are correct then it will display the success message like this:
  • Click OK.
  • Now go to the NCache Manager ->Security menu option again and select Configure Security option.
  • Security Configuration Wizard will open. Specify the server IP address for which you want to configure the security and click Next.
  • Security Configurations Wizard will open. Expand the Available Domain Users. It will list down all of the active directory users.
  • Select users from the users list and then add the required users using ‘>’ button. These users will be allowed to manage the caches.
  • Check the Enable Security checkbox to enable the security.
  • Click Finish.
See Also
Configuring Security for Cache | Configuring Encryption for Cache | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Security for Cache

< Previous page Next page >

Configuring Security for Cache

Security can also be configured on cache itself. This can be done as follow:
Using NCache Manager
  • Open NCache Manager.
  • Go to Security menu option and select Security Credentials option.
  • Security Credentials dialog will open.
  • Provide the valid credentials for your active directory like name of Domain Controller, Port (optional), User Name and Password.
  • Click on the Verify Credentials button. It will prompt success or failure messages. If provided security credentials are correct then it will display the success message like this:
  • Click OK.
  • Click the cache name for which you want to configure the security. Cache settings open in the right pane inside the NCache Manager.
  • Go to the Security tab in cache settings.
  • Expand the domain users under the Available Domain Users section.
  • Add required users to Selected Users section using ‘>’ button. These users will have access for cache operations.
  • Check Enable Security check box.
  • Select users from the users list and then add the required users using ‘>’ button. These users will be allowed to manage the caches.
  • Check the Enable Security checkbox to enable the security.
  • Right click on the cache name in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use configurecachesecurity.exe, provide the required information:
configurecachesecurity demoClusteredCache /E /s 20.200.21.95 /U james_tredwell /P yourpassword /C yourdomain.org
  • Hit ENTER key, it will enable security for demoClusteredCache on server 20.200.21.95 and add the user james_tredwell.
  • If you want to add more users, use the following command after step 2:
configurecachesecurity demoClusteredCache /A /N aaron_finch /s 20.200.21.95 /U administrator /P yourpassword /C yourdomain.org
  • Hit ENTER key. It will add the user aaron_finch to the secured users list of demoClusteredCache.
How to pass Security Credentials to API:
User can also pass security credentials to API from the application using the following code:
NCache.InitializeCache("cacheId", new Alachisoft.NCache.Web.Security.SecurityParams("Username", "Password"), null);
See Also
Configuring Security for Cache Management | Configuring Encryption for Cache | Configuring Caches | Configuring Client Cache Settings | Cache Management operations | Configuring Bridge | Monitoring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Encryption for Cache

< Previous page Next page >

Configuring Encryption for Cache

To enable and configure encryption for cache, follow the steps below:
Using NCache Manager
  • Open NCache Manager.
  • Go to Security tab.
  • Check the Enable checkbox inside Encryption group to enable encryption.
  • Select the encryption provider as per you requirement from the given Provider dropdown list.
  • Enter the encryption key in the Key textbox.
  • Right click on the cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Security for Cache Management | Configuring Security for Cache | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Bridge for WAN Replication

< Previous page Next page >

Configuring Bridge for WAN Replication
This feature is not available in NCache Express and Professional edition.
This section explains what is bridge, the operations that can be performed on a bridge and describes how to configure different bridge settings.
In This Section
Overview of Bridge
Explains what is bridge and what are the two main bridge topologies provided by NCache.
Creating Clustered Bridge
Explains how to create a clustered bridge.
Configuring Bridge Settings
Describes what are basic bridge settings and how can they be configured.
Configuring Conflict Resolver
Explains how the conflict, if occured in bridge operations, can be resolved.
Changing Cache Synchronization Modes
Explains how to change the synchronization mode of clustered cache connected to the bridge
Configuring Master Cache
Explains how an active cache (connected to a bridge) can be made a master cache.
Force State Transfer
Explains how to carry out state transfer explicitly between master cache and bridge.
Connect/Disconnect a Cache
Explains how to connect/disconnect a running cluster to bridge
Remove a Cache from Bridge
Explains how to remove a cache from bridge once it is stopped.
Bridge Management
Explains different bridge management operations and their usage.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview of Bridge

< Previous page Next page >

Overview of Bridge

Remote data replication is a critical component for any plan to ensure effective and efficient protection and rapid recovery from a major interruption. Synchronous replication of data is good internally for the cluster but its impact on performance becomes a significant consideration when two clusters of cache are geographically separated. Bridge topology is designed for the scenarios which involve replication of data from one on-site cache to one/multiple and on-site/off-site disaster recovery cache(s) across the WAN. Due to asynchronous replication, all clients connected to the active cache(s) get an impression that the operations are being performed on the active cache while a complete backup is taken to the other cache(s) seamlessly.
When an operation is performed on source cache, it is asynchronously handed over to the bridge cache. This operation is then enqueued to a queue maintained by the bridge cache. Operations from the queue are transferred to the other cache(s) when bridge finds the cache(s) available and ready to accept operations. With the bridge topology, it is ensured that:
  • There is no performance degradation.
  • Operations are performed in same sequence as they were on original cache.
  • Operations are not lost in case of connection failure.
Below are the main bridge topologies provided by NCache:
  • Active-Passive (one Active and one Passive Cache)
  • Active-Active (two Active Caches and no Passive Cache)
In This Section
Active-Passive Bridge Topology
Explains what is meant by Active-Passive Bridge topology provided by NCache.
Active-Active Bridge Topology
Explains what is meant by Active-Active Bridge topology provided by NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Active-Passive

< Previous page Next page >

Active-Passive

Three NCache Clusters participate in Active Passive topology:
  • An active cache (replicated, partitioned, mirror or partitioned replica), where all clients are connected and perform read and write operations.
  • A passive cache (replicated, partitioned, mirror or partitioned replica), where all operations performed on an active cache are replicated. Clients can connect to passive cache and perform both read and write operations but those operations are not replicated to the other caches. Modification can be done at passive cache if required.
  • A Bridge Cache between the active cache and the passive cache.
See Also
Overview of Bridge | Active-Active Bridge Topology | Creating Clustered Bridge | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Active-Active

< Previous page Next page >

Active-Active

Three NCache Clusters participate in Active-Active topology:
  • Two active caches (replicated, partitioned, mirror or partitioned replica), where all clients are connected and perform read and write operations. Here any updates to the cache are applied asynchronously to the other cache.
  • A Bridge Cache between both the active caches.
See Also
Overview of Bridge | Active-Passive Bridge Topology | Creating Clustered Bridge | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating Clustered Bridge

< Previous page Next page >

Creating Clustered Bridge

A bridge can be created in NCache and caches are added in it using the following method:
Using NCache Manager
  • From the Cache Explorer view, right click the Bridges node and then click Create New Bridge option.
  • The New Bridge Wizard appears, displaying the Specify Bridge Identification dialog. Please provide the Name for the
new bridge and click on the Next button.
  • Select Bridge Member Nodes dialog opens up.
  • Speicfy the node IP address in text box or select from the Network Neighborhood and click on the ‘>’ button to add it in selected nodes list. Click on the Next button once all required nodes are added.
  • Specify Queue Parameters dialog box appears. Here, you can specify the multiple bridge properties, i.e., Bridge Port, Maximum Queue Size, and Replicator Queue Size.
  • After providing the required values click Next.
  • On the Specify Target Cache Options dialog box, you can change the Queue Replication Interval and Connection Retry Interval values. There is also a check box Start this bridge on Service restart. Check it if you want to start this bridge automatically when NCache bridge service starts. Click the Finish button to proceed ahead.
  • Your bridge will be successfully created and will be visible in the Cache Explorer view under the Bridges node.
Adding Clustered Caches to the Bridge
Depending on your bridge topology, you can add two caches to your bridge. The caches that you want to add should already be created on the local server or on remote server(s). Please follow these steps to add a cache to your bridge:
  • From the Cache Explorer view, right click the bridge to which you want to add a cache and then click on the Add Cluster Cache option.
  • On the Add Clustered Cache wizard, specify the server IP address in text box or select from the Network Neighborhood listed in Available Nodes list box and click Next button:
  • Select a clustered cache dialog window, all of the caches on your provided server are listed. Choose any one cache and click Next.
  • On the Select settings for bridge clustered cache dialog, choose the cache mode for this bridge configuration.
Default cache mode is Active, but you can change that.
  • The selected cache will successfully get added for this bridge and will be visible under the Caches node of the bridge.
  • Add the 2nd cache for this bridge using same steps mentioned above.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Bridge Settings

< Previous page Next page >

Configuring Bridge Settings

The NCache Manager provides the ability to change the configuration of bridges, whether it’s Active-Passive or Active-Active. To change the configuration of a bridge, click the bridge from the Cache Explorer view. You will be able to see various tabs in the Cache Details view through which you can configure various options of your bridge.
In This Section
Bridge Queue Size
Explains how to configure the bridge queue size.
Bridge Connection Settings
Explains how to configure the settings of bridge connection with other bridge nodes.
Enable the Queue Optimization
Explains how to enable queue optimization for bridge.
Bulk Size for Operation Replication
Explains how to configure bulk size for operation replication.
Performance Counters
Explains how to enable or disable performance counters for bridge.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Bridge Queue Size

< Previous page Next page >

Bridge Queue Size

Bridge stores the received data/objects in cache queues. You can modify (increase or decrease) these queues’ size using the following method:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Main tab.
  • Increse or decrease the Queue Size according to your requirements.
  • Right click on the bridge name in Cache Explorer and select Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Bridge Connection Settings

< Previous page Next page >

Bridge Connection Settings

Every bridge cache opens a unique port for communication with other bridge nodes. The settings for this connection can be configured as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Main tab.
  • Change the Bridge Port. Make sure that your newly provide port is not already in use of any other application.
  • Click on the Bridge Caches tab.
  • Change the Connection Retry Interval, which suites your environment (according to WAN latency).
  • Right click on the bridge name in Cache Explorer and select Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Enable the Queue Optimization

< Previous page Next page >

Enable the Queue Optimization

NCache provides the optimized queue to eliminate the redundant operation replication to the bridge and other caches. It can be enabled as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Main tab.
  • Check the Enable Queue Optimization check box on this tab.
  • Right click on the bridge name in Cache Explorer and select Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Performance Counters

< Previous page Next page >

Performance Counters

NCache provides and publish multiple performance counters for bridge caches. You can enable or disable the performance counters publishing according to your requirements. These can be enabled or disabled as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Options tab.
  • Check or unckeck the Enable performance counters check box.
  • Right click on the bridge name in the Cache Explorer and select Apply Configuration option.
See Also
Bulk Size for Operation Replications | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches | Monitoring Cache Counters
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Bulk Size for Operation Replications

< Previous page Next page >

Bulk Size for Operation Replications

Replication can be controlled or throttled according to the underlying network performance to boost the bridge replication performance. These settings can be configured as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Bridge Caches tab.
  • Increase or decrease the Bulk Operation Size on this tab.
  • Right click on the bridge name in the Cache Explorer and select Apply Configuration option.
See Also
Performance Counters | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Conflict Resolver

< Previous page Next page >

Configuring Conflict Resolver

There are situations when a bridge tries to replicate an operation for a key that already exist in the cache. Conflict Resolver is introduced to resolve the conflict between existing operations and operation replicated from bridge to the cache. It decides which key to apply on the cache depending upon defined rules. By default the decision will be made on Time Based rule, which keeps the latest key on a cache. Users can also define their own rules for conflict resolver. Its settings can be configured as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Conflict Resolver tab.
  • Check Enable Conflict Resolver check box to enable it. Others options will become enable after that.
  • Click on the ‘…’ button and select the assembly in which you have implemented the IBridgeConflictResolver interface.
  • Name of selected assembly will be appeared in Assembly Name textbox and all of its classes which have implemented the IBridgeConflictResolver interface will be listed down in Class Name list box. Select the required class.
  • Click New to provide any additional parameters, if required.
  • New Parameter dialog appears; provide the Parameter Name and Parameter Value.
  • Click the Deploy Conflict Resolver button, select your assembly in which you have implemented IBridgeConflictResolver interface and click on the button in Open dialog.
  • Apply configuration using right clicking on the cache name in Cache Explorer and selecting Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Changing Cache Synchronization Modes

< Previous page Next page >

Changing Cache Synchronization Modes

The NCache Manager provides the ability to change the synchronization mode of clustered cache connected to the bridge. This can be done by either making an active cache passive or a passive cache active.
In This Section
Making Passive Cache as Active Cache
Explains how to make a passive cache in bridge as an active cache.
Making Active Cache as Passive Cache
Explains how to make an active cache in bridge as a passive cache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Making Passive Cache as Active Cache

< Previous page Next page >

Making Passive Cache as Active Cache

NCache Manager provides the facility to convert a passive cache in a bridge to an active cache using the following steps:
Using NCache Manager
  • Right click on the passive cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Make Active option in the right click context menu.
See Also
Making Active Cache as Passive Cache | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Making Active Cache as Passive Cache

< Previous page Next page >

Making Active Cache as Passive Cache

NCache Manager provides the facility to convert an active cache in a bridge to a passive cache using the following steps:
Using NCache Manager
  • Right click on the active cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Make Passive option in the right click context menu.
See Also
Making Passive Cache as Active Cache | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Master Cache

< Previous page Next page >

Configuring Master Cache

You can make an active cache (connected to a bridge) master. Please follow these steps:
Using NCache Manager
  • Right click on the active cache name (which is not marked as master cache) under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Make Master option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Force State Transfer

< Previous page Next page >

Force State Transfer

State transfer is process in which bridge ask the master cache to re-replicate all of its cached objects to the bridge. The main benefit of this process is to make sure the other cache in this bridge is resynchronized with the master cache. By default, state transfer is initiated on the change of master cache, cache connection after disconnection or on cluster restart.
You can execute state transfer at any time after bridge starts to synchronize both caches. Force state transfer using NCache Manager as follows:
Using NCache Manager
  • Right click on the active cache name (which is not marked as master cache) under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Force State Transfer option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Connect/Disconnect a Cache

< Previous page Next page >

Connect/Disconnect a Cache

By default all added clusters are connected with bridge on start. You can disconnect then re-connect a running cluster to bridge. Please follow the steps given below:
Using NCache Manager
  • Right click on the cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Disconnect option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Remove a Cache from Bridge | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Remove a Cache from Bridge

< Previous page Next page >

Remove a Cache from Bridge

You can remove a cache from bridge after the bridge stops. This can be done as follows:
Using NCache Manager
  • Right click on the cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Remove option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Bridge Management | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Bridge Management

< Previous page Next page >

Bridge Management

You can manage a bridge using NCache Manager. It allows to you to perform different management operations, e.g., add, remove etc, on a bridge. This section states how to perform different management operations on a bridge.
In This Section
Add a Bridge Node
Explains how to add a node to a bridge.
Apply and Reset Configuration
Explains how to apply and reset configuration.
Remove a Bridge Node
Explains how to remove a node from a bridge.
Start Bridge
Explains how to start a bridge.
Stop Bridge
Explains how to stop a bridge.
Remove Bridge
Explains how to remove a bridge.
Start Bridge Service
Explains how to start bridge service on a bridge node.
Stop Bridge Service
Explains how to stop bridge service on a bridge node.
Restart Bridge Service
Explains how to restart bridge service on a bridge node.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Add a Bridge Node

< Previous page Next page >

Add a Bridge Node

This section explains how to add a node in the bridge. Please follow the steps given below for this purpose.
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Add Bridge Node option in the right click context menu.
  • Specify the server IP address in text box or select a server from the Network Neighborhood listed under Available Nodes. Click Finish.
  • Right click on the name of the bridge and select Apply Configuration.
See Also
Remove a Bridge Node | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Apply and Reset Configuration

< Previous page Next page >

Apply and Reset Configuration

This section explains how to apply and reset configurations of a bridge. Steps are given below
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • From the right click context menu, select Apply Configuration to apply the changes and Reset Configuration if you want to restore the old settings of a bridge.
See Also
Add a Bridge Node | Remove a Bridge Node | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Remove a Bridge Node

< Previous page Next page >

Remove a Bridge Node

NCache manager also lets the user remove a node from the bridge. This can be done as follows:
Using NCache Manager
  • Right click on the bridge node under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Remove option in the right click context menu.
  • A message box appears asking to confirm the bridge node removal. If you are sure to remove this node, then click on Yes button.
  • The node will be removed from the bridge on clicking Yes.
  • Right click on the name of the bridge and select Apply Configuration.
See Also
Add a Bridge Node | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Bridge

< Previous page Next page >

Start Bridge

A particular bridge can be started by following the methods given below:
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Start option in the right click context menu.
  • The color of the Bridge name’s icon and the bridge nodes’ icon change when it is started successfully, like this:
  • Right click on the name of the bridge and select Apply Configuration.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use startBridge.exe, provide the required information:
startBridge.exe demoBridge /s 20.200.21.95
  • Hit ENTER key, it will start demoBridge on server node 20.200.21.95 .
See Also
Stop Bridge | Remove Bridge | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Bridge

< Previous page Next page >

Stop Bridge

A particular bridge can be stopped by following the methods given below:
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Stop option in the right click context menu.
  • The color of the Bridge name’s icon and the bridge nodes’ icon change when it is stopped successfully, like this:
  • Right click on the name of the bridge and select Apply Configuration.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use stopBridge.exe, provide the required information:
stopBridge.exe demoBridge /s 20.200.21.95
  • Hit ENTER key, it will stop demoBridge on server node 20.200.21.95 .
See Also
Start Bridge | Remove Bridge | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Remove Bridge

< Previous page Next page >

Remove Bridge

A particular bridge can be removed by following the methods given below:
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Remove Bridge option in the right click context menu.
  • A dialogue box will appear. Click Yes to delete the bridge.
  • The bridge will be removed when Yes is clicked.
See Also
Start Bridge | Stop Bridge | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Bridge Service

< Previous page Next page >

Stop Bridge Service

Bridge service can be stopped on a particular node following the methods given below:
Using NCache Manager
  • Right click on the node under Bridge Nodes tree node of a bridge in the Cache Explorer.
  • Click on the Stop Bridge Service option in the right click context menu.
  • Bridge service will be stopped on the selected node.
See Also
Start Bridge Service | Restart Bridge Service | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Bridge Service

< Previous page Next page >

Start Bridge Service

Bridge service can be started on a particular node following the methods given below:
Using NCache Manager
  • Right click on the node under Bridge Nodes tree node of a bridge in the Cache Explorer.
  • Click on the Start Bridge Service option in the right click context menu.
  • Bridge service will be started on the selected node.
See Also
Stop Bridge Service | Restart Bridge Service | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Restart Bridge Service

< Previous page Next page >

Restart Bridge Service

Bridge service can be restarted on a particular node following the methods given below:
Using NCache Manager
  • Right click on the node under Bridge Nodes tree node of a bridge in the Cache Explorer.
  • Click on the Restart Bridge Service option in the right click context menu.
  • This stops the bridge on the given server and then starts it automatically on the same server.
See Also
Stop Bridge Service | Start Bridge Service | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring NCache

< Previous page Next page >

Monitoring NCache

NCache publishes different performance counters, provides logging for caches, cache clients, and email notifications for clustered caches. Using these options, you can monitor the caches.
In This Section
Cache Counters
Describes different counters published by NCache.
Monitoring Caches using NCache Manager
Describes how to monitor caches and clustered caches NCache manager.
Monitoring Caches using NCache Monitor
Describes how to monitor the performance, health and activity of cache servers and clients through NCache monitor.
Monitoring Bridge using NCache Manager
Describes how to monitor bridges through NCache manager.
Monitoring NCache using Windows Perfmon Tool
Explains how to monitor cache servers, clients and bridges using Windows Perfmon tool.
Logging
Explains different types of logging facilities provided by NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Counters

< Previous page Next page >

Cache Counters

NCache publishes different counters for monitoring purposes. It published its performance counters through perfmon. It also publishes some counters for debugging purposes. You can monitor NCache counters for a specific cache on any windows machine using both windows perfmon tool and monitor.
In This Section
Performance Counters
Explains NCache performance counters and how to view them.
Debugging Counters
Explains NCache debugging counters and the way to to view them.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Performance Counters

< Previous page Next page >

Performance Counters

NCache is not only enriched with powerful monitoring facilities, but besides that; it also provides different categories of
counters for windows performance monitor. This lets the clients monitor the overall performance of NCache. These
categories include cluster, client, server and bridge. They cover all aspects of NCache monitoring including remote
clients, cache clients, clustered operations, server counters, bridge queue status counters and many more.
Performance counters provide valuable information about system hardware, services, networks and applications that can be used to determine their performance. It helps in diagnosing problems, used to fine-tune systems and
applications, monitoring real-time application performance and resolving bottleneck cause of system components.
Performance counters can be seen both from Perfmon and NCache Monitor. The statistics view is also used to see the performance statistics of a cache or a cluster.
These counters include:
  • Fetches/sec: Number of Get operations per second.
  • Hits/sec: Number of successful Get operations per second.
  • Misses/sec: Number of failed Get operations per second.
  • Additions/sec: Number of Add operations per second.
  • Updates/sec: Number of Insert operations per second.
  • Deletes/sec: Number of Remove operations per second.
  • Expirations/sec: Number of items being expired currently per second.
  • Evictions/sec: Number of items evicted per second.
  • State Txfr/sec: Number of items this node is either reading from other nodes or sending to other nodes during a state transfer mode.
  • Data Bal/sec: Number of items this node is either reading from other nodes or sending to other nodes during a Data Load Balancing mode.
  • Mirror Queue Size: Number of items in the Mirror queue.
  • Average sec/fetch: Average time in seconds taken to complete one fetch operation.
  • Average sec/add: Average time in seconds taken to complete one Add operation.
  • Average sec/insert: Average time in seconds taken to complete one insert operation.
  • Average sec/remove: Average time in seconds taken to complete one remove operation.
  • Average sec/cache operation: Average time, in seconds, taken to complete one cache operation.
  • Client Request/sec: Number of requests sent by all clients to the cache server.
  • Client Response/sec: Number of responses received by all clients from the cache server.
  • Clustered opsrecv/sec: Number of clustered operations performed per second.
  • Clustered opsent/sec: Number of clustered operations performed per second.
  • Count: Number of items in the cache.
  • DispatchEnter/sec: Number of clustered operations performed per second.
  • Mirror queue size: Number of items in the Mirror queue.
  • Misses/sec: Number of failed Get operations per second.
  • Readthru/sec: Number of Readthru operations per second.
  • Response sent/sec: Number of clustered operations performed per second.
  • Responses/sec: Number of responses sent (meaning cache response for commands like add, get, insert, remove etc.) to all clients by this cache server.
  • State transfer/sec: Number of items this node is either reading from other nodes or sending to other nodes during a state transfer mode.
  • Writethru/sec: Number of Writethru/Writebehind operations per second.
  • CacheLastAccessCount: Number of items which are older then the access interval specified in the config.
  • Cluster ops/sec: Number of clustered operations performed per second.
  • Bytes sent/sec: How much data is sent from this node to other nodes in the cache.
  • Bytes received/sec: How much data is received by this node from other nodes in the cache.
  • Requests/sec: Number of requests (meaning cache commands like add, get, insert, remove etc.) being processed from all clients by this cache server.
  • Client bytes sent/sec: Bytes being sent from cache server to all its clients.
  • Client bytes received/sec: Bytes being received by cache server from all its clients.
  • Response Queue Count: Number of items in response queue; all responses are queued in the response queue before being sent.
  • Response Queue Size: Size of the response queue in bytes. Is displays the total data size of all the responses in the response queue.
  • Event Queue Count: Number of events in the event queue.
  • Events Processed/sec: Number of events processed per second on a client.
  • Events Triggered/sec: Number of events triggered and received by client per second.
  • Average ms/event: Average time taken by client to process a single event.
You can select different counters to be displayed in 'Cluster Performance Test Bed' to analyze cluster performance through Options Dialog. You can enable Performance Counters for both Local and Clustered Caches from Options Tab of their view window.
See Also
Debugging Counters | Monitoring Caches using NCache Manager | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Debugging Counters

< Previous page Next page >

Debugging Counters

Debugging counters are installed for debugging purposes. These counters include:
  • Socket send time (sec): Time in milli seconds taken to send a request.
  • Socket send size (bytes): Bytes sent per second.
  • Socket recv time (sec): Time in milli seconds taken to receive a request.
  • Socket recv size (bytes): Bytes received per second.
  • Naggling msg count: How many messages were sent together in socket.send.
  • TcpUpQueueCount: Number of items in TCP up queue.
  • TcpDownQueueCount: Number of items in TCP down queue.
  • TcpdownEnter/sec:.
  • BCastQueueCount: Number of items in BCast Queue.
  • MCastQueueCount: Number of items in MCast Queue.
Debugging counters are disabled by default and can be enabled by adding following key-value pair in ' alachisoft.ncache.service.exe.config ' file.
<key="EnableDebuggingCounters" value="true"/>
See Also
Performance Counters | Monitoring Caches using NCache Manager | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Caches using NCache Manager

< Previous page Next page >

Monitoring Caches using NCache Manager

NCache Manager is a tool to manage the caches and bridge, but it also provides the basic monitoring for the caches. In this way, you are able to manage and monitor your caches at a single place. Using NCache Manager, you can also configure the different monitoring settings. The sub sections provide an overview of how to configure these settings.
In This Section
Changing Management Port of a Cache Node
Explains how to change the default management port of a cache node.
Configuring Counters to Display
Explains how to select the counters to be displayed.
Fetching the Statistics using Server IP or Server Name
Gives user the option to fetch statistics using either server IP or server name.
Cluster Health
Explains how to view a cache cluster's health.
Monitoring Cache Clusters using NCache Email Alerts
Explains how to monitor the cache clusters using NCache Email Alerts.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Changing Management Port of a Cache Node

< Previous page Next page >

Changing Management Port of a Cache Node

All performance and connectivity related data is fetched using a particular port called NCache Management Port. Default value of this port is 8250 but it is configurable using NCache Manager.
Using NCache Manager
  • Open NCache Manager.
  • Go to Tools menu option.
  • Select Options and a dialog box appear with Statistics, Management and Startup tabs. Go to the Management tab.
  • Type any value within your system’s port range and make sure that the port is free. Click OK.
See Also
Configuring Counters to Display | Fetching the Statistics using Server IP or Server Name | Cluster Health | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Counters to Display

< Previous page Next page >

Configuring Counters to Display

By Default, a few important counters are displayed in statistics window but you can add/remove more counters according to
your requirements.
Using NCache Manager
  • Open NCache Manager.
  • Go to Tools menu option.
  • Select Options and a dialog box appear with Statistics, Management and Startup tabs. Go to the Statistics tab.
  • All performance counters are displayed in this tab in categorical view; you can select/deselect counters from this tab.
  • Click OK to save your selection.
See Also
Changing Management Port of a Cache Node | Fetching the Statistics using Server IP or Server Name | Cluster Health | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Fetching the Statistics using Server IP or Server Name

< Previous page Next page >

Fetching the Statistics using Server IP or Server Name

Statistics data is fetched in either of two ways, using server name or server IP. This option is configurable. By default
NCache use the server name to fetch the performance counters from servers.
Using NCache Manager
  • Open NCache Manager.
  • Go to Tools menu option.
  • Select Options and a dialog box appear with Statistics, Management and Startup tabs. Go to the Statistics tab.
  • In this tab, under Statistic Options, there is an option Fetch statistics using with two radio buttons Server Name and IP Address.
  • Choose the required option and click OK to save your selection.
See Also
Changing Management Port of a Cache Node | Configuring Counters to Display | Cluster Health | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cluster Health

< Previous page Next page >

Cluster Health

You can view cluster health using NCache Manager. Cluster health shows the connection status of each server in cache cluster. There are three types of Status:
  • Fully Connected: The cache is running and all server nodes are connected with each other.
  • Partially Connected: The cache is running but not all server nodes are connected with each other.
  • Cache Stopped: The cache is running but the server with this status is stopped.
Using NCache Manager
  • Right click on the cache name under Clustered Caches tree node in Cache Explorer view to bring up the context menu.
  • Select View Cluster Connectivity option. Cluster Connectivity dialog box appears.
This screenshot shows the cluster connectivity of a two node clustered cache, one server is running and the other is stopped.
  • Click Close to dismiss the dialog.
See Also
Changing Management Port of a Cache Node | Configuring Counters to Display | Fetching the Statistics using Server IP or Server Name | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Cache Clusters using NCache Email Alerts

< Previous page Next page >

Monitoring Cache Clusters using NCache Email Alerts

NCache also provides the Email Alerts (notifications) for different cache activities. You can choose the required (few or all) events for which you want to receive the email alerts from NCache, so that you remain fully aware what is going on. And in case of any serious issue, you can manage the cache accordingly.
  • Configure the Email Alerts for a cache using NCache Manager. Follow the steps in Configuring Email Notifications section to configure the NCache Email Alerts.
  • Stop the cache for which you have configured email alerts.
  • Now check your email which you have provided for receiving email from NCache. You will see the an email from NCache with contents like this:
See Also
Changing Management Port of a Cache Node | Configuring Counters to Display | Fetching the Statistics using Server IP or Server Name | Cluster Health | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Caches using NCache Monitor

< Previous page Next page >

Monitoring Caches using NCache Monitor

Clustered caches can be monitored to view performance counters in live visual graphs using NCache Monitor shipped with NCache Enterprise edition. In NCache Monitor, we have two types of dash boards; Graphical and Report View.
  • Graphical View
In graphical dashboards, counters are shown in the form of graphs with respect to time. Counter value will be plotted along y-axis and time on x-axis. Graphical dashboards are helpful in the scenarios where you want to monitor cache for some specific time.
  • Report View
In report view dashboards, counter are shown in the form of numeric values. Report view dashboards are helpful in the scenarios when you want to monitor instantaneous performance of NCache.
In This Section
Monitoring Cache Server Counters Using Built-In Dashboard
Explains how to use NCache monitor's built-in dashboard to monitor cache server counters.
Monitoring Cache Client Counters Using Built-In Client Dashboard
Explains how to use built-in client dashboard in NCache monitor to monitor cache client counters.
Monitoring Cache Cluster Counters Using Custom Dashboard
Describes how to use custom dashboard NCache monitor to monitor cache cluster counters.
Monitoring Perfmon Counters Using Custom Dashboard
Explains how to monitor perfmon counters through custom dashboard in NCache monitor.
Monitoring Cache Event Logs Using Custom Dashboard
Explains how to observe and monitor cache event logs using custom dashboard.
Monitoring Client Process of a Clustered Cache Using Custom Dashboard
Explains how to observe and monitor client process of a cache cluster using custom dashboard.
ASP.NET Session Monitoring Using Custom Dashboard
Explains how to monitor ASP.NET sessions through custom dashboard.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Cache Server Counters Using Built-In Dashboard

< Previous page Next page >

Monitoring Cache Server Counters Using Built-In Dashboard

There are two major categories of performance counters; Server counters and Client counters. This section describes how to monitor server counters using built-in dashboard.
Launch NCache Monitor using NCache Manager
  • Right click on the clustered cache name under Clustered Cached tree node in Cache Explorer context menu.
  • Select Monitor Cluster option from the right click menu.
  • NCache monitor is opened. By default there are two dashboards already opened,
  • Server Dashboard
  • Report-View Dashboard.
Both default dashboards are non-editable. It means no counter or graph can be added or removed from default dashboards.
  • Select Monitor Cluster option from the right click menu.
Server Dashboard
It contains Cluster Health, Event Logs along with some mostly required cache counter graphs like, NCache CPU Graph, NCache Network Graph, Cache Size, NCache Request/sec Graph and NCache Memory Graph etc. Server Dashboard is generally a graphical view dashboard.
Report View Dashboard
This view shows counters in numeric form rather than graphs. It contains two portions, each for Server Report View
and Client Report View. Both portions contain respective counters.
See Also
Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Cache Client Counters Using Built-In Client Dashboard

< Previous page Next page >

Monitoring Cache Client Counters Using Built-In Client Dashboard

NCache Monitor also provides built-in dashboard named as Client Dashboard. This dashboard has all required
counters/graph in it for the clients’ performance monitoring. It can be viewed for monitoring as follows:
  • Click on the View menu of the NCache Monitor and click on the Client Dashboard menu option.
  • Client Dashboard appears and it consist of different client side graphs.
This built-in dashboard displays different client side counters. Few of the counters display the NCache client system resource usage info like NCache Client CPU, NCache Client Memory, NCache Client Network. This dashboard also shows the NCache client specific information like NCache Client Request Queue, NCache Client Read Operations/sec, NCache Client Write Operations. It also shows the ASP.NET session counters like ASP.NET Requests/sec, ASP.NET Pending Queue/sec, ASP.NET Total Sessions.
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Cache Cluster Counters Using Custom Dashboard

< Previous page Next page >

Monitoring Cache Cluster Counters Using Custom Dashboard

You can also add a custom dashboard to place the required counters on it for the monitoring using NCache Monitor.
  • Click on the File menu of the NCache Monitor.
  • Create Dashboard Wizard appears. Provide Dashboard Name and select the Dashboard Layout (Graphical or Report View). Click Next.
  • Select number of rows and column for this dashboard and click on the Finish button.
  • New dashboard Dashboard1 is created with specified number of rows and columns.
  • Now drag and drop the required counters from Cache Server category or from Cache Client category that exists in the Toolbox available on the left side of NCache Monitor.
The custom dashboard after placing different server and client counters on it will look similar to this:
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Perfmon Counters Using Custom Dashboard

< Previous page Next page >

Monitoring Perfmon Counters Using Custom Dashboard

Performance Monitor is Microsoft Windows tool that can be used within NCache Monitor custom dashboards just like
other NCache custom controls. Follow the steps given below to add perfmon control in a custom dashboard:
  • Go to the Toolbox, available on the left side inside NCache Monitor.
  • Click on the Cache Server button on the Toolbox.
  • Select the perfmon control; drag and drop it in any cell inside a custom dashboard.
  • Now you can add the required NCache counters in it or any other perfmon based counters. Click on the green plus button, select the required server machine and then choose the required perfmon counters.
  • More details on Perfmon can be found at Using Performance Monitor .
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Cache Event Logs Using Custom Dashboard

< Previous page Next page >

Monitoring Cache Event Logs Using Custom Dashboard

Event Logs control displays log entries specific to cache. NCache logs multiple events’ information (Node left, Node Joins, Cache Started, Cache Stopped etc) in windows event logs. Using this control, you can monitor all of the cache events in a single place. Details of these events along with date time can be monitored using Event Logs control.
Double click on any log entry to open it with full details in new window, like this:
You can also add any other event source which publishes events in windows event logs using the NCache Monitor ‘Event logs’ control. Please follow the steps given below to add any other event source for monitoring in NCache Monitor Event Log control:
  • Click on the Tools ->Options in NCache Monitor.
  • A dialog box will open up. Click on the Event Log option in the left side menu.
  • Specify the name of the Event source (any application or service that publishes events logs). Click Add.
  • Click OK to save the changes. Now NCache Monitor starts event log monitoring for this newly added event source too (along with all of the previously added event sources).
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Client Process of a Cache Cluster Using Custom Dashboard

< Previous page Next page >

Monitoring Client Process of a Cache Cluster Using Custom Dashboard

Client Process control shows details of running client applications against current cache. Details include client IP, process ID, port, server IP with which this client application is connected and Sent/Received bytes by each client.
Follow the steps given below to add Client Process control in a custom dashboard:
  • Go to the Toolbox, available on the left side inside NCache Monitor.
  • Click on the Cache Server button on the Toolbox.
  • Select the Client Process control; drag and drop it into any cell inside a custom dashboard.
Information of all the currently connected clients displayed in Client Process control for current cache.
  • Client processes can be grouped using any column. Drag and drop a column header on Drag a column header here to group by that column. Below image is an example of grouping by Server IP field.
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: ASP.NET Session Monitoring Using Custom Dashboard

< Previous page Next page >

ASP.NET Session Monitoring Using Custom Dashboard

Using NCache Monitor you can also monitor the ASP.NET session counters. Currently you can monitor the ASP.NET Requests/sec, ASP.NET Pending Requests and ASP.NET Total Session counter in NCache Monitor. Controls for these counters exist in Toolbox under Cache Client category.
Just drag and drop these controls in a custom dashboard, and NCache Monitor starts fetching the values of these counters.
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Caches Using NCache Monitor | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Bridge Using NCache Manager

< Previous page Next page >

Monitoring Bridge Using NCache Manager

Bridge is used to synchronize caches across the WAN. Bridge can be monitored using NCache Manager and NCache Monitor.
In This Section
Configuring Bridge Counters to Display
Explains how to configure cluster counters connected to Bridge.
Browse Bridge Statistics
Explains how to view and monitor statistics of a Bridge.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Bridge Counters to Display

< Previous page Next page >

Configuring Bridge Counters to Display

By default, a few important counters are displayed in statistics window but you can add/remove cluster counters connected to bridge according to your requirements.
  • Go to Tools menu of NCache Manager.
  • Select Options menu and a dialog box appears with Statistics, Management and Startup tabs. Go to the Statistics tab.
  • Check the Show counters of Caches connected with bridge checkbox.
  • Click OK.
See Also
Configuring Bridge for WAN Replication | Browse Bridge Statistics | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Cache Counters | Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Browse Bridge Statistics

< Previous page Next page >

Browse Bridge Statistics

To view statistics of a bridge, follow the steps given below.
  • Right click on the bridge name under the Bridges tree node in Cache Explorer to bring up context menu.
  • Click on the Statistics option. It opens statistics tab for this bridge in the right pane.
  • You can also choose the Statistics in New Window option from the right click context menu. It opens statistics for this bridge in a new window instead of a tab.
See Also
Configuring Bridge for WAN Replication | Configuring Bridge Counters to Display | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring NCache Using Windows Perfmon Tool

< Previous page Next page >

Monitoring NCache Using Windows Perfmon Tool

NCache publishes its performance counters through perfmon. You can monitor NCache counters for a specific cache on any windows machine using windows perfmon tool.
In This Section
Monitoring Cache Server Counters using Perfmon Tool
Explains how to view and monitor all the counters related to cache server through Perfmon tool.
Monitoring Cache Client Counters using Perfmon Tool
Explains how to view and monitor all the counters related to cache client through Perfmon tool.
Monitoring Bridge Counters using Perfmon Tool
Explains how to view and monitor all the counters related to bridge through Perfmon tool.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Cache Server Counters Using Perfmon Tool

< Previous page Next page >

Monitoring Cache Server Counters Using Perfmon Tool

NCache publishes cache server counters in perfmon under category NCache. This category has all the counters related to the cache server. Follow the steps given below to monitor the NCache counters through perfmon tool:
  • Press WINDOWS + R keys on your keyboard OR click on the windows start menu and then type perfmon and press ENTER key.
  • Perfmon tool opens up. Click on the Performance Monitor under Monitoring Tools.
  • Click on the cross (X) button to remove the default counter which is already added in it. Then click on the plus (+) button to open the Add Counters dialog box.
  • Using the vertical slider of available counters list box, scroll upward to find NCache category.
  • Click on the down arrow head icon to expand the NCache category. All of its counters are listed under it. Select the required counters from this list like this:
  • All of the current running caches (and replicas of caches) appear inside of Instances of selected objects list box. Select the required instance or simply click on the <All instances> and click on the Add >> button. All of the selected counters for all the selected instances of caches appear in Added counters list box on the right side.
  • Click OK. All of the selected counters will appear in perfmon tool like this:
You can also change the view of perfmon from Report view to Line view. Follow the steps given below:
Click on the Line option of the drop down menu. This changes the perfmon view from Report to Line. In Line view, counters values are displayed in the form of continuous graph, like this:
See Also
Monitoring Cache Client Counters Using Perfmon Tool | Monitoring Bridge Counters Using Perfmon Tool | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Logging | Configuring Caches | Cache Counters
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Cache Client Counters Using Perfmon Tool

< Previous page Next page >

Monitoring Cache Client Counters Using Perfmon Tool

NCache publishes cache client counters in perfmon under the category NCache Client. This category has all the counters
related to the cache client. Follow these steps to monitor the NCache client side counters through perfmon tool:
  • Press WINDOWS + R keys on your keyboard OR click on the windows start menu and then type perfmon and press ENTER key.
  • Perfmon tool opens up. Click on the Performance Monitor under Monitoring Tools.
  • Click on the cross (X) button to remove the default counter which is already added in it. Then click on the plus (+) button to open the Add Counters dialog box.
  • Using the vertical slider of available counters list box, scroll upward to find NCache client category.
  • Click on the down arrow head icon to expand the NCache Client category. All of its counters are listed under it. Select the required counters from this list like this:
  • All of the current running caches for which clients are running appear inside of Instances of selected objects list box. Select the required instance or simply click on the <All instances>, and click on the Add >> button. All of the selected counters for all the selected instances of caches appear in Added counters list box (exist on the right side).
  • Click OK. All of the selected counters will appear in perfmon tool like this:
See Also
Monitoring Cache Server Counters Using Perfmon Tool | Monitoring Bridge Counters Using Perfmon Tool | Browse Bridge Statistics | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Cache Counters | Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Monitoring Bridge Counters Using Perfmon Tool

< Previous page Next page >

Monitoring Bridge Counters Using Perfmon Tool

NCache publishes bridge counters in perfmon under category NCacheBridge. This category has all the counters related to the bridge. Follow these steps to monitor the NCache bridge counters through perfmon tool:
  • Press WINDOWS + R keys on your keyboard OR click on the windows start menu and then type perfmon and press ENTER key.
  • Perfmon tool opens up. Click on the Performance Monitor under Monitoring Tools.
  • Click on the cross (X) button to remove the default counter which is already added in it. Then click on the plus (+) button to open the Add Counters dialog box.
  • Using the vertical slider of available counters list box, scroll upward to find NCache Bridge category.
  • Click on the down arrow head (icon) to expand the NCache Bridge category. All of its counters are listed under it.
  • All of the current running instances of bridge appear inside of Instances of selected objects list box. Select the required instance or simply click on the <All instances>, and click on the Add >> button. All of the counters that were selected in step 5 for all the selected instance of caches appear in Added counters list box on the right side.
  • Click OK. All of the selected counters will appear in perfmon tool like this:
See Also
Monitoring Cache Server Counters Using Perfmon Tool | Monitoring Cache Client Counters Using Perfmon Tool | Browse Bridge Statistics | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Cache Counters | Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Logging

< Previous page Next page >

Logging

NCache provides a rich set of modules for logging run-time statistics of different components available in NCache. And, also provides different level of logging that includes log-files, report views, statistics and events. NCache presents the
following mechanisms to logging from different perspective to analysis NCache independently.
  • NCache Monitor Logging
  • Support for PerfMon Logging
  • Support Windows Event Logging
  • File based Logging (log-files)
  • Client API Logging
  • Details Logging (client app/webs or socket server)
  • Email Notifications on NCache Events
In This Section
NCache Monitor Logging
Explains the logging facilty provided by NCache Monitor.
Performance Counters Logging
Explains how to view performance counters using Report View in NCache Monitor.
Windows Event Logging
Explains the Windows events logging provided by NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Monitor Logging

< Previous page Next page >

NCache Monitor Logging

NCache Monitor also provides the logging functionality for different server and client counters with the help of Report View dashboard. Server counters of 'Server Report View' and Client counters of 'Client Report View' can be logged independently.
NCache Monitor Report view also provides the functionality to schedule logging, where the start and stop timings of logging counters can be specified.
Run-time statistics of all counters specified in the specific report view panel, are logged in files of .csv format. Default path of these files is different for server and client counters as:
  • 'Server Report View' panel counters are logged in :
%InstalledDirectory%\log-files\NCacheMonitor\Server\
  • 'Client Report View' panel counters are logged in :
%InstalledDirectory%\log-files\NCacheMonitor\Client\
This logged data can be used for later evaluation of cache cluster and clients performance and health.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | Windows Event Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Performance Counters Logging

< Previous page Next page >

Performance Counters Logging

Using Report-View you can instantly monitor performance but you can also log these counters in a csv file. All the counter values which are currently in dashboard will be logged into a .CSV file after each second. You can start the performance counters logging instantly or you can schedule the logging on a specific time.
Manual Logging
Follow the below given steps to log the counters using NCache Monitor:
  • Go to the Report-View Dashboard (built-in Report-View dashboard or your created dashboard).
  • Click on the Start Logging button icon exist on the report view control. This starts the logging.
  • Log file can be found under %NCHOME%/log-files/NCacheMonitor
  • You can stop the performance counter logging on clicking on the Stop Logging icon in the Report-View Dashboard.
Schedule Logging
Rather than manually starting and stopping logging you can also schedule logging. This way you can obtain logging data for a particular period of time.
  • Click on the Schedule Logging icon in Report-View dashboard.
  • Schedule Logging dialog box appears. Check the Log counters at the following schedule check box and configure the Start Time and Stop Time.
  • Click OK. Logging will start at the specified time automatically. Schedule logging only works if NCache Monitor is started during specified schedule time.
See Also
Monitoring Caches using NCache Monitor | NCache Monitor Logging | Windows Event Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Windows Event Logging

< Previous page Next page >

Windows Event Logging

NCache provides support to view events in Windows Event Log. NCache logs its important events in Window Event Logs. This allows monitoring all such events through Windows Event Viewer or with any other tool that support Window Event Logger. Some of the events that are logged include:
  • All NCache installation events. These events are combination of successful or aborted installation.
  • All errors encountered by NCache, Bridge and Memcache services.
  • Service start and stop events
  • Cache start and stop
  • Cache server joining or leaving a cache cluster
  • Cache size going above a configurable 80% threshold
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Email Notifications on NCache Events

< Previous page Next page >

Email Notifications on NCache Events

NCache provides built-in facility to notify about events information via Email Notifications. This feature notifies the user via email and also updates about events which are invoked by NCache, from anywhere around the world. NCache raises events whenever any of the following happens.
  • Cache is started or stopped.
  • Cache server joining or leaving the cluster.
  • Cache state transfer is started and completed.
  • Cache size going above configurable 80% threshold.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging | Cache Server Logging | Client Side API Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Server Logging

< Previous page Next page >

Cache Server Logging

Another feature provided by NCache is logging different states of clustered, client, bridge caches into different log files. These log files are created whenever cache starts and are locked until cache changes its status to stop or whenever the service stops. Log files encapsulate different level of information based on logging status.
NCache creates each log file for particular cache with different time span. This time initializes as cache starts and continues until cache status changes from running to stopped. NCache writes log file with default format that gives user a readable format. It also logs thread name whenever an operation is performed by any running thread. NCache presents different stages of logging. These logging level are configurable and are described as follows:
  • Info Level: Info level describes some useful information about any operation performed on cache, such as log starting and stopping state of state transfer operations. Info level is disabled by default.
  • Error Level: This log flag gives the cause of errors that are raised during operation execution. This status log is useful in most of troubleshooting scenarios such as during start of cache exception which occurs for joining with its own replica.
  • Critical Level: This flag logs the critical status of any action or operation on cache, such as “cache exceeds its memory limits”. This log information is useful to optimize cache performance and is the most high priority logs among all log-file information.
  • Detail Debug Level: This flag is disabled by default but the user can configure it. This log option prints detailed information about any operations in cache such as information of each operation like key, cache items during state transfer. This log information is useful to analysis cache issues in details whenever normal debugging is not possible and drilling any hidden issue. But this cause performance degradations for cache operations.
NCache also provides logging for client application and socket level by configurations options. These options are disable by defaults, but they can be enabled changing settings of app/web files. These logs are created into defaults location where NCache logs are saved. These logs contain information of client operations and also usage data of operations propagate through socket server to communicate with remote server.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging | Cache Server Logging | Client Side API Logging
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Side API Logging

< Previous page Next page >

Client Side API Logging

NCache Client Side API Logging is a diagnostic feature which logs all NCache API calls made by an application. This is a configurable logging mechanism that creates several log files. The purpose of API logging is to identify which API and the its sequences cause the problem, so that problem can be reproduced easily at user’s end. Client API logging saves appropriate overload of the method called along with key, data size, cache status, encryption and compression information.
API logging has a performance impact it is recommended to enable the logging only for diagnostic purposes.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging | Cache Server Logging | Email Notifications on NCache Events
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Programmer's Guide

< Previous page Next page >

Programmer's Guide

This section provides a practical guide for programmers who want to use various features of NCache in .NET to develop high performance and scalable applications. It provides four different sets of features for programming with NCache. In order to use NCache API in .NET applications, following things are required to be done:
  • For .NET applications, you must add reference to the 'Alachisoft.NCache.Web.Caching.dll' in your application. This assembly contains all the APIs which are required to connect to the server and use cache. This assembly is copied into the install directory of NCache, by default it is in "%INSTALL_DIR%/NCache/bin/assembly/
  • Client API also requires the server list generated from NCache Manager. For this purpose, client configuration file must be placed in NCache install directory. The Client Configuration file is updated whenever you apply configurations to the cache. Information for compact data types is also generated as part of ( config.ncconf ), if the cache is registered with any Compact Serializable data type.
In This Section
Client Side API Programming
Provides a practical guide for client side features.
Server Side API Programming
Provides a practical guide for server side features.
Client Side ASP.NET Features
Demonstrates the use and capabilities of client side ASP.NET features.
Client Side Third Party Integrations
Demonstrates the use and capabilities of client side Third Party Integration tools.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Side API Programming

< Previous page Next page >

Client Side API Programming

This tutorial is a practical guide for programmers who want to utilize powerful features of Client side NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
Setting Up Development Environment
Explains the steps to set up the development environment for using NCache API.
Using Basic Cache Operations
Explains how to perform basic operations like initialize, add or remove data etc on cache.
Bulk Operations
Describes performing bulk operations to add, insert or remove collection of items in a single method call. It helps speeding up the process and minimizes cluster traffic.
Asynchronous Operations
Explains utilizing notifications that arise as a result of add, insert or remove operations against all or selective cache items, or when cluster status changes.
Group/Subgroup
Presents distributing related objects in 'logical' groups.
Tags
Explains how Tags work.
Named Tags
Explains how Named Tags work.
Data Invalidation Strategies
Describes how certain cached items can be automatically removed from the cache when required.
Cache Dependencies
Explains how to implement dependency of cached items on files, database table rows and other cached items.
Locking
Describes how to lock cached items to prevent multiple clients from updating the same data simultaneously.
Object Query Language in NCache
Presents search API for querying objects from the cache using SQL like syntax.
Event Notifications
Explains utilizing notifications that arise as a result of add, insert or remove operations against all or selective cache items, or when cluster status changes.
Continuous Query
Explains how Continuous Query work.
Streaming
NCache provides you the facility of Streaming. Using streaming NCache binary data can be read or written from/to the cache using streams.
Security and Encryption
Explains different levels of cache security provided by NCache.
Data Compression
Explains the data compression feature provided by NCache to minimize the data traffic between cluster and client nodes and efficiently using the memory.
NCache Management API
Explains how to use the API provided by NCache to perform the basic cache management operations without using either NCache Manager or NCache tools.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Setting Up Development Environment

< Previous page Next page >

Setting Up Development Environment

  1. Open File-> New -> Project.
  2. Select a Console Application from range of generic templates.
  3. Specify the Name for the Application.
  4. Specify the appropriate Location to save a project.
  5. Click OK button to create a new project.
  6. Add the following reference in your application to start working with NCache, as shown in the figure below: Alachisoft.NCache.Web.
  7. Select the reference from the list of references as shown below:
  8. Add the following namespace in your application:
using Alachisoft.NCache.Web.Caching;
See Also
Caching Concepts | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features | Client Side Third Party Integrations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Basic Cache Operations

< Previous page Next page >

Using Basic Cache Operations

NCache provides a very user friendly API for performing basic cache operations This section explains how to perform these operations on cache. They include:
  • Initialize Cache
  • Add/Update Data to Cache
  • Fetch or Remove Data from Cache
  • Dispose Cache
In This Section
Initialize Cache
The cache needs to be initialized before performing any other operation on it. This section explains how to use NCache Client API for initializing cache.
Add/Update Data to Cache
Explains how to add or update any data on cache using NCache Client API.
Fetch Data from Cache
Explains how to retrieve data from cache based on different criteria using NCache Client API.
Remove Data from Cache
Explains how to delete data from cache using NCache Client API.
Dispose Cache
Explains how to destroy the cache instance once you are done using it.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Initialize Cache

< Previous page Next page >

Initialize Cache

After you have configured the cache, embed NCache API calls in your application to use it. The first thing you need to do is to initialize the cache. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Basic Initialize Method
This method is the simplest provided by NCache to Initialize a cache. It uses all properties specified in the client configuration file to Initialize.
Cache cache=null;
try
{
cache = NCache.InitializeCache("mycache");
}
catch (Exception ex)
{
//handle exception
// Possible Exceptions:
//1. No server available to process the request
//2. client.ncconf does not contain current cache information
}
Initializing Multiple Caches in a Single Application
For this exercise, both caches need to be configured previously and they must be in running state.
Cache cache1 = null;
Cache cache2 = null;
try
{
cache1 = NCache.InitializeCache("mycache");
cache2 = NCache.InitializeCache("myreplicatedcache");
}
catch (Exception ex)
{
//handle exception
}
Initializing InProc Cache
Initializing an in-proc cache is similar to initializing an OutProc cache except the fact that the InProc cache is not started.
Cache cache = null;
// Assumption: Cache ID has already been registered and running
try
{
cache = NCache.InitializeCache("myLocalCache");
}
catch (Exception exp)
{
//handle exception
}
Initializing Cache using CacheInitParams
InitParams allows editing values of the properties at initialization time. In this example, the values of RetryInterval and ConnectionRetries properties can be changed; for this application these values will be used instead of the ones specified in client configuration files.
Cache cache = null;
try
{
// Create new InitParam instance
CacheInitParams initParam = new CacheInitParams();
initParam.RetryInterval = 3;
initParam.ConnectionRetries = 2;
cache = NCache.InitializeCache("mycache", initParam);
}
catch (Exception exp)
{
// handle exception
}
Initializing Remote and Client Cache Simultaneously
In case client cache is configured using NCache manager basic public static Cache InitializeCache (string cacheId) call would initialize both remote cache and client cache.
If separate calls are made for both caches the local cache does not behave as a client cache instead it remains a separate local cache. In order to use an existing local cache as a client cache instead of making separate Initialization calls, we recommend that you use.
public static Cache InitializeCache(string remoteCacheId, string clientCacheId);
This API would return handler of the remote cache synchronizing all operations of the client cache.
Cache cache = null;
try
{
cache = NCache.InitializeCache("myRemoteCache", "myClientCache");
}
catch (Exception ex)
{
// handle exception
}
Similarly use following API to Initialize remote and client caches with CacheInitParams.
public static Cache InitializeCache(string remoteCacheId, CacheInitParams remoteInitParams, string clientCacheId, CacheInitParams clientInitParams);
See Also
Creating Caches | Add/Update Data to Cache | Fetch Data from Cache | Remove Data from Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Add/Update Data to Cache

< Previous page Next page >

Add/Update Data to Cache

After successful initialization of cache and gaining valid cache handle, Add operation can be performed. Add is the basic operation provided by NCache; data can be added/updated to the cache using multiple API calls.
  • Key-Value Cache Store
NCache has a basic “key” and “value” structure for objects. Every object must have a unique string key associated with it. Every key has an “Atomic” occurrence in cache be it local or clustered. Even though cached keys are case sensitive in nature; if the user tries to add another key with same value an Operation failed Exception is thrown by the cache.
  • Custom Objects
The data to be used must be .NET serializable otherwise NCache will throw a serialization exception. Data can also be added directly as value property of CacheItem class; internally data is saved as a CacheItem.
Additionally, NCache Dynamic Compact Serialization framework for custom objects can also be used. This custom framework results in cost effective serialization of registered classes.
NCache returns CacheItemVersion with every add/Insert call; in these examples, we have ignored CacheItemVersion.
Adding Objects to Cache
In order to add data in cache it must be ensured that the object is either .NET serialized or registered with NCache Compact serialization framework. In this example, a new object of Product class is created and added to cache.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, product);
}
catch (OperationFailedException ex)
{
// handle exception
// usually thrown if key already exist in cache
// however verify the failure reason
}
Update Objects in Cache
Similarly in order to update data previously added in cache, it must be ensure that the object is either serialized. In this example, a new object is added with an existing key.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 5; // updated units
string key = "Product:" +product.ProductID ;
try
{
//precondition: Cache is already initialized and item exists
cache.Insert(key, product);
}
catch (OperationFailedException ex)
{
// handle exception
}
Adding Objects Using Cacheitem
Similarly in order to update data previously added in cache, it must be ensure that the object is either serialized. In this example, a new object is added with an existing key.
CacheItem is a custom class provided by NCache which can be used to add data to the cache. This class encapsulates data as its value property. CacheItem also lets you set additional specifications associated with an object as properties of this class.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
For the remaining API usage, kindly refer to the relevant NCache features.
Updating Objects Using Cacheitem
In this example, a key is updated that has already been exisiting in cache with object set as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 5; // updated units
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
try
{
cache.Insert(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
Updating Data Using Cache Indexer
NCache being a key-value paired structure lets the user perform operations like any other indexed based data structure. In this example a cache handle is used to directly access and update cache values using square brackets ”[]”.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 5; // updated units
string key = "Product:" +product.ProductID ;
try
{
cache[key]=product;
}
catch (OperationFailedException ex)
{
//handle exception
For the remaining API usage, kindly refer to the relevant NCache features.
See Also
Creating Caches | Initialize Cache | Fetch Data from Cache | Remove Data from Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Fetch Data from Cache

< Previous page Next page >

Fetch Data from Cache

Primarily a cache is only considered as effective as its ability to retrieve data. NCache utilizes the key-value architecture of its store to maximize the ways of data retrieval. Get method is the primary API provided to serve previously cached data; however basic indexer approach can also be used. Both of these methods are explained below.
Retrieve Data using Get Method
In this example, the basic Get method is used to retrieve item “Product:1001”. This item has previously been added to the cache. Get method returns general object which needs to be casted accordingly. If a key does not exist in cache null value is returned.
string key = "Product:1001";
Product product = null;
try
{
//null is returned if key does not exist in the cache.
object result = cache.Get(key);
if (result != null)
{
if (result is Product)
{
product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieve a CacheItem
In this example, the basic GetCacheItem method is used to retrieve item “Product:1001”. This item has been added to the cache. This method returns CacheItem whose value property encapsulates the data; the Object value need to be cast accordingly.
string key = "Product:1001";
Product product = null;
try
{
CacheItem result = cache.GetCacheItem(key);
if (result != null)
{
if (result.Value isProduct)
{
product = (Product)result.Value;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
/ handle exception
}
Retrieve Data with Cache Indexer
NCache being a key-value paired structure lets the user perform operations like any other indexed based data structure. In this example a cache handle is used to directly access cached values using square brackets ”[]”.
string key = "Product:1001";
Product product = null;
try
{
CacheItem result = cache.GetCacheItem(key);
if (result != null)
{
if (result.Value isProduct)
{
product = (Product)result.Value;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
/ handle exception
}
Retrieve Data with Cache Indexer
NCache being a key-value paired structure lets the user perform operations like any other indexed based data structure. In this example a cache handle is used to directly access cached values using square brackets ”[]”.
string key = "Product:1001";
Product product = null;
try
{
object result = cache[key];
if (result != null)
{
if (result is Product)
{
product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception }
Check If an Item Exists in Cache
In order to verify if a key exists in the cache or not, the contains method can be used. This method determines whether cache contains the specific key and returns true if key already exist in cache and false if not.
string key = "Product:1001";
try
{
if (cache.Contains(key))
{
// do something
}
else
{
// do something
}
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Creating Caches | Initialize Cache | Add/Update Data to Cache | Remove Data from Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Remove Data from Cache

< Previous page Next page >

Remove Data from Cache

Deleting item(s) from the cache is also considered as one of the basic operations. NCache primarily provides two methods to delete an item from cache. These are:
  • Delete
  • Remove
Difference between Delete and Remove methods
delete | remove
Returns nothing after deletion. | Deletes data from the cache and returns deleted data to the application.
Using Remove Method
A remove method is a basic method which removes the key from the cache and returns the removed object to the cache.
string key = "Product:1001";
Product product = null;
try
{
// null is returned if key does not exist in cache
object result = cache.Remove(key);
if (result != null)
{
if (result is Product)
{
product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Using Delete Method
A delete method is a basic method which deletes the key from the cache.
string key = "Product:1001";
try
{
cache.Delete(key);
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Creating Caches | Initialize Cache | Fetch Data from Cache | Add/Update Data to Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Dispose Cache

< Previous page Next page >

Dispose Cache

After you are done using the cache, you can dispose it. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
The code for disposing the cache is as follows:
Cache _cache = NCache.Caches["mycache"];
// Dispose the cache
_cache.Dispose();
Disposing the cache in ASP.NET Applications
If you're developing ASP.NET application, the best place to put Dispose() call is in your HTTP Application's Dispose() method. This method is called when the instance of your HTTP Application is destroyed.
public virtual void Dispose()
{
Cache _cache = NCache.Caches["mycache"];
// Dispose the cache
_cache.Dispose();
}
See Also
Creating Caches | Initialize Cache | Fetch Data from Cache | Remove Data from Cache | Add/Update Data to Cache | Bulk Operations | Start Cache | Stop Cache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Bulk Operations

< Previous page Next page >

Bulk Operations

Bulk operations are used to add, insert or remove collection of items in a single method call. It helps speeding up the process and minimizes cluster traffic. This sections explains the basic concept of bulk operations and describes how to perform different bulk operations on a cache using the Bulk Operations API provided by NCache.
In This Section
Overview
Explains the basic concept of bulk operations.
Using Bulk Operations
Explains how to perform different bulk operations on cache using NCache Client API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

There are scenarios when it is more feasible to fetch/update cache data in bulk. For example, an application can load customer information in bulk in the start. Bulk operations are desgined to get better performance as they are executed as a single operation on the server. Retrieving 100 cache items in a single bulk operation performs many folds faster than retrieving them through 100 individual Get calls.
Failures in Bulk Operations: Although bulk operation executes as a single operation, failure of operations constituting the bulk operation are treated individually, e.g., if a bulk add operation is performed with 100 cache items and 20 cache items already exist in the cache, then only those 20 cache items will not be added to the cache. The remaining 80 cache items will be added to the cache. Bulk operation returns a dictionary of failed operations.
Avoiding Large Bulk Operation: There is no limit on how many operation can be combined in a single bulk operation. But it is recommended to avoid larger bulk operations as it can raise the memory usage on both applications and cache servers due to serialization/desrialization of large amount of cache data in a single cache operation request/response.
How Bulk Operations Work
Bulk operations behave in different ways for different topologies. Therefore, in the following paragraph, topology specific working of bulk operations is discussed.
  • For Mirror and Replicated Cache
In mirror topology, there is one active node and one passive node. The client only communicates with active node, while passive node is the replica of active and is used for backup facility. In replicated topology, there are more than two nodes and all of them are active. So write operations are performed in parallel on all these nodes.
Bulk operations in these topologies, are sent to the specific node where the client is connected. Thus the bulk operation boosts performance by decreasing network trips to remote server.
  • For Partitioned and Partitioned-Replica Cache
Bulk operations are optimized in case of partitioned or partitioned-replica topology. In these topologies, the key-distribution map is maintained to distribute keys over multiple nodes. On the client side, this map is used to optimize bulk operations.
When data is updated or fetched; bulk operation bundles the collection of key-value pairs based on the key-distribution map. These bundles are sent to particular nodes on remote server. On getting a response, bulk operation merges these responses and return the accumulative result to the client application. Thus, optimizing the operations and increasing the performance of application.
See Also
Using Bulk Operations | Add/Update Data to Cache | Fetch Data from Cache | Remove Data from Cache | Asynchronous Operations | Cache Topologies
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Bulk Operations

< Previous page Next page >

Using Bulk Operations

Using bulk operations is handy if the user wants to work with collection of items.
This feature is not available in NCache Express and Professional edition.
NCache has multiple bulk API operations. The following operations can be performed in bulk:
  • Add
  • Insert
  • Get
  • Remove
  • Delete
Here users are supposed to provide unique keys for all bulk operations. Keys[] count has to be equal to items[] count.
Adding a Collection to Cache
A collection of items can be added in cache using AddBulk method. This method returns a dictionary of all the keys that failed to be added along with the exception.
Product product1 = new Product();
product1.ProductID = 1001;
product1.ProductName = "Chai";
product1.UnitsInStock = 15;
string key1="Product:"+product1.ProductID;
Product product2= new Product();
product2.ProductID = 1002;
product2.ProductName = "Chang";
product2.UnitsInStock = 25;
string key2="Product:"+product2.ProductID;
string[] keys = { key1, key2 };
CacheItem[] items = new CacheItem[2];
items[0] = new CacheItem(product1);
items[1] = new CacheItem(product2);
try
{
IDictionary result = cache.AddBulk(keys, items, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
Updating a Collection to Cache
An existing collection of items can be updated with the help of InsertBulk method.
Product product1 = new Product();
product1.ProductID = 1001;
product1.ProductName = "Chai";
product1.UnitsInStock = 5; //updated units
string key1="Product:"+product1.ProductID;
Product product2= new Product();
product2.ProductID = 1002;
product2.ProductName = "Chang";
product2.UnitsInStock = 6; //updated units
string key2="Product:"+product2.ProductID;
string[] keys = { key1, key2 };
CacheItem[] items = new CacheItem[2];
items[0] = new CacheItem(product1);
items[1] = new CacheItem(product2);
try
{
cache.InsertBulk(keys, items, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving a Collection from Cache
For fetching a collection from cache, use the GetBulk method. This method returns the collection of items.
string[] keys = { "Product:1001", "Product:1002" };
try
{
IDictionary items = cache.GetBulk(keys, DSReadOption.ReadThru);
if (items.Count > 0)
{
IEnumerator iter = items.Values.GetEnumerator();
while (iter.MoveNext())
{
Product info = (Product)iter.Current;
// do something
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Removing a Collection from Cache
Just like atomic remove operation, RemoveBulk also removes all cached items in list and returns removed items. Here it is returned in the form of a dictionary. Following is a code example for remove bulk operation:
string[] keys = { "Product:1001", "Product:1002" };
try
{
IDictionary removedItems = cache.RemoveBulk(keys, DSWriteOption.None, null);
foreach (DictionaryEntry entry in removedItems)
{
if (entry.Value is Product)
{
// do something
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Deleting a Collection from Cache
Following is a code snippet for DeleteBulk. This method can be used to delete multiple items from cache in a single bulk call.
string[] keys = { "Product:1001", "Product:1002" };
try
{
cache.DeleteBulk(keys, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Bulk Operations Overview | Add/Update Data to Cache | Fetch Data from Cache | Remove Data from Cache | Asynchronous Operations | Cache Topologies
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Asynchronous Operations

< Previous page Next page >

Asynchronous Operations

NCache supports both synchronous and asynchronous operations. This sections explains how to use asynchronous operations API provided by NCache to utilize notifications that arise as a result of add, insert or remove operations against all or selective cache items, or when cluster status changes.
In This Section
Overview
Explains the basic concept, need and the benefit of using asynchronous operations.
Using Asynchronous Operations
Explains how to perform different asynchronous operations on cache using NCache Client API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

NCache supports both synchronous and asynchronous (async) development. There are situations when the user would like to perform some operations in the background, while working on more critical operations. Suppose that an application updates a batch of keys to cache. It also needs to carry other operations such as receiving data from cache. Here the actual need of asynchronous operations is evolved.
Need of Asynchronous Operations: These operations are used when an application has important tasks to execute right away instead of blocking updates that are not important. As asynchronous operations cause delayed updates, these delays are expected.
Performance Improvement: It increases the performance of application in term of faster response time and enhances the overall responsiveness. This means that an application regains control while performing long-running tasks in background.
NCache provides asynchronous counterpart for almost every synchronous operations. As asynchronous operations do not notify upon the failure or success of the operations themselves, so NCache provides a Callback feature for asynchronous operations.
Callback Method: NCache provides optional Callback Methods for asynchronous operations. Callbacks are responsible for providing acknowledgment to application about the operations status.
Working of Asynchronous Operations
When an application issues request for adding/updating data to the cache or removing it from cache with asynchronous API call, NCache uses a thread pool on the server side to facilitate these operations. Whereas in case of any callback registered with asynchronous operations, NCache triggers appropriate events only for interested clients upon operation completion.
See Also
Using Asynchronous Operations | Bulk Operations | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Asynchronous Operations

< Previous page Next page >

Using Asynchronous Operations
In case of failure for asynchronous operation, server will not throw any exception.
Basic Asynchronous Operations
  • Adding Data to Cache Asynchronously
Data can be added to NCache asynchronously using AddAsync method.
In this example an object is added to the cache asynchronously.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" + product.ProductID;
try
{
cache.AddAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
  • Updating Data to Cache Asynchronously
An InsertAsync method enables the user to update existing data in the cache in an asynchronous manner.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.Category = 5; // updated category
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
try
{
cache.InsertAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
  • Removing Data from Cache Asynchronously
In case a user wants to perform a remove operation in the background, a RemoveAsync operation can be used to perform that operation. In this example, the key for the data that needs to be removed must be specified.
String key= "Product:1001";
try
{
cache.RemoveAsync(key, null, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
  • Clearing the Cache Asynchronously
To clear cache completely in background, ClearAsync method needs to be called.
try
{
cache.ClearAsync(null);
}
catch (Exception ex)
{
// handle exception
}
Using Asynchronous Callback Method
Since asynchronous operations do not notify upon the failure or success of the operation themselves, NCache provides a callback mechanism which can be registered while making operation call. These callbacks are triggered upon completion of the operation. Callbacks are integral in tracking operations.
In case of failure for asynchronous operation, server will not throw any exception but, with Async callback, user can know the status.
  • Adding Data with Registered Callback Method
AsyncItemAddedCallback are provided by NCache which can be registered with an asynchronous addition method. It allows the user to perform appropriate functions upon completion of the operation.
In this example, an ItemAddedCallback provided by NCache needs to be registered with an AddAsync call.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
cacheItem.AsyncItemAddCallback += new AsyncItemAddedCallback(OnItemAdded);
string key = "Product:" +product.ProductID ;
try
{
cache.AddAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
public void OnItemAdded(string key, object status)
{
if (status.ToString().Equals("Success"))
{ //do something
}
if (status.ToString().Equals("Failure"))
{ //do something
}
if (status is Exception)
{ //do something
}
}
  • Updating Data with Registered Callback Method
AsyncItemAddedCallback are provided by NCache which can be registered with an asynchronous addition method. It allows the user to perform appropriate functions upon completion of the operation.
In order to get a notification upon execution of an update operation, AsyncItemUpdatedCallback need to be registered with InsertAsync operation. It is demonstrated in the example below.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.Category = 5; // updated category
CacheItem cacheItem = new CacheItem(product);
cacheItem.AsyncItemUpdateCallback += new AsyncItemUpdatedCallback(OnItemUpdated);
string key = "Product:" +product.ProductID ;
try
{
cache.InsertAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
public void OnItemUpdate(string key, object status)
{
if (status.ToString().Equals("Success"))
{ //do something
}
if (status.ToString().Equals("Failure"))
{ //do something
}
if (status is Exception)
{ //do something
}
}
  • Removing Data with Registered Callback Method
NCache provides AsyncItemRemovedCallback to be used in order to receive notification upon completion of item removal. In this example you need to register the above mentioned callback with NCache to receive a notification.
string key= "Product:1001";
try
{
cache.RemoveAsync(key, new AsyncItemRemovedCallback(OnItemRemoved), DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
public void OnItemRemove(string key, object status)
{
if (status.ToString().Equals("Success"))
{ //do something
}
if (status.ToString().Equals("Failure"))
{ //do something
}
if (status is Exception)
{ //do something
}
}
  • Clearing Cache with Registered Callback Method
AsynccacheClearedCallback if registered with NCache is triggered whenever a ClearAsync operation is performed successfully. In this example, the user needs to register the callback when calling the method.
try
{
cache.ClearAsync(new AsyncCacheClearedCallback(OnCacheCleared));
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
void OnCacheCleared(object result)
{
if (result.ToString().Equals("Success"))
{ //do something
}
if (result.ToString().Equals("Failure"))
{ //do something
}
if (result is Exception)
{ //do something
}
}
See Also
Asynchronous Operations Overview | Bulk Operations | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Group/Subgroup

< Previous page Next page >

Group/Subgroup

NCache provides a feature to divide related data into logical groups and subgroups. This sections explains the basic concept of groups and using this feature using the client side API provided by NCache.
In This Section
Overview
Explains the basic concept and do's and dont's of using groups in NCache
Grouping Cached Data
Explains how to distribute data into groups and subgroups using NCache Client API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

Group/sub-group is a hierarchical way of grouping cached items. Let’s say, a cache has a large amount of product information. These products range from products like beverages, grocery to electronics etc. Among these products, there are further divisions like in electronic section group; there can be sub groups of home appliances, computer system gadgets, photography gadgets etc. Group is a logical partition of data; this partition can have a sub division (sub group) or can be just a major division (group), it is a two level grouping. Groups do not overlap but sub groups can be the same in one or more groups.
Case Sensitive: Group and sub group identifiers are case sensitive.
Retrieve/Remove using Groups: Using groups, all the items belonging to a particular group can be fetched or removed. The user can fetch just the keys and then only fetch a subset of them. Addition, update, removal, retrieval can be performed by specifying group identifier and/or its sub group identifier. Group keys or group data can be fetched using GetGroupKeys and GetGroupData API respectively.
Multiple Sub-Groups: NCache supports multiple sub groups within one group. But cache operations cannot be performed only with a sub group identifier, as two different groups can have the same sub group identifier.
Group Identifier cannot be Updated: Group identifier cannot be updated. For its update, cache key must first be removed and then inserted with a new group identifier.
See Also
Grouping Cached Data | Tags | Named Tags | Object Query Language (OQL) in NCache | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Grouping Cached Data

< Previous page Next page >

Grouping Cached Data

Adding an Item to Data Group
Data can be added to NCache asynchronously using AddAsync method.
In this example an object is added to the cache asynchronously. The following code adds an item to cache with data group "Product" and sub group "Beverages". In this example, AddOperation will be used to set group and sub-group of the item.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" + product.ProductID;
try
{
cache.Add(key, product, "Product", "Beverages");
}
catch (OperationFailedException ex )
{
// handle exception
}
Adding Data Group with CacheItem
In this example data group is set by assigning it as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" + product.ProductID;
CacheItem cacheItem=new CacheItem(product);
cacheItem.Group="Product";
cacheItem.SubGroup="Beverages";
try
{
cache.Add(key, cacheItem);
}
catch (Exception ex )
{
// handle exception
}
Updating an Item in a Data Group
If the user adds an item without any group or wants to add a group with that cached item, then he/she has to to first remove that item from the cache then insert/Add that item within the desired group and sub group. Otherwise, insert operation throws data groups mismatch exception.
Retrieving Keys Pertaining to a Particular Group
To return the list of keys that belong to a specified group and sub-group, the GetGroupKey method can be used. This method returns an arrayList of keys.
try
{
ArrayList keys = cache.GetGroupKeys("Product", "Beverages");
foreach (object obj in keys)
{
// do something
}
}
catch (Exception ex )
{
// handle exception
}
Retrieving Keys and Values Pertaining to a Particular Group
To return the dictionary of keys and values that belong to a specified group and sub-group, the GetGroupData method can be used. This method returns a dictionary of keys and values.
try
{
IDictionary dict = cache.GetGroupData("Product","Beverages") as System.Collections.IDictionary;
if (dict.Count> 0)
{
IDictionaryEnumerator ide = dict.GetEnumerator();
while (ide.MoveNext())
{
string key = (string)ide.Key;
object val = (object)ide.Value;
// do something
}
}
}
catch (Exception ex )
{
// handle exception
}
Removing a Data Group
The following code removes all items from data sub group 'Beverages' inside group 'Product'.
try
{
cache.RemoveGroupData("Product", "Beverages");
}
catch (Exception ex )
{
// handle exception
}
See Also
Group/Subgroup Overview | Tags | Named Tags | Object Query Language (OQL) in NCache | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Tags

< Previous page Next page >

Tags

NCache provides a feature known as Tags to associate keyword with data stored in cache. This section describes what are tags and how can they be used in NCache.
In This Section
Overview
Explains the basic concept and do's and dont's of tags in NCache
Tagging Cached Data
Explains how to use tagging feature in NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

Using Tags, keywords(s) can be associated with cache items. Data can be marked with tags which act as identifiers for cache items. For instance in an online library there are different genres of books, for each different category a tag identifier can be added. Tags for authors, year of publication etc. can also be added. Note here that a single author can have two books written under two different categories. And also multiple different authors may have publications in the same year, thus cache search can be made for each tag filter separately i.e. for all publications in year 2000 or for all publications of JohnKeats, etc. These filter tags can be used in combination with each other like all publications of John Keats in year 2000.
Retrieve/Remove using Tags: These identifying marks can help the user in finding and/or removing items from the cache.
Support for Multiple Tags: More than one keyword with any cache item.
Many-to-Many Grouping: Tags provide a many-to-many grouping where one tag can contain multiple cached items and one cached item can belong to multiple tags. NCache provides a Tag class in which the user can specify one or more tags associated with cached items.
Case Sensitive: Tags are case sensitive.
Query using Tags: NCache also supports tags in queries.
For example if the user tags your cache item with a list of tags i.e. “bookinformation” having tags like author, yearofpublication category, the items can be fetched through API which matches with any one tag (e.g., Book where author or yearofpublication or category is matched) from the list or the items can be fetched where all tags (e.g., book where author and yearofpublication and category are matched) in list match. Furthermore, the cache can also be searched on the basis of only one tag (i.e. only author is a match). Items can also be removed from cache on the basis of these marks of identification. The same filters of tags can be used for removal of items. These different filters can be used according to specific business needs.
See Also
Tagging Cached Data | Group/Subgroup | Named Tags | Object Query Language (OQL) in NCache | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Tagging Cached Data

< Previous page Next page >

Tagging Cached Data

NCache provides with the facility of Tags which act as identifying marks for the cache items. Through tags, the user can associate string keywords(s) with cache items. You can also search and remove items from the cache by specifying tags.
Creating Tags
Tag is a class provided by NCache. This class can be used to associate tags with a particular data.
Tags are case sensitive.
// Create a Tag array and specify tags.
Tag[] productTags= new Tag[2];
productTags[0] = new Tag("Product");
productTags[1] = new Tag("Beverages");
Adding Items to Cache with Tags
In this example Add Operation overload is used to associate tags that were previously created.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" + product.ProductID;
try
{
cache.Add(key, product, productTags);
}
catch (OperationFailedException ex)
{
// handle exception
}
Tagging Data through CacheItem
In this example tags are set by assigning them as a property of CacheItem.
CacheItem cacheItem = new CacheItem(product);
cacheItem.Tags = productTags;
try
{
cache.Add(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving Previously Tagged Data
  • Retrieving Keys Associated with a Tag
//For finding keys related to one tags
ICollection keys = cache.GetKeysByTag(productTags[0]);
//For Finding keys containing at least any one tag from tag list.
ICollection keys = cache.GetKeysByAnyTag(productTags);
//For finding keys containing all tags from tag list.
ICollection keys = cache.GetKeysByAllTags(productTags);
  • Retrieving Keys from Cache Containing Tag
//For finding keys and values related to one tag.
Hashtable result = cache.GetByTag(productTags[0]);
//For finding keys and values containing at least any one tag in the tag list
Hashtable result = cache.GetByAnyTag(productTags);
//For finding keys and values related to all tags from the tag list
Hashtable result = cache.GetByAllTags(productTags);
  • Querying Cached Items with respect to Tags
Hashtable queryValue = new Hashtable();
//Add items to cache containing tags in ArrayList if multiple tags value is required.
ArrayList queryTagList = new ArrayList();
queryTagList.Add("Product");
queryTagList.Add("Beverages");
// Add tag list to Hashtable for query searching values.
queryValue.Add("$Tag$", queryTagList);
try
{
//Query string, for searching Cache items with respect to Tags.
ICollection keysResultSet = cache.Search("SELECT Product WHERE this.$Tag$=? AND this.$Tag$=?", queryValue);
// keysResultSet contains all keys related to both tags.
}
catch (OperationFailedException ex)
{
// handle exception
}
Here the user needs to specify the fully qualified name of custom class instead of 'Product' in the query string. Only .NET clients can use System.String or System.Int32 etc related to cache value types.
  • Removing Items from Cache Containing Tag
//For removing keys containing specified tag
cache.RemoveByTag(productTags[0]);
//For removing keys containing at least one tag from tags list.
cache.RemoveByAnyTag(productTags);
//For removing keys containing all tags from list
cache.RemoveByAllTags(productTags);
See Also
Tags Overview | Named Tags | Group/Subgroup | Object Query Language (OQL) in NCache | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Named Tags

< Previous page Next page >

Named Tags

NCache provides a feature “Named Tags” through which the user is able to associate one or more keywords with cache items. Named tags act as an identifying mark for the cache items and can be used for querying the cache data.
In This Section
Overview
Explains the basic concept and do's and dont's of Named Tags in NCache
Using Named Tags
Explains how to use Named Tags in NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

NCache is providing feature “Named Tags” through which user will be able to associate one or more keywords with cache items. These keywords will act as an identifying mark for the cache items and will be used for querying the cache data.
"Named Tags" is the enhancement of "Tags". Consider a scenario where user needs to store an object in textual form such as "xml", he will not be able to search that object using tags. The limitation of tags is that it can only have text values and only one attribute i.e. $Tag$. With named tags user will be able to store additional information (of any type) required to query the object stored as string.
Here users are required to provide the list of named tags, each having two parameters, "key" (name of a tag) as string and "value" (assigned value) as any primitive type. NCache then allows you to search your objects through these named tags.
If there are multiple applications that are sharing the same cache and all of them are supposed to add named tags, then make sure that the same named tags have homogenous data types, e.g., if one client is adding named tag "ProductID" with String data type, then all other clients should add values of "ProductID" in String format not in Integer or other for the same cache.
See Also
Using Named Tags | Tags | Group/Subgroup | Object Query Language (OQL) in NCache | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Named Tags

< Previous page Next page >

Using Named Tags

NamedTagsDictionary class will be used to define Named Tags which will be added with the cache items for further use. Only string is allowed as a Named Tag “keys” and primitive data types are allowed as valid Named Tag “values”.
To use the Named Tags,the following namespace should be added in project:
using Alachisoft.NCache.Runtime.Caching;
Creating Named Tags
A NameTagsDictionary is a class provided by NCache so that these tags can be associated with a particular data.
// Creating NameTagsDictionary and adding custom named tags.
NamedTagsDictionary productNamedTag = new NamedTagsDictionary();
productNamedTag.Add("UnitsAvailable", 4);
productNamedTag.Add("Category", 25);
productNamedTag.Add("Supplier", "Alex");
Adding Items to Cache with Named Tags
In this example, Add Operation overload is used to associate named tags previously created.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, product, productNamedTag);
}
catch (OperationFailedException ex)
{
// handle exception
}
Adding Named Tags through CacheItem
In this example, named tags are set by assigning them as a property of CacheItem.
CacheItem cacheItem = new CacheItem(product);
cacheItem.NamedTags = productNamedTag;
try
{
cache.Add(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
Querying Cached Items with respect to Named Tags
string queryString = "SELECT Product WHERE this.UnitsAvailable = ? AND this.Supplier = ?";
Hashtable values = new Hashtable();
values.Add("UnitsAvailable", 4);
values.Add("Supplier", "Alex");
try
{
//if only related cache keys are required than use Search
ICollection keysResultSet = cache.Search(queryString, values);
// if both keys and values are required than use SearchEntries
IDictionary resultSet = cache.SearchEntries(queryString, values);
if (resultSet.Count> 0)
{
//Iterate through list of all products having UnitsAvailable as 4 and Supplier name is "Alex"
IDictionaryEnumerator ide = resultSet.GetEnumerator();
while (ide.MoveNext())
{
String key = (String)ide.Key;
String value = (String)ide.Value;
//...
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Here, the fully qualified name of the custom class should be specified instead of 'Product' in query string. If Named Tags are associated with “int” or any other data type then specific syntax to that type will be used. For example, for values of "int" data type "SELECT System.int32 WHERE this.UnitsAvailable = ?" will be used to query Named Tags.
If you have multiple applications that are sharing same cache and all of them are supposed to add named tags than make sure that same named tags have homogenous data types, e.g., if one client is adding named tag "ProductID" with String data type than all other clients should add values of "ProductID" in String format not in Integer or other for same cache.
See Also
Named Tags Overview | Tags | Group/Subgroup | Object Query Language (OQL) in NCache | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Data Invalidation Strategies

< Previous page Next page >

Data Invalidation Strategies

The feature "Expirations" is provided by NCache through which certain cached items can be automatically removed from the cache when required. This section explains the basic concept and use of Expirations in NCache.
In This Section
Overview
Explains the basic concept and two types of Expirations provided by NCache
Using Expirations
Explains how to use Expirations in NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

The main purpose of a caching solution is to cache the commonly used data which consequently boosts up the application performance. But caching a large amount of data without constantly updating it may lead to stale data. Thus it is very important that cached data must be up to date. For this purpose, an effective caching solution must have data invalidation strategies which can be very demanding in a distributed environment. Fortunately, NCache supports different data invalidation strategies which cover almost all major needs of most of the applications. Depending upon the sensitivity, importance and the rate at which data can change, an appropriate invalidation strategy can be chosen. For instance, the user can decide to keep data in cache on the basis of its access or he/she can invalidate certain data according to its change in master data source. A combination of these strategies can be chosen to keep data refreshed in cache.
Time Based Invalidation
NCache supports time based data invalidation where time or interval can be specified to invalidate cache data. This type of data invalidation is used if changes to the data occur in a deterministic time fashion or where the frequency of data change can be determined. For example, customer information or region information may not be frequently updated, so time based expiration can be used to invalidate such data.
You will specify this time/interval with items of cache data. NCache maintains an index for items with time based expiration. There is a dedicated thread which checks cache data for these expired items. This thread periodically runs after a configurable interval of time called Clean Interval. By default its value is 15 seconds. It means that the maximum time an item can take to be removed from cache is expiration time + clean interval. So this interval shoud be selected carefully according to the expiration time of your data.
NCache provides two types in time based expiration.
  • Absolute Expiration
  • Sliding Expiration
1. Absolute Expiration
In Absolute Expiration, an item can be added to the cache by specifying the exact date and time at which the item should be invalidated. When this time is elapsed, item will be removed from cache. Here NCache maintains UTC time for absolute expiration on caching servers which facilitates in case clients and cache servers are in different time zones. This means that expiration time specified by clients (in any time zones) will be converted to UTC on cache server and item will be expired on exact date and time as specified by clients. Expiration time can range from seconds to days and months.
However, note that the item will be removed when expired on next cache clean up interval. For example, if an expiration of 10 seconds is specified with an item and cache clean up interval is configured to 15 seconds, then the item will be removed within the time frame of 15-25 seconds.
2. Sliding Expiration
In liding expiration, the data is retained in cache as long as it's being used by the application. If the data is not used for a specific period of time, it is removed from cache. For example, ASP.NET session data can be stored in the cache as long as the session is active. For this type of data, sliding expiration ranging from seconds to days and months can be specified.
Whenever a cache data with sliding expiration is accessed, its time to live in cache is extended by the expiration interval specified e.g. an item with 30 seconds sliding expiration will be removed from cache if not accessed for at least 30 seconds or it can be said that with each Get, its expiration interval will be reset to 30 seconds. Similar to absolute expiration, cache items with sliding expiration are removed on cache cleanup interval.
See Also
Using Expirations | Eviction | Configuring Expiration Clean Up Interval | Configuring Eviction Policy | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Expirations

< Previous page Next page >

Using Expirations

1. Absolute Expiration
In absolute expiration cached item is removed after absolute interval. This interval starts when an item is added into the cache, and its duration is specified in parameters provided on cache insertion.
If Absolute Expiration is being used, then sliding expiration should be turned off by specifying NoSlidingExpiration parameter.
  • Adding New Data with Absolute Expiration
In this example Add Operation provided by NCache is used to add absolute expiration to item. The expiration is set by using DateTime class. Also if Absolute expiration is used, NoSlidingExpiration is to be specified.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
// adding absolute expiration of 5 min through Add API.
cache.Add(key, product, null, System.DateTime.Now.AddMinutes(5), Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Updating Data with Absolute Expiration
In this example, Insert Operation provided by NCache is used to add/update absolute expiration to item added to the key. The expiration is set by using DateTime class. Also as absolute expiration is being used, NoSlidingExpiration is used for sliding expiration.
try
{
// adding absolute expiration of 5 min through Add API.
cache.Insert(key, product, null, System.DateTime.Now.AddMinutes(5), Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Setting Absolute Expiration with CacheItem
In this example expiration is set by assigning it as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
// Setting Absolute expiration of 10 minutes.
cacheItem.AbsoluteExpiration = System.DateTime.Now.AddMinutes(10);
try
{
cache.Add(key, cacheItem, DSWriteOption.None, null);
}
catch(OperationFailedException ex)
{
// handle exception
}
2. Sliding Expiration
In Sliding expiration, time for item expiration is not fixed. It is an interval between last access time of item and current
time. If this elapsed time interval is equal to defined sliding expiration settings then this item is removed from cache.
As sliding expiration means expire after a period of inactivity and is good for session and other temporary data that
must be removed if not used.
If sliding expiration is being used, the absolute Expiration should be turned off by specifying
NoAbsoluteExpiration .
  • Adding New Item with Sliding Expiration
In this example, Add operation provided by NCache is used to add absolute expiration to item. The expiration is set by using TimeSpan class. Also while using sliding expiration, NoAbsoluteExpiration is used for absolute expiration.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
// adding sliding expiration of 5 sec through Add API.
cache.Add(key, product, null, Cache.NoAbsoluteExpiration,new TimeSpan(0, 0, 5), CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Updating New Item with Sliding Expiration
In this example, Insert operation provided by NCache is used to add/update sliding expiration to item added to the cache. The expiration is set by using TimeSpan class. Also sliding expiration is the selected mode of expiration, NoAbsoluteExpiration is used for absolute expiration.
try
{
// adding sliding expiration of 5 sec through Insert API.
cache.Insert(key, product, null, Cache.NoAbsoluteExpiration,new TimeSpan(0, 0, 5), CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Setting Sliding Expiration with CacheItem
In this example expiration is set by assigning it as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
// Setting sliding expiration of 10 seconds.
cacheItem.SlidingExpiration = new TimeSpan(0, 0, 10);
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, cacheItem, DSWriteOption.None, null);
}
catch(OperationFailedException ex)
{
// handle exception
}
See Also
Expirations Overview | Eviction | Configuring Expiration Clean Up Interval | Configuring Eviction Policy | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Dependencies

< Previous page Next page >

Cache Dependencies

Through Cache Dependencies, the dependency of cached items on files, database table rows and other cached items can be implemented. This sections explains this concept and its API.
In This Section
Overview
Explains what is meant by Cache Dependency and the types of dependencies provided by NCache.
Using Cache Dependencies
Explains how to use Cache Dependencies through NCache Client API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

The data in cache can have dependency relations with items like a file on some location, a record in a database, results of a particular query or another cached item; such that any change in the item can invalidate the data in the cache. In that case, all dependent data must be reloaded or removed from cache otherwise data will become stale.
Expiration in Clustered Environment
In a clustered cache environment where multiple caching servers are involved, expiration is handled differently in various NCache topologies. In replicated cache, expiration is performed by coordinator node and operation will be then synchronized to other clustered nodes. In partitioned cache, as data is distributed on separate nodes, each node is responsible for its own items expiration. For partitioned-replica topology, expiration will be performed on active nodes and propagate to their respective replicas. Similarly in mirror active node will perform expiration and synchronies it on passive node.
Key Dependency
There are situations when it is important to maintain a relationship among the related cache data. For example, if item B depends on item A thenin such situations, item B has to be removed if A no longer exists in cache. Here, key dependency can be used to maintain the relationship.
Key dependency creates a dependency relationship between cached items. For example, a key dependency can be specified on customer's data while putting his order's data. In this way, if customer is removed by the application or expired, then NCache will remove the order data too.
In NCache, the dependent items and the cache items on which they depend upon, both are aware of this relationship. So when an item on which other items depend is removed either by the application or by expiration, all the dependent items will also be removed. However vice versa is not possible i.e. on removal of an item, say Y, which has dependency on any other item, say on item X, the item X will not be removed.
A cache item can have dependency on any number of other items in the cache. For example, an item A may depends on item X, Y and Z. Similarly an item to which other depend upon can also depend on other cache item i.e. item X may depend on Y while items A and B depends on X. In short cascaded dependencies are allowed to nth level e.g. an item A depends on item B and B depends on item C then removal of C will result in removal of B and then C.
Cyclic key dependency is not supported i.e. Item A depends on Item B and B depends on A. Or A depends on B and B depends on C and in turn C depends on A.
Cache Synchronization Dependency
Cache synchronization dependency is provided by NCache to synchronize two separate caches; so that an item updated or removed from one cache have the same effect on the synchronized cache. For example, you can have a local cache that keeps the items frequently being used by your application and a clustered cache that keeps a larger number of items being shared with other applications. Let’s say this local cache is synchronized with the clustered cache to improve performance and avoid data integrity issues. Cache synchronization dependency synchronizes these two caches using item level notifications provided by NCache. Whenever an item is updated or removed from one cache, a key based notification is fired to the other cache in order to synchronize data in both caches.
Notification Based Database Dependencies
Now-a-days, most of the applications that heavily use database calls are incorporating distributed caching to cache expensive queries result set which helps to boost application performance. Caching the result set improves both the performance and scalability of the application. For this purpose, the user would like that whenever any data changes occur in the database, cache data should be invalidated and removed from cache. NCache provides a mechanism where data can be invalidated when changes occur in the database in real time. For this purpose, notification based database dependencies are provided in NCache.
How It Works: In this type of database dependency, NCache uses data change notifications provided by databases servers to invalidate cache data. SQL server(2005 and 2008) and Oracle (10g or later) provides an event notification mechanism where the distributed cache like NCache can register itself for change notification through SqlDependency/OracleDependency. NCache receives notifications from database whenever underlying data changes occurs in the database. This allows NCache to immediately invalidate or reload the corresponding cached item and this keeps the cache always synchronized with the database.
Database Dependency Using SQL Server
NCache provides SqlCacheDependency for notification based dependency with SQL Server database. Internally NCache use SqlDependency provided by .NET framework to register data change notifications with SQL Server. Hence the limitations and working mechanism of SqlDependency while using this dependency needs to be understood. For example, a limited set of queries can be registered with SqlDependency. See Special Considerations Using Query Notifications and SqlDependency class for more detail.
Database Dependency Using Oracle
Similarly NCache provides OracleCacheDependency for notification based dependencies with Oracle. Internally NCache use OracleDependency to register data change notifications with Oracle database server. Hence the limitations and working mechanism of OracleDependency while using this dependency need to be understood. For example, a limited set of queries can be registered with OracleDependency. See Special Considerations Using Query Notifications and OracleDependency class for more detail.
Notification based dependency is the best option while using queries with comparatively less data changes or when a large amount of data dependencies are not involved. As notification based dependencies involve notifications to invalidate data so it can be very intensive in term of resource usage at database end. It should be carefully selected in case of creating large amounts of data dependencies as database servers need to monitor each dependency separately to track any data changes related to it. This may consume a lot of resources and hence put burden on the database servers in terms of memory and processing.
Also, database servers mostly fire separate events for each data change and NCache responds to these events accordingly. Large amounts of these events can easily overwhelm the network traffic and the overall performance of client application and NCache servers.
To avoid this, other options like polling based database dependency provided by NCache or writing a CLR/Java procedure that communicates with NCache to invalidate cache items can be used. For this, a CLR/Java stored procedure needs to be created that connects with NCache and updates or invalidates the cached item. This procedure can be invoked on update or delete trigger of the table. In this way, data changes can be monitored and can be directly replicated to cache. This approach is more efficient as data base server do not need to monitor data changes by creating data structures related to SqlCacheDependency. And, it also does not fire .NET events to NCache. Instead, it open up an NCache client connection and directly tells NCache whether to invalidate a cached item or reload it. And, this connection with NCache is highly optimized and much faster and lighter than .NET events.
Polling Based Database Dependencies
NCache supports another database dependency called polling based dependency which is basically designed to work on large scale. Notification based dependency only works with database server which provides support for data change notifications i.e. either with SQL Server(2005 or above) or Oracle (10g or later). Whereas polling based dependency also works with other databases which do not provide data change notifications support. Also, notification based dependency
is not as much resource efficient as polling based for using it on large scale.
In polling based dependency, a table named ncache_db_sync needs to be created in database which is used by NCache to synchronize the database with cache store. Also, UPDATE and DELETE triggers needs to be created for every table on which notification is required. These triggers will be scripted to invalidate corresponding cache keys in this table in case of data change.
When an item is added to the cache with dependency, a row will be created in this table for this cache key as shown:
In case of data change in table, corresponding triggers will set modified flag to true. On Cache clean up interval, NCache polls ncache_db_sync table for modified keys, collects them, sets their work in progress flag to true and finally removes all corresponding keys from cache. After successfully removing keys from cache, all those rows where work_in_progress flag is set to true are removed from the 'ncache_db_sync' table.
In a clustered cache, if a node crashes while it was removing items from the cache, the next node in the cluster will again start the process.
File Dependency
NCache supports Database dependencies (explained later on in this chapter) to invalidate cache data when data changes occur in relational database management systems (RDBMS). On the other hand, file dependency provides a mechanism to invalidate the cache data in case of non-relational data sources.
Here you can associate a file/folder dependency with a cache item. Whenever that file/folder is removed or modified, NCache will remove its dependent item from cache. Cache clean up (expiration) thread monitor the dependent file/folder for any change at every Clean Interval.
On cache clean up interval NCache will triggers dependency in the following scenarios:
  • Dependency file/folder is removed/modified.
  • Dependency file is replaced with directory and vice versa.
  • Dependency is created on non-existed file/folder, but on clean up interval it is created.
Similarly multiple items can depend on a single file. Any change in file either by updating file or deletion causes cache to remove the dependent items from the cache. Also an item can create dependency on multiple files in file dependency.
A delay called "start after" can be mentioned in file dependency which indicates when to start monitoring the dependent file for any change. In this way NCache will start checking the dependant file after the "start after" time elapsed.
Custom Dependency
NCache provides flexible ways to determine data invalidation using various dependencies. However the users can implement their own custom logic for dependency if none of the built in invalidation strategy suits their environment. For example, a custom dependency can be implemented which makes call to a web service for the validation of data.
In custom dependency, a custom logic can be defined which specifies when a certain data becomes invalid. For this purpose, NCache provides an abstract class ExtensibleDependency. To write a custom logic, all that’s needed is to inherit the custom dependency class from this class and override its HasChanged property. Like expiration, cache clean up thread periodically calls HasChanged property of custom dependency and if it returns true, item is removed from the cache.
Aggregate Cache Dependency
NCache also allows using different strategies in combination with the same cache data in the form of Aggregate Cache Dependency. Aggregate Cache Dependency allows associating multiple dependencies of different types with a single cached item. For example, a key dependency and file dependency can be associated with an item using aggregate dependency and data will be invalidated which ever dependency triggers first.
Aggregate Cache Dependency associates one cached item with a collection of dependency objects which can be any other dependency provided by NCache e.g. CacheDependency, DBCacheDependency or any combination of these. The AggregateCacheDependency monitors a collection of dependency objects so that when any of them changes, the cached object becomes obsolete and is removed from the cache.
Combining different invalidation strategies provides you more flexible ways to meet your application needs in different environments.
See Also
Using Cache Dependencies | Custom Dependency | Event Notifications | Data Invalidation Strategies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Cache Dependencies

< Previous page Next page >

Using Cache Dependencies

This section explains in detail how to use different cache dependencies using NCache Client API.
In This Section
Adding Data with File and Key Dependencies
Explains how to add data using file and key dependency.
Synchronizing Cache with Relational Database
Explains how to use database dependency for the purpose of synchronizing cache with database.
Synchronizing Cache with Custom Data Sources
Explains how the user can write his own dependency scenarios and use the feature of custom dependency.
Synchronize Data across Multiple Caches
Explains how to synchronize data among different caches to ensure data integrity.
Add Dependency to the Existing Cached Item
Explains how cache dependency can be added to an existing item without any need to update it.
Aggregate Cache Dependency
Explains how to add multiple dependencies with a single cache item.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding Data with File and Key Dependencies

< Previous page Next page >

Adding Data with File and Key Dependencies

Data in cache can depend on items like a file on some location, a record in database, results of a particular query or another cached item, such that any change in the item which has dependent data in cache invalidates the data. In that case all dependent data must be reloaded or removed from cache otherwise data will become stale.
Adding Data with Key Dependency
An object can be specified as being dependent on another key at the time of addition. Note that the only keys present in cache can be specified as key dependency. Nonexistent key specified as key dependency will result OperationFailedException.
The following code shows how to add an item with key dependency:
// precondition : Item with key "Product:1001" already exists in cache
Product product=new Product();
product.ProductID=1002;
product.ProductName="Chang";
string key1="Product:1001";
string key2="Product:"+product.ProductID;
try
{
//Adding cache item "Product:1002" with KeyDependency on "Product:1001"
cache.Insert(key2, product, new KeyDependency(key1), Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
//Removing/Deleting/Updating key: "Product:1001" will automatically make all of its dependant keys removed, here it's "Product:1002"
}
catch (OperationFailedException ex)
{
// handle exception
}
In Key Dependency an item can only depend on an existing item, thus all dependency keys must exist in cache before an item can depend on them.
Adding Data with File Dependency
Following code shows how to add data with File Dependency.
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
string filepath = "C:\\tempProductList.txt";
try
{
//Adding cache item "Product:1001" with FileDependency on file "tempProductList.txt"
cache.Insert(key, product, new FileDependency(filepath), Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch (OperationFailedException e)
{
// handle exception
}
//Modifying file: "Product:1001" will automatically removed
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Synchronizing Cache with Relational Database

< Previous page Next page >

Synchronizing Cache with Relational Database

NCache provides feature of database dependency for the purpose of synchronizing cache with database. When using cache with the database, data in cache has to always be synchronized with the database. This is because the cache is keeping a copy of the data that already exists in the database.
In This Section
Using SQL Dependency
Explains how to use SQL dependency feature for the purpose of synchronizing cache with Microsoft SQL Server 2005/2008.
Using Oracle Dependency
Explains how to use Oracle dependency feature for the purpose of synchronizing cache with Oracle database.
Using Polling Based Dependency
Explains how to use polling based dependency to synchronize cache with databases who don't provide notifications feature.
Using CLR Procedures to Call NCache
Explains how to write CLR stored procedures for database to synchronize cache with the database.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using SQL Dependency

< Previous page Next page >

Using SQL Dependency

NCache provides feature of SQL dependency for the purpose of synchronizing cache with Microsoft SQL Server 2005/2008. An item is added with SQL dependency, specifying SQL statement representing one or more rows (query result set) in database. Then NCache establishes a link with the database against these rows. If data is updated in the database by any application, SQL Server fires a .NET event notification which NCache catches and removes the corresponding item from the distributed cache.
i. Configuring Notification on SQL Server
NCache tracks changes in database using notifications received from SQL server about changes in database. Internally NCache registers for these data change notification and receives notification from database in case of any change in the registered query result set. On the basis of these received notification, cache invalidates the corresponding data and removes it from cache.
Notifications must be enabled in SQL server database for NCache. Unlike time based expirations where data is invalidated by cache clean up thread on a configurable interval, NCache removes the corresponding data as soon it receives notification from the database.
For this purpose, enable the service broker in SQL Server 2005 or above before NCache can use SqlCacheDependency. This allows SQL Server 2005 to send event notifications to NCache to let it know that data has changed in the database.
[SQL]
ALTER DATABASE Northwind SET ENABLE_BROKER;
GO
To verify that the broker is running, properties in the databaseserver can be checked using SQL Management studio or run the following query:
select is_broker_enabled from sys.databases where name = '<dbname>'
If the result is “1” it means broker has been enabled.
For further details, refer to MSDN article on Enabling Event Notifications for SQL Server .
ii. Database Permissions
The following permissions need to be enabled in order to use NCache SQL cache dependency if the user does not have database permissions. Database permissions are defined for two different modes: Default mode and Custom mode.
For Default Mode
GRANT SUBSCRIBE QUERY NOTIFICATIONS TO <database_principal>
GRANT CREATE QUEUE TO <database_principal>
GRANT CREATE SERVICE TO <database_principal>
GRANT CREATE PROCEDURE TO <database_principal>
For Custom Mode
CREATE QUEUE "NCacheSQLQueue-[IP-Address]";
CREATE SERVICE "NCacheSQLService-[IP-Address]"
ON QUEUE "NCacheSQLQueue-[IP-Address]"
([http://schemas.microsoft.com/SQL/Notifications/PostQueryNotification]);
GRANT SUBSCRIBE QUERY NOTIFICATIONS TO [User Name];
GRANT RECEIVE ON "NCacheSQLQueue-[IP-Address]" TO [User Name];
GRANT RECEIVE ON QueryNotificationErrorsQueue TO [User Name] ;
GRANT SEND ON SERVICE :: "NCacheSQLService-[IP-Address]" to [User Name] ;
  • IReplace [IP-Address] with node IP address and [User Name] with database user name.
  • In a clustered environment, users are supposed to create SQL Service and Queue per NCache process.
  • You can also create required SQL Service and Queue using script "NCacheServiceQueue.sql" located at:
"%Install Directory%/NCache/bin/resources"
iii. Adding Data with SQL Dependency
To add data with Sql dependency, create SqlCacheDependency object, and use Add/Insert API to add item with SqlCacheDependency.
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
try
{
//Creating SqlCacheDependency
string connectionString = "Data Source=localhost;Initial Catalog=Northwind;Integrated Security=SSPI;";
string query="SELECT ProductID FROM dbo.Products WHERE ProductID = 1001";
SqlCacheDependency sqlDependency = new SqlCacheDependency(connectionString,query);
//Adding cache item "Product:1001" with SqlCacheDependency
cache.Insert(key, product, sqlDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch (OperationFailedException e)
{
Console.WriteLine(e.ToString());
}
//Modifying Product record in database will automatically remove Product from cache
See Also
Cache Dependencies Overview | Using Oracle Dependency | Using Polling Based Dependency | Using CLR Procedures to Call NCache | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Oracle Dependency

< Previous page Next page >

Using Oracle Dependency

Oracle Dependency is provided by NCache for synchronizing cache with Oracle database. Item expires if result of the command (based on command text) changes. Oracle Dependency is only available for Oracle database 10g release 2 or later. Also make sure that Oracle Data Providers for .NET (version 10.1.0.2.0 or later) is installed.
i. Configuring Notification on Oracle server
NCache tracks changes in database using notifications received from Oracle server. For this purpose NCache registers Change Notification with oracle server. NCache server should have Change Notification privileges to create notification registration. Grants the Change Notification privilege to the user by following statement.
[SQL]
"grant change notification to scott"
ii. Adding Data with Oracle Dependency
Following code shows how to add data with Oracle Dependency. Altering data after addition with Oracle Dependency will remove it from cache.
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
try
{
//Creating OracleCacheDependency
String connectionString = "User Id=scott;Password=tiger;Data Source=oracle";
string query = "SELECT rowID, productID FROM dbo.Products WHERE productID = 1001";
OracleCacheDependency oracleDependency = new OracleCacheDependency(connectionString, query);
//Adding cache item "Product:1001" with SqlDependency
cache.Insert(key, product, oracleDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
//Modifying Product record in database will automatically remove Product from cache
}
catch (OperationFailedException e)
{
// handle exception
}
In Oracle 10g, database change notifications are only object based. This means that change notifications will be fired if any row is modified in object. Therefore rowID needs to be checked to confirm if the row changed is the one for which the event is registered. RowID's cannot be retrieved unless explicitly included in query. Therefore customer has to include rowID in query that they are registering with OracleDependecy, otherwise change notification will be fired if any row is modified in table.
When rowID is included in query like: "select rowID, productID, productname, unitprice from Products where ProductID = 220"; NCache will save the rowID of rows for which change notification is registered. When it receives any change notification, NCache will compare the rowIDs to determine whether the row changed is the one for which the rowID is registered. Otherwise NCache will have no way to check this and items for which change notification is registered will be removed after any row in table changes.
In Oracle 11g both object based and query based (default) notifications are provided. In query based notifications; change of the modified row will be notified only if the change notification is registered for it.
See Also
Cache Dependencies Overview | Using SQL Dependency | Using Polling Based Dependency | Using CLR Procedures to Call NCache | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Polling Based Dependency

< Previous page Next page >

Using Polling Based Dependency

Polling based dependency enables you to keep the cache items synchronized with any of the database. SQL and Oracle dependencies explained earlier need SQL/Oracle databases to notify NCache about any change in the database, however if database does not provides Change Notifications feature, NCache provides the facility to synchronize cache with database using polling based dependency.
i. How to Prepare Database for Polling Dependency
Since polling based dependency works as NCache polls database for changes, database has to be configured to keep record of changes in database. This includes creating a table named "ncache_db_sync" and creating a trigger to update this table according to changes in database.
Follow these steps to configure database:
  • Create a table 'ncache_db_sync' having four fields (cache_key VARCHAR, cache_id VARCHAR, modified BIT and work_in_progress BIT). Script to create the table is as follows:
//Create table'ncache_db_sync'
CREATE TABLE ncache_db_sync(
cache_key VARCHAR(256),
cache_id VARCHAR(256),
modified BIT DEFAULT(0),
work_in_progress BIT DEFAULT(0),
PRIMARY KEY(cache_key, cache_id) );
  • Create UPDATE and DELETE triggers, for every table on which notification is required. They set the 'modified' field of corresponding row in the ncache_db_sync table to 1.To carry out the task, see the following sample script that creates trigger on 'Products' table:
//create trigger
CREATE TRIGGER myTrigger
ON dbo.Products
FOR DELETE, UPDATE
AS
UPDATE ncdbs
SET modified = 1
fromncache_db_syncncdbs
inner join Deleted old on cache_key = (Cast((old.ProductID) as VarChar)
+ ':dbo.Products' );
The syntax of SQL scripts specified here are for SQL server database. Change the syntax according to the database.
Now as soon as an item is added to the cache with dependency, a row will be created in table 'ncache_db_sync' for this cache key. The format of cache key while adding into cache should exactly be the exactly same as defined in the corresponding trigger, e.g., for trigger explained above, cache key for product id 10 should be, "10:dbo.Products".
ii. Adding Data with Polling Based Dependency
The following code shows the use of polling based dependency with SQL server database, where database has been already configured to use polling based dependency.
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
try
{
//Creating Polling based dependency
string connectionString = "Provider=SQLOLEDB;Data Source=localhost;Database=northwind;User Id=sa;Password=;";
DBCacheDependency oledbDependency = DBDependencyFactory.CreateOleDbCacheDependency(connectionString, product.ProductID + ":dbo.Products");
//cache key for product id 1 will be "1:dbo.Products"
cache.Insert(product.ProductID + ":dbo.Products", product, oledbDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, Alachisoft.NCache.Runtime.CacheItemPriority.Default);
}
catch (OperationFailedException e)
{
// handle exception
}
//Modifying Product record in database will automatically remove Product from cache
See Also
Cache Dependencies Overview | Using SQL Dependency | Using Oracle Dependency | Using CLR Procedures to Call NCache | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using CLR Procedures to Call NCache

< Previous page Next page >

Using CLR Procedures to Call NCache

Database dependencies using SQL server notifications may reduce application's performance as SQL server throws a separate notification for each data update which is then handled by NCache. If there are too many changes being made in database, notifications may overwhelm network traffic, reducing performance of both NCache and user application.
NCache allows you to write CLR stored procedures for database to synchronize cache with the database. CLR procedures does not involve creating dependency data structures like SqlCacheDependency, also no database monitoring or notification mechanism is required. To use CLR store procedures for NCache, follow steps specified below. All example SQL scripts specified are for SQL Server 2008 and .NET framework 2.0.
i. Enable CLR Integration on Database
The user should allow CLR procedures to be executed in database by executing the following query on his/her database:
-- Enable CLR Integration on Database
sp_configure'clr enabled', 1
GO
RECONFIGURE
GO
ii. Register Assemblies with Database
To use NCache in CLR stored procedure, NCache assemblies need to be registered with database. This will enable database to use NCache API in stored procedure.
SQL server does not resolve referred assemblies from GAC, therefore assemblies required by NCache need to be copied in NCache assemblies directory before deploying them on database. Copy these assemblies from GAC to "NCache/bin/assembly/2.0" folder (choose 4.0 if the target platform is .NET 4.0).
  • log4net.dll
  • protobuf-net.dll
  • Oracle.DataAccess.dll
Copy following assemblies from"NCache\bin\IDE\NCache Manager" to "NCache/bin/assembly/2.0"
  • Renci.SshNet.dll
  • SharpSnmpLib.dll
Execute the following query to register assemblies (If NCache install directory is different from used in this query, change path accordingly).
use Northwind
alter database Northwind
set trustworthyon;
go
-- REGISTER SYSTEM ASSEMBLIES ...
dropassembly [System.ServiceModel]
dropassembly SMdiagnostics
dropassembly [System.Web]
dropassembly [System.Messaging]
dropassembly [System.Management]
CREATEASSEMBLY [SMdiagnostics] AUTHORIZATION dbo FROM N'C:\Windows\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation\SMdiagnostics.dll' WITHpermission_set=unsafe
CREATEASSEMBLY [System.Web] AUTHORIZATION dbo FROM N'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.Web.dll' WITHpermission_set=unsafe
CREATEASSEMBLY [System.Management] AUTHORIZATION dbo FROM N'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.management.dll' WITHpermission_set=unsafe
CREATEASSEMBLY [System.Messaging] AUTHORIZATION dbo
FROM N'C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Messaging.dll'
WITHpermission_set=unsafe
CREATEASSEMBLY [System.ServiceModel] AUTHORIZATION dbo
FROM N'C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0\System.ServiceModel.dll'
WITHpermission_set=unsafe
--REGISTER NCACHE ASSEMBLIES ...
CREATEASSEMBLY [Alachisoft.NCache.Web] FROM N'C:\Program Files\NCache\bin\assembly\2.0\Alachisoft.NCache.Web.dll'WITHpermission_set=unsafe
iii. Create and Deploy CLR Stored Procedure
  • Create a SQL CLR database project for your database in Visual Studio as shown below.
  • Add reference to NCache assembly named "Alachisoft.NCache.Web" in project.
  • Add a stored procedure in your project. Write synchronization logic in database. Following is a sample CLR stored procedure which will remove an item if it is updated in cache.
Public partial class StoredProcedures
{
[Microsoft.SqlServer.Server.SqlProcedure]
public static void RemoveOnUpdate(string cacheName, string key)
{
try
{
if (string.IsNullOrEmpty(cacheName))
cacheName = "mycache";
if (!string.IsNullOrEmpty(key))
{
Cache cache = NCache.InitializeCache(cacheName);
cache.Delete(key);
cache.Dispose();
}
}
catch (OperationFailedException exp)
{
//handle exception
}
}
}
  • Deploy stored procedure on database. After deployment stored procedure will appear in database stored procedures, as shown below.
iv. Write Trigger to Call Stored Procedure
Finally a database trigger needs to be written that will call stored procedure created in the previous steps whenever an update or delete is performed on database table. Following is a sample script to create trigger on Product table in Northwind database:
Create TRIGGER [dbo].[myTrigger]
ON [dbo].[Products]
FOR DELETE,UPDATE
AS
Declare @cacheName asnvarchar(4000)
declare @key asvarchar(4000)
select @key=Cast((Deleted.ProductID)asnVarChar)+':dbo.Products', @cacheName='mycache' from Deleted
EXEC dbo.RemoveOnUpdate@cacheName, @key
v. Adding Data in Cache
Following is a sample code that adds an item in cache and updates it in database to verify that item has been removed from cache:
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
try
{
//Cache key should be same as used in trigger
cache.Insert("1:dbo.Products", product);
}
catch (OperationFailedException e)
{
// handle exception
}
//Modifying Product record in database will automatically remove Product from cache
While adding data in cache, cache key format should be same as passed to stored procedure from trigger in database.
See Also
Cache Dependencies Overview | Using SQL Dependency | Using Polling Based Dependency | Using Oracle Dependency | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Synchronizing Cache with Custom Data Sources

< Previous page Next page >

Synchronizing Cache with Custom Data Sources

In custom dependency, the user can have his own dependencies scenarios. In this way, items can be be expired from cache in a number of flexible ways where expiration logic meets the user’s business requirements. NCache provides an abstract class ExtensibleDependency that is base for all dependencies. For defining his own dependency, the user's dependency class needs to inherit ExtensibleDependency class and change the definition of abstract function HasChanged(). Once implemented, place the assembly or executable file of class overriding ExtensibleDependency in NCache service folder and restart the NCache service.
For more details, please read Custom Cache Dependency in section Server Side API Programming .
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Synchronize Data across Multiple Caches

< Previous page Next page >

Synchronize Data across Multiple Caches

NCache cache sync dependency provides a way to synchronize two caches, so that an item updated or removed from one cache have the same effect on the synchronized cache.
Adding Data with Cache Sync Dependency
The following code explains the use of cache synch dependency. An item in clustered cache 'myreplicatedcache' is replicated in local cache 'mycache' with cache sync dependency. Any change in clustered cache will automatically remove dependent item in local cache.
Note that for cache sync dependency, item must exist in cache before another item can be added with dependency on it.
try
{
Cache cache1 = NCache.InitializeCache("mycache");
Cache cache2 = NCache.InitializeCache("myreplicatedcache");
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
cache1.Insert(key,product);
CacheSyncDependency dependency = new CacheSyncDependency("mycache",key);
CacheItem cacheItem = new CacheItem(cache1.Get(key));
cacheItem.SyncDependency = dependency;
cache2.Insert(key, cacheItem);
//Removing/Deleting item from cache1 will expire it from cache2 as well
catch (OperationFailedException e)
{
// handle exception if any cache operation fails
}
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Add Dependency to the Existing Cached Item

< Previous page Next page >

Add Dependency to the Existing Cached Item

If data has been added to cache without dependency, NCache allows to add any of the dependency supported by NCache, with this existing data without any need of updating data. This can be done using AddDependency API of NCache.
The following code shows how to add dependency with existing data.
string key1="Product:1001";
string key2="Product:1002";
// precondition: items with keys "Product:1001" and Product:1002" are already in cache
try
{
cache.AddDependency(key2, new KeyDependency(key1), false);
}
catch (OperationFailedException ex)
{
// handle exception
}
To add file dependency use:
cache.AddDependency(key, new FileDependency(filepath), false);
Any dependency can be added with the existing cached item with the same API.
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Aggregate Cache Dependency
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Aggregate Cache Dependency

< Previous page Next page >

Aggregate Cache Dependency

NCache provides feature of Aggregate dependency to support multiple dependencies with a single cache item. The following code explains how to add AggregateCacheDependency with an item.
Product product=new Product();
product.ProductID=1002;
product.ProductName="Chang";
string key="Product:"+product.ProductID;
try
{
//Initializing Aggregate Dependency; Item dependant on File and Key
AggregateCacheDependency aggregateDependency = new AggregateCacheDependency();
aggregateDependency.Dependencies.Add(new FileDependency("C:\\tempProductList.txt"));
aggregateDependency.Dependencies.Add(new KeyDependency("Product:1001"));
//Inserting item with AggregateCacheDependency
cache.Insert(key, product, aggregateDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch (OperationFailedException e)
{
// handle exception
}
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Locking

< Previous page Next page >

Locking

Locking prevents multiple clients from updating the same data simultaneously and also ensures data consistency. A proper locking mechanism is necessary to ensure data consistency when there is a possibility of multiple clients accessing and possibly modifying the same data at the same time. This section the locking feature provided by NCache.
In This Section
Overview
Explains the basic concept of locking and types of locking in NCache
Locking Items in Cache
Explains how to lock an item in cache using NCache API.
Using Cache Item Versioning
Explains how to use Cache Item Versioning feature of NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

NCache provides a variety of ways to manipulate the cache data suitable for different use cases in different environments. NCache provides a clustered environment where multiple clients can access cache data. In such situation, parallel requests may occur for same data changes e.g. multiple parallel threads from within multiple applications can issue an update call against the same data. Internally, NCache allows every request to execute as much in parallel as possible to get the best performance without sacrificing data integrity. Every update in the cache store is treated as atomic and even replication between active and mirror nodes follow the same strategy to guarantee data consistency across the entire cache cluster. Beside this, NCache provides with an API to lock specific cache data, so that only a single thread can update or read it.
There are two types of locking available with NCache:
  • Optimistic Locking (Cache Item Versioning)
  • Pessimistic Locking (Exclusive Locking)
Optimistic Locking (Cache Item Versioning)
In optimistic locking, NCache uses cache item versioning. Cache Item Version is a property associated with every cache item. It is basically a numeric value that is used to represent the version of cached item which changes with every update to an item. This property allows tracking whether any change occurred in item or not. When an item is fetched from cache, its current version is also fetched at the same time.
Cache item version can be specified in data update call. This update call succeeds only if the current version of the cache item is the same as passed by the client otherwise, it fails. This is used when a user wants to update a cache item which he/she has previously read from cache. If someone else has updated the cache item, update should fail. In this way each client will update only the latest copy of the data and hence maintain data integrity throughout the cache.
The latest version of item can be retrieved from cache through GetIfNewer API. Through this method, the user provides the existing version and asks the for more latest version if any. In this way, it can be track that whether an item is updated in cache or not.
Pessimistic Locking (Exclusive Locking)
NCache provides a locking mechanism, that exclusively locks the cached data. In this mechanism APIs with lock handle should be used. A lock handle is a handle associated with every locked item in the cache, which is returned by locking API. A locked item can be fetched/updated or unlocked only when its lock handle is provided at API level. However, it should be done with care to avoid data integrity issues. This locking mechanism is useful in situation when the user wants to exclusively lock his/herr cache data to prevent multiple clients to update it simultaneously.
Lock Expiration: Lock timeout can also be specified while locking a cached item. The lock timeout is the time interval after which lock will be automatically released if no explicit call is made for releasing the lock during time out interval. This will prevent data from being locked for infinite time.
Forceful Release of Locks: Situation can arise in distributed environments when an application which had acquired the lock on a cache item terminates abruptly. In such a situation, all the locks acquired by such an application should be released. NCache provides unlock API, which releases the cache item lock forcefully.
Special Consideration while using Locking API
NCache provides set of APIs with and without lock handle to fetch/update the cache item. APIs without lock handle ignores item locking. So you should use all locking APIs for data manipulation. For example, if an item is locked and an update API call is made which does not take lock handle as input parameter, then item will be updated in the cache irrespective of its locking state. Therefore, when using locking feature , only those API calls should be used which take lock handle as parameters. APIs which do not take lock handle can be used but with a lot of care so that it does not affect data integrity.
In case of eviction/expiration, NCache ignores locks which mean that a locked item can be removed as a result of expiration or eviction.
See Also
Locking Items in Cache | Using Cache Item Versioning | Data Invalidation Strategies | Cache Dependencies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Locking Items in Cache

< Previous page Next page >

Locking Items in Cache

A lockHandle is associated with item to be locked. This ensures that the particular item remains inaccessible throughout the cache. Two primary properties lockId and lockdate are used for locking while performing various cache operations.
NCache provides method calls exclusively for locking as well as numerous overloads that manipulate the locking mechanism.
Locking an Item Explicitly
Lock on an item can be acquired explicitly before performing any operation. Lock method requires a TimeSpan to lock an item for a specified time. However, if you do not want the acquired lock to expire simply specify a new TimeSpan(). The lock method used in this example associates a lockHandle. Kindly ensure that the single LockHandle is associated with a single key. Release the lock before re-using the handle; otherwise it might lead to inconsistency of behavior.
//create a new lock Handle
LockHandle lockHandle = new LockHandle();
string key="Product:1001";
try
{
// Specifiying the time span of 10 sec for which the item remains locked
bool locked = cache.Lock(key, new TimeSpan(0, 0, 10), out lockHandle);
}
catch (OperationFailedException ex)
{
// handle exception
}
Locking an Item During Fetch Operation
An item while being retrieved. The item will be inaccessible for others unless it is released. In case of a mismatch of key, null is returned.
In this example, a key and a lockHandle for the key should be provided to fetch the cached object and lock it. “True” should be given if the user wants to acquire lock.
LockHandle lockHandle = new LockHandle();
//Specify time span of 10 sec for which the item remains locked
TimeSpan lockSpan = new TimeSpan(0,0,10);
string key="Product:1001";
try
{
object result = cache.Get(key, lockSpan , ref lockHandle,true);
if (result != null)
{
if (result is Product)
{
Product product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Locking with Expiration
If time is specified as a value of TimeSpan(), NCache would lock the item for that specified duration.
LockHandle lockHandle = new LockHandle();
//Specify time span of 10 sec for which the item remains locked
TimeSpan lockSpan = new TimeSpan(0,0,10);
string key="Product:1001";
try
{
bool lockAcquired = cache.Lock(key, lockSpan, out lockHandle);
//Verify that the lock is released automatically after this time period.
}
catch (OperationFailedException ex)
{
// handle exception
}
Releasing Lock with Update Operation
While updating an item, the lock can be released allowing other cache clients to use the cached data. In order to successfully release the locked item, you will lockHandle that was initially used to lock the item must be specified. In case of an invalid or different handle, NCache would throw an OperationFailedException.
Product updatedProduct = new Product();
updatedProduct.ProductID = 1001;
updatedProduct.ProductName = "Chai";
updatedProduct.Category = 4;
string key = "Product"+ updatedProduct.ProductID;
LockHandle lockHandle = new LockHandle();
try
{
// lock exisiting item for the time span of 30 seconds
bool locked = cache.Lock(key, TimeSpan.FromSeconds(30), out lockHandle);
if (locked)
{
cache.Insert(key, new CacheItem(updatedProduct), lockHandle, true);
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Releasing Lock Explicitly
In order to release lock forcefully on a previously locked cached item, lockHandle that was used to lock the key should be specified.
LockHandle lockHandle = new LockHandle();
string key = "Product:1001";
try
{
// lock an existing item and save the lockHandle for 10 seconds
bool locked = cache.Lock(key, new TimeSpan(0, 0, 10), out lockHandle);
if (locked)
{
// unlock locked item using saved LockHandle
cache.Unlock(key, lockHandle);
}
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Locking Overview | Using Cache Item Versioning | Data Invalidation Strategies | Cache Dependencies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Cache Item Versioning

< Previous page Next page >

Using Cache Item Versioning

CacheItemVersion adds an additional dimension to the development of application using NCache. Optimistic Concurrency can be achieved in applications by NCache Item Versioning.
When any item is added in cache, cache item version is returned to the cache client. This value denotes the number of updates performed on a particular data. With every update, item version value is incremented.
Saving Item Version for the First Time
An add operation returns CacheItemVersion. If the item is added for the first time ‘1’ is returned. This version will be used in future operations on this key.
In this example a custom data with key “Product:1001” is added in cache and its item version is saved. However, it should be ensured that the object is either .NET serialized or registered with NCache Compact serialization framework.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
CacheItemVersion itemVersion = cache.Add(key, product);
//Save this item Version for future utilization
}
catch (OperationFailedException ex)
{
// handle exception
}
Updating Item with Specific Version
In environments where multiple applications work on a single cache, item version can be used to ensure that the data which is updated is the same as in cache and is not updated priorily by any other cache client.
In this example, a previously cached item is upated by specifying item version. If the specified version is equal to the one in the cache, then it will be updated else OperationFailedException will be thrown by NCache.
//precondition: itemVersion is saved when item was added in cache
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.Category = 5; // updated category
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
//saved itemVersion from add item call
cacheItem.Version=itemVersion;
try
{
CacheItemVersion newVersion = cache.Insert(key, cacheItem);
//save new version for future usage
//verify the updated version and value in cache
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving Cached Item with Specific Version
A cached item can be retrieved by specifing version. In case of a mismatch of version, null is returned.
In this example, key and the previously saved item version of that key needs to be specified to fetch the cached object.
//precondition: itemVersion is saved when item was added or inserted in cache
try
{
string key="Product:1001";
//saved itemVersion from add or insert item call
CacheItem result = cache.GetCacheItem (key,ref itemVersion);
if (result.Value != null)
{
if (result.Value is Product)
{
Product product = (Product)result.Value;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving Item if a Newer Version Exists in Cache
GetIfNewer method can be used to fetch the existing item if a newer version is available in cache. By specifying the current version as an argument of the method, cache returns the appropriate result.
If the version specified is less than the one in cache, only then the method returns a new Item else null would be returned.
//precondition: itemVersion is saved when item was added or inserted in cache
string key="Product:1001";
try
{
//saved itemVersion from add or insert item call
object result = cache.GetIfNewer(key,ref itemVersion);
if (result != null)
{
if (result is Product)
{
Product product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Removing an Item with a Specific Item Version
A remove method is a basic method which removes the key from cache and returns the removed object to cache. If custom object is added to cache, remove method will return Object.
If the item version is different from the one in cache or if the key does not exist an OperationFailedException will be thrown by NCache.
//precondition: itemVersion is saved when item was added or inserted in cache
string key="Product:1001";
try
{
//saved itemVersion from add or insert item call
object result = cache.Remove(key,itemVersion);
if (result != null)
{
if (result is Product)
{
Product product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Deleting an Item with Item Version
A delete method is a basic method which deletes the key from cache. If the item version is different from the one in cache or if the key does not exist, an OperationFailedException will be thrown by NCache.
//precondition: itemVersion is saved when item was added or inserted in cache
string key="Product:1001";
try
{
//saved itemVersion from add or insert item call
cache.Delete(key,itemVersion);
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Locking Overview | Locking Items in Cache | Data Invalidation Strategies | Cache Dependencies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Object Query Language (OQL) in NCache

< Previous page Next page >

Object Query Language (OQL) in NCache

Locking prevents multiple clients from updating the same data simultaneously and also ensures data consistency. A proper locking mechanism is necessary to ensure data consistency when there is a possibility of multiple clients accessing and possibly modifying the same data at the same time. This section the locking feature provided by NCache.
In This Section
Overview
Explains the basic concept of OQL provided by NCache
Object Query Language (OQL) Syntax
Explains the syntax of OQL provided by NCache.
NCache Language Integrated NCache Query (LINQ)
Explains how LINQ can be used in NCache for querying.
Querying Data in NCache
Explains how to query data in NCache using indexing mechanism.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

Most of the applications use cache for storing key-value pair type of data. Every data item can be retrieved through keys like primary keys are used to find data in any relational database. This approach seems good when it is known that which key is associated with what kind of data but in large and complex applications, items can’t be retrieved through keys only. There might be a need to search relative data for any specific attribute value because a lot of live data is stored in the cache. A very basic example can be of e a web e-commerce application where there might be a need for fetching all products related to specific category etc. In such a case, category based keys cannot be specified for all the products and hence keys lists cannot be used for retrieval.
For searching purpose, NCache provides a powerful searching mechanism where cache keys/data can be fetched using SQL like query syntax. NCache provides with NQL (NCache Query Language) which is the subset of SQL. NQL facilitates searching the cache against criteria on which data is required. For the e commerce web application, if all the products related to a particular category are to be retrieved, then a sample query in NQL would be something like follows:
Sample query: "SELECT Product WHERE this.Category = ?"
By specifying a particular category in this query, all product keys and cached items that have the specified category can be searched.
NCache allows searching and deleting result set according to a query criteria. It means that cache can be updated through queries at runtime when needed.
NCache requires all searchable attributes to be indexed before using those indexes. These settings are not hot applicable so they should be defined before cache start. See Indexing in NCache for details on indexing.
See Also
Object Query Language (OQL) Syntax | NCache Language Integrated NCache Query (LINQ) | Querying Data in NCache | Continuous Query | Indexing | Configuring Query Indexes
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Object Query Language (OQL) Syntax

< Previous page Next page >

Object Query Language (OQL) Syntax
This feature is not available in NCache Express and Professional edition.
NCache supports SQL-like language called Object Query Language (OQL). A rich set of operators are provided by NCache according to required query criteria to fetch the desired result set from cache.
OQL is not case sensitive.
The following operator categories are supported in NCache queries:
Category | Operator
<Query> | = , == , != , <> , < , > , <=, >=, IN, LIKE , NOT LIKE
Logical Operators | AND , OR , NOT
Aggregate Functions | Sum, Count, AVG, Min, Max
Miscellaneous | DateTime.Now , DateTime ("any date time compatible string")
Syntax of the language is explained with the help of examples below:
Basic Query Operators
Operator | Description | Example
= OR == | Equals to | "SELECT Product WHERE this.ProductID == ?"
!= OR <> | Not equals to | "SELECT Product WHERE this.ProductID <> ?"
< | Less than | "SELECT Product WHERE this.ProductID < ?"
> | Greater than | "SELECT Product WHERE this.ProductID > ?"
<= | Less than equal to | "SELECT Product WHERE this.ProductID <= ?"
>= | Greater than equal to | "SELECT Product WHERE this.ProductID >= ?"
IN | In a range | "SELECT Product this.UnitsAvailable IN (?,?,?,?))"
LIKE | Pattern like. Mostly used for wild card base searching. Use "*" for one or many occurrence of character. Use "." for single occurrence of character. | "SELECT Product WHERE this.ProductName LIKE ? AND this.Category LIKE ?"
NOT LIKE | Not like pattern | "SELECT Product WHERE this.ProductID NOT LIKE ?"
Logical Query Operators
Operator | Description | Example
AND | Retrieve merged result set for two or more conditions. | "SELECT Product WHERE this.ProductName LIKE ? AND this.Category LIKE ?"
OR | Retrieve result set whichfulfills any one condition. | "SELECT Product WHERE this.ProductName NOT LIKE ? OR this.Category NOT LIKE ?";
NOT | Retrieve result set which doesn't match the given criteria. | "SELECT Product WHERE this.ProductID NOT LIKE ?"
Aggregate Function
Operator | Description | Example
Sum | Calculate sum of result set of specified criteria. | "SELECT SUM(Product.UnitsAvailable) WHERE this.ProductID <= 10"
Count | Calculates count of the result set for a specified criteria. | "SELECT count(Product) WHERE this.ProductID < ?"
Avg | Calculates average of the result set for specified criteria. | "SELECT AVG(Product.UnitsAvailable) WHERE this.ProductID < ?"
Min | Returns minimum of the result set for specified criteria. | "SELECT MIN(Product.UnitsAvailable) WHERE this.Category = ?"
Max | Returns maximum of the result set for specified criteria. | "SELECT MAX(Product.UnitsAvailable) WHERE this.Category = ?
Miscellaneous
Operator | Description | Example
DateTime.Now | Retrieve result set with respect to current date time. | "SELECT Order WHERE this.OrderDate = ?"
DateTime ("any date time compatible string") | Retrieve result set with respect to specified date time. | "SELECT Order WHERE this.OrderDate = ?"
See Also
OQL in NCache Overview | NCache Language Integrated NCache Query (LINQ) | Querying Data in NCache | Continuous Query | Indexing | Configuring Query Indexes
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Language Integrated Query (LINQ)

< Previous page Next page >

NCache Language Integrated Query (LINQ)

LINQ allows fetching data of any type through a set of pre-defined standard rules. This helps in setting a common standard through which data can be accessed. It simply joins the application's object layer to data layer. Data can be retrieved in collection of any possible data structure like objects, XML tree, lists etc but there will be no change in the retrieval format of code. If the model is created through LINQ, then there is no need to worry about inner details.
NCache allows using LINQ with cache to improve the application’s performance through caching without changing the LINQ object model. The cache handle should be given to the NCache LINQ provider after creating its instance. NCache LINQ provider converts LINQ related query into NQL format and returns the result accordingly after transforming it in LINQ format. Because of using NQL under the wrapper of NCache LINQ provider, indexes should be configured for using LINQ too.
Here is a sample query in LINQ
var result = from product in products
where product.ProductID > 10
select product;
In this query, all those products which have Product ID greater than 10 will be fetched from the cache. The query format is the same as when normal LINQ is used without NCache LINQ provider. Here ProductID and other required attributes need to be indexed before using this query with NCache.
There are some LINQ operators which are not supported by NCache LINQ Provider. These are:
  • NCache LINQ Provider does not support nested queries.
  • LINQ operator ORDERBY is not supported by NCache LINQ Provider.
  • LINQ operator GROUPBY is not supported by NCache LINQ Provider.
  • Join operations are not supported by NCache LINQ Provider.
Runtime indexing is not supported in NCache LINQ integration now.
To provide LINQ benefits, LINQ is integrated with NCache by implementing a class named NCacheQuery, which further implements the interface called IQueryable provided by .NET framework. This integration allows the user to run LINQ queries on cached items. For executing LINQ queries on cached items, an object implementing IQueryable interface should be defined and passed as an instance of cache which contains the object as shown below:
IQueryable<Product> products = new NCacheQuery<Product>(cache);
Defining Indexes
NCache requires all searchable attributes to be indexed. NCache provides its own indexing mechanism through which the users can identify objects in .NET assemblies that they want to index. See the section Indexing for details.
NCache only support single entity search, multiple entities or joins are not supported.
Using LINQ
No code change is required for using NCache with LINQ except that a new assembly reference and namespace should be added in application. Rest of the code will work without any change in application.
The namespace to be added in application for LINQ support is as follows:
using Alachisoft.NCache.Linq;
The following code shows how to implement the NCacheQuery class which further implements IQueryable interface. The code also shows the LINQ query based on NCache Query Language running on a cached data.
//create your custom class LINQ object by giving handle of your cache.
IQueryable<Product> products = new NCacheQuery<Product>(cache);
try
{
var result = from product in products
where product.ProductID > 1010
select product;
if (result != null)
{
foreach (Product product in result)
{
//put your code here for modification of products.
}
}
else
{
//if there is no result in the cache related to your query
}
}
catch (Exception)
{
// can be operation failed due to server lost, state transfer or invalid query format of LINQ
}
See Also
OQL in NCache Overview | Object Query Language (OQL) Syntax | Querying Data in NCache | Continuous Query | Indexing | Configuring Query Indexes
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Querying Data in NCache

< Previous page Next page >

Querying Data in NCache

NCache provides the ability to query the indexed cache data. NCache provides its own indexing mechanism. Indexing for searchable objects and their attributes need to be configured first as explained in earlier sections.
Using API for Querying
The following API is available for using NCache query feature:
public ICollection Search(string query, IDictionary searchValues)
public IDictionary SearchEntries(string query, IDictionary searchValues)
public ICacheReader ExecuteReader(string query, IDictionary searchValues)
Methods
Name | Return Type | Description
Search | ICollection | Only return list of keys in result set which fulfill the query criteria.
SearchEntries | IDictionary | Return list of key-value pairs in result set which fulfill the query criteria. This key value pair have cache key and their respective value.
ExecuteReader | ICacheReader | Return result set for GROUP BY clause in the form of columns which fulfill the query criteria. NOTE: ExecuteReader is only used with 'GROUP BY' clause and with aggregate queries.
Parameters
Name | Type | Description
Query | String | Query string but instead of values '?' will be specified by user, e.g., "SELECT Product WHERE this.ProductID == ?"
searchValues | IDictionary | Key-value pairs of attribute-names and their values on which your search criteria is based on. Hashtable searchValues = new Hashtable(); searchValues.Add("ProductID", 1);
Adding and Updating Indexed Items
Before searching, items need to be indexed and added in cache. For adding indexed items, the basic APIs of add and insert as mentioned in NCache Basic Operations should be used.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, product);
}
catch (OperationFailedException ex)
{
// handle exception
}
Cache Search Returning Keys
The following code searches the cache and returns a collection of keys. Then, it iterates over all the returned keys and individually fetches the corresponding cached items from the cache.
Hashtable values = new Hashtable();
values.Add("ProductName", "Chai");
values.Add("UnitsInStock", 250);
try
{
// Instead of Product, specify fully qualified name of your custom class.
string query = "SELECT Product where this.ProductName = ?";
ICollection result = cache.Search(query, values);
query = "SELECT Product WHERE this.UnitsInStock > ?";
result = cache.Search(query, values);
query = "SELECT Product WHERE this.ProductName = ? and this.UnitsInStock > ?";
result = cache.Search(query, values);
query = "SELECT Product WHERE Not(this.ProductName = ? and this.UnitsInStock > ?)";
result = cache.Search(query, values);
}
catch (OperationFailedException ex)
{
// handle exception
}
The benefit of this approach is that the query returns keys only. Then, the client application can determine which key it wants to fetch. The drawback of this approach is increased number of trips to cache as most of the items are fetched from cache anyway. And, if the cache is distributed, this may eventually become costly.
Cache Search Returning Items
In some situations when the intention is to fetch all or most of the cached items associated with cache keys, it is better to fetch all the keys and items in one call. Below is an example of such a scenario. It searches the cache and returns a dictionary containing both keys and values. This way, all the data based on the search criteria is fetched in one call to NCache. This is much more efficient way of fetching all the data from the cache. Example is mentioned below.
string queryString = " SELECT Product where this.ProductID = ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 1001);
IDictionary items;
try
{
//Call SearchEntries for fetching result set in key value pairs.
items = cache.SearchEntries(queryString, values);
}
catch (OperationFailedException ex)
{
// handle exception
}
if (items.Count > 0)
{
IDictionaryEnumerator ide = items.GetEnumerator();
while (ide.MoveNext())
{
String key = (String)ide.Key;
Product product = (Product)ide.Value;
// use cache keys and values in your application code here.
}
}
Cache Search with Execute Reader (Group by)
For grouping the result set of aggregate functions on the basis of one or more columns, GROUP BY clause is used in queries. For executing queries with GROUP BY in NCache, ExecuteReader() function is used. It returns result set in tabular form in ICacheReader type of instance. Result of GROUP BY query is not sorted. Columns count and attribute values can be fetched through their names from ICacheReader. Example is as follows:
string queryString = "SELECT this.Category MAX(Product.ProductID) GROUP BY this.Category where this.Category = ?";
Hashtable values = new Hashtable();
values.Add("Category", 4);
ICacheReader result = cache.ExecuteReader(queryString, values);
if (result.ColumnCount > 0)
{
while (result.Read())
{
String category = (String)result.GetValue("Category");
//use other values in your code if needed.
}
}
Here is the complete code sample which uses all search APIs:
try
{
string queryString = "SELECT Product where this.ProductID = ?";
//Query for GROUP BY
string queryString2 = "SELECT this.Category,this.Supplier COUNT(Product.ProductID) GROUP BY this.Category,this.Supplier where this.Category = ?";
Hashtable values = new Hashtable();
values.Add("ProductID",1001);
values.Add("Category", 4);
//Call Search for fetching result set related keys only.
ICollection keys = cache.Search(queryString, values);
//Call SearchEntries for fetching result set in key value pairs.
IDictionary items = cache.SearchEntries(queryString, values);
// Call ExecuteReader for fetching result columns of any query with GROUP BY
ICacheReader result = cache.ExecuteReader(queryString2, values);
if (items.Count > 0)
{
IDictionaryEnumerator ide = items.GetEnumerator();
while (ide.MoveNext())
{
String key = (String)ide.Key;
Product product = (Product)ide.Value;
// use cache keys and values in your application code here.
}
}
}
catch (Exception ex)
{
// can be operation failed due to server lost, state transfer or invalid query format.
//Index not defined exception when attributes are not indexed.
//...
}
Querying Samples for Operators
Some code samples for different queries are given below:
Using Equal Operator
string queryString = "SELECT Product where this.ProductID = ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 1001);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using Multiple Operators
string queryString = "SELECT Product where this.ProductID < ? AND this.Category = ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 1001);
values.Add("Category", 4);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using IN Operator
string queryString = "SELECT Product where this.ProductID IN (?,?,?)";
ArrayList idList = new ArrayList();
idList.Add(10);
idList.Add(4);
idList.Add(7);
Hashtable values = new Hashtable();
values.Add("ProductID", idList);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using LIKE Operator
string queryString = "SELECT Product where this.ProductName LIKE ?";
ArrayList list = new ArrayList();
list.Add("Ch*");
Hashtable values = new Hashtable();
values.Add("ProductName", list);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using GROUP BY Clause
For using 'GROUP BY' clause, any aggregate function should be used in query and to get thequery result, ExecuteReader function should be used. GROUP BY clause cannot be used without aggregate function.
string queryString = "SELECT this.Category, COUNT(Product) WHERE this.ProductID > ? GROUP BY this.Category";
Hashtable values = new Hashtable();
values.Add("ProductID", 5);
try
{
ICacheReader reader = cache.ExecuteReader(queryString, values);
while (reader.Read())
{
string category = (string)reader.GetValue(0);
decimal countVal = (decimal)reader.GetValue(1);
}
}
catch(Exception ex)
{
// handle exception
}
Using DELETE Statement
For the delete statement, ExecuteNonQuery function should be used.
string queryString = "DELETE Product WHERE this.ProductID > ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 5);
try
{
int result = cache.ExecuteNonQuery(queryString, values);
//return number of effected rows.
}
catch(Exception ex)
{
// handle exception
}
See Also
OQL in NCache Overview | Object Query Language (OQL) Syntax | NCache Language Integrated NCache Query (LINQ) | Continuous Query | Indexing | Configuring Query Indexes
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Event Notifications

< Previous page Next page >

Event Notifications

This sections explains how to use notifications that arise as a result of events such as add, insert or remove operations against all or selective cache items, or when cluster status changes.
In This Section
Overview
Explains main types of notifications and levels of events provided by NCache.
NCache Events and Notifications
Explains how to use the three levels of events and notifications using NCache Client API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

Many applications today need to share data with each other at runtime asynchronously. And relational databases do not provide an efficient event notification mechanism. Hence their performance and scalability is a major concern.
NCache is an extremely fast and scalable in-memory distributed cache and also provides a simple and powerful Data Sharing Features with Notifications.
NCache features event driven fetching of data whenever the data in cache is modified. This allows client applications to receive data without any explicit data fetch request to the cache server. Events work on push mechanism for whenever there is some activity of interest takes place in cache, it publishes events to its subscribed clients. This allows runtime data sharing of single cache shared by separate applications or separate modules of same application.
Events enable NCache to notify client application if something of interest occurs. Events in NCache follow publisher subscriber model where cache is the publisher and client application is the subscriber.
Events have the following properties:
  • The publisher determines when an event is raised; the subscribers determine what action is taken in response to the event.
  • An event can have multiple subscribers. A subscriber can handle multiple events from multiple publishers.
  • Events are typically used to signal common cache operations like Add, Insert, Remove, Delete and Cache Cleared.
Types of Notifications
  • Add Notification
Add notification is triggered when a new item is added to the cache. All applications who have registered this event will receive a notification when data is added to the cache.
  • Update Notification
Update notification is triggered when an existing item is updated in the cache. All applications who have registered this event will receive a notification when data is updated in the cache.
  • Remove Notification
Remove notification is triggered when an item is removed from the cache. All applications who have registered this event will receive a notification when data is removed from the cache.
  • Cache Clear Notification
Cache Clear notification is triggered when cache is cleared. All applications who have registered this event will receive a notification when cache is cleared.
Levels of Events by NCache
NCache provides the following level of events:
  • Cache Level Events
NCache can notify clients on add, insert, and remove of any item in the cache or if the cache is cleared, if the client has registered interest in receiving such events.
  • Item Level Events:
NCache can notify clients on a specific item update and remove if the client has registered interest in it.
  • Continuous Query Events
NCache can monitor a dataset in the cache based on SQL-like criteria and then notify clients for add, update, and remove of items from this data set to clients who have registered interest in it.
  • Application Initiated Custom Events:
Applications can fire custom events into NCache so other applications who have registered interest in them can be notified.
See Also
NCache Event Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Event Notifications

< Previous page Next page >

NCache Event Notifications

NCache provides the following level of events:
  • Cache Level Events
  • Item Level Events:
  • Continuous Query Events
  • Application Initiated Custom Events
This section explains how to use event notifications at these three levels.
In This Section
Cache Level Data Event Notifications
Explains how to use notification mechanism for events occurring at cache level.
Item Level Data Event Notifications
Explains how to use notification mechanism for events occurring at item level.
Custom Event Notifications
Explains how to use custom events and notification mechanism provided by NCachel.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Level Data Event Notifications

< Previous page Next page >

Cache Level Data Event Notifications

Cache Level Data Notifications
Cache Level Notifications are fired when data is added in cache from clients, loader, read-through etc. Cache Level Data Notifications can be used to share data across different clients. The purpose of this feature is to notify clients about every operation performed on cache [add, insert, remove]. Clients that want to receive these notifications will have to register Cache Level Notification through RegisterCacheNotification API. Using this feature, the performance of cache will be a little low because cache has to send notifications to clients interested in notifications. Cache Level Data Notifications can be used in scenarios where the user wants to remain updated about every operation on cache.
Using Cache Level Events
By default they are disabled (except for Cache Cleared) for any cache configuration and must be enabled for events to be published.
The client application that is supposed to receive events must include the specific event handler method to respond to the event(s) raised. Whenever events are raised, the target event handler method executes the entire code written in the method body.
Client application is not able to receive events unless it registers itself again cache via specific event registration API call.
  • Registering Cache Level Events
Cache Level notifications are generic events which will be triggered upon every execution of the appropriate registered event type. To register these events for notification, RegisterCacheNotification method is used.
Appropriate EventType to be registered needs to be specified; single as well as multiple event types can be specified in a single method call. Also EventDataFilter needs to be specified to quantify the amount of information returned upon an event execution.
EventDataFilter must be carefully set to avoid unnecessary network bandwidth consumption.
Every target method returns a key and a CacheEventArgs object which contains information according to the data filter.
// Register target method
CacheDataNotificationCallback dataNotificationCallback = new CacheDataNotificationCallback( OnCacheDataModification);
try
{
// Register cache notification with appropriate event type
CacheEventDescriptor EventDescriptor = cache.RegisterCacheNotification(dataNotificationCallback,
EventType.ItemAdded | EventType.ItemRemoved | EventType.ItemUpdated,
EventDataFilter.None);
// Save the event descriptor for further usage
}
catch(Exception ex)
{
// handle exception
}
// Create a target method
static void OnCacheDataModification(string key, CacheEventArg args)
{
switch(args.EventType)
{
case EventType.ItemAdded:
//perform appropirate operations
break;
case EventType.ItemRemoved:
//perform appropirate operations
break;
case EventType.ItemUpdated:
//perform appropirate operations
break;
}
}
  • Unregistering Cache Level Events
A previously registered cache level notification can also be unregistered using the UnRegisterCacheNotification method. In this example, the EventDescriptor previously returned upon registering of event, needs to be specified.
try
{
cache.UnRegisterCacheNotification(EventDescriptor);
}
catch(Exception ex)
{
// handle exception
}
See Also
Event Notifications Overview | Item Level Data Event Notifications | Custom Events Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Item Level Data Event Notifications

< Previous page Next page >

Item Level Data Event Notifications

Item Level Data Notifications
When the user wants to be notified only about a limited set of data rather than every operation performed on cache, Item Level Data Notifications can be used. Clients register callback for a specific key in cache using RegisterCacheNotification API and gets notifications when that key gets updated or removed from cache. These notifications are asynchronously sent to client so that there is no overhead on client activities.
Using Item Level Events
Item level events are published from cache when particular item is updated or removed from the cache. Item level events are not associated with general events anyways and must be registered against some specific key(s) and events are published only for those specific key(s).
  • Registering Event with a Particular Item
NCache provides a separate classification of event which can be registered with individual keys. To register update or remove event with a particular key(s) RegisterCacheNotification method should be used.
The key must exist in cache for event to be registered. Only update or removed event types can be registered in item level events.
In this example the cache will generate notification when the appropriate operation is performed on the key.
// Register target method
CacheDataNotificationCallback dataNotificationCallback = new CacheDataNotificationCallback( OnCacheDataModification);
try
{
// Register notification with appropriate event type on existing key
CacheEventDescriptor EventDescriptor = cache.RegisterCacheNotification(key,dataNotificationCallback,
EventType.ItemRemoved | EventType.ItemUpdated,
EventDataFilter.DataWithMetadata);
// Save the event descriptor for further usage
}
catch(Exception ex)
{
// handle exception
}
// Create a target method
static void OnCacheDataModification(string key, CacheEventArg args)
{
switch(args.EventType)
{
case EventType.ItemRemoved:
//perform appropirate operations
break;
case EventType.ItemUpdated:
//perform appropirate operations
break;
}
}
  • Registering Event with CacheItem
An event can also be registered with a particular key by registering as a property of CacheItem. The SetCacheDataNotification method in CacheItem can be used to provide all appropriate information for registering the notification.
// Register target method
CacheDataNotificationCallback dataNotificationCallback = new CacheDataNotificationCallback( OnCacheDataModification);
try
{
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
CacheItem cacheItem = new CacheItem(product);
// Registering event with cacheItem
cacheItem.SetCacheDataNotification(dataNotificationCallback,EventType.ItemRemoved | EventType.ItemUpdated,EventDataFilter.DataWithMetadata);
string key = "Product:" +product.ProductID ;
// Registering
cache.Insert(key, cacheItem);
}
catch(Exception ex)
{
// handle exception
}
// Create a target method
static void OnCacheDataModification(string key, CacheEventArg args)
{
switch(args.EventType)
{
case EventType.ItemRemoved:
//perform appropirate operations
break;
case EventType.ItemUpdated:
//perform appropirate operations
break;
}
  • Un-Registering Item Level Notification
You can also unregister a previously registered item level notification using the UnRegisterCacheNotification method. In this example, the appropriate key, callback as CacheDataNotificationCallback and EventDescriptor previously returned upon registering of event must be specified.
try
{
cache.UnRegisterCacheNotification(key, callback, EventDescriptor);
}
catch(Exception ex)
{ // handle exception
}
See Also
Event Notifications Overview | Cache Level Data Event Notifications | Custom Events Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Custom Events Notifications

< Previous page Next page >

Custom Events Notifications

Custom Notifications
In multiple clients connected to cache environment, finding the best way to communicate among them is important. Custom Notifications are a special type of notifications which follow publisher and subscriber communication model in which one client application raises custom notification containing notification id and data and the other client applications who register for custom notification will receive it. It is a simple message passing mechanism to control the information flow among clients connected to a cache. In publisher subscriber model, the subscriber application will have to register for custom events and the publisher application raises notification which is sent to subscribers through cache.
This type of notification is used in scenarios where the user wants to raise the notification from client application or when he wants to write logic of raising notification on client side rather than cache to decide when to raise notification. For example, if there are multiple applications running and discount price for a specific product is changed on one application, then a custom notification will be raised to notify other client applications about the updated discount price so that they can also update the discount price for that product.
Using Custom Events
  • Registering Custom Notification
The user can create a custom event according to his/her requirements. This event needs to be registered with CustomEvent. NCache does not raise the custom events on its own, therefore in order to trigger it RaiseCustomEvent method needs to be called.
// Create a target method
Void CacheCustomEvent(object notifId, object data)
{
// do something
}
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
// Registering custom event
cache.CustomEvent += new CustomEventCallback(CacheCustomEvent);
// perform appropriate tasks
//…
//
//Raise Custom event upon according to need.
cache.RaiseCustomEvent("mycache", product);
Here product must be defined in an independent library so that it is visible to all the applications using custom level notifications.
See Also
Event Notifications Overview | Cache Level Data Event Notifications | Item Level Data Event Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Continuous Query

< Previous page Next page >

Continuous Query

Continuous query is provided by NCache for runtime monitoring and tracking of data related to observable data set. This sections explains how to use the feature of continuous query provided by NCache.
In This Section
Overview
Explains the concept of continuous query in NCache.
Using Continuous Query
Explains how to use continuous query using NCache API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

Distributed caching is the main need in this technological era where large scale multi-tier applications are built to cater millions of clients for high performance and scalability. But applications that require data changes rapidly demand synchronization of caches and client with the same pace. With synchronization of cache, it is also needed that all clients can share information related to some specific data set whenever any change occur in it.
Continuous query is provided by NCache for runtime monitoring and tracking of data related to observable data set. For example, if there is a web application regarding stock exchange where stock values will change frequently for any company.
The application’s clients will only be interested in the companies where they have shares. The query criteria for clients having shares in some companies are maintained and data related to only those companies should be updated on each clients view. In runtime applications, data addition is also runtime and there is no way of knowing when a specific query related data will be inserted in cache. For this, the client can register his/her query prior to data additions and when any cached item fulfilling the query criteria is added in cache, clients will be notified automatically.
NCache allows the user to specify any query criteria for indexed classes.
Changes in result set of a query can be triggered by:
  • Add: Adding an item in cache or updating any existing item that can add that item in any query.
  • Update: Updating any existing cache item but it remains in query result set.
  • Remove: Removing item from cache or updating any existing cached item that causes the removal of that item from query result set.
Filters can be specified for notifications that your cache client will receive. Filters are basically for the amount of modified cached item related data that will be received in query notifications. NCache provides three types of filters as mentioned below.
  • None (minimum data, i.e., only key)
  • Metadata (key with meta data related to cached item)
  • Data with metadata (key with complete cached and related data)
If any cached item related to result set of any registered query is removed due to expiration, eviction or dependencies then its notification will be sent to interested cache clients.
GROUP BY and Tags are not supported in this feature.
There might be an application that has .NET and Java clients. By enabling data sharing feature on the cluster cache, same objects can be indexed for both clients with even the same query. Notification will be sent to each client irrespective of Java or .NET for cached items added, updated or removed by both clients in any registered query result set. For example there might be an index defined for ProductID in .NET and productId in Java client. Data sharing feature was enabled between these clients and both were mapped for the same values. SELECT Product WHERE this.ProductID < 50 is registered in .NET client and SELECT Product WHERE this.productId < 50 is registered by Java client with notifications. Only one query observer will be started for both queries because both are registered for the same observable data set. Now if any item is added in cache from any of client that fulfils this query criterion, then both clients will be notified.
See Also
Using Continuous Query | Object Query Language (OQL) in NCache | Configuring Query Indexes | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Continuous Query

< Previous page Next page >

Using Continuous Query

Assuming that the searchable attributes are already indexed, the user then needs to implement continous query in his/her application. The first step is to define all the call backs that the user needs to be executed if the result set of the query is changed in any way. Following are the main methods which are provided by NCache and are associated with the implementation of continuous queries.
Methods | Description
RegisterCQ | The main purpose of this method is to activate the user’s continuous query with the cache server. This method can be used multiple times in an application depending on its need to receive the notifications for a change in the dataset of your query. This method takes as argument an object ofContinuousQuery which has the query and the callbacks registered to it.
UnRegisterCQ | UnregisterCQ is used by the application after the user has registered a continuous query to deactivate it on the cache server. Like RecgisterCQ, it takes as argument an object of ContinuousQuery to unregister the callbacks which are no more fired after this call. It is used when the user is no more interested in notifications for changes in a query result set.
SearchCQ | Sometimes the user requires not only to register the continuous query, but also to fetchthe result set associated with that continuous query. For this purpose, one of the methods provided by NCache is SearchCQ.This method takes the object of ContinuousQuery as its argument and returns a collection of keys to your application. These are the keys of objects which are in the result set of the query the CQ is registered to. It also registers the continuous query if it is not already registered. As this method only returns the keys, NCache API calls can be used to fetch the data of the keys which the user wishes to manipulate from the result set. If the result set of user’s query contains the majority items of cache, this approach can result in a large number of network trip, therefore, affecting the performance.
SearchEntriesCQ | The main reason to provide this method is the same as that of SearchCQ, that is, if the user wishes to fetch the result set when registering the continuous query. This method takes the object of ContinuousQuery as argument but, unlike SearchCQ, returns an IDictionary which contains keys as well as the data of the result set of that query. In this case, it is no longer required to fetch data using the keys explicitly, but the data of result set is returned from this call. In situations where the result set of the query is large, this option is better than SearchCQ as it takes only a single network trip to fetch the data set from the cache rather than fetching data against each key separately, as in the case of SearchCQ.
Example Code
class Program
{
static void Main(string[] args)
{
Cache cache = NCache.InitializeCache("mycache");
string queryString = "Select ClassLibrary.Product WHERE this.supplier=?";
Hashtable values = new Hashtable();
values.Add("supplier", "Carlos Diaz");
ContinuousQuery continuousQuery = new ContinuousQuery(queryString, values);
continuousQuery.RegisterNotification(new QueryDataNotificationCallback(ItemAddedCallBack), EventType.ItemAdded, EventDataFilter.None); // register notification for add operation.
continuousQuery.RegisterNotification(new QueryDataNotificationCallback(QueryItemCallBack), EventType.ItemUpdated | EventType.ItemRemoved , EventDataFilter.None); // register notification for update and remove operation.
continuousQuery.RegisterClearNotification(new ContinuousQueryClearCallback(CacheClear)); // register cache clear notification
cache.RegisterCQ(continuousQuery);
Product product = new Product();
product.ProductName = " Chai";
product.Supplier = "Carlos Diaz";
product.Categories = " Beverages";
cache.Add("key", new CacheItem(product)); //this operation trigger add notification.
product.Supplier = "Elio Rossi";
cache.Insert("key", new CacheItem(product)); //trigger remove notification because that key will be removed from the query result set by changing supplier name.
cache.Clear(); //trigger cache clear notification.
cache.Dispose();
}
// Create target methods
static void ItemAddedCallBack(string key, CQEventArg arg)
{
EventCacheItem item = eventArg.Item;
// do something
}
static void QueryItemCallBack(string key, CQEventArg arg)
{
switch (arg.EventType)
{
case EventType.ItemRemoved:
// do someting
break;
case EventType.ItemUpdated:
// do someting
break;
}
}
See Also
Continuous Query Overview | Object Query Language (OQL) in NCache | Configuring Query Indexes | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Streaming

< Previous page Next page >

Streaming

NCache also allows data to be read and write in cache using streams. This section explains how to use streams using NCache API.
In This Section
Overview
Explains the concept of streams, stream buffers and stream modes provided by NCache.
Using Streams
Explains how to use streams to read and write data in cache using NCache API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

Storing large binary data for, e.g., media files, large PDF documents, into the cache using cache API is inefficient. This will require loading the entire file into the application memory and then putting it into the cache as a single object. To overcome this, NCache provides Streaming API for reading/writing large binary data into the cache. Multiple parallel streams can be opened simultaneously into the cache.
When is it Useful
Suppose there is a high traffic application which has large media files that can be viewed by the user. For fast access, highly viewed media files are kept in cache. Adding and fetching large media files even in cache can take high processing and time if they are added and fetched at once, even if it is done asynchronously. Applications like these require high performance and the slow loading time can annoy the user. For resolving this issue, streams are used to write and read high object files in chunks like format. The files can be added and retrieved in stream chunks because those small chunks will take less time as compare to the whole large object.
In NCache serialization/deserialization, compression/decompression or encryption/decryption is not applied on data that is added in stream to avoid the chances of data corruption.
Stream Buffers
Streams are directly fetched/inserted from specified storage (here in cache) in general. However, a buffer can be added in between storage and stream. The stream will be added to that buffer and when that buffer is full, it writes the stream in cache or load it where needed. For using buffer in streaming, just the size of buffer needs to be specified. This is basically used to prevent delays in loading the data, e.g., to load a media file quickly.
NCache Stream does not support Seek operation.
Stream Modes
A cache stream can be opened in any of these modes:
  • Read
  • Read without Lock
  • Write
Stream Read
In read mode, multiple read operations can be performed simultaneously on a stream but no write operation is allowed.
Stream Read without Lock
In read without lock mode, write operations can be done in parallel to read operations because read operation does not acquire any lock to stop writing.
Stream Write
In write mode, only a single write operation can be performed on a stream. No read operation is allowed in this mode. Even thread having write lock cannot read that stream
Properly closing a stream after reading and writing is very important. The reason being that more threads might be waiting for that stream’s availability and until it is closed properly, the lock is not released which will give exception to other threads wanting to acquire the stream.
See Also
Using Streams | Data Compression | Security and Encryption | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Streams

< Previous page Next page >

Using Streams

Opening with Stream Modes
GetCacheStream API with different overloads is used to open a stream. GetCacheStream API opens the stream of specified key with provided streaming mode. It returns the handle of the opened stream as an object of CacheStream class.
CacheStream is derived from System.IO.Stream. It is designed to read/write BLOB using standard Stream interface. However, it does not support 'seeking' which is the querying and modifying the current position within a stream.
  • Reading from Stream
This mode is used for acquiring read-only access to the stream. With the help of example given below, a stream can be opened with read-only property on provided key.
string key = "key:ncache-manual";
CacheStream cacheStream = null;
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.Read);
}
catch (StreamException ex)
{
// handle exception
}
Now data can be read from this CacheStream object. GetCacheStream with Read mode throws StreamException if no data exists in the cache with the specified key.
  • Reading from Stream without Lock
This mode is useful when write and read operations are to be performed in parallel. The following example explains how to get stream object with read-without-lock property.
string key = "key:ncache-manual";
CacheStream cacheStream = null;
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.ReadWithoutLock);
}
catch (StreamException ex)
{
// handle exception
}
Data can be read from this CacheStream object. GetCacheStream with ReadWithoutLock mode throws StreamException if no data exists in the cache with the specified key.
  • Writing to a Stream
In write mode only single write operation can be performed on a stream. It will throw an exception if stream is already in use by another application.
string key = "key:ncache-manual";
CacheStream cacheStream = null;
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.Write);
}
catch (OperationFailedException ex)
{
// handle exception
}
Now data can be written to this CacheStream object.
Using GetBufferedStream
Buffered stream is the set of bytes used for storing the data up to the certain limit before reading or writing it to the cache. The following code shows how to use GetBufferedStream:
string key = "key:ncache-manual";
byte[] writeBuffer = System.IO.File.ReadAllBytes("C:\\ncache-manual.pdf");
int length = writeBuffer.Length;
try
{
System.IO.Stream wstream = _cache.GetCacheStream(key, StreamMode.Write).GetBufferedStream(length);
wstream.Write(writeBuffer, 0, length/2);//...No data is written in cache as buffer is not full
wstream.Write(writeBuffer, length/2, length/2);//...Data is written in cache because buffer is full now
////...Close the stream
}
catch (StreamException ex)
{
// handle exception }
26.2.3. Adding or Updating Data with Streams
string key="key:ncache-manual";
byte[] dataToWrite = System.IO.File.ReadAllBytes("C:\\ncache-manual.pdf");
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.Write);
cacheStream.Write(dataToWrite, 0, dataToWrite.Length);
//...Close stream
}
catch (StreamException ex)
{
// handle exception
}
The same method is used for adding and updating the data with stream. If the key provided with GetCacheStream API does not exist in the cache, the data written on the stream is added in cache. If an item already exists in cache with the provided key, binary data written on the stream appends with the existing data against the specified key.
Retrieving Data from Streams
To read data from streams, open stream in any read mode as explained above, and simply read data from it.
string key = "key:ncache-manual";
try
{
CacheStream cacheStream = cache.GetCacheStream(key, StreamMode.Read);
int dataSize = Convert.ToInt32(cacheStream.Length);
byte[] dataToRead = newbyte[dataSize];
cacheStream.Read(dataToRead, 0, dataSize);
//...Close stream
}
catch (StreamException e)
{
// handle exception
}
Read mode can be acquired either with lock or without lock. In read with lock mode, multiple read operations can be performed simultaneously on a stream but no write operation is allowed in this mode. While in read without lock, write operations can be done parallel to read operations.
Closing a Stream
The stream should be closed after being used in any mode in order to release the lock.
string key = "key:ncache-manual";
try
{
CacheStream cacheStream = cache.GetCacheStream(key, StreamMode.Read);
int dataSize = Convert.ToInt32(cacheStream.Length);
byte[] dataToRead = newbyte[dataSize];
cacheStream.Read(dataToRead, 0, dataSize);
// your logic here
cacheStream.Close();
}
catch (StreamException e)
{
// handle exception
}
Reading or writing a stream that was previously in use throws exception i.e. StreamAlreadyLockedException, if it was not closed properly.
Close the stream after all operations are done to the stream.
See Also
Streaming Overview | Data Compression | Security and Encryption | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Security and Encryption

< Previous page Next page >

Security and Encryption

NCache provides a customizable security feature for securing distributed cache access. Any unwanted or unauthorized access to the NCache cluster and to the data that resides in the cluster can be avoided by simply configuring NCache security. Moreover, the data being transmitted over network between cache servers and the application can be secured by configuring NCache data encryption mechanism. No code changes are required for NCache security and encryption customizations. This section explains how to use security and encryption in NCache.
In This Section
Overview
Explains different levels of security and types of encryption provided by NCache.
Using Security
Explains how to use security in cache using NCache API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

Security
Distributed cache operates in an environment having access to many different users, where any user can change cache configuration, perform any management operation or can have access to cache data without any restriction. The concern of cache security arises when the data being dealt with is critical or the administrative access to the cache should be granted to only a list of authenticated users. This is where NCache security comes in handy for providing different cache access levels and fulfilling the need to ensure a secure distributive caching system.
NCache provides a security feature with different level of granularity that can be implemented as per requirements.
NCache security feature incorporates security at two distinct access levels
  • Administrative/Management Level
  • Cache API Level
These levels of security are intended to secure both management and client level access to your cache. By default, security feature is disabled for both the access levels.
i. Administrative/Management Level Security
Management level security in NCache ensures that a remote cluster node is protected from any unauthorized user access. It is used to validate authorized users that have access to perform any management operation on a cluster node. To secure overall multi-node cache cluster, the security must be enabled on each individual node of the cluster.
Please see how to configure security to learn more about security configuration.
Once management level security is configured on the server node allowing only a few users to have administrative permissions, no users other than those specified will have access to perform any management operations such as creating new cache, removing/adding existing cache, starting/stopping cache etc on that node
Privileged Windows Administrator
Users other than those configured as node administrators are not permitted to perform any management related operation on the node. But there is one exception:
"A user is also granted administrative permissions if the provided credentials are valid local system administrator credentials."
It means that a local window administrator always has administrative rights and permissions whether managerial operation is performed locally, or from any other server node, using local windows credentials. So if a node is not authorized as an administrator and that node is being used to perform an operation on a personal machine, all that is needed to perform remote management operation on the system is to provide valid system credentials.
ii. Cache API level Security
Cache level security in NCache ensures that cache data is protected from any unauthorized user access. Cache API level security is used to validate authorized users who try to establish a connection with cache via NCache API. By enabling cache level security, the clients’ access to cluster cache data for either reading or writing can be controlled. Only those clients who are verified as valid and authenticated users, are allowed to perform cache level operations.
Once, cache level security is configured on a cache allowing only a few users to have cache API authorization, no users other than those specified will have access to perform any cache operations on the cache such as initializing cache, adding/ updating in cache, removing/fetching any data etc.
If security is enabled on a cache, then credentials must be provided along with initialize cache call to establish a connection.
Authentication and Authorization
NCache security ensures that only authenticated and authorized connections to the cache are accepted either for cache usage or for administration. All other connections are rejected.
  • Authentication
NCache uses system level and Active Directory authentication to verify connection identity. When NCache security is enabled, all connections to the cache cluster must first be authenticated against Active Directory at the cache server. If Active Directory authentication is failed, then system authentication is carried out only if management operation is requested on cache.
Credentials must be provided at the time of establishing a connection to the cache. And, if these credentials are not authenticated, the connection request is denied. User credentials can be specified at the following places:
  • NCache client configuration files.
  • When calling NCache.InitializeCache(…) API from client’s application.
  • In NCache Manager for administering the cache.
  • Authorization
After NCache authenticates a connection to the cache successfully, it checks NCache security configuration files at the cache server in order to authorize this connection.
Each connection to the cache can be categorized as one of the followings:
  • User: The user can access the cache for read/write but cannot administer it. A user is defined at cache level.
  • Admin: The admin can access the cache for read/write and can also administer it. An “admin” is defined at cache server level.
If an Admin connection is authenticated as local system administrator, then it is considered as an authorized connection without looking up the configuration files.
Data Encryption
As in distributive environment, caching systems mostly interact via network channels for transferring data between clients and remote servers. The data travels and resides in the cache in its original form, and anyone eavesdropping on a connection can intercept its data easily, if it is not encrypted. Data encryption feature provided by NCache is very important to secure sensitive data by reducing the security risk if data travels through network or is stored in the cache unprotected.
NCache provides a rich set of encryption algorithms that are nearly impossible to break. This ensures that the sensitive data is really protected well. NCache provides the following encryption algorithms to choose from:
  • 3DES: very strong 168-bit encryption
  • AES-128: very strong 128-bit encryption
  • AES-192: very strong 192-bit encryption
  • AES-256: very strong 256-bit encryption
NCache data encryption and decryption occurs inside the NCache client application process. This means that data traveling over the network between the application and the cache cluster is already encrypted. Similarly, only encrypted data is stored in cache store.
Encryption can be enabled through NCache management tools without any programming effort. To learn how to enable encryption, please see configuring encryption for cache .
Once encryption is enabled, NCache client automatically starts encrypting objects before sending them to the cache cluster. And, it automatically decrypts objects fetched from the cache before delivering them to the application.
If NCache encryption is enabled, data associated with all of the following operations is encrypted:
  • Data being transacted.
  • Data traveling via network.
  • Data being loaded via cache startup loader.
  • Data in cache queues buffer etc.
NCache uses an encryption key which is kept inside NCache security configuration files at each cache server in an encrypted manner. Encryption key is automatically sent to clients to be used in memory upon a successful connection.
See Also
Using Security | Configuring Security | Using Basic Cache Operations | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Security

< Previous page Next page >

Using Security

For using security after configuring security, security credentials need to be mentioned for initializing cache.
try
{
Cache cache = NCache.InitializeCache("mycache", new Alachisoft.NCache.Web.Security.SecurityParams("Admin", "password"), null);
}
catch (Exception ex)
{
// handle exception
}
Or CacheInitParam can be used to set security credentials as follows:
try
{
CacheInitParams ciParam = new CacheInitParams();
ciParam.PrimaryUserCredentials = new SecurityParams("primaryUserId", "primaryUserPassword");
ciParam.SecondaryUserCredentials = new SecurityParams("secondaryUserId", "secondaryUserPassword");
cache = Alachisoft.NCache.Web.Caching.NCache.InitializeCache("cacheId", "server", port, ciParam.PrimaryUserCredentials, ciParam.SecondaryUserCredentials);
}
catch (Exception exp)
{
// handle exception
}
Or security credentials can be mentioned in app.config file of the application.
try
{
string userName = String.Empty;
string password = String.Empty;
if(System.Configuration.ConfigurationManager.AppSettings["Username "]!=null)
{
userName=System.Configuration.ConfigurationManager.AppSettings["Username"].ToString();
}
if(System.Configuration.ConfigurationManager.AppSettings["Password"]!=null)
{
password=System.Configuration.ConfigurationManager.AppSettings["Password"].ToString();
}
// Initializing cache with security credential provided in web/app .config file
Cache cache = NCache.InitializeCache("mycache", new Alachisoft.NCache.Web.Security.SecurityParams(userName, password), null);
}
catch (Exception ex)
{
// handle exception
}
See Also
Security and Encryption Overview | Configuring Security | Using Basic Cache Operations | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Data Compression

< Previous page Next page >

Data Compression

NCache provides data compression feature to minimize the data traffic between cluster and client nodes and also to make the limited available memory, slightly more useful by storing more data in compressed form. Compression is by default disabled in NCache. Data compression can be enabled/disabled using NCache Manager.
Configuring NCache Compression Settings
Changing NCache compression settings will change the following configurations accordingly in config.ncconf file :
<compression enabled="true" threshold="500kb"/>
This xml tag specifies whether the items greater than the specified threshold should be compressed/decompressed at client side.
Enabled: If this attribute is set to "True", it means compression is enabled, otherwise disabled. Its default value is "False", as compression is disabled by default for all caches.
Threshold: Items greater than the value specified in threshold attribute will only be compressed/decompressed at client side (or sometimes at server side) if compression is enabled.
What Compression does
Once data compression is enabled, and the required threshold via NCache Manager is specified, NCache will apply GZip Compression for all objects of size greater than the specified threshold value, providing more memory storage and minimizing network traffic.
Compression will not be applied on the objects of the size less than the specified threshold value They will travel via network and will be stored in the cache in their original sizes.
Where does Compression Occur
Compression/decompression mostly occur at client side, but there are few cases when NCache server does the compression/decompression of the data.
Client Side Compression/Decompression
Client side compression/decompression takes place, if NCache compression is enabled, and any following case occurs:
  • For the data with size greater than the specified threshold, being send by the client to a remote server, data is compressed by client and sent to cache server in compressed form. Cache server just stores the data without applying any compression to it.
  • If a client requests for a data from the server, that is stored in cache in compressed form, cache server does not apply any decompression to the data and sends the data in its compressed form over the internet. Client receives the compressed data and decompresses it by itself.
Server Side Compression/Decompression
Server side compression/decompression takes place, if NCache compression is enabled, and any following case occurs:
  • For the data being loaded via configured cache startup loader or read-thru provider, and of size greater than the specified threshold, NCache server compresses the data after receiving it from the data source and before storing it in the cache.
  • For the data received by cache server in compressed form which has to be written in a data source via configured write-thru or write-behind provider, NCache server does not send the compressed data to the data source, in fact it decompresses the data first before sending it to the data store.
See Also
Configuring Compression | Dynamic Compact Serialization | Streaming | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Management API

< Previous page Next page >

NCache Management API

NCache management API is a set of programmable method calls that enables the user to perform basic management operations on out-proc caches without using either NCache Manager or NCache tools. Management API in some cases relies on the client configuration files to perform an operation, whereas in some cases it is self-sufficient to execute a request.
Include following namespace in project
using Alachisoft.NCache.Web.Management;
Starting Cache Using API Calls
Start Cache methods enable the user to start an out-proc cache on the specified server. In case of failure Management Exception is thrown by the cache. In this example, the user need to specify cache and server name to start a node.
//precondition: Cache has been registered but not initialized.
string cacheName="mycache";
string serverName="...."; // specify the server where cache is registered
try
{
CacheManager.StartCache(cacheName, serverName);
}
catch (ManagementException ex)
{
//thrown if no cache exists or server name is invalid
}
Stopping Cache Using API Calls
Stop Cache methods are used to stop a cache on a particular server. If no server is specified the method would read information from client configuration file. If the method fails to stop the cache or fails to find information regarding the cache, Management Exception is thrown. If called from the client node, the first server listed in the client configuration file associated with the cache will be stopped.
This example stops cache on an already started node. Cache and server name to stop cache on given node need to be specified.
try
{
CacheManager.StopCache(cacheName, serverName);
}
catch (ManagementException ex)
{
// handle exception
}
Viewing Cache Status Using API Calls
GetCacheHealth method enables the user to view the status of cache server nodes. This method call returns a CacheHealth object against every call. The user will need to include the following namespace in his/her project for CacheHealth class.
Alachisoft.NCache.Runtime.CacheManagement
In this example the user only needs to specify the cache name, the API uses client configuration file to connect to the server nodes and collect information; the initial node can also be specified. In case of failure of connection or incorrect cache name, the NCache would throw Management Exception.
try
{
CacheHealth cacheHealth = CacheManager.GetCacheHealth(cacheName);
}
catch (ManagementException)
{
// handle exception
}
Viewing List of Clients Connected with a Cache
GetCacheClient method enables the user to get a list of all connected clients on a server node at a given time. This method returns a dictionary containing server names and list of all client nodes connected at that given time. The user should include “Alachisoft.NCache.Runtime.CacheManagement” namespace in his/her project for the resultant dictionary of this method call.
In this example only the cache name needs to be specified, the API uses client configuration file to connect to the server nodes and collects information;the initial node can also be specified. In case of failure of connection or incorrect cache name, NCache would throw Management Exception.
try
{
//Returns list of all clients connected with cache servers
Dictionary<ServerNode, List<CacheClient>> clientList = CacheManager.GetCacheClients(cacheName);
}
catch (ManagementException ex)
{
// handle exception
}
See Also
Management Operations | Using Basic Cache Operations | Cluster Health | Server Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Server Side API Programming

< Previous page Next page >

Server Side API Programming

This section is a practical guide for programmers who want to utilize powerful features of Server side NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
Cache Startup Loader
Explains how to use Cache Startup Loader.
Data Source Provider (Backing Source)
Shows how to transparently fetch the required data from the master datasource if it is not available in the cache and vice versa.
Dynamic Compact Serialization
Explains making application data types Compact Serializable and use them in your application with NCache.
WAN Replication Through Bridge
Explains how to use Conflict Resolver.
Custom Cache Dependency
Depicts how you can use custom dependencies by defining your own expiration logics.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Startup Loader

< Previous page Next page >

Cache Startup Loader

This section is a practical guide for programmers who want to utilize powerful features of Server side NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
Overview
Explains the concept of Cache Startup Loader.
Using Cache Startup Loader
Explains how to use this Cache Startup Loader to preload cache with data as it starts up.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

NCache provides Cache Startup Loader through which cache can be preloaded with data as it starts up. This is useful for applications which depend on certain data and that data should be available to the application immediately after it begins executing. . For example, a video streaming site could have hundreds or thousands of videos at the beginning, and later new videos could be added on the server. For such an application, cache can be preloaded with existing videos on cache startup instead of manually adding the data in it.
To configure cache startup loader, CacheLoader interface provided by NCache needs to be implemented and then deployed using manager. NCache will use that custom provider to load data from the configured data source. Cache can be preloaded by loading data in it either at once or in chunks. On cache startup, NCache framework will iteratively call LoadNext method of this custom provider until it returns false. In this method, logic to return data at once or in multiple chunks can be implemented. The size of the added chunk in cache from data source can also be controlled. In short, NCache provides with flexible ways to load data into cache.
Cache Loader may fail to load data due to an unsuccessful connection with the data source or if an incorrect index is specified while extracting data from the data source. To identify this, server side cache logs for cache loader must be checked for errors/exceptions.
NCache loads data from data source on cache startup and populate it in cache in a separate thread. In case of clustered cache, only the coordinator node will be responsible for loading items in cache. If a node crashes or gets gracefully down while cache loader is in progress, then the next node will be responsible for initiating the cache loader from start.
The cache loader process can be delayed for a certain interval through cache loader start up delay configuration. By default its value is 20 seconds and it can be changed by providing NCacheServer.CacheLoaderStartupDelay key along with its value in NCache service XML file.
See Also
Using Cache Startup Loader | Configuring Cache Start-Up Loader | Data Source Provider (Backing Source) | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Cache Startup Loader

< Previous page Next page >

Using Cache Startup Loader
This feature is not available in NCache Express and Professional edition.
Namespace
For enabling Cache Startup Loader, your program needs a reference of the assembly Alachisoft.NCache.Runtime.dll that contains interface Alachisoft.NCache.Runtime.CacheLoader.ICacheLoader provided by NCache. The class implementing this interface allows framework to load data from the master datasource in the cache. Thus, the class needs to include the logic for loading the data from the datasource.
Following namespaces are required in your project for using ICacheLoader:
using Alachisoft.NCache.Runtime.CacheLoader;
using Alachisoft.NCache.Runtime.Caching;
ICacheLoader Interface:
In order to use ICacheLoader in your application, implement the following interface:
public void Init(System.Collections.IDictionary parameters);
public bool LoadNext(ref System.Collections.Specialized.OrderedDictionary data, ref object index);
public void Dispose();
Member | Description
Init | This method is called by NCache framework on cache startup.This method takes as input a dictionary of parameters which can be passed while configuring cache loader through NCache Manager. Please refer to how to configure cache loader section for details. Through this input parameter, runtime parameters to your deployed provider like connection strings etc can be specified. In this method tasks such as allocating resources, acquiring connections etc can be performed. The main concept of this method is to provide user with a starting point where he/she can initialize the data source settings before loading the data from it.
Dispose | This method is called by NCache framework on cache stop.The purpose of this method is to release resources that may be in use during loading data from data source to the cache.For example, when cache is stopped or LoadNext returns false, then this method can be implemented to close its connection with the datasource and dispose all resources in use.
LoadNext | This method is called by NCache framework on cache startup after init method. This method should contain the logic to load object(s) from the master data source. This method accepts a System.Collections.Specialized.OrderedDictionary which is to be populated bythe data being collected from the data source and an object which indicates the index. Both these parameters are passed by reference. The data loaded in the dictionary would be loaded in the cache and the index can be used to track the index if data is added in chunks. Please note that this method can contain the logic for returning one item at a time or multiple items in a chunk as it is called iteratively by NCache until it keeps returning false. Index can be used to control the size of the chunks being extracted from the data source. The user needs to make sure that the method returns true when the all the data has been added into the dictionary or else it will form an infinite loop.
Enabling Cache Startup Loader
To enable startup loader, please see Configuring Cache Startup Loader
Implementing Cache Startup Loader
public class CacheLoader : ICacheLoader
{
private SqlConnection connection;
//initialize your data source setting here
public void Init(System.Collections.IDictionary parameters)
{
string connString = parameters["connectionString"].ToString();
connection = new SqlConnection(connString);
connection.Open();
}
//Load data from source
public bool LoadNext(ref System.Collections.Specialized.OrderedDictionary data, ref object index)
{
int nextIndex = 0;
if (index != null)
{
nextIndex = (int)index;
}
SqlCommand command = new SqlCommand("SELECT * FROM Products WHERE ProductID > " + nextIndex.ToString() + " AND ProductID< " + (nextIndex + 10).ToString());
SqlDataReader reader = command.ExecuteReader();
if (!reader.HasRows)
return true;
while (reader.Read())
{
Product product = new Product();
product.ProductID = Convert.ToInt32(reader["ProductID"].ToString());
product.ProductName = reader["ProductName"].ToString();
product.Category = reader["Category"].ToString();
ProviderCacheItem provideritem = new ProviderCacheItem(product);
data.Add("Product:" + product.ProductID, provideritem);
}
index = nextIndex + 10;
reader.Close();
return false;
}
//Dispose your data source resources here
public void Dispose()
{
if (connection != null)
connection.Close();
}
}
See Also
Cache Startup Loader Overview | Configuring Cache Startup Loader | Data Source Provider (Backing Source) | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Data Source Provider (Backing Source)

< Previous page Next page >

Data Source Provider (Backing Source)

While working with data sources, it is important to transparently fetch the required data from the master data source if it is not available in the cache and vice versa. Read-Through and Write-through are provided by NCache for this purpose. Now you can add multiple Read-Through and Write-through providers with your applications.
If you are adding a custom object in NCache through backing source providers then you should place dlls local to the NCache service.
In this Section
Overview
Explains how Read-Through and Write-Through caching facilitates the user.
Read-Through Caching
Explains the basic concept of Read-Through caching.
Write-Through Caching
Explains the basic concept of Write-Through caching.
Configuring Read-Through Provider
Explains how to use Read-Through caching in NCache.
Configuring Write-Through Provider
Explains how to use Write-Through caching in NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

The main purpose of a caching solution is to cache the data source as temporary storage. While working with cache, client applications may need to perform operations on master data source. For this purpose, NCache supports transparent read/write operations to any type of back-end data source through read-through and write-through caching. Using this feature, client application can fetch or write data to master data source if needed. Read-through and Write-through caching facilitates user in the following cases:
  • User needs to fetch data from data source in case it is not present in cache store (Read-Through).
  • User needs to update data source (any write operation) after updating cache store (Write-Through).
Using this feature in NCache has the following advantages:
  • NCache provides pluggable architecture for read-through and write-through caching so the client application code does not need to contain data source logic.
  • The data source may be changed at any time so this pluggable architecture can configure different data source while keeping the application code intact.
  • Your application only needs to communicate with NCache and NCache will take care of backend communication with data source.
To use read- through or write-through caching, IReadThruProvider or IWriteThruProvider interfaces need to be implemented respectively and deploy it through NCacheManager.
Runtime parameters can also be provided to provider while configuring it through NCManager. These parameters will be passed to provider on its initialization. These initialization parameters can be used in many ways, e.g., connection string of a data source can be specified as a parameter and there is no need to put it in provider code. Thus, it provides a flexible way to change the data source settings while configuring it without code changes in provider.
In NCache, providers are configured by name and provider specific APIs can be employed by using provider name. NCache also supports multiple Read-Through/Write-though providers with applications. In case of multiple providers, one of provider will be configured as default one. Default provider will be called if provider name is not mentioned explicitly through API. Providers other than default can also be used by utilizing provider specific overloads of the given APIs.
See Also
Read-Through Caching | Write-Through Caching | Configuring Read-Through Provider | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Read-Through Caching

< Previous page Next page >

Read-Through Caching

Read-through caching facilitates in case client application wants to acquire an item from cache, which is not currently present in cache store, instead it is present in master data source only. In such a case if read-through is enabled, item will be transparently fetched from data source and stored in cache to fulfill future requests.
For read-through, IReadThruProvider interface needs to be implemented NCache framework uses this custom read-through provider to communicate with backend data source. In this case, custom logic needs to be implemented to load data from configured data source. NCache will call your provider to load data from data source behind Get call in case of cache miss.
NCache provides a performance counter for read-through operations per sec.
In clustered caches, where multiple servers are involved, read-through provider will be active (initialized) on all cache server nodes but read through operation will be performed by the node which receive Get operation according to topology.
See Also
Data Source Providers Overview | Write-Through Caching | Configuring Read-Through Provider | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Write-Through Caching

< Previous page Next page >

Write-Through Caching

NCache supports write-through caching which allows write operations to backend data source. In this way, cache and master data source can be synchronized. In write-through caching, NCache updates cache store first and then apply that operation to configure data source. For example, if client application updates an entry in cache, then NCache will also update the configured data source (if write-through is enabled).
Similarly for write-through, IWriteThruProvider interface needs to be implemented. NCache framework will internally use this custom provider to perform write operation on back-end data source. Here, custom logic for write operations on back-end data source needs to be implemented. NCache will call the provider behind write operations (Add, Insert, Remove/Delete) API calls with write-through. Currently NCache provides two modes for write-through caching.
  • Write-Through (Updates data source synchronously)
  • Write-Behind (Updates data source asynchronously)
NCache provides performance counter for write-through operations performed per sec.
Write-Through
In Write-through caching, an operation first applies on cache store and then synchronously updates the configured data source. In write-through mode, operation will be completed after NCache applies that operation on back-end data source. Write-through caching can be used if immediate database updates are critical and data source needs to be updated as soon as cache is updated.
Write-Behind
In Write-through, due to synchronous operations on data source, rate of operations on data source will be the same as rate of user operations on cache. For applications with high user traffic, rate of user operation on cache can be very high which can resultantly over whelm the data source. Also synchronous data source operation may affect response time of user operation.
To overcome these problem, write-behind can use instead of write through. In write-behind, data source operations are performed asynchronously after NCache performs operation on cache store. After updating cache store, these operations are queued up and later applied to configured data source asynchronously. Thus write-behind mode will enhance response time of operations. NCache provides different configurations settings in write-behind to control operations flow on data source. For instance, through Throttling, the rate at which NCache will apply write behind operations on data source can be specified. It indicates the number of operations applied on data source in a second. Default value for throttling is 500 ops/sec .This value can be changed through NCManager Backing Source settings.
NCache provides performance counter for write-behind operations performed per sec.
Write-Behind Modes
NCache allows write-behind operations to be applied either individually or in batch. A write-behind queue is maintained for write-behind operations. All write-behind operations will be en queued in this queue and later on applied to data source according to the configured batched or non-batched mode. These two modes are explained below:
  • Non Batch Mode
By default, non-batch mode will be configured for write-behind operations. In this mode, operations in write behind queue will be applied one by one on data source according to configured throttling rate. For example, if throttling rate is 500 operations per second, NCache will apply write behind operation one at a time to data source and their applying rate will not exceed from 500 operations per second.
  • Batch Mode
In Batch-mode, operation delay can be configured for write behind operations, which indicates the time in milliseconds that each operation must wait in write-behind queue before applying it on data source. By default, its value is zero. In this mode, a batch/bulk of operations is selected according to their operation delay. A dedicated thread periodically collects all those operations which complete their delay interval after a configurable interval called "batch-interval". Thus Batch-interval is the configurable interval according to which NCache periodically checks for operation delay timed out operations in write-behind queue. In short, a bulk of ready operations (that completed their delay interval) is selected at every batch interval.
For example, if operation delay is configured as 1000ms and batch interval as 5s then NCache checks the operations in write-behind queue after every 5s (batch-interval) and select all operations whom operation delays are expired (all operations which are in queue for the last 1000 milliseconds).
After selection of operation bulk, these operations are then applied to data source according to configured throttling rate. Let's say a bulk of 1000 operations are selected from write-behind queue, these operations are then applied to data source in a batch of 500 operations (if throttling rate is 500ops/sec) as the maximum operation applied to data source per second can't exceed the given throttling value.
Operation delay time can range from seconds to days and months. In this way, operations on data source can be paused by configurable amount of time.
NCache also provides performance counters for write-behind queue operations count and current batch operation count. Current batch operation count displays the number of operations selected in current batch interval for execution. For write-behind, if batching is enabled, operations ready to be executed on data source are de queued from write behind queue. Number of operation de queued in current batch interval will be displayed by current batch operation count counter.
Write-Through Caching Operation Result
NCache provides a flexible way to synchronize write-through operation in cache on the basis of its operation result. After applying an operation (Add/ Insert) on data source, operation status can be specified on the basis of which NCache will synchronize cache store. For example, in case of data source operation failure, that item can either be removed from cache or kept in it. The operation can even be retried on data source. For this, Success/Failure/FailureRetry/FailureDontRemove has to be specified as DSOperationStatus of OperationResult. This is provided in both modes of write-through caching i.e. write-through and write-behind. Data source operation statuses and their corresponding actions by NCache are described below:
  • Success: This means that data source operation is successful and item was added to the data source so NCache will keep it in the cache as well.
  • Failure:  This means that data source operation is failed and item could not be added to database, so NCache will remove it from the cache as well.
  • FailureDontRemove: This means that data source operation is failed and item could not be added to the database, but NCache will keep it in the cache.
  • FailureRetry: This means that data source operation is failed and item could not be added to the database, so NCache will keep the item in cache and retry. Retries will be done as write behind operations.
Retrying Failed Operations
NCache allows retrying operations in write-through/write-behind in case they are failed on data source. For this purpose, if operation retrying is enabled and specifications about retrying certain operations through provider are given, then NCache will retry that operation on data source. In case of write-through or write –behind, all retry operations will be re-queued to write behind queue. It means that a write-through retry operation will be retried asynchronously as a write behind operation.
NCache also provides performance counter for data source failed operations/sec. Write operations performed on data source returning Failure/ FailureRetry/ FailureDontRemove as DSOperationtatus of OperationResult are counted per second by this counter.
NCache allows limiting the number of failed operations to be retried. In such a situation, Failed operation queue limit through NCache Manger should be mentioned, and if that limit exceeds, failed operations can be evicted through a configurable eviction ratio. Here NCache will evict the most retried operations when retried queue is full. Each operation has associated RetryCount property which is incremented on each operation retry on data source.
For this, NCache provides performance counter for write-behind failure retry count and write-behind eviction/sec. Write-behind failure retry counter will show the number of operation re queued for retry. Data source write operation returning FailureRetry as status in OperationResult will be re queued for retry. Whereas write-behind eviction/sec counter will display the number of retry operations evicted per second.
Updating Cache after Data Source Operation
As stated earlier, in write-through caching, operation is first performed on cache store and then to data source. There may exist scenarios in which after performing operation on data source, an item’s value is modified, e.g., in case of identity columns, its value will be modified by data source operation. In such a situation, data may become inconsistent in cache and data source. To handle this, NCache allows specifying whether to update data in cache after data source operation or not. The flag UpdateInCache can be set to again perform the operation (Add/Insert) on cache store to make it synchronized with data source.
NCache updates operation in cache store, if specified, synchronously or asynchronously depending on the write-through caching mode. In write-through, synchronous updates will be applied and asynchronous in case of write-behind.
NCache also provides performance counter for data source updates/sec. It displays the number of update operations per second in cache after data source write operations. Data source write operations with UpdateInCache flag set to true in OperationResult are then performed on cache. This counter displays the number of these update operations performed on cache per second.
Monitor Write-Through Caching Using Counters
In write-through caching, NCache provides the following counters to monitor cache activity on data source:
  • Write-through/sec: Displays the number of write-through operations per second.
  • Write-behind/sec: Displays the number of write-behind operations per second.
  • Write-behind queue count: Displays the number of operations in write-behind queue.
  • Write-behind failure retry count: Displays the number of operations failed and re-queued for retry. Data source write operation returning FailureRetry will be re-queue. This counter displays re-queued operation count.
  • Average Write-Behind Updates: Average time, in milliseconds, taken to complete one data source update cache operation. Data source write operations with UpdateInCache flag set to true in OperationResult are then performed on cache. This counter displays the average time taken by these update operations on cache.
  • Write-behind evictions/sec: Displays the number of retried operations evicted per second. Data source write operation returning FailureRetry are re queued for retry. This counter displays number of such operations evicted per second.
  • Data source updates/sec: Displays the number of update operations per second in cache after data source write operations. Data source write operations with UpdateInCache flag set to true in operation result are then performed on cache. This counter displays number of these update operations performed on cache per second.
  • Data source failed operations/sec: Displays the number of data source write operations failed per second. Write operations performed on data source returning Failure/FailureRetry/FailureDontRemove as DSOperationtatus of OperationResult are counted per second by this counter.
  • Current batch operations count: Displays current batch operation count i.e. thenumber of operations selected in current batch interval for execution. For write-behind, if batching is enabled, operations ready to be executed on data source are de queued from write behind queue. The number of operations de queued in current batch interval will be displayed by current batch operation count counter.
Hot Apply Support for Write-Behind Configuration
NCache supports hot apply for write-behind settings which allow changing the write behind configuration at runtime without stopping the cache. Almost all write behind configurable attributes can be changed through NCache Manager and NCache will incorporate those changes dynamically.
In this hot apply support, write-behind mode can be changed from batch to non-batch and vice versa. For instance, if the batch mode is changed to non-batch, then NCache will ignore the operation delay value and start executing operations individually. The throttling rate can also be changed at runtime. Similarly operation delay, batch-interval, failed operation queue limit and eviction ratio can also be changed at runtime.
The failed operation queue limit can only be changed in increasing fashion; otherwise NCache will use its default value for further operations.
Write Behind in Clustered Environment
As a write-behind queue is maintained for write-behind operations, a separate dedicated thread monitors and executes these operations. Topology level details for write-behind are mentioned below:
  • In Replicated Cache topology, write-behind queue will be maintained on all nodes, but write-behind async processor will be present on coordinator node only. This means that all write-behind operations will be performed through this node and replicated to other node queues cluster wide. In this way, if a node is down, then the next coordinator will perform the remaining write behind operations.
  • In Partitioned-Replica topology, write-behind queue is maintained on each active node and also replicated to its corresponding replica. Each node will be responsible for its write-behind operation on data source.
  • In Mirrored Cache, write behind queue will be maintained on both active and passive node, but only active node will be responsible to perform write-behind operations. Similarly, if active node is down, then passive will become active and perform the remaining write behind operations.
  • In Partitioned Cache topology, write-behind queue is maintained on each partition and every node will be responsible for its write-behind operation on data source.
See Also
Data Source Providers Overview | Read-Through Caching | Configuring Read-Through Provider | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Read-Through Provider

< Previous page Next page >

Configuring Read-Through Provider

The following steps should be followed to configure and implement the Read-Through provider with NCache.
Implementing IReadThruProvider Interface
To implement IReadThruProvider, add following references in the provider assembly.
Alachisoft.NCache.Runtime.dll
Create a class that implements Alachisoft.NCache.Runtime.DatasourceProviders.IReadThruProvider interface and deploy it using NCache Manger. NCache framework will internally use this class to load the data from the configured data source if it is not available in the cache.
IReadThru Interface
Public void Init(System.Collections.IDictionary parameters, StringcacheId);
Public void Dispose();
Public void LoadFromSource(string key, out ProviderCacheItemcacheItem);
Public Dictionary<string, ProviderCacheItem> LoadFromSource(string[] keys);
Member
Description
Init
This method will be called by NCache framework on cache startup. User can use this method for performing tasks like allocating resources, acquiring connections of data source etc. This method takes as input the IDictionay instance of arguments passed to the provider through NCache Manger (configuration settings). It allows you to pass list of parameters to provider. These parameters can be utilized in many ways. For example, connection string of a data source can be specified as a parameter. Thus, it provides a flexible way to change the data source settings while configuring it without code changes.
The other argumentCacheId specifies the cache name for which read-through is configured.
LoadFromSource
This method will be called by NCache framework if the required item is not found in cache store and NCache has to load it through configured data source. This method should contain logic to load an object from configured data source. First argument "key" refers to the key of required item. The second argument is an out parameter of type Provider CacheItem which needs to be instantiate it along with required properties Here you can associate various properties to loaded item before returning it back to NCache framework. Make sure that Provider CacheItem.Value assigned in this method is "Serializable" because NCache will later save that item to cache store to fulfill future requests.
While implementing this method, you should take care of code thread safety as multiple Get requests can access this method for read-through. Also do care to avoid scenarios that cause recursive infinite loops e.g. in this method a Get request with read-through on the same cache handle will cause infinite recursion.
Note: In case of Get, LoadFromSource(string key, out ProviderCacheItemcacheItem) will be called from provider while for GetBulk, LoadFromSource(string[] keys)
will be called to load items from data source.
Dispose
This method will be called by NCache framework when cache stops. You can use this method for performing tasks like releasing resources, disposing connections etc. Here you can free the resources related to data source for effective resource utilization.
In NCache, Read-Through providers are configured on cache level i.e. for clustered caches all nodes will contain provider configurations and their deployed assemblies.
Sample Code for IReadThruProvider
// Contains methods used to read an object by its key from the master data source.
// Contains methods used to read an object by its key from the master data source.
public class SampleReadThruProvider : IReadThruProvider
{
private SqlConnection _connection;
//Perform tasks like allocating resources or acquiring connections
public void Init(IDictionary parameters, string cacheId)
{
object connStringObject = parameters["connstring"];
string connString = connStringObject == null ? "" : connStringObject.ToString();
if (connString != "")
_connection = new SqlConnection(connString);
try
{
_connection.Open();
}
catch (Exception ex)
{
//handle exception
}
}
//Responsible for loading an item from the external data source.
public void LoadFromSource(string key, out ProviderCacheItem cacheItem)
{
//where LoadFromDataSource is the dummy method to load data from data source.
object value = LoadFromDataSource(key);
cacheItem = new ProviderCacheItem(value);
cacheItem.ResyncItemOnExpiration = true;
}
//Perform tasks associated with freeing, releasing, or resetting resources.
public void Dispose()
{
if (_connection != null)
_connection.Close();
}
//Responsible for loading bulk of items from the external data source.
public Dictionary<string, ProviderCacheItem>LoadFromSource(string[] keys)
{
try
{
Dictionary<string, ProviderCacheItem> dictionary = new Dictionary<string, ProviderCacheItem>();
string key = null;
for (int index = 0; index <keys.Length; index++)
{
key = keys[index];
//where LoadFromDataSource is the dummy method to load data from data source.
dictionary.Add(key, new ProviderCacheItem(LoadFromDataSource(key)));
}
return dictionary;
}
catch (Exception exp)
{
Throw;
}
}
private object LoadFromDataSource(string key)
{
object retrievedObject = null;
// load item from your data source and populate retrieved Object
return retrievedObject;
}
}
After implementing and deploying this provider, direct calls can be made to NCache to get the required items. If item is not locally available in cache store, NCache will use "LoadFromSource" method in specified data access class to load items from data source.
Using Read-Through with Basic Operations
This section will explain the use of read-through provider after configuring and deploying it. NCache supports multiple read-through providers with an applications.
Add the following namespaces in application:
using Alachisoft.NCache.Web.Caching;
using Alachisoft.NCache.Runtime.DatasourceProviders;
using Alachisoft.NCache.Runtime;
NCache provides Alachisoft.NCache.Web.Caching.DSReadOption enum to specify Read thru option in APIs.
Multiple read-through providers can be configured through NCache. Default read-through provider will be called if specific provider name is not mentioned through API. You can also use providers other than default by using provider specific overloads of APIs.
  • Get Method
Member | Description
Get(string key, DSReadOption dsReadOption) | Get item from cache and uses default provider
Get(string key, string providerName, DSReadOption dsReadOption) | Get item from cache and uses specified provider
Product product=null;
try
{
string key = "Product:1001";
object data = cache.Get(key, DSReadOption.ReadThru);
if (data != null)
{
product = (Product)data;
}
}
catch (OperationFailedException exp)
{
//handle exception }
  • Bulk Method
For better understanding of the these operations review Bulk Operations. In this scenario, use the following API
Member | Description
IDictionary GetBulk(string[] keys, DSReadOption dsReadOption) | Get bulk items from cache and uses default provider
IDictionary GetBulk(string[] keys, string providerName, DSReadOption dsReadOption) | Get bulk items from cache and uses specified provider
try
{
String[] keys = { "Product:1001", "Product:1002", "Product:1003", "Product:1004" };
IDictionary resultSet = cache.GetBulk(keys, DSReadOption.ReadThru);
//IDictionary contains cached keys and values
}
catch (OperationFailedException exp)
{
//handle exception
}
  • Using Read-Through Provider with CacheItem
For this scenario, use the following API.
Member | Description
CacheItem GetCacheItem(string key DSReadOption dsReadOption) | Get CacheItem from cache and uses default provider
GetCacheItem(string key, string providerName, DSReadOption dsReadOption) | Get CacheItem from cache and uses specified provider
string key = "Product:1001";
Product product=null;
try
{
CacheItem data = cache.GetCacheItem(key, DSReadOption.ReadThru);
if (data!= null)
{
product = (Product)data.Value;
}
}
catch (Exception exp)
{
//handle exception
}
Please note that you can specify default provider through NCManager or through client.ncconf placed in config folder of NCache installation directory. If provider name is not provided in both API and client.ncconf, default provider will automatically be used.
<cache id="mycache" default-readthru-provider="defaultProviderName" client-cache-id="" client-cache-syncmode="optimistic" default-writethru-provider="" load-balance="True" server-runtime-context="NCACHE">
...
</cache>
CacheInitParam can also be used to specify providers.
NCache logs the warnings in Application event log in case of an exception during loading the assemblies.
See Also
Data Source Providers Overview | Read-Through Caching | Write-Through Caching | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Write-Through Provider

< Previous page Next page >

Configuring Write-Through Provider

To use Write-through caching you need to implement IWriteThruProvider interface provided by NCache. NCache framework will use this custom implementation to write data on backend data source.
Implementing IWriteThru Provider Interface
To implement IWriteThruProvider, add following references in provider assembly.
Alachisoft.NCache.Runtime.dll.
Create a class that implements Alachisoft.NCache.Runtime.DatasourceProviders.
IWriteThruProvider interface and deploy it using NCache Manger. NCache framework will internally use this class to perform write operation on configured data source.
IWriteThru Interface
Member
Description
Init
This method will be called by NCache framework on cache startup. User can use this method for performing tasks like allocating resources, acquiring connections of data source etc. This method takes as input the IDictionary instance of arguments passed to the provider through NCache Manger (configuration settings). It allows you to pass list of parameters to provider. These parameters can be utilized in many ways. For example, connection string of a data source can be specified as a parameter. Thus, it provides a flexible way to change the data source settings while configuring it without code changes.
The other argument CacheId specifies the cache name for which read-through is configured.
WriteToDataSource
This method will be called by NCache framework to perform actual write operation on configured data source.
-For write-thru, an atomic operation with write-thru will corresponds to atomic WriteToDataSource method in provider while in case bulk operation NCache will call bulk WriteToDataSource method from provider.
-For write-behind, NCache will call atomic WriteToDataSource method if non-batch mode is enabled while bulk WriteToDataSource method will be called for batch mode.
This method should contain logic to perform operation on configured data source. The argument WriteOperation contain the key, operation type (Add, Insert, Remove/Delete), retry count and provider cache item.
You will implement this method to perform write operations on data source according to operation type and return it to NCache as OperationResult. OperationResult holds information about:
· WriteOperation: Operation performed on data source.
· Update in cache flag : This flag specifies whether to update the returned write operation in cache or not. This is only applicable for Add and Insert operation types. In NCache an operation is first applied on cache store and then to data source (if write through caching is enabled). So if user wants to synchronize the cache store after updating data source then this flag will be used.
· Data source operation status : Write through caching basically synchronize your data source with cache store. Previously in case of operation failure on data source, item is also removed from cache, now NCache provides more flexible ways to allow user to decide whether to keep the item in cache based on these operation statuses.
· Success: This means item was successfully added to the data source so keep it in the cache as well.
· Failure: This means item could not be added to data source, so in case of Add/Insert operations, item will be removed from cache. Operation failure exception will be thrown to user in case of write-through and logged in case of write behind.
· FailureDontRemove: This means item could not be added to the data source, but keep it in the cache. Operation failure exception will be thrown to user in case of write thru and logged in case of write behind.
· FailureRetry: This means item could not be added to the data source, keep the item in cache and retry. In case of write thru retry will be performed as write behind operation.
While implementing this method, you should take care of code thread safety as multiple requests can access this method for write-through.
Dispose
This method will be called by NCache framework when cache stops. You can use this method for performing tasks like releasing resources, disposing connections etc. Here you can free the resources related to data source for effective resource utilization.
In NCache, Read-Through providers are configured on cache level i.e. for clustered caches all nodes will contain provider configurations and their deployed assemblies.
Sample Code for IWriteThruProvider
/// Contains methods used to save/update an object to the master data source.
public class SampleWriteThruProvider : IWriteThruProvider
{
/// Object used to communicate with the Data source.
private SqlConnection _connection;
//Perform tasks like allocating resources or acquiring connections
public void Init(IDictionary parameters, string cacheId)
{
object connStringObject = parameters["connstring"];
string connString = connStringObject == null ? "" : connStringObject.ToString();
if (connString != "")
_connection = new SqlConnection(connString);
try
{
_connection.Open();
}
catch (Exception ex)
{
//handle exception
}
}
//Perform tasks associated with freeing, releasing, or resetting resources.
public void Dispose()
{
if (_connection != null)
_connection.Close();
}
//Responsible for write operations on data source
public OperationResult WriteToDataSource(WriteOperation operation)
{
Product product = (Product)operation.ProviderCacheItem.Value;
SqlCommand command = new SqlCommand();
command.Connection = _connection;
if (operation.OperationType == WriteOperationType.Add)
command.CommandText = "INSERT INTO Products(ID,Name)VALUES( '" + operation.Key + "','" + product.ProductName + "')";
if (operation.OperationType == WriteOperationType.Delete)
command.CommandText = "DELETE FROM Products WHERE ID ='" + operation.Key + "'";
if (operation.OperationType == WriteOperationType.Update)
command.CommandText = "UPDATE Products SET Name = '" + product.ProductName + "' WHERE ID='" + operation.Key + "'";
int result = command.ExecuteNonQuery();
OperationResult operationResult = new OperationResult(operation, OperationResult.Status.Success);
if (result < 1)
{
operationResult.DSOperationStatus = OperationResult.Status.Failure;
}
return operationResult;
}
public OperationResult[] WriteToDataSource(WriteOperation[] operations)
{
OperationResult[] operationResult = new OperationResult[operations.Length];
SqlCommand command = new SqlCommand();
command.Connection = _connection;
int counter = 0;
foreach (WriteOperation operation in operations)
{
Product product = (Product)operation.ProviderCacheItem.Value;
if (operation.OperationType == WriteOperationType.Add)
command.CommandText = "INSERT INTO Products(ID,Name)VALUES( '" + operation.Key + "','" + product.ProductName + "')";
if (operation.OperationType == WriteOperationType.Delete)
command.CommandText = "DELETE FROM Products WHERE ID ='" + operation.Key + "'";
if (operation.OperationType == WriteOperationType.Update)
command.CommandText = "UPDATE Products SET Name = '" + product.ProductName + "' WHERE ID='" + operation.Key + "'";
int result = command.ExecuteNonQuery();
operationResult[counter] = new OperationResult(operation, OperationResult.Status.Success);
if (result < 1)
{
operationResult[counter].DSOperationStatus = OperationResult.Status.Failure;
}
counter++;
}
return operationResult;
}
}
After implementing and deploying this provider, you can make direct calls to NCache for write operations on data source. NCache will use "WriteToDataSource" method in specified data access class to write operations on data source.
Using Write-Through with Basic Operations
This feature is not available in NCache Express and Professional edition.
This section will explain the use of write-through provider after configuring and deploying it. NCache supports multiple Write-Through providers with applications.
The following namespaces should be added in application:
using Alachisoft.NCache.Web.Caching;
using Alachisoft.NCache.Runtime.DatasourceProviders;
using Alachisoft.NCache.Runtime;
NCache provides Alachisoft.NCache.Web.Caching.DSWriteOption enum to specify Write thru/Write behind options in APIs. Multiple write-through providers can be configured through NCache. Default provider will be called if specific provider name is not mentioned through API. You can also use providers other than default by using provider specific overloads of APIs.
  • Adding with Write-Through
Member | Description
CacheItemVersion Add(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded) | Adds item in cache and uses default provider
CacheItemVersion Add(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemAdded) | Adds item in cache and uses specified provider
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" + product.ProductID ;
try
{
CacheItemVersion itemVersion = cache.Add(key, cacheItem, DSWriteOption.WriteThru, null);
}
catch (OperationFailedException exp)
{
// handle exception
}
  • Updating with Write-Through
Member | Description
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded) | Inserts item in cache and uses default provider
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Inserts item in cache and uses specified provider
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
CacheItemVersion updatedItemVersion;
try
{
updatedItemVersion = cache.Insert(key, cacheItem, DSWriteOption.WriteThru, "XmlWriteThruProvider", null);
if (updatedItemVersion.Version> 1)
{
//Item updated in cache. Perform further tasks.
}
}
catch (OperationFailedException exp)
{
//handle exception
}
  • Deleting an Existing Item with Write-Through
Member | Description
Delete(string key, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback) | Deletes item from cache and uses default provider
Delete(string key, DSWriteOption dsWriteOption, string providerName, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Deletes item from cache and uses specified provider
string key = "Product:1001";
try
{
cache.Delete(key, DSWriteOption.WriteThru, null);
}
catch (OperationFailedException exp)
{
// handle exception
}
  • Removing an Existing Item with Write-Through
Member | Description
object Remove(string key, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback) | Removes item from cache and uses default provider
object Remove(string key, DSWriteOption dsWriteOption, string providerName, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Removes item from cache and uses specified provider.
string key = "Product:1001";
Product product = null;
try
{
Object returnObject = cache.Remove(key, DSWriteOption.WriteThru, null);
//Verify the removed item from both cache and data source
if (returnObject != null)
{
product = (Product)returnObject;
}
}
catch (OperationFailedException exp)
{ // handle exception }
  • Adding New Item Asynchronously
Member | Description
AddAsync(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded); | Uses default provider and add item in cache asynchronously.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" + product.ProductID ;
try
{
cache.AddAsync(key, cacheItem, DSWriteOption.WriteThru, null);
}
catch (OperationFailedException exp)
{
//handle exception
}
  • Adding with Write-Behind
Member | Description
CacheItemVersion Add(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemAdded) | Adds item in cache by using Custom Provider and Write-Behind.
i. Add without Callback Method
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
try
{
cache.Add(key, cacheItem, DSWriteOption.WriteBehind, null);
}
catch (Exception exp)
{
//Operation fails if the item already exists
// Request is not sent to the backing source in
}
ii. Add with Callback Method
protected void OnDataSourceItemsAdded(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void AddTest()
{
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
try
{
cache.Add(key, cacheItem, DSWriteOption.WriteBehind, OnDataSourceItemsAdded);
//Verify item added in cache and in main source
}
catch (Exception exp)
{
//Operation fails if the item already exists
}
}
  • Updating Existing Data with Write-Behind
Member | Description
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback); | Adds item in cache by using default provider and write-behind.
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback); | Adds item in cache by using custom provider and write-behind.
protected void OnDataSourceItemsUpdated(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void UpdateTest()
{
string key = "Customer:David:1001";
cacheItem.SubGroup = "WriteThru-Test";
try
{
cache.Insert(key, cacheItem, DSWriteOption.WriteBehind,OnDataSourceItemsUpdated);
}
catch (Exception exp)
{
//handle exception
}
}
  • Deleting Existing Data with Write-Behind
Member | Description
Delete(string key, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Deletes item in cache with default provider and write-behind option.
Delete(string key, DSWriteOption dsWriteOption, string providerName,DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Deletes item in cache with custom provider and write-behind option.
protected void OnDataSourceItemsRemoved(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void DeleteTest()
{
string key = "Customer:David:1001";
try
{
cache.Delete(key, DSWriteOption.WriteBehind, OnDataSourceItemsRemoved);
//Verify the removed item from both cache and data source
}
catch (OperationFailedException exp)
{
//Operation fails if key does not exist in the cache
}
}
  • Asynchronous Operations with Write-Behind
i. Add New Item Asynchronously
Member | Description
AddAsync(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded); | Add item asynchronously in cache by using default provider and write-behind option.
void AddAsync(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemAdded) | Add item asynchronously in cache by using custom provider and write-behind option.
protected void OnDataSourceItemsAdded(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void AsyncAddTest()
{
try
{
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
cache.AddAsync(key, cacheItem, DSWriteOption.WriteBehind,OnDataSourceItemsAdded);
//verify that the key is added in Cache and master source
}
catch (Exception exp)
{
//handle exception
}
}
ii. Update Existing Item Asynchronously
Member | Description
void InsertAsync(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Updates existing item asynchronously in cache by using default provider
void InsertAsync(string key, CacheItem item, string providerName, DSWriteOption dsWriteOption, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Updates existing item asynchronously in cache by using custom provider
protected void OnDataSourceItemsUpdated(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void AsyncUpdateTest()
{
Cache mycache = NCache.InitializeCache("myreplicatedcache");
try
{
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
cacheItem.SubGroup = "Async-WriteThru-Test";
cache.InsertAsync(key, cacheItem, DSWriteOption.WriteBehind, OnDataSourceItemsUpdated);
//verify that the key is updated in Cache and master source
}
catch (Exception exp)
{
//handle exception
}
}
  • Bulk Operations with Write-Behind
i. Add New Items Using AddBulk Call
Member | Description
IDictionary AddBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemsAdded) | Adds items in cache by using default provider
IDictionary AddBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemsAdded) | Adds item in cache by using specific provider
protected void OnDataSourceItemsAdded(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void BulkAddTest()
{
try
{
String[] key = {"Customer:David:1001","Customer:Paul:1002","Customer:Dave:1003","Customer:Mathew:1004"};
//create custom objects of Product type
CacheItem[] data = GetCacheItems(keys.Length);
IDictionary failedItems = cache.AddBulk(keys, data, DSWriteOption.WriteBehind, OnDataSourceItemsAdded);
//verify updated items in the main source
}
catch (Exception exp)
{
//handle exception
}
}
ii. Update Existing Items Using InsertBulk API
Member | Description
IDictionary InsertBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Updates items in cache by using default provider and providing callback
IDictionary InsertBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemsAdded) | Updates items in cache by using specific provider and providing callback
protected void OnDataSourceItemsUpdated(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void BulkUpdateTest()
{
try
{
String[] key = {"Customer:David:1001","Customer:Paul:1002","Customer:Dave:1003","Customer:Mathew:1004"};
//create new custom objects for above mentioned keys of Product type
CacheItem[] data = cache.GetCacheItems(keys.Length);
IDictionary failedItems = cache.InsertBulk(keys, data, DSWriteOption.WriteBehind, OnDataSourceItemsUpdated);
//verify updated items in the main source
}
catch (Exception exp)
{
//handle exception
}
}
iii. Delete Existing Items Using DeleteBulk API
Member | Description
void DeleteBulk(string[] keys, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemsRemovedCallback) | Deletes items in cache by using default provider and providing callback
protected void OnDataSourceItemsRemoved(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void BulkDeleteTest()
{
try
{
String[] key = {"Customer:David:1001","Customer:Paul:1002","Customer:Dave:1003","Customer:Mathew:1004"};
IDictionary failedItems = cache.DeleteBulk(keys, DSWriteOption.WriteBehind, OnDataSourceItemsRemoved );
//verify items deleted from the main source
}
catch (Exception exp)
{
//handle exception
}
}
See Also
Data Source Providers Overview | Read-Through Caching | Write-Through Caching | Configuring Read-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Dynamic Compact Serialization

< Previous page Next page >

Dynamic Compact Serialization

NCache provides a feature to make application data types compact serializable. This section explains how to do it.
In this section
Overview
Explains the concept of Dynamic Compact Serialization and its benefits.
Using Compact Serialization
Explains how to use Dynamic Compact Serialization using NCache API.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

NCache stores application data in serialized form. Data is serialized on cache client before adding it to cache. Therefore data to be added in cache must also be marked as serializable. It supports native binary serialization for both JvCache client and NCache client and it also has its own serialization framework called compact serialization which is fast and compact than native serialization. In native serialization of .NET, all data of an object along with the entire type information is serialized. In this way, size of the object increases, whereas in compact serialization, the entire type information does not travel on the network so the object size which travels on network is reduced. As the object size decreases, network trips become faster and eventually the cost decreases while increasing the overall application performance.
Compact serialization is also binary serialization and has the following benefits:
Compact Data Size
In NCache, binary data size of the serialized object is compact. In certain scenarios data size may be 10 times less than that of native serialization. Smaller serialized objects take less time to travel on the network which results in a higher through put. This also helps in reducing memory consumption on cache’s server. In this manner NCache achieves better performance while reducing time and cost. Small object size and fast network traffic increases the application performance.
Fast
Compact serialization is faster than native serialization as it does not rely as much on reflection as native serialization does. Native serialization uses reflection for attribute information, this reflection is avoided in NCache’s compact serialization, type information for compact types are loaded only once when cache is initialized, which reduces the overhead faced using native serialization. Benchmarks have shown that in certain use cases, it is 5~10 times faster than native serialization.
No Code Change
There is no code change required to make a class compact serializable. The only step required is to configure your classes through management tools. (NCache Manager or command line tools).
NCache 4.3 and later versions allow selective serialization. It allows data members of a class to be mark as non-serializable. Please see administrator’s guide for more details. The excluded attributes’ values will not be serialized. The excluded attribute of any cached object will either be null or will have a default value if assigned. This feature is useful in a scenario where for certain attributes, there is no need for caching, e.g., connection object for database. By this selective serialization the process becomes even more efficient and more compact. For using Compact Serialization, a default public constructor (parameter less) in a compact serializable type must be provided and that type must be registered with NCache Manager.
The interface ICompactSerializable can be implemented which gives a more fine grained control over compact serialization. Through this interface, which data members are to be serialized and which are to be excluded can be controlled.
Support for the compact serialization of Generic Types is also available in NCache. The list of allowed types can be selected and specified either through NCache Manager, or by implementing a generic type handler.
The following points must be considered while using compact serialization.
  • A compact serializable class can have data members of other classes which are native serializable, but are not compact serializable.
  • A class which is only native serializable cannot have data member which are only compact serializable.
  • If your class is native serializable and it has data members which are both native and compact serializable, then native serialization will be used while serializing the object of container class.
If Read/Write-through provider or cache startup loader is configured along with compact serialization, then the assemblies containing compact classes should be deployed along with providers. For example, in a scenario where cache loader is configured, during cache filling, items are fetched from data source. These items are serialized before they are inserted into cache; here for serialization, assembly containing compact classes is required.
An object registered in Data Sharing cannot be registered in Compact Serialization at the same time.
See Also
Using Compact Serialization | Registering Classes for Compact Serialization | Cache Startup Loader | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Compact Serialization

< Previous page Next page >

Using Compact Serialization

To use compact serialization, object types that are to be compact serialized need to be configured through NCManager. NCache internally handles serialization/deserialization of registered classes and the user doesn’t need to explicitly code for it.
However, NCache also allows to explicitly implement ICompactSerializable interface provided in
Alachisoft.NCache.Runtime.Serialization.ICompactSerializable
To implement this interface, the custom object class needs to implement Serialize/Deserialize methods which will be called by NCache while serializing/deserializing this object. Sample code for implent this interface is given below:
//Sample code for custom ICompactSerializable class
public class CustomObject : ICompactSerializable
{
private string _attribute1;
private int _attribute2;
private bool _attribute3;
public CustomObject()
{ }
public CustomObject(string attrib1, int attrib2, bool attrib3)
{
_attribute1 = attrib1;
_attribute2 = attrib2;
_attribute3 = attrib3;
}
#region ICompactSerializable Members
public void Deserialize(Runtime.Serialization.IO.CompactReader reader)
{
_attribute1 = reader.ReadObject() as string;
_attribute2 = reader.ReadInt32();
_attribute3 = reader.ReadBoolean();
}
public void Serialize(Runtime.Serialization.IO.CompactWriter writer)
{
writer.WriteObject(_attribute1);
writer.Write(_attribute2);
writer.Write(_attribute3);
}
#endregion
}
Care should be taken that class attributes are deserialized in the same order in which they are serialized otherwise serialized stream won’t be deserialized.
Implementing a Generic Type Handler
NCache also allows registering generic types in compact serialization. For this, each type needs to be registered through NCManager. There is another way for registering generic compact types through "Generic Type Handler". With Generic Type Handler, the user can add all the generic types at once by implementing the IGenericTypeProvider interface from Alachisoft.NCache.Runtime.GenericTypesProvider. This saves a lot of time and effort in case the user wants to register a large number of types.
To implement this, the user needs to implement GetGenericTypes method and return the desired generic types in Type array. After this, deploy this class assembly to NCManager. NCManger will register all types populated in Type array. Sample code is given below:
using Alachisoft.NCache.Runtime.GenericTypesProvider;
namespace CompactSerialization
{
public class CustomGenericType<T,K,V>
{
}
public class SetGenerics : IGenericTypeProvider
{
Type[] allowedGenericTypes = new Type[5];
Type[] IGenericTypeProvider.GetGenericTypes()
{
allowedGenericTypes[0] = typeof(Dictionary<string, Customer>);
allowedGenericTypes[1] = typeof(List<int>);
allowedGenericTypes[2] = typeof(CustomGenericType<Employee, Product, Customer>);
allowedGenericTypes[3] = typeof(CustomGenericType<Employee, Product, int>);
allowedGenericTypes[4] = typeof(CustomGenericType<Employee, string, byte>);
return allowedGenericTypes;
}
}
}
As can be seen in the above example, a list of types are specified which are to be allowed in the generic types for compact serialization.
See Also
Compact Serialization Overview | Registering Classes for Compact Serialization | Cache Startup Loader | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: WAN Replication Through Bridge

< Previous page Next page >

WAN Replication Through Bridge

NCache provides WAN replication through Bridge feature. A bridge is created between two cluster caches and data is replicated from source to other site through that bridge. This section explains the concept of a bridge and describes the bridge configurations and implementation of a Bridge Conflict Resolver in NCache.
In this section
Overview
Explains the concept of Bridge in NCache.
Bridge Configurations
Explains the two kinds of Bridge configurations provided in NCache.
Bridge Conflict Resolver
Explains how to implement and use Bridge Conflict Resolver in NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

In IT industry, one has to deal with large scale applications which should be live for 24/7. Proper management of your application and millions of customers with high risk of internal or external failure is important. For critical applications, the disaster risk of any kind can’t be ignored and its recovery plans must be considered very carefully. Disaster can be of any type like natural disasters or internal hardware or software failure.
For large scale applications, distributed caches are used to improve their performance, reliability and runtime scalability. So distributed caches can be a very important part of disaster recovery plan. The best and most frequently used disaster recovery plan is live data replication to other backup site. So that when needed, the live users can be redirected to backup site without any error. For that purpose, the active and backup caches should always be in synchronized states. If they are not synchronized, then it can affect the application's cache clients.
Data replication also solves the problem if along with disaster recovery plans the application needs to be deployed on geographically separated regions for widely spread customers. In such a case, there will be two or more active sites which will deal with users of related regions and can also be used as backup of other region sites.
Data replication can be done in two ways, synchronously and asynchronously. But for WAN replication, asynchronous replication is mostly preferred.
NCache provides WAN replication through Bridge feature. A bridge is created between two cluster caches and data is replicated from source to other site through that bridge.
Pluggable Caching Architecture: Caches are not aware of each other they just know about bridge and replicate their data to bridge. Due to this loose coupling, the bridge can be configured between any two caches irrespective of their cache topology. Also caches configured with bridge can be freely removed.
Data Integrity: Operations performed at source cache are en-queued by the bridge maintaining the actual order in which they were performed at source cache. Bridge performs operations on target cache in the same order. Conflicts are resolved on target cache. In this way, caches becomes eventually consistent.
Dedicated Bridge Service: Bridge is also a stand-alone and dedicated service like cache service so cache operations will not be affected if any bridge operation is delayed due to latency in network.
Configuring Bridge: The bridge can be configured either on the same server where the cluster cache resides or on a separate server node. When both cluster caches are added into bridge, data is replicated between them.
Disaster Recovery: Bridge can be configured between an active and passive data center for disaster recovery.
Dealing Geographically Spread Customer: There can be two active sites which will deal with users of related regions and can also be used as backup of other region sites.
Asynchronous Replication: For WAN replication, asynchronous replication is used so that cache operations will not suffer in case of delays in bridge operations.
Queue Backup: Bridge is basically a two node clustered queue in which one node is active and the other is passive having backup of active queue to avoid data loss on bridge.
Connection Retries: Bridge also tries to replicate all operations by retrying when any connection failure occurs.
Configurable Queue Size: Bridge and target replicator queue size is configurable. The size of bridge queue can be configured by analyzing the cache load because every update will be replicated to bridge queue and if its size is small, then queue will become full resulting in data loss.
Bridge caches : Any topology can be used for cluster caches that will be part of the bridge. Even two different topology caches on each site in one bridge can exist too. The convention, however, is to use the same topology on both sites.
It is recommended that bridge caches have same configurations other than topology to avoid issues. For example if data source is configured on one cache you should configure it on other cache too. Because same operation specifications from one site cache will be replicated to other site.
See Also
Bridge Configurations | Bridge Conflict Resolver | Configuring Bridge for WAN Replication | Creating Caches | Configuring Cache Cluster Settings | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Bridge Configurations

< Previous page Next page >

Bridge Configurations

NCache Bridge provides two kinds of bridge configurations:
1. Active-Passive Configuration
This configuration is mostly used for creating backups for disaster recovery. In this configuration, there is an active site, a bridge and a passive site. Operations are replicated to the passive site from the active site through bridge. No requests are directed to the passive site. Bridge is created at the active site to reduce bridge replication cost from source to bridge.
If the active site goes down by any cause, the client requests can be transferred to passive site by making it active. The passive site will now behave as active and treat all requests without any request failures.
When the old active site is ready and restarted, reform the configurations same as before. Both sites should be active to transfer all the data from old passive to old active site. When data transfer is complete, make configurations to the passive site and redirect all requests to active site.
2. Active-Active Configuration
This configuration is used when there are active data centers in two regions and the need is to synchronize caches between those regions. The bridge has active sites on both its ends. Client requests are treated by all sites so replication is bidirectional. Operations are replicated from any one site to other site. Bridge can be created on any of the two sites since both of them are active. In most of the cases, the bridge resides in the region of that site which has higher user traffic to reduce bridge replication cost.
Since communication is between two active caches, so it is a possibility that the same cached data is updated on both sites simultaneously. This causes a conflict in the cache item’s value. To resolve this conflict, NCache provides a Conflict Resolver which resolves operation conflict on bridge time. It is quite possible that these two active sites reside in two different time zones. To address the conflict of time, both caches synchronize their time with bridge time. When an operation conflict occurs, the bridge time stamp is used to figure out which operation is the latest. By default, the latest operation wins and is applied on cache in case of a conflict. The users can also customize conflict resolver by providing their own implementation.
If any site goes down, then all the requests can be redirected to other active sites. When the site which was down goes up again, data is transferred from the already running site to this site and that region's requests are redirected again to this site.
Runtime Transfer Data
Data can be transferred from one site to another forcefully if there is a chance that both caches are not synchronized. For example, if a two node partitioned cluster cache is being used on both sites and at one site, one node of the cluster cache goes down, then data on that node will be lost. In such a situation, data can be forcefully transferred from the other site to this cache through bridge.
This feature can be enabled through Force State Transfer provided in NCache Manager.
Runtime Switching Between Configuration Modes
Switch can be made between active and passive mode of any site at runtime. This means that active-passive configuration can be changed to active-active configuration whenever needed without any downtime. This is useful when the load is increased on a site for some duration of time. In that duration, the user might want to use the passive site as active site for load distribution and better performance.
Connect/Disconnect Bridge Caches
The cache can be easily connected or disconnected from bridge at runtime without affecting client requests in terms of replication of data. When a cache is disconnected from bridge, then bridge does not send any operation to that cache for replication. Other active cache also does not replicate its operation to bridge. When the disconnected cache connects to the bridge again, all data replication is resumed again through bridge in the same manner as done before. Disconnecting a cache does not mean that cache is stopped. Client activity on both caches remains the same and only bridge replication is stopped.
See Also
WAN Replication Through Bridge Overview | Bridge Conflict Resolver | Configuring Bridge for WAN Replication | Creating Caches | Configuring Cache Cluster Settings | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Bridge Conflict Resolver

< Previous page Next page >

Bridge Conflict Resolver

In bridge topology, there can be more than one active site cache and cache operations can be simultaneous. It is possible that the client connected with one active site cache adds some keys and the same key operation is performed by the other active node. In such a situation the bridge conflict resolver comes into play. It resolves the conflicts and decides which key to apply on the cache depending upon the defined rules.
If user hasn't configured any conflict resolver rules, then NCache uses the default resolver rule. In the default rule, a timespan is added with each operation performed on the cache and it keeps the latest operation. A check is performed on the version of the bridge item. If it has a newer time stamp or if the version is the latest or the same it replaces that with the new entry and in case of old, it keeps the old entry.
Using Bridge Conflict Resolver
Namespace
For enabling Bridge Conflict Resolver, your program needs a reference to the assembly Alachisoft.NCache.Runtime.dll that contains interface Alachisoft.NCache.Runtime.Bridge.IBridgeConflictResolver provided by NCache. The class implementing this interface allows framework to resolve the conflict between existing operations and operation replicated from bridge to cache. Thus, the class needs to include the logic for Conflict Resolution between bridge and cache.
Following namespace is required in your project for using IBridgeConflictResolver:
using Alachisoft.NCache.Runtime.Bridge;
IBridgeConflictResolver Interface:
In order to use IBridgeConflictResolver in your application, implement the following interface:
public void Init(System.Collections.IDictionary parameters);
public ConflictResolution Resolve(ProviderBridgeItem oldEntry, ProviderBridgeItem newEntry);
public void Dispose();
Method
Description
void Init (IDictionary parameters)
This method performs tasks like allocating resources, acquiring connections etc. When cache is initialized and Conflict Resolvers is enabled, Init method is called to notify the client that cache is initializing and the client can initialize its conflict resolver via Init. The parameters passed as an argument contains all the parameters (if any) that were specified using NCache Manager cache/cluster views. These parameters can be utilized in many ways.
void Dispose();
This method performs tasks like releasing the resources etc. When Cache is stopped or the task is completed, it calls the Dispose() method to notify the client that it can now free the resources related to its task.
ConflictResolution Resolve (ProviderBridgeItemoldEntry, ProviderBridgeItemnewEntry);
This method contains the logic to resolve the conflict occur while replicating an operation from bridge for a key that already exists in the cache. Whenever any conflict occurs, cache call BridgeConflictResolution to decides which operation to apply on the cache depending upon rules implemented in it. It takes two parameters/entries, both are of ProviderBridgeItem type. ProviderBridgeItem contains the following parameters:
· BridgeItemVersion contains version of an item (LATEST, OLD, SAME).
· Key contains key of an item.
· Value of an item contains value of an item.
· BridgeItemOpCodes contains conflicted operation (Add, Remove, Update, Clear, RemoveGroup,RegisterKeyNotificationetc) .
Implementing Bridge Conflict Resolver
Here is a sample implementation for IBridgeConflictResolver:
public class Resolver : Alachisoft.NCache.Runtime.Bridge.IBridgeConflictResolver
{
//
// If true, logs will be generated
//
private bool _enableLogging;
private TextWriter _textLogger;
public void Dispose()
{
if (_enableLogging)
{
_textLogger.WriteLine("Closing logger");
_textLogger.Close();
}
}
public void Init(System.Collections.IDictionary parameters)
{
//
//Initialize textWriter
//
if (parameters.Contains("logging"))
{
_enableLogging = Convert.ToBoolean(parameters["logging"]);
}
if (_enableLogging)
{
_textLogger = new StreamWriter("bridgeResolverLog.txt");
_textLogger.WriteLine("Initializing bridge Conflict Resolver");
}
}
public ConflictResolution Resolve(ProviderBridgeItem oldEntry, ProviderBridgeItem newEntry)
{
ConflictResolution conflictResolution = new ConflictResolution();
switch (oldEntry.BridgeItemVersion)
{
case BridgeItemVersion.OLD:
{
conflictResolution.ResolutionAction = ResolutionAction.ReplaceWithNewEntry;
}
break;
case BridgeItemVersion.LATEST:
{
conflictResolution.ResolutionAction = ResolutionAction.KeepOldEntry;
}
break;
case BridgeItemVersion.SAME:
{
if (oldEntry.OpCode == BridgeItemOpCodes.Remove)
{
conflictResolution.ResolutionAction = ResolutionAction.ReplaceWithNewEntry;
}
else
{
conflictResolution.ResolutionAction = ResolutionAction.KeepOldEntry;
}
}
break;
}
if (_enableLogging)
_textLogger.WriteLine("Resolve Key {0} and decision taken {1}", oldEntry.Key, conflictResolution.ResolutionAction.ToString());
return conflictResolution;
}
}
See Also
WAN Replication Through Bridge Overview | Bridge Configurations | Configuring Bridge for WAN Replication | Creating Caches | Configuring Cache Cluster Settings | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Custom Dependency

< Previous page Next page >

Custom Dependency

In custom dependency, the user can have his own dependencies scenarios. In this way, items can be be expired from cache in a number of flexible ways where expiration logic meets the user’s business requirements. NCache provides an abstract class ExtensibleDependency that is base for all dependencies.
How to Implement Custom Dependency
For overriding ExtensibleDependency class, user’s program needs a reference to the assembly Alachisoft.NCache.Runtime.dll that contain abstract class Alachisoft.NCache.Runtime.Dependencies.ExtensibleDependency provided by NCache. ExtensibleDependency class contains following abstract method and property.
public abstract bool HasChanged { get; }
public abstract bool Initialize();
Method | Description
Public bool Initialize(); | This method can be used to perform tasks like allocating resources, acquiring connections etc. If resources has been successfully acquired, return true else false. If Initialize return false NCache removes item with custom dependency from the cache.
Public bool HasChanged { get;} | NCache calls HasChanged (property) after every clean interval. If HasChanged returns true all custom dependent items will be removed from cache.
Follow the following steps to implement custom dependency.
Step 1: Inherit the dependency class from ExtensibleDependency and override the abstract function and property.
Lets suppose there is a grocery store which has a big collection of those products which customer often buy. These products can be cached from the database to check their units in stock.The dependency polls the Northwind database and expires all the Products for which units in stock are less than 100.
[Serializable]
public class CustomDependency :ExtensibleDependency
{
private string _connString;
private int _productID;
public override bool Initialize()
{
return true;
}
public CustomDependency(int productID, string connString)
{
_connString = connString;
_productID = productID;
}
internal bool DetermineExpiration()
{
if (GetAvailableUnits(_productID) < 100)
return true;
return false;
}
internal int GetAvailableUnits(int productID)
{
SqlDataReader reader = null;
SqlConnection connection = new SqlConnection(_connString);
connection.Open();
int availableUnits = -1;
try
{
SqlCommand cmd = connection.CreateCommand();
cmd.CommandText = "Select UnitsInStockFrom Products where ProductID=" + productID + "";
reader = cmd.ExecuteReader();
if (reader.Read())
{
availableUnits = Convert.ToInt32(reader["UnitsInStock"].ToString());
}
reader.Close();
return availableUnits;
}
catch (Exception)
{
return availableUnits;
}
}
public override bool HasChanged
{
get
{
return DetermineExpiration();
}
}
}
Step 2: Place assembly or executable file of class overriding ExtensibleDependency in NCache service folder and restart the NCache service.
Adding Data with Custom Dependency
Once custom dependency class has been implemented and deployed, its ready to be used in your program. Following code shows how to use custom dependency:
string connString ="Provider=SQLOLEDB.1;Data Source=localhost;User ID=sa;password=;Initial Catalog=Northwind";
//Creating custom dependency
CustomDependency hint = new CustomDependency (123, connString);
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
try
{
//Adding data with custom dependency
cache.Insert(key, product, new CacheDependency(hint), Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, Alachisoft.NCache.Runtime.CacheItemPriority.Default);
}
catch (OperationFailedException exp)
{
// handle exception
}
See Also
Cache Dependencies | Configuring Basic Cache Settings | Cache Startup Loader | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Side ASP.NET Features

< Previous page Next page >

Client Side ASP.NET Features

This section is a practical guide for programmers who want to utilize powerful features of ASP.NET with NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
ASP.NET Sessions
Explains maintaining and synchronizing session state throughout a server farm using NCache Clustered Session.
View State Caching
Explains how to use View State Caching and content optimization feature of NCache.
ASP.NET Output Cache
Shows how to use output caching to cache the HTML output of dynamic requests to ASP.NET pages, hence speeding up the overall response process.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: ASP.NET Sessions

< Previous page Next page >

ASP.NET Sessions

You can quickly use clustered sessions in your existing ASP.NET applications without any code change and can immediately see a performance boost in your application. NCache provides high performance in-memory ASP.NET session clustering for web farms that is faster and more scalable than storing them in a database. It is faster because sessions are kept in memory and closer to the ASP.NET application. And, it is more scalable because sessions can be distributed to multiple servers in the farm that can better handle larger load than a database server.
With NCache, you can eliminate the need to use sticky sessions in your load balancer. This significantly improves your application scalability. NCache provides powerful dynamic clustering of sessions. You can replicate or distribute/partition sessions either locally on multiple web servers or on multiple dedicated session caching servers. NCache offers a rich set of features to grow you session clustering from small to large web farms.
In This Section
Overview
Explains the benefits of NCache based Session State Store Provider.
Using NCache Session State Store Provider
Explains how to configure and use NCache Session State Store Provider.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview
This feature is available only for .NET Framework version 2.0 and later.
ASP.NET Session State allows to store session data into custom data source by implementing SessionStateStoreProviderBase class. A session state store provider has been implemented using NCache to store data
into distributed cache.
NCache based Session State store provider has the following benefits:
  • No Code Change: NCache Session State provider can be used in an application without any code change.
  • Better Performance: Session data being stored in in-memory cache yields maximum performance.
  • Reliability: By default session is stored in memory of ASP.NET process. If process recycles or application server goes down, session data is lost. With NCache, session data is stored, outside of ASP.NET process, in cache cluster. Any cache topology can be opted to meet the needs of reliability. So in case the application server goes down, session data remains available when ASP.NET process recycles back or application server comes back.
  • No Need of Sticky Sessions: Using NCache session state provider will eliminate the use sticky sessions in load balancer.
  • NCache Cache Storage- Scalability: NCache session state provider uses NCache cache as storage, here cluster cache can be used to gain better scalability. Working with it allows adding more servers to session cluster at runtime; it results in more scalability and reliability for the application. ASP.NET session clustering for web farms is faster and more scalable than storing them in a database.
  • Availability, Load Balancing, Fault Tolerance: In web farm environment it provides better fault tolerance, keeping session data available at all server nodes in cluster cache to better handle larger load because sessions can be distributed to multiple servers in the farm. Thus it is safe to say that it results in a high performance. It is suitable for session clustering from small to large web farms.
  • Cluster Topologies: For session cache, different clustering topologies can be used. Replicated topology offers load balancing of client so that the web application does not suffer during intensive traffic. If partitioned-replica cache is used, it gives high scalability, high reliability to the application and is extremely fast. Sessions can be replicated or distribute/partitioned either locally on multiple web servers or on multiple dedicated session caching servers. For cache topology details, see section Cache Topologies .
  • Serialized Data: Session data needs to be in seralizable form.
  • Session Lookup in Cache Made Easy: All session data in cache can be retrieved in a single call. NCache provides tag with session, in one single operation all session data with tag can be easily fetched.
  • Exclusive Locking: To avoid deadlock and data integrity issue, exclusive locks are provided in NCache session state provider. Locking is configurable and in default is off.
  • Locking Release Retry: If exclusive lock is used, locking retries are also configured. In case of concurrent requests, lock release is tried a configured number of times.
  • Location Affinity: NCache’s session state provider's Location Affinity manages ASP.NET session state across multiple web farms which are geographically separated. For Location Affinity, one 'primary' and one or more 'secondary' caches have to be specified for each web farm. The primary cache will be used for all local traffic, in local region and secondary cache(s) are of distant geographical regions. These are configured in web.config. This optimization is possible only in .NET 2.0 and later versions.
See Also
Using NCache Session State Store Provider | View State Caching | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using NCache Session State Store Provider

< Previous page Next page >

Using NCache Session State Store Provider

NCache Session State Provider is a custom SessionStateStoreProviderBase implementation for an ASP.NET application.
How to Configure NCache Session State Provider
  • Modify Assemblies Tag
Modify <assemblies> section in the application's web.config and add following assembly.
For Enterprise and Professional Editions:-
<assemblies>
<add assembly ="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
For Open Source Edition:-
<assemblies>
<add assembly ="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
  • Replace version "x.x.x.x" with the actual NCache version that you have.
  • Refer Alachisoft.NCache.SessionStoreProvider in your project from "$NCache-install/bin/assembly/[2.0 or 4.0] folder.
  • Modify sessionState Tag
Edit your application's web.config file and modify the <sessionState> section as given below. Place the following code under <system.web> tag.
<sessionState cookieless ="false" regenerateExpiredSessionId ="true" mode ="Custom" customProvider ="NCacheSessionProvider" timeout ="10">
<providers>
<add name ="NCacheSessionProvider" type ="Alachisoft.NCache.Web.SessionState.NSessionStoreProvider" sessionAppId ="1234" cacheName ="myCache" enableSessionLocking ="false" sessionLockingRetry ="-1" writeExceptionsToEventLog ="false" enableLogs ="false" enableDetailLogs ="false" exceptionsEnabled ="false" operationRetry ="0" operationRetryInterval ="0"/>
</providers>
</sessionState>
Following is the description of different key-value pairs specified above:
Member | Description
sessionAppId | Optional string attribute. Specifies an identifier to make sure that session ID remains unique in case multiple applications are using the same cache. Application ID should be the same for an application in a web farm. If no app ID is specified, nothing will be concatenated with session ID.
cacheName | Required string attribute. Specifies the name of the cache to be used for caching session. If no cache name is specified, a configuration exception will be thrown.
enableSessionLocking | Optional Boolean attribute. If this flag is set, NCache Session Store Provider exclusively locks the session-store item for which multiple concurrent requests are made. The default is false. Read Session Locking in NCache Session Store Provider
sessionLockingRetry | Optional Integer attribute. If enableSessionLocking is true and this integer is not less than 0, NCache Session Store Provider will return empty session after sessionLockingRetry, which specify the number of retries to acquire a lock. The default is -1. Read Session Locking in NCache Session Store Provider
writeExceptionsToEventLog | Optional Boolean attribute. If this flag is set, all the exceptions from cache API are written to event logs. The default is false.
enableLogs | Optional Boolean attribute. When this flag is set, store provider logs all error information. The log files are created in "$NCache-install/log-files/SessionStoreProvider/". The default is false.
enableDetailLogs | Optional Boolean attribute. When this flag is set, store provider logs all debugging information. The log files are created in "$NCache-install/log-files/SessionStoreProvider/". The default is false.
exceptionsEnabled | Optional Boolean attribute. Specifies whether exceptions from cache API are propagated to the page output. Setting this flag is especially helpful during development phase of application since exceptions provide more information about the specific causes of failure. The default is false.
operationRetry | It specifies the number of times server will retry the operation, in case connection is lost with a server while an operation is executing. Its default is zero.
operationRetryInterval | It specifies the time interval between each operation retry, in case connection is lost with the server. Its default value is zero.
  • Modify MachineKey Tag
Add <machineKey> entry under <system.web> section. It is required to generate ASP.NET session IDs in the same manner on all nodes. You can use the genmackeys utility available with NCache installation to generate the keys.
<machineKey validationKey ="A01D6E0D1A5D2A22E0854CA612FE5C5EC4AECF24" decryptionKey ="ACD8EBF87C4C8937" validation ="SHA1"/>
How to Fetch Session Data
NCache version 4.3 and later allow viewing all session data stored in clustered cache via NCache Session State Module. All session data is added in the specified cache as a tagged cache item with tag:"NC_ASP.net_session_data".
In order to retrieve previously stored session data, data can be fetched by GetByTag API, which returns Hashtable populated with session ids and associated session data stored in the cache.
Hashtable allSessionData = cache.GetByTag(
new Alachisoft.NCache.Runtime.Caching.Tag("NC_ASP.net_session_data"));
Enabling Location Affinity for SessionStoreProvider
  • Add New Section for Session State Management
Modify <configSections> section in the application's web.config and add following section.
For Enterprise and Professional Editions:-
<configSections>
<section name="ncache" type="Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</configSections>
For Open Source Edition:-
<configSections>
<section name="ncache" type="Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</configSections>
  • Replace version "x.x.x.x" with the actual NCache version that you have.
  • Refer Alachisoft.NCache.SessionStateManagement in your project from "$NCache-install/bin/assembly/[2.0 or 4.0] folder.
Add a section with the section name specified above (<ncache> in this case), under <configuration> tag in your application's web.config.
<ncache>
<sessionLocation>
<primaryCache id="London_Cache" sid-prefix="LDC"/>
<secondaryCache id="NewYork_Cache" sid-prefix="NYC"/>
<secondaryCache id="Tokyo_Cache" sid-prefix="TKC"/>
</sessionLocation>
</ncache>
The sid-prefix is a unique identifier that is appended by custom session-ID manager in the beginning of session-ID. sid-prefix length must be equal to 4.
  • Modify sessionState Tag
Enable custom sessionID manager using the sessionIDManagerType attribute of the sessionState element in web.config and add custom provider.
Member | Description
sessionIDManagerType | Optional string attribute. Specifies an identifier to make sure that session ID remains unique in case multiple applications are using the same cache. Application ID should be same for an application in a web farm. If no app ID is specified, nothing will be concatenated with session ID.
  • When Location Affinity is enabled, cacheName specified in <providers> section of web.config will be ignored.
  • Cookieless sessions are not supported.
See Also
ASP.NET Sessions Overview | View State Caching | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: View State Caching

< Previous page Next page >

View State Caching

ASP.NET View State is a very powerful mechanism that stores pages, controls and custom values between multiple HTTP requests across client and the web server. This section explains the View State caching feature provided by NCache.
In This Section
Overview
Explains the concept of ASP.NET View State caching, the downsides of using it and how NCache's View State caching resolves these issues.
Using NCache View State Caching
Explains Content Optimization and View State caching feature of NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

ASP.NET today is widely used for high traffic web applications that need to handle millions of users and are deployed in load balanced web farms. ASP.NET View State is a very powerful mechanism that stores pages, controls and custom values between multiple HTTP requests across client and the web server. View State is ASP.NET method for persisting page and control states during post-backs. All ASP.NET applications have to deal with view state which is becoming a performance overhead. View State caching helps caching view state on web servers and send a much smaller payload to the user's browser containing only a unique ID for this view state. As a result, the page uses lesser bandwidth which improves performance and the ASP.NET application also scales much better.
Why Cache View State?
There are multiple downsides to View State. As it is known View State is an encrypted text string containing the state of web form controls and widgets and is sent to the user's browser to preserve the state across post-backs. For forms with lot of controls, DataGrid control, or some other complex controls, the View State can become quite large.
Another reason can be of heavy ASP.NET View State where the increased bandwidth usage increases the bandwidth cost considerably. For example, if for each HTTP requests, about 60-100k of additional ASP.NET View State data is appended, this multiplied by the total number of transactions and it is clear that bandwidth consumption becomes very high.
Also, in some situations, there is a security risk with sending confidential data as part of ASP.NET View State. And, encrypting it before sending is also costly.
Here are some reasons why it should be considered to cache the View State.
  • View State is large (tens of KB) on large forms and DataGrid.
  • Large View State slows down page download time.
  • Large View State slows down post-back request time.
  • Cache View State on web servers & send only a token to user.
  • View State cache is distributed to all web servers in the farm; there is no single point of failure.
NCache's View State Caching resolves these issues, following are some of its features:
  • Increased Performance: NCache reduces the request/response payload which improves the overall request time.
  • Availability and Reliability: NCache is in-memory cache, it is distributed and synchronized across all web servers, even if the post-back request goes to a different web server in the farm than the original server where the viewstate was created, NCache is able to find the viewstate value in the cache.
  • View State with its Session: NCache allows view state to be categorized with respect to its respective session.
  • Limit View State Caching: For longer sessions with abundant amount of viewstates it is now possible to limit viewstate per session to a configurable number. Metadata is used for limiting, meta data is also cached. It is also possible to lock metadata. Locking can be configured via web.config.
  • Page level Grouping for View State: NCache allows grouping on page level, multiple pages can be coupled to define a group. For each group, different configurations can be set.
  • ViewState.xml is required for view state grouping feature. This xml can have multiple web app configurations. In each web app configuration, there can be one or more group configurations. And different caches can be configured for different groups.
See Also
Using NCache View State Caching | ASP.NET Sessions | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using NCache View State Caching

< Previous page Next page >

Using NCache View State Caching

Content Optimization Feature of NCache
Following are the two steps that need to be performed in order to use content optimization feature of NCache:
Step 1: Update/Configure App Browser File
  • Create an App browser file in the ASP.NET application. It will be created under the directory of App_browsers.
  • Now plug page adapters in the app browser file as following:
<browsers>
<!-- NCache Plug page adapters in the app browser file as following:. -->
<browser refID="Default">
<controlAdapters>
<adapter controlType="System.Web.UI.Page"
adapterType="Alachisoft.NCache.Adapters.PageAdapter" />
</controlAdapters>
</browser>
</browsers>
This is an example of page adapter plugged at page level. You can also plug it at any control level for which you want to cache the view state.
Step 2: Update/Configure Web.config File
  • Add the following assembly reference in compilation section of web.config file
For Enterprise and Professional Editions:-
<compilation defaultLanguage="c#" debug="true" targetFramework= "4.0">
<assemblies>
<add assembly="Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
</compilation>
For Open Source Edition:-
<compilation defaultLanguage="c#" debug="true" targetFramework= "4.0">
<assemblies>
<add assembly="Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
</compilation>
  • A web config section needs to be registered which contains the following settings/properties in web.config file.
<configSections>
<!--NCache Register config section first. -->
<sectionGroup name="ncContentOptimization">
<section name= "settings" type= "Alachisoft.NCache.ContentOptimization.Configurations.ContentSettings" allowLocation="true" allowDefinition= "Everywhere"/>
</sectionGroup>
</configSections>
  • Add the actual setting/configuration section as follows:
<!--NCache actual setting/ configuration for view state
<ncContentOptimization>
<settings enableViewstateCaching="true" viewstateThreshold="1" cacheUriMapping="true" enableTrace="false" >
<cacheSettings cacheName="mycache” connectionRetryInterval="300">
<expiration type="Absolute" duration="1" />
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Member | Description
enableViewstateCaching | Boolean value to enable /disable the ViewState caching.
viewstateThreshold | Sets the minimum threshold size of viewstate in bytes. Viewstates which are smaller than threshold value will not be cached.
cacheUriMapping | Cache URL mapping, Default is true.
enableTrace | Enable/disable traces.
cacheName | Name of the Cache.
connectionRetyInterval | Retry Connection to Cache interval. Default is 300 seconds.
Expiration | Sets the expiration type which can either be Sliding, Absolute or None. And also expiration interval in minutes.
Duration | Sets expiration interval in minutes.
  • In the end, register the HTTP handler in the HttpHandlers section of web.config as following:
For Enterprise and Professional Editions:-
<add verb="GET,HEAD" path="NCResource.axd" validate="false" type="Alachisoft.NCache.Adapters.ContentOptimization.ResourceHandler, Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
For Open Source Edition:-
<add verb="GET,HEAD" path="NCResource.axd" validate="false" type="Alachisoft.NCache.Adapters.ContentOptimization.ResourceHandler, Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=144
8e8d1123e9096"/>
If the same cache is being used for View State caching and other data, viewstate data can be retrieved by NC_ASP.net_viewstate_data tag. With this tag it is easy to find the data specific to viewstate.
Hashtable allViewStateData = cache.GetByTag(new Alachisoft.NCache.Runtime.Caching.Tag("NC_ASP.net_viewstate_data"));
The view state of a particular session can easily be retrieved from cache based on sessionId.
How to Group View State with Session
NCache provides a feature that allows to group view state with a particular session. Due to this dependency, as the session is expired, the view state associated with it expires too. The view state and session can reside either on two different caches or on a single cache. To enable this feature, expireViewstateWithSession should be set as true in ncContentOptimization tag.
<ncContentOptimization>
<settings enableMinification="false" enableViewstateCaching="true" groupedViewStateWithSessions="true" viewstateThreshold="1" cacheUriMapping="true" enableTrace="true" expireViewstateWithSession="true" sessionCacheName="vscache" sessionAppId="SSP">
<cacheSettings cacheName="vscache2">
<expiration type="None" duration="0" />
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Member | Description
groupedViewStateWithSessions | Through this property session can be grouped with view state. All the viewstate for a session is grouped with sessionId. This allows to retrieve all viewstate grouped with a sessionId from the cache with group information. Set this property to "true" in order to enable viewstate grouping with sessions. By default, its value is false.
expireViewstateWithSession | By setting this property as true, it is made sure that when a session expires, its associated view state expires too.
sessionAppId | Specifies an identifier to make sure that session ID remains unique in case multiple applications are using the same cache. Its value should be the same as the sessionAppId in sessionState tag.
sessionCacheName | The name of the cache on which the session data is residing. Its value should be the same as the cacheName property in sessionState tag.
How to Limit View State Caching
Following are the configuration changes:
<ncContentOptimization>
<settings enableViewstateCaching="true" viewstateThreshold="0" cacheUriMapping="true" enableTrace="true" groupedViewStateWithSessions="true" maxViewStatesPerSession="5" enableMetadataLocking="false" releaseLockInterval="5000">
<cacheSettings cacheName="mycache">
<expiration type="None"duration="0" />
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Members | Description
MaxViewStatesPerSession | To enable this feature specify any value greater than zero, if zero or lesser value is configured all view state will be cached. If a tag is skipped, all view state will be cached.
EnableMetadataLocking | Defines whether internal metadata manipulation is a locking operation or not. Its default value is true. It comes into play if MaxViewStatesPerSession is enabled.
ReleaseLockInterval | Defines interval after which lock is released. Its value is in milliseconds. Its default value is 5000ms. It comes into play if MaxViewStatesPerSession is enabled.
How to Perform Page level Grouping for View State
The following configurations should be made in web.config file. Also add the property webAppId in settings as follows:
<ncContentOptimization>
<settings webAppId="WebApp_1" enableViewstateCaching="true" groupedViewStateWithSessions="true" viewstateThreshold="12" enableTrace="true" maxViewStatesPerSession="10">
<cacheSettings cacheName = "mycache">
<expiration type="Sliding" duration = "300"/>
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Members | Description
webAppId | Specifies the web application Id where the application is currently running. When webappId is specified, NCache looks up for ViewState.xml file to read configurations. If webAppId is not specified, view states will not be grouped and the default settings from web.config will be used.
ViewState.xml
ViewState.xml is required for this feature. This view state configuration file (ViewState.xml) can be placed at NCache installation config directory C:\Program Files\NCache\config or at web application bin path,e.g., C:\\ASP App\bin.
The web application id provided in web.config is matched with web application id in ViewState.xml file. From ViewState.xml detailed configurations for each group are then loaded.
The configurations provided in the web.config file are loaded as default settings. The configurations in this xml file are loaded per group. Here is a sample ViewState.xml file:
<configuration>
<viewstateConfig>
<webApp webAppId="aspViewState_A ">
<viewstateGroup groupId="Group_A" cacheUriMapping="false" enableViewstateCaching="True" viewstateThreshold="12" groupedViewStateWithSessions="false" maxViewStatePerSession="20">
<cacheSettings cacheName="myCache" connectionRetryInterval="300">
<expiration type="Sliding"duration="5"/>
</cacheSettings>
<pages>
<page url=”…/leftmenu.aspx"/><!—Relative url of a page-->
</pages>
</viewstateGroup>
<viewstateGroup groupId="Group_B" cacheUriMapping="false" enableViewstateCaching="true" viewstateThreshold="23" groupedViewStateWithSessions="false" maxViewStatePerSession="5" enableMetadataLocking="True" releaseLockInterval="5">
<cacheSettings cacheName="replicatedCache" connectionRetryInterval="300">
<expiration type="Sliding" duration="20"/>
</cacheSettings>
<pages>
<page url="…/testcaselist.aspx"/>
<page url="…/ViewState/ViewState_SessionGroup.aspx"/>
</pages>
</viewstateGroup>
</webApp>
<webApp webAppId="aspViewState_B">
<viewstateGroup groupId="Group_A" enableViewstateCaching="True" viewstateThreshold="2" groupedViewStateWithSessions="false" maxViewStatePerSession="200”>
<cacheSettings cacheName="cache">
<expiration type="Sliding" duration="20"/>
</cacheSettings>
<pages>
<page url="…/menu/viewstate.aspx"/>
</pages>
</viewstateGroup>
</webApp>
</viewstateConfig>
</configuration>
Configuration Members
Members | Description
webAppId | Used to distinguish multiple web app sections.(compulsory)
GroupId | Used to distinguish multiple groups. (compulsory)
page url | Relative URL for a page. (compulsory)
Please keep the following important points in mind.
  • The XML file can have multiple web app configurations. In each web app configuration, there can be one or more group configurations.
  • All the web pages for a certain group are provided in <pages> section and page url is the relative url of a page.
  • If a page configuration is not found in view state configuration file, default settings provided in web.config will be used.
  • If any property is missing for any group, default property value provided in web.config will be used.
  • Different caches can also be configured for different groups.
Default and Group Setting Usage:
If web.config provides a web app id, NCache will look for viewstate.xml file to read configuration. In this case, default settings will only be used if configuration for a page is not found in viewstate.xml or if some optional property is missing in viewstate.xml. But if web.config settings does not include web app ID, default settings will be used for all view state caching.
See Also
View State Caching Overview | ASP.NET Sessions | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: ASP.NET Output Cache

< Previous page Next page >

ASP.NET Output Cache

NCache provides extremely fast and reliable output caching feature for ASP.NET applications running in web farm environment, where regular output caching fails. Once a page is rendered by any of the web server in the web farm, it is available to all other servers due to clustered cache created by NCache. Your cached pages are highly available because clustered cache gives no single point of failure. This section explains how to use ASP.NET Output Cache feature in NCache.
In This Section
Overview
Explains the concept of ASP.NET View State caching, the downsides of using it and how NCache's View State caching resolves these issues.
Using ASP.NET Output Cache
Explains how to use ASP.NET Output Cache feature in NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

ASP.NET's output caching system caches the different versions of pages’ content depending on the various parameters e.g query string parameters, browser type etc. In ASP.NET 4.0, an extensibility point has been added that helps developers use any other caching system of their choice other than ASP.NET’s cache. NCache’s output cache provider is derived from System.Web.Caching.Output CacheProvider to get benefited from ASP.NET 4.0 output caching extensibility.
Since the enterprise level applications are typically hosted in multi-sever web farms, InProc output caching does not provide much benefit as compared to have a distributed OutProc cache. Using this extensibility feature of ASP.NET 4.0, NCache now has its own ASP.NET output caching provider.
  • Distributed in Nature: NCache Output Cache provider is OutProc as well as distributed in nature.
  • Availability: Using NCache’s Output Cache provider, content of different ASP.NET pages can be cached on multiple servers instead of caching them in each of the ASP.NET worker process separately. This allows each server in a web farm to share a single distributed cache.
  • Reliability and Fault Tolerance: Unlike ASP.NET’s output cache, content cached in NCache’s output cache provider is not lost when a worker process crashes or when IIS application pool is recycled.
  • Scalability:, NCache Output Cache provider is not restricted to the memory available on each server as the cache cluster can grow dynamically
  • Output Cache with Custom Hooks: NCache output cache provider gives extra control by allowing the users to hook their custom code to modify the cache item’s attributes before it is cached. Since the ASP.NET output caching system does not give any out of the box mechanism to specify cache dependencies, these hooks can be used to add cached items with the dependencies information. These dependencies can be key, file or database dependies As in most of the enterprise applications, a page or control’s output usually depends on some data in the database. In such applications, the user would want to keep an output of a page or control cached until the data gets changed in the database on which this page’s content depends. Similarly, the user may want to change the expiration time for certain pages at runtime overriding the default expiration given in configuration settings. All this can be achieved by writing a custom hook by implementing IOutPutCacheHook interface. These hooks can be implemented, configured and deployed without making any changes to the applications code. All that is required to configure and deploy is to modify the application’s web.config file.
  • No Application Code Change: These hooks can be implemented, configured and deployed without making any changes to the application’s code. All that is required to configure and deploy is to modify the application’s web.config file.
See Also
Using ASP.NET Output Cache | ASP.NET Sessions | ASP.NET Sessions | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using ASP.NET Output Cache

< Previous page Next page >

Using ASP.NET Output Cache
This feature is not available in NCache Express and Professional edition.
Here if the same cache is being used for output caching and for other data, output cache data can be retrieved by "NC_ASP.net_output_data" tag. With this tag it is easy to find data specific to output caching data.
Hashtable allOutputCacheData = cache.GetByTag(new Alachisoft.NCache.Runtime.Caching.Tag("NC_ASP.net_output_data"));
Plug-in NCache Output Cache to Existing Web Applications
In web.config of your application, under the section of system.web element add NCache provider as a default provider i.e.,
For Enterprise and Professional Editions:-
<!-- caching section group -->
<caching>
<outputCache defaultProvider ="NOutputCacheProvider">
<providers>
<add name="NOutputCacheProvider" type= "Alachisoft.NCache.OutputCacheProvider.NOutputCacheProvider, Alachisoft.NCache.OutputCacheProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769" cacheName="mypartitionofReplicaCache" exceptionsEnabled="false" enableDetailLogs="false" enableLogs="true" writeExceptionsToEventLog="false"/>"
</providers>
</outputCache>
</caching>
For Open Source Edition:-
<!-- caching section group -->
<caching>
<outputCache defaultProvider ="NOutputCacheProvider">
<providers>
<add name="NOutputCacheProvider" type= "Alachisoft.NCache.OutputCacheProvider.NOutputCacheProvider, Alachisoft.NCache.OutputCacheProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096" cacheName="mypartitionofReplicaCache" exceptionsEnabled="false" enableDetailLogs="false" enableLogs="true" writeExceptionsToEventLog="false"/>"
</providers>
</outputCache>
</caching>
Replace version “x.x.x.x” with the actual NCache version that you have.
Configuration Members
Members | Description
cacheName | Requires string parameter. Specifies the name of the cache that have been configured through NCache Manager. The application will use this cache for caching specified pages. If no cache name is specified, a configuration exception will be thrown.
exceptionsEnabled | Optional Boolean attribute. Specifies whether exceptions from cache API are propagated to the page output. Setting this flag is especially helpful during development phase of application since exceptions provide more information about the specific causes of failure. The default value is false.
enableLogs | Optional Boolean attribute. When this flag is set, all important events are logged including exceptions, cache initialized, disposed, and session not found etc. The default value is false.
enableDetailLogs | Optional Boolean attribute. When this flag is set, the information that is useful for debugging purposes will be included in logs. The default value is false.
Using Output Cache with Custom Hooks
Using NCache output provide,r output of pages and controls is stored in cache.In some scenarios it can be very helpful if the page/control output can be grouped according to some x.y.z criteria before insertion into cache.Here to provide end user with further more control, NCache provides a concept of “hooks”. Hooks allow users to group output of pages/controls before its insertion into cache.
Following configuration changes are required:
<!-- caching section group -->
<caching>
<outputCache defaultProvider="NOutputCacheProvider">
<providers>
<add name="NOutputCacheProvider" type="Alachisoft.NCache.OutputCacheProvider.NOutputCacheProvider, Alachisoft.NCache.OutputCacheProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=null" exceptionsEnabled="false" enableLogs="true" cacheName="mypartitionofReplicaCache" writeExceptionsToEventLog="false" hookAssemblyName="OutputCache, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" hookClassName="Sample.OutputCacheProvider.OutputCacheHook.OutputCacheHookSample"/>
</providers>
</outputCache>
</caching>
Replace version “x.x.x.x” with the actual NCache version that you have.
How to Implement IOutputCacheHook
Output Cache with custom hooks allows grouping data before storing into cache.To implement IOutputCacheHook, create a class which extends IOutputCacheHook. The following tables list the properties and methods that must be implemented.
Methods
Description
Initialize
Initializes required elements of Output Cache hook.
OnCachingOutput
Takes as input the HttpContext instance for the current request,string key and object value generated by framework for output are passed as is as input parameter. Input parameter CacheOperation type can be added or set, with respect to Output Cache Provider operations of add and set. DateTime utcExpiry is passed as a reference parameter which allows end user code to reset expiration for particular key value pair. If the value for expiration is not set, the default value provided by framework is used.
This method returns CacheMetadata which can have additional information about group, sub group, tag, named tag and dependency settings.
This method functions as a hook between OutputCache Provider and user code, it is called when output is generated by framework but before insertion into Cache thus allowing intermediate hook for user, where additional information can be added with CacheMetadata.
Dispose
It releases resources which are no longer in use by Output Cache hook.
Sample OutputCacheHook
public class OutputCacheHookSample : IOutputCacheHook
{
public void Initialize()
{
// initialize required elements here, according to business logic.
}
public CacheMetadata OnCachingOutput(System.Web.HttpContext context, string key, object value, CacheOperation operation, ref DateTime utcExpiry)
{
CacheMetadata cacheMetaData = null;
if(context != null)
{
cacheMetaData = new CacheMetadata();
// put required business logic to categorize input parameter key in //desired group. Groups, sub groups, tags, named tags and dependencies //can be assigned to object of cacheMetaDatawhich then is returned to be //inserted into cache.
cacheMetaData.GroupName = "vendorState";
cacheMetaData.Dependency = new KeyDependency(key);
utcExpiry = DateTime.Now.AddMinutes(5);
}
return cacheMetaData;
}
public void Dispose()
{
}
}
Add Alachisoft.NCache.OutputCacheProvider.OutputCacheHook.dll in the project from %NCache installed dir% \integration\OutputCacheProvider
See Also
ASP.NET Output Cache Overview | ASP.NET Sessions | ASP.NET Sessions | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Client Side Third Party Integrations

< Previous page Next page >

Client Side Third Party Integrations

This section is a practical guide for programmers who want to utilize powerful Third Party Integrations with NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
NHibernate
Explains how you can plug-in NCache to your existing NHibernate application to use NCache with NHibernate.
Entity Framework Caching Integration
Shows how to plug Entity Framework caching provider with NCache.
Memcached
NCache has implemented Memcached integration and you can plug-in NCache to your existing or new Memcached applications without any code changes.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NHibernate

< Previous page Next page >

NHibernate

This section explains what is NHibernate and the ways to configure and use NCache as NHibernate Second Level Cache.
In This Section
Overview
Explains NHibernate and the features of NCache as NHibernate's second level cache provider .
Using NCache as NHibernate Second Level Cache
Explains how to configure and use NCache as NHibernate Second Level Cache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

NHibernate is an open source Object-Relational Mapping solution which provides a framework for mapping relational database on object oriented representation of data. This reduces significant developer's efforts for retrieving data from database. Furthermore to improve applications performance and reduce load on database, NHibernate provides feature of caching to reduce repetitive database calls.
NHibernate First Level Cache
NHibernate First level caching module provides session level in process caching. Whenever a session is created, a session cache is associated with it. When an object is loaded from the database, a copy of object is maintained in the session cache. If the object is to be fetched again in the same session, cached copy of object is returned. In a particular transaction, if the same object is updated multiple times, it is only updated in session cache. At committing transaction, only the final state of object is persisted in database, thus avoiding repetitive update calls.
NCache as NHibernate Second Level Cache
NCache provides NHibernate second level cache provider. NCache provider can be configured as NHibernate second level cache without any code change. Using NCache as second level cache for NHibernate enable application to use NCache's distributed caching features.
NCache provides the following features with second level cache provider:
  • Specify Multiple Regions: Multiple NHibernate regions can be specified and configured in NCache configuration file for NHibernate. These regions are identified using region names and can be configured with multiple NCache features.
  • NCache Cache for Region: NCache allows to specify NCache cache instance for each region separately. Each region can be configured on separate NCache cache instance or one instance can also be used for multiple regions.
  • Cache Item Priority: Data in each region can be configured to have a priority in cache. This priority is then used for data eviction policies.
  • Absolute Expiration: NCache's configurable absolute expiration feature keeps data in cache up to date by expiring old data after configured time interval.
  • Sliding Expiration: Cache region can also be configured to have an absolute expirations for items in cache. Using sliding expiration data not used since the configured interval will be removed automatically by NCache.
  • Configure Multiple Regions even on a Single NCache Cache Instance: NCache provider for NHibernate allows using single NCache instance for multiple NHibernate cache instances. NCache keeps the record of data and its associated NHibernate region.
  • Database Dependencies: To ensure data consistency with database, NCache provides database dependency feature for NHibernate applications that can be configured on entity bases. Database dependency synchronizes cache data with the database such that any change in database record invalidates respective entity in cache. Thus NHibernate retrieves up to date record even if database is updated by an application other than NHibernate application.
  • Query Caching Feature to Cache Large Queries' Results: Complex and large queries if executed repeatedly with no result changed can put a huge load on database. To avoid multiple times execution of such queries NCache allows to cache such queries using NHibernate's query cache feature. So that such query and its results executed for one NHibernate application become available to all NHibernate applications using that database without querying the database.
  • No Code Change Required: NCache allows using all features through configuration files with no code change required.
See Also
Using NCache as NHibernate Second Level Cache | Entity Framework Caching Integration | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using NCache as NHibernate Second Level Cache

< Previous page Next page >

Using NCache as NHibernate Second Level Cache

NHibernate has a first level or session level cache which is used by default. Each session contains its own session level cache which is not shared with other sessions. This cache is disposed whenever the session is closed. However NHibernate allows to use second level, across session cache which spans across sessions life time and can be shared by multiple sessions.
NCache provides a second level or process level cache for NHibernate by implementing NHibernate's ICacheProvider and ICache interfaces. This enables NCache to be used as NHibernate second cache in existing NHibernate application without any code change. All that’s needed is to change NHibernate configuration file to plug-in NCache as cache provider and distributed caching can be used.
Second level cache can be configured by enabling the use of second level cache and configuring second level cache provider in NHibernate configurations.
Configuring NHibernate Application to use NCache as Second Level Cache
  • In NHibernate configuration, configure NCache as NHibernate's second level cache provider by adding the following property.
<property name="cache.provider_class"> Alachisoft.NCache.Integrations.NHibernate.Cache.NCacheProvider, Alachisoft.NCache.Integrations.NHibernate.Cache</property>
cache.provider_class: This option lets the user specify NCache as 2nd level cache provider. The user needs to mention two classes which implement ICacheProvider and ICache interfaces respectively. This is how NHibernate knows how to call this second level cache.
  • Place NCache’s NHibernate provider dll Alachisoft.NCache.Integrations.NHibernate.Cache.dll located at %NCacheInstallDir%/integration/nhibernate/assembly/ in application's base directory.
  • Enable the use of second level cache in application by adding the following property in NHibernate configuration section's session-factory tag:
<property name="cache.use_second_level_cache">true</property>
  • NCache provider for NHibernate identifies each application by an application id that is later used to find the appropriate configuration for that application from NCache configuration file for NHibernate "NCacheNHibernate.xml". This application id must be specified in application's configuration file (app.config/web.config). Add following property in application configuration for this purpose:
<appSettings>
....
<add key="ncache.application_id" value="myapp" />
....
</appSettings>
Configuring Cacheable Objects
Enabling the use of second level cache does not cache each class object by default. Instead classes needed to be cached are to be marked cacheable in class mapping (.hbm.xml) file. To mark a class cacheable add the following tag in class's configuration:
<cache usage="read-write" region ="AbsoluteExpirationRegion"/>
In the above tag, properties usage and region can be changed.
Region specifies the name of second level cache region to be used for this class objects. If no region is specified, fully qualified class name will be used as region name with default region configurations.
Usage specifies caching concurrency strategy to be used for this class. NHibernate allows the following three concurrency strategies to be used for caching:
  • Read-Write
  • Nonstrict-Read-Write
  • Read-Only
Configuring Cache Regions
NHibernate uses cache regions to store objects. NCache allows cache regions to be configured with different properties. For this purpose NCache has a configuration file named "NCacheNHibernate.xml", which contains all regions’ configurations and other related configurations used by NCache. This file can be placed at root directory of application or in config folder of NCache Installation directory.
Following is a sample configuration file:
<configuration>
<application-config application-id="myapp" enable-cache-exception="true"
default-region-name="default" key-case-sensitivity="false">
<cache-regions>
<region name="AbsoluteExpirationRegion" cache-name="mycache" priority="Default" expiration-type="sliding" expiration-period="180" />
<region name="default" cache-name="mycache" priority="default" expiration-type="none" expiration-period="0" />
</cache-regions>
<database-dependencies>
<dependency entity-name="nhibernator.BLL.Customer" type="oledb" sql-statement="select ContactName from dbo.Customers where CustomerID =?" cache-key-format="depdency.customer:[pk]"/>
</database-dependencies>
</application-config>
</configuration>
Multiple application configurations can be specified in NCacheNHibernate.xml. Any NHibernate application will use one of the specified configuration based on the application-id specified in applications app.config/web.config file.
Following are the configurable options in application-config section.
Member
Description
application-id
This option let the user specify a unique id for current application-config. This id is used to select appropriate configuration for a particular application.
enable-cache-exception
Identifies whether the exceptions if occurred in NCache will be propagated to NHibernate provider.
default-region-name
Allows to specify a default region for the application. If a particular region's configurations are not found, default region configurations will be used. Specified default region configuration must exist in cache-regions section.
key-case-sensitivity
This option allows to specify whether cache keys will be case sensitive or not. This option has to be configured according to database used. If database is case-sensitive set this option true, otherwise false.
cache-regions
This sections lets the user configure multiple cache regions for NHibernate application. Each region's configuration is specified in region tag.
region
This tag contains the configurations for one particular region. Following options can be configured for any particular region.
name: Each region is identified by its name. Name of the region should be unique.
cache-name: This option allows specifying NCache's cache name to be used for this region.
priority: The priority the user wants to use for cached items. The possible values are :
· Default
· Low
· BelowNormal
· Normal
· AboveNormal
· High
· NotRemovable
expiration-type: This options allows to specify type of expiration for any item in this region. Possible values are absolute/sliding/none.
expiraion-period: Allows to specify expiration period if absolute/sliding expiration is configured. Its value should be greater than 0.
database-dependencies
It lets the user specify database dependencies for current NHibernate application.
dependency:
Each dependency is configured in a dependency tag. Multiple tags can be configured for multiple dependencies. The following options can be configured for each dependency.
entity-name: Dependencies are added based on the fully qualified name of classes. This option allows to specify name of class for which current dependency is to be added. Any entity can have maximum one dependency.
type: Allows to specify database dependency type. Possible values are sql/oracle/oledb. Since NCache provider uses connection string specified in NHibernate's configuration, use dependency type appropriate to connection string.
sql-statement: Allows to specify sql statement to be used for building NCache's database dependency.
cache-key-format: This option is used to configure cache key format for any item of current entity type. Cache key format should include "[pk]" in it, which will be replaced with the primary key of record. cache-key-format may also include "[en]" which will be replaced with entity name. Default value of cache key format is "NHibernateNCache:[en] #[pk]". Same cache key format should be used while writing database trigger incase of oledb database dependency. See NCache help for writing database trigger for oledb dependency.
composite-key-separator: If the records of current entity have composite key as primary key, cache-key is formed by combining all keys separated by composite-key-separator. composite-key-separator must be of one character length. Its default value is "$".
Using Query Caching
NHibernate also provides a feature of query caching. Enabling query caching caches queries made by NHibernate to database, along with query result sets. Query caching makes use of second level cache to store queries, so that whenever the same query is needed to be executed again, it can be fetched from cache.
Any object retrieved as a result of query are cached to their respective regions, therefore objects must be marked as cacheable for efficient use of query caching. However query along with the primary keys of result sets is stored in a default query region named NHibernate.Cache.StandardQueryCache.
Since not every query's results remain same for a period of time. Therefore query caching should only be used with queries whose results are likely to be changed less frequently.
How to Enable Query Caching
To enable query caching, add the following property in NHibernate configuration section's session-factory tag:
<property name="cache.use_query_cache">true</property>
Enabling query cache does not cache each query by default. Instead queries needed to be cached are to be set cacheable in code. To set a query cacheable, call SetCacheable(true) function of query while creating query, e.g.,
IQuery qry = session.CreateQuery("from Customer c").SetCacheable(true);
See Also
NHibernate Overview | Entity Framework Caching Integration | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Entity Framework Caching Integration

< Previous page Next page >

Entity Framework Caching Integration

NCache has implemented a custom ADO.NET provider called as "Entity Framework-Caching Provider" which acts between Entity Framework and the original provider. This section explains what is ADO.NET Entity Framework and the ways to configure and use NCache as Entity Framework Second Level Cache.
In This Section
Overview
Explains Entity Framework and the features of NCache as Entity Framework second level cache provider .
Using NCache as Entity Framework Second Level Cache
Explains how to configure and use NCache as Entity Framework second level cache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Overview

< Previous page Next page >

Overview

The ADO.NET Entity Framework is a popular object-relational mapping framework. It provide abstraction from the underlying relational data that is stored in a database and presents its conceptual schema to the application.
In most of the high transaction cases, the database quickly becomes a bottleneck. Because in database tier, adding more and more servers cannot scale performance.To achieve this scalability use in-memory cache provider module along with Entity Framework application. Although, Entity Framework does not provide a Second Level Cache provider model but it is flexible to support second Level Cache Provider.
Entity Framework Caching Provider
NCache has implemented a custom ADO.NET provider called as "Entity Framework-Caching Provider" which acts between Entity Framework and the original provider. NCache provides the features listed below:
  • No Code Change: NCache Entity Framework Caching Provider can be integrated in application without any code change.
  • Better Performance: NCache custom provider intercepts all the database queries calls and puts result-sets of queries in a cache storage. This increases the performance of applications by avoiding expensive databases trips.
  • Application Scalability : NCache provides a reliable and shared memory resource for storage. It gives the ability for sharing transactional context between different entities in any entity framework application.
The caching provider can perform various functions, such as:
  • Managing connections, commands, transactions and data read
  • Monitoring queries and commands before they execute.
The following figure shows how and where NCache Entity Framework Provider plugs into an Entity Framework application.
Entity Framework Caching Integration Modes
There are two execution modes for NCache Entity Framework Caching Provider:
  1. Analysis Mode
  2. Caching Mode
These modes are mutually exclusive, so NCache Entity Framework Caching Provider cannot execute in both modes at the same time. It can either be in "Caching" mode or in "Analysis" mode
Recommendation: First execute the entity framework application within analysis mode of NCache Entity Framework-Caching Provider.
1. Analysis Mode:
Analysis mode is a pass-through mode, no caching is done at this mode. This mode provides features that are listed as follows:
  • Monitoring Query: Monitoring the number of times each query is executed by Entity framework Application. This allows the user to determines which queries are most frequent and are the best candidates for caching.
  • Generate Reports: It generates reports for queries with proper syntax and also arranging them in descending order. That allows the user to choose suitable queries and copy them for caching.
2. Caching Mode:
This mode is basically designed for the actual use of NCache in Entity Framework applications. At this point, queries and their result sets are cached. Caching mode only entertains those queries which are given in configuration file i.e. efcaching.ncconf.
See Also
Using NCache as Entity Framework Second Level Cache | NHibernate | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using NCache as Entity Framework Second Level Cache

< Previous page Next page >

Using NCache as Entity Framework Second Level Cache

Integration without any Code Change
NCache custom Entity Framework ADO.NET provider can be integrated in the application without any code change. Simply modify configuration files and specify NCache Entity Framework Caching Provider as second Level Cache provider.
Prerequisites:
Following are the prerequisites to enable NCache in Entity Framework application:
1. The user should have an Entity Framework application. The sample application for Entity Framework Caching from NCache sample
applications can also be used from the following path
%InstalledDirectory%/samples/clr20/EntityDataModelIntegrationDemo
2. Microsoft Visual Studio 2010 for Entity Framework 3.5 and 4.0 and Microsoft Visual Studio 2012-2013 for
Entity Framework 6.0 and 6.1.
3. Database Tool (e.g. MS SQL SERVER, ORACLE)
Steps required to enable NCache as Second Level Cache Provider in Entity Framework application are follows:
Adding Appropriate Assemble Reference
Add the following assembly
Alachisoft.Integrations.EntityFramework.CachingProvider
into Entity Framework application. This .dll file is placed on the following path:
%Installeddirectory%/integration/MSEntityFramework.
After adding the reference, the following changes are required:
Modifying Application or Web Configurations
Application or web configuration file which is generated on adding ADO.NET Entity Data Model in Entity Framework application, requires following changes:
Entity Framework 3.5 or 4.0
· Provider invariant name is specified in the connection string of application or web configuration file:
<connectionStrings>
<add name="NorthwindEntities"
connectionString="metadata=res://*/NorthwindCustomerModel.csdl
|res://*/NorthwindCustomerModel.ssdl
|res://*/NorthwindCustomerModel.msl;
provider=System.Data.EntityClient;
provider connection string=&quot;
Data Source=localhost;Initial Catalog=Northwind;user id= userid;
password=password;MultipleActiveResultSets=True&quot;"
providerName="System.Data.EntityClient"/>
</connectionStrings>
Change provider name to NCache Entity framework Provider and also add the provider wrapper information in connection string as shown below:
<connectionStrings>
<add name="NorthwindEntities"
connectionString="metadata=res://*/NorthwindCustomerModel.csdl
|res://*/NorthwindCustomerModel.ssdl
|res://*/NorthwindCustomerModel.msl;
provider=Alachisoft.Integrations.EntityFramework.CachingProvider;
provider connection string=&quot;
wrappedProvider=System.Data.SqlClient;
Data Source=localhost;Initial Catalog=Northwind;user id= userid;
password=password;MultipleActiveResultSets=True&quot;"
providerName="System.Data.EntityClient"/>
</connectionStrings>
· Also add the provider factory for initialization of NCache Entity framework Provider. The invariant attribute should be the same as the provider name in connection string.
For Enterprise and Professional Editions:-
<DbProviderFactories>
<add name="EF Caching Data Provider"
invariant="Alachisoft.Integrations.EntityFramework.
CachingProvider"
description="Caching Provider Wrapper"
type="Alachisoft.NCache.Integrations.
EntityFramework.EFCachingProviderFactory,
Alachisoft.Integrations.EntityFramework.
CachingProvider,
Version=1.0.0.0,
Culture=neutral,
PublicKeyToken=cff5926ed6a53769"/>
</DbProviderFactories>
Entity Framework 6.0
· Provider invariant name is also specified in the application (or web) configuration file:
<entityFramework>
<providers>
<provider invariantName="System.Data.SqlClient"
type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
</providers>
</entityFramework>
Change invariant name to EFCachingProviderServices and type to Alachisoft.NCache.Integrations.EntityFramework.EFCachingProviderServices, Alachisoft.Integrations.EntityFramework.CachingProvider as shown below:
<entityFramework>
<providers>
<provider invariantName="EFCachingProviderServices"
type="Alachisoft.NCache.Integrations.EntityFramework.EFCachingProviderServices,
Alachisoft.Integrations.EntityFramework.CachingProvider" />
</providers>
</entityFramework>
Entity Framework 6.1
· Add an interceptor in provider section in the application (or web) configuration file:
<entityFramework>
<providers>
<provider invariantName="System.Data.SqlClient"
type="System.Data.Entity.SqlServer.SqlProviderServices,
EntityFramework.SqlServer" />
</providers>
<interceptors>
<interceptor type="Alachisoft.NCache.Integrations.EntityFramework.Caching.EFCommandInterceptor,
Alachisoft.Integrations.EntityFramework.CachingProvider" />
</interceptors>
</entityFramework>
Configuration independent of Entity Framework version
· The following information should be added in appSettings of app.config or web.config
<appSettings>
<add key="app-id" value="EFCachingDemo"/>
<add key="logging-level" value="Debug"/>
</appSettings>
app-id: This will be the identifier for current application. This ID will be used to read configuration from efcaching.ncconf.NCache.EF Caching provider reads the required information from efcaching.ncconf on the basis of ID given in app/web .config file.
logging-level: Determines the logging level for application. The provider will log exceptions and errors only when level is set to Error. When the level is set to Debug, both exceptions/errors and other detailed information will be logged. Nothing will be logged if the level is set to Off (default). Path at which log files will be generated is
%Installeddirectory%/log-files/efcaching-logs/
App-id of efcaching.ncconf should be the same as in application (app.config) in order to avoid an error. Application should be restarted after above changes are made.
Alternative method through Programming
Entity Framework 3.5 or 4.0
Apart from specifying connection string in app.config/web.config, the connection can also be specified while creating ObjectContext or EntityConnection. While creating a connection string programmatically, the wrapper information must be included in a connection string. Here is how the connection string can be created and ObjectContext or EntityConnection can be initialized.
try
{
SqlConnectionStringBuilder sqlConnBuilder = new SqlConnectionStringBuilder();
sqlConnBuilder.DataSource = "localhost";
sqlConnBuilder.InitialCatalog = "EFTestDB";
sqlConnBuilder.IntegratedSecurity = true;
string conString = sqlConnBuilder.ToString();
EntityConnectionStringBuilder efConnBuilder = new EntityConnectionStringBuilder();
efConnBuilder.Provider = "EFCachingProvider";
efConnBuilder.ProviderConnectionString = @"wrappedProvider=System.Data.SqlClient;" + conString;
efConnBuilder.Metadata = "res:// /NorthwindCustomerModel.csdl|res:" + "// /NorthwindCustomerModel.ssdl|res:" +"// /NorthwindCustomerModel.msl;";
EntityConnection connection = new EntityConnection(efConnBuilder.ToString());
}
catch (Exception ex)
{
// handle exception
}
Entity Framework 6.0
Apart from specifying provider invariant in app.config/web.config, the provider invariant can be specified while initializing the
configuration (class inheriting DbConfiguration). Here is how the provider invariant can be specified.
try
{
this.SetProviderServices("EFCachingProviderServices", EFCachingProviderServices.Instance);
}
catch (Exception ex)
{
// handle exception
}
Entity Framework 6.1
Apart from specifying database interceptor in app.config/web.config, the database interceptor can be specified while initializing the
configuration (class inheriting DbConfiguration). Here is how the interceptor can be specified.
try
{
this.AddInterceptor(new EFCommandInterceptor());
}
catch (Exception ex)
{
// handle exception
}
Through API (6.0 and 6.1)
User can now also cache results using extension provided for IQueryable.
· Specify the namespace
using Alachisoft.NCache.Integrations.EntityFramework.Caching;
· Call cache method overloads now from IQueryable insance
var students = from s in db.Students
select s;
students.Cache(); // results are not cached yet
foreach (Student student in students) //results are cached when enumerator from query is iterated completely
{
//using student
}
The application will need to be rebuilt the application for effectively applying the above changes.
Entity Framework-Caching Configuration File
EFcaching.ncconf configuration contains cache and caching policy related information used by NCache Entity Framework caching provider. Some changes are required in "efcaching.ncconf" to run the Entity Framework Application with NCache.This config file is placed on the following path:
%Installeddirectory%/config
Below are the changes required in efcaching.ncconf.
<configuration>
<app-config app-id="EFCachingDemo" mode="analysis|caching">
<analysis-policy log-path="" analysis-time="1min" cache-enable-threshold="1" default-expiration-type="Sliding" default-expiration-time="180sec" dbsyncdependency="false"/>
<cache-policy-configurationdatabase="none|sqlserver|oracle" cache-id="mycache">
<api-level-caching expiration-type="sliding|absolute" enable="True|False" expiration-time="120sec" dbsyncdependency="True|False">
<!--sql-query = "SELECT [Extent1].[CustomerID] AS
[CustomerID],= @param_0"-->
<query>
<cache-query query text="SELECT [Extent1].
[OrderID] AS [OrderID], &lt; @param_0"/>
<cache-policy vary-by-cache-param="param_0" expiration-type="Sliding" enabled="True"
expiration-time="180sec" dbsyncdependency="False"/>
</query>
</cache-policy-configuration>
</app-config>
</configuration>
Member
Description
app-id
This ID is same as defined in app/web configuration file of application.
mode
NCache Entity Framework Caching provider works under two modes. It can either be in "Caching" or in "Analysis" mode.
Analysis Mode
Analysis Mode is used for monitoring the number of times each query executes and then it generates a report. Report contains the query text and the call count for each query. No caching is done at this mode.
· log-path: The default Path at which analysis log files will be generated is %Installeddirectory%/log-files/EFCachingAnalysisLogs/
· analysis-time: Time for which the analysis will run. Default = 1 min
· cache-enable-threshold: Caching will automatically be enabled for queries whose call-count exceeds this threshold. By default, its value is 1.
· default-expiration-type: Default expiration type for analyzed queries. The default type is sliding.
· default-expiration-time: Default expiration time for analyzed queries. Default is 180 sec (3 min)
· dbsyncdependency: Determines whether to enable database-dependency or not. Default value is false.
Caching Mode
Wrapping provider will cache the results of all the specified queries. Whenever update is detected (either UPDATE, INSERT or DELETE) in a respective database, the provider invalidates the affected cache entries by evicting all cached queries which were dependent on any of the updated tables.
· database : Database server where user’s database reside.
· cache-id : Specified Cache Name where query results are stored for fast access.
query
Query attribute including user-configurable list of queries that should be cached with their results. A particular query can be configured with its cache policy defined in cache policy tag. Cache query and Cache policy are separated by dedicated tags. User can easily change policies from cache-policy tag without facing any XML parsing error.
cache-query
For cache query, this tag is auto generated by Entity Framework Caching Provider when the application is running in analysis mode. For ease of understanding, commented SQL-query tag is added so that the user can read the query.
· cache-query-text : This is used for XML parser and the user is not allowed to make any sort of changes in it.
Cache-policy
When mode is selected as Caching, only those query results will be cached for which caching is enabled. The user can also specify caching policies for all queries.
· vary-by-cache-param: User can specify which parameter should be included as part of cache key. NCache Entity Framework Cacheing Provider will replace the actual parameter in.config file with its own names which should follow the following parameter format:
@param_[parameter-no/index]
For example,
@param_0, @param_1,@param_2;
A sample query with parameters:
"select * from dbo.customers where customer_id = @param_0 and dob > @param_1;"
· enable : Determines whether caching is enabled for this query or not. Default value is true.
· expiration-type: Type of expiration, it can be 'absolute' or 'sliding'. Default is sliding.
· expiration-time: Expiration time for this query. Default is 180 sec (3 min).
· dbsyncdependency: Determines whether to enable database-dependency for this query or not. Default is false.
Api-level-caching
While using the api for caching, the user can also specify caching policies for all queries he is caching using api.
· enable : Determines whether caching is enabled for api-level-caching or not. Default value is true.
· expiration-type: Type of expiration, it can be 'absolute' or 'sliding'. Default is sliding.
· expiration-time: Expiration time for this query. Default is 180 sec (3 min).
· dbsyncdependency: Determines whether to enable database-dependency for this query or not. Default is false.
SQL Dependency will be registered only for those SQL queries that satisfy all the conditions for SQL Notification Registration as described in the Microsoft provided document .
InProc client cache stores items in object form, therefore if object is modified by the application, it should be updated back to the cache so that other remote clustered cache and other client caches have no data integrity issue.
See Also
Entity Framework Caching Integration Overview | NHibernate | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Memcached

< Previous page Next page >

Memcached

Memcached is a simple in-memory key-value store providing basic features for caching. Memcached server communicates with memcached clients using defined text or binary protocol. Memcache servers are stand-alone servers with no clustering or distributed caching features to provide scalability.
NCache has implemented Memcached integration and the users can plug-in NCache to their existing or new Memcached applications without any code changes. The users only need to change their application config files to take advantage of NCache distributed caching system.
NCache provides support for Memcached in two different ways.
  • Memcached Gateway Approach
  • Memcached Client Plug-In for .NET
In This Section
NCache Memcached Gateway Approach
Explains how to use NCache provided Memcached gateway server to use NCache without nay code change.
Memcached Client Plug-In for .NET
Explains how to use Memcached Client Plug-In for .NET provided by NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Memcached Gateway Approach

< Previous page Next page >

NCache Memcached Gateway Approach

NCache provides Memcached gateway server to use NCache without any application code changes or recompilation.
NCache Memcached gateway is implemented based on Memcached socket protocol and acts as Memcached server for Memcached applications. It understands all Memcached clients request and send responses accordingly.
However, it only serves as a proxy and in fact connects to the NCache cluster. Gateway intercepts Memcached commands and then in turn executes NCache APIs equivalent to these commands on NCache distributed cache. This gives the user NCache support for any type of Memcached client regardless of which programming language it is developed in.
There are two deployments of NCache Memcached gateway.
Memcached Client Side Gateway
NCache gateway server is installed on the application servers. Applications talk to local gateway severs and then gateway servers act as NCache client and execute the requested commands on NCache.
The following diagram illustrates this deployment.
Gateway server is an intelligent NCache client that keeps record of all NCache servers in the cluster. Thus if any of the node in NCache cluster gets down, gateway starts communicating with other available NCache servers. This avoids a single point of failure for application. While using gateway, it is recommended to use NCache remote client configuration for using NCache in memcached applications.
Memcached Server Side Gateway
NCache gateway server is installed on the NCache servers. Applications talk to gateway severs running on cache servers and then gateway server talks to cache and sends response back to client.
The following diagram illustrates this deployment.
In the above diagram, it can be seen that the Memcached gateway server (also called Memcached Client Wrapper) runs on NCache cache servers. The Memcached client application talks to this gateway as if it is a Memcached server. And, this in turn talks to the NCache cluster using NCache API calls.
In this configuration when gateway server is running on one of the server nodes in the cluster, memcahed application communicates with only that server node. This produces a single point of failure risk for memcached client application. However in this configuration memcahed socket protocol messages that are more compact and less in size than NCache protocol messages will be communicated over network Memcached Client Plug-In for .NET.
See Also
Memcached Client Plug-in for .NET | NHibernate | Entity Framework Caching Integration | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Memcached Client Plug-in for .NET

< Previous page Next page >

Memcached Client Plug-in for .NET

NCache provides its Memcached Client Plug-in for popular .NET Memcached clients Eniym, BeIT Memcached and .NET memcached client library so that NCache can be directly used for Memcached applications using these clients. NCache API calls equivalent to Memcached calls are internally implemented in these plug-ins and there is no code change or recompilation required on application side. These modified Memcached client libraries are provided along with their source code in NCache installation.
It is generally recommended to use plug-In approach instead of gateway because gateway induces an extra network/process hop whereas this Plug-In becomes part of the client application process and directly talks to the NCache cluster using NCache API so it should result in a better performance.
This diagram illustrates the NCache deployment with plug-in approach.
See Also
NCache Memcached Gateway Approach | NHibernate | Entity Framework Caching Integration | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Troubleshooting

< Previous page Next page >

Troubleshooting

This section is intended as a quick reference for error codes, messages, and symptoms generated by NCache, and provides a summary of the likely problem. Refer to the following section to find details about symptoms and workarounds.
In This Section
Implementing Clusters
Provides help to troubleshoot the problems related to cluster implementation.
Using NCache Client API
Provides help to troubleshoot the problems related to NCache Client API.
Using Security
Provides help to troubleshoot the problems that may arise when using NCache security.
Viewing Statistics
Provides help to view remote server statistics.
Installing NCache
Gives workarounds of the problems that may arise during NCache installation process.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Add Reference issue of Visual Studio 2010

< Previous page Next page >

Add Reference issue of Visual Studio 2010

If your development environment is Visual Studio 2010, you may not be able to see NCache .NET assemblies in the Add Reference dialog box under .NET tab. However, you can add reference to the NCache assemblies by using the Browse tab. You can find all these assembly files in NCache Installed folder/bin/assembly/.
See Also
Installing NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Upgrade NCache without disturbing deployed environment

< Previous page Next page >

Upgrade NCache without disturbing deployed environment

When a newer version of NCache is installed, your code doesn't need to recompile with the most recent version. Now, with each installation of NCache, a publisher policy file is installed. This file redirects all the previous versions of the specified assembly to the newer version. Policy assembly files for various NCache assemblies are as follows:
NCache Assembly | Publisher Policy Assembly
Alachisoft.NCache.Web.dll | policy.<version>.Alachisoft.NCache.Web.dll
Alachisoft.NCache.Runtime.dll | policy.<version>.Alachisoft.NCache.Runtime.dll
Alachisoft.NCache.Cache.dll | policy.<version>.Alachisoft.NCache.Cache.dll
Here <version> is the newer version of NCache. For example, for NCache 4.4.0.0, publisher policy file for Alachisoft.NCache.Web.dll will be Policy.4.4.0.0.Alachisoft.NCache.Web.dll. These policy assembly files are added to the GAC with all other assemblies and are removed at uninstall.
You can also bypass the publisher policy file by specifying 'publisherpolicy' tag in the "App.config" file.
For Enterprise and Professional Editions:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
For Open Source Edition:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
Publisher Policy Assemblies are not shipped along with NCache installation package but can be made available on demand.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Troubleshooting Scripts

< Previous page Next page >

Troubleshooting Scripts

The InstallNCache and UnInstallNCache scripts internally uses methods of Win32_Product class. If you got any error related to this class during script execution, it means that Win32_Product class is not installed on that machine.
On Windows 2003 the Win32_Product class some times isn't installed by default. You can install it with Add/Remove Windows Component.
Steps for Installing Win32_Product class :
Step 1:
Go to Add/Remove Windows Components.
Step 2:
Look for the "Management and Monitoring Tools". If it is uncheck, make it checked. Click on Details Button.
Step 3:
Look for the "WMI Windows Installer Provider". Make it checked. Click OK.
See Also
Configuring PowerShell Environment | Remote Installation/Uninstallation | Activate NCache
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Viewing Statistics of a Remote Server Node

< Previous page Next page >

Viewing Statistics of a Remote Server Node

This section will help you in resolving problems that can occur while monitoring remote server nodes (Windows computers).
In this Section
Computer Name Not Found
Describes the reason of this error and provides solutions to resolve it.
Diskperf Not Installed
Describes the cause and provides steps to run Diskperf to avoid this error on monitored server node.
No READ Access to the Perflib Subkeys
Explains how to grant account READ permission to the Perflib sub key to avoid error while monitoring performance of a remote sever node.
Unable to Connect to Remote Server (Windows XP Machine)
Discusses the causes of this error and offers solutions.
See Also
Implementing Clusters
Provides help to troubleshoot the problems related to cluster implementation.
Using NCacheAPI
Provides help to troubleshoot the problems related to NCache API.
Using Security
This section provides solutions for some common troubles in using NCache security.
Installing NCache
Provides quick reference for error codes, messages, and symptoms generated by NCache during installation
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Troubleshooting Counters

< Previous page Next page >

Troubleshooting Counters

You can receive an error message 'Computer Name Not Found' when trying to monitor a remote server node from a non-administrator account.
Workaround
To enable remote monitoring on server node (Windows NT computer), do the following:
  • Grant at least READ access to the following files:%windir%/system32/PERFCxxx.DAT
  • %windir%/system32/PERFHxxx.DAT
    where xxx is the basic language ID for the system; for example, 009 for English.
  • Grant READ access to the following registry keys on the remote computer: Using REGEDT32, grant the user account at least READ access to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/CurrentVersion/Perflib and all sub keys of that key.
  • Using REGEDT32, give the user at least READ access to HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/SecurePipeServers/winreg.
    Please keep in mind that using Registry Editor incorrectly can cause serious system-wide problems that can make you to reinstall Windows operating system. Use this tool at your own risk.
See Also
Diskperf Not Installed | No READ Access to Perflib Subkeys | Unable to Connect to Server Node
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Diskperf Not Installed

< Previous page Next page >

Diskperf Not Installed

The Windows parameter sets cannot collect information about the monitored computer unless the Disk Performance Statistics Driver (Diskperf) has already been run on the monitored computer.
By default, Diskperf installs the Disk Performance Statistics Driver above the fault tolerant driver, Ftdisk.sys, in the I/O Manager disk driver stack. To determine if Ftdisk is started in your configuration, use the Devices Control Panel.
Workaround
Use the following steps to run Diskperf on the monitored Windows computer. You must be a member of the Administrator's local group on a computer to run Diskperf on that computer.
  • Open a Command Prompt window.
  • At the command prompt, type one of the following commands, and press 'Enter'.
  • diskperf -y: enables the counters on a standard disk configuration
  • diskperf: indicates whether disk counters are enabled or disabled
  • diskperf -yv: enables disk counters on mirror and stripe sets and other noncontiguous partition sets and installs the performance statistics driver below the fault tolerant driver in the I/O stack
  • diskperf -n: disables disk counters
  • To run diskperf on a remote computer, type the command name, followed by the computer name. For example: diskperf //computername
  • To monitor the physical disks in disk configurations that include Ftdisk, run the diskperf -yv command.
  • Restart the computer.
See Also
Troubleshooting Counters | No READ Access to Perflib Subkeys | Unable to Connect to Server Node
Send comments on this topic
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: No READ Access to Perflib Subkeys

< Previous page Next page >

No READ Access to Perflib Subkeys

After the Performance Monitor (PerfMon) account connects to the Registry of the monitored computer, the account on the monitored computer needs READ access to the subkeys that PerfMon uses. The computer uses the ACL for the Perflib/LanguageID subkey to determine who has access to PerfMon data in the Registry, where LanguageID is the numeric code for the spoken language installed with Windows NT. The Perflib/LanguageID subkey is located in the following Registry path:
HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT /CurrentVersion/Perflib
By default, EVERYONE, LOCAL SERVICE group has READ access to the Perflib key. You need to give full control to these accounts on Perflib key.
Workaround
Here is how you can enable permissions on CurrentVersion/Perflib key:
  • On the computer to be monitored, start regedit.
  • Right-click Perflib and go to permissions.
  • Give full control to Local Service and Everyone users. You may have to add these users if they are not already in the list.
  • Go to Control Panel -> Services and restart 'Remote Registry' service.
Now you'll be able to monitor this machine remotely.
See Also
Diskperf Not Installed | Troubleshooting Counters | Unable to Connect to Server Node
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)

< Previous page Next page >

Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)

This error can occur when remote monitoring is not enabled on the server nodes that are running the Windows XP operating system.
Workaround
Use the following steps to enable remote monitoring:
  • Open Windows Explorer on the target Windows XP computer.
  • Choose 'Tools' -> 'Folder Options'.
  • Click the 'View' tab.
  • Clear the 'Use Simple File Sharing' check box, and click 'OK'.
  • Verify privileges on the target Windows XP computer as described in Microsoft Knowledge Base article# Q300702 .
  • If the systemroot is on an NTFS partition, you must have at least READ access to the following two files:
  • %SystemRoot%/System32/Perfc009.dat
  • %SystemRoot%/System32/Perfh009.dat
  • You must have at least READ access to the following registry keys on the remote computer:HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/SecurePipeServers/winreg
  • HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Perflib
  • Reboot Windows XP computer.
A user that has administrator rights for the remote computer can also view remote counters.
In windows 7 if you are still unable to view counters of a remote server then enable "File, Folder and network sharing" options.
Follow steps given below
  • Go to Control panel, select "Network and Sharing center"
  • Click "Change Advanced Sharing Settings"
  • Under the Network discovery option select "Turn on network discovery"
  • Under the File and printer sharing option select "Turn on file and printer sharing"
  • Under the Public folder sharing option select "Turn on sharing so anyone with network access can read and write files in Public folders"
  • Then click Save changes, as shown in figure below.
See Also
Diskperf Not Installed | No READ Access to Perflib Subkeys | Troubleshooting Counters
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache API

< Previous page Next page >

NCache API

While using NCache API, you might experience some problems. This section provides solutions for some common troubles.
In This Section
No Server is available to process the request
Different situations are explained when this exception is thrown by NCache Client API (both Java and .NET).
java.lang.NoClassDefFoundError: com/alachisoft/ncache/licensing/LicenseManager
Describes when this error occurs and how to solve it. This solution is only for Java version of NCache Client API.
com.alachisoft.ncache.exceptions.GeneralFailureException: License not verified
Explains the reason of occurrence of this exception and also tells ways to solve this problem. This solution is only for Java version of NCache Client API.
See Also
Implementing Clusters
Provides help to troubleshoot the problems related to cluster implementation.
Using NCache API
Provides help to troubleshoot the problems related to NCache API.
Using Security
Provides help to troubleshoot the problems that may arise when using NCache security.
Viewing Statistics
Provides help to view remote server statistics.
Installing NCache
Provides quick reference for error codes, messages, and symptoms generated by NCache during installation.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: GeneralFailureException

< Previous page Next page >

GeneralFailureException

You may get this exception when any general type error occur in NCache. For example when the required jar files are not available at their appropriate location or if you cannot connect to the target cache etc.
Workaround
  • Run 'install.bat' file at least once before start using NCache Client API. This file is located at %INSTALL_DIR%/NCache/java/lib/.
  • 'installer.jar', 'NCActivate', 'NCRuntime.jar', 'NCSerialization.jar', 'NCClient.jar' and 'javaReg.properties' should also be present at the above mentioned location.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: java.lang.NoClassDefFoundError

< Previous page Next page >

java.lang.NoClassDefFoundError

The "java.lang.NoClassDefFoundError : com/alachisoft/ncache/licensing/LicenseManager" occurs when the required jar files are not available at their appropriate location. NCache Client API for Java is shipped with the following jar files:
  • NCClient.jar: The Main NCache Client API file.
  • NCActivate.jar: The file is responsible for the Activation of NCache. The user may extend his/her evaluation period by running this file. This file can be run by executing the "activate.bat" file.
  • installer.jar: This file is only for Unix environment and is responsible for NCache client installation on Unix machines.
  • NCRuntime.jar: The file is responsible for Read-through/Write-through caching and Cache Startup operations.
  • NCSerialization.jar: This file is responsible for dynamic compact serialization and object sharing operations.
  • NCacheSessionProvider.jar: This file is responsible for providing JSP session caching support.
  • NCUtil.jar: This file contains the methods required by NCache Manager and Service.
  • swing-layout-1.0.4.jar: This file is providing Java library for GUI.
  • javassist.jar: This file is the 3rd party library responsible for runtime code generation.
Workaround
Copy all three jar files at the same location and mention location in class-path.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: No server available to process request

< Previous page Next page >

No server available to process request

You may get this exception if the cache you are trying to connect is not running or the cache does not exist on the target machine.
Workaround
To workaround this problem, do the following:
  • See if the Servers specified in the client.ncconf are stopped. If so, then start them using NCache Manager. See Start a Server Node for further details .
  • Another situation can be that NCache Server is running but the cache that you are trying to use is not running. See Start a Cluster for more information.
  • Verify that you are using correct version of NCache Client API. Note that the Developer Edition does not allow you to connect to the remote NCache Server; however you can connect to NCache Server running on the same machine, using "localhost" as the server name in the client configuration file. Enterprise Edition does not have any such restriction. You can check NCache Edition from Help->About menu option in NCache Manager.
  • NCache Client API also throws this exception if it does not find the client.ncconf file or if there is any error reading NCache Server information from it.
  • And same error occurs if user tries to initialize a cache which does not exist or that cache is not listed in the "client.ncconf".
See Also
Start the Cluster | Start NCache Service | Configuring Clients
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: SessionStoreProvider not found

< Previous page Next page >

SessionStoreProvider not found

You may get following error message when using Session Store Provider.
Error: Could not load type 'Alachisoft.NCache.Web.SessionState.NSessionStoreProvider'.
Workaround
Please make sure the following also exists in your web.config:
For Enterprise and Professional Editions:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
For Open Source Edition:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
Replace version “x.x.x.x” with the actual NCache version that you have.
See Also
Using Session State Store Provider
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: IndexNotDefinedException

< Previous page Next page >

IndexNotDefinedException

In case no nametag has been added to a cache and the cache is searched with SearchCQ for nametag values, you get "IndexNotDefinedException". If you want that no such exception should be thrown even if you have not added any nametag to your cache, NCache now provides a way to disable this exception.
Workaround
You can suppress this exception by following these steps:
  • Go to Alachisoft.NCache.Service.exe.config located at
    %INSTALLATION_PATH%/NCache/bin/service/Alachisoft.NCache.Service.exe.config
  • Add the following line in the configuration file:
<add key = "NCacheServer.DisableIndexNotDefinedException" value = "true" />
The value "true" indicates that no IndexNotDefinedException will be thrown, whereas, the value "false" means that the exception will be thrown.
  • Restart the NCache service for these changes to take effect.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Implementing Clusters

< Previous page Next page >

Implementing Clusters

When Implementing Clusters, you may experience some problems. This section provides solutions for some of such troubles.
In This Section
Multiple Network Cards
Tells how to resolve the issue when NCache service may not be able to communicate with other nodes in the cluster if you have multiple network cards installed.
Compact Serialization Exception
Explains various causes of serialization exception.
Blocked Node Communication due to Firewall
Explains ports used by default clusters and NCache service.
Out of Memory Problem
Describes why your system throws out of memory exception and gives workaround.
Unable to Apply Configurations or Start Cache due to Disabled Network Card
Explains problems that arise due to disabled network card and provides solutions.
NCache Manager shows that Both the Nodes in Mirror Cache are Active Nodes
Provides the solution for the problem when both the nodes in a mirror cache appear as active nodes in NCache Manager.
Nodes in a Clustered Cache are not Joining with Each Other.
Provides the solution for the problem nodes in a clustered cache are not joining with each other. Cluster is not formed and cache runs on every node as standalone cache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Compact Serialization Exception

< Previous page Next page >

Compact Serialization Exception

Sometimes a Serialization exception may occur on node where Compact Serializable types are not registered.
Workaround
Register Compact Serializable types on all the nodes in the cluster. See Using Compact Types for further information.
See Also
Using Compact Serialization | Multiple Network Cards | Blocked node communication due to firewall | Out of memory problem | Unable to apply configurations or start cache due to disabled network card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Disabled Netwrok Card

< Previous page Next page >

Unable to Apply Configurations or Start Cache due to Disabled Network Card

You may not be able to apply cache configurations or start the cache. Or, clients may be unable to connect with server even on local machine. These problems arise when network card is disabled or cable is not connected.
Workaround
To resolve this problem, restart NCache service once after the network card is disabled or network cable is disconnected. Restarting NCache service will rebind it to local host rather than IP address of that machine.
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Out of Memory Problem

< Previous page Next page >

Out of Memory Problem

Sometimes your system throws out of memory exception while using NCache. This usually happens when Maximum Size for the cache is not specified correctly. Often, processing overhead is not kept into consideration while specifying the Maximum Size.
Workaround
In order to resolve out of memory issue, NCache has provided a memory based cache, where you can specify an upper limit on the size of the cache in MB. Please specify correct Maximum Size for your cache.
You should specify a Maximum Size which, if completely consumed, still leaves enough space in the system so that it never goes under low resources. While specifying the cache size, consider the following factors:
  • Average size of Sessions or Objects.
  • Number of expected Sessions or Objects.
  • Available memory for the NCache process.
Then you can calculate the required memory by keeping the following in mind.
  • 15% Overhead per session.
  • 15-20% overhead for processing. If object size is greater than 80KB, this ratio may be little bit high.
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Unable to apply configurations or start cache due to disabled network card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other
Send comments on this topic .
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Maximum Size

< Previous page Next page >

Maximum Size

Through this configuration option, you can specify an upper limit on size of the cache in MB. The number of items in cache are limited by maximum size of the cache and amount of free system memory (virtual or physical). If some eviction policy is specified, whenever total data size in cache reaches maximum size or when lesser than 10% of memory is left in the system, items are removed from the cache as per eviction policy. Maximum size of a cache can be specified by one of following two ways.
NCache Manager:
You can specify cache max size for a Cache on Main Tab of its view window.
Config.ncconf:
You can specify the cache max size through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<storage type="heap" cache-size="250mb"/>
</cache-config>
See Also
Configure Local Cache | Configure Cluster
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Multiple Network Cards

< Previous page Next page >

Multiple Network Cards

If you have dedicated network cards configured for public and private communication, then you might not be able to create new clusters or possibly existing NCache cluster could not communicate with others. Please note, the following problems will occur if nodes are unable to communicate with each other on specific interface(s).
  • NCache Service starts at one interface whereas other nodes try to communicate with it on the other interface. Therefore the two nodes are always unable to communicate with each other even when apparently both nodes are fully functional.
  • NCache Clients connect to NCache Server to get OutProc cache instances. So, it is possible that NCache Server starts at one interface whereas the client tries to connect to it on the other interface. This way, though NCache Server is ready to accept the client requests, client applications will always be unable to connect to the OutProc caches.
  • Situations can arise where cluster nodes are unable to join with each other and no cluster is forming. The reason could be that one node is listening join requests from other nodes on one network interface whereas other nodes send join requests on other network interface.
Workaround
To avoid such problems, you can bind NCache service to specific IP that is publicly available to other nodes in the cluster. Here is how you can bind IP to NCache service:
<add key = "NCacheServer.BindToClientServerIP" value = "" />
BindToClusterIP: You can inform NCache which interface to use for cluster-wide communication. In order to do so, provide the IP Address you want the cluster server to bind with.
BindToClientServerIP: You can inform NCache which interface to use for client communication. In order to do so, please provide the IP Address you want the client's (NCache client) server to bind with.
If you want to initialize your clustered cache as InProc, you need to provide same information in your application's config file. Otherwise, this node may not join with other cluster nodes.
See Also
Configuring NCache Service | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Unable to apply configurations or start cache due to disabled network card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Nodes not Joining

< Previous page Next page >

Nodes in a clustered cache are not joining

Some times it may be the case when you start a clustered cache, but nodes do not join with each other. It means that cluster is not formed and cache runs on each node as a standalone cache. You can use listcaches utility to confirm if the cluster is formed properly or not. When listcaches utility is used with '/a' switch, it lists all the nodes that have successfully joined the cluster. You can also use the NCache Manager "View Cluster Connectivity" GUI tool to check the node connectivity. "View Cluster Connectivity" option is available in a cluster properties and also located at NCache Manager tool bar.
Workaround
To resolve this problem:
  • See that every node can be accessed from every other node participating in the clustered cache. For this you can use the 'ping' utility. If nodes are not accessible then there is some network problem and must be resolved before starting the cache.
  • Please see that the cache configuration on each node contains the correct initial hosts list. Every node participating in the clustered cache must be listed there.
  • If the initial hosts list is not correct then update the initial hosts list and restart NCache service on all nodes.
  • Restart the clustered cache.
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Both nodes in a mirror cache appear as active nodes in NCache Manager
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Blocked Node Communication due to Firewall

< Previous page Next page >

Blocked Node Communication due to Firewall

Sometimes a cluster can not be formed, or cluster nodes are unable to communicate with each other. It may happen when Server and Cluster ports are blocked by firewall. Following error messages can occur in this case.
Error: "No server available to process request"
or
Error: "Unable to communicate with server node"
Workaround
  • If cluster is not formed, make it sure that Server port, at which NCache Service starts and accepts different client connections, is not blocked by firewall. Default value of this port is '9800'. You can change the default value from Alachisoft.NCache.Service.exe.config file.
  • If nodes in a cluster are unable to communicate, please see if your firewall is allowing the Cluster port. Cluster port is a port at which nodes in a cluster communicate. You can change the default value of these ports from NCache Manager. If you have specified a port range in NCache Manager, unblock all ports in range.
  • If NCache Manager is unable to connect with NCache Service, even when it is started, then your system firewall might be blocking Service port. Unblock Service port from system firewall.
See Also
Configuring Ports | Multiple Network Cards | Compact serialization exception | Out of memory problem | Unable to apply configurations or start cache due to disabled netwrok card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other
Send comments on this topic .
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Two Active Nodes Situation

< Previous page Next page >

Both Nodes in a Mirror Cache appear as Active in NCache Manager

On starting a mirror cache, situation may arise where both nodes are shown as active in NCache Manager. This means that nodes could not join with each other. It is not a mirror cache cluster instead two different mirror caches are running on each node.
Workaround
To resolve this problem see how to resolve the nodes not joining issue .
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Nodes in a clustered cache are not joining with each other
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Installing NCache

< Previous page Next page >

Installing NCache

This section is intended as a quick reference for error codes, messages, and symptoms generated by NCache during installation, and provides a summary of the likely problem. Refer to the following section to find details about symptoms and workarounds.
In This Section
NCache Installation Error 1606: Could not Access Network Location
Helps to troubleshoot the problem of NCache installation on Windows Vista.
Installation Error 1721: A Required Program could not be Run
Provides help to troubleshoot the error 1721 occurred during install or uninstall process.
Upgrade NCache
Gives help on upgrading NCache without disturbing deployed environment.
Installation Roll Back Problem on Windows Vista
Gives work around for installation roll back problem on Windows Vista.
NCache Activation Problem
Explains why NActivate tool fails to launch and gives workaround.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Activation Error

< Previous page Next page >

NCache Activation Error

In some situations, while trying to launch NActivate tool, following error message is shown:
Error: "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."
This error message occurs usually when VC++ libraries are not installed. NActivate tool uses assemblies developed in VC++. Windows 2003 installation does not install Visual C++ Libraries required to run applications developed with Visual C++ on a computer that does not have Visual C++ 2005 SP1 installed.
Workaround
Install redistributable package from Microsoft. It will install all the required libraries. You can download redistributable package from the following link:
http://www.microsoft.com/en-us/download/details.aspx?id=26347
See Also
NCache Installation Error 1606 | Installation Error 1721: A required progaram could not be run | Upgrading NCache | Installation rolls back on Windows Vista
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Error 1721: A Required Program could not be Run

< Previous page Next page >

Installation Error 1721: A Required Program could not be Run

On Windows Vista and Windows Server 2010, you may get the following error during install or uninstall process:
Error 1721: 'There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.'
This usually happens if UAC (User Account Control) is enabled on the target machine.
Workaround
To workaround this problem, please follow these steps:
  • Create a batch file containing the following command:
    msiexec /I "<NCache MSI path>"
  • Right click on the batch file and click Run as Administrator.
See Also
NCache Installation Error 1606 | Upgrading NCache | Installation Rolls Back on Windows Vista | NCache Activation Problem
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Upgrade NCache without Disturbing Deployed Environment

< Previous page Next page >

Upgrade NCache without Disturbing Deployed Environment

When a newer version of NCache is installed, your code need no longer be recompiled with the most recent version. Now, with each installation of NCache, a publisher policy file is installed. This file redirects all the previous versions of the specified assembly to the newer version. Policy assembly files for various NCache assemblies are as follows:
NCache Assembly | Publisher Policy Assembly
Alachisoft.NCache.Web.dll | policy.<version>.Alachisoft.NCache.Web.dll
Alachisoft.NCache.Runtime.dll | policy.<version>.Alachisoft.NCache.Runtime.dll
Alachisoft.NCache.Cache.dll | policy.<version>.Alachisoft.NCache.Cache.dll
Here <version> is the newer version of NCache. For example, for NCache 4.4.0.0, publisher policy file for Alachisoft.NCache.Web.dll will be Policy.4.4.0.0.Alachisoft.NCache.Web.dll. These policy assembly files are added to the GAC with all other assemblies and are removed at uninstall.
You can also bypass the publisher policy file by specifying 'publisherpolicy' tag in the "App.config" file.
For Enterprise and Professional Editions:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
For Open Source Edition:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
See Also
NCache Installation Error 1606 | Installation Error 1721: A Required Program could not be Run | Installation Rolls Back on Windows Vista | NCache Activation Problem
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Installation Ended Prematurely

< Previous page Next page >

Installation Ended Prematurely

With 64-bit NCache installation, you may get the following error at the end of the installation.
Error: "installation ended prematurely"
This usually happens when NCache service is not removed properly.
Workaround
To workaround this problem on Windows computer, please follow these steps.
  • Run the following command on VS.NET command prompt to uninstall the service.
/> InstallUtil /u "C:\ProgramFiles\NCache\bin\serviceAlachisoft.NCache.Service.exe"
  • If you don't have the service file in the NCache/bin/service folder then copy it from the other machine and paste it there and run the command. It should uninstall the NCache service.
  • Install NCache.
See Also
Removing NCache assemblies from GAC
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Removing NCache assemblies from GAC

< Previous page Next page >

Unable to Remove Assembly from the GAC Machine

You may be unable to uninstall assemblies using select and delete mechanism from GAC. You will need to delete them using command prompt (manually). You will get following message:
Error: "Assembly Alachisoft.NCache.* could not be uninstalled because it is required by other application."
Workaround
Do the following to delete assemblies from GAC:
  • Go to command prompt.
  • Go to folder %windir%/assembly/GAC_MSIL/
  • Go to the respective assembly folder and remove the assembly.
See Also
Installation Ends Prematurely
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: NCache Installation Error 1606

< Previous page Next page >

NCache Installation Error 1606: Could not access network location

In some situations, you may unable to install NCache on Windows Vista with following error message.
Error: 'Error 1606. Could not access network location %SystemDrive%/inetpub/wwwroot/'
Workaround
In order to fix this, do the following:
  • Disable UAC in Windows Vista.
  • Find the following key: HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/InetStp/PathWWWRoot
  • Change the value of this registry key from '%SystemDrive%/inetpub/wwwroot' to 'C:\inetpub\wwwroot'. If your default website in IIS is stored at a different location, set the value of this registry key to that path.
  • Enable IIS 6.0 administration.
See Also
Installation Error 1721: A required progaram could not be run | Upgrading NCache | Installation rolls back on Windows Vista | NCache activation problem
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Installation Roll Backs on Windows Vista

< Previous page Next page >

Installation Roll Backs on Windows Vista

When you install NCache on Windows Vista, sometimes it rolls back towards the end without giving any error.
Workaround
To workaround this problem on a Windows Vista computer, please follow these steps.
  • Click Start, go to Settings, and then click Control Panel.
  • In control panel, click the Programs and then click the "Turn Windows features on or off"
  • In the windows features dialog, find Internet Information Services and expand the tree to Web Management Tools and click the node IIS 6 Management Compatibility to enable it.
  • Click OK and let Windows install the selected feature on your system.
  • Now you can install NCache.
See Also
Upgrading NCache | NCache Installation Error 1606 | Installation Error 1721: A required program could not be run | NCache activation problem
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Using Security

< Previous page Next page >

Using Security

This section provides solutions for some common troubles in using NCache security.
In This Section
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Different situations are explained when this exception is thrown by NCache.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Alachisoft.NCache.Runtime.Exceptions.SecurityException

< Previous page Next page >

Alachisoft.NCache.Runtime.Exceptions.SecurityException

This exception is raised if an unauthorized user tries to perform cache operations, or wrong credential information is given in the InitializeCache() overload given below or in client.ncconf file.
Workaround
To avoid security exception, do the following :
  • Check if you have given correct credential information through API or in client.ncconf. A typing mistake can be the result of this exception.
  • See if the user which you have specified exists under given domain in LDAP. Login credentials are required to belong to any WINDOWS Server hosting the user login and running Active Directory services.
  • Check if you have given a double slash '//' to separate domain name and User ID when passing them as a string through API. Sometimes a single slash is given, which is recognized as an escape sequence. In that case, no compile time error arises, rather it results in a security exception. Correct way to pass security information through API is shown below:
    // Initialize the cache
    NCache.InitializeCache("myQSReplicatedCache", primaryUserCredentials, secondaryUserCredentials);
See Also
Configuring Security
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Cache Event IDs

< Previous page Next page >

Cache Event IDs

Below is a table explaining Cache Event IDs.
Event Name | ID | Description
CacheStart | 1000 | Cache Started Successfully
CacheStop | 1001 | Cache Stopped Successfully
CacheStartError | 1002 | You don't have permission to perform this operation
CacheStopError | 1003 | Cache cannot be stopped due to an exception
ClientConnected | 1004 | Client has connected to cache
ClientDisconnected | 1005 | Client has disconnected from the cache
NodeJoined | 1006 | Node has joined
NodeLeft | 1007 | Node Has Left
StateTransferStart | 1008 | NCache has started state transfer
StateTransferStop | 1009 | NCache has completed state transfer
StateTransferError | 1010 | NCache has ended state transfer prematurely
UnhandledException | 1011 | An unhandled exception has occurred
ServiceStartFailure | 1013 | NCache Service fails to start (Normally in case of server reboot)
LoggingEnabled | 1014 | Logging enabled successfully
LoggingDisabled | 1015 | Logging disabled successfully
CacheSizeWarning | 1016 | Cache has exceeded from allocated cache size
GeneralError | 1017 | NCache failed to open log
GeneralInformation | 1018 | Any other information that cannot be defined using the current event IDs
ConfigurationError | 1019 | BridgeServer failed to load configuration information
LicensingError | 1020 | NCache evaluation has expired. It can't be extended anymore therefore, please purchase NCache license from sales@alachisoft.com and activate before expiration
SecurityError | 1021 | You don't have permission to perform this operation
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Troubleshooting Client Socket Deadlock

< Previous page Next page >

Troubleshooting Client Socket Deadlock

You may experience a deadlock situation on your client socket because of a long wait for a response from the cache server. This may also result in a lot of waiting threads that may cause performance issues. To resolve this problem, please follow these steps:
Step1: Changes on Server Side
  • Go to Alachisoft.NCache.Service.exe.config located at
    %INSTALLATION_PATH%/NCache/bin/service/Alachisoft.NCache.Service.exe.config
  • Add the following lines in the configuration file:
<add key = "NCacheServer.EnableBadClientDetection" value = "true" />
The value "true" indicates that BadClientDetection is enabled on your client socket. This means that now if a deadlock situation arises on your client socket, the socket will be reset. The default value of this property is "false".
<add key = "NCacheServer.ClientSocketSendTimeout" value = "10" />
When you have enabled BadClientDetection, you can specify the time interval after which the socket is reset in case of a deadlock. The default value of this property is "10" and this value can not be less than 1.
A few other properties have also been introduced in Alachisoft.NCache.Service.exe.config to help with this issue. Please configure these properties as follows:
<add key ="NCacheServer.EventPriorityRatio" value="30"/>
On the server-side a priority queue is used for events and cache operations. You can configure a ratio of events and cache operations for this queue through the property called EventPriorityRatio. The default value of this property is 30 which indicates a ratio 30:70 for events and cache operations. The value of this property can not be less than 1.
<add key ="NCacheServer.EventBulkCount" value="50"/>
The cache server now sends events to clients in bulk. Through this property you can set the number of items to be sent in bulk. By default this value is 50 and the value can not be less than 1. This is available in client version 4124 and above.
<add key ="NCacheServer.EventBulkCollectionInterval" value="2"/>
This property is used to set the time interval, in seconds, after which bulk of events is fired even in case the bulk count does not reach the EventBulkCount that the user has specified. Default value for this property is 2 seconds and the value can not be less than 1.
  • Restart the NCache service for these changes to take effect.
Step2: Changes on Client Side
  • Please make the following changes in your app.config/web.config file:
<configuration>
<appSettings>
<add key ="NCacheClient.AsynchronousEventNotification" value="true"/>
<add key ="NCacheClient.NumberofEventProccesingThreads" value="2"/>
</appSettings>
</configuration>
  • AsychronousEventNotification: Specifies whether events will be fired asynchronously or synchronously on client side. The default value is "true" which indicates that events will be fired asynchronously. The value "false" means that events will be fired synchronously on client side.
  • NumberofEventProcessingThreads: When the user has configured events to be fired synchronously, this flag is used to specify the number of threads which will process these events on client side. A very large value can cause performance issues.
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: How to's

< Previous page Next page >

How to's

This section contains the most commonly asked question.
In This Section
How to do NCache Version Upgrades?
Describes how to upgrade Microsoft SharePoint Server 2007 to Microsoft SharePoint Server 2010.
What is the Recommended Way to Apply Windows Patches on NCache Server?
Describes how to convert External BLOB Storage to Remote BLOB Storage without copying BLOBs .
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: How to do NCache Version Upgrades?

< Previous page Next page >

How to do NCache Version Upgrades?

NCache major version can be upgraded by few simple steps given below:
1. Create Backup of config.ncconf (Optional)
If you are upgrading major version of the NCache then in order to restore old configurations you need to create a backup of config.ncconf file but it is recommended to use new configuration settings in case of major version upgrade. Also refer back to the backup config.ncconf file to see what options you have already configured in order to have exactly same configuration settings again. Backup of log files can also be kept for history purpose.
2. Uninstall NCache
Uninstall current version of NCache. If any application is using NCache and you uninstall NCache, an error message will be displayed as shown below.
Here you have to remove assemblies by yourself
  1. Remove .NET Framework 2.0 assemblies manually from [System Drive]:\Windows\assembly
  2. Remove .NET Framework 4.0 assemblies from [SystemDrive]:\Windows\Microsoft.NET\assembly
  1. For NCache 3.8 remove assemblies manually e.g.
1. [SystemDrive]:\Windows\Microsoft.NET\assembly\GAC_32\Alachisoft.NCache.Web\ v4.0_3.8.0.0__cff5926ed6a53769\Alachisoft.NCache.Web.dll
2. [SystemDrive]:\Windows\Microsoft.NET\Assembly\GAC_64\Alachisoft.NCache.Web\v4.0_3.8.0.0__cff5926ed6a53769\Alachisoft.NCache.Web.dll
b. For NCache 4.3 and above remove assemblies manually from [SystemDrive]:\Windows\Microsoft.NET\assembly\GAC_MSIL e.g.
1. [SystemDrive]:\Windows\Microsoft.NET\Assembly\GAC_MSIL\Alachisoft.NCache.Web\v4.0_4.3.0.0__cff5926ed6a53769\Alachisoft.NCache.Web.dll
3. Install New Version
Install new version of NCache. For complete step by step installation process see installation guide .
4. Verification
After installation you can verify whether NCache has been installed correctly or not by using some command line tools such as:
Startcache mycache It will start default shipped cache ‘mycache’.
Addtestdata mycache It will add 10 items in the cache ‘mycache’, if cache is already started.
Getcachecount mycache It will return the number of total item exist in cache i.e. ‘mycache’.
Listcaches It will show all the created caches on current machine.
5. Upgradeconfiguration Tool (Optional)
For restoring previous configuration settings use command line tool upgradeconfiguration.exe. Use of this tool is useful only when you want to use previous configuration settings otherwise it is not required.
You can also bind NCache service to specific IP that is publicly available to other nodes in the cluster. For details see Select Network Interface Card .
6. Recompile Application
If you are using object caching then you have to recompile your application. And if you are using view state caching or session state caching then you may have to change version manually from web.config file, generally their versions are not changed. But still it can be changed from web.config file For Example:
For Enterprise and Professional Editions:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
For Open Source Edition:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
Replace Version “x.x.x.x” with the NCache version that you have just installed.
Similarly, if you are using NCache SessionStore provider module or content optimization feature then you need to follow the same process. Find “Alachisoft.NCache.*” and change “version=x.x.x.x” with the current version of the NCache module in use.
Note: NCache module version can be different from the NCache version e.g. NCache current release version is “4.4.0.0” but its ContentOptimization module version is “1.0.0.0”.
See Also
Installation Guide | Upgrading NCache | Configuring NCache | NCache Activation Problem
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: What is the Recommended Way to Apply Windows Patches on NCache Server?

< Previous page Next page >

What is the Recommended Way to Apply Windows Patches on NCache Server?

Recommended way for applying windows patches on NCache Server is windows standard procedure.
Required steps are:
1. Stop the Cache
Stop the cache by right click on IP address of the node in NCache Manager under your cache cluster. If this node is part of multiple cache clusters then you need to stop this node/cache from all cache clusters. This will start state transfer process and data will be re-adjusted on other nodes available in the cluster.
2. Stop NCache Service
Stop NCache service on this server and also change the service startup type from “Automatic” to “Manual”, so that you can manually start NCache service after reboot.
3. Apply Patch
Apply required patches/updates. Complete all the maintenance tasks running on this machine and then reboot the servers.
4. Restart NCache service
After successful completion of step 3 now restart NCache service and also change service start up type back to “Automatic” for normal usage.
5. Start the cache
Now start the cache manually from NCache manager if auto-start is not enabled. Refresh cache cluster from NCache manger to view this node as active node in the cluster. Furthermore, you can see data being transferred to this lately added cache node.
Perform same steps for other nodes in your environment. The main reason of starting NCache service manually is that some of the patches complete their operations after some time of system startup and it is a good practice to start NCache service manually once all the patches are fully applied and maintenance work is complete on your server.
See Also
Installation Guide | Upgrading NCache | Unable to Connect to Remote Server (Windows XP Machine) | How to do NCache version upgrades
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: How to Debug Providers?

< Previous page Next page >

How to Debug Providers?

Steps for Debugging a Provider:
Here are the steps required to debug your providers
  1. Insert break point in your application from where you want to debug.
  2. From menu bar click on "Debug" and select "Attach to process..." option as shown below.
3. Attach to a process named "Alachisoft.NCache.Service.exe", as shown below.
  • Please make sure that options "Show processes from all users" and "Show processes in all sessions" are selected.
See Also
Read-Through and Write-Through Caching | Cache Startup Loader | Unable to Connect to Remote Server (Windows XP Machine) | How to do NCache Version Upgrades
Send comments on this topic.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: How to Configure and Use NCache Manager for Visual Studio

< Previous page Next page >

How to Configure and Use NCache Manager for Visual Studio

This guide helps you to configure and use NCache Manager in Visual Studio
Note: NCache Manager for Visual Studio will only work with 2010, 2012 and 2013 versions of Visual Studio and its editions which support extensions.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Installation

< Previous page Next page >

Installation

1. NCache Manager for Visual Studio comes with Developer type installation of Enterprise edition of NCache Version 4.4 SP1 and onwards. The setup installer will automatically try to install the Visual Studio extension on all of the edition(s) installed of VS 2010, 2012 and 2013 on the system.
2. NCache Manager for Visual Studio can also be installed from Visual Studio’s Extension Manager/Extension Updater by searching for “NCache Manager for Visual Studio” in Online Gallery/Online section and downloading it.
3. NCache Manager for Visual Studio alternatively can be downloaded (.VSIX file) from the link https://visualstudiogallery.msdn.microsoft.com/46af433a-1e84-4085-ab39-50d0f6ba2817 and installed in any version/edition of Visual Studio of the user’s choice.
Note: NCache Manager for Visual Studio will only work with 2010, 2012 and 2013 versions of Visual Studio and its editions which support extensions.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Usage

< Previous page Next page >

Usage

After successful installation of NCache Manager for Visual Studio extension for the selected version(s)/Edition(s) of Visual Studio, NCache Explorer can be opened by selecting VIEW>Other Windows>NCache Explorer from the Visual Studio’s menu bar.
Opening NCache Explorer:
This will open NCache Explorer tool window, which can be tabbed, docked or closed just like any common tool window of Visual Studio, which will also remember its state even if the Visual Studio gets closed.
The window contains a toolbar which will have listed available operations and a “tree”, kind of a hierarchical structure to show caches and related information. The toolbar’s operations update according to selected item in the tree, operations can also be performed from the right-click menu of an item in the tree.
The root-item NCache Explorer will have Clustered Caches and Local Caches as child-items, each of them will be a parent to the type of cache (Clustered/Local) added. Each item in the tree will have its icon updated according to its state.
A clustered cache type of item will futher have Server Nodes and Client Nodes child-items, which will represent server nodes and client nodes in the cache, where a child-item of Local Cache will represent server node hosting the cache of type Local. Image below is representing a Clustered cache named “myReplicatedCache” and a Local cache name “myCache”.
NCache Explorer tool window:
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Operations

< Previous page Next page >

Operations

You can Create Clustered Cache, Local Cache, add/remove server node(s), add/remove client node(s), configure basic cache-settings, perform Management Operations (Start a cache, Stop a cache and etc.), configure and view statistics in Visual Studio using NCache Manager for Visual Studio.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating Clustered Cache

< Previous page Next page >

Creating Clustered Cache

Clustered cache can be created in NCache Explorer the following way:
1. Select “Create New Clustered Cache” toolbar item/”NCache Explorer”, the top item in tree right-click menu item/”Clustered Caches” right-click menu item.
2. New Clustered cache wizard will open. Specify the name of cache and click Next.
3. In Select caching topology dialog, select the required cache topology. You can also change the Operation timeout (sec.) and Statistic replication interval (sec.) under the Advanced cluster options. Specify the desired information and click Next.
4. If you selected the Partition Replica Cache topology, you have to select a, either Asynchronous or Synchronous. Click Next.
5. Specify the node IP address in text box or select from the Network Neighborhood and click on the ‘>’ button to add it in the Selected Nodes list. Click Next once all the required nodes are added.
6. Change the Cluster Port if required. Click Next.
7. On this wizard page, you can change the ache size if required. Click Finish. Created cache will appear in NCache Explorer under Clustered Caches section.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Creating Local Cache

< Previous page Next page >

Creating Local Cache

Local cache can be created in following way:
1. Select “Create New Local Cache” toolbar item/”NCache Explorer”, the top item in tree right-click menu item/”Local Caches” right-click menu item.
2. In New Cache Wizard, specify the server IP address and click Next.
3. Specify the name of the cache in text box and click Next.
4. Change the cache size if required and click Finish. Created cache will appear in NCache Explorer under Local Caches node hierarchy.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding/Removing Server Node to/from Existing Clustered Cache

< Previous page Next page >

Adding/Removing Server Node to/from Existing Clustered Cache

Regardless of the fact that clustered cache has been created, NCache Manager for Visual Studio allows you to add or remove server nodes to/from the existing clustered cache. This section explains how to add/remove server nodes from existing caches.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding Server Node

< Previous page Next page >

Adding Server Node

Server node can be added to a clustered cache the following way:
1. Right click on a cache name in NCache Explorer and select Add Server Node option OR click on “Server Node” item in a clustered cache and select “Add Server Node” operation from the top toolbar in NCache Explorer.
2. Add Node Wizard will open. Specify the server IP which you want to add in text box and click Finish.
Added node will appear in Server Nodes list under this cache name.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Removing Server Node

< Previous page Next page >

Removing Server Node

A server node from the cache can be removed in the following way:
1. Expand the cache and in Server Nodes section, right click on the node which you want to remove from cache.
2. Select the Remove option/ Select Remove Server Node from the toolbar.
This will remove the server node from the cache.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding/Removing Client Node to/from Existing Clustered Cache

< Previous page Next page >

Adding/Removing Client Node to/from Existing Clustered Cache

Each clustered cache tree in Cache Explorer contains a node known as Client Nodes. Any number of client nodes can be added in a clustered cache.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Adding Client Node

< Previous page Next page >

Adding Client Node

1. Right click on Client Nodes in NCache Explorer for a cache and then click on the Add Node option.
2. Provides the client machine name/IP by expending Network Neighborhood or you can manually enter client machine name/IP in text box.
3. Click on the Finish button, newly added client node appears under Client Nodes in NCache Explorer tree view.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Removing Client Node

< Previous page Next page >

Removing Client Node

A client node from the cache can be removed in the following way:
1. Expand the cache and in Client Nodes section, right click on the node which you want to remove from cache.
2. Select the Remove Node option.
This will remove the client node from cache
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Basic Cache Settings

< Previous page Next page >

Configuring Basic Cache Settings

NCache Manager for Visual Studio gives you limited control on cache configurations so that you can create and configure a cache according to your requirements. When you click on the cache name in NCache Explorer, you can see a new window with various inputs on the right side.
1. Change the Cache Max. Size/Cluster Port (of a Clustered cache)/Isolation Level (of a Local cache) of a stopped cache.
2. Upon the change in the configuration the “Apply Configuration” button will get enabled, click it to change the configuration of the cache.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Management Operations

< Previous page Next page >

Management Operations

This section describes that how you can manage caches and their related configuration.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start Cache

< Previous page Next page >

Start Cache

You can start a clustered cache on all the server nodes altogether or start it on a specific node. Please follow these steps to start the clustered cache:
1. Starting Cache on All Server Nodes
I. From the NCache Explorer view, right click on the cache name which you want to start.
II. Click on the Start option in the right click context menu.
2. Starting Cache on a Particular Server Node
I. From the NCache Explorer view, right click on the server name under Server Nodes tree node, on which you want to start the cache.
II. Click on the Start option in the right click menu, in order to start the cache.
This starts the ClusteredCache on the selected server node.
Server node icons turn to sky blue if cache is started on it.
III. This starts the ClusteredCache on all the server nodes listed under the Server Nodes tree view. Server node color turns to sky blue if cache is started successfully.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Stop Cache

< Previous page Next page >

Stop Cache

You can stop a clustered cache on all the nodes altogether or stop it on a specific node.
1. Stop Cache on all Server Nodes
I. From the NCache Explorer view, right click the clustered cache on which you want to stop the cache.
II. Click on the Stop Cache option.
III. This will stop the ClusteredCache on all the server nodes added in this cache. If cache is stopped successfully, then the color all of the server nodes change to black, like this:
2. Stopping Cache on a Particular Server Node
I. From the NCache Explorer view, right click on the server name under Server Nodes tree node, on which you want to start the cache.
II. Click on the Stop option in the right click menu.
III. This will stop the ClusteredCache on the selected node. Icon color of the selected node changes to black if cache is stopped successfully on it, like this:
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Start/Stop Service on a Server Node

< Previous page Next page >

Start/Stop Service on a Server Node

You can start/stop/restart NCache service on a server node added to a clustered cache by following the steps given below:
1. Start Cache Service on a Server Node
I. In NCache Explorer view, right click the server node on which you want to.
II. Click on the Start Cache Service option in the right click context menu.
This will start the NCache service on this node.
2. Stop Cache Service on a Server Node
I. In NCache Explorer view, right click on the server node on which you want to stop the service.
II. Click on the Stop Cache Service option in the right click context menu.
This will stop the NCache service on this selected node
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Configuring Statistics Counters to Display Management Port

< Previous page Next page >

Configuring Statistics Counters to Display Management Port

By Default, NCache Management Port is set to 8250 and a few important counters are displayed in statistics window but you can add/remove more counters according to your requirements. To configure these setting there is following way:
1. Click Plugin Options button from top toolbar menu in NCache Explorer.
2. All performance counters are displayed in this view; you can select/deselect counters from this tab and change Management Port according to your wish.
3. Click OK to save your selection.
< Previous page Next page >
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Viewing Statistics of a Cache

< Previous page

Viewing Statistics of a Cache

NCache Manager for Visual Studio also lets you monitor statistics of a cache; following is the way to view it.
1. Right click any running cache, and select Statistic menu item/Select any running cache and click Show Statistics item from top toolbar menu.
2. This will open a new tool window which will contain statistics for the cache.
A Local Cache’s (cache) statistics.
A Clustered Cache’s(ClusteredCache2) Statistics.
< Previous page
Copyright © 2005-2015 Alachisoft. All rights reserved.


Topic: Activate NCache Purchased License

NCache 4.4 - Online Documentation
NCache
What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Activate NCache Purchased License

This PowerShell script lets you activate NCache license on remote machines. It makes your administrative tasks easy when you have many servers to activate because you don't have to manually activate the license on each server.
You should have internet access on all the machines where you want to activate NCache through the PowerShell script. Internally, this script uses command line tool NActivate.exe of NCache. You must have to provide valid admin user id and password that has the permissions to execute commands on remote machine.
Please refer to the Troubleshooting Install script section if you have any issue in executing this script. You should find the UninstallNCache .ps1 script at the NCache installation path in the integration folder:
%INSTALLPATH%/NCache/Integration/PowerShell/ ActivateNCache.ps1
PS C:/Users>./ ActivateNCache.ps1 /k key /f first-name /l last-name /email email-address /uid server-username /pwd server-password [ options[...] ].
Argument | Description
/k key | Allows users to specify a valid license key .
/f first-name | Allows users to specify first name.
/l last-name | Allows users to specify last name .
/email email-address | Allows users to specify email address.
/uid | Specify a valid user name that has permissions to execute the command on remote machine.
/pwd | Specify a valid password.
Option | Description
/servers server-names | Allows the user to specify a comma separated list of names or IPs of the machines on which NCache is to be activated .
/a address | Allows users to specify the company's address
/city city-name | Allows users to specify the edition of NCache. Default is "0".
/s state | Allows users to specify state name
/c country-name | Allows users to specify the country name.
/p phone-number | Allows users to specify the company's phone number.
/z zip-code | Allows users to specify the zip code
/? | Displays command syntax and options for the utility.
Remarks
In the following examples we will activate NCache License key on three machines Test1, Test2, and Test3 using the PowerShell script ActivateNCache.ps1. It is assumed that NCache is installed on the default path “C:/program files”.
Example of Activating NCache License Remotely:
PS C:/Program Files/ncache/integration/PowerShell>./ ActivateNCache.ps1 /k xxxxxxxx-xxxxxx-xxxxxxxx /f Paul /l Jones /email paul.jones@alachisoft.com /servers Test1, Test2, Test3 /uid Administrator /pwd 123pwd
This will activate NCache on three machines Test1, Test2 and Test3. Please replace the server “Test1, Test2, Test3” with your own server names.
See Also


Topic: Activate NCache Purchased License

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Activate NCache Purchased License

If you have purchased NCache licenses, you can activate them by following the steps given below:
  • Run the NActivateWizard Tool from "%Install Directory%/NCache/bin/NActivate" path.
  • NCache License Manager will open. Please check Activate Purchased License Key and click Next.
  • You will see the following screen.
Please note that if you have installed Enterprise Edition of NCache, you'll only get the "Production License" option here. Similarly, if you have installed Developer Edition, you'll get the "Developer License" option. Click Next button and you'll see the following screen.
  • In this dialog box, there are two different options to choose from. If your computer has Internet access, just select the Online (Recommended) option. It will ask you to enter a license key and will activate NCache license for you immediately.
Online Activation
Online activation is the fastest way to activate but requires that your machine has Internet access.
Online activation is the fastest way to activate but requires that your machine has Internet access.
  • Please enter the required information in this form. License Key, First Name, Last Name and Email are compulsory fields. Enter your purchased license key to proceed. Click Next.
  • You will see the final screen for activating your license. Just press Activate Now and it will activate NCache license for you immediately.
If for some reason you're unable to activate, it will display an error message. Your license activation can fail for a number of reasons as following:
• Your firewall does not allow HTTP POST from Activation Program to the Alachisoft License Server.
• You do not have Internet access
• Your license key is invalid
• You have already used up the purchased CPUs or nodes. If this happens, then please review your NCache license usage and then contact Alachisoft Sales.
Manual Activation
However, if your computer does not have Internet access (which is the case in many production servers behind the firewall), then you should opt for manual activation.
  • Select Manual and click Next.
  • The following screen will appear.
This dialog box shows two options. If you already have the activation code, then check Step2 - Proceed with activation. Let's say you don't have the activation code. Check Step1 - Generate activation code info and click Next. The following dialog box will appear.
  • Please enter the required information in this form. License Key, First Name, Last Name and Email are compulsory fields. Enter your purchased license key to proceed. Click Next.
  • A screen showing a long encrypted text appears. Press Copy to copy this text to the clipboard. Paste this in an email and send that email to Alachisoft Support ( support@alachisoft.com ). This is an Activation Request Code that you need to obtain an Activation Authentication Key. Or you can also obtain the Activation Key directly by clicking on the link given below:
NCache Email Activation .
  • Paste the Activate Request Code into the text box on this page and then press Verify.
  • Activation Data Verification form will appear.
  • There will be an Activate button at the bottom of the page shown above. Click this button and it displays a page with the Activation Authentication key as shown below.
  • The Generated Activation Key is shown as a long encrypted string. Copy this key to your clipboard. Then, go back to NActivate Wizard select Manual activation option. Click Next.
  • Check Step2 - Proceed with activation. Click Next.
  • Paste the Activation Key that you received from Alachisoft and paste in the box below.
  • Click Finish. You will be prompted with a success message and NCache will be activated on your machine.
See Also
Getting Started | Command Line Install | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Deactivate NCache License
Send comments on this topic.


Topic: NCache Activation Error

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Activation Error

In some situations, while trying to launch NActivate tool, following error message is shown:
Error: "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."
This error message occurs usually when VC++ libraries are not installed. NActivate tool uses assemblies developed in VC++. Windows 2003 installation does not install Visual C++ Libraries required to run applications developed with Visual C++ on a computer that does not have Visual C++ 2005 SP1 installed.
Workaround
Install redistributable package from Microsoft. It will install all the required libraries. You can download redistributable package from the following link:
http://www.microsoft.com/en-us/download/details.aspx?id=26347
See Also
NCache Installation Error 1606 | Installation Error 1721: A required progaram could not be run | Upgrading NCache | Installation rolls back on Windows Vista


Topic: Active-Active

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Active-Active

Three NCache Clusters participate in Active-Active topology:
  • Two active caches (replicated, partitioned, mirror or partitioned replica), where all clients are connected and perform read and write operations. Here any updates to the cache are applied asynchronously to the other cache.
  • A Bridge Cache between both the active caches.
See Also
Overview of Bridge | Active-Passive Bridge Topology | Creating Clustered Bridge | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches


Topic: Active-Passive

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Active-Passive

Three NCache Clusters participate in Active Passive topology:
  • An active cache (replicated, partitioned, mirror or partitioned replica), where all clients are connected and perform read and write operations.
  • A passive cache (replicated, partitioned, mirror or partitioned replica), where all operations performed on an active cache are replicated. Clients can connect to passive cache and perform both read and write operations but those operations are not replicated to the other caches. Modification can be done at passive cache if required.
  • A Bridge Cache between the active cache and the passive cache.
See Also
Overview of Bridge | Active-Active Bridge Topology | Creating Clustered Bridge | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches


Topic: Making Active Cache as Passive Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Making Active Cache as Passive Cache

NCache Manager provides the facility to convert an active cache in a bridge to a passive cache using the following steps:
Using NCache Manager
  • Right click on the active cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Make Passive option in the right click context menu.
See Also
Making Passive Cache as Active Cache | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring NCache


Topic: Adding Items

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding Items

Once you have a valid cache handle, you can do the "Add" operations. The Add operation has many overloads and the basic overload takes two parameters "key" as string and "value" as object. The value must be a .NET serializable object otherwise NCache will throw a serialization exception if .NET serialization or NCache compact serialization is not being used.
Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Add Method
An "Add" method will add item to the cache only if that item does not already exist in the cache. Otherwise, it will throw an exception.
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    static void Main( string [] args)
    {
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Add Item to Cache
    _cache.Add( "Customer:David:1001", customer);
    Object object_Customer = _cache.Get("Customer:David:1001");
    Customer customerInformation = ( Customer )object_Customer;
    Console.WriteLine("Customer ID: " + customerInformation.customerID);
    Console.WriteLine("Name: " + customerInformation.name);
    Console.WriteLine("City: " + customerInformation.City);
    Console.WriteLine("Contact Number: " + customerInformation.ContactNumber);
    Console.WriteLine("Order placed: " + customerInformation.IsOrderInProcess);
    }
  4. Start the Local Cache 'myCache'.
  5. Run the project.
Using Insert Method
Additionally, you can use "Insert" method to either add or update the item in the cache. Insert method adds item only if it does not already exist in the cache. Otherwise, it updates the item.
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    static void Main( string [] args){
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Insert Item to Cache
    _cache.Insert("Customer:David:1001", customer);
    Object objectCustomer = _cache.Get("Customer:David:1001");
    Customer customerInformation = (Customer)objectCustomer;
    Console.WriteLine("Customer ID: " + customerInformation.customerID);
    Console.WriteLine("Name: " + customerInformation.name);
    Console.WriteLine("City: " + customerInformation.City);
    Console.WriteLine("Contact Number: " + customerInformation.ContactNumber);
    Console.WriteLine("Order placed: " + customerInformation.IsOrderInProcess);
    }
  4. Start the Local Cache 'myCache'.
  5. Run the project.
See Also
Initialize Cache | Finding items | Removing Items | Dispose Cache | Start Cache | Stop Cache


Topic: Add a Bridge Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Add a Bridge Node

This section explains how to add a node in the bridge. Please follow the steps given below for this purpose.
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Add Bridge Node option in the right click context menu.
  • Specify the server IP address in text box or select a server from the Network Neighborhood listed under Available Nodes. Click Finish.
  • Right click on the name of the bridge and select Apply Configuration.
See Also
Remove a Bridge Node | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Adding Client Node in a Cache Cluster

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding Client Node in a Cache Cluster

Each clustered cache tree in Cache Explorer contains a node known as Client Nodes. Any number of client nodes can be added in a clustered cache.
This can be done as follows:
Using NCache Manager
  • Right click on Client Nodes in Cache Explorer for a cache and then click on the Add Node option.
  • Provide the client machine name/IP by expending Network Neighborhood or you can manually enter client Node
Name/IP Address in text box.
  • Click on the Finish button, newly added client node appears under Client Nodes in Cache Explorer tree view.
If you have more than one IP address on a client machine, then enter the IP address on which NCache service is running.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addclientnode.exe, provide the required information:
addclientnode.exe demoClusteredCache /s 20.200.21.95 /e 20.200.21.144
  • Hit ENTER key, it adds 20.200.21.144 as client node in cache named demoClusteredCache.
See Also
Configuring Caches | Create Caches | Configuring Client Node Settings | Configuring Client Cache Settings | Creating Client Cache | Disable Client Cache | Enable Client Cache


Topic: Add Dependency to the Existing Cached Item

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Add Dependency to the Existing Cached Item

If data has been added to cache without dependency, NCache allows to add any of the dependency supported by NCache, with this existing data without any need of updating data. This can be done using AddDependency API of NCache.
The following code shows how to add dependency with existing data.
string key1="Product:1001";
string key2="Product:1002";
// precondition: items with keys "Product:1001" and Product:1002" are already in cache
try
{
cache.AddDependency(key2, new KeyDependency(key1), false);
}
catch (OperationFailedException ex)
{
// handle exception
}
To add file dependency use:
cache.AddDependency(key, new FileDependency(filepath), false);
Any dependency can be added with the existing cached item with the same API.
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Aggregate Cache Dependency


Topic: Adding an Existing Cache Cluster

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding an Existing Cache Cluster

An already created cache cluster can also added in your project. this can be done as follows:
Using NCache Manager
  • Right click on Clustered Caches in Cache Explorer and select Add Existing Clustered Cache.
  • Add Clustered Cache Wizard will appear. Specify the Node Name/IP Address on which the cache cluster is registered and click Next.
  • A list of cache clusters registered on the node you specified will appear. Select the cluster and press Finish.
  • The selected cache cluster will appear in Cache Explorer under Clustered Caches section.
See Also
Creating Local Cache | Creating a New Cache Cluster | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations


Topic: Adding Server Node in a Cache Cluster

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding Server Node in a Cache Cluster

A Server Node can be added in cluster any time. After adding a server node in a cluster, you need to start that node so that it can join the cluster.
Using NCache Manager
  • Right click on a cache name in Cache Explorer and select Add Server Node option.
  • Add Node Wizard will open. Specify the server IP which you want to add in text box and click Finish.
  • Added node will appear in Server Nodes list under this cache name.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addnode.exe, provide the required information:
addnode.exe demoClusteredCache /x 20.200.21.95 /N 20.200.21.107
  • Hit ENTER key, , it will add 20.200.22.107 node in demoLocalCache.
See Also
Creating Caches Clusters | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations


Topic: Add/Update Data to Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Add/Update Data to Cache

After successful initialization of cache and gaining valid cache handle, Add operation can be performed. Add is the basic operation provided by NCache; data can be added/updated to the cache using multiple API calls.
  • Key-Value Cache Store
NCache has a basic “key” and “value” structure for objects. Every object must have a unique string key associated with it. Every key has an “Atomic” occurrence in cache be it local or clustered. Even though cached keys are case sensitive in nature; if the user tries to add another key with same value an Operation failed Exception is thrown by the cache.
  • Custom Objects
The data to be used must be .NET serializable otherwise NCache will throw a serialization exception. Data can also be added directly as value property of CacheItem class; internally data is saved as a CacheItem.
Additionally, NCache Dynamic Compact Serialization framework for custom objects can also be used. This custom framework results in cost effective serialization of registered classes.
NCache returns CacheItemVersion with every add/Insert call; in these examples, we have ignored CacheItemVersion.
Adding Objects to Cache
In order to add data in cache it must be ensured that the object is either .NET serialized or registered with NCache Compact serialization framework. In this example, a new object of Product class is created and added to cache.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, product);
}
catch (OperationFailedException ex)
{
// handle exception
// usually thrown if key already exist in cache
// however verify the failure reason
}
Update Objects in Cache
Similarly in order to update data previously added in cache, it must be ensure that the object is either serialized. In this example, a new object is added with an existing key.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 5; // updated units
string key = "Product:" +product.ProductID ;
try
{
//precondition: Cache is already initialized and item exists
cache.Insert(key, product);
}
catch (OperationFailedException ex)
{
// handle exception
}
Adding Objects Using Cacheitem
Similarly in order to update data previously added in cache, it must be ensure that the object is either serialized. In this example, a new object is added with an existing key.
CacheItem is a custom class provided by NCache which can be used to add data to the cache. This class encapsulates data as its value property. CacheItem also lets you set additional specifications associated with an object as properties of this class.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
For the remaining API usage, kindly refer to the relevant NCache features.
Updating Objects Using Cacheitem
In this example, a key is updated that has already been exisiting in cache with object set as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 5; // updated units
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
try
{
cache.Insert(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
Updating Data Using Cache Indexer
NCache being a key-value paired structure lets the user perform operations like any other indexed based data structure. In this example a cache handle is used to directly access and update cache values using square brackets ”[]”.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 5; // updated units
string key = "Product:" +product.ProductID ;
try
{
cache[key]=product;
}
catch (OperationFailedException ex)
{
//handle exception
For the remaining API usage, kindly refer to the relevant NCache features.
See Also
Creating Caches | Initialize Cache | Fetch Data from Cache | Remove Data from Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache


Topic: Adding Client Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding Client Node

1. Right click on Client Nodes in NCache Explorer for a cache and then click on the Add Node option.
2. Provides the client machine name/IP by expending Network Neighborhood or you can manually enter client machine name/IP in text box.
3. Click on the Finish button, newly added client node appears under Client Nodes in NCache Explorer tree view.


Topic: Adding/Removing Server Node to/from Existing Clustered Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding/Removing Server Node to/from Existing Clustered Cache

Regardless of the fact that clustered cache has been created, NCache Manager for Visual Studio allows you to add or remove server nodes to/from the existing clustered cache. This section explains how to add/remove server nodes from existing caches.


Topic: Adding/Removing Client Node to/from Existing Clustered Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding/Removing Client Node to/from Existing Clustered Cache

Each clustered cache tree in Cache Explorer contains a node known as Client Nodes. Any number of client nodes can be added in a clustered cache.


Topic: Adding Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding Server Node

Server node can be added to a clustered cache the following way:
1. Right click on a cache name in NCache Explorer and select Add Server Node option OR click on “Server Node” item in a clustered cache and select “Add Server Node” operation from the top toolbar in NCache Explorer.
2. Add Node Wizard will open. Specify the server IP which you want to add in text box and click Finish.
Added node will appear in Server Nodes list under this cache name.


Topic: Administrator's Guide

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Administrator's Guide

This section provides a guide to perform administrative tasks on caches and bridges using NCache Manager, command line tools and configuration files.
In This Section
Configuring Caches
Discusses how to create caches and configure settings of both local caches and cache clusters.
Management Operations
Describes how to perform different cache management operations like start cache, stop cache, apply configuration etc.
Configuring Cache Clients
Explains the procedure to add/remove node in client cache, create client cache and configure its basic settings.
Configuring Security
Discusses how to configure appropriate security and encryption for cache.
Configuring Bridge for WAN Replication
Discusses bridges in NCache and its configurations. It also explains how to perform different bridge management operations.
Monitoring NCache
Describes cache counters provided by NCache. It also explains how to oversee the performance of caches and bridges using NCache Manager, Monitor and Perfmon Tool.


Topic: Aggregate Cache Dependency

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Aggregate Cache Dependency

NCache provides feature of Aggregate dependency to support multiple dependencies with a single cache item. The following code explains how to add AggregateCacheDependency with an item.
Product product=new Product();
product.ProductID=1002;
product.ProductName="Chang";
string key="Product:"+product.ProductID;
try
{
//Initializing Aggregate Dependency; Item dependant on File and Key
AggregateCacheDependency aggregateDependency = new AggregateCacheDependency();
aggregateDependency.Dependencies.Add(new FileDependency("C:\\tempProductList.txt"));
aggregateDependency.Dependencies.Add(new KeyDependency("Product:1001"));
//Inserting item with AggregateCacheDependency
cache.Insert(key, product, aggregateDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch (OperationFailedException e)
{
// handle exception
}
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item


Topic: Apply Configuration

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Apply Configuration

Settings of a cache can be changed while it is stopped. For these settings to be successfully configured, it is important to apply configuration as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to apply the configuration settings.
  • Click on the Apply Configuration option in the right click context menu.
Your changes will be applied on all of the nodes of this clustered cache.
  • You can also apply configuration using tool bar buttons in the manager.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Hot Apply Configuration | Reset Configuration | Data Load Balancing


Topic: Apply and Reset Configuration

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Apply and Reset Configuration

This section explains how to apply and reset configurations of a bridge. Steps are given below
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • From the right click context menu, select Apply Configuration to apply the changes and Reset Configuration if you want to restore the old settings of a bridge.
See Also
Add a Bridge Node | Remove a Bridge Node | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: ASP.NET Session Monitoring Using Custom Dashboard

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

ASP.NET Session Monitoring Using Custom Dashboard

Using NCache Monitor you can also monitor the ASP.NET session counters. Currently you can monitor the ASP.NET Requests/sec, ASP.NET Pending Requests and ASP.NET Total Session counter in NCache Monitor. Controls for these counters exist in Toolbox under Cache Client category.
Just drag and drop these controls in a custom dashboard, and NCache Monitor starts fetching the values of these counters.
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Caches Using NCache Monitor | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring NCache


Topic: ASP.NET Output Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

ASP.NET Output Cache

NCache provides extremely fast and reliable output caching feature for ASP.NET applications running in web farm environment, where regular output caching fails. Once a page is rendered by any of the web server in the web farm, it is available to all other servers due to clustered cache created by NCache. Your cached pages are highly available because clustered cache gives no single point of failure. This section explains how to use ASP.NET Output Cache feature in NCache.
In This Section
Overview
Explains the concept of ASP.NET View State caching, the downsides of using it and how NCache's View State caching resolves these issues.
Using ASP.NET Output Cache
Explains how to use ASP.NET Output Cache feature in NCache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

ASP.NET's output caching system caches the different versions of pages’ content depending on the various parameters e.g query string parameters, browser type etc. In ASP.NET 4.0, an extensibility point has been added that helps developers use any other caching system of their choice other than ASP.NET’s cache. NCache’s output cache provider is derived from System.Web.Caching.Output CacheProvider to get benefited from ASP.NET 4.0 output caching extensibility.
Since the enterprise level applications are typically hosted in multi-sever web farms, InProc output caching does not provide much benefit as compared to have a distributed OutProc cache. Using this extensibility feature of ASP.NET 4.0, NCache now has its own ASP.NET output caching provider.
  • Distributed in Nature: NCache Output Cache provider is OutProc as well as distributed in nature.
  • Availability: Using NCache’s Output Cache provider, content of different ASP.NET pages can be cached on multiple servers instead of caching them in each of the ASP.NET worker process separately. This allows each server in a web farm to share a single distributed cache.
  • Reliability and Fault Tolerance: Unlike ASP.NET’s output cache, content cached in NCache’s output cache provider is not lost when a worker process crashes or when IIS application pool is recycled.
  • Scalability:, NCache Output Cache provider is not restricted to the memory available on each server as the cache cluster can grow dynamically
  • Output Cache with Custom Hooks: NCache output cache provider gives extra control by allowing the users to hook their custom code to modify the cache item’s attributes before it is cached. Since the ASP.NET output caching system does not give any out of the box mechanism to specify cache dependencies, these hooks can be used to add cached items with the dependencies information. These dependencies can be key, file or database dependies As in most of the enterprise applications, a page or control’s output usually depends on some data in the database. In such applications, the user would want to keep an output of a page or control cached until the data gets changed in the database on which this page’s content depends. Similarly, the user may want to change the expiration time for certain pages at runtime overriding the default expiration given in configuration settings. All this can be achieved by writing a custom hook by implementing IOutPutCacheHook interface. These hooks can be implemented, configured and deployed without making any changes to the applications code. All that is required to configure and deploy is to modify the application’s web.config file.
  • No Application Code Change: These hooks can be implemented, configured and deployed without making any changes to the application’s code. All that is required to configure and deploy is to modify the application’s web.config file.
See Also
Using ASP.NET Output Cache | ASP.NET Sessions | ASP.NET Sessions | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations


Topic: ASP.NET Sessions

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

ASP.NET Sessions

You can quickly use clustered sessions in your existing ASP.NET applications without any code change and can immediately see a performance boost in your application. NCache provides high performance in-memory ASP.NET session clustering for web farms that is faster and more scalable than storing them in a database. It is faster because sessions are kept in memory and closer to the ASP.NET application. And, it is more scalable because sessions can be distributed to multiple servers in the farm that can better handle larger load than a database server.
With NCache, you can eliminate the need to use sticky sessions in your load balancer. This significantly improves your application scalability. NCache provides powerful dynamic clustering of sessions. You can replicate or distribute/partition sessions either locally on multiple web servers or on multiple dedicated session caching servers. NCache offers a rich set of features to grow you session clustering from small to large web farms.
In This Section
Overview
Explains the benefits of NCache based Session State Store Provider.
Using NCache Session State Store Provider
Explains how to configure and use NCache Session State Store Provider.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview
This feature is available only for .NET Framework version 2.0 and later.
ASP.NET Session State allows to store session data into custom data source by implementing SessionStateStoreProviderBase class. A session state store provider has been implemented using NCache to store data
into distributed cache.
NCache based Session State store provider has the following benefits:
  • No Code Change: NCache Session State provider can be used in an application without any code change.
  • Better Performance: Session data being stored in in-memory cache yields maximum performance.
  • Reliability: By default session is stored in memory of ASP.NET process. If process recycles or application server goes down, session data is lost. With NCache, session data is stored, outside of ASP.NET process, in cache cluster. Any cache topology can be opted to meet the needs of reliability. So in case the application server goes down, session data remains available when ASP.NET process recycles back or application server comes back.
  • No Need of Sticky Sessions: Using NCache session state provider will eliminate the use sticky sessions in load balancer.
  • NCache Cache Storage- Scalability: NCache session state provider uses NCache cache as storage, here cluster cache can be used to gain better scalability. Working with it allows adding more servers to session cluster at runtime; it results in more scalability and reliability for the application. ASP.NET session clustering for web farms is faster and more scalable than storing them in a database.
  • Availability, Load Balancing, Fault Tolerance: In web farm environment it provides better fault tolerance, keeping session data available at all server nodes in cluster cache to better handle larger load because sessions can be distributed to multiple servers in the farm. Thus it is safe to say that it results in a high performance. It is suitable for session clustering from small to large web farms.
  • Cluster Topologies: For session cache, different clustering topologies can be used. Replicated topology offers load balancing of client so that the web application does not suffer during intensive traffic. If partitioned-replica cache is used, it gives high scalability, high reliability to the application and is extremely fast. Sessions can be replicated or distribute/partitioned either locally on multiple web servers or on multiple dedicated session caching servers. For cache topology details, see section Cache Topologies .
  • Serialized Data: Session data needs to be in seralizable form.
  • Session Lookup in Cache Made Easy: All session data in cache can be retrieved in a single call. NCache provides tag with session, in one single operation all session data with tag can be easily fetched.
  • Exclusive Locking: To avoid deadlock and data integrity issue, exclusive locks are provided in NCache session state provider. Locking is configurable and in default is off.
  • Locking Release Retry: If exclusive lock is used, locking retries are also configured. In case of concurrent requests, lock release is tried a configured number of times.
  • Location Affinity: NCache’s session state provider's Location Affinity manages ASP.NET session state across multiple web farms which are geographically separated. For Location Affinity, one 'primary' and one or more 'secondary' caches have to be specified for each web farm. The primary cache will be used for all local traffic, in local region and secondary cache(s) are of distant geographical regions. These are configured in web.config. This optimization is possible only in .NET 2.0 and later versions.
See Also
Using NCache Session State Store Provider | View State Caching | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations


Topic: Asynchronous Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Asynchronous Operations

NCache supports both synchronous and asynchronous operations. This sections explains how to use asynchronous operations API provided by NCache to utilize notifications that arise as a result of add, insert or remove operations against all or selective cache items, or when cluster status changes.
In This Section
Overview
Explains the basic concept, need and the benefit of using asynchronous operations.
Using Asynchronous Operations
Explains how to perform different asynchronous operations on cache using NCache Client API.


Topic: Auto Start Cache at Boot

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Auto Start Cache at Boot

You can automatically start cache(s) at system startup. By default, Auto-start cache option is off. You can enable/disable this option by one of the following ways.
Using NCache Manager
  • In NCache Manager see under Main tab and select the option Auto start this cache on service startup. Select this option for each cache you want to automatically start at NCache service startup. This is the recommended way for enabling auto-startup option.
  • After configuring you have to Apply Configurations as well. See how to apply .
Through config.ncconf
You can enable\disable auto start cache option from config.ncconf file.
By default auto-start tag is "False". In order to enable this option, set this tag to "True" for each cache you want to automatically start on service startup.
auto-start="True"
Moreover, you can add some delay time in auto-startup. To add delay time you have to add following tag in NCache service config file. Value is specified in minutes.
<add key="NCacheSrver.AutoStartDelay" value="5"/>
Whenever NCache service will be restarted, all caches which are set to auto start will automatically start after specified delay time interval.
Restart NCache Service after adding AutoStartDelay tag.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Cache Server Backward Compatibility

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Server Backward Compatibility

NCache provides backward compatibility protocol for its older clients. NCache 3.8 onward versions will give you the facility to work with your older clients without re-deploying or re-referencing them with upgraded servers. Backward compatibility will be for onward versions only, any client earlier than 3.8 will not be supported by this protocol. With this feature a client should work with both an older and an upgraded version of the server; otherwise with each updates on server, clients are supposed to be upgraded accordingly.
Upgrading a server for new version involves adding new features of NCache while the existing features remains unchanged. For example an upgraded server can only add new features without changing the older ones. In this way it will not break the compatibility with its older clients.


Topic: Using Basic Cache Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Basic Cache Operations

NCache provides a very user friendly API for performing basic cache operations This section explains how to perform these operations on cache. They include:
  • Initialize Cache
  • Add/Update Data to Cache
  • Fetch or Remove Data from Cache
  • Dispose Cache
In This Section
Initialize Cache
The cache needs to be initialized before performing any other operation on it. This section explains how to use NCache Client API for initializing cache.
Add/Update Data to Cache
Explains how to add or update any data on cache using NCache Client API.
Fetch Data from Cache
Explains how to retrieve data from cache based on different criteria using NCache Client API.
Remove Data from Cache
Explains how to delete data from cache using NCache Client API.
Dispose Cache
Explains how to destroy the cache instance once you are done using it.


Topic: Binding Client/Server with a Dedicated IP

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Binding Client/Server with a Dedicated IP

Client/Server can also be bound with a dedicated IP address. This can be done as folloes:
Using NCache Manager
  • Right click on a server IP address under Server Nodes in Cache Explorer and click on Select Network Interface Card option.
  • Available Network Interface Cards dialog will open. It will contain all network cards available on that node with drop down list. By default IP is used for both client-server and inter cluster communications.
  • Select Client/Server option from drop down in front of the IP with which you want to bind the client and server.
  • Click Apply.
  • NCache will ask for confirmation to apply configuration and restart service. Click Yes.
This restarts the NCache service to use the selected IP addresses for the client/server communication.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Binding Cluster with a Dedicated IP


Topic: Binding Cluster with a Dedicated IP

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Binding Cluster with a Dedicated IP

A cache cluster can be bound with a dedicated IP address in the following way:
Using NCache Manager
  • Right click on a server IP address under Server Nodes in Cache Explorer and click on Select Network Interface Card option.
  • Available Network Interface Cards dialog will open. It will contain all network cards available on that node with drop down list. By default, IP is used for both client-server and inter cluster communications.
  • Select the Cluster option from the drop down list in front of the IP address with which you want to bind the cluster.
  • Click Apply.
  • NCache will ask for confirmation to apply configuration and restart service. Click Yes.
This restarts the NCache service to use the selected IP addresses for the specified communication (inter-cluster).
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Binding Client/Server with a Dedicated IP


Topic: Binding Cluster and Client/Server with a Dedicated IP for Performance

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Binding Cluster and Client/Server with a Dedicated IP for Performance

NCache provides you with the opportunity to bind cluster, client/server or both (cluster and client/server) with dedicated IP addresses. Binding cluster and client with different dedicated IP addresses is only useful if server machine have multiple addresses.
In This Section
Binding Cluster with a Dedicated IP
Explains how to bind cache cluster with a dedicated IP address.
Binding Client Server with a Dedicated IP
Explains how to bind Client/Server or both with a dedicated IP address.


Topic: Blocked Node Communication due to Firewall

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Blocked Node Communication due to Firewall

Sometimes a cluster can not be formed, or cluster nodes are unable to communicate with each other. It may happen when Server and Cluster ports are blocked by firewall. Following error messages can occur in this case.
Error: "No server available to process request"
or
Error: "Unable to communicate with server node"
Workaround
  • If cluster is not formed, make it sure that Server port, at which NCache Service starts and accepts different client connections, is not blocked by firewall. Default value of this port is '9800'. You can change the default value from Alachisoft.NCache.Service.exe.config file.
  • If nodes in a cluster are unable to communicate, please see if your firewall is allowing the Cluster port. Cluster port is a port at which nodes in a cluster communicate. You can change the default value of these ports from NCache Manager. If you have specified a port range in NCache Manager, unblock all ports in range.
  • If NCache Manager is unable to connect with NCache Service, even when it is started, then your system firewall might be blocking Service port. Unblock Service port from system firewall.
See Also
Configuring Ports | Multiple Network Cards | Compact serialization exception | Out of memory problem | Unable to apply configurations or start cache due to disabled netwrok card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other
Send comments on this topic .


Topic: Configuring Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Bridge
This feature is not available in NCache Express and Professional edition.
Bridge configuration file contains information regarding all registered bridges. It is installed with NCache and is located at "%Install Directory%/NCache/config". bridge.ncconf is used whenever you add an existing bridge in NCache Manager. All bridge related configurations are stored in a single bridge.ncconf file. User can change the configuration of a bridge either from NCache Manger or from bridge.ncconf file.
Bridge.ncconf file is explained below:
<bridge-config id="b1799_AP" bridge-nodes="20.200.20.35,20.200.20.32" num-bridge-nodes="2" bridge-active="20.200.20.35" bridge-port="10029" opt-timeout="60" src-cache="" topology="active-passive" replicator-virtual-queue-size="10MB">
Bridge-config Id: Is the bridge identifier. Bridge cache will be known by whatever name you will specify here. This is the same name as you specify while initializing bridge.
Bridge-nodes: IP's of Server nodes involved in making up of this bridge.
Num-bridge-nodes: Number of servers involved in making up of the bridge node.
Bridge-active: This represents the active node in the bridge.
Bridge-port: Port number on which the bridge is hosted.
Opt-timeout: (Operation Timeout) Timeout time after which the bridge will consider itself disconnected from the connected cache(s).
Topology: Specifies which topology does the bridge follow, it can be either one of the following as provided by NCache:
  • Active-Active Topology
  • Active-Passive Topology
  • Hub-Spoke Topology
  • Star Topology
Replicator-virtual-queue-size: It is the size of a virtual queue for the replicator that replicates data from bridge to target cache.
<log enabled="True" trace-errors="True" trace-notices="False" trace-warnings="False" trace-debug="False"/>
NCache maintains a log file to write traces for information and debugging purpose. NCache is providing different type of traces as shown in the above xml tag. Using these tags user can enable\disable the various traces. By default only “Error” trace is enabled, rest of the traces are disabled. Error trace does not affect the cache performance but for other traces we recommend not to enable them in a production environment as they affect the performance of NCache. Here log files for each cache will be created at "%Install Directory%/NCache/log-files" location which contains information related to the enabled traces.
<queue optimized="False" size="500"/>
Size: Specifies the upper limit of queue size in MB. The amount of items in queue is limited by the maximum queue size and amount of free memory.
<perf-counter enabled="True"/>
Perf-counter: It is used to enable Performance counters.
<cache cache-id="replicated cache" status="active|passive" servers-list="20.200.20.35, 20.200.20.20" bulk-operation-size="500" enable-compression="False" connection-retry-interval="3" clear-target-cache="True" heart-beat-enabled="True" replicator-virtual-queue-size="10MB"/>
</bridge-config>
Cache-Id: Is the cache identifier.
Status: Is the status of the cache connected to the bridge. It can either be an active or passive depending on the selected topology.
Servers-List: Server nodes comprising up of the cache clusters.
Bulk-operation-size: Specify an upper limit on the size of the bundled operation that is to be replicated on target cache.
Enable-compression: To enable compression while sending operations on its Target Cache.
Connect-retry-interval: Specifies interval between the two consecutive retries to connect with target cache, if not already connected.
Clear-target-cache: If "true" it will clear the target cache on bridge service startup.
Replicator-virtual-queue-size: It is the size of a virtual queue for the replicator that replicates data from bridge to target cache.
See Also
Cache Config | Configuring Security | Client Side Configuration Files | Configure Basic Cache Settings | Configure Bridge Settings Using NCache Manager


Topic: Bridge Configurations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Bridge Configurations

NCache Bridge provides two kinds of bridge configurations:
1. Active-Passive Configuration
This configuration is mostly used for creating backups for disaster recovery. In this configuration, there is an active site, a bridge and a passive site. Operations are replicated to the passive site from the active site through bridge. No requests are directed to the passive site. Bridge is created at the active site to reduce bridge replication cost from source to bridge.
If the active site goes down by any cause, the client requests can be transferred to passive site by making it active. The passive site will now behave as active and treat all requests without any request failures.
When the old active site is ready and restarted, reform the configurations same as before. Both sites should be active to transfer all the data from old passive to old active site. When data transfer is complete, make configurations to the passive site and redirect all requests to active site.
2. Active-Active Configuration
This configuration is used when there are active data centers in two regions and the need is to synchronize caches between those regions. The bridge has active sites on both its ends. Client requests are treated by all sites so replication is bidirectional. Operations are replicated from any one site to other site. Bridge can be created on any of the two sites since both of them are active. In most of the cases, the bridge resides in the region of that site which has higher user traffic to reduce bridge replication cost.
Since communication is between two active caches, so it is a possibility that the same cached data is updated on both sites simultaneously. This causes a conflict in the cache item’s value. To resolve this conflict, NCache provides a Conflict Resolver which resolves operation conflict on bridge time. It is quite possible that these two active sites reside in two different time zones. To address the conflict of time, both caches synchronize their time with bridge time. When an operation conflict occurs, the bridge time stamp is used to figure out which operation is the latest. By default, the latest operation wins and is applied on cache in case of a conflict. The users can also customize conflict resolver by providing their own implementation.
If any site goes down, then all the requests can be redirected to other active sites. When the site which was down goes up again, data is transferred from the already running site to this site and that region's requests are redirected again to this site.
Runtime Transfer Data
Data can be transferred from one site to another forcefully if there is a chance that both caches are not synchronized. For example, if a two node partitioned cluster cache is being used on both sites and at one site, one node of the cluster cache goes down, then data on that node will be lost. In such a situation, data can be forcefully transferred from the other site to this cache through bridge.
This feature can be enabled through Force State Transfer provided in NCache Manager.
Runtime Switching Between Configuration Modes
Switch can be made between active and passive mode of any site at runtime. This means that active-passive configuration can be changed to active-active configuration whenever needed without any downtime. This is useful when the load is increased on a site for some duration of time. In that duration, the user might want to use the passive site as active site for load distribution and better performance.
Connect/Disconnect Bridge Caches
The cache can be easily connected or disconnected from bridge at runtime without affecting client requests in terms of replication of data. When a cache is disconnected from bridge, then bridge does not send any operation to that cache for replication. Other active cache also does not replicate its operation to bridge. When the disconnected cache connects to the bridge again, all data replication is resumed again through bridge in the same manner as done before. Disconnecting a cache does not mean that cache is stopped. Client activity on both caches remains the same and only bridge replication is stopped.
See Also
WAN Replication Through Bridge Overview | Bridge Conflict Resolver | Configuring Bridge for WAN Replication | Creating Caches | Configuring Cache Cluster Settings | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Bridge Conflict Resolver

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Bridge Conflict Resolver

In bridge topology, there can be more than one active site cache and cache operations can be simultaneous. It is possible that the client connected with one active site cache adds some keys and the same key operation is performed by the other active node. In such a situation the bridge conflict resolver comes into play. It resolves the conflicts and decides which key to apply on the cache depending upon the defined rules.
If user hasn't configured any conflict resolver rules, then NCache uses the default resolver rule. In the default rule, a timespan is added with each operation performed on the cache and it keeps the latest operation. A check is performed on the version of the bridge item. If it has a newer time stamp or if the version is the latest or the same it replaces that with the new entry and in case of old, it keeps the old entry.
Using Bridge Conflict Resolver
Namespace
For enabling Bridge Conflict Resolver, your program needs a reference to the assembly Alachisoft.NCache.Runtime.dll that contains interface Alachisoft.NCache.Runtime.Bridge.IBridgeConflictResolver provided by NCache. The class implementing this interface allows framework to resolve the conflict between existing operations and operation replicated from bridge to cache. Thus, the class needs to include the logic for Conflict Resolution between bridge and cache.
Following namespace is required in your project for using IBridgeConflictResolver:
using Alachisoft.NCache.Runtime.Bridge;
IBridgeConflictResolver Interface:
In order to use IBridgeConflictResolver in your application, implement the following interface:
public void Init(System.Collections.IDictionary parameters);
public ConflictResolution Resolve(ProviderBridgeItem oldEntry, ProviderBridgeItem newEntry);
public void Dispose();
Method
Description
void Init (IDictionary parameters)
This method performs tasks like allocating resources, acquiring connections etc. When cache is initialized and Conflict Resolvers is enabled, Init method is called to notify the client that cache is initializing and the client can initialize its conflict resolver via Init. The parameters passed as an argument contains all the parameters (if any) that were specified using NCache Manager cache/cluster views. These parameters can be utilized in many ways.
void Dispose();
This method performs tasks like releasing the resources etc. When Cache is stopped or the task is completed, it calls the Dispose() method to notify the client that it can now free the resources related to its task.
ConflictResolution Resolve (ProviderBridgeItemoldEntry, ProviderBridgeItemnewEntry);
This method contains the logic to resolve the conflict occur while replicating an operation from bridge for a key that already exists in the cache. Whenever any conflict occurs, cache call BridgeConflictResolution to decides which operation to apply on the cache depending upon rules implemented in it. It takes two parameters/entries, both are of ProviderBridgeItem type. ProviderBridgeItem contains the following parameters:
· BridgeItemVersion contains version of an item (LATEST, OLD, SAME).
· Key contains key of an item.
· Value of an item contains value of an item.
· BridgeItemOpCodes contains conflicted operation (Add, Remove, Update, Clear, RemoveGroup,RegisterKeyNotificationetc) .
Implementing Bridge Conflict Resolver
Here is a sample implementation for IBridgeConflictResolver:
public class Resolver : Alachisoft.NCache.Runtime.Bridge.IBridgeConflictResolver
{
//
// If true, logs will be generated
//
private bool _enableLogging;
private TextWriter _textLogger;
public void Dispose()
{
if (_enableLogging)
{
_textLogger.WriteLine("Closing logger");
_textLogger.Close();
}
}
public void Init(System.Collections.IDictionary parameters)
{
//
//Initialize textWriter
//
if (parameters.Contains("logging"))
{
_enableLogging = Convert.ToBoolean(parameters["logging"]);
}
if (_enableLogging)
{
_textLogger = new StreamWriter("bridgeResolverLog.txt");
_textLogger.WriteLine("Initializing bridge Conflict Resolver");
}
}
public ConflictResolution Resolve(ProviderBridgeItem oldEntry, ProviderBridgeItem newEntry)
{
ConflictResolution conflictResolution = new ConflictResolution();
switch (oldEntry.BridgeItemVersion)
{
case BridgeItemVersion.OLD:
{
conflictResolution.ResolutionAction = ResolutionAction.ReplaceWithNewEntry;
}
break;
case BridgeItemVersion.LATEST:
{
conflictResolution.ResolutionAction = ResolutionAction.KeepOldEntry;
}
break;
case BridgeItemVersion.SAME:
{
if (oldEntry.OpCode == BridgeItemOpCodes.Remove)
{
conflictResolution.ResolutionAction = ResolutionAction.ReplaceWithNewEntry;
}
else
{
conflictResolution.ResolutionAction = ResolutionAction.KeepOldEntry;
}
}
break;
}
if (_enableLogging)
_textLogger.WriteLine("Resolve Key {0} and decision taken {1}", oldEntry.Key, conflictResolution.ResolutionAction.ToString());
return conflictResolution;
}
}
See Also
WAN Replication Through Bridge Overview | Bridge Configurations | Configuring Bridge for WAN Replication | Creating Caches | Configuring Cache Cluster Settings | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Bridge Connection Settings

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Bridge Connection Settings

Every bridge cache opens a unique port for communication with other bridge nodes. The settings for this connection can be configured as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Main tab.
  • Change the Bridge Port. Make sure that your newly provide port is not already in use of any other application.
  • Click on the Bridge Caches tab.
  • Change the Connection Retry Interval, which suites your environment (according to WAN latency).
  • Right click on the bridge name in Cache Explorer and select Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Bridge Management

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Bridge Management

You can manage a bridge using NCache Manager. It allows to you to perform different management operations, e.g., add, remove etc, on a bridge. This section states how to perform different management operations on a bridge.
In This Section
Add a Bridge Node
Explains how to add a node to a bridge.
Apply and Reset Configuration
Explains how to apply and reset configuration.
Remove a Bridge Node
Explains how to remove a node from a bridge.
Start Bridge
Explains how to start a bridge.
Stop Bridge
Explains how to stop a bridge.
Remove Bridge
Explains how to remove a bridge.
Start Bridge Service
Explains how to start bridge service on a bridge node.
Stop Bridge Service
Explains how to stop bridge service on a bridge node.
Restart Bridge Service
Explains how to restart bridge service on a bridge node.


Topic: Overview of Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview of Bridge

Remote data replication is a critical component for any plan to ensure effective and efficient protection and rapid recovery from a major interruption. Synchronous replication of data is good internally for the cluster but its impact on performance becomes a significant consideration when two clusters of cache are geographically separated. Bridge topology is designed for the scenarios which involve replication of data from one on-site cache to one/multiple and on-site/off-site disaster recovery cache(s) across the WAN. Due to asynchronous replication, all clients connected to the active cache(s) get an impression that the operations are being performed on the active cache while a complete backup is taken to the other cache(s) seamlessly.
When an operation is performed on source cache, it is asynchronously handed over to the bridge cache. This operation is then enqueued to a queue maintained by the bridge cache. Operations from the queue are transferred to the other cache(s) when bridge finds the cache(s) available and ready to accept operations. With the bridge topology, it is ensured that:
  • There is no performance degradation.
  • Operations are performed in same sequence as they were on original cache.
  • Operations are not lost in case of connection failure.
Below are the main bridge topologies provided by NCache:
  • Active-Passive (one Active and one Passive Cache)
  • Active-Active (two Active Caches and no Passive Cache)
In This Section
Active-Passive Bridge Topology
Explains what is meant by Active-Passive Bridge topology provided by NCache.
Active-Active Bridge Topology
Explains what is meant by Active-Active Bridge topology provided by NCache.


Topic: Bridge Queue Size

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Bridge Queue Size

Bridge stores the received data/objects in cache queues. You can modify (increase or decrease) these queues’ size using the following method:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Main tab.
  • Increse or decrease the Queue Size according to your requirements.
  • Right click on the bridge name in Cache Explorer and select Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Browse Bridge Statistics

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Browse Bridge Statistics

To view statistics of a bridge, follow the steps given below.
  • Right click on the bridge name under the Bridges tree node in Cache Explorer to bring up context menu.
  • Click on the Statistics option. It opens statistics tab for this bridge in the right pane.
  • You can also choose the Statistics in New Window option from the right click context menu. It opens statistics for this bridge in a new window instead of a tab.
See Also
Configuring Bridge for WAN Replication | Configuring Bridge Counters to Display | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Logging


Topic: Bulk Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Bulk Operations

Bulk operations are used to add, insert or remove collection of items in a single method call. It helps speeding up the process and minimizes cluster traffic. This sections explains the basic concept of bulk operations and describes how to perform different bulk operations on a cache using the Bulk Operations API provided by NCache.
In This Section
Overview
Explains the basic concept of bulk operations.
Using Bulk Operations
Explains how to perform different bulk operations on cache using NCache Client API.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

There are scenarios when it is more feasible to fetch/update cache data in bulk. For example, an application can load customer information in bulk in the start. Bulk operations are desgined to get better performance as they are executed as a single operation on the server. Retrieving 100 cache items in a single bulk operation performs many folds faster than retrieving them through 100 individual Get calls.
Failures in Bulk Operations: Although bulk operation executes as a single operation, failure of operations constituting the bulk operation are treated individually, e.g., if a bulk add operation is performed with 100 cache items and 20 cache items already exist in the cache, then only those 20 cache items will not be added to the cache. The remaining 80 cache items will be added to the cache. Bulk operation returns a dictionary of failed operations.
Avoiding Large Bulk Operation: There is no limit on how many operation can be combined in a single bulk operation. But it is recommended to avoid larger bulk operations as it can raise the memory usage on both applications and cache servers due to serialization/desrialization of large amount of cache data in a single cache operation request/response.
How Bulk Operations Work
Bulk operations behave in different ways for different topologies. Therefore, in the following paragraph, topology specific working of bulk operations is discussed.
  • For Mirror and Replicated Cache
In mirror topology, there is one active node and one passive node. The client only communicates with active node, while passive node is the replica of active and is used for backup facility. In replicated topology, there are more than two nodes and all of them are active. So write operations are performed in parallel on all these nodes.
Bulk operations in these topologies, are sent to the specific node where the client is connected. Thus the bulk operation boosts performance by decreasing network trips to remote server.
  • For Partitioned and Partitioned-Replica Cache
Bulk operations are optimized in case of partitioned or partitioned-replica topology. In these topologies, the key-distribution map is maintained to distribute keys over multiple nodes. On the client side, this map is used to optimize bulk operations.
When data is updated or fetched; bulk operation bundles the collection of key-value pairs based on the key-distribution map. These bundles are sent to particular nodes on remote server. On getting a response, bulk operation merges these responses and return the accumulative result to the client application. Thus, optimizing the operations and increasing the performance of application.
See Also
Using Bulk Operations | Add/Update Data to Cache | Fetch Data from Cache | Remove Data from Cache | Asynchronous Operations | Cache Topologies


Topic: Bulk Size for Operation Replications

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Bulk Size for Operation Replications

Replication can be controlled or throttled according to the underlying network performance to boost the bridge replication performance. These settings can be configured as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Bridge Caches tab.
  • Increase or decrease the Bulk Operation Size on this tab.
  • Right click on the bridge name in the Cache Explorer and select Apply Configuration option.
See Also
Performance Counters | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Cache Client

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Client

Cache clients are light weight modules through which cache applications can connect to hosted caches servers.
TCP Based communication: Cache client connects to the cache server using TCP sockets. Cache client opens a persistent connection with the cache server so when it is disconnected due to network failure, it always reconnects with the cache server.
No Change in API: For both local and remote connections, API for cache operations does not change.
Data Serialization: Data to be added needs to be serializable, serialization is performed in cache client.
Data Compression: Compression is configurable. If enabled, serialized data is compressed in cache client.
Data Encryption: Encryption is also configurable. If enabled, data is encrypted after compression in cache client. NCache supports AES and 3DES encryption.
Request Timeout: Timeout for synchronous cache operations like Add/Insert can be configured, if no response is received within configured time, exception will be thrown. Default operation timeout is 60 seconds. This request timeout should always be higher than cluster operation timeout.
Cache Server Information: Cache clients require server information in order to establish connection. This cache server information can be provided in two ways, either through CacheInitParams or through client configurations (client.ncconf).
Add/Remove Node: If any node is added or removed in cache cluster, cache client will also add/ remove server information to its server list. In case of fail over, client will automatically connect to the newly joined node.
Fail Over: In case a server goes down, cache client seamlessly establishes connection with the next available server. if none of the server is available, e.g., due to network failure, cache client keeps on trying to establish connection with the server in background. When a server again becomes available, it immediately connects to it and application can resume its activity with the cache. In partition and partitioned-replica cache topology, cache client maintains connection with every cache server. In case cache client is unable to connect with some of the server(s), it executes cache requests through other available cache servers. Meanwhile, it keeps trying to establish connection with the server in background.
Connection Retry Interval and Retry Count: When an application executes any cache operation through cache client and no connection is available, then cache client tries to establish the connection. The connection establishment process tries to establish connection for a configurable number of retries. The interval between two consecutive retries can be configured. Meanwhile, application thread waits for connection establishment. When retires are over and cache client is unable to connect to any of the cache servers, then application request is considered as failed and an exception is thrown to the client application.
Load Balancing: Cache client is topology aware and it behaves according to topology. In replicated cache cluster, clients are load balanced among cache servers, if any node joins/leaves the existing replicated cluster, load is re shuffled.
Awareness of Data Distribution: In partition and partitioned-replica cache, client is aware of data distribution and establishes connection with all cache servers.
Advantages of Data Distribution Approach:
  1. Operation is one hop which results in higher throughput
  2. Cache requests are truly balanced among cache servers and no single server is overwhelmed.
Compatibility between NCache and JvCache: NCache and JvCache are fully compatible with each other, NCache cache client can communicate with JvCache Sever and JvCache client can communicate with NCache server.
See Also
Creating Caches | Configuring Cache Clients | Cache Topologies | Cache Cluster | Local Cache | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing


Topic: Cache Cluster

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Cluster

A cache cluster is a set of interconnected server nodes forming a cluster of servers which behave as a single cache unit from outside. Cache clusters are usually preferred in scenarios where performance and scalability are needed. With additions of more server nodes in a cluster cache, more storage space and high availability of cached data can be gained for large applications.
Fault Tolerance: Due to their interconnected nature, cluster caches can tolerate runtime failure of any node in the cluster. In cluster topologies where replica of each server node is maintained on other node, if any node failure occurs, data can be resumed from replica which provides high fault tolerance and availability without affecting any client request.
Runtime Scalability: Cluster caches are horizontally scalable in terms of server node any time. Server nodes can be added or removed even at runtime whenever needed without losing data and downtime.
Single Unit View to Clients: While knowing the fact that there are many peer to peer server nodes in one cache cluster, cache client views the cache as a single unit. It doesn’t matter if any server node is removed or added to the cache, cache client deals with the cache in a homogenous manner. Connections are established with other running nodes at runtime.
TCP Based Connection: All server nodes in a cache cluster are connected through a highly reliable TCP based channel. TCP based connections use combination of IP and Port for forming and differentiating a cache cluster.
Coordinator: The first or senior most running node of the cluster is declared as coordinator node. A coordinator node has the ownership of controlling the management of membership across the cluster.
Cluster Messaging: Each server in the cache cluster can send message to any or all servers in a cache cluster. Messages can be sent in broadcast, multicast or unicast mode.
Data Distribution Strategy: Data distribution in cache cluster is done according to specified topology of the cluster, e.g., in partitioned cache, data is distributed among each partition.
Retries on Connection Breakage: Cache cluster has the ability to tolerate connection breakages for shorter period of time. If any connection breakage between server nodes occurs, then retries for establishing connection are done for configured amount of time.
Leave Detection: Cache cluster is flexible in terms of adding and removing server nodes. It can detect at runtime when any node leaves the cluster by heart beat mechanism without affecting cache clients.
Message Nagling: Message nagling is used to get the best performance over the TCP connections. This means that the cluster tries to avoid the network trip for each single message, instead it combines multiples messages together. This option is configurable through NCache service exe configuration.
See Also
Creating Cache Clusters | Configuring Cache Cluster Settings | Cache Topologies | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing


Topic: Cache Counters

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Counters

NCache publishes different counters for monitoring purposes. It published its performance counters through perfmon. It also publishes some counters for debugging purposes. You can monitor NCache counters for a specific cache on any windows machine using both windows perfmon tool and monitor.
In This Section
Performance Counters
Explains NCache performance counters and how to view them.
Debugging Counters
Explains NCache debugging counters and the way to to view them.


Topic: Cache Dependencies

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Dependencies

Through Cache Dependencies, the dependency of cached items on files, database table rows and other cached items can be implemented. This sections explains this concept and its API.
In This Section
Overview
Explains what is meant by Cache Dependency and the types of dependencies provided by NCache.
Using Cache Dependencies
Explains how to use Cache Dependencies through NCache Client API.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

The data in cache can have dependency relations with items like a file on some location, a record in a database, results of a particular query or another cached item; such that any change in the item can invalidate the data in the cache. In that case, all dependent data must be reloaded or removed from cache otherwise data will become stale.
Expiration in Clustered Environment
In a clustered cache environment where multiple caching servers are involved, expiration is handled differently in various NCache topologies. In replicated cache, expiration is performed by coordinator node and operation will be then synchronized to other clustered nodes. In partitioned cache, as data is distributed on separate nodes, each node is responsible for its own items expiration. For partitioned-replica topology, expiration will be performed on active nodes and propagate to their respective replicas. Similarly in mirror active node will perform expiration and synchronies it on passive node.
Key Dependency
There are situations when it is important to maintain a relationship among the related cache data. For example, if item B depends on item A thenin such situations, item B has to be removed if A no longer exists in cache. Here, key dependency can be used to maintain the relationship.
Key dependency creates a dependency relationship between cached items. For example, a key dependency can be specified on customer's data while putting his order's data. In this way, if customer is removed by the application or expired, then NCache will remove the order data too.
In NCache, the dependent items and the cache items on which they depend upon, both are aware of this relationship. So when an item on which other items depend is removed either by the application or by expiration, all the dependent items will also be removed. However vice versa is not possible i.e. on removal of an item, say Y, which has dependency on any other item, say on item X, the item X will not be removed.
A cache item can have dependency on any number of other items in the cache. For example, an item A may depends on item X, Y and Z. Similarly an item to which other depend upon can also depend on other cache item i.e. item X may depend on Y while items A and B depends on X. In short cascaded dependencies are allowed to nth level e.g. an item A depends on item B and B depends on item C then removal of C will result in removal of B and then C.
Cyclic key dependency is not supported i.e. Item A depends on Item B and B depends on A. Or A depends on B and B depends on C and in turn C depends on A.
Cache Synchronization Dependency
Cache synchronization dependency is provided by NCache to synchronize two separate caches; so that an item updated or removed from one cache have the same effect on the synchronized cache. For example, you can have a local cache that keeps the items frequently being used by your application and a clustered cache that keeps a larger number of items being shared with other applications. Let’s say this local cache is synchronized with the clustered cache to improve performance and avoid data integrity issues. Cache synchronization dependency synchronizes these two caches using item level notifications provided by NCache. Whenever an item is updated or removed from one cache, a key based notification is fired to the other cache in order to synchronize data in both caches.
Notification Based Database Dependencies
Now-a-days, most of the applications that heavily use database calls are incorporating distributed caching to cache expensive queries result set which helps to boost application performance. Caching the result set improves both the performance and scalability of the application. For this purpose, the user would like that whenever any data changes occur in the database, cache data should be invalidated and removed from cache. NCache provides a mechanism where data can be invalidated when changes occur in the database in real time. For this purpose, notification based database dependencies are provided in NCache.
How It Works: In this type of database dependency, NCache uses data change notifications provided by databases servers to invalidate cache data. SQL server(2005 and 2008) and Oracle (10g or later) provides an event notification mechanism where the distributed cache like NCache can register itself for change notification through SqlDependency/OracleDependency. NCache receives notifications from database whenever underlying data changes occurs in the database. This allows NCache to immediately invalidate or reload the corresponding cached item and this keeps the cache always synchronized with the database.
Database Dependency Using SQL Server
NCache provides SqlCacheDependency for notification based dependency with SQL Server database. Internally NCache use SqlDependency provided by .NET framework to register data change notifications with SQL Server. Hence the limitations and working mechanism of SqlDependency while using this dependency needs to be understood. For example, a limited set of queries can be registered with SqlDependency. See Special Considerations Using Query Notifications and SqlDependency class for more detail.
Database Dependency Using Oracle
Similarly NCache provides OracleCacheDependency for notification based dependencies with Oracle. Internally NCache use OracleDependency to register data change notifications with Oracle database server. Hence the limitations and working mechanism of OracleDependency while using this dependency need to be understood. For example, a limited set of queries can be registered with OracleDependency. See Special Considerations Using Query Notifications and OracleDependency class for more detail.
Notification based dependency is the best option while using queries with comparatively less data changes or when a large amount of data dependencies are not involved. As notification based dependencies involve notifications to invalidate data so it can be very intensive in term of resource usage at database end. It should be carefully selected in case of creating large amounts of data dependencies as database servers need to monitor each dependency separately to track any data changes related to it. This may consume a lot of resources and hence put burden on the database servers in terms of memory and processing.
Also, database servers mostly fire separate events for each data change and NCache responds to these events accordingly. Large amounts of these events can easily overwhelm the network traffic and the overall performance of client application and NCache servers.
To avoid this, other options like polling based database dependency provided by NCache or writing a CLR/Java procedure that communicates with NCache to invalidate cache items can be used. For this, a CLR/Java stored procedure needs to be created that connects with NCache and updates or invalidates the cached item. This procedure can be invoked on update or delete trigger of the table. In this way, data changes can be monitored and can be directly replicated to cache. This approach is more efficient as data base server do not need to monitor data changes by creating data structures related to SqlCacheDependency. And, it also does not fire .NET events to NCache. Instead, it open up an NCache client connection and directly tells NCache whether to invalidate a cached item or reload it. And, this connection with NCache is highly optimized and much faster and lighter than .NET events.
Polling Based Database Dependencies
NCache supports another database dependency called polling based dependency which is basically designed to work on large scale. Notification based dependency only works with database server which provides support for data change notifications i.e. either with SQL Server(2005 or above) or Oracle (10g or later). Whereas polling based dependency also works with other databases which do not provide data change notifications support. Also, notification based dependency
is not as much resource efficient as polling based for using it on large scale.
In polling based dependency, a table named ncache_db_sync needs to be created in database which is used by NCache to synchronize the database with cache store. Also, UPDATE and DELETE triggers needs to be created for every table on which notification is required. These triggers will be scripted to invalidate corresponding cache keys in this table in case of data change.
When an item is added to the cache with dependency, a row will be created in this table for this cache key as shown:
In case of data change in table, corresponding triggers will set modified flag to true. On Cache clean up interval, NCache polls ncache_db_sync table for modified keys, collects them, sets their work in progress flag to true and finally removes all corresponding keys from cache. After successfully removing keys from cache, all those rows where work_in_progress flag is set to true are removed from the 'ncache_db_sync' table.
In a clustered cache, if a node crashes while it was removing items from the cache, the next node in the cluster will again start the process.
File Dependency
NCache supports Database dependencies (explained later on in this chapter) to invalidate cache data when data changes occur in relational database management systems (RDBMS). On the other hand, file dependency provides a mechanism to invalidate the cache data in case of non-relational data sources.
Here you can associate a file/folder dependency with a cache item. Whenever that file/folder is removed or modified, NCache will remove its dependent item from cache. Cache clean up (expiration) thread monitor the dependent file/folder for any change at every Clean Interval.
On cache clean up interval NCache will triggers dependency in the following scenarios:
  • Dependency file/folder is removed/modified.
  • Dependency file is replaced with directory and vice versa.
  • Dependency is created on non-existed file/folder, but on clean up interval it is created.
Similarly multiple items can depend on a single file. Any change in file either by updating file or deletion causes cache to remove the dependent items from the cache. Also an item can create dependency on multiple files in file dependency.
A delay called "start after" can be mentioned in file dependency which indicates when to start monitoring the dependent file for any change. In this way NCache will start checking the dependant file after the "start after" time elapsed.
Custom Dependency
NCache provides flexible ways to determine data invalidation using various dependencies. However the users can implement their own custom logic for dependency if none of the built in invalidation strategy suits their environment. For example, a custom dependency can be implemented which makes call to a web service for the validation of data.
In custom dependency, a custom logic can be defined which specifies when a certain data becomes invalid. For this purpose, NCache provides an abstract class ExtensibleDependency. To write a custom logic, all that’s needed is to inherit the custom dependency class from this class and override its HasChanged property. Like expiration, cache clean up thread periodically calls HasChanged property of custom dependency and if it returns true, item is removed from the cache.
Aggregate Cache Dependency
NCache also allows using different strategies in combination with the same cache data in the form of Aggregate Cache Dependency. Aggregate Cache Dependency allows associating multiple dependencies of different types with a single cached item. For example, a key dependency and file dependency can be associated with an item using aggregate dependency and data will be invalidated which ever dependency triggers first.
Aggregate Cache Dependency associates one cached item with a collection of dependency objects which can be any other dependency provided by NCache e.g. CacheDependency, DBCacheDependency or any combination of these. The AggregateCacheDependency monitors a collection of dependency objects so that when any of them changes, the cached object becomes obsolete and is removed from the cache.
Combining different invalidation strategies provides you more flexible ways to meet your application needs in different environments.
See Also
Using Cache Dependencies | Custom Dependency | Event Notifications | Data Invalidation Strategies | Server Side API Programming


Topic: Cache Level Data Event Notifications

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Level Data Event Notifications

Cache Level Data Notifications
Cache Level Notifications are fired when data is added in cache from clients, loader, read-through etc. Cache Level Data Notifications can be used to share data across different clients. The purpose of this feature is to notify clients about every operation performed on cache [add, insert, remove]. Clients that want to receive these notifications will have to register Cache Level Notification through RegisterCacheNotification API. Using this feature, the performance of cache will be a little low because cache has to send notifications to clients interested in notifications. Cache Level Data Notifications can be used in scenarios where the user wants to remain updated about every operation on cache.
Using Cache Level Events
By default they are disabled (except for Cache Cleared) for any cache configuration and must be enabled for events to be published.
The client application that is supposed to receive events must include the specific event handler method to respond to the event(s) raised. Whenever events are raised, the target event handler method executes the entire code written in the method body.
Client application is not able to receive events unless it registers itself again cache via specific event registration API call.
  • Registering Cache Level Events
Cache Level notifications are generic events which will be triggered upon every execution of the appropriate registered event type. To register these events for notification, RegisterCacheNotification method is used.
Appropriate EventType to be registered needs to be specified; single as well as multiple event types can be specified in a single method call. Also EventDataFilter needs to be specified to quantify the amount of information returned upon an event execution.
EventDataFilter must be carefully set to avoid unnecessary network bandwidth consumption.
Every target method returns a key and a CacheEventArgs object which contains information according to the data filter.
// Register target method
CacheDataNotificationCallback dataNotificationCallback = new CacheDataNotificationCallback( OnCacheDataModification);
try
{
// Register cache notification with appropriate event type
CacheEventDescriptor EventDescriptor = cache.RegisterCacheNotification(dataNotificationCallback,
EventType.ItemAdded | EventType.ItemRemoved | EventType.ItemUpdated,
EventDataFilter.None);
// Save the event descriptor for further usage
}
catch(Exception ex)
{
// handle exception
}
// Create a target method
static void OnCacheDataModification(string key, CacheEventArg args)
{
switch(args.EventType)
{
case EventType.ItemAdded:
//perform appropirate operations
break;
case EventType.ItemRemoved:
//perform appropirate operations
break;
case EventType.ItemUpdated:
//perform appropirate operations
break;
}
}
  • Unregistering Cache Level Events
A previously registered cache level notification can also be unregistered using the UnRegisterCacheNotification method. In this example, the EventDescriptor previously returned upon registering of event, needs to be specified.
try
{
cache.UnRegisterCacheNotification(EventDescriptor);
}
catch(Exception ex)
{
// handle exception
}
See Also
Event Notifications Overview | Item Level Data Event Notifications | Custom Events Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming


Topic: Cache Server Configurations in Service Config File

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Server Configurations in Service Config File

Client/Server TCP Port
Client/Server TCP Port in service config will specify the port at which Cache Server will listen for incoming connection requests.
<add key = "NCacheServer.Port" value = "9800"/>
Enable License Logging
Enable License Logging in service config will specify whether this service will log license information for clients or not.
<add key = "NCacheServer.LicenseLogging" value = "false"/>
Bind Multiple NIC's
When your machine has more than one network cards, you can inform NCache which interface to use for cluster-wide communication. In order to do so, provide IP Address you want the cluster server to bind with in service config.
<add key = "NCacheServer.BindToClusterIP" value = "20.200.20.39"/>
You can follow the above procedure for client communication. Provide the IP Address you want the client's (NCache client) server to bind with.
<add key = "NCacheServer.BindToClientServerIP" value = "20.200.20.39"/>
Auto Start Cache on Reboot
You can configure caches to start with the start of NCache service. As, by default NCache service starts at the system startup so these settings are useful incase you want some caches to auto start at the system startup.
<add key = "NCacheServer.AutoStartCache" value = "mycache,myreplicatedcache,mypartitionedcache"/>
<add key = "NCacheServer.CacheUser" value = "domain/userId"/>
<add key = "NCacheServer.CachePassword" value = "password"/>
Enable Debug PerfMon Counters
Some performance counters are disabled by default but they can be really helpful to see NCache behavior over the network. These counters include:
  • Socket send time (time taken for the last send operation)
  • Socket receive time (time taken for the last receive operation)
  • Bytes sent/second
  • Bytes received/second
  • Naggling message count (number of messages bundled together in the last socket send operation)
  • TcpUpQueueCount: Number of items in TCP up queue.
  • TcpDownQueueCount: Number of items in TCP down queue.
  • BCastQueueCount: Number of items in BCast Queue.
  • MCastQueueCount: Number of items in MCast Queue.
These counters help find the source of the problem incase we see the cluster is not performing as expected.
<add key = "NCacheServer.EnableDebuggingCounters" value = "true"/>
Configure Expiration Cleanup
Expired items are removed in bulk. Specify the size of the bulk operation i.e. how many items should be removed in one bulk operation.
<add key = "NCacheServer.ExpirationBulkRemoveSize" value = "10"/>
Expired items are removed in bulk. This may affect the performance of user operations during expirations. This delay specified (in milliseconds) causes a delay between two consecutive bulk remove operations.
<add key = "NCacheServer.ExpirationBulkRemoveDelay" value = "0"/>
Configure Eviction Cleanup
During eviction items are removed in bulk. Specify the size of the bulk operation i.e. how many items should be removed in one bulk operation. EvictionBulkRemoveSize should be specified in multiple of 300.
<add key = "NCacheServer.EvictionBulkRemoveSize" value = "10"/>
During eviction items are removed in bulk. This may affect the performance of user operations during expirations. This delay specified (in seconds) causes a delay between two consecutive bulk remove operations.
<add key = "NCacheServer.EvictionBulkRemoveDelay" value = "0"/>
Configure Windows Events Logging
CacheSizeThreshold is the size of cache in percentage of total cache size. When this threshold is reached a warning message is logged into system event log. No warning message is logged if the following line is commented.
<add key = "NCacheServer.CacheSizeThreshold" value = "80"/>
CacheSizeReportInterval is the interval in minutes during which CacheSizeThreshold warning is issued once. If cache size falls below CacheSizeThreshold due to eviction and again crosses the CacheSizeThreshold limit during this interval no warning is generated. The minimum value is 5 minutes.
<add key = "NCacheServer.CacheSizeReportInterval" value = "15"/>
Enables/Disables the logging of client connectivity events into event viewer. By default these events are disabled.
<add key = "NCacheServer.LogClientEvents" value = "false"/>
Specifies the level of events which are logged into event viewer. There are three levels of events
  • Error : Only errors will be logged
  • Warning : Errors and Warnings will be logged
  • All : all events will be logged
<add key = "NCacheServer.EventLogLevel" value = "all"/>
Configure .NET Garbage Collection
Enables/Disables forced garbage collection when using Server GC. Applicable on server operating systems only. Possible values are 'true' or 'false'. If value is true, a forced GC.Collect( ) is called after system memory usage reaches a specific threshold. This threshold is specified under property 'NCacheServer.ForcedGCThreshold'. Default value for this property is 'true'.
<add key = "NCacheServer.EnableForcedGC" value = "true"/>
%age Memory usage threshold that is used to call forced garbage collection. This property depends on property 'NCacheServer.EnableForcedGC'. If the property is set 'true', given threshold value is used to call explicit Garbage collection. Default value is 80. This implies that an explicit GarbageCollection should be called when system memory usage reached 80% of the total memory.
<add key = "NCacheServer.ForcedGCThreshold" value = "80"/>
Value of seconds after which service should check if it needs to do a forced garbage collection. This property dictates how frequent you want to check if a forced Garbage Collection is required or not. Default value is 20 seconds. Minimum possible value is 5 seconds.
<add key = "NCacheServer.ForcedGCInterval" value = "20"/>
Configure SQL Dependency
SQL Dependency can be used in two modes i.e. Default mode or Custom mode. In default mode, SQL Dependency creates a default service and queue at run time. In case of Custom mode, a customer defined SQL Dependency service and queue will be created and used by NCache. In this case, NCache will connect with the pre-created service and queue with following naming convention:
  • "NCacheDBService-[IP-Address]"
  • "NCacheDBQueue-[IP-Address]"
You can change the SQL Dependency service and queue name prefix by specifying it against the NCacheServer.NCacheDBService key/NCacheServer.NCacheDBQueue key.
<add key = "NCacheServer.NCacheSQLNotificationService" value = "NCacheSQLService"/>
<add key = "NCacheServer.NCacheSQLNotificationQueue" value = "NCacheSQLQueue"/>
Configure Response Data Size
NCache introduces "Response Data Size" to limit the large result sets returned in response to bulk Search, Tags and Groups operations. .NET framework does not support the serialization of large result sets which exceeds the size of 1.9Gb. To solve this problem NCache splits the large result sets into smaller chunks of data.
NCacheServer.ResponseDataSize can be used to specify the size of a response. It will help in limiting a response size by dividing the bigger response into multiple responses each containing the data approximately equal to the specified limit. These multiple responses will be merged by the NCache Client as a single response. Here it takes value in MB’s. Default size is 1024MB.
<add key = "NCacheServer.ResponseDataSize" value = "1024"/>
At least one object must be sent in response even if the data size of an object exceeds the specified limit for data.
Configure Max Response Length
NCache introduces "Max Response Length" to limit the large result sets returned in response to all operations whether bulk or not .NET framework does not support the serialization of large result sets which exceeds the size of 1.9Gb. To solve this problem NCache splits the large result sets into smaller chunks of data.
NCacheServer.MaxResponseLength can be used to specify the size of a response. It will help in limiting a response size by dividing the bigger response into multiple responses each containing the data approximately equal to the specified limit. These multiple responses will be merged by the NCache Client as a single response. Here it takes value in KB’s. Default size is 512KB.
<add key = "NCacheServer.MaxResponseLength" value = "512"/>
At least one object must be sent in response even if the data size of an object exceeds the specified limit for data.
Configure Enumeration
The purpose of introducing enumeration is to keep cache free from locking while enumerating the cache data. This process eventually increases the cache performance and its availability for clients. NCache is following the technique of taking snapshots of cache data and send it to the client for enumeration which keeps the cache free from being locked during the process of enumeration. Four attributes are defined for enumeration, which are:
NCacheServer.SnapshotPoolingCacheSize can be used to specify the size of the cache (in terms of number of items) for enabling enumeration on cache. It will help in deciding whether to create a pool of snapshots for enumeration or not. A complete snapshot of cache is returned to the enumerator until the threshold reaches its limit. Once the threshold value is crossed, cache will create a pool of snapshots that will hold those snapshots based on time slicing. These snapshots will be provided to the enumerator on demand from client by the cache server. Default Size is 100000 items in cache.
<add key = "NCacheServer.EnableSnapshotPoolingCacheSize" value = "100000"/>
NCacheServer.SnapshotPoolSize can be used to specify the number of snapshots allowed in the pool for enumeration. Once the pool reaches its maximum limit, it won’t allow more snapshots to be added to the pool. It will wait till any existing snapshot in the pool has been removed. Default Size is 10 snapshots in cache snapshot pool.
<add key = "NCacheServer.SnapshotPoolSize" value = "10"/>
NCacheServer.SnapshotCreationThreshold can be used to specify after how many seconds a new snapshot will be added to pool for enumeration purpose. Same cache snapshot from the pool is provided to all enumerators on cache until the threshold time is elapsed. Any enumerator that requests a snapshot after that will get a new snapshot from the pool. Default size is 30 seconds.
<add key = "NCacheServer.SnapshotCreationThreshold" value = "30"/>
NCacheServer.EnumeratorChunkSize can be used to specify the chunk size for enumeration. Chunk size is the number of cache items returned to the enumerator from cache server. Once the enumerator is done enumerating through a chunk of data it will get the next chunk from the cache server for enumeration. Default size is 1000 items returned in each chunk.
<add key = "NCacheServer.EnumeratorChunkSize" value = "1000"/>
Cache Startup Loader Delay
User can introduce a delay in Cache Startup Loader in order to avoid some data loss problems which may occur while the cache is still in process of member joining. This is done by setting the following property:
<add key = "NCacheServer.CacheLoaderStartupDelay" value = "20"/>
The value of this property is set in seconds. By default, this value is 20 while minimum value is 10 seconds.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Configuration Files


Topic: Cache Size

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Size

Through this configuration option, you can specify an upper limit on the size of the cache in MB. The number of items in the cache are limited by maximum size of the cache and amount of free system memory (virtual or physical). If some eviction policy is specified, whenever total data size in cache reaches maximum size or when less than 10% of memory is left in the system, items are removed from the cache as per eviction policy. Maximum size of a cache can be specified by one of following two ways.
Using NCache manager
Default cache size is 250 MB but it can be changed as follows.
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Main tab.
  • Change the Cache Max. Size as per your needs.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
The size of the cache is also specified at the time of creating cache using S option in the definition using command line tool as follows.
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createcache.exe, provide the required information:
createcache.exe Cache /s test1 /S 250
  • Hit ENTER key, it will create Cache of local topology of size 250mb on test1 node. Here, instead of 250, any size can be mentioned.
Through Config.ncconf
You can specify the cache max size through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<storage type="heap" cache-size="250mb"/>
</cache-config>
See Also
Creating Caches | Configuring Isolation Levels | Configuring Expiration Clean Up Interval | Cache Management Operations | Monitoring Cache Operations


Topic: Cache Startup Loader

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Startup Loader

This section is a practical guide for programmers who want to utilize powerful features of Server side NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
Overview
Explains the concept of Cache Startup Loader.
Using Cache Startup Loader
Explains how to use this Cache Startup Loader to preload cache with data as it starts up.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

NCache provides Cache Startup Loader through which cache can be preloaded with data as it starts up. This is useful for applications which depend on certain data and that data should be available to the application immediately after it begins executing. . For example, a video streaming site could have hundreds or thousands of videos at the beginning, and later new videos could be added on the server. For such an application, cache can be preloaded with existing videos on cache startup instead of manually adding the data in it.
To configure cache startup loader, CacheLoader interface provided by NCache needs to be implemented and then deployed using manager. NCache will use that custom provider to load data from the configured data source. Cache can be preloaded by loading data in it either at once or in chunks. On cache startup, NCache framework will iteratively call LoadNext method of this custom provider until it returns false. In this method, logic to return data at once or in multiple chunks can be implemented. The size of the added chunk in cache from data source can also be controlled. In short, NCache provides with flexible ways to load data into cache.
Cache Loader may fail to load data due to an unsuccessful connection with the data source or if an incorrect index is specified while extracting data from the data source. To identify this, server side cache logs for cache loader must be checked for errors/exceptions.
NCache loads data from data source on cache startup and populate it in cache in a separate thread. In case of clustered cache, only the coordinator node will be responsible for loading items in cache. If a node crashes or gets gracefully down while cache loader is in progress, then the next node will be responsible for initiating the cache loader from start.
The cache loader process can be delayed for a certain interval through cache loader start up delay configuration. By default its value is 20 seconds and it can be changed by providing NCacheServer.CacheLoaderStartupDelay key along with its value in NCache service XML file.
See Also
Using Cache Startup Loader | Configuring Cache Start-Up Loader | Data Source Provider (Backing Source) | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Cache Topologies

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Topologies

Caching topology defines the strategy for data storage in a clustered cache. It refers to the behavior of cache cluster under different scenarios. These behavior specifications help in choosing the cache topology which suites best to an
application’s environment.
NCache provides the following set of topologies for cluster caches.
  • Mirrored Cache (Two-Server Active/Passive)
  • Replicated Cache
  • Partitioned Cache
  • Partitioned-Replica Cache (Asynchronous and Synchronous)
Reference Data VS Transactional Data:
Cached data can be differentiated into two broad types i.e. Reference and Transactional. Reference refers to the type of data that has a high ratio of reads than writes e.g. product catalog prices may change after one or few days . On the other hand, transactional refers to the data that has almost the same ratio of reads and writes e.g. each ASP.NET
Sessions is updated with all the activities of each application user.
In This Section
Mirror Cache
Describes mirror cache and its main features.
Replicated Cache
Describes replicated cache and its main features.
Partitioned Cache
Describes partitioned cache and its main features.
Partitioned-Replica Cache
Describes partitioned-replica cache and its main features.


Topic: Caching Concepts

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Caching Concepts

This section explains basic caching concepts that will help you understand NCache in a better way.
In This Section
Caching Topologies
Explains what is a caching topology. It also discusses the four types of cache topologies in NCache.
Cache Cluster
Explains the concept of cache cluster and its main features.
Local Cache
Explains local cache and its two isolation levels.
Cache Client
Explains the concept of cache client and its basic features.
Client Cache
Explains cache client and its main features.
Data Load Balancing
Explains the concept of data load balancing and the two load balancing options that NCache provides.
Client Backward Compatibility
Explains the concept of client backward compatibility.
Eviction
Explains the concept of eviction and different options for eviction provided by NCache.
Indexing
Explains different type of indexing provided by NCache.
Runtime Data Sharing
Explains the concept of runtime data sharing in distributed caches.
Portable Data Types (.NET & JAVA)
Explains data types portablity feature provided by NCache.
Class Versioning
Explains the concept of class versioning provided by NCache.
Graceful Node Down
Explains the graceful node down feature provided by NCache to avoid losing any background operations.
IP Binding
Explains the concept of IP Binding provided by NCache.


Topic: Caching Topologies

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Caching Topologies

A caching topology is essentially data storage strategy in a clustered cache. NCache provides a rich set of caching topologies to let you choose the one that suits your environment best. The goal of this is to cater from very small two-server caches to very large cache clusters consisting of hundreds of cache servers. Below are the main caching topologies provided to you:
  • Mirrored Cache (2-server active/passive)
  • Replicated Cache
  • Partitioned Cache
  • Partitioned-Replica Cache (Asynchronous and Synchronous)
  • Client Cache (a Local Cache connected to a Clustered Cache)
A short explanation of each of these caching topologies is given below.
Reference Data versus Transactional Data:
Reference data use means you cache something once and read it over and over again. So, there are a lot more reads than writes. On the other hand, transactional data use means that you're updating the data as frequently as you're reading it (or fairly close to it). Originally, cache was considered good only for reference data but distributed caches have proven to be faster and more scalable than databases even for transactional data.
Caching a product catalog where prices change maybe once a day or so is reference use. On the other hand, ASP.NET Session State and JSP Servlet session storage is considered a transactional use.
All topologies are good for reference data but only some topologies are good for transactional data. You need to determine how many updates you'll be doing to figure out which topology is best for you. Below is a list.
Mirrored Cache
A Mirrored Cache is a 2-server active/passive cache cluster. In mirrored cache there is one active and one passive node only and no client can connect with passive unless it is active. Primarily passive node is used to keep asynchronous backup of data. A mirrored cache has no clustering cost, besides it gives data reliability through backup. By default, ImportHashmap flag will be false as in this topology client is not aware of data distribution between servers.
  • Reference data : Good. Max 30000 reads/sec (1k size).
  • Transactional data : Good. Max 20000 writes/sec (1k size).
Replicated Cache
A Replicated Cache consists of two or more cache servers in a cluster (there is no limit for number of nodes however, recommendation is for maximum three). It is suitable for situations where transactional data usage is lesser than reference data usage. Performance can slow down in transactional data because updates are applied synchronously on all the other servers in the cluster. Moreover, performance can diminish when more nodes are added in cluster. By default, ImportHashmap flag will be false.
  • Reference data : Good. 30000 reads/sec per server. Grow linearly by adding servers.
  • Transactional data : Not so good. Max 2500 writes/sec. Drops if you add 3rd server.
Partitioned Cache (no replication):
A Partitioned Cache is intended for larger cache clusters as it is a very scalable caching topology. It is suitable in cases where performance is your major concern but without reliability of data. If any cache server goes down, data will be lost of that node as there is no replication/backup of data. Client gets connected with each server and request is sent to the targeted server only because client is aware of data distribution flanked by servers. By default, ImportHashmap flag will be true as client is data aware.
  • Reference data : Good. 30000 reads/sec per server. Grow linearly by adding servers.
  • Transactional data : Good. 25000 writes/sec per server. Grow linearly by adding servers.
Partition-Replica Cache (with replication):
Partitioned-Replica topology is combination of Partitioned topology and Replicated topology. It gives high performance with Reliability of data through replication and scalability through partitioning. It is suitable in cases where performance is major concern without fear of data loss. Partitioned-Replica provides both sync and async replication whereas, async replication is the default option. Async replication is quick for the reason that user doesn’t have to wait for operation to be done on replica as well. By default, ImportHashmap flag will be true.
  • Reference data : Good. 30000 reads/sec per server. Grow linearly by adding servers.
  • Transactional data : Good. 20000 writes/sec per server. Grow linearly by adding servers.
There is some overlap between Mirrored Cache and Partitioned-Replica Cache for 2-server clusters because both provide similar performance with replication. But, Mirrored Cache accommodates situations where you only have one dedicated cache server and the mirror server is being shared with other apps. But, if you have a need for 3 or more cache servers, then Partition-Replica Cache is the best choice for transactional use.
It is recommended to create a cache of at least 20% greater size than the actual data size.
For more details, either see Caching Concepts - Cache Topologies or visit Caching Topologies on our website.
See Also
Dynamic Clustering


Topic: Changing Cache Synchronization Modes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Changing Cache Synchronization Modes

The NCache Manager provides the ability to change the synchronization mode of clustered cache connected to the bridge. This can be done by either making an active cache passive or a passive cache active.
In This Section
Making Passive Cache as Active Cache
Explains how to make a passive cache in bridge as an active cache.
Making Active Cache as Passive Cache
Explains how to make an active cache in bridge as a passive cache.


Topic: Changing Management Port of a Cache Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Changing Management Port of a Cache Node

All performance and connectivity related data is fetched using a particular port called NCache Management Port. Default value of this port is 8250 but it is configurable using NCache Manager.
Using NCache Manager
  • Open NCache Manager.
  • Go to Tools menu option.
  • Select Options and a dialog box appear with Statistics, Management and Startup tabs. Go to the Management tab.
  • Type any value within your system’s port range and make sure that the port is free. Click OK.
See Also
Configuring Counters to Display | Fetching the Statistics using Server IP or Server Name | Cluster Health | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches


Topic: Class Versioning (Same Platform)

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Class Versioning (Same Platform)

In a distributed environment, multiple applications are connected with cache. Let’s say client applications need to be upgraded. Now all the applications can’t be upgraded at the same time. Meanwhile if some classes get upgraded in some applications, how can they share data with other old ones? Here comes the concept of Class Versioning.
If a class is serializable and the objects of the class are written to a data source and then later they are read back in, the versions of the objects that were written and read must be the same. If the object of one version of the class is saved in the database and later on that class is changed (new version), then a read operation will read the old version from database.
NCache provides the feature of Class Versioning Compatibility for the same platform. This class versioning feature can be used by configuring it through administrative NCache Data Sharing Tool and providing mapping for attributes with target class.
Class Attributes Mapping
ProductV2 Class (C#) | ProductV1 Class (C#)
ID | ID
name | name
price | price
quantity | quantity
Discount |
In above mentioned table, the attributes of class have been mapped with each other, discount is a new attribute added in product class so it is left unmapped.
Mapping ProductV2 with ProductV1will allow storing ProductV2 and getting it in ProductV1 and vice versa.
NCache uses compact serialization and creates dynamic serialization code for both classes for compatibility and as a result, reduces size of data and boosts performance of client applications.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Portable Data Types (.NET & JAVA)


Topic: Expiration Clean Up Interval

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Expiration Clean Up Interval

Clean interval is the periodic interval after which the expired items are removed from the cache. By default, its value is 15 sec. You can change the it by one of following two ways.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Policies tab.
  • Change the Clean Interval as per your needs.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through Config.ncconf
Clean interval of a cache can also be specified through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<eviction-policy enabled="True" default-priority="normal" policy="priority" eviction-ratio="0.25"/>
<cleanup interval="15sec"/>
</cache-config>
See Also
Creating Caches | Configuring Isolation Levels | Configuring Cache Sizel | Cache Management Operations | Monitoring Cache Operations


Topic: Client Backward Compatibility

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Backward Compatibility
NCache version 3.8 and onwards support this feature.
In context of computing products, new updates and releases are launched very frequently. In these newer versions, it is desirable that it is able to work with older version, it can work with the input generated by an older version.
Here NCache provides backward compatibility for its older clients. If the user upgrades his/her cache server for using new features of version or for some fixes of older version, older clients can communicate seamlessly with newer versions of cache server without re-deploying, upgrading the clients.
Protocol Buffers: For backward compatibility, NCache uses protocol buffers. With these protocols it keeps its structured data in efficient yet extensible formats. Thus by using these protocols, backward client compatibility is ensured and cache clients can communicate with both the upgraded and older version of cache server. In new versions of cache servers, new features are added, existing are updated without breaking the compatibility of older clients.
See Also
Creating Caches | Data Load Balancing | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Eviction | Indexing


Topic: Client Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Cache

A client cache is a local cache synchronized with a remote clustered cache. It always synchronizes with remote cache through notifications that are triggered whenever changes are made into the state of data. Because of synchronized nature of client cache, it provides maximum boost in performance and scalability of application for read operations without compromising data integrity.
Since the client cache resides on the same box where client application is running, it saves the network roundtrip every time data is served from the client cache. Therefore, data retrieval in this case is much faster as compared to fetching the same data from the remote server.
Client cache can either be InProc (resides within the application process) or OutProc (resides locally or on remote box). By default, cache is initialized as OutProc, however, from NCache Manager, it can be configured to start as InProc. Client applications can initialize the cache as InProc by specifying the initialization mode as ‘InProc’ while calling NCache.InitializeCache(). Client cache cannot be directly initiated using Client API Initialize method. It's always used with some remote clustered cache such as Mirrored, Partitioned, and Partition-Replica Cache.
Synchronization Modes
There can be multiple client cache instances running on different client nodes that simultaneously interact with remote clustered caches. Also, client cache has a subset of data residing in remote clustered cache. It means that there is a small window of time for client caches to sync their state. To solve this problem, client cache provides data synchronization with the clustered cache. Data synchronization is performed between client cache and remote clustered cache and is inevitable. Client cache provides two synchronization modes.
  • Optimistic Synchronization
In optimistic mode, application fetches data from client cache despite the fact that data is updated or not. It assumes that data is newer in client cache however, there are possibilities that data may be older than that on the clustered cache because event notifications might not have yet been received during get operations. In optimistic synchronization, updates are propagated to the client cache using event notifications. Synchronization mechanism is explained later in this chapter.
  • Pessimistic Synchronization
Pessimistic mode is used when applications are handling sensitive data. On data fetch request, if data is found in client cache, its version is matched with item on remote cache. If both versions are same, then item is returned otherwise updated item is fetched from remote cache and is updated back to client cache. This is done to make sure that client application always gets the latest data. However, get operations are slower in pessimistic mode than in optimistic, but it ensures data consistency and takes extra care that the retrieved data is always updated. Notification based updates work similar to optimistic mode.
How Client Cache Works
Whenever the client application using client cache adds/updates data into the cache, it's first updated to second level (remote clustered cache) then on the successfully completed operation, data is updated to client cache. Whereas in the case of data retrieval, it's first looked into client cache; if found, the data is returned to client, otherwise it is fetched from the remote cache and inserted into client cache to make it available for next access. By doing this, client cache reduces unwanted trips to clustered cache, thus increasing performance while fetching data. The figure below explains the internal working of client cache for update and fetch operations on data.
Data Synchronization in Client Cache
While an an item is added to client cache, client cache registers an item level notification with the remote server for any updates or removal of that very item. Whenever this item is updated on the server node, client cache receives a notification which then fetches the updated data from remote cache and updates it locally too. This way, it is made sure that client cache is always synchronized with cache servers even when items are being updated from clients running on other machines. The remote servers propagate these changes only to the clients who have shown interest in the specific items instead of propagating these changes to all client caches. This synchronization mechanism is used for both optimistic and pessimistic client cache. The following figure demonstrates data synchronized with clustered cache and client cache.
InProc client cache stores items in object form, therefore if object is modified by the application, it should be updated back to the cache so that other remote clustered cache and other client caches have no data integrity issues.
See Also
Creating Client Cache | Configuring Cache Clients | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing


Topic: Configuring Client Cache Settings

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Client Cache Settings

There are some settings which specific to client cache. These settings can be configured by using the tabs
  • Main
  • Policies
  • Options
on the right side of the manager when client cache is clicked.
This sections explains how to configure some basic settings of the client cache.
In This Section
Configuring Synchronization Mode
Explains how to select the required synchronization mode for the client cache.
Configuring Client Cache Size
Explains how to change the size of the client cache.
Configuring Isolation Level
Describes how to configure the required isolation level (inproc or outproc) for the client cache.


Topic: Client Cache Size

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Cache Size

Size of client cache is also configurable and can be changed as follows:
Using NCache Manager
  • Click on the client cache and go to the Main tab in the right pane. Under this tab, Cache Max. Size can be changed.
  • Right click on client cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Synchronization Mode | Isolation Level | Creating Client Cache | Enable Client Cache


Topic: Client Config

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Config

Client configuration file is used by NCache client API to get initial information for establishing connection with server. It is located at "%Install Directory%/NCache/config". Modules that need to read the configurations, first try to find client.ncconf in application folder. If client.ncconf is not found in application folder, it then reads the configuration from installation folder.
Client configuration file is used by client to connect to out-proc caches. Light weight client also uses this configuration file to connect to the remote caches. This file is automatically generated each time a new cache/cluster is created or cache/cluster configuration settings are applied. Additionally security information can be provided for each cache in this file.
Client configuration file is explained below:
<configuration>
<ncache-server port="9800" client-request-timeout="90" connection-retries="5" retry-connection-delay="0" retry-interval="1" connection-timeout="5" />
<cache id ="myreplicatedcache" client-cache-id="" client-cache-syncmode="optimistic" load-balance="true">
<server name="server-1"/>
</cache>
<cache id ="mypartitionedcache" client-cache-id="" client-cache-syncmode="optimistic"load-balance="true">
<server name="server-2"/>
</cache>
</configuration>
Client-request-Timeout:
Client-request-timeout is the period for which client API waits for a response for a command from the server. After this period is elapsed an "OperationFailedException" is thrown. By default it is 90 seconds and minimum value could be 60 seconds. Time span specified less than minimum value will automatically be reset to minimum value i.e. 60 seconds.
Connection-retries:
connection-retries are the number of retries the client makes on the whole list of servers mentioned in the client.ncconf at the time of connection establishment. It is the same for connection break scenario.
Retry-interval
If connection with cache server is dropped then client tries to reconnect with the server and retry connection delay flag introduces the delay between each retry. Flag is specified in seconds.
Connection-timeout:
connection-timeout is the period threads wait before throwing OperationFailedException during connection-break, while one thread tries to establish connection with cache server. If the connection is successfully established then, all threads will complete their respective operations. Otherwise, they will throw OperationFailedException.
Retry-connection-delay:
retry-connection-delay is the time when client API waits before going through another iteration of connection-retries. Delay is specified in seconds.
See Also
Client Nodes | EFCaching Config | Server Side Configuration Files


Topic: Client Side API Logging

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Side API Logging

NCache Client Side API Logging is a diagnostic feature which logs all NCache API calls made by an application. This is a configurable logging mechanism that creates several log files. The purpose of API logging is to identify which API and the its sequences cause the problem, so that problem can be reproduced easily at user’s end. Client API logging saves appropriate overload of the method called along with key, data size, cache status, encryption and compression information.
API logging has a performance impact it is recommended to enable the logging only for diagnostic purposes.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging | Cache Server Logging | Email Notifications on NCache Events


Topic: Monitoring Client Process of a Cache Cluster Using Custom Dashboard

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Client Process of a Cache Cluster Using Custom Dashboard

Client Process control shows details of running client applications against current cache. Details include client IP, process ID, port, server IP with which this client application is connected and Sent/Received bytes by each client.
Follow the steps given below to add Client Process control in a custom dashboard:
  • Go to the Toolbox, available on the left side inside NCache Monitor.
  • Click on the Cache Server button on the Toolbox.
  • Select the Client Process control; drag and drop it into any cell inside a custom dashboard.
Information of all the currently connected clients displayed in Client Process control for current cache.
  • Client processes can be grouped using any column. Drag and drop a column header on Drag a column header here to group by that column. Below image is an example of grouping by Server IP field.
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring NCache


Topic: Client Side API Programming

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Side API Programming

This tutorial is a practical guide for programmers who want to utilize powerful features of Client side NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
Setting Up Development Environment
Explains the steps to set up the development environment for using NCache API.
Using Basic Cache Operations
Explains how to perform basic operations like initialize, add or remove data etc on cache.
Bulk Operations
Describes performing bulk operations to add, insert or remove collection of items in a single method call. It helps speeding up the process and minimizes cluster traffic.
Asynchronous Operations
Explains utilizing notifications that arise as a result of add, insert or remove operations against all or selective cache items, or when cluster status changes.
Group/Subgroup
Presents distributing related objects in 'logical' groups.
Tags
Explains how Tags work.
Named Tags
Explains how Named Tags work.
Data Invalidation Strategies
Describes how certain cached items can be automatically removed from the cache when required.
Cache Dependencies
Explains how to implement dependency of cached items on files, database table rows and other cached items.
Locking
Describes how to lock cached items to prevent multiple clients from updating the same data simultaneously.
Object Query Language in NCache
Presents search API for querying objects from the cache using SQL like syntax.
Event Notifications
Explains utilizing notifications that arise as a result of add, insert or remove operations against all or selective cache items, or when cluster status changes.
Continuous Query
Explains how Continuous Query work.
Streaming
NCache provides you the facility of Streaming. Using streaming NCache binary data can be read or written from/to the cache using streams.
Security and Encryption
Explains different levels of cache security provided by NCache.
Data Compression
Explains the data compression feature provided by NCache to minimize the data traffic between cluster and client nodes and efficiently using the memory.
NCache Management API
Explains how to use the API provided by NCache to perform the basic cache management operations without using either NCache Manager or NCache tools.


Topic: Client Side ASP.NET Features

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Side ASP.NET Features

This section is a practical guide for programmers who want to utilize powerful features of ASP.NET with NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
ASP.NET Sessions
Explains maintaining and synchronizing session state throughout a server farm using NCache Clustered Session.
View State Caching
Explains how to use View State Caching and content optimization feature of NCache.
ASP.NET Output Cache
Shows how to use output caching to cache the HTML output of dynamic requests to ASP.NET pages, hence speeding up the overall response process.


Topic: Client Side Third Party Integrations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Side Third Party Integrations

This section is a practical guide for programmers who want to utilize powerful Third Party Integrations with NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
NHibernate
Explains how you can plug-in NCache to your existing NHibernate application to use NCache with NHibernate.
Entity Framework Caching Integration
Shows how to plug Entity Framework caching provider with NCache.
Memcached
NCache has implemented Memcached integration and you can plug-in NCache to your existing or new Memcached applications without any code changes.


Topic: Using CLR Procedures to Call NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using CLR Procedures to Call NCache

Database dependencies using SQL server notifications may reduce application's performance as SQL server throws a separate notification for each data update which is then handled by NCache. If there are too many changes being made in database, notifications may overwhelm network traffic, reducing performance of both NCache and user application.
NCache allows you to write CLR stored procedures for database to synchronize cache with the database. CLR procedures does not involve creating dependency data structures like SqlCacheDependency, also no database monitoring or notification mechanism is required. To use CLR store procedures for NCache, follow steps specified below. All example SQL scripts specified are for SQL Server 2008 and .NET framework 2.0.
i. Enable CLR Integration on Database
The user should allow CLR procedures to be executed in database by executing the following query on his/her database:
-- Enable CLR Integration on Database
sp_configure'clr enabled', 1
GO
RECONFIGURE
GO
ii. Register Assemblies with Database
To use NCache in CLR stored procedure, NCache assemblies need to be registered with database. This will enable database to use NCache API in stored procedure.
SQL server does not resolve referred assemblies from GAC, therefore assemblies required by NCache need to be copied in NCache assemblies directory before deploying them on database. Copy these assemblies from GAC to "NCache/bin/assembly/2.0" folder (choose 4.0 if the target platform is .NET 4.0).
  • log4net.dll
  • protobuf-net.dll
  • Oracle.DataAccess.dll
Copy following assemblies from"NCache\bin\IDE\NCache Manager" to "NCache/bin/assembly/2.0"
  • Renci.SshNet.dll
  • SharpSnmpLib.dll
Execute the following query to register assemblies (If NCache install directory is different from used in this query, change path accordingly).
use Northwind
alter database Northwind
set trustworthyon;
go
-- REGISTER SYSTEM ASSEMBLIES ...
dropassembly [System.ServiceModel]
dropassembly SMdiagnostics
dropassembly [System.Web]
dropassembly [System.Messaging]
dropassembly [System.Management]
CREATEASSEMBLY [SMdiagnostics] AUTHORIZATION dbo FROM N'C:\Windows\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation\SMdiagnostics.dll' WITHpermission_set=unsafe
CREATEASSEMBLY [System.Web] AUTHORIZATION dbo FROM N'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.Web.dll' WITHpermission_set=unsafe
CREATEASSEMBLY [System.Management] AUTHORIZATION dbo FROM N'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\System.management.dll' WITHpermission_set=unsafe
CREATEASSEMBLY [System.Messaging] AUTHORIZATION dbo
FROM N'C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.Messaging.dll'
WITHpermission_set=unsafe
CREATEASSEMBLY [System.ServiceModel] AUTHORIZATION dbo
FROM N'C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0\System.ServiceModel.dll'
WITHpermission_set=unsafe
--REGISTER NCACHE ASSEMBLIES ...
CREATEASSEMBLY [Alachisoft.NCache.Web] FROM N'C:\Program Files\NCache\bin\assembly\2.0\Alachisoft.NCache.Web.dll'WITHpermission_set=unsafe
iii. Create and Deploy CLR Stored Procedure
  • Create a SQL CLR database project for your database in Visual Studio as shown below.
  • Add reference to NCache assembly named "Alachisoft.NCache.Web" in project.
  • Add a stored procedure in your project. Write synchronization logic in database. Following is a sample CLR stored procedure which will remove an item if it is updated in cache.
Public partial class StoredProcedures
{
[Microsoft.SqlServer.Server.SqlProcedure]
public static void RemoveOnUpdate(string cacheName, string key)
{
try
{
if (string.IsNullOrEmpty(cacheName))
cacheName = "mycache";
if (!string.IsNullOrEmpty(key))
{
Cache cache = NCache.InitializeCache(cacheName);
cache.Delete(key);
cache.Dispose();
}
}
catch (OperationFailedException exp)
{
//handle exception
}
}
}
  • Deploy stored procedure on database. After deployment stored procedure will appear in database stored procedures, as shown below.
iv. Write Trigger to Call Stored Procedure
Finally a database trigger needs to be written that will call stored procedure created in the previous steps whenever an update or delete is performed on database table. Following is a sample script to create trigger on Product table in Northwind database:
Create TRIGGER [dbo].[myTrigger]
ON [dbo].[Products]
FOR DELETE,UPDATE
AS
Declare @cacheName asnvarchar(4000)
declare @key asvarchar(4000)
select @key=Cast((Deleted.ProductID)asnVarChar)+':dbo.Products', @cacheName='mycache' from Deleted
EXEC dbo.RemoveOnUpdate@cacheName, @key
v. Adding Data in Cache
Following is a sample code that adds an item in cache and updates it in database to verify that item has been removed from cache:
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
try
{
//Cache key should be same as used in trigger
cache.Insert("1:dbo.Products", product);
}
catch (OperationFailedException e)
{
// handle exception
}
//Modifying Product record in database will automatically remove Product from cache
While adding data in cache, cache key format should be same as passed to stored procedure from trigger in database.
See Also
Cache Dependencies Overview | Using SQL Dependency | Using Polling Based Dependency | Using Oracle Dependency | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency


Topic: Cluster Health

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cluster Health

You can view cluster health using NCache Manager. Cluster health shows the connection status of each server in cache cluster. There are three types of Status:
  • Fully Connected: The cache is running and all server nodes are connected with each other.
  • Partially Connected: The cache is running but not all server nodes are connected with each other.
  • Cache Stopped: The cache is running but the server with this status is stopped.
Using NCache Manager
  • Right click on the cache name under Clustered Caches tree node in Cache Explorer view to bring up the context menu.
  • Select View Cluster Connectivity option. Cluster Connectivity dialog box appears.
This screenshot shows the cluster connectivity of a two node clustered cache, one server is running and the other is stopped.
  • Click Close to dismiss the dialog.
See Also
Changing Management Port of a Cache Node | Configuring Counters to Display | Fetching the Statistics using Server IP or Server Name | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches


Topic: Implementing Clusters

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Implementing Clusters

When Implementing Clusters, you may experience some problems. This section provides solutions for some of such troubles.
In This Section
Multiple Network Cards
Tells how to resolve the issue when NCache service may not be able to communicate with other nodes in the cluster if you have multiple network cards installed.
Compact Serialization Exception
Explains various causes of serialization exception.
Blocked Node Communication due to Firewall
Explains ports used by default clusters and NCache service.
Out of Memory Problem
Describes why your system throws out of memory exception and gives workaround.
Unable to Apply Configurations or Start Cache due to Disabled Network Card
Explains problems that arise due to disabled network card and provides solutions.
NCache Manager shows that Both the Nodes in Mirror Cache are Active Nodes
Provides the solution for the problem when both the nodes in a mirror cache appear as active nodes in NCache Manager.
Nodes in a Clustered Cache are not Joining with Each Other.
Provides the solution for the problem nodes in a clustered cache are not joining with each other. Cluster is not formed and cache runs on every node as standalone cache.


Topic: Cluster Port

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cluster Port

Cluster ports are the ports at which NCache clusters start. You can change the default value of these ports from NCache Manager. For installed caches (myReplicatedCache, myPartitionedCache), NCache looks for ports starting from 7800 onwards and allot the available ports to these caches in the available Port Range .
Port of a cluster can be changed in the following ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Change the value of Cluster Port if required.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
Port of a cluster can be changed using config.ncconf as follows:
<cluster-connection-settings cluster-port="8706" port-range="2"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Port Range | Server Port


Topic: Command Line Activation

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Command Line Activation

NCache can also be activated via command line. This will help the users to automate the process of NCache Activation. The tool NActivate.exe is a console application and can be found inside %INSTALLATION_PATH%/NCache/bin/NActivate folder.
nactivate /k R4179Gba-b1f296-78F6U590 /f Paul /l Jones /e paul@alachisoft.com [option[...]]
Argument | Description
/k key | Specifies the license key got from Alachisoft.
/f first name
Specifies the user's first name.
/l last name
Specifies the user's last name.
/e email address
Specifies the user's email address.
Option | Description
/comp[any] company | Specifies the user's company name.
/a address | Specifies the user's address.
/city city | Specifies the name of city.
/s state | Specifies the name of state.
/c[ountry] country | Specifies the name of country.
/z zip | Specifies the postal or zip code.
/p phone | Specifies the phone number.
/nologo | Suppresses display of the logo banner.
/? | Displays command syntax and options for the utility.
Remarks
You must supply the license key that you got from Alachisoft.
Examples
  • The following command activates the NCache on a machine.
nactivate /k R4179Gba-b1f296-78F6U590 /f Paul /l Jones /e paul@alachisoft.com
  • The following command displays command syntax and options for the utility. Logo banner is displayed as a part.
nactivate /?
  • The following command displays command syntax and options for the utility suppressing the display of logo banner.
nactivate /? /nologo


Topic: Command Line Install

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Command Line Install

NCache provides a command line installation that you can either run from a Command Prompt or add to your script files (.bat files). To install NCache form Command Prompt you use the msiexec.exe utility. Below is the syntax for using
msiexec.exe to install NCache.
Install NCache
Msiexec.exe
/I <Installation Package Path>
EDITION ="0|2|3"
KEY ="EVAL_KEY_EMAILED_TO_YOU"
USERFIRSTNAME ="John"
USERLASTNAME ="Smith"
COMPANYNAME ="Alachisoft"
EMAILADDRESS ="john@alachisoft.com"
INSTALLDIR ="<Target Dir>"
SETPERMISSION ="0|1"
/qn
#
Switch/Properties
Purpose
Default Value
01
EDITION
Specifies the installation option. Possible values are
• 0 (Cache Server)
• 2 (Developer)
• 3 (Remote Client)
0
(Cache Server)
02
KEY ( required )
Installation Key must be provided by you. You will receive this via email from Alachisoft when you downloaded NCache. If not, then visit http://www.alachisoft.com/download.html to register and obtain one.
Empty
03
USERFIRSTNAME
Your first name
Empty
04
USERLASTNAME
Your last name
Empty
05
COMPANYNAME
Your company name
Alachisoft
06
EMAILADDRESS
(required)
Your email address
Empty
07
INSTALLDIR
Directory where you want NCache to be installed. Most commonly, this should be "C:\program files\NCache".
Local Directory
08
SETPERMISSION
NCache requires your permission to configure system permissions for PerfMon with NCache. Possible values are
  • 0 (No)
  • 1 (Yes)
1
(Yes)
09
/I <Installation Package Path>
(required)
Path where you have kept NCache.clr20.msi file. You must specify this.
Empty
10
/qn
Quiet mode. If you want to run the install silently without any user intervention, use this switch.
Empty
Examples
Installing a Cache Server:
msiexec.exe /I "C:\NCacheSetup\NCache.clr20.msi" EDITION=0 KEY=INSTALL_KEY_EMAILED_TO_YOU USERFIRSTNAME="John" USERLASTNAME="Smith" COMPANYNAME="Alachisoft" EMAILADDRESS="john@alachisoft.com" INSTALLDIR="C:\Program Files\NCache" SETPERMISSION="1" /qn
Installing NCache on a Developer work station:
msiexec.exe /I "C:\NCacheSetup\NCache.clr20.msi" EDITION=2 KEY=INSTALL_KEY_EMAILED_TO_YOU USERFIRSTNAME="John" USERLASTNAME="Smith" COMPANYNAME="Alachisoft" EMAILADDRESS="john@alachisoft.com" INSTALLDIR="C:\Program Files\NCache" SETPERMISSION="1" /qn
Installing a Remote Client:
msiexec.exe /I "C:\NCacheSetup\NCache.clr20.msi" EDITION=3 KEY=INSTALL_KEY_EMAILED_TO_YOU USERFIRSTNAME="John" USERLASTNAME="Smith" COMPANYNAME="Alachisoft" EMAILADDRESS="john@alachisoft.com" INSTALLDIR="C:\Program Files\NCache" SETPERMISSION="1" /qn
Uninstall NCache
To uninstall NCache through command line, use the following syntax:
msiexec.exe> /x <Installation Package Path> /qn
An example is given below:
C:\> msiexec.exe /x "C:\NCacheSetup\NCache.clr20.msi" \qn
See Also
Getting Started | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Activate NCache Purchased License


Topic: Compact Serialization Exception

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Compact Serialization Exception

Sometimes a Serialization exception may occur on node where Compact Serializable types are not registered.
Workaround
Register Compact Serializable types on all the nodes in the cluster. See Using Compact Types for further information.
See Also
Using Compact Serialization | Multiple Network Cards | Blocked node communication due to firewall | Out of memory problem | Unable to apply configurations or start cache due to disabled network card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

NCache stores application data in serialized form. Data is serialized on cache client before adding it to cache. Therefore data to be added in cache must also be marked as serializable. It supports native binary serialization for both JvCache client and NCache client and it also has its own serialization framework called compact serialization which is fast and compact than native serialization. In native serialization of .NET, all data of an object along with the entire type information is serialized. In this way, size of the object increases, whereas in compact serialization, the entire type information does not travel on the network so the object size which travels on network is reduced. As the object size decreases, network trips become faster and eventually the cost decreases while increasing the overall application performance.
Compact serialization is also binary serialization and has the following benefits:
Compact Data Size
In NCache, binary data size of the serialized object is compact. In certain scenarios data size may be 10 times less than that of native serialization. Smaller serialized objects take less time to travel on the network which results in a higher through put. This also helps in reducing memory consumption on cache’s server. In this manner NCache achieves better performance while reducing time and cost. Small object size and fast network traffic increases the application performance.
Fast
Compact serialization is faster than native serialization as it does not rely as much on reflection as native serialization does. Native serialization uses reflection for attribute information, this reflection is avoided in NCache’s compact serialization, type information for compact types are loaded only once when cache is initialized, which reduces the overhead faced using native serialization. Benchmarks have shown that in certain use cases, it is 5~10 times faster than native serialization.
No Code Change
There is no code change required to make a class compact serializable. The only step required is to configure your classes through management tools. (NCache Manager or command line tools).
NCache 4.3 and later versions allow selective serialization. It allows data members of a class to be mark as non-serializable. Please see administrator’s guide for more details. The excluded attributes’ values will not be serialized. The excluded attribute of any cached object will either be null or will have a default value if assigned. This feature is useful in a scenario where for certain attributes, there is no need for caching, e.g., connection object for database. By this selective serialization the process becomes even more efficient and more compact. For using Compact Serialization, a default public constructor (parameter less) in a compact serializable type must be provided and that type must be registered with NCache Manager.
The interface ICompactSerializable can be implemented which gives a more fine grained control over compact serialization. Through this interface, which data members are to be serialized and which are to be excluded can be controlled.
Support for the compact serialization of Generic Types is also available in NCache. The list of allowed types can be selected and specified either through NCache Manager, or by implementing a generic type handler.
The following points must be considered while using compact serialization.
  • A compact serializable class can have data members of other classes which are native serializable, but are not compact serializable.
  • A class which is only native serializable cannot have data member which are only compact serializable.
  • If your class is native serializable and it has data members which are both native and compact serializable, then native serialization will be used while serializing the object of container class.
If Read/Write-through provider or cache startup loader is configured along with compact serialization, then the assemblies containing compact classes should be deployed along with providers. For example, in a scenario where cache loader is configured, during cache filling, items are fetched from data source. These items are serialized before they are inserted into cache; here for serialization, assembly containing compact classes is required.
An object registered in Data Sharing cannot be registered in Compact Serialization at the same time.
See Also
Using Compact Serialization | Registering Classes for Compact Serialization | Cache Startup Loader | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Troubleshooting Counters

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Troubleshooting Counters

You can receive an error message 'Computer Name Not Found' when trying to monitor a remote server node from a non-administrator account.
Workaround
To enable remote monitoring on server node (Windows NT computer), do the following:
  • Grant at least READ access to the following files:%windir%/system32/PERFCxxx.DAT
  • %windir%/system32/PERFHxxx.DAT
    where xxx is the basic language ID for the system; for example, 009 for English.
  • Grant READ access to the following registry keys on the remote computer: Using REGEDT32, grant the user account at least READ access to HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT/CurrentVersion/Perflib and all sub keys of that key.
  • Using REGEDT32, give the user at least READ access to HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/SecurePipeServers/winreg.
    Please keep in mind that using Registry Editor incorrectly can cause serious system-wide problems that can make you to reinstall Windows operating system. Use this tool at your own risk.
See Also
Diskperf Not Installed | No READ Access to Perflib Subkeys | Unable to Connect to Server Node


Topic: Cache Config

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Config

Cache configuration file contains information regarding all registered caches/clusters. It is installed with NCache and is located at "%Install Directory%/NCache/config". Modules that need to read the configurations first try to find config.ncconf in application folder i.e. along side web.config. If config.ncconf is not found in application folder, it then reads the configuration from installation folder.
config.ncconf file is explained below:
<!--
Configuration file (config.ncconf) contains the details of all the registered caches. All caches configurations are enclosed in <configuration></configuration> tag. Whereas each cache detail is enclosed in <cache-config></cache-config>.
-->
<cache-config name="cachepor" inproc="False" config-id="0" last-modified="" type="local-cache" auto-start ="True|False">
Name: Is the cache identifier. Cache will be known by whatever name you will specify here. This is the same name as you specify while initializing cache.
Inproc: Determine whether the cache will run as in-proc (in your application process) or out-proc (in NCache Service process). If set to "False" cache will run as out-proc or if set to "True" then cache will run as in-proc.
Config-id: Is used to determine whether the configuration is modified or not.
Last-modifed: Contains information related to last modification in cache configuration.
Type: Specifies whether the cache is clustered or local cache. This attribute can any of the following:
  • "clustered-cache" means the cache is any of the clustered cache type. i.e; Partition of Replica, Replicated, Partitioned and Mirror.
  • "local-cache" means the cache is a stand-alone cache.
  • "client-cache" means the cache a Local Cache connected to a Clustered Cache.
Auto-Start: This xml tag specifies the auto start status of cache.
<log enabled="True" trace-errors="True" trace-notices="False" trace-warnings="False" trace-debug="False"/>
NCache maintains a log file to write traces for information and debugging purpose. NCache is providing different type of traces as shown in the above xml tag. Using these tags user can enable\disable the various traces. By default only “Error” trace is enabled, rest of the traces are disabled. Error trace does not affect the cache performance but for other traces we recommend not to enable them in a production environment as they affect the performance of NCache. Here log files for each cache will be created at "%Install Directory%/NCache/log-files" location which contains information related to the enabled traces.
<perf-counters enabled="True"/>
Using this xml tag you can enable/disable the publishing of data as perfmon counters:
Enabled: If this attribute is set to "True" NCache will updated the published perfmon counters. If set to "False" then Ncache will not update any of the published perfmon counter.
<replication-strategy synchronous="False"/>
In case of Partition of Replica the you will find this tag in cache configuration. Replication strategy defines how data is replicated to backup node.
Synchronous: This attribute can be set to True/False. If set to "False" then data operation will be replicated asynchronously on the backup node. If set to "True" then data operation will be replicated synchronously on the backup node.
<compression enabled="False" threshold="500kb"/>
This xml tag specifies whether the items greater then specified threshold should be compressed/decompressed at client side.
Enabled: To enable compression set this attribute to "True" otherwise set it to "False"
Threshold: Item greater than the value specified in threshold attribute will only be compressed/decompressed at client side if compression is enabled.
As per above mentioned compression tag example only item greater than 100kb of size will be compressed/decompressed at client side.
<notifications item-remove="False" item-add="False" item-update="False" cache-clear="False"/>
Notification xml tag specifies the registered event with Cache.
Item-add: This attribute can be set to "True" or "False". If set to "True" will notify when an item is added to the cache and similarly if set to "False" no notification will be fired if item is added in cache.
Item-remove: This attribute can be set to "True" or "False". If set to "True" will notify when an item is removed from the cache and similarly if set to "False" no notification will be fired if item is removed in cache.
Item-update: This attribute can be set to "True" or "False". If set to "True" will notify when an item is updated in the cache and similarly if set to "False" no notification will be fired if item is updated in cache.
Item-clear: This attribute can be set to "True" or "False". If set to "True" will notify when cache is cleared and similarly if set to "False" no notification will be fired if the cache is cleared.
<cleanup interval="15sec"/>
Cleanup xml tag specify the periodic interval after which item for expiration will be checked:
Interval: attribute specify the periodic clean up interval. If set to "15sec" this means the expiration check will be performed after every 15sec.
<storage type="heap" cache-size="250mb"/>
Storage xml tag specifies the storage related details for cache:
Type: this attribute can only be set to "heap" as currently ncache only supports heap based storage.
Cache-size: this attribute specifies the upper limit of cache size in MB.
<eviction-policy enabled="True" default-priority="normal" policy="priority" eviction-ratio="5%"/>
This xml tag specifies whether to perform the eviction or not. If eviction is enabled then cache will remove the existing item to accommodate new ones. Exiting items will be removed based on eviction strategy.
Enabled: To enable eviction set this attribute to "True" otherwise set it to "False"
Policy: attribute the eviction policy to be used. Eviction policy can be one of the following:
  • Lru (Least recently used)
  • Lfu (Least frequently used)
  • Priority based
Default-priority: specifies default priority that is associated with an item if no priority is specified for that item. This attribute can be set to following:
  • High
  • Above-normal
  • Normal
  • Below-normal
  • Low
This is only applicable in case of priority based eviction.
Eviction-ratio: specifies how much percentage of data should be evicted when eviction is performed.
<cluster topology="partition-replica" op-timeout="60sec" stats-repl-interval="60sec" use-heart-beat="False">
This xml tag is used for specifying the in-cluster communication details, it also contains a sub tag, channel, which further defines the communication details of the cluster:
Please Note, this tag will not be present in Local Cache.
Topology: Specifies which topology does the cluster follow, it can be either one of the following as provided by NCache
  • Partition Replica Topology
  • Replicated Topology
  • Partitioned Topology
  • Mirror Topology
Op-timeout: (Operation Time Out) Determines the timeout of a connection among the servers if a server in the cluster fails to respond
Stats-repl-interval: (Statistics Replication Interval) the interval provided to the cluster at which to synchronize their information among its servers
Use-heart-beat: Heart Beat is used to monitor the connectivity between nodes
Active-mirror-node: in Mirror topology, only two server nodes are allowed, of which one is active i.e. the one which handles all the request made by the client, here the ip of the active node is provided
<channel tcp-port="8011" port-range="2" connection-retries="0" connection-retry-interval="0secs" initial-hosts="sanfransisco[8011],sanramon[8011]" num-initial-hosts="2"/>
Channel xml tag specifies the details of port connectivity and and other communication options among the cluster servers:
Tcp-port: connection is channeled through a TCP port, this value defines the port which it occupies
Port-range: when initializing, if the port provided is taken by some other application then it will try to establish its connection on port incremented by 1, for this the range is provided i.e. to what range should it search for an available TCP port
Connection-retries: if connection among the node(s) is failed, then this defines how many retries should be done to consider it a permanent faliure
Connection-retry-interval: the interval between connection retries is defined in this value
Initial-hosts: Specifies the server IPs making up the cluster and with their starting port number
Num-initial-hosts: (Number of Initial Hosts) specifies the number of Server Nodes
<alerts>
<email-notification email-notification-enabled="False" sender="" smtp-server="" smtp-port="0" ssl="False" authentication="False" sender-login="" sender-password=""/>
<alerts-types cache-stop="False" cache-start="False" node-left="False" node-joined="False" state-transfer-started="False" state-transfer-stop="False" state-transfer-error="False" cache-size="False"/>
</alerts>
If Event notifications through email is required then information for its setup is configured here:
Email-notification: contains all the information related to the email address
Email-notification-enabled: enables notification through email
Sender : specify the email account from whom the email notifications are sent
Smtp -server: specify the gateway to send email notifications
Smtp -port: The port number used to forward emails
SSL : (Secure Socket Layer) To enable SSL security
Authentication : If any authentication is required, this is to be True
Sender-login : if Authentication is required, specify the login name
Sender-password : Authentication password is entered here
Alert-Types: Specifies at which event an automated email is to be generated
Cache-stop : if the cache is stopped at any moment
Cache-start : at start of cache, email notification is generated
Node-left : when a server node leaves the cluster or if a server node is inaccessible for any reason, email notification will be sent if this is enabled
Node-joined : At joining of any server node
State-Transfer - started : To notify whenever a state transfer is occurred which happens when Load balancing is performed
Cache-size : whenever cache size is changed (Hot Apply-able)
<sql-dependency use-default="False"/>
This xml tag specifies the queuing and service SQL notification architecture.
Use-default: The attribute can be set to True/False. If the attribute is set to "True" then default SQL Dependency service and queue will be created at run time. If the attribute is set to "False" then the custom define SQL Dependency service and queue will be created and used by NCache.
See Also
Configuring Security | Configuring Bridge | Client Side Configuration Files | Configure Basic Cache Settings


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

This section of the documentation discusses configuration files that NCache provides for client end and server end. This section helps you to understand how to configure these configuration files. All config files are installed with NCache and is located at " %Install Directory%/NCache/config". Five different config files are installed with NCache which are used to configure the client and server end, i.e.
Client End:
  • Client Configuration File (Client.ncconf)
  • EFCaching Configuration File (Efcaching.ncconf)
Server End:
  • Cache Configuration File (Config.ncconf)
  • Bridge Configuration File (Bridge.ncconf)
  • Security Configuration File (Security.ncconf)
Client configuration file is used by NCache client API to get initial information for establishing connection with server. Modules that need to read the configurations first try to find client.ncconf in application folder. If it doesn't fins client.ncconf in application folder, it then reads the configuration from installation folder. EFCaching configuration file contains information regarding Entity Framework provider which helps in integrating NCache with Entity Framework application.
Cache configuration file contains information regarding all registered caches/clusters. It is used to configure all levels of caches. Modules that need to read the configurations first try to find config.ncconf in application folder. If it doesn't find config.ncconf in application folder, it then reads the configuration from installation folder.
Bridge configuration file contains information regarding all registered bridges. The configuration of all created bridges are store in a single bridge.ncconf file. User can change the configuration of a bridge either from settings of the bridge in NCache Manger or from bridge.ncconf file.
Security configuration file keeps security information that is used by a server node for calling clients. Alachisoft.NCache.NCSecurity.dll at server node is required to provide security services to all clients. Whatever information is required by this assembly, for managing security related issues, is present in security.ncconf file.
See Also
Client Config | Efcaching Config | Cache Config | Security Config | Bridge Config


Topic: Configuring PowerShell Environment

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring PowerShell Environment

In order to run the NCache PowerShell scripts, PowerShell V2 or higher must be installed. Also, you need to enable script execution permissions in PowerShell. Here is how you can enable script execution in PowerShell.
  1. Go to PowerShell Administration console. You may simply go to command prompt and type/> PowerShell
  2. Set the script execution policy to unrestricted so that you can do remote installations. Here is how you can do this PS C:/Users> set-executionpolicy unrestricted
  3. Also, make sure that WinRM listener is configured and running on all remote machines where you'll do the configuration or installation remotely through our PowerShell Scripts. Here is how you can check the configuration status
    C:/Users/qa>winrm get winrm/config
    If the WinRM is listener is not already configured then type the following command to configure it.
    C:/Users/qa>winrm qc
See Also


Topic: Step 1: Configure the Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 1: Configure the Cache

To use Session State Store Provider in your application, follow the steps written below. You can either choose to create a Local Cache that resides only on your computer or a Clustered Cache involving multiple computers. For now, we'll create a clustered cache.
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Create a new cluster . Select following options from the New Cluster Wizard:
  • Cluster Name: myQSReplicatedCache
  • Cluster Type: Replicated
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least one node
  • Cluster Port: Any available port
  • Maximum Size: 250MB (default)
  • Eviction: Priority Based (default)
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of sessions, we recommend to turn off eviction)
  • Clean Interval (sec.): 15 (default)
  • Start the cluster .
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from .
  • Clear the cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop the cluster.
  • Go to Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply the changes to the cluster . You will notice that you no longer have the 'myCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Edit Web.Config or Machine.Config | Start/Restart ASP.NET App


Topic: Step 1: Configure the Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 1: Configure the Cache

To use Session State HTTP Module in your application, follow the steps mentioned below. You can either choose to create a Local Cache that resides only on your computer or a Clustered Cache involving multiple computers. For now, we'll create a clustered cache.
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Create a new cluster . Select following options from the New Cluster Wizard:
  • Cluster Name: myQSReplicatedCache
  • Cluster Type: Replicated
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least one node.
  • Cluster Port: Any available port
  • Maximum Size: 250MB (default)
  • Eviction: Priority Based (default)
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of sessions, we recommend to turn off eviction)
  • Clean Interval (sec.): 15(default)
  • Start the cluster .
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear the cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop the cluster
  • Go to Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply the changes to the cluster . You will notice that you no longer have the 'myReplicatedCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Edit Web.Config or Machine.Config | Start/Restart ASP.NET Application


Topic: Configuring Bridge Counters to Display

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Bridge Counters to Display

By default, a few important counters are displayed in statistics window but you can add/remove cluster counters connected to bridge according to your requirements.
  • Go to Tools menu of NCache Manager.
  • Select Options menu and a dialog box appears with Statistics, Management and Startup tabs. Go to the Statistics tab.
  • Check the Show counters of Caches connected with bridge checkbox.
  • Click OK.
See Also
Configuring Bridge for WAN Replication | Browse Bridge Statistics | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Cache Counters | Logging


Topic: Configuring Bridge for WAN Replication

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Bridge for WAN Replication
This feature is not available in NCache Express and Professional edition.
This section explains what is bridge, the operations that can be performed on a bridge and describes how to configure different bridge settings.
In This Section
Overview of Bridge
Explains what is bridge and what are the two main bridge topologies provided by NCache.
Creating Clustered Bridge
Explains how to create a clustered bridge.
Configuring Bridge Settings
Describes what are basic bridge settings and how can they be configured.
Configuring Conflict Resolver
Explains how the conflict, if occured in bridge operations, can be resolved.
Changing Cache Synchronization Modes
Explains how to change the synchronization mode of clustered cache connected to the bridge
Configuring Master Cache
Explains how an active cache (connected to a bridge) can be made a master cache.
Force State Transfer
Explains how to carry out state transfer explicitly between master cache and bridge.
Connect/Disconnect a Cache
Explains how to connect/disconnect a running cluster to bridge
Remove a Cache from Bridge
Explains how to remove a cache from bridge once it is stopped.
Bridge Management
Explains different bridge management operations and their usage.


Topic: Configuring Bridge Settings

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Bridge Settings

The NCache Manager provides the ability to change the configuration of bridges, whether it’s Active-Passive or Active-Active. To change the configuration of a bridge, click the bridge from the Cache Explorer view. You will be able to see various tabs in the Cache Details view through which you can configure various options of your bridge.
In This Section
Bridge Queue Size
Explains how to configure the bridge queue size.
Bridge Connection Settings
Explains how to configure the settings of bridge connection with other bridge nodes.
Enable the Queue Optimization
Explains how to enable queue optimization for bridge.
Bulk Size for Operation Replication
Explains how to configure bulk size for operation replication.
Performance Counters
Explains how to enable or disable performance counters for bridge.


Topic: Configuring Caches

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Caches

This section of the documentation discusses configuration options that NCache provides for local and clustered caches. It helps you configure cache through NCache Manager and configuration files.
In This Section
Creating Caches
Discusses how to create local and clustered caches.
Adding Server Node in a Cache Cluster
Describes configuring local and clustered caches and their operations through NCache Manager.
Configuring Basic Cache settings
This section explains how to configure basic cache settings.
Configuring Cache Cluster Settings
This section discusses how to configure basic clustered cache settings.
Configuring Query Indexes
This section discusses how to configure query indexes for a cache.
Registering Classes for Compact Serialization
This section describes how to register classes for compact serialization.
Registering Classes for Portable Data Sharing
This section describes how to register classes for portable data sharing.
Configuring Data Source Providers
This section explains how to configure data source providers like read-through, write-through and write-behind.
Configuring Cache Start-up Loader
This section explains how to configure cache start up loader through which a user can preload the cache with given data at the time of cache start-up.
Configuring Cache Level Events
This section describes how to configure cache level events for addition, update and removal of an item.
Configuring Eviction Policy
This section explains how to configure eviction policy for a cache.
Configuring Compression
This section explains how to configure data compression for a cache.
Configuring Email Notifications
This section explains how to configure email notifications for events occurring in a cache.
Binding Cluster and Client/server for a Dedicated IP
This section explains how to bind a cluster, client/server or both (cluster and client/server) with dedicated IP addresses.
Configuring Heart Beat
This section explains what is heart beat, the way to enable/disable it and its basic configuration settings.
Auto Start Cache at Boot
This section explains the auto start cache at boot option and how to configure it.
Nagling
This section explains what is nagling and how to configure its settings using service's config file.
Dual Sockets
This section explains the concept of dual sockets and how to enable/disable it.
Error Logging
This section explains how to enable/disable error logging and where these logs are generated.


Topic: Step 1: Configure the Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 1: Configure the Cache

Create a Clustered Cache named 'myQSReplicatedCache' as follows:
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Create a new cluster . Select following options from the New Cluster Wizard:
  • Cluster name: myQSReplicatedCache
  • Cluster Type: Replicated
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least your current computer and maybe others if you want.
  • Cluster Port: 8714
  • Cache Name: Provide a unique identifier for the cache.
  • Maximum Size: 250MB (default)
  • Eviction: Priority based
  • Default Priority: Normal
  • Eviction Percentage: 5 (default)(In case of sessions it is recommended that turn off eviction)
  • Clean Interval (sec.): 15 (default)
  • Start cluster.
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop cluster
  • Go to Main tab
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply changes to the cluster . You will notice that you no longer have the 'myQSReplicatedCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Register NCache with NHibernate | Enable DBCacheDependency in NHibernate | Run your NHibernate based Application


Topic: Step 1: Configure the Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 1: Configure the Cache
This feature is not available in NCache Express and Professional edition.
To use Output Cache in your web application, follow the steps mentioned below. You can either choose to create a Local Cache that resides only on your computer or a Clustered Cache involving multiple computers. For now, we'll create a clustered cache.
  • Launch NCache Manager from Start->Programs->NCache->NCache Manager.
  • Create a new project.
  • Select following options from the New Cluster Wizard:
  • Cluster Name: myQSPartitionedCache
  • Cluster Type: Partitioned
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Member Nodes: At least one node.
  • Cluster Port: Create a new cluster on any available port.
  • Maximum Size: 250MB (default)
  • Eviction: Priority Based (default)
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of session it is recommended that turn off eviction)
  • Clean Interval (sec): 15 (default)
  • Start the cluster.
  • Verify that cluster is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear the cluster to make it ready for your application.
Specifying InProc or OutProc Access Mode
Please note that this cluster has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cluster details window. If you want to change it to InProc, do the following:
  • Stop the cluster.
  • Go to Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply the changes to the cluster .
You will notice that you no longer have the 'myPartitionedCache node->Start' menu enabled. This is because the cluster is now supposed to start as part of your application process.
See Also
Edit Web.Config or Machine.Config | Start/Restart ASP.NET Application


Topic: Configuring Cache Clients

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Cache Clients

This section describes step-by-step instructions on how to add or remove client nodes in a clustered cache, create or remove client cache and configure client specific settings. A client node is the one from where clustered cache can be initialized to make API calls.
In This Section
Adding Client Node
Explains how to add client node in a clustered cache.
Configuring Client Node Settings
Explains how to configure the settings of a client node.
Creating Client Cache
Describes how to create client cache on a client node.
Disable Client Cache on Client Node
Describes how to disable client cache on client node.
Enable Client Cache on Client Node
Describes the process to enable client cache on client node
Configuring Client Cache Settings
Describes how to configure basic client cache settings such as synchronization modes, size and isolation levels.


Topic: Configuring Cache Level Events

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Cache Level Events

NCache event notifications let you design applications that react to various cache events. These notifications are disabled by default to save precious CPU and network resources. Events are fired upon addition, update and removal of an object or when cache is cleared. These notifications are off by default but can be turned on, for Clustered or Local Caches, as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Options tab.
  • Check Item add notification, Item remove notification and Item update notification check boxes.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Configuring Basic Cache Settings

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Basic Cache Settings

This section describes how to configure the following basic cache settings.
  • Cache Size
  • Isolation Levels (InProc/OutProc)
  • Clean up Interval
Cache settings can be configured by using NCache manager or command line tools. These settings can also be specified in client.ncconf file.
In This Section
Cache Size
Explains how to configure the size of cache.
Isolation Levels
Explains what are isolation levels and how can they be configured for a cache.
Expiration Clean Up Interval
Explains clean up interval and the procedure to configure it for your cache.


Topic: Configuring Cache Start-Up Loader

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Cache Start-Up Loader

NCache supports cache start-up loader through which a user can preload the cache with given data at the time of cache start-up. This feature can be configured in the following ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Cache Loader tab.
  • Check Enable Cache Startup Loader check box to enable it. After enabling it, other options will get enabled as well.
  • Click on the ‘…’ button to select the assembly implementing ICacheLoader interface.
  • Browse for the required assembly and click Open after selecting the required assembly.
  • Name of selected assembly will be appeared in Assembly Name and its classes implementing interface will be listed down in Class Name list box at Cache Loader tab. Select the required class
  • You can also add the parameters for your cache loader implementation, if required. Click New; provide the Parameter Name and Parameter Value in the New Parameter dialog box.
  • Deploy the required assemblies using Deploy Cache Loader button at the lower left corner of Cache Loader tab. Browse for the required assemblies and select Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addstartuploader.exe tool, provide the required information as:
addstartuploader demoLocalCache /a C:\Downloads\Providers.dll/cNCache.Sample.Providers.Loaders.Loader1
  • Hit ENTER key, it will add Loader1 as startup loader on demoLocalCache.
  • Now depoly all of the required assemblies (assembly in which you have implemented the write-through provider and all of its dependency assemblies) using deployprovider.exe. Use following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Configuring Client Node Settings

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Client Node Settings

There are some configuration settings related to client node. These settings can be configured as follows:
Using NCache Manager
  • Click on a client machine IP address in Cache Explorer for a cache to open client related settings of this client node.
  • On Main tab you can configure Connection Timeout, Connection Retries, Retry Interval and Client Request Timeout. All values are in seconds. A brief description of each attribute is given is given in NCache Manager alongside each attribute.
  • Using the Settings tab, you can enable/disable client load balancing using the checkbox Enable Client Load Balancing, specify Server Priority for this client, and change Sync Mode of client cache to either Optimistic or Pessimistic.
  • Using the Security tab you can specify Primary and Secondary user credentials, i.e., User Id and Password. These
credentials will be used when this cache is initialized from this client node.
  • At the Backing Source tab, you can select the default Read-Thru and/or Write-Thru providers, only if these providers are
configured for the cache.
  • Apply configuration changes by right clicking on the cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Cache Settings | Creating Client Cache | Disable Client Cache | Enable Client Cache


Topic: Client Side

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Client Side

This section is intended to help you in configuring .NET and Java Clients. It also gives you an overview of client configuration file (client.ncconf) required for the connection establishment with cache server and EFCaching configuration file for enabling EFCaching with NCache.
In This Section
Client Config
Describes configuring NCache light-weight Clients through client.ncconf file.
EF Caching Config
Describes configuring EFCaching with NCache through efcaching.ncconf file.


Topic: Configuring Cache Cluster Settings

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Cache Cluster Settings

This section describes different cache cluster settings and ways to configure them. These cache settings can be configured by using NCache manager or config.ncconf.
In This Section
Ports
Explains how to configure ports that NCache uses for communication.
Operation Timeout
Explains what is operation timeout and how to configure it.
Statistic Replication Interval
Explains statistic replication interval and the procedure to configure it for your cache cluster.
Connection Retries
Explains connection retries and the procedure to configure it.
Retry Interval
Explains retry interval and how to configure it for your cache cluster.


Topic: Configuring Compression

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Compression

To minimize data traffic between cluster and client nodes, NCache provides GZip Compression for objects of size greater than the specified threshold value. Objects greater than the specified threshold size will be compressed /decompressed by NCache. Average compression gains are higher for objects of greater size. By default, data compression is off. You can enable/disable data compression by one of following methods.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Options tab.
  • Check Enable Compression check box.
  • Change the Threshhold Size as per your requirment.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf:
You can enable/disable data compression option for a cache through config.ncconf as follows.
<compression enabled="true" threshold="500kb"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Configuring Counters to Display

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Counters to Display

By Default, a few important counters are displayed in statistics window but you can add/remove more counters according to
your requirements.
Using NCache Manager
  • Open NCache Manager.
  • Go to Tools menu option.
  • Select Options and a dialog box appear with Statistics, Management and Startup tabs. Go to the Statistics tab.
  • All performance counters are displayed in this tab in categorical view; you can select/deselect counters from this tab.
  • Click OK to save your selection.
See Also
Changing Management Port of a Cache Node | Fetching the Statistics using Server IP or Server Name | Cluster Health | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches


Topic: Configuring Data Source Providers

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Data Source Providers

While working with cache, client applications may need to perform operations on master data source. For this purpose, NCache supports transparent read/write operations to any type of back-end data source through read-through and write-through caching. Using this feature, client application can fetch or write data to master data source using the following providers.
  • Read Through
  • Write-Through
  • Write-Behind
In This Section
Read-Through Provider
Explains how to enable and configure read-through provider on a cacha.
Write-Through Provider
Explains how to enable and configure write-through provider on a cacha.
Write-Through Provider for Write-Behind Operations
Explains how to configure write-through provider for write-behind operations.


Topic: Configuring Email Notifications

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Email Notifications

You can configure email notifications in NCache. NCache will send you an email automatically when a selected event occurs in cache for which you have enabled notification. You can configure email notification for a cache in the following way:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Alerts tab.
  • Check the Enable Email Notifications checkbox to enable this feature.
  • Enter sender email in the Sender Email text box.
  • Enter SMPT server in the SMTP Server text box.
  • Enter port in the Port text box.
  • Check SSL Required check box, if your email server requires SSL authentication.
  • Check the Authentication Required check box if required and enter login and password in Login text box and Password text box respectively.
  • Specify recipients’ email addresses in To text box.
  • Check the the cache events for which you want to receive notications from NCache.
  • Apply configuration by right clicking on the cache name in Cache Explorer and selecting Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Configuring Encryption for Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Encryption for Cache

To enable and configure encryption for cache, follow the steps below:
Using NCache Manager
  • Open NCache Manager.
  • Go to Security tab.
  • Check the Enable checkbox inside Encryption group to enable encryption.
  • Select the encryption provider as per you requirement from the given Provider dropdown list.
  • Enter the encryption key in the Key textbox.
  • Right click on the cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Security for Cache Management | Configuring Security for Cache | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches


Topic: Configuring Eviction Policy

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Eviction Policy

There is a storage limit, maximum size is the capacity to which a cache can add objects in it. If cache reaches its maximum size and eviction is turned on, the specified ratio of items will be evicted to make space for new objects. On the other hand, if cache reaches its maximum storage limit and eviction is turned off, items are neither evicted nor added to the cache any further.
An eviction scheme is used to select the objects that need to be removed from cache. A particular eviction policy can be selected at the creation time but once it is set it cannot be altered in the running cache. User can change eviction policy after creating a cache only if it is not running. Three types of Eviction Policies are provided by NCache.
  • Least Frequently Used
  • Least Recently Used
  • Priority Based Eviction
Least Frequently Used
In this scheme a counter that counts the access made to an object is used. At the time of eviction objects with lowest counter number are evicted first. Here too a random selection is made between two objects with same counter.
Least Recently Used
This eviction scheme associates a timestamp with all objects. This timestamp is updated each time the object is accessed. When evicting, objects with the oldest timestamp are picked first. In case of two objects with the same time stamp, a random selection is made.
Priority Based Eviction
This is the default eviction policy and has the same mechanism as LFU with the addition of a relative cost that is associated with an object at the time of its addition to cache. Objects with lower cost are removed before objects with higher cost. Client application can choose from a list of priorities that is predefined (Low, Below Normal, Normal, Above Normal, High and Not Removable). In case a priority is not chosen, it is set by default as Normal.
These eviction policies for a cache can be specified in one of the following two ways.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Policies tab.
  • Uncheck the Turn off Eviction check box.
  • Select the Eviction Policy from drop down list.
  • If you have selected the Priority based eviction, then Default Priority can also be changed in the drop down list.
Change the Eviction Percentage if required. Eviction percentage is the percentage of items to be removed on each eviction.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf:
You can select the Eviction Policy for a cache through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<eviction-policy enabled="True" default-priority="normal" policy="priority" eviction-ratio="0.05"/>
</cache-config>
Eviction-ratio=0.05 is equal to 5% of total cache size. Eviction is not recommended in case of sessions.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Configuration Files

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuration Files

This section discusses various configuration files provided by NCache for both client end and server end.
In This Section
Overview
Explains various configuration files and their use.
Client Side Configurations
Describes client side configuration files required for the connection establishment with cache server.
Server Side Configurations
Describes server side configuration files required for cache, security and bridge configurations.


Topic: Configuring Heart Beat

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Heart Beat

Communication between Cluster nodes is critical for smooth cluster operations. Therefore, NCache provides an option called Heart Beat for the clusters to detect connection breakage with any node of the cluster. Connection breakage may occur due to an unplugged network cable or disabling of a network connection. When this option is enabled, a node of a cluster sends some dummy packets to other nodes and waits for acknowledgment. Therefore, if live nodes do not receive acknowledgments from any idle node after specific duration, they will consider it dead and will update their views by excluding it from the cluster. There will be no overhead of heart beat messages when all nodes are active and sending messages to each other. You can enable/disable heart beat through following methods.
Using NCache Manager
You can enable or disable heartbeat option from Cluster Settings Tab of Cluster view window.
Through config.ncconf
You can enable heart beat option through configuration file, config.ncconf . Heart beat interval can also be specified inside service's config file as follows
<add key="NCacheServer.HeartbeatInterval" value="30"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Configuring Master Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Master Cache

You can make an active cache (connected to a bridge) master. Please follow these steps:
Using NCache Manager
  • Right click on the active cache name (which is not marked as master cache) under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Make Master option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Performance Counters

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Performance Counters

NCache provides and publish multiple performance counters for bridge caches. You can enable or disable the performance counters publishing according to your requirements. These can be enabled or disabled as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Options tab.
  • Check or unckeck the Enable performance counters check box.
  • Right click on the bridge name in the Cache Explorer and select Apply Configuration option.
See Also
Bulk Size for Operation Replications | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches | Monitoring Cache Counters


Topic: Configuring Query Indexes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Query Indexes

Indexes are used in query for efficiency.Indexes are based on the type of a class. The user may further specify the attributes of the class on which indexes are required. Query Indexes can be configured as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Query Indexes tab.
  • Click Add.
  • Select Query Indices wizard will open. Click Browse to browse for the required assembly. Select the assembly.
  • Assembles and all its classes will be listed in Selected Assemblies section.
  • Select the required classes by checking the check box and clicking Add Class button.
  • List of selected classes and its attributes will be listed in List of selected Classes section. Select the attributes you want to add indexes for and click OK. Select Query Indexes wizard will close and selected classes along with their attributes will appear in Selected classes and their attributes section.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addqueryindex.exe, provide the required information:
addqueryindex.exe demoLocalCache /a C:\temp\Data.dll /c NCache.Sample.Data.Product /L ProductID$ProductName$Category$Supplier$UnitsAvailable
addqueryindex.exe demoLocalCache /a C:\temp\Data.dll /c NCache.Sample.Data.Customer /L CustomerID$CompanyName
  • Hit ENTER key, it will add ProductID, ProductName, Category, Supplier and UnitsAvailable attributes from the class NCache.Sample.Data.Product and NCache.Sample.Data.Customer of Data.dll in query indexes for demoLocalCache.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Configuring Read-Through Provider

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Read-Through Provider

The following steps should be followed to configure and implement the Read-Through provider with NCache.
Implementing IReadThruProvider Interface
To implement IReadThruProvider, add following references in the provider assembly.
Alachisoft.NCache.Runtime.dll
Create a class that implements Alachisoft.NCache.Runtime.DatasourceProviders.IReadThruProvider interface and deploy it using NCache Manger. NCache framework will internally use this class to load the data from the configured data source if it is not available in the cache.
IReadThru Interface
Public void Init(System.Collections.IDictionary parameters, StringcacheId);
Public void Dispose();
Public void LoadFromSource(string key, out ProviderCacheItemcacheItem);
Public Dictionary<string, ProviderCacheItem> LoadFromSource(string[] keys);
Member
Description
Init
This method will be called by NCache framework on cache startup. User can use this method for performing tasks like allocating resources, acquiring connections of data source etc. This method takes as input the IDictionay instance of arguments passed to the provider through NCache Manger (configuration settings). It allows you to pass list of parameters to provider. These parameters can be utilized in many ways. For example, connection string of a data source can be specified as a parameter. Thus, it provides a flexible way to change the data source settings while configuring it without code changes.
The other argumentCacheId specifies the cache name for which read-through is configured.
LoadFromSource
This method will be called by NCache framework if the required item is not found in cache store and NCache has to load it through configured data source. This method should contain logic to load an object from configured data source. First argument "key" refers to the key of required item. The second argument is an out parameter of type Provider CacheItem which needs to be instantiate it along with required properties Here you can associate various properties to loaded item before returning it back to NCache framework. Make sure that Provider CacheItem.Value assigned in this method is "Serializable" because NCache will later save that item to cache store to fulfill future requests.
While implementing this method, you should take care of code thread safety as multiple Get requests can access this method for read-through. Also do care to avoid scenarios that cause recursive infinite loops e.g. in this method a Get request with read-through on the same cache handle will cause infinite recursion.
Note: In case of Get, LoadFromSource(string key, out ProviderCacheItemcacheItem) will be called from provider while for GetBulk, LoadFromSource(string[] keys)
will be called to load items from data source.
Dispose
This method will be called by NCache framework when cache stops. You can use this method for performing tasks like releasing resources, disposing connections etc. Here you can free the resources related to data source for effective resource utilization.
In NCache, Read-Through providers are configured on cache level i.e. for clustered caches all nodes will contain provider configurations and their deployed assemblies.
Sample Code for IReadThruProvider
// Contains methods used to read an object by its key from the master data source.
// Contains methods used to read an object by its key from the master data source.
public class SampleReadThruProvider : IReadThruProvider
{
private SqlConnection _connection;
//Perform tasks like allocating resources or acquiring connections
public void Init(IDictionary parameters, string cacheId)
{
object connStringObject = parameters["connstring"];
string connString = connStringObject == null ? "" : connStringObject.ToString();
if (connString != "")
_connection = new SqlConnection(connString);
try
{
_connection.Open();
}
catch (Exception ex)
{
//handle exception
}
}
//Responsible for loading an item from the external data source.
public void LoadFromSource(string key, out ProviderCacheItem cacheItem)
{
//where LoadFromDataSource is the dummy method to load data from data source.
object value = LoadFromDataSource(key);
cacheItem = new ProviderCacheItem(value);
cacheItem.ResyncItemOnExpiration = true;
}
//Perform tasks associated with freeing, releasing, or resetting resources.
public void Dispose()
{
if (_connection != null)
_connection.Close();
}
//Responsible for loading bulk of items from the external data source.
public Dictionary<string, ProviderCacheItem>LoadFromSource(string[] keys)
{
try
{
Dictionary<string, ProviderCacheItem> dictionary = new Dictionary<string, ProviderCacheItem>();
string key = null;
for (int index = 0; index <keys.Length; index++)
{
key = keys[index];
//where LoadFromDataSource is the dummy method to load data from data source.
dictionary.Add(key, new ProviderCacheItem(LoadFromDataSource(key)));
}
return dictionary;
}
catch (Exception exp)
{
Throw;
}
}
private object LoadFromDataSource(string key)
{
object retrievedObject = null;
// load item from your data source and populate retrieved Object
return retrievedObject;
}
}
After implementing and deploying this provider, direct calls can be made to NCache to get the required items. If item is not locally available in cache store, NCache will use "LoadFromSource" method in specified data access class to load items from data source.
Using Read-Through with Basic Operations
This section will explain the use of read-through provider after configuring and deploying it. NCache supports multiple read-through providers with an applications.
Add the following namespaces in application:
using Alachisoft.NCache.Web.Caching;
using Alachisoft.NCache.Runtime.DatasourceProviders;
using Alachisoft.NCache.Runtime;
NCache provides Alachisoft.NCache.Web.Caching.DSReadOption enum to specify Read thru option in APIs.
Multiple read-through providers can be configured through NCache. Default read-through provider will be called if specific provider name is not mentioned through API. You can also use providers other than default by using provider specific overloads of APIs.
  • Get Method
Member | Description
Get(string key, DSReadOption dsReadOption) | Get item from cache and uses default provider
Get(string key, string providerName, DSReadOption dsReadOption) | Get item from cache and uses specified provider
Product product=null;
try
{
string key = "Product:1001";
object data = cache.Get(key, DSReadOption.ReadThru);
if (data != null)
{
product = (Product)data;
}
}
catch (OperationFailedException exp)
{
//handle exception }
  • Bulk Method
For better understanding of the these operations review Bulk Operations. In this scenario, use the following API
Member | Description
IDictionary GetBulk(string[] keys, DSReadOption dsReadOption) | Get bulk items from cache and uses default provider
IDictionary GetBulk(string[] keys, string providerName, DSReadOption dsReadOption) | Get bulk items from cache and uses specified provider
try
{
String[] keys = { "Product:1001", "Product:1002", "Product:1003", "Product:1004" };
IDictionary resultSet = cache.GetBulk(keys, DSReadOption.ReadThru);
//IDictionary contains cached keys and values
}
catch (OperationFailedException exp)
{
//handle exception
}
  • Using Read-Through Provider with CacheItem
For this scenario, use the following API.
Member | Description
CacheItem GetCacheItem(string key DSReadOption dsReadOption) | Get CacheItem from cache and uses default provider
GetCacheItem(string key, string providerName, DSReadOption dsReadOption) | Get CacheItem from cache and uses specified provider
string key = "Product:1001";
Product product=null;
try
{
CacheItem data = cache.GetCacheItem(key, DSReadOption.ReadThru);
if (data!= null)
{
product = (Product)data.Value;
}
}
catch (Exception exp)
{
//handle exception
}
Please note that you can specify default provider through NCManager or through client.ncconf placed in config folder of NCache installation directory. If provider name is not provided in both API and client.ncconf, default provider will automatically be used.
<cache id="mycache" default-readthru-provider="defaultProviderName" client-cache-id="" client-cache-syncmode="optimistic" default-writethru-provider="" load-balance="True" server-runtime-context="NCACHE">
...
</cache>
CacheInitParam can also be used to specify providers.
NCache logs the warnings in Application event log in case of an exception during loading the assemblies.
See Also
Data Source Providers Overview | Read-Through Caching | Write-Through Caching | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Configuring Security

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Security
This feature is not available in NCache Express and Professional edition.
Every Server node keeps security information that it has to provide to calling clients. Alachisoft.NCache.NCSecurity.dll at server node is required to provide security services to all clients. Whatever information is required by this assembly, for managing security related issues, is present in security.ncconf file. security.ncconf file helps enabling NCache security as well as to manage Node and API level security. You will find security.ncconf file at "%Install Directory%/NCache/config".
security.ncconf file is as shown below:
<!-- Security Configuration file for NCache 4.3 and later versions -->
<cache-security>
<!-- Change the value true/false to enable or disable security
feature in NCache -->
<enabled>false</enabled>
<!-- LDAP path is required to log-on to domain. -->
<ldap>LDAP://DomainControllerName</ldap>
<!-- Following users are Administrators and are allowed to add 'THIS' node
into their clusters and also allowed to perform Cache operations at
API level for all Caches. -->
<ncache-administrators>
<uid>Administrator</uid>
</ncache-administrators>
</cache-security>
  • <enabled> tells users if security is enabled or not (true/false)
  • <ldap> specifies ldap path for active directory server provider. It is the domain controller. NCache uses Microsoft Active Directory Service for authentication of user. User should exist under given domain in LDAP. For more information, see LDAP ADsPath
  • <ncache-administrators> keeps list of users having rights on all node-based and API-based operations.
In This Section
Configuring Security for Cache Management
Explains how to configure security for cache managerial tasks.
Configuring Security for Cache
Explains how to configure the security for cache.
Configuring Encryption for Cache
Describes how to enable and configure encryption for cache.


Topic: Configuring Write-Through Provider

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Write-Through Provider

To use Write-through caching you need to implement IWriteThruProvider interface provided by NCache. NCache framework will use this custom implementation to write data on backend data source.
Implementing IWriteThru Provider Interface
To implement IWriteThruProvider, add following references in provider assembly.
Alachisoft.NCache.Runtime.dll.
Create a class that implements Alachisoft.NCache.Runtime.DatasourceProviders.
IWriteThruProvider interface and deploy it using NCache Manger. NCache framework will internally use this class to perform write operation on configured data source.
IWriteThru Interface
Member
Description
Init
This method will be called by NCache framework on cache startup. User can use this method for performing tasks like allocating resources, acquiring connections of data source etc. This method takes as input the IDictionary instance of arguments passed to the provider through NCache Manger (configuration settings). It allows you to pass list of parameters to provider. These parameters can be utilized in many ways. For example, connection string of a data source can be specified as a parameter. Thus, it provides a flexible way to change the data source settings while configuring it without code changes.
The other argument CacheId specifies the cache name for which read-through is configured.
WriteToDataSource
This method will be called by NCache framework to perform actual write operation on configured data source.
-For write-thru, an atomic operation with write-thru will corresponds to atomic WriteToDataSource method in provider while in case bulk operation NCache will call bulk WriteToDataSource method from provider.
-For write-behind, NCache will call atomic WriteToDataSource method if non-batch mode is enabled while bulk WriteToDataSource method will be called for batch mode.
This method should contain logic to perform operation on configured data source. The argument WriteOperation contain the key, operation type (Add, Insert, Remove/Delete), retry count and provider cache item.
You will implement this method to perform write operations on data source according to operation type and return it to NCache as OperationResult. OperationResult holds information about:
· WriteOperation: Operation performed on data source.
· Update in cache flag : This flag specifies whether to update the returned write operation in cache or not. This is only applicable for Add and Insert operation types. In NCache an operation is first applied on cache store and then to data source (if write through caching is enabled). So if user wants to synchronize the cache store after updating data source then this flag will be used.
· Data source operation status : Write through caching basically synchronize your data source with cache store. Previously in case of operation failure on data source, item is also removed from cache, now NCache provides more flexible ways to allow user to decide whether to keep the item in cache based on these operation statuses.
· Success: This means item was successfully added to the data source so keep it in the cache as well.
· Failure: This means item could not be added to data source, so in case of Add/Insert operations, item will be removed from cache. Operation failure exception will be thrown to user in case of write-through and logged in case of write behind.
· FailureDontRemove: This means item could not be added to the data source, but keep it in the cache. Operation failure exception will be thrown to user in case of write thru and logged in case of write behind.
· FailureRetry: This means item could not be added to the data source, keep the item in cache and retry. In case of write thru retry will be performed as write behind operation.
While implementing this method, you should take care of code thread safety as multiple requests can access this method for write-through.
Dispose
This method will be called by NCache framework when cache stops. You can use this method for performing tasks like releasing resources, disposing connections etc. Here you can free the resources related to data source for effective resource utilization.
In NCache, Read-Through providers are configured on cache level i.e. for clustered caches all nodes will contain provider configurations and their deployed assemblies.
Sample Code for IWriteThruProvider
/// Contains methods used to save/update an object to the master data source.
public class SampleWriteThruProvider : IWriteThruProvider
{
/// Object used to communicate with the Data source.
private SqlConnection _connection;
//Perform tasks like allocating resources or acquiring connections
public void Init(IDictionary parameters, string cacheId)
{
object connStringObject = parameters["connstring"];
string connString = connStringObject == null ? "" : connStringObject.ToString();
if (connString != "")
_connection = new SqlConnection(connString);
try
{
_connection.Open();
}
catch (Exception ex)
{
//handle exception
}
}
//Perform tasks associated with freeing, releasing, or resetting resources.
public void Dispose()
{
if (_connection != null)
_connection.Close();
}
//Responsible for write operations on data source
public OperationResult WriteToDataSource(WriteOperation operation)
{
Product product = (Product)operation.ProviderCacheItem.Value;
SqlCommand command = new SqlCommand();
command.Connection = _connection;
if (operation.OperationType == WriteOperationType.Add)
command.CommandText = "INSERT INTO Products(ID,Name)VALUES( '" + operation.Key + "','" + product.ProductName + "')";
if (operation.OperationType == WriteOperationType.Delete)
command.CommandText = "DELETE FROM Products WHERE ID ='" + operation.Key + "'";
if (operation.OperationType == WriteOperationType.Update)
command.CommandText = "UPDATE Products SET Name = '" + product.ProductName + "' WHERE ID='" + operation.Key + "'";
int result = command.ExecuteNonQuery();
OperationResult operationResult = new OperationResult(operation, OperationResult.Status.Success);
if (result < 1)
{
operationResult.DSOperationStatus = OperationResult.Status.Failure;
}
return operationResult;
}
public OperationResult[] WriteToDataSource(WriteOperation[] operations)
{
OperationResult[] operationResult = new OperationResult[operations.Length];
SqlCommand command = new SqlCommand();
command.Connection = _connection;
int counter = 0;
foreach (WriteOperation operation in operations)
{
Product product = (Product)operation.ProviderCacheItem.Value;
if (operation.OperationType == WriteOperationType.Add)
command.CommandText = "INSERT INTO Products(ID,Name)VALUES( '" + operation.Key + "','" + product.ProductName + "')";
if (operation.OperationType == WriteOperationType.Delete)
command.CommandText = "DELETE FROM Products WHERE ID ='" + operation.Key + "'";
if (operation.OperationType == WriteOperationType.Update)
command.CommandText = "UPDATE Products SET Name = '" + product.ProductName + "' WHERE ID='" + operation.Key + "'";
int result = command.ExecuteNonQuery();
operationResult[counter] = new OperationResult(operation, OperationResult.Status.Success);
if (result < 1)
{
operationResult[counter].DSOperationStatus = OperationResult.Status.Failure;
}
counter++;
}
return operationResult;
}
}
After implementing and deploying this provider, you can make direct calls to NCache for write operations on data source. NCache will use "WriteToDataSource" method in specified data access class to write operations on data source.
Using Write-Through with Basic Operations
This feature is not available in NCache Express and Professional edition.
This section will explain the use of write-through provider after configuring and deploying it. NCache supports multiple Write-Through providers with applications.
The following namespaces should be added in application:
using Alachisoft.NCache.Web.Caching;
using Alachisoft.NCache.Runtime.DatasourceProviders;
using Alachisoft.NCache.Runtime;
NCache provides Alachisoft.NCache.Web.Caching.DSWriteOption enum to specify Write thru/Write behind options in APIs. Multiple write-through providers can be configured through NCache. Default provider will be called if specific provider name is not mentioned through API. You can also use providers other than default by using provider specific overloads of APIs.
  • Adding with Write-Through
Member | Description
CacheItemVersion Add(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded) | Adds item in cache and uses default provider
CacheItemVersion Add(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemAdded) | Adds item in cache and uses specified provider
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" + product.ProductID ;
try
{
CacheItemVersion itemVersion = cache.Add(key, cacheItem, DSWriteOption.WriteThru, null);
}
catch (OperationFailedException exp)
{
// handle exception
}
  • Updating with Write-Through
Member | Description
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded) | Inserts item in cache and uses default provider
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Inserts item in cache and uses specified provider
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
CacheItemVersion updatedItemVersion;
try
{
updatedItemVersion = cache.Insert(key, cacheItem, DSWriteOption.WriteThru, "XmlWriteThruProvider", null);
if (updatedItemVersion.Version> 1)
{
//Item updated in cache. Perform further tasks.
}
}
catch (OperationFailedException exp)
{
//handle exception
}
  • Deleting an Existing Item with Write-Through
Member | Description
Delete(string key, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback) | Deletes item from cache and uses default provider
Delete(string key, DSWriteOption dsWriteOption, string providerName, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Deletes item from cache and uses specified provider
string key = "Product:1001";
try
{
cache.Delete(key, DSWriteOption.WriteThru, null);
}
catch (OperationFailedException exp)
{
// handle exception
}
  • Removing an Existing Item with Write-Through
Member | Description
object Remove(string key, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback) | Removes item from cache and uses default provider
object Remove(string key, DSWriteOption dsWriteOption, string providerName, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Removes item from cache and uses specified provider.
string key = "Product:1001";
Product product = null;
try
{
Object returnObject = cache.Remove(key, DSWriteOption.WriteThru, null);
//Verify the removed item from both cache and data source
if (returnObject != null)
{
product = (Product)returnObject;
}
}
catch (OperationFailedException exp)
{ // handle exception }
  • Adding New Item Asynchronously
Member | Description
AddAsync(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded); | Uses default provider and add item in cache asynchronously.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" + product.ProductID ;
try
{
cache.AddAsync(key, cacheItem, DSWriteOption.WriteThru, null);
}
catch (OperationFailedException exp)
{
//handle exception
}
  • Adding with Write-Behind
Member | Description
CacheItemVersion Add(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemAdded) | Adds item in cache by using Custom Provider and Write-Behind.
i. Add without Callback Method
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
try
{
cache.Add(key, cacheItem, DSWriteOption.WriteBehind, null);
}
catch (Exception exp)
{
//Operation fails if the item already exists
// Request is not sent to the backing source in
}
ii. Add with Callback Method
protected void OnDataSourceItemsAdded(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void AddTest()
{
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
try
{
cache.Add(key, cacheItem, DSWriteOption.WriteBehind, OnDataSourceItemsAdded);
//Verify item added in cache and in main source
}
catch (Exception exp)
{
//Operation fails if the item already exists
}
}
  • Updating Existing Data with Write-Behind
Member | Description
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback); | Adds item in cache by using default provider and write-behind.
CacheItemVersion Insert(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback); | Adds item in cache by using custom provider and write-behind.
protected void OnDataSourceItemsUpdated(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void UpdateTest()
{
string key = "Customer:David:1001";
cacheItem.SubGroup = "WriteThru-Test";
try
{
cache.Insert(key, cacheItem, DSWriteOption.WriteBehind,OnDataSourceItemsUpdated);
}
catch (Exception exp)
{
//handle exception
}
}
  • Deleting Existing Data with Write-Behind
Member | Description
Delete(string key, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Deletes item in cache with default provider and write-behind option.
Delete(string key, DSWriteOption dsWriteOption, string providerName,DataSourceItemsRemovedCallback onDataSourceItemRemovedCallback); | Deletes item in cache with custom provider and write-behind option.
protected void OnDataSourceItemsRemoved(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void DeleteTest()
{
string key = "Customer:David:1001";
try
{
cache.Delete(key, DSWriteOption.WriteBehind, OnDataSourceItemsRemoved);
//Verify the removed item from both cache and data source
}
catch (OperationFailedException exp)
{
//Operation fails if key does not exist in the cache
}
}
  • Asynchronous Operations with Write-Behind
i. Add New Item Asynchronously
Member | Description
AddAsync(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemAdded); | Add item asynchronously in cache by using default provider and write-behind option.
void AddAsync(string key, CacheItem item, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemAdded) | Add item asynchronously in cache by using custom provider and write-behind option.
protected void OnDataSourceItemsAdded(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void AsyncAddTest()
{
try
{
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
cache.AddAsync(key, cacheItem, DSWriteOption.WriteBehind,OnDataSourceItemsAdded);
//verify that the key is added in Cache and master source
}
catch (Exception exp)
{
//handle exception
}
}
ii. Update Existing Item Asynchronously
Member | Description
void InsertAsync(string key, CacheItem item, DSWriteOption dsWriteOption, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Updates existing item asynchronously in cache by using default provider
void InsertAsync(string key, CacheItem item, string providerName, DSWriteOption dsWriteOption, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Updates existing item asynchronously in cache by using custom provider
protected void OnDataSourceItemsUpdated(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void AsyncUpdateTest()
{
Cache mycache = NCache.InitializeCache("myreplicatedcache");
try
{
string key = "Customer:David:1001";
CacheItem cacheItem = new CacheItem(new Product());
cacheItem.SubGroup = "Async-WriteThru-Test";
cache.InsertAsync(key, cacheItem, DSWriteOption.WriteBehind, OnDataSourceItemsUpdated);
//verify that the key is updated in Cache and master source
}
catch (Exception exp)
{
//handle exception
}
}
  • Bulk Operations with Write-Behind
i. Add New Items Using AddBulk Call
Member | Description
IDictionary AddBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, DataSourceItemsAddedCallback onDataSourceItemsAdded) | Adds items in cache by using default provider
IDictionary AddBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemsAdded) | Adds item in cache by using specific provider
protected void OnDataSourceItemsAdded(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void BulkAddTest()
{
try
{
String[] key = {"Customer:David:1001","Customer:Paul:1002","Customer:Dave:1003","Customer:Mathew:1004"};
//create custom objects of Product type
CacheItem[] data = GetCacheItems(keys.Length);
IDictionary failedItems = cache.AddBulk(keys, data, DSWriteOption.WriteBehind, OnDataSourceItemsAdded);
//verify updated items in the main source
}
catch (Exception exp)
{
//handle exception
}
}
ii. Update Existing Items Using InsertBulk API
Member | Description
IDictionary InsertBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, DataSourceItemsUpdatedCallback onDataSourceItemUpdatedCallback) | Updates items in cache by using default provider and providing callback
IDictionary InsertBulk(string[] keys, CacheItem[] items, DSWriteOption dsWriteOption, string providerName, DataSourceItemsAddedCallback onDataSourceItemsAdded) | Updates items in cache by using specific provider and providing callback
protected void OnDataSourceItemsUpdated(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void BulkUpdateTest()
{
try
{
String[] key = {"Customer:David:1001","Customer:Paul:1002","Customer:Dave:1003","Customer:Mathew:1004"};
//create new custom objects for above mentioned keys of Product type
CacheItem[] data = cache.GetCacheItems(keys.Length);
IDictionary failedItems = cache.InsertBulk(keys, data, DSWriteOption.WriteBehind, OnDataSourceItemsUpdated);
//verify updated items in the main source
}
catch (Exception exp)
{
//handle exception
}
}
iii. Delete Existing Items Using DeleteBulk API
Member | Description
void DeleteBulk(string[] keys, DSWriteOption dsWriteOption, DataSourceItemsRemovedCallback onDataSourceItemsRemovedCallback) | Deletes items in cache by using default provider and providing callback
protected void OnDataSourceItemsRemoved(IDictionary iDict)
{
//Perform appropriate actions upon response
}
private void BulkDeleteTest()
{
try
{
String[] key = {"Customer:David:1001","Customer:Paul:1002","Customer:Dave:1003","Customer:Mathew:1004"};
IDictionary failedItems = cache.DeleteBulk(keys, DSWriteOption.WriteBehind, OnDataSourceItemsRemoved );
//verify items deleted from the main source
}
catch (Exception exp)
{
//handle exception
}
}
See Also
Data Source Providers Overview | Read-Through Caching | Write-Through Caching | Configuring Read-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Configuring Basic Cache Settings

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Basic Cache Settings

NCache Manager for Visual Studio gives you limited control on cache configurations so that you can create and configure a cache according to your requirements. When you click on the cache name in NCache Explorer, you can see a new window with various inputs on the right side.
1. Change the Cache Max. Size/Cluster Port (of a Clustered cache)/Isolation Level (of a Local cache) of a stopped cache.
2. Upon the change in the configuration the “Apply Configuration” button will get enabled, click it to change the configuration of the cache.


Topic: Server Side

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Server Side

This section will help you in configuring .NET and Java Servers. Three types of configuration files are present at server side, which are:
In This Section
Cache Config
Explains config.ncconf file that contains information regarding all registered caches/clusters.
Security Config
Helps enabling NCache security as well as to manage Node and API level security through security.ncconf file.
Bridge Config
Explains bridge.ncconf file that contains information regarding bridges.


Topic: Configuring Statistics Counters to Display Management Port

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Statistics Counters to Display Management Port

By Default, NCache Management Port is set to 8250 and a few important counters are displayed in statistics window but you can add/remove more counters according to your requirements. To configure these setting there is following way:
1. Click Plugin Options button from top toolbar menu in NCache Explorer.
2. All performance counters are displayed in this view; you can select/deselect counters from this tab and change Management Port according to your wish.
3. Click OK to save your selection.


Topic: Configuring Conflict Resolver

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Conflict Resolver

There are situations when a bridge tries to replicate an operation for a key that already exist in the cache. Conflict Resolver is introduced to resolve the conflict between existing operations and operation replicated from bridge to the cache. It decides which key to apply on the cache depending upon defined rules. By default the decision will be made on Time Based rule, which keeps the latest key on a cache. Users can also define their own rules for conflict resolver. Its settings can be configured as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Conflict Resolver tab.
  • Check Enable Conflict Resolver check box to enable it. Others options will become enable after that.
  • Click on the ‘…’ button and select the assembly in which you have implemented the IBridgeConflictResolver interface.
  • Name of selected assembly will be appeared in Assembly Name textbox and all of its classes which have implemented the IBridgeConflictResolver interface will be listed down in Class Name list box. Select the required class.
  • Click New to provide any additional parameters, if required.
  • New Parameter dialog appears; provide the Parameter Name and Parameter Value.
  • Click the Deploy Conflict Resolver button, select your assembly in which you have implemented IBridgeConflictResolver interface and click on the button in Open dialog.
  • Apply configuration using right clicking on the cache name in Cache Explorer and selecting Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Connect/Disconnect a Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Connect/Disconnect a Cache

By default all added clusters are connected with bridge on start. You can disconnect then re-connect a running cluster to bridge. Please follow the steps given below:
Using NCache Manager
  • Right click on the cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Disconnect option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Connection Retries

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Connection Retries

Nodes participating in a clusterare connected with each other through TCP connections which may break up due to network failure. In that case, a client node tries to reestablish the connection. It goes through all the servers in the list once and if none are available, then sleeps for the Retry Interval seconds and then scans the list again. This is done Connection Retries times. In other words, Connection Retries specifies how many times the node should try to restore the connection. It can be configured in the following ways.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Set the Connection Retries as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
Connection retries can also be configured in config.ncconf file as follows.
<ncache-server port="9800" connection-retries="60" retry-interval="1"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Continuous Query

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Continuous Query

Continuous query is provided by NCache for runtime monitoring and tracking of data related to observable data set. This sections explains how to use the feature of continuous query provided by NCache.
In This Section
Overview
Explains the concept of continuous query in NCache.
Using Continuous Query
Explains how to use continuous query using NCache API.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

Distributed caching is the main need in this technological era where large scale multi-tier applications are built to cater millions of clients for high performance and scalability. But applications that require data changes rapidly demand synchronization of caches and client with the same pace. With synchronization of cache, it is also needed that all clients can share information related to some specific data set whenever any change occur in it.
Continuous query is provided by NCache for runtime monitoring and tracking of data related to observable data set. For example, if there is a web application regarding stock exchange where stock values will change frequently for any company.
The application’s clients will only be interested in the companies where they have shares. The query criteria for clients having shares in some companies are maintained and data related to only those companies should be updated on each clients view. In runtime applications, data addition is also runtime and there is no way of knowing when a specific query related data will be inserted in cache. For this, the client can register his/her query prior to data additions and when any cached item fulfilling the query criteria is added in cache, clients will be notified automatically.
NCache allows the user to specify any query criteria for indexed classes.
Changes in result set of a query can be triggered by:
  • Add: Adding an item in cache or updating any existing item that can add that item in any query.
  • Update: Updating any existing cache item but it remains in query result set.
  • Remove: Removing item from cache or updating any existing cached item that causes the removal of that item from query result set.
Filters can be specified for notifications that your cache client will receive. Filters are basically for the amount of modified cached item related data that will be received in query notifications. NCache provides three types of filters as mentioned below.
  • None (minimum data, i.e., only key)
  • Metadata (key with meta data related to cached item)
  • Data with metadata (key with complete cached and related data)
If any cached item related to result set of any registered query is removed due to expiration, eviction or dependencies then its notification will be sent to interested cache clients.
GROUP BY and Tags are not supported in this feature.
There might be an application that has .NET and Java clients. By enabling data sharing feature on the cluster cache, same objects can be indexed for both clients with even the same query. Notification will be sent to each client irrespective of Java or .NET for cached items added, updated or removed by both clients in any registered query result set. For example there might be an index defined for ProductID in .NET and productId in Java client. Data sharing feature was enabled between these clients and both were mapped for the same values. SELECT Product WHERE this.ProductID < 50 is registered in .NET client and SELECT Product WHERE this.productId < 50 is registered by Java client with notifications. Only one query observer will be started for both queries because both are registered for the same observable data set. Now if any item is added in cache from any of client that fulfils this query criterion, then both clients will be notified.
See Also
Using Continuous Query | Object Query Language (OQL) in NCache | Configuring Query Indexes | Server Side API Programming


Topic: Copyright ©

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Copyright ©

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the written permission of Alachisoft. Alachisoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Alachisoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property. 2015 Alachisoft. All rights reserved. The names of actual companies and products mentioned herein may be the trademarks of their respective owners.
See Also
What's New in NCache 4.4? | Dynamic Clustering | Caching Topologies | Copyright ©


Topic: Creating Caches

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating Caches

In NCache, you can create two main types of caches.
  • Local Cache
  • Clustered Cache
This section provides step by step details on creating these caches using both the NCache manager and command line tools.
In This Section
Creating Local Cache
Explains how to create local cache using the NCache manager and command line tools.
Creating Cache Clusters
Explains how to create clustered cache using the NCache manager and command line tools.


Topic: Creating Cache Clusters

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating Cache Clusters

A cache cluster is a set of interconnected server nodes forming a cluster of servers which behave as a single cache unit from outside. Cache clusters are usually preferred in scenarios where performance and scalability are needed. With additions of more server nodes in a cluster cache, more storage space and high availability of cached data can be gained
for large applications.
A cache cluster can be Mirrored, Partitioned, Partitioned Replica or Replicated. This section describes two ways of creating a clustered cache.
  • Create a new clustered cache
  • Add an existing clustered cache
In This Section
Creating a New Cache Cluster
Explains how to create a new cache cluster using the NCache manager and command line tools.
Add an Existing Cache Cluster
Explains how to use already created cache clusters.


Topic: Creating Client Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating Client Cache

Client Cache is a cache that exists on client node. You can create client cache in either of the two ways described below:
Using NCache Manager
  • Right click Client Cache tree node in Cache Explorer for a cache. Click on the Create New Cache option in the right click menu.
  • Enter Enter client cache Name, select client cache Sync Mode and choose the Isolation Level. And then click on the Next button.
  • Change the cache size if require and click Next.
  • In Advanced options dialog, you can configure followings:
  • You can change the Eviction policy and Eviction percentage; items will be evicted from cache using the selected policy and percentage value, if eviction is enabled.
  • You can change Clean interval value. Its default value is 15 sec.
  • You can make the cache to start automatically after service restart by checking checkbox Auto start this cache on service startup.
  • This will create client cache on all client nodes and Client cache Creation Status window is displayed showing client cache creation status for each client node.
  • Click Close and the newly created client cache will appear under Client Cache in the Cache Explorer.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createclientcache.exe, provide the required information:
createclientcache.exe demoClusteredCache /c demoClientCache /s 20.200.21.95 /N 20.200.21.144 /S 250
  • Hit ENTER key, it will create a client cache demoClientCache for cache demoClusteredCache on node 20.200.21.144.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Configuring Client Cache Settings | Disable Client Cache | Enable Client Cache


Topic: Creating Clustered Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating Clustered Bridge

A bridge can be created in NCache and caches are added in it using the following method:
Using NCache Manager
  • From the Cache Explorer view, right click the Bridges node and then click Create New Bridge option.
  • The New Bridge Wizard appears, displaying the Specify Bridge Identification dialog. Please provide the Name for the
new bridge and click on the Next button.
  • Select Bridge Member Nodes dialog opens up.
  • Speicfy the node IP address in text box or select from the Network Neighborhood and click on the ‘>’ button to add it in selected nodes list. Click on the Next button once all required nodes are added.
  • Specify Queue Parameters dialog box appears. Here, you can specify the multiple bridge properties, i.e., Bridge Port, Maximum Queue Size, and Replicator Queue Size.
  • After providing the required values click Next.
  • On the Specify Target Cache Options dialog box, you can change the Queue Replication Interval and Connection Retry Interval values. There is also a check box Start this bridge on Service restart. Check it if you want to start this bridge automatically when NCache bridge service starts. Click the Finish button to proceed ahead.
  • Your bridge will be successfully created and will be visible in the Cache Explorer view under the Bridges node.
Adding Clustered Caches to the Bridge
Depending on your bridge topology, you can add two caches to your bridge. The caches that you want to add should already be created on the local server or on remote server(s). Please follow these steps to add a cache to your bridge:
  • From the Cache Explorer view, right click the bridge to which you want to add a cache and then click on the Add Cluster Cache option.
  • On the Add Clustered Cache wizard, specify the server IP address in text box or select from the Network Neighborhood listed in Available Nodes list box and click Next button:
  • Select a clustered cache dialog window, all of the caches on your provided server are listed. Choose any one cache and click Next.
  • On the Select settings for bridge clustered cache dialog, choose the cache mode for this bridge configuration.
Default cache mode is Active, but you can change that.
  • The selected cache will successfully get added for this bridge and will be visible under the Caches node of the bridge.
  • Add the 2nd cache for this bridge using same steps mentioned above.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Creating Local Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating Local Cache

Local cache can be created in two ways:
  • Using NCache Manager
  • Using Command Line Tools
Using NCache Manager
  • To create a new Local Cache through NCache Manager, from the 'File' menu select 'New' -> 'Cache'.
  • A 'New Cache Wizard' will appear. In New Cache Wizard, specify the server IP address and click Next.
  • Specify the name of the cache in text box and click Next.
  • Change the cache size if required and click Next.
  • In Advanced options dialog, you can configure the following settings:
Eviction Policy: Specifies the eviction policy to determine which items are to be removed from cache, if it is full, to accommodate new items. You can change the eviction policy. Eviction policy will be configured but if you want this feature, then you have to turn it on after cache creation.
Eviction percentage: Specifies the percentage of items to be removed on each eviction. It can also be changed. Items will be evicted from cache using this percentage value if eviction is enabled.
Clean Interval: The periodic interval after which the expired items are removed from the cache. Its default value is 15 sec.
Start this cache on finish: If this check box is checked then this new cache will start automatically as you click the finish. Using “Auto start this cache on service startup” option, user will be able to mark the cache as a startup cache which will be started on cache service startup.
  • Click Finish. Created cache will be appeared in Cache Explorer under Local Caches node hierarchy.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createcache.exe, provide the required information:
createcache.exe Cache /s test1 /S 250
  • Hit ENTER key, it will create Cache of local topology of size 250mb on test1 node.
See Also
Creating Cache Clusters | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations


Topic: Creating a New Cache Cluster

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating a New Cache Cluster

Clustered Cache can be created in the following two ways:
Using NCache Manager
  • From the 'File' menu select 'New' -> 'Clustered Cache'.
  • A New Clustered Cache Wizard will appear. Specify the name of cache and click Next.
  • In Select caching topology dialog, select the required cache topology.
Cluster Caching Topologies: Mirrored cache is a cluster of two nodes (Active and passive), where all operations are performed on active node while the passive node is updated asynchronously. Passive node is promoted to active node as soon as the active node goes down. The Partitioned scheme partitions the data across the cluster, whereas the Replicated scheme provides data replication on all the nodes. Partitioned Replica scheme is same as a regular partitioned cache but it allows you to have replicas for each partition, replication can be done either synchronously or asynchronously.
Operation timeout (sec): The maximum time in seconds during which a clustered operation must be completed, otherwise the operation will fail.
Statistics replication interval (sec.): The time interval in seconds after which a node sends its statistics to all the other nodes in the cluster.
  • In case of Partitioned Replica cache you can have the choice to select the replication strategy for your cache using the screen shown below. Replication Strategy screen will only be encountered in case of POR.
Replication Strategy: Replication Strategy is defines as how the data is replicated to the backup node. It can be Synchronous or Asynchronous.
  • Asynchronous replication: In Asynchronous replication data operations are replicated asynchronously to the backup node.
  • Synchronous replication: In Synchronous replication data operations are replicated synchronously to the backup node.
  • Specify the node IP address in text box or select from the Network Neighborhood and click on the ‘>’ button to add it in the Selected Nodes list. Click Next once all the required nodes are added.
  • Change the Cluster Port if required. Click Next.
  • In the next dialog, you can change the cache size if required. Click Next.
  • In Advanced options dialog, you can configure the following settings:
Eviction Policy: Specifies the eviction policy to determine which items are to be removed from cache, if it is full, to accommodate new items. You can change the eviction policy. Eviction policy will be configured but if you want this feature, then you have to turn it on after cache creation.
Eviction percentage: Specifies the percentage of items to be removed on each eviction. It can also be changed. Items will be evicted from cache using this percentage value if eviction is enabled.
Clean Interval: The periodic interval after which the expired items are removed from the cache. Its default value is 15 sec.
Start this cache on finish: If this check box is checked then this new cache will start automatically as you click the finish. Using “Auto start this cache on service startup” option, user will be able to mark the cache as a startup cache which will be started on cache service startup.
  • Click on the Finish button. Created cache will appear in Cache Explorer under Clustered Caches section.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use createcache.exe, provide the required information:
createcache.exe ClusteredCache /s test3 /S 250 /t replicated /C 7818
  • Hit ENTER key, it will create ClusteredCache of replicated topology on server test3 with size 250mb using 7817 port.
See Also
Creating Local Cache | Adding an Existing Cache Cluster | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations


Topic: Creating Clustered Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating Clustered Cache

Clustered cache can be created in NCache Explorer the following way:
1. Select “Create New Clustered Cache” toolbar item/”NCache Explorer”, the top item in tree right-click menu item/”Clustered Caches” right-click menu item.
2. New Clustered cache wizard will open. Specify the name of cache and click Next.
3. In Select caching topology dialog, select the required cache topology. You can also change the Operation timeout (sec.) and Statistic replication interval (sec.) under the Advanced cluster options. Specify the desired information and click Next.
4. If you selected the Partition Replica Cache topology, you have to select a, either Asynchronous or Synchronous. Click Next.
5. Specify the node IP address in text box or select from the Network Neighborhood and click on the ‘>’ button to add it in the Selected Nodes list. Click Next once all the required nodes are added.
6. Change the Cluster Port if required. Click Next.
7. On this wizard page, you can change the ache size if required. Click Finish. Created cache will appear in NCache Explorer under Clustered Caches section.


Topic: Creating Local Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Creating Local Cache

Local cache can be created in following way:
1. Select “Create New Local Cache” toolbar item/”NCache Explorer”, the top item in tree right-click menu item/”Local Caches” right-click menu item.
2. In New Cache Wizard, specify the server IP address and click Next.
3. Specify the name of the cache in text box and click Next.
4. Change the cache size if required and click Finish. Created cache will appear in NCache Explorer under Local Caches node hierarchy.


Topic: Custom Dependency

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Custom Dependency

In custom dependency, the user can have his own dependencies scenarios. In this way, items can be be expired from cache in a number of flexible ways where expiration logic meets the user’s business requirements. NCache provides an abstract class ExtensibleDependency that is base for all dependencies.
How to Implement Custom Dependency
For overriding ExtensibleDependency class, user’s program needs a reference to the assembly Alachisoft.NCache.Runtime.dll that contain abstract class Alachisoft.NCache.Runtime.Dependencies.ExtensibleDependency provided by NCache. ExtensibleDependency class contains following abstract method and property.
public abstract bool HasChanged { get; }
public abstract bool Initialize();
Method | Description
Public bool Initialize(); | This method can be used to perform tasks like allocating resources, acquiring connections etc. If resources has been successfully acquired, return true else false. If Initialize return false NCache removes item with custom dependency from the cache.
Public bool HasChanged { get;} | NCache calls HasChanged (property) after every clean interval. If HasChanged returns true all custom dependent items will be removed from cache.
Follow the following steps to implement custom dependency.
Step 1: Inherit the dependency class from ExtensibleDependency and override the abstract function and property.
Lets suppose there is a grocery store which has a big collection of those products which customer often buy. These products can be cached from the database to check their units in stock.The dependency polls the Northwind database and expires all the Products for which units in stock are less than 100.
[Serializable]
public class CustomDependency :ExtensibleDependency
{
private string _connString;
private int _productID;
public override bool Initialize()
{
return true;
}
public CustomDependency(int productID, string connString)
{
_connString = connString;
_productID = productID;
}
internal bool DetermineExpiration()
{
if (GetAvailableUnits(_productID) < 100)
return true;
return false;
}
internal int GetAvailableUnits(int productID)
{
SqlDataReader reader = null;
SqlConnection connection = new SqlConnection(_connString);
connection.Open();
int availableUnits = -1;
try
{
SqlCommand cmd = connection.CreateCommand();
cmd.CommandText = "Select UnitsInStockFrom Products where ProductID=" + productID + "";
reader = cmd.ExecuteReader();
if (reader.Read())
{
availableUnits = Convert.ToInt32(reader["UnitsInStock"].ToString());
}
reader.Close();
return availableUnits;
}
catch (Exception)
{
return availableUnits;
}
}
public override bool HasChanged
{
get
{
return DetermineExpiration();
}
}
}
Step 2: Place assembly or executable file of class overriding ExtensibleDependency in NCache service folder and restart the NCache service.
Adding Data with Custom Dependency
Once custom dependency class has been implemented and deployed, its ready to be used in your program. Following code shows how to use custom dependency:
string connString ="Provider=SQLOLEDB.1;Data Source=localhost;User ID=sa;password=;Initial Catalog=Northwind";
//Creating custom dependency
CustomDependency hint = new CustomDependency (123, connString);
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
try
{
//Adding data with custom dependency
cache.Insert(key, product, new CacheDependency(hint), Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, Alachisoft.NCache.Runtime.CacheItemPriority.Default);
}
catch (OperationFailedException exp)
{
// handle exception
}
See Also
Cache Dependencies | Configuring Basic Cache Settings | Cache Startup Loader | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Custom Events Notifications

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Custom Events Notifications

Custom Notifications
In multiple clients connected to cache environment, finding the best way to communicate among them is important. Custom Notifications are a special type of notifications which follow publisher and subscriber communication model in which one client application raises custom notification containing notification id and data and the other client applications who register for custom notification will receive it. It is a simple message passing mechanism to control the information flow among clients connected to a cache. In publisher subscriber model, the subscriber application will have to register for custom events and the publisher application raises notification which is sent to subscribers through cache.
This type of notification is used in scenarios where the user wants to raise the notification from client application or when he wants to write logic of raising notification on client side rather than cache to decide when to raise notification. For example, if there are multiple applications running and discount price for a specific product is changed on one application, then a custom notification will be raised to notify other client applications about the updated discount price so that they can also update the discount price for that product.
Using Custom Events
  • Registering Custom Notification
The user can create a custom event according to his/her requirements. This event needs to be registered with CustomEvent. NCache does not raise the custom events on its own, therefore in order to trigger it RaiseCustomEvent method needs to be called.
// Create a target method
Void CacheCustomEvent(object notifId, object data)
{
// do something
}
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
// Registering custom event
cache.CustomEvent += new CustomEventCallback(CacheCustomEvent);
// perform appropriate tasks
//…
//
//Raise Custom event upon according to need.
cache.RaiseCustomEvent("mycache", product);
Here product must be defined in an independent library so that it is visible to all the applications using custom level notifications.
See Also
Event Notifications Overview | Cache Level Data Event Notifications | Item Level Data Event Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming


Topic: Data Compression

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Data Compression

NCache provides data compression feature to minimize the data traffic between cluster and client nodes and also to make the limited available memory, slightly more useful by storing more data in compressed form. Compression is by default disabled in NCache. Data compression can be enabled/disabled using NCache Manager.
Configuring NCache Compression Settings
Changing NCache compression settings will change the following configurations accordingly in config.ncconf file :
<compression enabled="true" threshold="500kb"/>
This xml tag specifies whether the items greater than the specified threshold should be compressed/decompressed at client side.
Enabled: If this attribute is set to "True", it means compression is enabled, otherwise disabled. Its default value is "False", as compression is disabled by default for all caches.
Threshold: Items greater than the value specified in threshold attribute will only be compressed/decompressed at client side (or sometimes at server side) if compression is enabled.
What Compression does
Once data compression is enabled, and the required threshold via NCache Manager is specified, NCache will apply GZip Compression for all objects of size greater than the specified threshold value, providing more memory storage and minimizing network traffic.
Compression will not be applied on the objects of the size less than the specified threshold value They will travel via network and will be stored in the cache in their original sizes.
Where does Compression Occur
Compression/decompression mostly occur at client side, but there are few cases when NCache server does the compression/decompression of the data.
Client Side Compression/Decompression
Client side compression/decompression takes place, if NCache compression is enabled, and any following case occurs:
  • For the data with size greater than the specified threshold, being send by the client to a remote server, data is compressed by client and sent to cache server in compressed form. Cache server just stores the data without applying any compression to it.
  • If a client requests for a data from the server, that is stored in cache in compressed form, cache server does not apply any decompression to the data and sends the data in its compressed form over the internet. Client receives the compressed data and decompresses it by itself.
Server Side Compression/Decompression
Server side compression/decompression takes place, if NCache compression is enabled, and any following case occurs:
  • For the data being loaded via configured cache startup loader or read-thru provider, and of size greater than the specified threshold, NCache server compresses the data after receiving it from the data source and before storing it in the cache.
  • For the data received by cache server in compressed form which has to be written in a data source via configured write-thru or write-behind provider, NCache server does not send the compressed data to the data source, in fact it decompresses the data first before sending it to the data store.
See Also
Configuring Compression | Dynamic Compact Serialization | Streaming | Server Side API Programming


Topic: Data Load Balancing in Partitioned and Partitioned-Replica Topologies

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Data Load Balancing in Partitioned and Partitioned-Replica Topologies

Data distribution in partitioned and partitioned-replica cluster caches is based on hash code of cache keys. Data is almost evenly distributed among all server nodes.
Each node knows about the data load of every other node in the cluster. There can be scenarios when data load on any one node becomes high depending upon the pattern of cache keys inserted in the cache.
NCache provides the following load balancing options:
Auto Load Balancing Task
  • Configurable: Auto load balancing is a configurable feature which automatically balances data load on each and every server node.
  • Automatic: It continuously monitors data load on all servers of the cluster after configurable interval and detects uneven data load.
  • Turning Off: This feature can be turned off if the user doesn’t want load balancing among cluster nodes.
Manual Load Balancing
  • Manual: Data load can be balanced any time by manual load balancing feature through NCache Manager.
  • Balance Data on Overloaded Server: Data balancing can be triggered through selecting option on the server node on which the data load is more than other server nodes.
  • No Threshold: There is no threshold. Data balancing can be started whenever required.
See Also
Creating Caches | Data Load Balancing | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Client Backward Compatibility | Eviction | Indexing


Topic: Data Source Provider (Backing Source)

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Data Source Provider (Backing Source)

While working with data sources, it is important to transparently fetch the required data from the master data source if it is not available in the cache and vice versa. Read-Through and Write-through are provided by NCache for this purpose. Now you can add multiple Read-Through and Write-through providers with your applications.
If you are adding a custom object in NCache through backing source providers then you should place dlls local to the NCache service.
In this Section
Overview
Explains how Read-Through and Write-Through caching facilitates the user.
Read-Through Caching
Explains the basic concept of Read-Through caching.
Write-Through Caching
Explains the basic concept of Write-Through caching.
Configuring Read-Through Provider
Explains how to use Read-Through caching in NCache.
Configuring Write-Through Provider
Explains how to use Write-Through caching in NCache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

The main purpose of a caching solution is to cache the data source as temporary storage. While working with cache, client applications may need to perform operations on master data source. For this purpose, NCache supports transparent read/write operations to any type of back-end data source through read-through and write-through caching. Using this feature, client application can fetch or write data to master data source if needed. Read-through and Write-through caching facilitates user in the following cases:
  • User needs to fetch data from data source in case it is not present in cache store (Read-Through).
  • User needs to update data source (any write operation) after updating cache store (Write-Through).
Using this feature in NCache has the following advantages:
  • NCache provides pluggable architecture for read-through and write-through caching so the client application code does not need to contain data source logic.
  • The data source may be changed at any time so this pluggable architecture can configure different data source while keeping the application code intact.
  • Your application only needs to communicate with NCache and NCache will take care of backend communication with data source.
To use read- through or write-through caching, IReadThruProvider or IWriteThruProvider interfaces need to be implemented respectively and deploy it through NCacheManager.
Runtime parameters can also be provided to provider while configuring it through NCManager. These parameters will be passed to provider on its initialization. These initialization parameters can be used in many ways, e.g., connection string of a data source can be specified as a parameter and there is no need to put it in provider code. Thus, it provides a flexible way to change the data source settings while configuring it without code changes in provider.
In NCache, providers are configured by name and provider specific APIs can be employed by using provider name. NCache also supports multiple Read-Through/Write-though providers with applications. In case of multiple providers, one of provider will be configured as default one. Default provider will be called if provider name is not mentioned explicitly through API. Providers other than default can also be used by utilizing provider specific overloads of the given APIs.
See Also
Read-Through Caching | Write-Through Caching | Configuring Read-Through Provider | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Deactivate NCache Purchased License

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Deactivate NCache Purchased License

NCache license can be deactivated by following the steps given below:
  • Run the NActivateWizard Tool from "%Install Directory%/NCache/bin/NActivate" path.
  • NCache License Manager will open. Please check Deactivate NCache License and click Next.
  • The following screen appears. Enter the deactivation code provided to you by Alachisoft and click Next.
  • The next dialog box shows two options for deactivation.
  • If your computer has Internet access, just select the Online (Recommended) option. It will contact Alachisoft activation server and deactivate NCache license for you immediately.
Online Deactivation
Online deactivation is the fastest way to deactivate but requires that your machine has Internet access.
  • Click Deactivate Now.
  • Your license will be deactivated and you will be prompted with a success message as follows:
  • Click Finish to exit NCache License Manager.
Manual Deactivation
However, if your computer does not have Internet access (which is the case in many production servers behind the firewall), then you should opt for manual deactivation.
  • Select Manual and click Next.
  • The following screen appears.
  • Click Yes to continue.
  • A screen showing a long encrypted text appears. This is Deactivate Request Code Press Copy to copy this text to the clipboard. Paste it on the link given below to proceed.
NCache Manual Deactivation .
  • Paste the Deactivate Request Code into the text box on this page and then press Verify.
  • Deactivation Data Verification form will appear.
  • There will be a Deactivate! button at the bottom of the page shown above. Click this button and it displays a page with Deactivation Confirmation as shown below.
  • NCache is now deactivated on your machine.
See Also
Getting Started | Command Line Install | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Activate NCache License |


Topic: How to Debug Providers?

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

How to Debug Providers?

Steps for Debugging a Provider:
Here are the steps required to debug your providers
  1. Insert break point in your application from where you want to debug.
  2. From menu bar click on "Debug" and select "Attach to process..." option as shown below.
3. Attach to a process named "Alachisoft.NCache.Service.exe", as shown below.
  • Please make sure that options "Show processes from all users" and "Show processes in all sessions" are selected.
See Also
Read-Through and Write-Through Caching | Cache Startup Loader | Unable to Connect to Remote Server (Windows XP Machine) | How to do NCache Version Upgrades


Topic: Deleting Items

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Deleting Items

Once you have a valid cache handle, you can perform "Delete" operations on cache. This operation has many overloads and the basic overload takes only one parameter i.e. "key" as string.
Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Delete Method
A "Delete" method will delete item from the cache only if that item already exist in the cache. Exception will be thrown if the method is unable to delete the key from the cache.
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    static void Main( string [] args)
    {
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Add Item to the Cache
    _cache.Add("Customer:David:1001", customer);
    // Delete the above Item from the Cache
    _cache.Delete("Customer:David:1001");
    }
  4. Start the Local Cache 'myCache'.
  5. Run the project.
See Also
Initialize Cache | Finding items | Removing Items | Dispose Cache | Start Cache | Stop Cache


Topic: Diskperf Not Installed

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Diskperf Not Installed

The Windows parameter sets cannot collect information about the monitored computer unless the Disk Performance Statistics Driver (Diskperf) has already been run on the monitored computer.
By default, Diskperf installs the Disk Performance Statistics Driver above the fault tolerant driver, Ftdisk.sys, in the I/O Manager disk driver stack. To determine if Ftdisk is started in your configuration, use the Devices Control Panel.
Workaround
Use the following steps to run Diskperf on the monitored Windows computer. You must be a member of the Administrator's local group on a computer to run Diskperf on that computer.
  • Open a Command Prompt window.
  • At the command prompt, type one of the following commands, and press 'Enter'.
  • diskperf -y: enables the counters on a standard disk configuration
  • diskperf: indicates whether disk counters are enabled or disabled
  • diskperf -yv: enables disk counters on mirror and stripe sets and other noncontiguous partition sets and installs the performance statistics driver below the fault tolerant driver in the I/O stack
  • diskperf -n: disables disk counters
  • To run diskperf on a remote computer, type the command name, followed by the computer name. For example: diskperf //computername
  • To monitor the physical disks in disk configurations that include Ftdisk, run the diskperf -yv command.
  • Restart the computer.
See Also
Troubleshooting Counters | No READ Access to Perflib Subkeys | Unable to Connect to Server Node
Send comments on this topic


Topic: Disable Client Cache on Client Nodes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Disable Client Cache on Client Nodes

In some cases when you create client cache but do not want to use it, then you can disable client cache for a particular client node or for all client nodes.
Each client node has an indicator showing whether client cache is enabled or disabled. A red square sign indicates that client cache is enabled and grey square sign indicates that client cache is disabled, as shown in screen shots below.
Using NCache Manager
  • Right click on Client Nodes in Cache Explorer for a cache.
  • Click on Disable Client Cache option in the right click menu. Client cache becomes disabled for all the client nodes, currently listed under Client nodes in Cache Explorer. Grey square sign on client node indicates a disabled client cache.
Please note that you can also disable client cache by right clicking on a particular client node instead of Client Nodes. In this way, client cache will be enabled for the selected client node only.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Configuring Client Cache Settings | Creating Client Cache | Enable Client Cache


Topic: Disabled Netwrok Card

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Unable to Apply Configurations or Start Cache due to Disabled Network Card

You may not be able to apply cache configurations or start the cache. Or, clients may be unable to connect with server even on local machine. These problems arise when network card is disabled or cable is not connected.
Workaround
To resolve this problem, restart NCache service once after the network card is disabled or network cable is disconnected. Restarting NCache service will rebind it to local host rather than IP address of that machine.
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other


Topic: Dispose Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Dispose Cache

After you are done using cache, you can dispose it. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
The code for disposing the cache is as follows:
Cache _cache = NCache.InitializeCache("myCache");
// Dispose the cache
_cache.Dispose();
Disposing the cache in ASP.NET Applications
If you're developing ASP.NET application, the best place to put Dispose() call is in your HttpApplication's Dispose() method. This method is called when the instance of your HttpApplication is destroyed.
public virtual void Dispose()
{
Cache_cache = NCache.InitializeCache("myCache");
// Dispose the cache
_cache.Dispose();
}
See Also
Initialize Cache | Adding Items | Finding items | Removing Items | Start Cache | Stop Cache


Topic: Dispose Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Dispose Cache

After you are done using the cache, you can dispose it. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
The code for disposing the cache is as follows:
Cache _cache = NCache.Caches["mycache"];
// Dispose the cache
_cache.Dispose();
Disposing the cache in ASP.NET Applications
If you're developing ASP.NET application, the best place to put Dispose() call is in your HTTP Application's Dispose() method. This method is called when the instance of your HTTP Application is destroyed.
public virtual void Dispose()
{
Cache _cache = NCache.Caches["mycache"];
// Dispose the cache
_cache.Dispose();
}
See Also
Creating Caches | Initialize Cache | Fetch Data from Cache | Remove Data from Cache | Add/Update Data to Cache | Bulk Operations | Start Cache | Stop Cache


Topic: Dual Socket

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Dual Socket

Each node participating in cluster can establish two connections with every other node. Purpose of increasing the number of connections is to increase throughput by maximizing the network usage. As network I/O is a slow process, therefore, opening multiple connections improve the performance. By default, dual connections are disabled. You can enable or disable this feature by specifying following options in <appSettings> of NCache service's config file . If you are using cache as InProc, you need to specify this in config.exe of your application.
<appSettings>
<add key="NCache.EnableDualSocket" value="true"/>
</appSettings>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Self Healing Dynamic Clustering

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Self Healing Dynamic Clustering

NCache has a self-healing dynamic clustering capability based on a peer-to-peer cluster architecture. NCache does not use Windows Clustering or any other OS-based clustering but instead creates its own TCP based dynamic cluster of cache servers. The purpose of this dynamic cluster is to provide you 100% uptime by allowing you to add or remove cache servers from the cluster at runtime without stopping the dynamic cluster.
With dynamic clustering you can get the following capabilities:
  • 100% uptime for the cluster due to peer to peer architecture
  • Add or remove cache servers at runtime without stopping the cache
  • Can perform load balancing for client connections to cache servers (at connection time)
  • Clients automatically reconnect to a different cache server if their server goes down
NCache provides a dynamic clustering capability with 100% uptime for the cluster. This is due to a peer to peer architecture of the cluster where there is no single point of failure.
A cache cluster is a collection of one or more cache servers with every server connected to every other server in the cluster. When a cache cluster is formed, it contains a cluster coordinator that manages all membership to the cluster. The coordinator is the oldest server in the cluster (meaning the first server that started). If the coordinator ever goes down, this role passes on to the next senior-most server in the cluster. This removes any single point of failure in cluster membership management.
You can find out more detail on our website for Self Healing Dynamic Clustering .
See Also
Caching Topologies


Topic: Dynamic Compact Serialization

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Dynamic Compact Serialization

NCache provides a feature to make application data types compact serializable. This section explains how to do it.
In this section
Overview
Explains the concept of Dynamic Compact Serialization and its benefits.
Using Compact Serialization
Explains how to use Dynamic Compact Serialization using NCache API.


Topic: Step 2: Edit web.config or machine.config

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 2: Edit web.config or machine.config

After you have configured the cache and have named it "myQSReplicatedCache", you now need to configure your ASP.NET application to use the Custom Session Store Provider that is provided with NCache installation. To do so, you must edit web.config file.
Please follow these steps for enabling NCache Session Store Provider to transparently save and retrieve ASP.NET session state:
  • Edit your application's web.config file and modify the <sessionState> section as given below.
    For Enterprise and Professional Edition:-
    <assemblies>
    <add assembly = "Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
    </assemblies>
    <sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom" customProvider = "NCacheSessionProvider" timeout = "10">
    <providers>
    <add name = "NCacheSessionProvider" type = "Alachisoft.NCache.Web.SessionState.NSessionStoreProvider"
    sessionAppId = "1234" cacheName = "myQSReplicatedCache" writeExceptionsToEventLog = "false"
    enableLogs = "false" enableDetailLogs = "false" exceptionsEnabled = "false" operationRetry = "0" operationRetryInterval = "0" />
    </providers>
    </sessionState>
    For Open Source Edition:-
    <assemblies>
    <add assembly = "Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
    </assemblies>
    <sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom" customProvider = "NCacheSessionProvider" timeout = "10">
    <providers>
    <add name = "NCacheSessionProvider" type = "Alachisoft.NCache.Web.SessionState.NSessionStoreProvider"
    sessionAppId = "1234" cacheName = "myQSReplicatedCache" writeExceptionsToEventLog = "false"
    enableLogs = "false" enableDetailLogs = "false" exceptionsEnabled = "false" operationRetry = "0" operationRetryInterval = "0" />
    </providers>
    </sessionState>
Replace version “x.x.x.x” with the actual NCache version that you have.
For detailed description of different key-value pairs specified above, please see Using Session State Store Provider .
  • Add <machinekey> entry under <system.web> section of web.config. It is required, so that ASP.NET session IDs are generated in the same manner on all nodes. You can use genmackeys utility available with NCache installation to generate the keys.
    <machineKey validationKey = "A01D6E0D1A5D2A22E0854CA612FE5C5EC4AECF24" decryptionKey = "ACD8EBF87C4C8937"
    validation = "SHA1"/>
Enable Location Affinity for SessionStoreProvider
  • Add following section in web.config.
    For Enterprise and Professional Edition:-
    <configSections>
    <section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
    Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
    </configSections>
    <ncache >
    <sessionLocation >
    <primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
    <secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
    <secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
    </sessionLocation>
    </ncache>
    For Open Source Edition:-
    <configSections>
    <section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
    Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
    </configSections>
    <ncache >
    <sessionLocation >
    <primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
    <secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
    <secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
    </sessionLocation>
    </ncache>
    For detailed description of different key-value pairs specified above, please see Using Location Affinity for Sessions .
    Please keep the following points in mind:
  • Replace version “x.x.x.x” with the actual NCache version that you have.
  • The sid-prefix is a unique identifier that is appended by custom session-ID manager in the beginning of session-ID. sid-prefix length must be equal to 4.
  • When Location Affinity is enabled, "CacheName" specified in <providers> section of web.config will be ignored.
  • Enable custom session-ID manager using the sessionIDManagerType attribute of the sessionState element in web.config.
    <sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom"customProvider = "NCacheSessionProvider" timeout = "60" sessionIDManagerType = "Alachisoft.NCache.Web.SessionStateManagement.CustomSessionIdManager, Alachisoft.NCache.SessionStateManagement">
See Also
Configure the Cache | Start/Restart ASP.NET App


Topic: Step 2: Edit web.config or machine.config

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 2: Edit web.config or machine.config

After you have configured the cache and have named it 'myQSReplicatedCache', you now need to configure your ASP.NET application to use the Clustered Session HTTP Module that is provided with NCache installation. To do so, you must edit web.config file.
Please follow these steps for enabling NCache Session State Module to transparently save and retrieve ASP.NET session-state objects.
  1. Edit your application's web.config file to add <appSettings> entry under <configuration> section.
    <appSettings>
    <add key = "CacheName" value = "myQSReplicatedCache "/>
    <add key = "sessionAppId " value = " 1234 "/>
    <add key = "exceptionsEnabled " value = " true "/>
    <add key = "enableLogs " value = " false " />
    <add key = "enableDetailLogs " value = " false "/>
    <add key = "clearASPSession " value = " false "/>
    <add key = "writeExceptionsToEventLog " value = " false "/>
    <add key = "operationRetries" value = "0"/>
    <add key = "operationRetryInterval" value = "0"/>
    </appSettings>
    For detailed description of different key-value pairs specified above, please see Using NCache Session State Module .
  2. Add <httpmodules> entry under <system.web> section in web.config.
    For Enterprise and Professional Edition:-
    <httpModules>
    <add name = "NCacheWebSessionState" type = "Alachisoft.NCache.Web.SessionState.NSessionStateModule,
    Alachisoft.NCache.SessionState, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
    </httpModules>

    For Open Source Edition:-
    <httpModules>
    <add name = "NCacheWebSessionState" type = "Alachisoft.NCache.Web.SessionState.NSessionStateModule,
    Alachisoft.NCache.SessionState, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</httpModules>
Replace version “x.x.x.x” with the actual NCache version that you have.
  1. Add <machinekey> entry under <system.web > section in the web.config. It is required to generate ASP.NET session IDs in the same manner on all nodes.
    <machineKey validationKey = "A01D6E0D1A5D2A22E0854CA612FE5C5EC4AECF24" decryptionKey = "ACD8EBF87C4C8937" validation = "SHA1"/>
Enable Location Affinity for HttpModule
1. Add following section in web.config.
For Enterprise and Professional Edition:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</configSections>
<ncache>
<sessionLocation >
<primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
<secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
<secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
</sessionLocation>
</ncache>
For Open Source Edition:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</configSections>
<ncache>
<sessionLocation >
<primaryCache id = "myQSReplicatedCache" sid-prefix = "abcd"/>
<secondaryCache id = "myQSReplicatedCache2" sid-prefix = "pqrs"/>
<secondaryCache id = "myQSReplicatedCache3" sid-prefix = "wxyz"/>
</sessionLocation>
</ncache>
For detailed description of different key-value pairs specified above, please see Using Location Affinity for Sessions .
Please keep the followinf points in mind:
  • Replace version “x.x.x.x” with the actual NCache version that you have.
  • The sid-prefix is a unique identifier that is appended by custom session-ID manager in the beginning of session-ID. sid-prefix length must be equal to 4.
  • When Location Affinity is enabled, "CacheName" specified in <appSettings> section of web.config will be ignored.
2. Enable custom session-ID manager using the sessionIDManagerType attribute of the sessionState element in web.config.
<sessionState mode = "InProc" cookieless = "true" timeout = "20" sessionIDManagerType = "Alachisoft.NCache.Web.SessionStateManagement.CustomSessionIdManager, Alachisoft.NCache.SessionStateManagement"/>
Custom session-ID manager is only supported for .NET 2.0 and later. Thus, for any applications build with earlier versions of .NET, Custom session-ID manager is not required.
See Also
Configure the Cache | Start/Restart ASP.NET Application


Topic: Step 2: Edit Web.Config or Machine.Config

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 2: Edit Web.Config or Machine.Config
This feature is not available in NCache Express and Professional edition.
After you have configured the cache and have named it "myQSPartitionedCache", you now need to configure your ASP.NET application to use the Output Cache Module that is provided with NCache installation. To do so, you must edit web.config file.
Please follow these steps for enabling NCache Output Caching Module to transparently save and retrieve rendered pages.
  1. Register NOutputCache as httpmodule inside <system.web> in web.config file.
    For Enterprise and Professional Edition:-
    <httpModules>
    <add name = "Alachisoft.NCache.Web.NOutputCache" type = "Alachisoft.NCache.Web.NOutputCache.NOutputCache,
    Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
    </httpModules>
    For Open Source Edition:-
    <httpModules>
    <add name = "Alachisoft.NCache.Web.NOutputCache" type = "Alachisoft.NCache.Web.NOutputCache.NOutputCache,
    Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
    </httpModules>
Replace version “x.x.x.x” with the actual NCache version that you have.
2. Register 'ncache' configuration section in the <configSections> of the web.config as follows:
For Enterprise and Professional Editions:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.NOutputCache.NCacheSection, Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
</configSections>
For Open Source Edition:-
<configSections>
<section name = "ncache" type = "Alachisoft.NCache.Web.NOutputCache.NCacheSection, Alachisoft.NCache.OutputCache, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</configSections>
Replace version “x.x.x.x” with the actual NCache version that you have.
3. Then add actual <ncache> section in <configuration> section of web.config holding information of pages to be cached.
<ncache>
<outputCacheSettings cacheName = "myQSPartitionedCache" clientCacheName = "" exceptionsEnabled = "true" enableLogs = "false" enableClientCacheSync = "false">
<outputCachePages>
<add name = "/NOutputCacheSample/main.aspx" enabled = "true" requestType = "post" duration = "20" varyByParam = "cbxCustomerName" varyByHeader = "Connection" varyByCustom = "browser"/>
</outputCachePages>
</outputCacheSettings>
</ncache>
For detailed description of different key-value pairs specified above, please see Using Output Cache .
See Also
Configure the Cache | Start/Restart ASP.NET Application


Topic: EFCaching Config

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

EFCaching Config
This feature is not available in NCache Express and Professional edition.
EFCaching configuration file contains information regarding Entity Framework provider. It is installed with NCache and is located at "%Install Directory%/NCache/config". efcaching.ncconf is used for enabling NCache in Entity Framework applications. The configurations are stored in an efcaching.ncconf file.
EFCaching configuration file is explained below:
  • Provider Configuration contains cache and caching policy related information. Below are the changes required in efcaching.ncconf.
    <configuration>
    <app-config app-id = "PersonNameApp" mode = "analysis|caching">
  • App-id: Is an identifier for an application. The configuration can contain multiple configuration settings for different applications. App-id for efcaching.ncconf should be same as in application otherwise it will prompt an error.
  • Mode: Can either be "analysis" or "caching". (Hot Applicable)
  • Default = 'caching'
  • "Analysis" mode is used for monitoring the number of times each query executes and then it generates a report. Report contains the Query text and the call count for each query. This report can be used in Custom policy. No caching is done at this mode.
    <analysis-policy log-path = "" analysis-time = "60" cache-enable-threshold = "5" default-expiration-type = "absolute|sliding" default-expiration-time = "180" dbsyncdependency = "true"/>
  • Log-path: Path at which analysis log files will be generated.
Default = < install-dir > /log-files/efcaching-analysis-logs/
  • Analysis-time: Time for which the analysis will run.
  • Default = 60 min
  • Cache-enable-threshold: Caching will automatically be enabled for queries whose call-count exceeds this threshold.
  • Default = 5
  • Default-expiration-type: Default expiration type for analyzed queries.
  • Default = absolute
  • Default-expiration-time: Default expiration time for analyzed queries.
  • Default = 180 sec (3 min)
  • dbsyncdependency: Determine whether to enable database-dependency or not.
  • Default = "true"
  • For "Caching" mode, wrapping provider will cache the results of all the specified queries. Caching mode works on either cacheall policy or custom policy. Both policies have their own specifications. Whenever update is detected (either UPDATE, INSERT or DELETE) in a respective database, the provider invalidates affected cache entries by evicting all cached queries which were dependent on any of the updated tables.
<cache-policy default-policy = "cacheall|custom" database = "none|oracle10i2|sqlserver" cache-id = "mycache" enabled = "true">
  • Default-policy: The default policy for caching. (Hot Applicable)
  • Default = 'cacheall'
  • Database: Database information is collected to create database sync dependency. (Hot Applicable)
  • Default = 'none'
  • Cache-id:
  • Default = 'mycache'
  • Enabled: Determine whether the policy is in effect or not. (Hot Applicable)
  • Default = 'true'
  • For cacheall policy, it caches all the queries and their results.
    <cacheall-policy expiration-type = "absolute|sliding" expiration-time = "1800" dbsyncdependency = "true"/>
  • Expiration-type: Type of expiration, it can be 'sliding' or 'absolute'.
  • Default = 'absolute'.
  • Expiration-time: Default = 180 sec (3 min)
dbsyncdependency: Determine whether to enable the database-dependency or not.
  • Default = 'true'
  • For custom policy, it includes user-configurable list of queries that should be cached with their results. When custom policy is selected, only those queries results will be cached for which the caching is enabled. You can also specify custom caching policy for all queries.
    <custom-policy>
    <query query-text = "" ["SELECT FROM Products"] | stored-procedure-name = "" ] caching = "true" expiration-type = "absolute"| sliding = "" expiration-time = "180" dbsyncdependency = "true"/>
    </custom-policy>
    </cache-policy>
    </app-config>
    </configuration>
  • Query-text: Text of the query whose result is to be cached OR name of a stored procedure whose output is to be cached.
  • Caching: Determines whether caching is enabled for this query or not.
  • Default = 'true'
  • Expiration-type: Type of expiration, it can be 'absolute' or 'sliding'.
  • Default = 'absolute'.
  • Expiration-time: Default = 180 sec (3 min)
  • dbsyncdependency: Determine whether to enable database-dependency for analyzed queries.
  • Default = " true"
  • In case of stored procedures, query text will be the name of a stored procedure, and there will be no default policy or database sync dependency. User can cache stored procedures result with expiration only, no database dependency is needed here.
See Also
EF Caching Integration | Client Config


Topic: Email Notifications on NCache Events

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Email Notifications on NCache Events

NCache provides built-in facility to notify about events information via Email Notifications. This feature notifies the user via email and also updates about events which are invoked by NCache, from anywhere around the world. NCache raises events whenever any of the following happens.
  • Cache is started or stopped.
  • Cache server joining or leaving the cluster.
  • Cache state transfer is started and completed.
  • Cache size going above configurable 80% threshold.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging | Cache Server Logging | Client Side API Logging


Topic: Enable Client Cache on Client Nodes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Enable Client Cache on Client Nodes

If a client cache is already created but currently is disabled, you can enable this client cache at any time as follows:
Using NCache Manager
  • Right click on Client Nodes in Cache Explorer for a cache.
  • Click on Enable Client Cache option in the right click menu. Client cache becomes disabled for all the client nodes, currently listed under Client nodes in Cache Explorer. Grey square sign on client node indicates a disabled client cache.
  • Client cache becomes enabled for this cache in Cache Explorer. Red square sign on client node indicates that client cache is enabled now.
Please note that you can also enable client cache by right clicking on particular client node instead of Client Nodes in Cache Explorer. In this way, client cache will be enabled for the selected client node only.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Configuring Client Cache Settings | Disable Client Cache | Enable Client Cache


Topic: Step 3: Enable DBCacheDependency in NHibernate

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 3: Enable DBCacheDependency in NHibernate

To enable Database Cache Dependency in nhibernate items, you need to define <database-dependencies> configuration section in the application's configuration file (it could be app.config file if its a desktop application or web.config file if its a web application) and enable database notifications in the database.
To enable DBCacheDependency in NHibernate, do the following:
  1. Provide dbSync type in <database-dependencies> section as follows:
<configuration>
<application-config application-id="myapp" enable-cache-exception="true" default-region-name="default"
key-case-sensitivity="false">
<cache-regions>
<region name="AbsoluteExpirationRegion" cache-name="myCache" priority="Default" expiration-type="sliding"
expiration-period="180"/>
<region name="default" cache-name="myCache" priority="default" expiration-type="none"
expiration-period="0" />
</cache-regions>
<database-dependencies>
<dependency entity-name="nhibernator.BLL.Customer" type="oledb" sql-statement="select ContactName from
dbo.Customers where CustomerID =?" cache-key-format="depdency.customer:[pk]"/>
</database-dependencies>
</application-config>
</configuration>
The type of database dependency is either "sql", "oracle", "oledb". sql is a mechanism for synchronizing your cache with SQL Server 2005 database through .NET events. oledb allows you to synchronize your cache with any OLEDB compliant database through a configurable polling interval. If you specify "sql" value, then you must also specify the sql-statement="...". You specify a "select" SQL statement to identify a row in SQL Server 2005 database that corresponds to this cached item. Then, whenever that row is updated or removed, this cached item is also removed.
2. Enable database notifications on the database except when you are using SQL Server 2005. For further details see Enabling Database Notifications for SQL Server , Enabling Database Notifications for Oracle and Enabling Database Notifications for DB2.
See Also
Configure the Cache | Register NCache with NHibernate | Run your NHibernate based Application


Topic: Entity Framework Caching Integration

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Entity Framework Caching Integration

NCache has implemented a custom ADO.NET provider called as "Entity Framework-Caching Provider" which acts between Entity Framework and the original provider. This section explains what is ADO.NET Entity Framework and the ways to configure and use NCache as Entity Framework Second Level Cache.
In This Section
Overview
Explains Entity Framework and the features of NCache as Entity Framework second level cache provider .
Using NCache as Entity Framework Second Level Cache
Explains how to configure and use NCache as Entity Framework second level cache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

The ADO.NET Entity Framework is a popular object-relational mapping framework. It provide abstraction from the underlying relational data that is stored in a database and presents its conceptual schema to the application.
In most of the high transaction cases, the database quickly becomes a bottleneck. Because in database tier, adding more and more servers cannot scale performance.To achieve this scalability use in-memory cache provider module along with Entity Framework application. Although, Entity Framework does not provide a Second Level Cache provider model but it is flexible to support second Level Cache Provider.
Entity Framework Caching Provider
NCache has implemented a custom ADO.NET provider called as "Entity Framework-Caching Provider" which acts between Entity Framework and the original provider. NCache provides the features listed below:
  • No Code Change: NCache Entity Framework Caching Provider can be integrated in application without any code change.
  • Better Performance: NCache custom provider intercepts all the database queries calls and puts result-sets of queries in a cache storage. This increases the performance of applications by avoiding expensive databases trips.
  • Application Scalability : NCache provides a reliable and shared memory resource for storage. It gives the ability for sharing transactional context between different entities in any entity framework application.
The caching provider can perform various functions, such as:
  • Managing connections, commands, transactions and data read
  • Monitoring queries and commands before they execute.
The following figure shows how and where NCache Entity Framework Provider plugs into an Entity Framework application.
Entity Framework Caching Integration Modes
There are two execution modes for NCache Entity Framework Caching Provider:
  1. Analysis Mode
  2. Caching Mode
These modes are mutually exclusive, so NCache Entity Framework Caching Provider cannot execute in both modes at the same time. It can either be in "Caching" mode or in "Analysis" mode
Recommendation: First execute the entity framework application within analysis mode of NCache Entity Framework-Caching Provider.
1. Analysis Mode:
Analysis mode is a pass-through mode, no caching is done at this mode. This mode provides features that are listed as follows:
  • Monitoring Query: Monitoring the number of times each query is executed by Entity framework Application. This allows the user to determines which queries are most frequent and are the best candidates for caching.
  • Generate Reports: It generates reports for queries with proper syntax and also arranging them in descending order. That allows the user to choose suitable queries and copy them for caching.
2. Caching Mode:
This mode is basically designed for the actual use of NCache in Entity Framework applications. At this point, queries and their result sets are cached. Caching mode only entertains those queries which are given in configuration file i.e. efcaching.ncconf.
See Also
Using NCache as Entity Framework Second Level Cache | NHibernate | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features


Topic: Error Logging

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Error Logging

When running a cache, error messages can be helpful. These messages can be saved to a log file if required. NCache Manager can be used to enable logging. You will find this option on Options Tab of Cluster/Local Cache view window. Each time user enables error logging a new trace file is created in the "log-files" folder under NCache installation directory with current time stamp.
Enabling error logging generates fatal and normal logs, while enabling detailed error logging generates log file containing info, debug and warning logs. By default, logging is disabled. Enabling "Detail error logging" generates logs very frequently, which may affect the performance of cache/cluster. In case of an error, it is reported in the application's event log in system.
Enable logs for Java Client
Logging in the NCache Java client can be controlled by setting enableNCLogs property before initializing the cache. This is how you can enable error logging for Java Client.
[Java]
System.setProperty("enableNCLogs", Level.INFO.toString());
Log file is generated in the application home directory. The above property will enable logging of all INFO messages. It will also enable logging of SEVERE and WARNING messages.
The Level class (Java.util.logging) defines a set of standard logging levels that can be used to control logging output. The logging Level objects are ordered and are specified by ordered integers. Enabling logging at a given level also enables logging at all higher levels. Clients should use the predefined Level constants such as Level.SEVERE. The levels in descending order are as follows:
  • SEVERE (highest value)
  • WARNING
  • INFO
  • CONFIG
  • FINE
  • FINER
  • FINEST (lowest value)
In addition, there is a level OFF that can be used to turn off logging, and a level ALL that can be used to enable logging of all messages.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Evaluation Period Expiration & Extension

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Evaluation Period Expiration & Extension

By default, when you install NCache, it is installed as an Evaluation Copy and is valid for 60 days only. At the end of this period, NCache will stop working.
Indications of NCache Being Expired
You will be able to notice that NCache evaluation period has expired from the following indications:
• NCache API will no longer work. You won't be able to add or fetch items from cache.
• NCache Manager splash screen will show NCache evaluation period expired.
• NCache Manager window title will show “Expired”.
• NCache Manager HELP -> ABOUT dialog will show NCache has expired.
• You won't be able to add an expired cache server to a cache cluster from NCache Manager.
• You won't be able to start cache on an expired cache server.
Extending Evaluation Period
If any of the above happens, then it's time for you to either purchase NCache licenses or if you need an extension to your evaluation period, you can get an Extension Key from Alachisoft Sales. Please send an email to sales@alachisoft.com (or to your account manager if you're already in touch with him/her) and ask for an extension key. You will be provided a 30-day extension key.
Once you have obtained the extension key, please follow the steps given below to extend your evaluation period.
  • Run NActivate Wizard from "%Install Directory%/NCache/bin/NActivate" path. Below is a screenshot for the screen to be displayed. Please select Extend evaluation period option and then click Next button.
  • A new dialog box will appear. Here, enter the extension key provided to you by Alachisoft Sales and then press Finish. If this key is valid, you will be prompted with a Success message. If the key is not valid, you will be prompted accordingly.
A 30-day extension is valid from the original installation date and not from the day you are trying to extend. So, if you have been waiting for 15 extra days after the initial 60 day evaluation period to extend it, you'll only get 15 extra days extension.
See Also


Topic: Cache Event IDs

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Event IDs

Below is a table explaining Cache Event IDs.
Event Name | ID | Description
CacheStart | 1000 | Cache Started Successfully
CacheStop | 1001 | Cache Stopped Successfully
CacheStartError | 1002 | You don't have permission to perform this operation
CacheStopError | 1003 | Cache cannot be stopped due to an exception
ClientConnected | 1004 | Client has connected to cache
ClientDisconnected | 1005 | Client has disconnected from the cache
NodeJoined | 1006 | Node has joined
NodeLeft | 1007 | Node Has Left
StateTransferStart | 1008 | NCache has started state transfer
StateTransferStop | 1009 | NCache has completed state transfer
StateTransferError | 1010 | NCache has ended state transfer prematurely
UnhandledException | 1011 | An unhandled exception has occurred
ServiceStartFailure | 1013 | NCache Service fails to start (Normally in case of server reboot)
LoggingEnabled | 1014 | Logging enabled successfully
LoggingDisabled | 1015 | Logging disabled successfully
CacheSizeWarning | 1016 | Cache has exceeded from allocated cache size
GeneralError | 1017 | NCache failed to open log
GeneralInformation | 1018 | Any other information that cannot be defined using the current event IDs
ConfigurationError | 1019 | BridgeServer failed to load configuration information
LicensingError | 1020 | NCache evaluation has expired. It can't be extended anymore therefore, please purchase NCache license from sales@alachisoft.com and activate before expiration
SecurityError | 1021 | You don't have permission to perform this operation


Topic: Event Notifications

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Event Notifications

This sections explains how to use notifications that arise as a result of events such as add, insert or remove operations against all or selective cache items, or when cluster status changes.
In This Section
Overview
Explains main types of notifications and levels of events provided by NCache.
NCache Events and Notifications
Explains how to use the three levels of events and notifications using NCache Client API.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

Many applications today need to share data with each other at runtime asynchronously. And relational databases do not provide an efficient event notification mechanism. Hence their performance and scalability is a major concern.
NCache is an extremely fast and scalable in-memory distributed cache and also provides a simple and powerful Data Sharing Features with Notifications.
NCache features event driven fetching of data whenever the data in cache is modified. This allows client applications to receive data without any explicit data fetch request to the cache server. Events work on push mechanism for whenever there is some activity of interest takes place in cache, it publishes events to its subscribed clients. This allows runtime data sharing of single cache shared by separate applications or separate modules of same application.
Events enable NCache to notify client application if something of interest occurs. Events in NCache follow publisher subscriber model where cache is the publisher and client application is the subscriber.
Events have the following properties:
  • The publisher determines when an event is raised; the subscribers determine what action is taken in response to the event.
  • An event can have multiple subscribers. A subscriber can handle multiple events from multiple publishers.
  • Events are typically used to signal common cache operations like Add, Insert, Remove, Delete and Cache Cleared.
Types of Notifications
  • Add Notification
Add notification is triggered when a new item is added to the cache. All applications who have registered this event will receive a notification when data is added to the cache.
  • Update Notification
Update notification is triggered when an existing item is updated in the cache. All applications who have registered this event will receive a notification when data is updated in the cache.
  • Remove Notification
Remove notification is triggered when an item is removed from the cache. All applications who have registered this event will receive a notification when data is removed from the cache.
  • Cache Clear Notification
Cache Clear notification is triggered when cache is cleared. All applications who have registered this event will receive a notification when cache is cleared.
Levels of Events by NCache
NCache provides the following level of events:
  • Cache Level Events
NCache can notify clients on add, insert, and remove of any item in the cache or if the cache is cleared, if the client has registered interest in receiving such events.
  • Item Level Events:
NCache can notify clients on a specific item update and remove if the client has registered interest in it.
  • Continuous Query Events
NCache can monitor a dataset in the cache based on SQL-like criteria and then notify clients for add, update, and remove of items from this data set to clients who have registered interest in it.
  • Application Initiated Custom Events:
Applications can fire custom events into NCache so other applications who have registered interest in them can be notified.
See Also
NCache Event Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming


Topic: Eviction

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Eviction

For every cache, cache size should be estimated in advance with careful consideration of data usage by client application. But cache has storage limitation and if data resides in cache forever, then it will eventually become full. To handle this, NCache's Eviction feature can be utilized. In Eviction, when cache gets full, NCache decides to evict its existing data on the basis of usage or priority to accommodate new incoming data. Eviction will smooth cache operations while keeping cache size limited by removing a configured percentage of data.
NCache provides different polices for eviction. These policies decide which data would be evicted when cache is full. Following eviction policies are provided by NCache:
1. Priority Based Eviction
This eviction policy lets cache evict less important data first.This policy should be used if the cached data can be categorized with respect to its importance. NCache has defined the following levels of priority to categorize the cached data. These priorities are assigned while adding data to the cache.
  • Low
  • Below Normal
  • Normal
  • Above Normal
  • High
  • Not Removable
This priority level specifies that cache item should not be evicted.
2. Least Recently Used (LRU)
In this eviction policy, the data which is no longer in use is evicted. Similar to priority based policy; cached item indexes are also maintained in least recently used policy. Items are indexed on their last access time; these indexes are maintained for each cached item. When cache becomes full and there is a need for eviction, selection of data for eviction is based on these indexes. The data which was accessed a long time ago is a more suitable candidate for eviction than the data which is accessed recently. The access time is updated each time the data is fetched or updated in the cache.
3. Least Frequently Used (LFU)
In this eviction policy, data is evicted based on its frequency of usage i.e. how many times a particular data is accessed by the client application(s). Using least frequently used policy, cache maintains index on the basis of the frequency of usage of each item. When a cache is full and requires eviction, selection of the prospect items for eviction is based upon these indexes maintained by cache. Cache removes the least frequently used data first.
Do not Evict: Along with different policies there is another option to turn off eviction. In this case, when cache gets full, cache does not evict any data instead it rejects all incoming data addition requests.
Eviction Ratio: Eviction ratio can also be specified, i.e., by what percentage data should be evicted from cache. Eviction removes only the configured percentage of data from cache once eviction is triggered.
Warn User when Cache is Near Full: When cache is about 80% full and needs eviction, NCache logs events to both event viewer in windows and also in cache logs files.
Bulk Removal of Data: The number of cache items to be removed during eviction can be huge, depending on cache size and eviction ratio. So eviction removes data in bulk. Size of the bulk operation is configurable through Service.exe.config . Similarly the delay between two bulk removal operations can be configured with the help of server.properties file.
Eviction in Cluster Environment: In Partition and Partitioned-Replica topologies, data distribution is based on hashing algorithm. Each node has divided data thus each node is responsible to evict its own data. However, replica node in partitioned-replica does not evict data themselves; rather data is automatically removed on replica when removed from active node. In replicated topology, every node has the same set of data, only cluster coordinator is responsible for eviction. Mirror Cache has only two nodes, one active and other passive. Thus active node is responsible to carry out eviction on the entire cache.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Runtime Data Sharing


Topic: Data Invalidation Strategies

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Data Invalidation Strategies

The feature "Expirations" is provided by NCache through which certain cached items can be automatically removed from the cache when required. This section explains the basic concept and use of Expirations in NCache.
In This Section
Overview
Explains the basic concept and two types of Expirations provided by NCache
Using Expirations
Explains how to use Expirations in NCache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

The main purpose of a caching solution is to cache the commonly used data which consequently boosts up the application performance. But caching a large amount of data without constantly updating it may lead to stale data. Thus it is very important that cached data must be up to date. For this purpose, an effective caching solution must have data invalidation strategies which can be very demanding in a distributed environment. Fortunately, NCache supports different data invalidation strategies which cover almost all major needs of most of the applications. Depending upon the sensitivity, importance and the rate at which data can change, an appropriate invalidation strategy can be chosen. For instance, the user can decide to keep data in cache on the basis of its access or he/she can invalidate certain data according to its change in master data source. A combination of these strategies can be chosen to keep data refreshed in cache.
Time Based Invalidation
NCache supports time based data invalidation where time or interval can be specified to invalidate cache data. This type of data invalidation is used if changes to the data occur in a deterministic time fashion or where the frequency of data change can be determined. For example, customer information or region information may not be frequently updated, so time based expiration can be used to invalidate such data.
You will specify this time/interval with items of cache data. NCache maintains an index for items with time based expiration. There is a dedicated thread which checks cache data for these expired items. This thread periodically runs after a configurable interval of time called Clean Interval. By default its value is 15 seconds. It means that the maximum time an item can take to be removed from cache is expiration time + clean interval. So this interval shoud be selected carefully according to the expiration time of your data.
NCache provides two types in time based expiration.
  • Absolute Expiration
  • Sliding Expiration
1. Absolute Expiration
In Absolute Expiration, an item can be added to the cache by specifying the exact date and time at which the item should be invalidated. When this time is elapsed, item will be removed from cache. Here NCache maintains UTC time for absolute expiration on caching servers which facilitates in case clients and cache servers are in different time zones. This means that expiration time specified by clients (in any time zones) will be converted to UTC on cache server and item will be expired on exact date and time as specified by clients. Expiration time can range from seconds to days and months.
However, note that the item will be removed when expired on next cache clean up interval. For example, if an expiration of 10 seconds is specified with an item and cache clean up interval is configured to 15 seconds, then the item will be removed within the time frame of 15-25 seconds.
2. Sliding Expiration
In liding expiration, the data is retained in cache as long as it's being used by the application. If the data is not used for a specific period of time, it is removed from cache. For example, ASP.NET session data can be stored in the cache as long as the session is active. For this type of data, sliding expiration ranging from seconds to days and months can be specified.
Whenever a cache data with sliding expiration is accessed, its time to live in cache is extended by the expiration interval specified e.g. an item with 30 seconds sliding expiration will be removed from cache if not accessed for at least 30 seconds or it can be said that with each Get, its expiration interval will be reset to 30 seconds. Similar to absolute expiration, cache items with sliding expiration are removed on cache cleanup interval.
See Also
Using Expirations | Eviction | Configuring Expiration Clean Up Interval | Configuring Eviction Policy | Server Side API Programming


Topic: Features Highlights

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Features Highlights

Below are some features of NCache. Have a look at them:
Light-weight .NET Client
NCache now has a light-weight client that is more scalable and faster than 3.0. This light-weight client uses our own socket level protocol to talk to NCache server (either locally or remotely).
Light-weight Java Client
NCache does not rely on any Java-to-.NET interoperability bridge and instead uses its own socket level protocol to talk to the NCache server (just like the .NET light-weight client). Now you can have your Java applications use NCache as a clustered object cache. This protects your investment in NCache and allows you to keep one cache deployed and used by multiple applications. Java client works the same way as .NET client. The Java client can run on any Java compatible platform.
Failover in Remote Light-weight Clients
Both Java and .NET light-weight clients have fail over capability. This means that if the primary server they're connected to goes down, they'll automatically connect to another server in the cluster. And, you can specify the priority of these servers for each client differently. Additionally, when new servers are added or removed at runtime, this information is passed on to the remote clients so they can use them for failover as well.
Security
NCache now provides security with authentication and authorization built into the product. Authentication is done through LDAP. NCache allows you to specify administrators and users. Administrators can manage the cluster while the users can only make runtime API calls to a specific cache. NCache allows you to save data in encrypted form in order to secure your data. For this 3DES Encryption algorithm is used.
Application Connects to Multiple Caches
NCache client applications can now connect to multiple caches simultaneously. This allows you to keep multiple caches for different purposes and share them across applications more effectively.
Multi-key Event Notifications
Applications can register interest into multiple items in the cache to be notified when they're updated or removed. Then, whenever these items are updated or removed, the client application is notified anywhere in the cluster.
Synchronize Items in Multiple Caches
A new cache dependency called CacheSyncDependency is added that allows items in one cache to be dependent on items in another cache. This way, for example, you can have a Local Cache that keeps items frequently used by your application and a Clustered Cache that keeps a larger number of items being shared with other applications. And, your local items are kept synchronized with the clustered cache so you never have any data integrity problems while improving your app performance even further.
Cluster Management Events
NCache fires events whenever a node joins or leaves the cluster or when a client finds that its server has gone down and it now needs to connect with another server. You can write hooks for these events and take appropriate actions when these events occur.
Cache Management API
You can now manage the cache through API (in addition to NCache Manager and command line tools). You can start or stop a cache from an API now.
Multiple Cache Instances on same Server (TCP Port Range)
You can now run multiple cache instances (as InProc) on the same server without any port conflict. Now, you can specify a range of TCP ports to be used for cache clustering instead of only one port previously. This way, multiple instances of the cache can run with each instance using one port.
Callbacks for Async operations
You can now specify a callback for AddAsync, InsertAsync, and RemoveAsync operations. This callback is called when the operation completes either successfully or with a failure.
Performance Improvement to Partitioned Cache with Replicas
NCache has now optimized communication in the cluster for this topology.
Native .NET Clustering
  • NCache developed natively in .NET
  • Truly scalable peer-to-peer multicasting clustering
  • Automatic and transparent node failure recovery
  • On the fly addition and removal of servers
Caching
  • Easy to understand API
  • Same API for Local or Clustered environments
  • Cache configuration through a graphical tool (NCache Manager)
  • Fixed or variable sized cache
  • Time-to-live expiration of cache entries
  • Fixed-time expiration of cache entries
  • Idle-time expiration of cache entries
  • Least-Recently-Used (LRU), Least-Frequently-Used (LFU), and Priority based Eviction Policies
  • Expired Items Resynchronization
  • SQL and OleDB Cache Dependency
  • Support for custom dependencies
  • Event Notifications in Local and Clustered environments
  • In-process and out-of-process cache configurations
  • Heap, raw memory, memory mapped file, and file based storage options.
  • Intelligent relationship management through File and Key based dependencies
  • Read-through and Write-through caching
  • High performance Write-behind caching
  • Clustered Location Transparency
  • Clustered Lock Management
Clustering Options
  • Replicated Cache
  • Partitioned Cache
  • Client Cache
  • Data-less Nodes
  • UDP and TCP based Cluster
HTTP Clustered Session Management
  • Maintain and synchronize session state throughout a server farm
  • Users can now move from server to server on each http request
  • Achieve optimum load-balancing (no more sticky sessions needed)
  • No single-point-of-failure due to sophisticated clustering topologies
  • Built on top of NCache clustering to true in-memory performance
  • Same API as Clustered Session State
GUI Based Cache Configuration
  • NCache Manager is a Windows GUI
  • Create and manage Local Cache or Clustered Cache from it
  • View rich statistics on the entire clustered cache from a single point
  • Change clustering topology without affecting the client application
  • Add or remove nodes from the cluster at run-time
See Also
What's New in NCache 4.4? | Caching Topologies | Copyright ©


Topic: Fetching the Statistics using Server IP or Server Name

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Fetching the Statistics using Server IP or Server Name

Statistics data is fetched in either of two ways, using server name or server IP. This option is configurable. By default
NCache use the server name to fetch the performance counters from servers.
Using NCache Manager
  • Open NCache Manager.
  • Go to Tools menu option.
  • Select Options and a dialog box appear with Statistics, Management and Startup tabs. Go to the Statistics tab.
  • In this tab, under Statistic Options, there is an option Fetch statistics using with two radio buttons Server Name and IP Address.
  • Choose the required option and click OK to save your selection.
See Also
Changing Management Port of a Cache Node | Configuring Counters to Display | Cluster Health | Monitoring Clustered Caches using NCache Email Alerts | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches


Topic: Adding Data with File and Key Dependencies

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Adding Data with File and Key Dependencies

Data in cache can depend on items like a file on some location, a record in database, results of a particular query or another cached item, such that any change in the item which has dependent data in cache invalidates the data. In that case all dependent data must be reloaded or removed from cache otherwise data will become stale.
Adding Data with Key Dependency
An object can be specified as being dependent on another key at the time of addition. Note that the only keys present in cache can be specified as key dependency. Nonexistent key specified as key dependency will result OperationFailedException.
The following code shows how to add an item with key dependency:
// precondition : Item with key "Product:1001" already exists in cache
Product product=new Product();
product.ProductID=1002;
product.ProductName="Chang";
string key1="Product:1001";
string key2="Product:"+product.ProductID;
try
{
//Adding cache item "Product:1002" with KeyDependency on "Product:1001"
cache.Insert(key2, product, new KeyDependency(key1), Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
//Removing/Deleting/Updating key: "Product:1001" will automatically make all of its dependant keys removed, here it's "Product:1002"
}
catch (OperationFailedException ex)
{
// handle exception
}
In Key Dependency an item can only depend on an existing item, thus all dependency keys must exist in cache before an item can depend on them.
Adding Data with File Dependency
Following code shows how to add data with File Dependency.
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
string filepath = "C:\\tempProductList.txt";
try
{
//Adding cache item "Product:1001" with FileDependency on file "tempProductList.txt"
cache.Insert(key, product, new FileDependency(filepath), Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch (OperationFailedException e)
{
// handle exception
}
//Modifying file: "Product:1001" will automatically removed
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency


Topic: Finding Items

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Finding Items

Items can be retrieved from cache either by using Get method or the cache indexer. Both methods are explained below with examples.
Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Get Method
Here is how items can be retrieved fom the cache.
Cache _cache = NCache.Caches["myCache"];
// Returns null if item not found
object myObject = _cache.Get("Customer:David:1001");
if (myObject == null)
{
// Item not found
}
Using Cache["key"]
Here is another way to retrieve items from the cache.
Cache _cache = NCache.Caches["myCache"];
// Returns null if item not found
object myObject = _cache["Customer:David:1001"];
if (myObject == null)
{
// Item not found
}
Using Contains Method
You can also check whether an item exists in the cache or not.
Cache _cache = NCache.Caches["myCache"];
// Returns true or false
if (_cache.Contains("Customer:David:1001") == false)
{
// Item found
}
See Also
Initialize Cache | Adding Items | Removing Items | Dispose Cache | Start Cache | Stop Cache


Topic: Force State Transfer

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Force State Transfer

State transfer is process in which bridge ask the master cache to re-replicate all of its cached objects to the bridge. The main benefit of this process is to make sure the other cache in this bridge is resynchronized with the master cache. By default, state transfer is initiated on the change of master cache, cache connection after disconnection or on cluster restart.
You can execute state transfer at any time after bridge starts to synchronize both caches. Force state transfer using NCache Manager as follows:
Using NCache Manager
  • Right click on the active cache name (which is not marked as master cache) under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Force State Transfer option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: GeneralFailureException

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

GeneralFailureException

You may get this exception when any general type error occur in NCache. For example when the required jar files are not available at their appropriate location or if you cannot connect to the target cache etc.
Workaround
  • Run 'install.bat' file at least once before start using NCache Client API. This file is located at %INSTALL_DIR%/NCache/java/lib/.
  • 'installer.jar', 'NCActivate', 'NCRuntime.jar', 'NCSerialization.jar', 'NCClient.jar' and 'javaReg.properties' should also be present at the above mentioned location.


Topic: Registering Generic Classes using Generic Type Handler

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Registering Generic Classes using Generic Type Handler

NCache also gives you the facility to configure all required generic classes at once using Generic Type Handler. For this, first of all, you have to implement IGenericTypeProvider interface. Write the code for all the required combinations for all data types that can be used in your application. This can be done as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Compact Serialization tab.
  • Click the Generic Type handler button.
  • In the Select Compact Classes dialog, click Browse to select the assembly that contains your generic type provider
class, for which you have implemented the IGenericTypeProvider interface.
  • All of the classes that had the implementation of the IGenericTypeProvider interface will get listed in Class Name drop
down menu. Select the required generic type provider class from the drop down list.
  • Click OK. It loads all of the generic classes with their generic types.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Generic Classes | Registering Non-Generic Classes


Topic: Fetch Data from Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Fetch Data from Cache

Primarily a cache is only considered as effective as its ability to retrieve data. NCache utilizes the key-value architecture of its store to maximize the ways of data retrieval. Get method is the primary API provided to serve previously cached data; however basic indexer approach can also be used. Both of these methods are explained below.
Retrieve Data using Get Method
In this example, the basic Get method is used to retrieve item “Product:1001”. This item has previously been added to the cache. Get method returns general object which needs to be casted accordingly. If a key does not exist in cache null value is returned.
string key = "Product:1001";
Product product = null;
try
{
//null is returned if key does not exist in the cache.
object result = cache.Get(key);
if (result != null)
{
if (result is Product)
{
product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieve a CacheItem
In this example, the basic GetCacheItem method is used to retrieve item “Product:1001”. This item has been added to the cache. This method returns CacheItem whose value property encapsulates the data; the Object value need to be cast accordingly.
string key = "Product:1001";
Product product = null;
try
{
CacheItem result = cache.GetCacheItem(key);
if (result != null)
{
if (result.Value isProduct)
{
product = (Product)result.Value;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
/ handle exception
}
Retrieve Data with Cache Indexer
NCache being a key-value paired structure lets the user perform operations like any other indexed based data structure. In this example a cache handle is used to directly access cached values using square brackets ”[]”.
string key = "Product:1001";
Product product = null;
try
{
CacheItem result = cache.GetCacheItem(key);
if (result != null)
{
if (result.Value isProduct)
{
product = (Product)result.Value;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
/ handle exception
}
Retrieve Data with Cache Indexer
NCache being a key-value paired structure lets the user perform operations like any other indexed based data structure. In this example a cache handle is used to directly access cached values using square brackets ”[]”.
string key = "Product:1001";
Product product = null;
try
{
object result = cache[key];
if (result != null)
{
if (result is Product)
{
product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception }
Check If an Item Exists in Cache
In order to verify if a key exists in the cache or not, the contains method can be used. This method determines whether cache contains the specific key and returns true if key already exist in cache and false if not.
string key = "Product:1001";
try
{
if (cache.Contains(key))
{
// do something
}
else
{
// do something
}
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Creating Caches | Initialize Cache | Add/Update Data to Cache | Remove Data from Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache


Topic: Getting Started

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Getting Started

NCache provides a Windows Installer Package (.msi) to let you easily install NCache. However, before you install NCache, keep the following points in mind.
What to Install during Evaluation?
NCache Enterprise: Regardless of which NCache edition you ultimately end up using, you should do your evaluation with NCache Enterprise. This is because you will be able to see all the features that NCache offers in full and then decide whether you need to downgrade to NCache Professional or stay with NCache Enterprise.
Installation Options
Whether you install NCache Enterprise or Professional, you're given the following installation options when you run the .msi file.
  • Cache Server: This is a full install of NCache and contains everything that the other two options provide plus cache clustering capability. You must install this on any server where you're going to host the cache, regardless of whether you have dedicated or shared cache servers.
  • Remote Client: This installs the remote client libraries and client cache on all your web/app servers so you can access the cache across the network. Please note that you need remote client libraries to access the cache across the network.
  • Developer: This installs the NCache API, online help/documentation, and a local stand-alone cache without any clustering capability. Please note that you cannot access a remotely hosted cache from a developer install machine. You can access only a local cache.
Where to Install NCache?
Production, Staging, QA, or Dev Servers: Install NCache Enterprise Edition on the following:
  • Cache Servers (dedicated or shared): If you have 4 or more web/app servers in your environment hosting your application, then we recommend a dedicated caching tier of 2 servers. A dedicated cache cluster should have a minimum of 2 servers for replication and then a ratio of 5:1 between your web/app servers and the cache servers. For smaller environments, even using your web/app servers as cache servers is fine, as long as you have enough memory available on these machines.
  • NCache Remote Clients (App or Web Servers): Any web/app server that is not hosting the cache server but instead will access it remotely across the network is considered an NCache remote client. You need to install the "remote client" portion of NCache on these machines.
  • Developer Workstations: If you're using NCache for object caching, you will be making NCache API calls within your application. Therefore, you need to install NCache "Developer" portion on all the developer machines. A developer install includes all the NCache API's, online help, and a local stand-alone cache. Please note that you cannot access any cache remotely from a developer install .
System Recommendations
  • Windows 2003/2008 Server (64-bit) as Cache Servers: It is highly recommended that you use 64-bit Windows 2008 or 2012 Server platform for cache servers.
  • Adequate RAM in cache servers: NCache puts a minimum of 15% overhead on top of your data. However, this overhead may grow to be a lot more than 15% if you’re using indexes since each index uses memory. Please keep this in mind while deciding how much memory to have in your cache servers. The total memory you need depends on how much data you plan to store in cache.
  • Two 1Gbit NIC's in cache servers: If you have two NIC's in cache servers, it allows you to configure NCache so that it uses one of the NIC's for cache clustering and the second one for client/server communication. This improves your throughput greatly.
  • Dual-CPU, Quad-Core or higher: NCache is a highly multi-threaded software and takes full advantage of extra cores and CPUs. The most common configuration for NCache is a dual-CPU quad-core machine. You may need stronger processing power if you have higher transaction loads and/or larger amount of data being stored in NCache. Please consult NCache technical support to get a specific recommendation for your needs.
  • Disk: NCache does not make heavy use of disk space. Hence you don't need any extra disk space in your cache server machines.
See Also
Command Line Install | Network Install with PowerShell | Interactive Windows Installer | Evaluation Period Expiration & Extension | Activate NCache Purchased License


Topic: Getting Started

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Getting Started

This section provides you information about installing NCache Java Client in UNIX environment. It provides the system and software requirements, along with information about the administrative privileges you need in order to install NCache Java Client.
Installation
On the UNIX platform you can install NCache Java Client only in Command Line Mode through Custom Installation (.tar.gz) installation mode. In custom installation, you can specify customized parameters for installing NCache Java Client. Without customization, NCache Java Client is installed according to default values and in the /opt/ncache/ directory. To view the complete installation steps please see Installation .
Installation Types
When you install NCache Java Client Enterprise, you are only given the remote client installation option. This option installs the remote client libraries and client cache on all your web/app servers so you can access the cache across the network. Please note that you need remote client libraries to access the cache across the network.
Installer Account Privileges
Installing NCache Java Client on your system requires special user privileges.
  • In order to install NCache Java Client on your machine, you need to have “root” privileges.
  • You can specify a user at the time of installation and NCache Java Client service process runs under this user’s identity. You can also set a password for the specified user, though it is optional. In case you don’t specify a user, a default user “NCache” is created.
Installation Requirements
  • System Requirements
  • UNIX OS as Clients: NCache Java Client is officially supported on RedHat Enterprise Linux Server (v 6.4), Fedora (v 18), CentOS (6.3) and Ubuntu Server (12.10).
  • Adequate RAM in Cache Clients: Each NCache Java Client server uses around 40-50MB memory as a JVM process and will not use further memory until unless you are using client cache. If you are using client cache then it puts 15-20% overhead on whatever you cache. Please keep this in mind when deciding how much memory to have in your cache clients. The total memory you need depends on how much data you plan to store in the client cache. If you’re storing JSP Servlet Sessions, then figure out your average session size and maximum number of sessions you will ever have in the cache. You can do the same for application data caching.
  • Dual-CPU, Multi-core: NCache Java Client is a highly multi-threaded application and takes full advantage of extra cores and CPUs. The most common configuration for NCache Java Client is a dual-CPU machine where each CPU is either dual-core or quad-core.
  • Disk: NCache Java Client does not make heavy use of the disk space so you don’t need any extraordinary disk space in your cache server machines.
  • Software Requirements
JRE/JDK 1.5 or above
Where to Install NCache Java Client
Any web/app server that is not hosting the cache server but instead accesses it remotely across the network is considered an NCache Java Client Remote Client. You need to install the Remote Client portion of NCache on these machines.
See Also
What is NCache Java Client? | Installation Steps for UNIXl | Post Installation License Management for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX


Topic: Getting Started

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Getting Started

Familiarizes you with the fundamentals of NCache and offers help to use NCache quickly and efficiently.
In This Section
Quickly Configure and Use NCache
Describes basic steps for smooth installation, configuration and use of NCache.
Quickly Use Cache API in .NET
Describes most common API's provided by NCache with examples for .NET users.
Quick Start Guides for .NET
Provides quick start guides to use .NET features with NCache.


Topic: Quickly Configure and use NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Quickly Configure and use NCache

Here are some basic steps you should follow to ensure a smooth installation, configuration, and use of NCache.
Add Reference issue of Visual Studio 2010
If your development environment is Visual Studio 2010, you may not be able to see the NCache .NET assemblies in the "Add Reference" dialog box under ".NET" tab. However, you can add reference to the NCache assemblies by using the "Browse" tab. You can find all these assembly files in [NCache Installed folder]/bin/assembly/
1. Install NCache on Cache Server and Remote Client Machines
Install NCache on all remote client and cache server machines. If you have a separate caching tier, you'll have remote clients. Otherwise, cache will be hosted on your application server.
You can install either 32-bit or 64-version of NCache. 64-bit cache servers work fine with 32-bit clients.
2. Configure Servers for Multiple Network Cards (optional)
If your cache servers (including your app servers if you're hosting cache on them) have multiple network cards, then you must bind NCache to a specific card. You need to specify the following in "Alachisoft.NCache.Service.exe.config" in "NCache/bin/service" folder:
<appSettings>
...
<add key="NCacheServer.BindToClusterIP" value="20.200.20.200" />
<add key="NCacheServer.BindToClientServerIP" value="20.200.20.200" />
...
</appSettings>
Anytime you modify "Alachisoft.NCache.Service.exe.config", you must restart NCache Service. You can do this through following commands:
C:/Users/Administrator>net stop ncachesvc
C:/Users/Administrator>net start ncachesvc
You can also bind Client/Server communication to a different network card than the Clustering network card, if you have multiple network cards. Or, you can bind both to the same card (as shown above).
3. Open Firewall TCP Port for Clients (optional)
If there is a firewall between your remote clients and the cache servers, then you must open a TCP port (default 9800) for the remote clients to talk to the cache servers. If you want to change this from 9800 to another port, then you must make changes in all remote client and all cache server machines. On the remote clients, you need to change the "port" value in "client.ncconf" as following:
<configuration>
<ncache-server port = "9800" client-request-timeout = "90" connection-retries = "1" retry-interval = "0" connection-timeout = "5"/>
</configuration>
And, you need to change the "NCacheServer.Port" value in "Alachisoft.NCache.Service.exe.config" file located in "NCache/bin/service" folder on all cache servers as following:
<appSettings>
...
<add key="NCacheServer.Port" value="9800" />
...
</appSettings>
Anytime you modify "Alachisoft.NCache.Service.exe.config", you must restart NCache Service (as described above).
All remote clients by default talk to NCache servers on TCP port 9800. So, if there is a firewall between the remote clients and the cache server, then you must open TCP port 9800 in your firewall.
4. Open Firewall TCP Port for Cache Cluster (optional)
If you have a situation where there is a firewall between the cache servers and the cluster must be formed across this firewall, then you must open at least two TCP ports (bi-directional) in this firewall. This port is the Cluster Port specified by you while creating a new clustered cache. For example:
Cluster Port: 7800
Port Range: 1
Open ports 7800. If Port Range is 2, then open 7800 and 7801.
5. Create New Clustered Cache
Run NCache Manager from ONLY ONE location (preferably from one of your cache servers), and create a new clustered cache. You can choose to create one of the following types of caches:
  1. Mirrored Cache
  2. Partitioned Cache
  3. Partitioned Cache with Replicas (recommended)
  4. Replicated Cache
For starters, we recommend to create a Replicated Cache. Later on, you can decide whether a different caching topology meets your requirements better or not. For now, we want to go through the entire process quickly.
6. Test Cache Cluster from Statistics Window
Once you have created a clustered cache, you should test to make it sure that it works fine. Here are the steps to test the cluster from within NCache Manager.
  1. Start the cache
  2. View Statistics of the cache (right-click menu)
  3. Press Add button on top of the Statistics window. It should add "10" dummy items to the cache. And, the "Count" counter should reflect this. If you have a Replicated Cache, then all cache servers should show the same "Count" value and if Count value is same, then cluster is working fine.
7. Remote Client Machines
NCache provides remote client management through NCache Manager. By right click on the Client Nodes, context menu will appear having "Add Node" option as shown in figure. Using this option you can add and configure a single or multiple client nodes in a clustered cache.
8. Ensure All Objects are Serializable
Whether you're using NCache for ASP.NET Sessions or for object caching, you must ensure that all .NET objects are serializable. This is true even for those .NET objects which are being stored in your Session. Here is how to ensure that:
[Serializable]
class Product
{
...
}
9. Modify "web.config" for ASP.NET Sessions
If you're using NCache for ASP.NET Sessions, you need to modify your "web.config". For .NET 1.1, you need to specify an HttpModule (see online help and "samples" for example). And, for .NET 2.0 or later, you need to add a custom Session State Provider (SSP) to your "web.config" as following:
For Enterprise and Professional Edition:-
<compilation defaultLanguage ="C#" debug="true" >
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider,
Version=x.x.x.x,Culture=neutral,
PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
</compilation>
For Open Source Edition:-
<compilation defaultLanguage ="C#" debug="true" >
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider,
Version=x.x.x.x,Culture=neutral,
PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
</compilation>
Replace version “x.x.x.x” with the actual NCache version that you have.
<sessionState cookieless = "false" regenerateExpiredSessionId = "true" mode = "Custom" customProvider = "NCacheSessionProvider" timeout = "20">
<providers>
<add name = "NCacheSessionProvider" type = "Alachisoft.NCache.Web.SessionState.NSessionStoreProvider" sessionAppId = "NCacheTest" cacheName = "myTestCache" writeExceptionsToEventLog = "false"/>
</providers>
</sessionState>
Please read online help for more details on each of the above properties. For now, just make sure that cacheName="myTestCache" reflects name of the cache you've created.
10. Configure Visual Studio Project for Object Caching
If you're using NCache for ASP.NET Sessions only, then you do not need to do anything here. However, if you're using NCache for object caching where you'll be making NCache API calls, then you need to do the following in your Visual Studio project and also your C# or VB.NET source code.
  1. Reference "Alachisoft.NCache.Web" assembly in your project.
  2. Use "using Alachisoft.NCache.Web.Caching;" in your C# files and its equivalent in your VB.NET files.
You can test NCache using the following code example:
Cache cache = NCache.InitializeCache("myCache");
cache.Add("Customer:David:1001","Data");
cache.Get("Customer:David:1001");
cache.Dispose();
11. Run Application and Monitor from NCache Manager
You're now ready to run your application. Once you do, you can watch the cache performance from the Statistics window in NCache Manager. Below is an example:


Topic: Graceful Node Down

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Graceful Node Down

With client operations there are many operations that are performed in background of cluster cache. When any server node in cluster cache is stopped, then all those background operations are lost which result in data lost. To avoid operation lost, the user should always gracefully down any node. Server node is not stopped until all the background operations are completed or graceful down time out is elapsed.
If any task takes a longer time than shut down timeout, like in write-behind, database transactions can take longer than expected time, then count of the remaining operations will be written in cache server logs but those operations will be lost.
Configurable Time Outs: Shutdown timeouts are configurable in NCache's service configuration file by the following tags:
  • CacheServer.GracefullShutdownTimeout: Total timeout of graceful shutdown. Default value is 180 seconds.
  • CacheServer.BlockingActivityTimeout: Timeout of wait for operations completion which are started before blocking activity.  Default value is 3 seconds.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Portable Data Types (.NET & JAVA) | IP Binding


Topic: Grouping Cached Data

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Grouping Cached Data

Adding an Item to Data Group
Data can be added to NCache asynchronously using AddAsync method.
In this example an object is added to the cache asynchronously. The following code adds an item to cache with data group "Product" and sub group "Beverages". In this example, AddOperation will be used to set group and sub-group of the item.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" + product.ProductID;
try
{
cache.Add(key, product, "Product", "Beverages");
}
catch (OperationFailedException ex )
{
// handle exception
}
Adding Data Group with CacheItem
In this example data group is set by assigning it as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" + product.ProductID;
CacheItem cacheItem=new CacheItem(product);
cacheItem.Group="Product";
cacheItem.SubGroup="Beverages";
try
{
cache.Add(key, cacheItem);
}
catch (Exception ex )
{
// handle exception
}
Updating an Item in a Data Group
If the user adds an item without any group or wants to add a group with that cached item, then he/she has to to first remove that item from the cache then insert/Add that item within the desired group and sub group. Otherwise, insert operation throws data groups mismatch exception.
Retrieving Keys Pertaining to a Particular Group
To return the list of keys that belong to a specified group and sub-group, the GetGroupKey method can be used. This method returns an arrayList of keys.
try
{
ArrayList keys = cache.GetGroupKeys("Product", "Beverages");
foreach (object obj in keys)
{
// do something
}
}
catch (Exception ex )
{
// handle exception
}
Retrieving Keys and Values Pertaining to a Particular Group
To return the dictionary of keys and values that belong to a specified group and sub-group, the GetGroupData method can be used. This method returns a dictionary of keys and values.
try
{
IDictionary dict = cache.GetGroupData("Product","Beverages") as System.Collections.IDictionary;
if (dict.Count> 0)
{
IDictionaryEnumerator ide = dict.GetEnumerator();
while (ide.MoveNext())
{
string key = (string)ide.Key;
object val = (object)ide.Value;
// do something
}
}
}
catch (Exception ex )
{
// handle exception
}
Removing a Data Group
The following code removes all items from data sub group 'Beverages' inside group 'Product'.
try
{
cache.RemoveGroupData("Product", "Beverages");
}
catch (Exception ex )
{
// handle exception
}
See Also
Group/Subgroup Overview | Tags | Named Tags | Object Query Language (OQL) in NCache | Server Side API Programming


Topic: Group/Subgroup

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Group/Subgroup

NCache provides a feature to divide related data into logical groups and subgroups. This sections explains the basic concept of groups and using this feature using the client side API provided by NCache.
In This Section
Overview
Explains the basic concept and do's and dont's of using groups in NCache
Grouping Cached Data
Explains how to distribute data into groups and subgroups using NCache Client API.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

Group/sub-group is a hierarchical way of grouping cached items. Let’s say, a cache has a large amount of product information. These products range from products like beverages, grocery to electronics etc. Among these products, there are further divisions like in electronic section group; there can be sub groups of home appliances, computer system gadgets, photography gadgets etc. Group is a logical partition of data; this partition can have a sub division (sub group) or can be just a major division (group), it is a two level grouping. Groups do not overlap but sub groups can be the same in one or more groups.
Case Sensitive: Group and sub group identifiers are case sensitive.
Retrieve/Remove using Groups: Using groups, all the items belonging to a particular group can be fetched or removed. The user can fetch just the keys and then only fetch a subset of them. Addition, update, removal, retrieval can be performed by specifying group identifier and/or its sub group identifier. Group keys or group data can be fetched using GetGroupKeys and GetGroupData API respectively.
Multiple Sub-Groups: NCache supports multiple sub groups within one group. But cache operations cannot be performed only with a sub group identifier, as two different groups can have the same sub group identifier.
Group Identifier cannot be Updated: Group identifier cannot be updated. For its update, cache key must first be removed and then inserted with a new group identifier.
See Also
Grouping Cached Data | Tags | Named Tags | Object Query Language (OQL) in NCache | Server Side API Programming


Topic: Hot Apply Configuration

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Hot Apply Configuration

Settings of a cache that are changed while it is running can be successfully configured using hot apply configuration as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to apply the configuration settings.
  • Click on the Hot Apply Configuration option in the right click context menu.
Your changes will be applied on all of the nodes of this clustered cache.
  • You can also apply configuration using tool bar buttons in the manager.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Apply Configuration | Reset Configuration | Data Load Balancing


Topic: How to's

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

How to's

This section contains the most commonly asked question.
In This Section
How to do NCache Version Upgrades?
Describes how to upgrade Microsoft SharePoint Server 2007 to Microsoft SharePoint Server 2010.
What is the Recommended Way to Apply Windows Patches on NCache Server?
Describes how to convert External BLOB Storage to Remote BLOB Storage without copying BLOBs .


Topic: How to Configure and Use NCache Manager for Visual Studio

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

How to Configure and Use NCache Manager for Visual Studio

This guide helps you to configure and use NCache Manager in Visual Studio
Note: NCache Manager for Visual Studio will only work with 2010, 2012 and 2013 versions of Visual Studio and its editions which support extensions.


Topic: Import/Export Data Share Configuration

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Import/Export Data Share Configuration

Data sharing configurations can be imported and exported using the following method.
Using NCache Manager
Export Data Share Configurations
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Data Sharing tab.
  • Click on the Export button and save the data sharing configuration in an xml file.
  • Provide a file name and click Save.
Import Data Share Configurations
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Data Sharing tab.
  • Click on the Import button to get the data sharing configuration from an XMLl file.
  • Browse the saved data share configuration file and click Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use adddatashare tool, provide the required information:
adddatashare demoLocalcache -T C:/temp/SharedTypes.xml
  • Hit ENTER key, it will configure shared types from the provided xml file.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Classes for Portable Data Sharing


Topic: IndexNotDefinedException

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

IndexNotDefinedException

In case no nametag has been added to a cache and the cache is searched with SearchCQ for nametag values, you get "IndexNotDefinedException". If you want that no such exception should be thrown even if you have not added any nametag to your cache, NCache now provides a way to disable this exception.
Workaround
You can suppress this exception by following these steps:
  • Go to Alachisoft.NCache.Service.exe.config located at
    %INSTALLATION_PATH%/NCache/bin/service/Alachisoft.NCache.Service.exe.config
  • Add the following line in the configuration file:
<add key = "NCacheServer.DisableIndexNotDefinedException" value = "true" />
The value "true" indicates that no IndexNotDefinedException will be thrown, whereas, the value "false" means that the exception will be thrown.
  • Restart the NCache service for these changes to take effect.


Topic: Indexing

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Indexing

The purpose of using an index is to optimize speed and performance in finding relevant data for a search. For searching purposes, all searchable attributes should be indexed. Without an index, the search would scan every data, which would require considerable time and computing power. The additional computer storage required to store the index, as well as the considerable increase in the time required for an update to take place, are traded off for the time saved during information retrieval.
NCache internally use indexing in different modules to boost searching on cache performance and keeps track of it for different purposes.
Cache Searching Index
NCache provide Cache Searching Index in order to boost the execution of queries on cache. For searching purpose, all that is needed to be done is to just index all the searchable attributes. NCache will not search the non indexed attribute from the cache because it has to traverse through whole cache to find related data which will affect the cache performance.
Also indexes are defined against the actual data types of the cached items. Through indexing NCache knows what kind of data will be stored and it will store it in searchable way.
NCache provides two ways to define indexes.
  • Pre-Defined Index (Static Index)
  • Runtime Index (Dynamic Index)
1. Pre-Defined Index (Static Index)
To search custom class objects like Product in a cluster cache, these indexes need to be defined in advance. In this way, cache will save that type of data in the form where it can be easily fetched through queries. Indexes can be configured for public, private and protected primitive data members (including string).
These kind of indexes are defined before cache start. To define new indexes, the cache needs to be stopped first and restarted after modifications for deploying changes. On insertion of the indexed type of data in cache, NCache automatically detects its type and it can be used in searching queries afterwards.
2. Runtime Index (Dynamic Index)
If there are attributes in an application that are defined and used at runtime, then runtime indexing should be used. For example there may be some calculated values assigned to a product related to its sales. When any product is purchased by any customer, the sale details is saved in cache for generating daily report of sales trend through cached values later. This value is defined at runtime so it’s the runtime attribute of the product.
NCache will automatically create indexes for data that is added by the cache client. It means that indexes don’t need to be configured before using them for runtime attributes.
Runtime index can be further categorized into following types:
  • Tag Index
  • Named Tag Index
i. Tag Index
One or more identification marks can be associated with cache items. These identification marks are called tags. Through tags, the user can associate keywords(s) with cache items. Collection of cached items can be found and removed from the cache by specifying tags too. Tags are only allowed in string format. For every new tag, a new tag entry will be created in the tag index and all related cached items will be associated with that index.
ii. Named Tag Index
If there is a need to use high level of tagging where tags can have different data types or names and the requirement is to query data related to specific type of tag, then Named Tags should be used.
Named Tags" is the enhancement of "Tags". Named tags allows the user to store additional information (of any type) required to query the object stored as string. For example, "Highest-Sale-Time" named tag with value of time can be stored when any product sale is the highest in whole day. Named tags allow indexing the data according to required attributes at runtime. Later on, a query can be constructed using named tags to fetch the desired result set. . Multiple named tags can be associated with one cached item and vice versa.
When a data is added with a named tag that does not exist in cache, a new index is created for this new named tag. All the related data will be assigned to that index for searching. Unlike Tag, named tag index can be defined for all primitive types, string and date time. So there is more flexibility to add wide range of searchable data with different data types.
If there are multiple applications that are sharing the same cache and all of them are supposed to add named tags, then make sure that the same named tags have homogenous data types, e.g., if one client is adding named tag "ProductID" with String data type, then all other clients should add values of "ProductID" in String format not in Integer or other for the same cache.
Eviction Index
Eviction is a useful feature in NCache, where when cache is full it decides to evict its existing data so as to accommodate incoming data. In this scenario, eviction can smooth cache operations while keeping cache size limit by removing a configured percentage of data.
NCache provides different polices for eviction. These policies decide which data would be evicted when cache is full. NCache provides the following policies for eviction.
  • Priority Based Eviction
  • Least Recently Used (LRU)
  • Least Frequently Used (LFU)
In order to perform Eviction, NCache keeps the index of eviction for cache data for eviction.
For Priority Based Eviction, index is kept for priority from high to low and when cache is full, eviction thread selects keys from index with low priority and evicts them from cache.
For Least Recently Used (LRU), eviction index is kept for time of usage of keys and when cache is full, eviction thread selects keys from index which are least recently used and evicts them cache.
For Least Frequently Used (LFU), eviction index is kept for the number of usage of keys and when cache is full, eviction thread selects keys from index which are least frequently used and evicts them cache.
Expiration Index
Expiration is a property attached with each item which is being cached. This property is attached with each object so that each cache object can be evaluated upon its age, this age of object will decide upon its expiration time. When that expiration object invalidates, the associated item is removed from the cache.
NCache Keep DateTime Expiration index for cache keys in order to remove them efficiently on expiration.Expiration manager expired items after Clean Interval.
Clean interval is the periodic interval after which the expired items are removed from the cache. The clean interval for a cache can be changed in configuration settings.
After clean interval has elapsed, expiration manager get keys from index and expired items are removed from cache. After removing expired items from cache, expiration thread sleeps for “clean interval duration” specified in cache configuration.
NCache provides with two types of expirations
  • Absolute Expiration
  • Sliding Expiration
Indexing Object Attributes for Search
This feature is not available in NCache Express and Professional edition.
NCache requires all searchable attributes to be indexed. This is because, without indexing, NCache would have to traverse the entire cache in order to find items. This could be very costly operation with potential of slowing down the entire cache processes.
NCache provides its own indexing mechanism. The user can select objects in .NET assemblies that he/she wants to index. NCache uses .NET Reflection to extract data from the indexed attributes and builds its internal index. When data to be indexed is inserted in cache, NCache creates an index tree and adds those associated keys in them. These indexes than later on contain all the keys from cache associated to them. When cache is queried, NCache uses these indexes to quickly find the desired objects and returns all related keys or items.
Indexing Attributes of the Cached Item
NCache Manager provides a user friendly interface for defining indexes. The following example demonstrates procedure of defining indexes on attributes.
Suppose that cache contains Customer object where the definition of Customer is as below:
[Serializable]
public class Customer
{
public string CustomerID;
public string Country;
public Customer(string id, string country)
{
this.CustomerID = id;
this.Country = country;
}
}
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Runtime Data Sharing


Topic: Initialize Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Initialize Cache

After you have configured the cache, embed NCache API calls in your application to use it. The first thing you need to do is to initialize the cache. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
The code for initializing the cache is as follows:
// Initialize the cache.
Cache _cache = NCache.InitializeCache("myCache");
Initializing Cache in ASP.NET Applications
If you're developing ASP.NET application, the best place to put InitializeCache call is in your Application_Start() functions in Global.asax.cs file. Additionally, instead of hard-coding, we recommend keeping the cache-name in Web.Config and then accessing it from your code. This way, if you will be required to change your cache name at any stage, you won't have to recompile the code.
// Pick up the cache-name from Web.Config
public override void Init()
{
string cacheName = ConfigurationSettings.AppSettings["CacheName"];
Cache _cache = NCache.InitializeCache(cacheName);
}
And, in your Web.Config, you can specify cache name as follows:
<appSettings>
<add key = "CacheName" value = "myCache"/>
</appSettings>
See Also
Adding Items | Finding items | Removing Items | Dispose Cache | Start Cache | Stop Cache


Topic: Initialize Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Initialize Cache

After you have configured the cache, embed NCache API calls in your application to use it. The first thing you need to do is to initialize the cache. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Basic Initialize Method
This method is the simplest provided by NCache to Initialize a cache. It uses all properties specified in the client configuration file to Initialize.
Cache cache=null;
try
{
cache = NCache.InitializeCache("mycache");
}
catch (Exception ex)
{
//handle exception
// Possible Exceptions:
//1. No server available to process the request
//2. client.ncconf does not contain current cache information
}
Initializing Multiple Caches in a Single Application
For this exercise, both caches need to be configured previously and they must be in running state.
Cache cache1 = null;
Cache cache2 = null;
try
{
cache1 = NCache.InitializeCache("mycache");
cache2 = NCache.InitializeCache("myreplicatedcache");
}
catch (Exception ex)
{
//handle exception
}
Initializing InProc Cache
Initializing an in-proc cache is similar to initializing an OutProc cache except the fact that the InProc cache is not started.
Cache cache = null;
// Assumption: Cache ID has already been registered and running
try
{
cache = NCache.InitializeCache("myLocalCache");
}
catch (Exception exp)
{
//handle exception
}
Initializing Cache using CacheInitParams
InitParams allows editing values of the properties at initialization time. In this example, the values of RetryInterval and ConnectionRetries properties can be changed; for this application these values will be used instead of the ones specified in client configuration files.
Cache cache = null;
try
{
// Create new InitParam instance
CacheInitParams initParam = new CacheInitParams();
initParam.RetryInterval = 3;
initParam.ConnectionRetries = 2;
cache = NCache.InitializeCache("mycache", initParam);
}
catch (Exception exp)
{
// handle exception
}
Initializing Remote and Client Cache Simultaneously
In case client cache is configured using NCache manager basic public static Cache InitializeCache (string cacheId) call would initialize both remote cache and client cache.
If separate calls are made for both caches the local cache does not behave as a client cache instead it remains a separate local cache. In order to use an existing local cache as a client cache instead of making separate Initialization calls, we recommend that you use.
public static Cache InitializeCache(string remoteCacheId, string clientCacheId);
This API would return handler of the remote cache synchronizing all operations of the client cache.
Cache cache = null;
try
{
cache = NCache.InitializeCache("myRemoteCache", "myClientCache");
}
catch (Exception ex)
{
// handle exception
}
Similarly use following API to Initialize remote and client caches with CacheInitParams.
public static Cache InitializeCache(string remoteCacheId, CacheInitParams remoteInitParams, string clientCacheId, CacheInitParams clientInitParams);
See Also
Creating Caches | Add/Update Data to Cache | Fetch Data from Cache | Remove Data from Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache


Topic: Post Installation Client/Server Configuration for UNIX

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Post Installation Client/Server Configuration for UNIX

Configure Multiple Network Interface Cards
NCache Java Client, being a network intensive solution, has mainly two kinds of communication going on in a cache cluster:
  • Communication between different cache servers
  • Communication between cache client(s) and cache server(s)
For these communications, you need to configure Network Interface Cards, available on your cache server(s), to ensure optimal load sharing. If you have two NICs, NCache Java Client starts utilizing both of them, once “Dual NIC” interface is configured. Using Dual NICs means that you enhance the overall bandwidth throughput by distributing load on two NICs, thus immensely increasing performance. One NIC is dedicated for server-to-server communication inside the cache cluster and second NIC being reserved only for client-to-cache server communication. In this way, network load for cache communication is distributed on two NICs and resources will be utilized more efficiently.
If you have two NICs available on a cache server, it is highly recommended to use both NICs for Cache server-to-server and Cache slient-to-server communications.
You can specify which NICs to use for your server to server communications and client to server communication. For this purpose you have to make some modifications in the file: server.properties.
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
CacheServer.BindToClusterIP=20.200.20.202
CacheServer.BindToClientServerIP=20.200.20.202
BindtoClusterIP: You can inform NCache Java Client which interface to use for cluster-wide communication. In order to do so, provide the IP Address you want the cluster server to bind with.
BindtoClientServerIP: You can inform NCache Java Client which interface to use for client communication. In order to do so, please provide the IP Address you want the client's server to bind with.
Example
<cache id="MyCache" client-cache-id="" client-cache-syncmode="optimistic" default-readthru-provider="" default-writethru-provider="" load-balance="True">
<server name="20.200.20.59"/>
Please note that you must use the same IP address while creating your clustered cache to which you have bound your cache server. If you want to use a host-name at the time of defining your cache, then please make sure that the host-name resolves to the same IP address as the one you have bound it to.
  • Restart NCache service for these changes to take effect.
Client/Server TCP Port
By default, all clients communicate with NCache Java Client server on TCP port 9800. If this TCP Port is reserved for any of your other applications or you want to change it for some other reason, you can change it through the property file: server.properties .You will also have to modify the file: client.ncconf.
1. Modify Server Properties
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
CacheServer.Port=9800
Here you can specify a different client/server TCP port.
Please make sure that you specify the same port in all your cache servers.
  • Restart NCache Java Client service for these changes to take effect.
2. Modify client.ncconf for all clients (remote/local)
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
<configuration bind-ip="20.200.20.36">
< server port="9800" connection-retries="5" retry-interval="1" retry-connection-delays="0" client-request-timeout="90" connection-timeout="5" local-server-ip=""/>
</configuration>
Here you can specify a different TCP port.
Please make sure that all Port values in client.ncconf and server.properties are consistent.
  • Restart NCache Java Client service for these changes to take effect.
3. Change SNMP/JMX Counters Port
NCache Java Client uses SNMP and JMX servers to publish performance counters. If the default SNMP/JMX Counter Port is reserved for any of your other application, you are not able to view the counters due to IP conflict. To resolve the IP conflict, you will have to make some modifications in the file: server.properties.
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
JmxServer.Port=1617
JmxSnmp.Port=1618
Here you can specify different SNMP and JMX ports.
  • Restart NCache Java Client service for these changes to take effect.
4. Change the Cache Management Port
Cache Management Port port is used while performing management operations on caches. If the default Cache Management Port is reserved any of your other application or you want to change it for some other reason, you have to make some modifications in the file: server.properties
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/NCache_install_dir/config
  • Edit the following properties in the file:
CacheManagementServer.Port=8250
Here you can specify different SNMP and JMX ports.
  • Restart NCache Java Client service for these changes to take effect.
5. Change JDK/JRE Version
At the time of installation, NCache Java Client automatically picks the version information of JDK/JRE installed on your system. If at a later stage, you switch to a different version of JDK/JRE, you need to manually change Java path in the file env.properties in order to configure the JDK/JRE version. Please follow these steps:
  • In order to access server.properties, navigate to the config folder under NCache Java Client installation dir. Enter the following command:
[root@servername]# cd ~/opt/NCache/config
  • Open the file env.properties and provide Java path through the following property:
JAVA_HOME=/
  • After you have modified Java path, save/write and quit the service file from editor.
  • Restart NCache Java Client service for these changes to take effect.
See Also
What is NCache Java Client? | Getting Startedl | Installation Steps for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX


Topic: Installation Ended Prematurely

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Installation Ended Prematurely

With 64-bit NCache installation, you may get the following error at the end of the installation.
Error: "installation ended prematurely"
This usually happens when NCache service is not removed properly.
Workaround
To workaround this problem on Windows computer, please follow these steps.
  • Run the following command on VS.NET command prompt to uninstall the service.
/> InstallUtil /u "C:\ProgramFiles\NCache\bin\serviceAlachisoft.NCache.Service.exe"
  • If you don't have the service file in the NCache/bin/service folder then copy it from the other machine and paste it there and run the command. It should uninstall the NCache service.
  • Install NCache.
See Also
Removing NCache assemblies from GAC


Topic: NCache Installation Error 1606

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Installation Error 1606: Could not access network location

In some situations, you may unable to install NCache on Windows Vista with following error message.
Error: 'Error 1606. Could not access network location %SystemDrive%/inetpub/wwwroot/'
Workaround
In order to fix this, do the following:
  • Disable UAC in Windows Vista.
  • Find the following key: HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/InetStp/PathWWWRoot
  • Change the value of this registry key from '%SystemDrive%/inetpub/wwwroot' to 'C:\inetpub\wwwroot'. If your default website in IIS is stored at a different location, set the value of this registry key to that path.
  • Enable IIS 6.0 administration.
See Also
Installation Error 1721: A required progaram could not be run | Upgrading NCache | Installation rolls back on Windows Vista | NCache activation problem


Topic: Error 1721: A Required Program could not be Run

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Installation Error 1721: A Required Program could not be Run

On Windows Vista and Windows Server 2010, you may get the following error during install or uninstall process:
Error 1721: 'There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.'
This usually happens if UAC (User Account Control) is enabled on the target machine.
Workaround
To workaround this problem, please follow these steps:
  • Create a batch file containing the following command:
    msiexec /I "<NCache MSI path>"
  • Right click on the batch file and click Run as Administrator.
See Also
NCache Installation Error 1606 | Upgrading NCache | Installation Rolls Back on Windows Vista | NCache Activation Problem


Topic: Installation Roll Backs on Windows Vista

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Installation Roll Backs on Windows Vista

When you install NCache on Windows Vista, sometimes it rolls back towards the end without giving any error.
Workaround
To workaround this problem on a Windows Vista computer, please follow these steps.
  • Click Start, go to Settings, and then click Control Panel.
  • In control panel, click the Programs and then click the "Turn Windows features on or off"
  • In the windows features dialog, find Internet Information Services and expand the tree to Web Management Tools and click the node IIS 6 Management Compatibility to enable it.
  • Click OK and let Windows install the selected feature on your system.
  • Now you can install NCache.
See Also
Upgrading NCache | NCache Installation Error 1606 | Installation Error 1721: A required program could not be run | NCache activation problem


Topic: Network Install with PowerShell

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Network Install with PowerShell

NCache provides integration with Windows PowerShell so that you can easily automate NCache processes on your network. You can manage NCache remote installation/un-installation tasks on your network through a single computer using PowerShell scripts. NCache also allows you to automate the activation process on all your cache servers and cache clients by using NCache PowerShell scripts. There are few PowerShell scripts that comes with NCache installation and we'll be discussing those in this section.
In This Section
Configuring PowerShell Environment
Describes how to configure environment for PowerShell.
Remote Installation/Uninstallation
Describes how to install/uninstall NCache on remote machines.
Activate NCache
Describes how to Activate NCache license on remote machine.
Troubleshooting problems occurring in Scripts
Describes solutions to common problems when using PowerShell scripts.


Topic: Installation Steps for UNIX

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Installation Steps for UNIX

This section describes step-by-step instructions for installing NCache Java Client on UNIX.
Installation
In installation, you can make use of the .tar.gz file to install NCache Java Client on your UNIX machine. You can specify some customized parameters such as install directory, a user under which NCache Java Client service will run, network IP to be used by NCache Java Client etc. If you don’t customize any parameters, NCache Java Client is installed according to default values. It is installed in the /opt/ncache/ directory and NCache service runs under a default user called “NCache”.
In order to install NCache Java Client on your machine, you need to have “root” privileges.
In order to install NCache Java Client on you UNIX system, please follow these steps:
  • Please log in as root user.
  • In UNIX terminal, enter the following command in order to navigate to the directory where you have placed the .tar.gz file of NCache Java Client you downloaded from the Alachisoft website.
[root@servername]# cd [NCache_Java_Client_setup_path]
  • Uncompress the .tar.gz file through the following command:
[root@servername]# tar –zxvf NCache.Java.Client.tar.gz
  • Uncompress the .tar.gz file through the following command:
[root@servername]# tar –zxvf NCache.Java.Client.tar.gz
The extracted files can be found in the directory named ncache-enterprise-4.4-sp1-javaclient.
  • Navigate to the directory where .tar.gz has been extracted, through the following command:
[root@servername]# cd ncache-enterprise-4.4-sp1-javaclient
  • Now is the time to run installation. Use the following command (as root):
[root@servername]# ./install –f John –l Smith –e john@alachisoft.com -u Jenny –k EVAL-KEY –j JAVA_HOME_PATH –I 20.200.20.202
EVAL-KEY is emailed to you when you register at Alachisoft website. And, please specify JDK/JRE 1.6 or later.
NCache Java Client is now successfully installed on your UNIX machine!
After successful installation, you will get the following output message:
Starting NCache service
jvmargument: -Xmx816000m -Dcom.sun.management.jmxremote -Dcom.sun.management.jmx
remote.port=1501 -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.man agement.jmxremote.ssl=false -Xdebug -Xrunjdwp:server=y,transport=dt_socket,address=4000, suspend=n -Djava.library.path=/opt/NCache/lib/resources/sigar/ -server
CacheServer.BindToClientServerIP =20.200.20.202
CacheServer.BindToClusterIP=20.200.20.202
CacheManagementServer.Port=8250
CacheServer.Port=9800
Checking service status ...
NCache service started.
  • You can customize your installation through the following flags:
Flag |  | Purpose
-f | --firstname | First name of the user to which NCache Java Client is licensed.
-l | --lastname | Last name of the user to which NCache Java Client is licensed.
-e | --email | Email address of the user to which NCache Java Client is licensed.
-j | --javahome | It points to the directory where Java Runtime Environment (JRE) or Java Development Kit (JDK) is installed on your system. If no or invalid path is specified, it will search for the Java location itself. Recommended Java version is 1.6. It will first look for version 1.6; if it is not found, it will search for any greater version available.
-i | --ipaddress | IP address to be used by NCache Java Client, if no IP is specified it will use the first network interface card it finds.
-p | --installpath | Location where NCache Java Client will be installed, by default it will be installed on current location.
-k | --evalkey | You receive this via email from Alachisoft when you downloaded NCache Java Client. If not, then visit Alachisoft Download Center to register and obtain one. It is mandatory for you to specify this.
Verify NCache Java Client Installation
After installation you can verify NCache Java Client installation by any of the following ways:
  • In UNIX terminal, enter the following command:
[root@servername]# chkconfig
This command lists system services. If the NCache Java Client service NCached is also listed as follows you can be sure that NCache Java Client has been successfully installed.
NCached 0:off 1:off 2:on 3:on 4:on 5:on 6:off
OR
Set NCHOME to the location where you have installed NCache Java Client through the command:
[root@servername] export NCHOME=/opt/ncache
Then run the following commands:
[root@servername] cd /opt/ncache/bin
[root@servername] ./NCached status
If your installation was successful, you should be able to see the following output:
NCache Java Client Server Status: Running
CacheServer.BindToClientServerIP =20.200.20.202
CacheServer.BindToClusterIP=20.200.20.202
CacheManagementServer.Port=8250
CacheServer.Port=9800
  • Navigate to the config folder of NCache Java Client. The server.properties file is placed in this folder. server.properties file can be found in installation directory. This directory is the one you specified through the “-p” flag. In order to verify your connection, please look up for this file through the following command:
[root@servername]# cd ~/NCache_install_dir/ncache/config
After locating the file server.properties, open it in editor. In case of successful installation, you should be able to see your system IP used by property values as follows:
CacheServer.BindToClusterIP=20.200.20.202
CacheServer.BindToClientServerIP=20.200.20.202
What has been Installed?
NCache Java Client is installed in the directory you mentioned at the time of installation. In custom .tar.gz installation, this directory will either be the default directory that is /opt/ncache/, or it will be the directory you mentioned at the time of installation using –p parameter.
After installation, you will find the following files in this directory:
  • Configuration Files: The following configuration files are provided in order to configure and run NCache Java Client:
  1. config.ncconf
  2. client.ncconf
  • Libraries: Various .jar assembly files are provided for you to refer to when developing with NCache Java Client. These libraries are also used by NCache service.
  • Tools: The following NCache Java Client Tools are provided:
  • addclientnode
  • addnode
  • addtestdata
  • clearcache
  • verifylicense
  • removecache
  • createcache
  • createclientcache
  • dumpcache
  • getcachecount
  • ncached
  • listcaches
  • removeclientnode
  • removenode
  • startcache
  • stopcache
  • stresstesttool
  • removeclientcache
  • Documents: Help files and reference documents are provided for you to work with NCache Java Client.
  • Integrations: Some integrations (hibernate, hibernate 3.5) are provided along with the installation. These are used while integrating NCache as second level cache in many provider based frameworks.
  • Samples: NCache Java Client basic samples are provided on installation, they vary from basic API tests to samples for using integrations.
  • Logs: This folder will contains client and server related logs.
See Also
What is NCache Java Client? | Getting Startedl | Post Installation License Management for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX


Topic: Remote Installation/Uninstallation

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Remote Installation/Uninstallation

Installing NCache using PowerShell Script
NCache provides a PowerShell script called InstallNCache.ps1 for installing NCache on remote machines. Please refer to the Troubleshooting Install script section if you have any issue in executing this script.
You should find the InstallNCache.ps1 script at the NCache installation path in the integration folder
%INSTALLPATH%/NCache/Integration/PowerShell/InstallNCache.ps1
PS C:/Users> IntallNCache.ps1 /k key /file msi-file-name /file-path complete-file-path-of-msi [option[...]]
Argument | Description
/file file-name | Allows the user to specify the name of the setup file along with the file extension.
/file-path complete-file-path | Allows the user to specify the complete file-path/file-location of the setup file.
/k key | Allows the user to specify a valid license key.
Option | Description
/servers server-names | Allows the user to specify a comma separated list of Server Names or IP Addresses of machines where NCache is going to be installed.
/f first-name | Allows the user to specify first name.
/l last-name | Allows the user to specify last name.
/e edition | Allows the user to specify the NCache installation. Use "0" Cache Server installation, “2” is for Developer and “3” for Remote Client installation. Default is “0”.
/email email-address | Allows the user to specify the email address.
/company company-name | Allows the user to specify the company name.
/install-dir installation-path | Allows the user to specify the path where to install NCache. Default is "C:/Program Files/".
/set-per permissions | Allows the user to specify the permissions for quite mode. Default is "1".
/? | Displays command syntax and options for the utility.
Example of NCache Remote Installation:
In this example we will install NCache Cache Server on three computers (Test1, Test2, and Test3) using the PowerShell script InstallNCache.ps1. It is assumed that the NCache setup file “NCache.clr20.msi” is available on C Drive root and also that NCache is installed on the default path “C:/program files”.
PS C:/Program Files/ncache/integration/PowerShell> ./installNCache.ps1 /e 0 /k 7B1JYKITFRERLEIIE /file “NCache.clr20.msi” /file-path “C:/” /s Test1, Test2, Test3
This will install NCache Cache Server on all remote machines Test1, Test2 and Test3. Please replace the server “Test1, Test2, Test3” with your own server names. Upon successful installation you will see a message with “Return Value : 0”.
Uninstall NCache
NCache provides another PowerShell script called UninstallNCache.ps1 which helps to uninstall NCache from remote machine in silent mode. Please refer to the Troubleshooting Install script section if you have any issue in executing this script.
You should find the UninstallNCache .ps1 script at the NCache installation path in the integration folder
%INSTALLPATH%/NCache/Integration/PowerShell/ UninstallNCache .ps1
PS C:/Users>./UninstallNCache.ps1 ServerName1 ServerName2 ... n
Note: Server names must be separated with by BLANK Space. The names can be computer names or IP address of System.
Example of NCache Remote Un-Installation:
In this example we will uninstall NCache Cache Server from three computers (Test1, Test2, and Test3) using the PowerShell script UninstallNCache.ps1. It is assumed that that NCache is installed on the default path “C:/program files”
PS C:/Program Files/ncache/integration/PowerShell> ./UninstallNCache.ps1 Test1 Test2 Test3
This will uninstall NCache from all Cache servers Test1, Test2 and Test3. Please replace the server “Test1, Test2, Test3” with your own server names. Upon successful un-installation you should see a message with “Return Value : 0 ” Or 1614.
See Also


Topic: Installation

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Installation

1. NCache Manager for Visual Studio comes with Developer type installation of Enterprise edition of NCache Version 4.4 SP1 and onwards. The setup installer will automatically try to install the Visual Studio extension on all of the edition(s) installed of VS 2010, 2012 and 2013 on the system.
2. NCache Manager for Visual Studio can also be installed from Visual Studio’s Extension Manager/Extension Updater by searching for “NCache Manager for Visual Studio” in Online Gallery/Online section and downloading it.
3. NCache Manager for Visual Studio alternatively can be downloaded (.VSIX file) from the link https://visualstudiogallery.msdn.microsoft.com/46af433a-1e84-4085-ab39-50d0f6ba2817 and installed in any version/edition of Visual Studio of the user’s choice.
Note: NCache Manager for Visual Studio will only work with 2010, 2012 and 2013 versions of Visual Studio and its editions which support extensions.


Topic: Installation Guide

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Installation Guide

The Installation Guide provides you the most comprehensive information about installation, prerequisites and system configuration. It also provides a detailed, step-by-step guide about how to install NCache using command line installer and interactive window installer.
In This Section
Installation Guide for .NET
Describes comprehensive information about installation, prerequisites and system configuration for NCache installation for .NET.
NCache Java Client Installation Guide for UNIX
Explains the process of installation, licensing and uninstallation of NCache Java client for UNIX.


Topic: .NET Installation Guide

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

.NET Installation Guide

The Installation Guide provides you the most comprehensive information about installation, prerequisites and system configuration. It also provides a detailed, step-by-step guide about how to install NCache using command line installer and interactive window installer.
In This Section
Getting Started
Describes the pre-requisites for NCache installation.
Command Line Install
Describes how NCache provides a command line installation that can either run from a Command Prompt or add to a script files (.bat files).
Network Install with PowerShell
Describes how to manage NCache remote installation and un-installation tasks on your network through a single computer with the help PowerShell scripts.
Interactive Windows Installer
Describes, how to install NCache using interactive Windows Installer.
Evaluation Period Expiration & Extension
Describes the procedure for extending NCache evaluation period.
Activate NCache Purchased License
Describes how to activate NCache license.
Command Line Activation
Describes how NCache can be activated via command line.
Deactivate NCache Purchased License
Describes how to deactivate NCache License.


Topic: Installing NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Installing NCache

This section is intended as a quick reference for error codes, messages, and symptoms generated by NCache during installation, and provides a summary of the likely problem. Refer to the following section to find details about symptoms and workarounds.
In This Section
NCache Installation Error 1606: Could not Access Network Location
Helps to troubleshoot the problem of NCache installation on Windows Vista.
Installation Error 1721: A Required Program could not be Run
Provides help to troubleshoot the error 1721 occurred during install or uninstall process.
Upgrade NCache
Gives help on upgrading NCache without disturbing deployed environment.
Installation Roll Back Problem on Windows Vista
Gives work around for installation roll back problem on Windows Vista.
NCache Activation Problem
Explains why NActivate tool fails to launch and gives workaround.


Topic: Interactive Windows Installation

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Interactive Windows Installation

Another way by which you can install NCache is to double click on NCache.clr20.msi from the Windows Explorer. This launches the interactive Windows Installer. Below are the screen snapshots of the installation process.
  • After you click on NCache.clr20.msi, you will see the following as your first screen. Click Next.
  • The next screen asks you to accept the license agreement. By clicking I accept the terms in the License Agreement, you are making a legal commitment to abide by the Alachisoft Software License Agreement for NCache. You cannot proceed without accepting the license agreement.
  • The next screen is an important one. It asks you to choose the edition of NCache which you want to install. The basic rule of thumb is that except for your developer work stations where you have Visual Studio 2005, 2008 or 2010 installed, you should install NCache Enterprise everywhere else. Click Next.
  • Evaluation Information dialog appears which asks you for the installation key. This is the key which you have received from Alachisoft. If you do not have an Installation key, please click on Get Installation Key button which takes you to Alachisoft web site to register and obtain an Installation key.
Please note that even when you have purchased NCache and have a license key, you must provide the INSTALL KEY here (and not the purchased license key). You'll get an opportunity later to specify your purchased license key when you activate your licenses.
Below is the screen showing the page on Alachisoft website where you can register and obtain an Installation key. You have two options here. If you’re already registered, just enter your email address and an Installation key will be emailed to you. Otherwise, register by specifying information and an Installation key will be emailed to you.
  • In User Information dialog, you need to enter your name, company name, and email address. This information will be displayed as part of NCache to indicate your identity. Click Next.
  • By default, NCache is installed in "C:\program files\NCache" folder. However, if you want to change this location, you can specify a different one below. Click Next.
  • In the next dialog box, you can see all the components that will be installed automatically. You can unselect some of the components if you wish. But, it is strongly recommended that you keep everything as default. After selection, click Next.
  • You will then be prompted to start installation process by pressing the Install button.
  • Installation process will begin.
  • After everything is done, a final screen appears indicating a successful finish of NCache installation.
  • Click Finish to exit the installation setup.
See Also
Getting Started | Command Line Install | Network Install with PowerShell | Evaluation Period Expiration & Extension | Activate NCache Purchased License


Topic: Introduction to NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Introduction to NCache

NCache is a clustered caching solution that makes sharing and managing data in a cluster as simple as on a single server. It accomplishes this by coordinating updates to the data using cluster wide concurrency control and replicating and distributing data modifications across the cluster using the highest performing clustered protocol available. The primary purpose of NCache is to help improve performance of .NET applications that would otherwise make expensive trips to database systems, web services, mainframes, or other systems across the network.
In This Section
What's New in 4.4?
Updates you with new features in the latest version of NCache.
Dynamic Clustering
Gives an overview of dynamic clustering in NCache.
Caching Topologies
Gives an overview of various topologies.
Feature Highlight
Describes various features that NCache provides.
Support for .NET & ASP.NET Apps
Describes .NET and ASP.NET application support in NCache.
Support for Java & JSP Apps
Describes Java & JSP application support in NCache.
Copyright ©
Gives the copyright statement for NCache.


Topic: IP Binding

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

IP Binding

By using multiple network interface cards, the network load can be distributed and thus can increase bandwidth throughput. NCache being a network intensive solution, allows the use of dual NIC's and thus network load for cache communication will be distributed on two NICs which will enhance the overall performance.
NCache involves two kinds of network communication in a cache cluster.
  • Communication between cache server nodes (server-to-server communication).
  • Communication between cache client and cache server (client-to-server communication).
Different NIC cards can be configured for each type of network communication in NCache. One NIC will be dedicated for server-to-server communication inside the cache cluster and the second NIC will be reserved only for client-to-server communication. BindToClusterIP will be specified for cluster-wide(server-to-server) communication, and through BindToClientServerIP, NCache can be informed which interface to use for client communication with cache server.
In this way, network load for cache communication is distributed on two NICs and resources will be utilized more efficiently, thus increasing the overall performance.
NCache can detect all Network Interface Cards (NICs) on a server node and allows the user to choose any of them. Selected NIC will be used by NCache for cluster wide communication. If there are two NICs available on a cache server, then it is highly recommended to use both NICs for these NCache communications. NCache will start utilizing both Network Interface Cards (NICs) on cache servers, once dual NIC interface is configured. Using dual NICs will enhance the overall bandwidth throughput by distributing load on two NICs, thus increasing the performance immensely.
Dual NICs can be configured for NCache through NCManager. NCache service config file in installation directory can be manually updated for this purpose.
Command line tools provided by NCache communicate with NCache server on BindToClusterIP.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Portable Data Types (.NET & JAVA) | Graceful Node Down


Topic: Isolation Level

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Isolation Level

The client cache can either be inproc or outproc. Please see Isolation Levels to learn more about it.
These levels can be configured as follows:
Using NCache Manager
  • Click on the client cache under Client Cache tree view in Cache Explorer and go to the MAIN tab in the right pane.
  • In Main tab, a drop down list labeled as Isolation Level is available. The levels can be changed to either High (OutProc) or Low (InProc).
  • Right click on client cache name in Cache Explorer and select Apply Configuration option.
To change the isolation levels, the client cache must be disabled first.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Synchronization Mode | Client Cache Size | Creating Client Cache | Enable Client Cache


Topic: Isolation Levels

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Isolation Levels

If your application is running on a server node (the node that is participating in the cluster), you can access the cache either as InProc or OutProc. For InProc, cache lives inside your application process and performs all the clustering operations from there. For OutProc, you have to start the cache independently and then connect to it. Both access modes have their own pros and cons.
InProc mode in a replicated cache can give you really fast GET operations since you're accessing all the data from within your own memory space. However, since your application and the cache are sharing the same memory, you may face memory size limitation (in terms of how much you can cache).
Similarly, OutProc has benefit that multiple applications on the same machine can share a common cache. Additionally, since the cache lives in its own memory, you have more memory available to you. But, there is an overhead of transferring data between your application process and the NCache process.
OutProc requires that your .NET Assemblies (the ones that contain the objects you're going to add into NCache) are either registered in GAC or are located at $INSTALL/NCache/bin/service folder. Otherwise, NCache will not find your object definitions which it requires for .NET Serialization. And, this will result in NCache throwing an exception when you do Add, Insert, Get, or Remove operations.
If you're running NCache in a clustered configuration, you must ensure this on all machines in the cluster. By default, all caches are outproc but isolation level can be changed for caches of local topology. It can be done in the following way:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Main tab.
  • Change the Isolation Level to Low (InProc) or High (OutProc) as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through Config.ncconf
In Config.ncconf , you can specify the attribute value of inproc as true (for inproc) or false (for outproc).
<!-- myreplicatedcache will start in inproc mode -->
<cache-config name="myreplicatedcache" inproc="true" config-id="8" last-modified="7/31/2010 3:53:53 PM">
<!-- mypartitionedcache will start in outproc mode -->
<cache-config name="mypartitionedcache" inproc="false" config-id="1" last-modified="6/20/2010 3:50:34 PM">
InProc mode is only available for Replicated and Local cache.
See Also
Creating Caches | Configuring Cache Size | Configuring Expiration Clean Up Interval | Cache Management Operations | Monitoring Cache Operations


Topic: Item Level Data Event Notifications

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Item Level Data Event Notifications

Item Level Data Notifications
When the user wants to be notified only about a limited set of data rather than every operation performed on cache, Item Level Data Notifications can be used. Clients register callback for a specific key in cache using RegisterCacheNotification API and gets notifications when that key gets updated or removed from cache. These notifications are asynchronously sent to client so that there is no overhead on client activities.
Using Item Level Events
Item level events are published from cache when particular item is updated or removed from the cache. Item level events are not associated with general events anyways and must be registered against some specific key(s) and events are published only for those specific key(s).
  • Registering Event with a Particular Item
NCache provides a separate classification of event which can be registered with individual keys. To register update or remove event with a particular key(s) RegisterCacheNotification method should be used.
The key must exist in cache for event to be registered. Only update or removed event types can be registered in item level events.
In this example the cache will generate notification when the appropriate operation is performed on the key.
// Register target method
CacheDataNotificationCallback dataNotificationCallback = new CacheDataNotificationCallback( OnCacheDataModification);
try
{
// Register notification with appropriate event type on existing key
CacheEventDescriptor EventDescriptor = cache.RegisterCacheNotification(key,dataNotificationCallback,
EventType.ItemRemoved | EventType.ItemUpdated,
EventDataFilter.DataWithMetadata);
// Save the event descriptor for further usage
}
catch(Exception ex)
{
// handle exception
}
// Create a target method
static void OnCacheDataModification(string key, CacheEventArg args)
{
switch(args.EventType)
{
case EventType.ItemRemoved:
//perform appropirate operations
break;
case EventType.ItemUpdated:
//perform appropirate operations
break;
}
}
  • Registering Event with CacheItem
An event can also be registered with a particular key by registering as a property of CacheItem. The SetCacheDataNotification method in CacheItem can be used to provide all appropriate information for registering the notification.
// Register target method
CacheDataNotificationCallback dataNotificationCallback = new CacheDataNotificationCallback( OnCacheDataModification);
try
{
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.UnitsInStock = 15;
CacheItem cacheItem = new CacheItem(product);
// Registering event with cacheItem
cacheItem.SetCacheDataNotification(dataNotificationCallback,EventType.ItemRemoved | EventType.ItemUpdated,EventDataFilter.DataWithMetadata);
string key = "Product:" +product.ProductID ;
// Registering
cache.Insert(key, cacheItem);
}
catch(Exception ex)
{
// handle exception
}
// Create a target method
static void OnCacheDataModification(string key, CacheEventArg args)
{
switch(args.EventType)
{
case EventType.ItemRemoved:
//perform appropirate operations
break;
case EventType.ItemUpdated:
//perform appropirate operations
break;
}
  • Un-Registering Item Level Notification
You can also unregister a previously registered item level notification using the UnRegisterCacheNotification method. In this example, the appropriate key, callback as CacheDataNotificationCallback and EventDescriptor previously returned upon registering of event must be specified.
try
{
cache.UnRegisterCacheNotification(key, callback, EventDescriptor);
}
catch(Exception ex)
{ // handle exception
}
See Also
Event Notifications Overview | Cache Level Data Event Notifications | Custom Events Notifications | Configuring Cache Level Events | Configuring Email Notifications | Cache Dependencies | Server Side API Programming


Topic: Support for Java/J2EE & JSP Apps

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Support for Java/J2EE & JSP Apps

NCache provides 100% native Java API support for Java applications. You can use NCache from any Java applications including JSP Servlet, web services, Grid Computing applications, and any other server-type applications with high transactions.
NCache Java client uses the same proprietary socket-level protocol to talk to the cache server that the .NET client does. So, the performance and scalability from Java is the same as .NET.
NCache provides the following support for Java:
  • 100% Native Java API
  • JSP Servlet Session Storage
  • Windows & UNIX Support
  • Java SE and Java EE Support
  • Hibernate and Spring Support
See Also
Support for .NET & ASP.NET


Topic: Post Installation License Management for UNIX

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Post Installation License Management for UNIX

When you install NCache Java Client on your system, it is installed as an “Evaluation Copy” by default. You can use this evaluation copy for 60 days after which it expires and NCache Java Client stops working. You can either Activate NCache Java Client License (for a purchased copy) or Extend Evaluation Period (for a trial version).
If you are using a purchased copy of NCache Java Client, we recommend you to activate its license right after installation in order to avoid inconvenience.
Activate NCache Java Client License
After you have purchased NCache Java Client licenses and installed NCache Java Client, you can activate your copy of NCache Java Client. Activating NCache Java Client saves you from the trouble of NCache Java Client expiration and you can use it for as long as you want. If you have internet connection on your machine, follow the Online Activation process to activate your license, otherwise, follow the process Manual Activation.
If your computer has Internet access, we will suggest you to follow the simple and one-step Online Activation process .
Online Activation
Online activation is the fastest way to activate NCache Java Client but requires your machine to have Internet access. In order to activate your NCache Java Client copy through online activation, follow the steps given below:
  • In UNIX terminal of your server machine, go to the location where you have installed NCache Java Client.
  • Navigate to the bin\activation folder to access the activate-cmd tool:
[root@servername]# cd ~/NCache_install_dir/bin/activation
  • Run the activate-NCache Java Client-cmd tool as follows:
[root@servername]# ./activate-cmd -k key -f first-name -l last-name -e email [option[…]].
You get the following output on successful license activation:
Thank you for registering your copy of NCache Java Client.
  • You can customize the license activation process through the following properties:
Switch/Properties |  | Purpose
-k(Required) | --licensekey | Specifies the License key you received from Alachisoft
-f(Required) | --firstname | Specifies first name of the user
-l(Required) | --lastname | Specifies last name of the user
-e(Required) | --email | Specifies last name of the user
-m | --manual | Enables manual mode
-a | --authcode | Specifies the Activation Authorization Code that you received in an email or generated through the Alachisoft website.
-c | --company | Specifies user’s company name
-r | --address | Specifies address of the user
-t | --city | Specifies city name of the user
-s | -state | Specifies state of the user
-y | --country | Specifies country of the user
-z | --zip | Specifies postal/zip code of the user
-p | --phone | Specifies phone number of the user
-h | --help | Displays a detailed help screen
-G | --nologo | Suppresses displaying the logo banner
Manual Activation
Manual activation means you manually activate your copy of NCache Java Client through the following process:
  • In UNIX terminal of your server machine, go to the location where you have installed NCache Java Client.
  • Navigate to the bin\activation folder to access the activate-cmd tool:
[root@servername]# cd ~/NCache_install_dir/bin/activation
  • First generate an Activation Request Code through the command:
[root@servername]# ./activate-cmd -k key -f first-name -l last-name -e email -m
The output of this command is an encrypted text. This encrypted text is called Activation Request Code. You will use this code later to request an Activation Authorization Code which is required to activate NCache Java Client.
  • There are two ways to generate Activation Authorization Code.
  1. Send an Email to support@alachisoft.com to request an Activation Authorization Code. In your email, please copy the Activation Request Code you generated through the pervious step.
  2. Generate Activation authorization Code from Alachisoft website.
  • Once you have the Activation Authorization Code, run the following command:
[root@servername]# ./activate-cmd –a activation-authorization-code
  • Your copy of NCache Java Client is successfully activated. You will get the following output on successful activation:
Thank you for registering your copy of NCache Java Client.
  • You can customize the license activation process through the following properties:
Switch/Properties |  | Purpose
-a (required) | --authcode | Specifies the Activation Authorization Code that you received in an email or generated through the Alachisoft website.
-G | --nologo | Suppresses displaying the logo banner
-h | --help | Displays a detailed help screen
Generate Activation authorization Code from Alachisoft website.
An alternative to sending an email to receive the Activation Authorization Code is to directly generate an Activation Authorization Code from the Alachisoft website. This method is less time consuming than as it saves you from sending an email and waiting for a reply. Please follow these steps to get the Activation Authorization code:
  • Open Customer License Console .
  • Enter the License Key and click Find and then click the Activate NCache link. NCache Java Client Email Activation page is displayed.
  • On the Email Activation page, enter the Activation Requested Code you generated through the –m flag in activate-cmd tool.
  • Click Verify. The Activation Data Verification page appears.
  • Verify the information displayed on this page and click Activate! The next page that opens shows you the required Activation Authorization Key.
  • Once you have generated this key, please follow the steps described in Manual Activation to complete your registration process.
Extend Evaluation Period
When you install NCache Java Client on your system, it is installed as an “Evaluation Copy” by default. You can use this evaluation copy for 60 days after which it expires and NCache Java Client stops working. When NCache Java Client expires, it is time for you to either purchase NCache Java Client licenses or if you need an extension to your evaluation period, you can obtain an “Extension Key” from Alachisoft Sales. Please send an email to sales@alachisoft.com (or to your account manager if you’re in touch with him/her already) and ask for an extension key. You are provided with a 30-day extension key.
You can extend your trial version only 4 times; after that you will have to purchace NCache Java Client licenses in order to use NCache Java Client.
Once you have obtained the extension key, please follow the following steps to extend your evaluation period:
  • In the UNIX terminal of your server machine, go to the location where you have installed NCache Java Client.
  • Navigate to the bin\activation folder to access the activate-cmd tool:
[root@servername]# cd ~/NCache_install_dir/bin/activation
  • Run the extend-evaluation-cmd tool through the following command:
[root@servername]# ./extend-evaluation-cmd –e evaluation-key
You will see the following output message on successful extension of your evaluation period:
NCache Java Client Evaluation period has been extended.
  • You can customize the license activation process through the following properties:
Switch/Properties |  | Purpose
-e(required) | --extensionkey | Specifies the evaluation extension key you received from Alachisoft
-h | --help | Displays a detailed help screen
-G | --nologo | Suppresses displaying the logo banner.
See Also
What is NCache Java Client? | Getting Startedl | Installation Steps for UNIX | Post Installation License Management for UNIX | Uninstall NCache Java Client from UNIX


Topic: Local Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Local Cache

NCache supports a standalone, non-clustered cache which resides on a single node. Local cache is similar in features with other clustered caches, i.e., it has all the caching features provided in any other caching topology, but it is not scalable or fault tolerant like clustered caches. As it is a single server cache, so its transactional capacity can’t be increased by adding multiple servers. Also, it creates a single cache instance (no backup or replica) thus if it goes down, all cached data is lost. Local cache is suitable for applications having a small number of clients with low activity or where applications don't need to cache large amount of data.
Isolation Levels
A local cache has the following two isolation levels.
  • InProc
This isolation level means that cache resides inside the memory space of client application. As this type of cache exists inside the application process, so the response time is faster. In InProc, NCache keeps cached data as live objects (not in serialized form) which reduces the serialization/de-serialization cost. However, memory limitations can be faced since application and cache share the same memory. Also cached data in this case can’t be shared with applications running outside this process.
  • OutProc
This isolation level means that cache resides in a separate process (NCache service process) than client application. Multiple clients (local and remote) can connect to the same cache to share data. Latency in this case is more than InProc cache because of communication cost outside the process.
OutProc local cache is suitable for situations when multiple clients application needs to access the same cached data. For example, in a web garden where each ASP.NET application runs in a separate worker process, OutProc cache should be used. Also in ASP.NET applications, using an InProc cache instance is not considered as the best option due process memory limitation. However, note that there will be an overhead of transferring data between application process and the cache itself.
Local Cache is the only cache available in developer edition of NCache, but remote clients for local cache are not supported in this edition.
See Also
Creating Local Cache | Configuring Basic Cache Settings | Cache Topologies | Cache Cluster | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Eviction | Indexing


Topic: Locking

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Locking

Locking prevents multiple clients from updating the same data simultaneously and also ensures data consistency. A proper locking mechanism is necessary to ensure data consistency when there is a possibility of multiple clients accessing and possibly modifying the same data at the same time. This section the locking feature provided by NCache.
In This Section
Overview
Explains the basic concept of locking and types of locking in NCache
Locking Items in Cache
Explains how to lock an item in cache using NCache API.
Using Cache Item Versioning
Explains how to use Cache Item Versioning feature of NCache.


Topic: Locking Items in Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Locking Items in Cache

A lockHandle is associated with item to be locked. This ensures that the particular item remains inaccessible throughout the cache. Two primary properties lockId and lockdate are used for locking while performing various cache operations.
NCache provides method calls exclusively for locking as well as numerous overloads that manipulate the locking mechanism.
Locking an Item Explicitly
Lock on an item can be acquired explicitly before performing any operation. Lock method requires a TimeSpan to lock an item for a specified time. However, if you do not want the acquired lock to expire simply specify a new TimeSpan(). The lock method used in this example associates a lockHandle. Kindly ensure that the single LockHandle is associated with a single key. Release the lock before re-using the handle; otherwise it might lead to inconsistency of behavior.
//create a new lock Handle
LockHandle lockHandle = new LockHandle();
string key="Product:1001";
try
{
// Specifiying the time span of 10 sec for which the item remains locked
bool locked = cache.Lock(key, new TimeSpan(0, 0, 10), out lockHandle);
}
catch (OperationFailedException ex)
{
// handle exception
}
Locking an Item During Fetch Operation
An item while being retrieved. The item will be inaccessible for others unless it is released. In case of a mismatch of key, null is returned.
In this example, a key and a lockHandle for the key should be provided to fetch the cached object and lock it. “True” should be given if the user wants to acquire lock.
LockHandle lockHandle = new LockHandle();
//Specify time span of 10 sec for which the item remains locked
TimeSpan lockSpan = new TimeSpan(0,0,10);
string key="Product:1001";
try
{
object result = cache.Get(key, lockSpan , ref lockHandle,true);
if (result != null)
{
if (result is Product)
{
Product product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Locking with Expiration
If time is specified as a value of TimeSpan(), NCache would lock the item for that specified duration.
LockHandle lockHandle = new LockHandle();
//Specify time span of 10 sec for which the item remains locked
TimeSpan lockSpan = new TimeSpan(0,0,10);
string key="Product:1001";
try
{
bool lockAcquired = cache.Lock(key, lockSpan, out lockHandle);
//Verify that the lock is released automatically after this time period.
}
catch (OperationFailedException ex)
{
// handle exception
}
Releasing Lock with Update Operation
While updating an item, the lock can be released allowing other cache clients to use the cached data. In order to successfully release the locked item, you will lockHandle that was initially used to lock the item must be specified. In case of an invalid or different handle, NCache would throw an OperationFailedException.
Product updatedProduct = new Product();
updatedProduct.ProductID = 1001;
updatedProduct.ProductName = "Chai";
updatedProduct.Category = 4;
string key = "Product"+ updatedProduct.ProductID;
LockHandle lockHandle = new LockHandle();
try
{
// lock exisiting item for the time span of 30 seconds
bool locked = cache.Lock(key, TimeSpan.FromSeconds(30), out lockHandle);
if (locked)
{
cache.Insert(key, new CacheItem(updatedProduct), lockHandle, true);
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Releasing Lock Explicitly
In order to release lock forcefully on a previously locked cached item, lockHandle that was used to lock the key should be specified.
LockHandle lockHandle = new LockHandle();
string key = "Product:1001";
try
{
// lock an existing item and save the lockHandle for 10 seconds
bool locked = cache.Lock(key, new TimeSpan(0, 0, 10), out lockHandle);
if (locked)
{
// unlock locked item using saved LockHandle
cache.Unlock(key, lockHandle);
}
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Locking Overview | Using Cache Item Versioning | Data Invalidation Strategies | Cache Dependencies | Server Side API Programming


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

NCache provides a variety of ways to manipulate the cache data suitable for different use cases in different environments. NCache provides a clustered environment where multiple clients can access cache data. In such situation, parallel requests may occur for same data changes e.g. multiple parallel threads from within multiple applications can issue an update call against the same data. Internally, NCache allows every request to execute as much in parallel as possible to get the best performance without sacrificing data integrity. Every update in the cache store is treated as atomic and even replication between active and mirror nodes follow the same strategy to guarantee data consistency across the entire cache cluster. Beside this, NCache provides with an API to lock specific cache data, so that only a single thread can update or read it.
There are two types of locking available with NCache:
  • Optimistic Locking (Cache Item Versioning)
  • Pessimistic Locking (Exclusive Locking)
Optimistic Locking (Cache Item Versioning)
In optimistic locking, NCache uses cache item versioning. Cache Item Version is a property associated with every cache item. It is basically a numeric value that is used to represent the version of cached item which changes with every update to an item. This property allows tracking whether any change occurred in item or not. When an item is fetched from cache, its current version is also fetched at the same time.
Cache item version can be specified in data update call. This update call succeeds only if the current version of the cache item is the same as passed by the client otherwise, it fails. This is used when a user wants to update a cache item which he/she has previously read from cache. If someone else has updated the cache item, update should fail. In this way each client will update only the latest copy of the data and hence maintain data integrity throughout the cache.
The latest version of item can be retrieved from cache through GetIfNewer API. Through this method, the user provides the existing version and asks the for more latest version if any. In this way, it can be track that whether an item is updated in cache or not.
Pessimistic Locking (Exclusive Locking)
NCache provides a locking mechanism, that exclusively locks the cached data. In this mechanism APIs with lock handle should be used. A lock handle is a handle associated with every locked item in the cache, which is returned by locking API. A locked item can be fetched/updated or unlocked only when its lock handle is provided at API level. However, it should be done with care to avoid data integrity issues. This locking mechanism is useful in situation when the user wants to exclusively lock his/herr cache data to prevent multiple clients to update it simultaneously.
Lock Expiration: Lock timeout can also be specified while locking a cached item. The lock timeout is the time interval after which lock will be automatically released if no explicit call is made for releasing the lock during time out interval. This will prevent data from being locked for infinite time.
Forceful Release of Locks: Situation can arise in distributed environments when an application which had acquired the lock on a cache item terminates abruptly. In such a situation, all the locks acquired by such an application should be released. NCache provides unlock API, which releases the cache item lock forcefully.
Special Consideration while using Locking API
NCache provides set of APIs with and without lock handle to fetch/update the cache item. APIs without lock handle ignores item locking. So you should use all locking APIs for data manipulation. For example, if an item is locked and an update API call is made which does not take lock handle as input parameter, then item will be updated in the cache irrespective of its locking state. Therefore, when using locking feature , only those API calls should be used which take lock handle as parameters. APIs which do not take lock handle can be used but with a lot of care so that it does not affect data integrity.
In case of eviction/expiration, NCache ignores locks which mean that a locked item can be removed as a result of expiration or eviction.
See Also
Locking Items in Cache | Using Cache Item Versioning | Data Invalidation Strategies | Cache Dependencies | Server Side API Programming


Topic: Logging

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Logging

NCache provides a rich set of modules for logging run-time statistics of different components available in NCache. And, also provides different level of logging that includes log-files, report views, statistics and events. NCache presents the
following mechanisms to logging from different perspective to analysis NCache independently.
  • NCache Monitor Logging
  • Support for PerfMon Logging
  • Support Windows Event Logging
  • File based Logging (log-files)
  • Client API Logging
  • Details Logging (client app/webs or socket server)
  • Email Notifications on NCache Events
In This Section
NCache Monitor Logging
Explains the logging facilty provided by NCache Monitor.
Performance Counters Logging
Explains how to view performance counters using Report View in NCache Monitor.
Windows Event Logging
Explains the Windows events logging provided by NCache.


Topic: NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
Next page >
Welcome to NCache version 4.4. NCache is a caching solution that provides high performance and scalability. NCache provides a set of services and API's that incorporates various user needs of caching.
NCache package contains samples, tutorials, and tools designed to help you incorporate NCache in your applications. Package also provides a documentation that includes an extensive class library reference, conceptual overviews and step-by-step illustrations to assist you in understanding NCache more effectively.
In NCache Documentation
Introduction to NCache
Presents a brief introduction to NCache, with an emphasis on new and old features, editions and requirements of NCache.
Caching Concepts
Discusses important caching concepts to enable you to understand the later sections in a better way.
Installation Guide
Discusses step by step details for installation and activation of NCache using interactive Windows installer and command line installer. It also explains NCache network install with Powershel and NCache Java client installation for UNIX.
Getting Started
Familiarizes you with the fundamentals of NCache and offers help to use NCache quickly and efficiently.
Administrator's Guide
Provides a guide to perform administrative tasks and configuring settings of caches and bridges using NCache Manager, command line tools and configuration files.
Programmer's Guide
Focuses on what is essential to become skilled at developing with NCache. It includes programmer's guide, sample applications, hands on tutorials and extensive help on API reference.
Troubleshooting
Helps in troubleshooting different problems that may arise while using NCache.
How to's
Provides the answers to some of the most commonly asked questions regarding NCache.


Topic: Manage Cache Service on a Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Manage Cache Service on a Server Node

NCache service can be started, stopped or restarted on a paticular server node added in the clustered cache using the NCache manager.
In This Section
Start Cache Service on a Server Node
This section explains how to start cache service on a server node of a clustered cache.
Stop Cache Service on a Particular Server Node
This section explains how to stop cache service on a specific server node.
Restart Cache Service on a Particular Server Node
This section explains how to restart cache service on a particular server node.


Topic: Data Load Balancing

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Data Load Balancing

You can request to balance a node in a partitioned cluster without waiting for the automatic load balancing task to trigger it. This brings data load on the node near to average data per node while rest of the data is distributed across other nodes in the cluster. Candidate nodes for accepting the load are selected on the bases of the amount of data currently present on them. A node having less data gets a larger share from the load. This can be done as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the server node of a cache cluster.
  • Click on the Balance Data Load option in the right click context menu.
Data will be evenly distributed across the nodes of the cluster.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing


Topic: Management Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Management Operations

This section describes that how you can manage caches and their related configuration.


Topic: Management Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Management Operations

This section of the documentation discusses different cache management operations in NCache and explains how these operations can be performed in NCache.
In This Section
Start Cache
Explains how to start a cache in NCache.
Stop Cache
Explains how to start a cache in NCache.
Manage Cache Service on a Server Node
Explains how to start, stop and reset a cache service on a server node in NCache.
Apply Configuration
This section discusses how to successfully configure settings of caches in NCache using Apply Configuration.
Hot Apply Configuration
This section discusses how to successfully configure settings of caches in NCache using Hot Apply Configuration.
Reset Configuration
This section discusses how to reset configuration settings of caches in NCache.
Data Load Balancing
This section describes how to balance data load among different nodes in partitioned clusters.


Topic: Maximum Size

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Maximum Size

Through this configuration option, you can specify an upper limit on size of the cache in MB. The number of items in cache are limited by maximum size of the cache and amount of free system memory (virtual or physical). If some eviction policy is specified, whenever total data size in cache reaches maximum size or when lesser than 10% of memory is left in the system, items are removed from the cache as per eviction policy. Maximum size of a cache can be specified by one of following two ways.
NCache Manager:
You can specify cache max size for a Cache on Main Tab of its view window.
Config.ncconf:
You can specify the cache max size through Config.ncconf as follows.
<cache-config name="mypartitionedcache" inproc="False" config-id="1" last-modified="6/20/2010 3:50:34 PM">
<storage type="heap" cache-size="250mb"/>
</cache-config>
See Also
Configure Local Cache | Configure Cluster


Topic: Memcached

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Memcached

Memcached is a simple in-memory key-value store providing basic features for caching. Memcached server communicates with memcached clients using defined text or binary protocol. Memcache servers are stand-alone servers with no clustering or distributed caching features to provide scalability.
NCache has implemented Memcached integration and the users can plug-in NCache to their existing or new Memcached applications without any code changes. The users only need to change their application config files to take advantage of NCache distributed caching system.
NCache provides support for Memcached in two different ways.
  • Memcached Gateway Approach
  • Memcached Client Plug-In for .NET
In This Section
NCache Memcached Gateway Approach
Explains how to use NCache provided Memcached gateway server to use NCache without nay code change.
Memcached Client Plug-In for .NET
Explains how to use Memcached Client Plug-In for .NET provided by NCache.


Topic: Memcached Client Plug-in for .NET

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Memcached Client Plug-in for .NET

NCache provides its Memcached Client Plug-in for popular .NET Memcached clients Eniym, BeIT Memcached and .NET memcached client library so that NCache can be directly used for Memcached applications using these clients. NCache API calls equivalent to Memcached calls are internally implemented in these plug-ins and there is no code change or recompilation required on application side. These modified Memcached client libraries are provided along with their source code in NCache installation.
It is generally recommended to use plug-In approach instead of gateway because gateway induces an extra network/process hop whereas this Plug-In becomes part of the client application process and directly talks to the NCache cluster using NCache API so it should result in a better performance.
This diagram illustrates the NCache deployment with plug-in approach.
See Also
NCache Memcached Gateway Approach | NHibernate | Entity Framework Caching Integration | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features


Topic: Out of Memory Problem

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Out of Memory Problem

Sometimes your system throws out of memory exception while using NCache. This usually happens when Maximum Size for the cache is not specified correctly. Often, processing overhead is not kept into consideration while specifying the Maximum Size.
Workaround
In order to resolve out of memory issue, NCache has provided a memory based cache, where you can specify an upper limit on the size of the cache in MB. Please specify correct Maximum Size for your cache.
You should specify a Maximum Size which, if completely consumed, still leaves enough space in the system so that it never goes under low resources. While specifying the cache size, consider the following factors:
  • Average size of Sessions or Objects.
  • Number of expected Sessions or Objects.
  • Available memory for the NCache process.
Then you can calculate the required memory by keeping the following in mind.
  • 15% Overhead per session.
  • 15-20% overhead for processing. If object size is greater than 80KB, this ratio may be little bit high.
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Unable to apply configurations or start cache due to disabled network card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other
Send comments on this topic .


Topic: Mirror Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Mirror Cache

Mirror cache consists of two server active/passive nodes. One server node is active node which is basically the coordinator node . The coordinator node is the oldest server node in any cache cluster having membership management
authorities. The other node is passive/mirror node.
Clients Connection: All cache client can only connect with the active node. Passive node is added for creating the exact backup of active node.
Backup Support: Mirror cache provides data reliability by creating a backup through asynchronous replication of all updates on mirror/passive node. Due to asynchronous replication between active and passive node, cache clients get
better performance. Active and passive servers can be interchanged at any time.
Failure Recovery: If active node goes down due to any reason, then passive node automatically becomes active without any intervention. All the cache clients connect to the new active node and can perform operations without any
performance degradation and downtime.
Runtime Scalability: As there is a single active node in this topology, its scalability is the same as that of a local
cache. But due to mirroring of data, it also provides fault tolerance which lacks in local cache.
State Transfer: Mirror node always replicates the state from active node when it joins the cache cluster.
See Also
Replicated Cache | Partitioned Cache | Partitioned-Replica Cache


Topic: Monitoring Bridge Counters Using Perfmon Tool

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Bridge Counters Using Perfmon Tool

NCache publishes bridge counters in perfmon under category NCacheBridge. This category has all the counters related to the bridge. Follow these steps to monitor the NCache bridge counters through perfmon tool:
  • Press WINDOWS + R keys on your keyboard OR click on the windows start menu and then type perfmon and press ENTER key.
  • Perfmon tool opens up. Click on the Performance Monitor under Monitoring Tools.
  • Click on the cross (X) button to remove the default counter which is already added in it. Then click on the plus (+) button to open the Add Counters dialog box.
  • Using the vertical slider of available counters list box, scroll upward to find NCache Bridge category.
  • Click on the down arrow head (icon) to expand the NCache Bridge category. All of its counters are listed under it.
  • All of the current running instances of bridge appear inside of Instances of selected objects list box. Select the required instance or simply click on the <All instances>, and click on the Add >> button. All of the counters that were selected in step 5 for all the selected instance of caches appear in Added counters list box on the right side.
  • Click OK. All of the selected counters will appear in perfmon tool like this:
See Also
Monitoring Cache Server Counters Using Perfmon Tool | Monitoring Cache Client Counters Using Perfmon Tool | Browse Bridge Statistics | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Cache Counters | Logging


Topic: Monitoring Bridge Using NCache Manager

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Bridge Using NCache Manager

Bridge is used to synchronize caches across the WAN. Bridge can be monitored using NCache Manager and NCache Monitor.
In This Section
Configuring Bridge Counters to Display
Explains how to configure cluster counters connected to Bridge.
Browse Bridge Statistics
Explains how to view and monitor statistics of a Bridge.


Topic: Monitoring Caches using NCache Manager

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Caches using NCache Manager

NCache Manager is a tool to manage the caches and bridge, but it also provides the basic monitoring for the caches. In this way, you are able to manage and monitor your caches at a single place. Using NCache Manager, you can also configure the different monitoring settings. The sub sections provide an overview of how to configure these settings.
In This Section
Changing Management Port of a Cache Node
Explains how to change the default management port of a cache node.
Configuring Counters to Display
Explains how to select the counters to be displayed.
Fetching the Statistics using Server IP or Server Name
Gives user the option to fetch statistics using either server IP or server name.
Cluster Health
Explains how to view a cache cluster's health.
Monitoring Cache Clusters using NCache Email Alerts
Explains how to monitor the cache clusters using NCache Email Alerts.


Topic: Monitoring Caches using NCache Monitor

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Caches using NCache Monitor

Clustered caches can be monitored to view performance counters in live visual graphs using NCache Monitor shipped with NCache Enterprise edition. In NCache Monitor, we have two types of dash boards; Graphical and Report View.
  • Graphical View
In graphical dashboards, counters are shown in the form of graphs with respect to time. Counter value will be plotted along y-axis and time on x-axis. Graphical dashboards are helpful in the scenarios where you want to monitor cache for some specific time.
  • Report View
In report view dashboards, counter are shown in the form of numeric values. Report view dashboards are helpful in the scenarios when you want to monitor instantaneous performance of NCache.
In This Section
Monitoring Cache Server Counters Using Built-In Dashboard
Explains how to use NCache monitor's built-in dashboard to monitor cache server counters.
Monitoring Cache Client Counters Using Built-In Client Dashboard
Explains how to use built-in client dashboard in NCache monitor to monitor cache client counters.
Monitoring Cache Cluster Counters Using Custom Dashboard
Describes how to use custom dashboard NCache monitor to monitor cache cluster counters.
Monitoring Perfmon Counters Using Custom Dashboard
Explains how to monitor perfmon counters through custom dashboard in NCache monitor.
Monitoring Cache Event Logs Using Custom Dashboard
Explains how to observe and monitor cache event logs using custom dashboard.
Monitoring Client Process of a Clustered Cache Using Custom Dashboard
Explains how to observe and monitor client process of a cache cluster using custom dashboard.
ASP.NET Session Monitoring Using Custom Dashboard
Explains how to monitor ASP.NET sessions through custom dashboard.


Topic: Monitoring Cache Client Counters Using Built-In Client Dashboard

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Cache Client Counters Using Built-In Client Dashboard

NCache Monitor also provides built-in dashboard named as Client Dashboard. This dashboard has all required
counters/graph in it for the clients’ performance monitoring. It can be viewed for monitoring as follows:
  • Click on the View menu of the NCache Monitor and click on the Client Dashboard menu option.
  • Client Dashboard appears and it consist of different client side graphs.
This built-in dashboard displays different client side counters. Few of the counters display the NCache client system resource usage info like NCache Client CPU, NCache Client Memory, NCache Client Network. This dashboard also shows the NCache client specific information like NCache Client Request Queue, NCache Client Read Operations/sec, NCache Client Write Operations. It also shows the ASP.NET session counters like ASP.NET Requests/sec, ASP.NET Pending Queue/sec, ASP.NET Total Sessions.
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters


Topic: Monitoring Cache Client Counters Using Perfmon Tool

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Cache Client Counters Using Perfmon Tool

NCache publishes cache client counters in perfmon under the category NCache Client. This category has all the counters
related to the cache client. Follow these steps to monitor the NCache client side counters through perfmon tool:
  • Press WINDOWS + R keys on your keyboard OR click on the windows start menu and then type perfmon and press ENTER key.
  • Perfmon tool opens up. Click on the Performance Monitor under Monitoring Tools.
  • Click on the cross (X) button to remove the default counter which is already added in it. Then click on the plus (+) button to open the Add Counters dialog box.
  • Using the vertical slider of available counters list box, scroll upward to find NCache client category.
  • Click on the down arrow head icon to expand the NCache Client category. All of its counters are listed under it. Select the required counters from this list like this:
  • All of the current running caches for which clients are running appear inside of Instances of selected objects list box. Select the required instance or simply click on the <All instances>, and click on the Add >> button. All of the selected counters for all the selected instances of caches appear in Added counters list box (exist on the right side).
  • Click OK. All of the selected counters will appear in perfmon tool like this:
See Also
Monitoring Cache Server Counters Using Perfmon Tool | Monitoring Bridge Counters Using Perfmon Tool | Browse Bridge Statistics | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring Caches | Cache Counters | Logging


Topic: Monitoring Cache Cluster Counters Using Custom Dashboard

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Cache Cluster Counters Using Custom Dashboard

You can also add a custom dashboard to place the required counters on it for the monitoring using NCache Monitor.
  • Click on the File menu of the NCache Monitor.
  • Create Dashboard Wizard appears. Provide Dashboard Name and select the Dashboard Layout (Graphical or Report View). Click Next.
  • Select number of rows and column for this dashboard and click on the Finish button.
  • New dashboard Dashboard1 is created with specified number of rows and columns.
  • Now drag and drop the required counters from Cache Server category or from Cache Client category that exists in the Toolbox available on the left side of NCache Monitor.
The custom dashboard after placing different server and client counters on it will look similar to this:
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters


Topic: Monitoring Cache Clusters using NCache Email Alerts

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Cache Clusters using NCache Email Alerts

NCache also provides the Email Alerts (notifications) for different cache activities. You can choose the required (few or all) events for which you want to receive the email alerts from NCache, so that you remain fully aware what is going on. And in case of any serious issue, you can manage the cache accordingly.
  • Configure the Email Alerts for a cache using NCache Manager. Follow the steps in Configuring Email Notifications section to configure the NCache Email Alerts.
  • Stop the cache for which you have configured email alerts.
  • Now check your email which you have provided for receiving email from NCache. You will see the an email from NCache with contents like this:
See Also
Changing Management Port of a Cache Node | Configuring Counters to Display | Fetching the Statistics using Server IP or Server Name | Cluster Health | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches


Topic: Debugging Counters

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Debugging Counters

Debugging counters are installed for debugging purposes. These counters include:
  • Socket send time (sec): Time in milli seconds taken to send a request.
  • Socket send size (bytes): Bytes sent per second.
  • Socket recv time (sec): Time in milli seconds taken to receive a request.
  • Socket recv size (bytes): Bytes received per second.
  • Naggling msg count: How many messages were sent together in socket.send.
  • TcpUpQueueCount: Number of items in TCP up queue.
  • TcpDownQueueCount: Number of items in TCP down queue.
  • TcpdownEnter/sec:.
  • BCastQueueCount: Number of items in BCast Queue.
  • MCastQueueCount: Number of items in MCast Queue.
Debugging counters are disabled by default and can be enabled by adding following key-value pair in ' alachisoft.ncache.service.exe.config ' file.
<key="EnableDebuggingCounters" value="true"/>
See Also
Performance Counters | Monitoring Caches using NCache Manager | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches


Topic: Monitoring Cache Event Logs Using Custom Dashboard

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Cache Event Logs Using Custom Dashboard

Event Logs control displays log entries specific to cache. NCache logs multiple events’ information (Node left, Node Joins, Cache Started, Cache Stopped etc) in windows event logs. Using this control, you can monitor all of the cache events in a single place. Details of these events along with date time can be monitored using Event Logs control.
Double click on any log entry to open it with full details in new window, like this:
You can also add any other event source which publishes events in windows event logs using the NCache Monitor ‘Event logs’ control. Please follow the steps given below to add any other event source for monitoring in NCache Monitor Event Log control:
  • Click on the Tools ->Options in NCache Monitor.
  • A dialog box will open up. Click on the Event Log option in the left side menu.
  • Specify the name of the Event source (any application or service that publishes events logs). Click Add.
  • Click OK to save the changes. Now NCache Monitor starts event log monitoring for this newly added event source too (along with all of the previously added event sources).
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Configuring NCache


Topic: Monitoring NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring NCache

NCache publishes different performance counters, provides logging for caches, cache clients, and email notifications for clustered caches. Using these options, you can monitor the caches.
In This Section
Cache Counters
Describes different counters published by NCache.
Monitoring Caches using NCache Manager
Describes how to monitor caches and clustered caches NCache manager.
Monitoring Caches using NCache Monitor
Describes how to monitor the performance, health and activity of cache servers and clients through NCache monitor.
Monitoring Bridge using NCache Manager
Describes how to monitor bridges through NCache manager.
Monitoring NCache using Windows Perfmon Tool
Explains how to monitor cache servers, clients and bridges using Windows Perfmon tool.
Logging
Explains different types of logging facilities provided by NCache.


Topic: Monitoring NCache Using Windows Perfmon Tool

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring NCache Using Windows Perfmon Tool

NCache publishes its performance counters through perfmon. You can monitor NCache counters for a specific cache on any windows machine using windows perfmon tool.
In This Section
Monitoring Cache Server Counters using Perfmon Tool
Explains how to view and monitor all the counters related to cache server through Perfmon tool.
Monitoring Cache Client Counters using Perfmon Tool
Explains how to view and monitor all the counters related to cache client through Perfmon tool.
Monitoring Bridge Counters using Perfmon Tool
Explains how to view and monitor all the counters related to bridge through Perfmon tool.


Topic: Monitoring Perfmon Counters Using Custom Dashboard

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Perfmon Counters Using Custom Dashboard

Performance Monitor is Microsoft Windows tool that can be used within NCache Monitor custom dashboards just like
other NCache custom controls. Follow the steps given below to add perfmon control in a custom dashboard:
  • Go to the Toolbox, available on the left side inside NCache Monitor.
  • Click on the Cache Server button on the Toolbox.
  • Select the perfmon control; drag and drop it in any cell inside a custom dashboard.
  • Now you can add the required NCache counters in it or any other perfmon based counters. Click on the green plus button, select the required server machine and then choose the required perfmon counters.
  • More details on Perfmon can be found at Using Performance Monitor .
See Also
Monitoring Cache Server Counters Using Built-In Dashboard | Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters


Topic: Performance Counters

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Performance Counters

NCache is not only enriched with powerful monitoring facilities, but besides that; it also provides different categories of
counters for windows performance monitor. This lets the clients monitor the overall performance of NCache. These
categories include cluster, client, server and bridge. They cover all aspects of NCache monitoring including remote
clients, cache clients, clustered operations, server counters, bridge queue status counters and many more.
Performance counters provide valuable information about system hardware, services, networks and applications that can be used to determine their performance. It helps in diagnosing problems, used to fine-tune systems and
applications, monitoring real-time application performance and resolving bottleneck cause of system components.
Performance counters can be seen both from Perfmon and NCache Monitor. The statistics view is also used to see the performance statistics of a cache or a cluster.
These counters include:
  • Fetches/sec: Number of Get operations per second.
  • Hits/sec: Number of successful Get operations per second.
  • Misses/sec: Number of failed Get operations per second.
  • Additions/sec: Number of Add operations per second.
  • Updates/sec: Number of Insert operations per second.
  • Deletes/sec: Number of Remove operations per second.
  • Expirations/sec: Number of items being expired currently per second.
  • Evictions/sec: Number of items evicted per second.
  • State Txfr/sec: Number of items this node is either reading from other nodes or sending to other nodes during a state transfer mode.
  • Data Bal/sec: Number of items this node is either reading from other nodes or sending to other nodes during a Data Load Balancing mode.
  • Mirror Queue Size: Number of items in the Mirror queue.
  • Average sec/fetch: Average time in seconds taken to complete one fetch operation.
  • Average sec/add: Average time in seconds taken to complete one Add operation.
  • Average sec/insert: Average time in seconds taken to complete one insert operation.
  • Average sec/remove: Average time in seconds taken to complete one remove operation.
  • Average sec/cache operation: Average time, in seconds, taken to complete one cache operation.
  • Client Request/sec: Number of requests sent by all clients to the cache server.
  • Client Response/sec: Number of responses received by all clients from the cache server.
  • Clustered opsrecv/sec: Number of clustered operations performed per second.
  • Clustered opsent/sec: Number of clustered operations performed per second.
  • Count: Number of items in the cache.
  • DispatchEnter/sec: Number of clustered operations performed per second.
  • Mirror queue size: Number of items in the Mirror queue.
  • Misses/sec: Number of failed Get operations per second.
  • Readthru/sec: Number of Readthru operations per second.
  • Response sent/sec: Number of clustered operations performed per second.
  • Responses/sec: Number of responses sent (meaning cache response for commands like add, get, insert, remove etc.) to all clients by this cache server.
  • State transfer/sec: Number of items this node is either reading from other nodes or sending to other nodes during a state transfer mode.
  • Writethru/sec: Number of Writethru/Writebehind operations per second.
  • CacheLastAccessCount: Number of items which are older then the access interval specified in the config.
  • Cluster ops/sec: Number of clustered operations performed per second.
  • Bytes sent/sec: How much data is sent from this node to other nodes in the cache.
  • Bytes received/sec: How much data is received by this node from other nodes in the cache.
  • Requests/sec: Number of requests (meaning cache commands like add, get, insert, remove etc.) being processed from all clients by this cache server.
  • Client bytes sent/sec: Bytes being sent from cache server to all its clients.
  • Client bytes received/sec: Bytes being received by cache server from all its clients.
  • Response Queue Count: Number of items in response queue; all responses are queued in the response queue before being sent.
  • Response Queue Size: Size of the response queue in bytes. Is displays the total data size of all the responses in the response queue.
  • Event Queue Count: Number of events in the event queue.
  • Events Processed/sec: Number of events processed per second on a client.
  • Events Triggered/sec: Number of events triggered and received by client per second.
  • Average ms/event: Average time taken by client to process a single event.
You can select different counters to be displayed in 'Cluster Performance Test Bed' to analyze cluster performance through Options Dialog. You can enable Performance Counters for both Local and Clustered Caches from Options Tab of their view window.
See Also
Debugging Counters | Monitoring Caches using NCache Manager | Monitoring Caches using NCache Monitor | Monitoring Bridge using NCache Manager | Monitoring NCache using Windows Perfmon Tool | Configuring Caches


Topic: Monitoring Cache Server Counters Using Built-In Dashboard

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Cache Server Counters Using Built-In Dashboard

There are two major categories of performance counters; Server counters and Client counters. This section describes how to monitor server counters using built-in dashboard.
Launch NCache Monitor using NCache Manager
  • Right click on the clustered cache name under Clustered Cached tree node in Cache Explorer context menu.
  • Select Monitor Cluster option from the right click menu.
  • NCache monitor is opened. By default there are two dashboards already opened,
  • Server Dashboard
  • Report-View Dashboard.
Both default dashboards are non-editable. It means no counter or graph can be added or removed from default dashboards.
  • Select Monitor Cluster option from the right click menu.
Server Dashboard
It contains Cluster Health, Event Logs along with some mostly required cache counter graphs like, NCache CPU Graph, NCache Network Graph, Cache Size, NCache Request/sec Graph and NCache Memory Graph etc. Server Dashboard is generally a graphical view dashboard.
Report View Dashboard
This view shows counters in numeric form rather than graphs. It contains two portions, each for Server Report View
and Client Report View. Both portions contain respective counters.
See Also
Monitoring Cache Client Counters Using Built-In Dashboard | Monitoring Cache Cluster Counters Using Custom Dashboard | Monitoring Perfmon Counters Using Custom Dashboard | Monitoring Cache Event Logs Using Custom Dashboard | Monitoring Client Process of a Cache Cluster Using Custom Dashboard | Monitoring Caches Using NCache Monitor | ASP.NET Session Monitoring Using Custom Dashboard | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Cache Counters


Topic: Monitoring Cache Server Counters Using Perfmon Tool

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Monitoring Cache Server Counters Using Perfmon Tool

NCache publishes cache server counters in perfmon under category NCache. This category has all the counters related to the cache server. Follow the steps given below to monitor the NCache counters through perfmon tool:
  • Press WINDOWS + R keys on your keyboard OR click on the windows start menu and then type perfmon and press ENTER key.
  • Perfmon tool opens up. Click on the Performance Monitor under Monitoring Tools.
  • Click on the cross (X) button to remove the default counter which is already added in it. Then click on the plus (+) button to open the Add Counters dialog box.
  • Using the vertical slider of available counters list box, scroll upward to find NCache category.
  • Click on the down arrow head icon to expand the NCache category. All of its counters are listed under it. Select the required counters from this list like this:
  • All of the current running caches (and replicas of caches) appear inside of Instances of selected objects list box. Select the required instance or simply click on the <All instances> and click on the Add >> button. All of the selected counters for all the selected instances of caches appear in Added counters list box on the right side.
  • Click OK. All of the selected counters will appear in perfmon tool like this:
You can also change the view of perfmon from Report view to Line view. Follow the steps given below:
Click on the Line option of the drop down menu. This changes the perfmon view from Report to Line. In Line view, counters values are displayed in the form of continuous graph, like this:
See Also
Monitoring Cache Client Counters Using Perfmon Tool | Monitoring Bridge Counters Using Perfmon Tool | Monitoring Bridge Using NCache Manager | Monitoring NCache Using Windows Perfmon Tool | Logging | Configuring Caches | Cache Counters


Topic: Multiple Network Cards

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Multiple Network Cards

If you have dedicated network cards configured for public and private communication, then you might not be able to create new clusters or possibly existing NCache cluster could not communicate with others. Please note, the following problems will occur if nodes are unable to communicate with each other on specific interface(s).
  • NCache Service starts at one interface whereas other nodes try to communicate with it on the other interface. Therefore the two nodes are always unable to communicate with each other even when apparently both nodes are fully functional.
  • NCache Clients connect to NCache Server to get OutProc cache instances. So, it is possible that NCache Server starts at one interface whereas the client tries to connect to it on the other interface. This way, though NCache Server is ready to accept the client requests, client applications will always be unable to connect to the OutProc caches.
  • Situations can arise where cluster nodes are unable to join with each other and no cluster is forming. The reason could be that one node is listening join requests from other nodes on one network interface whereas other nodes send join requests on other network interface.
Workaround
To avoid such problems, you can bind NCache service to specific IP that is publicly available to other nodes in the cluster. Here is how you can bind IP to NCache service:
<add key = "NCacheServer.BindToClientServerIP" value = "" />
BindToClusterIP: You can inform NCache which interface to use for cluster-wide communication. In order to do so, provide the IP Address you want the cluster server to bind with.
BindToClientServerIP: You can inform NCache which interface to use for client communication. In order to do so, please provide the IP Address you want the client's (NCache client) server to bind with.
If you want to initialize your clustered cache as InProc, you need to provide same information in your application's config file. Otherwise, this node may not join with other cluster nodes.
See Also
Configuring NCache Service | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Unable to apply configurations or start cache due to disabled network card | Both nodes in a mirror cache appear as active nodes in NCache Manager | Nodes in a clustered cache are not joining with each other


Topic: Nagling

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Nagling

Nagling refers to concatenating a number of small buffer messages. It increases the efficiency of a network application system by decreasing the number of packets that must be sent. Nagling can be thought of as bulk operation on the network. By default Nagling is enabled. You can turn it off in your service's config file as follows:
<add key="NCacheServer.EnableNagling" value="false"/>
Nagling combines all the available messages present in a queue whose combine size is less than Nagling threshold. Size is specified in terms of Kilo bytes. By default it is 500Kb. You can specify it in service's config file as follows:
<add key="NCacheServer.NaglingSize" value="500"/>
If you are using cache as InProc, you need to specify the above lines of code in config.exe of your application.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Named Tags

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Named Tags

NCache provides a feature “Named Tags” through which the user is able to associate one or more keywords with cache items. Named tags act as an identifying mark for the cache items and can be used for querying the cache data.
In This Section
Overview
Explains the basic concept and do's and dont's of Named Tags in NCache
Using Named Tags
Explains how to use Named Tags in NCache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

NCache is providing feature “Named Tags” through which user will be able to associate one or more keywords with cache items. These keywords will act as an identifying mark for the cache items and will be used for querying the cache data.
"Named Tags" is the enhancement of "Tags". Consider a scenario where user needs to store an object in textual form such as "xml", he will not be able to search that object using tags. The limitation of tags is that it can only have text values and only one attribute i.e. $Tag$. With named tags user will be able to store additional information (of any type) required to query the object stored as string.
Here users are required to provide the list of named tags, each having two parameters, "key" (name of a tag) as string and "value" (assigned value) as any primitive type. NCache then allows you to search your objects through these named tags.
If there are multiple applications that are sharing the same cache and all of them are supposed to add named tags, then make sure that the same named tags have homogenous data types, e.g., if one client is adding named tag "ProductID" with String data type, then all other clients should add values of "ProductID" in String format not in Integer or other for the same cache.
See Also
Using Named Tags | Tags | Group/Subgroup | Object Query Language (OQL) in NCache | Server Side API Programming


Topic: NCache API

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache API

While using NCache API, you might experience some problems. This section provides solutions for some common troubles.
In This Section
No Server is available to process the request
Different situations are explained when this exception is thrown by NCache Client API (both Java and .NET).
java.lang.NoClassDefFoundError: com/alachisoft/ncache/licensing/LicenseManager
Describes when this error occurs and how to solve it. This solution is only for Java version of NCache Client API.
com.alachisoft.ncache.exceptions.GeneralFailureException: License not verified
Explains the reason of occurrence of this exception and also tells ways to solve this problem. This solution is only for Java version of NCache Client API.
See Also
Implementing Clusters
Provides help to troubleshoot the problems related to cluster implementation.
Using NCache API
Provides help to troubleshoot the problems related to NCache API.
Using Security
Provides help to troubleshoot the problems that may arise when using NCache security.
Viewing Statistics
Provides help to view remote server statistics.
Installing NCache
Provides quick reference for error codes, messages, and symptoms generated by NCache during installation.


Topic: Using NCache as Entity Framework Second Level Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using NCache as Entity Framework Second Level Cache

Integration without any Code Change
NCache custom Entity Framework ADO.NET provider can be integrated in the application without any code change. Simply modify configuration files and specify NCache Entity Framework Caching Provider as second Level Cache provider.
Prerequisites:
Following are the prerequisites to enable NCache in Entity Framework application:
1. The user should have an Entity Framework application. The sample application for Entity Framework Caching from NCache sample
applications can also be used from the following path
%InstalledDirectory%/samples/clr20/EntityDataModelIntegrationDemo
2. Microsoft Visual Studio 2010 for Entity Framework 3.5 and 4.0 and Microsoft Visual Studio 2012-2013 for
Entity Framework 6.0 and 6.1.
3. Database Tool (e.g. MS SQL SERVER, ORACLE)
Steps required to enable NCache as Second Level Cache Provider in Entity Framework application are follows:
Adding Appropriate Assemble Reference
Add the following assembly
Alachisoft.Integrations.EntityFramework.CachingProvider
into Entity Framework application. This .dll file is placed on the following path:
%Installeddirectory%/integration/MSEntityFramework.
After adding the reference, the following changes are required:
Modifying Application or Web Configurations
Application or web configuration file which is generated on adding ADO.NET Entity Data Model in Entity Framework application, requires following changes:
Entity Framework 3.5 or 4.0
· Provider invariant name is specified in the connection string of application or web configuration file:
<connectionStrings>
<add name="NorthwindEntities"
connectionString="metadata=res://*/NorthwindCustomerModel.csdl
|res://*/NorthwindCustomerModel.ssdl
|res://*/NorthwindCustomerModel.msl;
provider=System.Data.EntityClient;
provider connection string=&quot;
Data Source=localhost;Initial Catalog=Northwind;user id= userid;
password=password;MultipleActiveResultSets=True&quot;"
providerName="System.Data.EntityClient"/>
</connectionStrings>
Change provider name to NCache Entity framework Provider and also add the provider wrapper information in connection string as shown below:
<connectionStrings>
<add name="NorthwindEntities"
connectionString="metadata=res://*/NorthwindCustomerModel.csdl
|res://*/NorthwindCustomerModel.ssdl
|res://*/NorthwindCustomerModel.msl;
provider=Alachisoft.Integrations.EntityFramework.CachingProvider;
provider connection string=&quot;
wrappedProvider=System.Data.SqlClient;
Data Source=localhost;Initial Catalog=Northwind;user id= userid;
password=password;MultipleActiveResultSets=True&quot;"
providerName="System.Data.EntityClient"/>
</connectionStrings>
· Also add the provider factory for initialization of NCache Entity framework Provider. The invariant attribute should be the same as the provider name in connection string.
For Enterprise and Professional Editions:-
<DbProviderFactories>
<add name="EF Caching Data Provider"
invariant="Alachisoft.Integrations.EntityFramework.
CachingProvider"
description="Caching Provider Wrapper"
type="Alachisoft.NCache.Integrations.
EntityFramework.EFCachingProviderFactory,
Alachisoft.Integrations.EntityFramework.
CachingProvider,
Version=1.0.0.0,
Culture=neutral,
PublicKeyToken=cff5926ed6a53769"/>
</DbProviderFactories>
Entity Framework 6.0
· Provider invariant name is also specified in the application (or web) configuration file:
<entityFramework>
<providers>
<provider invariantName="System.Data.SqlClient"
type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
</providers>
</entityFramework>
Change invariant name to EFCachingProviderServices and type to Alachisoft.NCache.Integrations.EntityFramework.EFCachingProviderServices, Alachisoft.Integrations.EntityFramework.CachingProvider as shown below:
<entityFramework>
<providers>
<provider invariantName="EFCachingProviderServices"
type="Alachisoft.NCache.Integrations.EntityFramework.EFCachingProviderServices,
Alachisoft.Integrations.EntityFramework.CachingProvider" />
</providers>
</entityFramework>
Entity Framework 6.1
· Add an interceptor in provider section in the application (or web) configuration file:
<entityFramework>
<providers>
<provider invariantName="System.Data.SqlClient"
type="System.Data.Entity.SqlServer.SqlProviderServices,
EntityFramework.SqlServer" />
</providers>
<interceptors>
<interceptor type="Alachisoft.NCache.Integrations.EntityFramework.Caching.EFCommandInterceptor,
Alachisoft.Integrations.EntityFramework.CachingProvider" />
</interceptors>
</entityFramework>
Configuration independent of Entity Framework version
· The following information should be added in appSettings of app.config or web.config
<appSettings>
<add key="app-id" value="EFCachingDemo"/>
<add key="logging-level" value="Debug"/>
</appSettings>
app-id: This will be the identifier for current application. This ID will be used to read configuration from efcaching.ncconf.NCache.EF Caching provider reads the required information from efcaching.ncconf on the basis of ID given in app/web .config file.
logging-level: Determines the logging level for application. The provider will log exceptions and errors only when level is set to Error. When the level is set to Debug, both exceptions/errors and other detailed information will be logged. Nothing will be logged if the level is set to Off (default). Path at which log files will be generated is
%Installeddirectory%/log-files/efcaching-logs/
App-id of efcaching.ncconf should be the same as in application (app.config) in order to avoid an error. Application should be restarted after above changes are made.
Alternative method through Programming
Entity Framework 3.5 or 4.0
Apart from specifying connection string in app.config/web.config, the connection can also be specified while creating ObjectContext or EntityConnection. While creating a connection string programmatically, the wrapper information must be included in a connection string. Here is how the connection string can be created and ObjectContext or EntityConnection can be initialized.
try
{
SqlConnectionStringBuilder sqlConnBuilder = new SqlConnectionStringBuilder();
sqlConnBuilder.DataSource = "localhost";
sqlConnBuilder.InitialCatalog = "EFTestDB";
sqlConnBuilder.IntegratedSecurity = true;
string conString = sqlConnBuilder.ToString();
EntityConnectionStringBuilder efConnBuilder = new EntityConnectionStringBuilder();
efConnBuilder.Provider = "EFCachingProvider";
efConnBuilder.ProviderConnectionString = @"wrappedProvider=System.Data.SqlClient;" + conString;
efConnBuilder.Metadata = "res:// /NorthwindCustomerModel.csdl|res:" + "// /NorthwindCustomerModel.ssdl|res:" +"// /NorthwindCustomerModel.msl;";
EntityConnection connection = new EntityConnection(efConnBuilder.ToString());
}
catch (Exception ex)
{
// handle exception
}
Entity Framework 6.0
Apart from specifying provider invariant in app.config/web.config, the provider invariant can be specified while initializing the
configuration (class inheriting DbConfiguration). Here is how the provider invariant can be specified.
try
{
this.SetProviderServices("EFCachingProviderServices", EFCachingProviderServices.Instance);
}
catch (Exception ex)
{
// handle exception
}
Entity Framework 6.1
Apart from specifying database interceptor in app.config/web.config, the database interceptor can be specified while initializing the
configuration (class inheriting DbConfiguration). Here is how the interceptor can be specified.
try
{
this.AddInterceptor(new EFCommandInterceptor());
}
catch (Exception ex)
{
// handle exception
}
Through API (6.0 and 6.1)
User can now also cache results using extension provided for IQueryable.
· Specify the namespace
using Alachisoft.NCache.Integrations.EntityFramework.Caching;
· Call cache method overloads now from IQueryable insance
var students = from s in db.Students
select s;
students.Cache(); // results are not cached yet
foreach (Student student in students) //results are cached when enumerator from query is iterated completely
{
//using student
}
The application will need to be rebuilt the application for effectively applying the above changes.
Entity Framework-Caching Configuration File
EFcaching.ncconf configuration contains cache and caching policy related information used by NCache Entity Framework caching provider. Some changes are required in "efcaching.ncconf" to run the Entity Framework Application with NCache.This config file is placed on the following path:
%Installeddirectory%/config
Below are the changes required in efcaching.ncconf.
<configuration>
<app-config app-id="EFCachingDemo" mode="analysis|caching">
<analysis-policy log-path="" analysis-time="1min" cache-enable-threshold="1" default-expiration-type="Sliding" default-expiration-time="180sec" dbsyncdependency="false"/>
<cache-policy-configurationdatabase="none|sqlserver|oracle" cache-id="mycache">
<api-level-caching expiration-type="sliding|absolute" enable="True|False" expiration-time="120sec" dbsyncdependency="True|False">
<!--sql-query = "SELECT [Extent1].[CustomerID] AS
[CustomerID],= @param_0"-->
<query>
<cache-query query text="SELECT [Extent1].
[OrderID] AS [OrderID], &lt; @param_0"/>
<cache-policy vary-by-cache-param="param_0" expiration-type="Sliding" enabled="True"
expiration-time="180sec" dbsyncdependency="False"/>
</query>
</cache-policy-configuration>
</app-config>
</configuration>
Member
Description
app-id
This ID is same as defined in app/web configuration file of application.
mode
NCache Entity Framework Caching provider works under two modes. It can either be in "Caching" or in "Analysis" mode.
Analysis Mode
Analysis Mode is used for monitoring the number of times each query executes and then it generates a report. Report contains the query text and the call count for each query. No caching is done at this mode.
· log-path: The default Path at which analysis log files will be generated is %Installeddirectory%/log-files/EFCachingAnalysisLogs/
· analysis-time: Time for which the analysis will run. Default = 1 min
· cache-enable-threshold: Caching will automatically be enabled for queries whose call-count exceeds this threshold. By default, its value is 1.
· default-expiration-type: Default expiration type for analyzed queries. The default type is sliding.
· default-expiration-time: Default expiration time for analyzed queries. Default is 180 sec (3 min)
· dbsyncdependency: Determines whether to enable database-dependency or not. Default value is false.
Caching Mode
Wrapping provider will cache the results of all the specified queries. Whenever update is detected (either UPDATE, INSERT or DELETE) in a respective database, the provider invalidates the affected cache entries by evicting all cached queries which were dependent on any of the updated tables.
· database : Database server where user’s database reside.
· cache-id : Specified Cache Name where query results are stored for fast access.
query
Query attribute including user-configurable list of queries that should be cached with their results. A particular query can be configured with its cache policy defined in cache policy tag. Cache query and Cache policy are separated by dedicated tags. User can easily change policies from cache-policy tag without facing any XML parsing error.
cache-query
For cache query, this tag is auto generated by Entity Framework Caching Provider when the application is running in analysis mode. For ease of understanding, commented SQL-query tag is added so that the user can read the query.
· cache-query-text : This is used for XML parser and the user is not allowed to make any sort of changes in it.
Cache-policy
When mode is selected as Caching, only those query results will be cached for which caching is enabled. The user can also specify caching policies for all queries.
· vary-by-cache-param: User can specify which parameter should be included as part of cache key. NCache Entity Framework Cacheing Provider will replace the actual parameter in.config file with its own names which should follow the following parameter format:
@param_[parameter-no/index]
For example,
@param_0, @param_1,@param_2;
A sample query with parameters:
"select * from dbo.customers where customer_id = @param_0 and dob > @param_1;"
· enable : Determines whether caching is enabled for this query or not. Default value is true.
· expiration-type: Type of expiration, it can be 'absolute' or 'sliding'. Default is sliding.
· expiration-time: Expiration time for this query. Default is 180 sec (3 min).
· dbsyncdependency: Determines whether to enable database-dependency for this query or not. Default is false.
Api-level-caching
While using the api for caching, the user can also specify caching policies for all queries he is caching using api.
· enable : Determines whether caching is enabled for api-level-caching or not. Default value is true.
· expiration-type: Type of expiration, it can be 'absolute' or 'sliding'. Default is sliding.
· expiration-time: Expiration time for this query. Default is 180 sec (3 min).
· dbsyncdependency: Determines whether to enable database-dependency for this query or not. Default is false.
SQL Dependency will be registered only for those SQL queries that satisfy all the conditions for SQL Notification Registration as described in the Microsoft provided document .
InProc client cache stores items in object form, therefore if object is modified by the application, it should be updated back to the cache so that other remote clustered cache and other client caches have no data integrity issue.
See Also
Entity Framework Caching Integration Overview | NHibernate | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features


Topic: Using NCache as NHibernate Second Level Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using NCache as NHibernate Second Level Cache

NHibernate has a first level or session level cache which is used by default. Each session contains its own session level cache which is not shared with other sessions. This cache is disposed whenever the session is closed. However NHibernate allows to use second level, across session cache which spans across sessions life time and can be shared by multiple sessions.
NCache provides a second level or process level cache for NHibernate by implementing NHibernate's ICacheProvider and ICache interfaces. This enables NCache to be used as NHibernate second cache in existing NHibernate application without any code change. All that’s needed is to change NHibernate configuration file to plug-in NCache as cache provider and distributed caching can be used.
Second level cache can be configured by enabling the use of second level cache and configuring second level cache provider in NHibernate configurations.
Configuring NHibernate Application to use NCache as Second Level Cache
  • In NHibernate configuration, configure NCache as NHibernate's second level cache provider by adding the following property.
<property name="cache.provider_class"> Alachisoft.NCache.Integrations.NHibernate.Cache.NCacheProvider, Alachisoft.NCache.Integrations.NHibernate.Cache</property>
cache.provider_class: This option lets the user specify NCache as 2nd level cache provider. The user needs to mention two classes which implement ICacheProvider and ICache interfaces respectively. This is how NHibernate knows how to call this second level cache.
  • Place NCache’s NHibernate provider dll Alachisoft.NCache.Integrations.NHibernate.Cache.dll located at %NCacheInstallDir%/integration/nhibernate/assembly/ in application's base directory.
  • Enable the use of second level cache in application by adding the following property in NHibernate configuration section's session-factory tag:
<property name="cache.use_second_level_cache">true</property>
  • NCache provider for NHibernate identifies each application by an application id that is later used to find the appropriate configuration for that application from NCache configuration file for NHibernate "NCacheNHibernate.xml". This application id must be specified in application's configuration file (app.config/web.config). Add following property in application configuration for this purpose:
<appSettings>
....
<add key="ncache.application_id" value="myapp" />
....
</appSettings>
Configuring Cacheable Objects
Enabling the use of second level cache does not cache each class object by default. Instead classes needed to be cached are to be marked cacheable in class mapping (.hbm.xml) file. To mark a class cacheable add the following tag in class's configuration:
<cache usage="read-write" region ="AbsoluteExpirationRegion"/>
In the above tag, properties usage and region can be changed.
Region specifies the name of second level cache region to be used for this class objects. If no region is specified, fully qualified class name will be used as region name with default region configurations.
Usage specifies caching concurrency strategy to be used for this class. NHibernate allows the following three concurrency strategies to be used for caching:
  • Read-Write
  • Nonstrict-Read-Write
  • Read-Only
Configuring Cache Regions
NHibernate uses cache regions to store objects. NCache allows cache regions to be configured with different properties. For this purpose NCache has a configuration file named "NCacheNHibernate.xml", which contains all regions’ configurations and other related configurations used by NCache. This file can be placed at root directory of application or in config folder of NCache Installation directory.
Following is a sample configuration file:
<configuration>
<application-config application-id="myapp" enable-cache-exception="true"
default-region-name="default" key-case-sensitivity="false">
<cache-regions>
<region name="AbsoluteExpirationRegion" cache-name="mycache" priority="Default" expiration-type="sliding" expiration-period="180" />
<region name="default" cache-name="mycache" priority="default" expiration-type="none" expiration-period="0" />
</cache-regions>
<database-dependencies>
<dependency entity-name="nhibernator.BLL.Customer" type="oledb" sql-statement="select ContactName from dbo.Customers where CustomerID =?" cache-key-format="depdency.customer:[pk]"/>
</database-dependencies>
</application-config>
</configuration>
Multiple application configurations can be specified in NCacheNHibernate.xml. Any NHibernate application will use one of the specified configuration based on the application-id specified in applications app.config/web.config file.
Following are the configurable options in application-config section.
Member
Description
application-id
This option let the user specify a unique id for current application-config. This id is used to select appropriate configuration for a particular application.
enable-cache-exception
Identifies whether the exceptions if occurred in NCache will be propagated to NHibernate provider.
default-region-name
Allows to specify a default region for the application. If a particular region's configurations are not found, default region configurations will be used. Specified default region configuration must exist in cache-regions section.
key-case-sensitivity
This option allows to specify whether cache keys will be case sensitive or not. This option has to be configured according to database used. If database is case-sensitive set this option true, otherwise false.
cache-regions
This sections lets the user configure multiple cache regions for NHibernate application. Each region's configuration is specified in region tag.
region
This tag contains the configurations for one particular region. Following options can be configured for any particular region.
name: Each region is identified by its name. Name of the region should be unique.
cache-name: This option allows specifying NCache's cache name to be used for this region.
priority: The priority the user wants to use for cached items. The possible values are :
· Default
· Low
· BelowNormal
· Normal
· AboveNormal
· High
· NotRemovable
expiration-type: This options allows to specify type of expiration for any item in this region. Possible values are absolute/sliding/none.
expiraion-period: Allows to specify expiration period if absolute/sliding expiration is configured. Its value should be greater than 0.
database-dependencies
It lets the user specify database dependencies for current NHibernate application.
dependency:
Each dependency is configured in a dependency tag. Multiple tags can be configured for multiple dependencies. The following options can be configured for each dependency.
entity-name: Dependencies are added based on the fully qualified name of classes. This option allows to specify name of class for which current dependency is to be added. Any entity can have maximum one dependency.
type: Allows to specify database dependency type. Possible values are sql/oracle/oledb. Since NCache provider uses connection string specified in NHibernate's configuration, use dependency type appropriate to connection string.
sql-statement: Allows to specify sql statement to be used for building NCache's database dependency.
cache-key-format: This option is used to configure cache key format for any item of current entity type. Cache key format should include "[pk]" in it, which will be replaced with the primary key of record. cache-key-format may also include "[en]" which will be replaced with entity name. Default value of cache key format is "NHibernateNCache:[en] #[pk]". Same cache key format should be used while writing database trigger incase of oledb database dependency. See NCache help for writing database trigger for oledb dependency.
composite-key-separator: If the records of current entity have composite key as primary key, cache-key is formed by combining all keys separated by composite-key-separator. composite-key-separator must be of one character length. Its default value is "$".
Using Query Caching
NHibernate also provides a feature of query caching. Enabling query caching caches queries made by NHibernate to database, along with query result sets. Query caching makes use of second level cache to store queries, so that whenever the same query is needed to be executed again, it can be fetched from cache.
Any object retrieved as a result of query are cached to their respective regions, therefore objects must be marked as cacheable for efficient use of query caching. However query along with the primary keys of result sets is stored in a default query region named NHibernate.Cache.StandardQueryCache.
Since not every query's results remain same for a period of time. Therefore query caching should only be used with queries whose results are likely to be changed less frequently.
How to Enable Query Caching
To enable query caching, add the following property in NHibernate configuration section's session-factory tag:
<property name="cache.use_query_cache">true</property>
Enabling query cache does not cache each query by default. Instead queries needed to be cached are to be set cacheable in code. To set a query cacheable, call SetCacheable(true) function of query while creating query, e.g.,
IQuery qry = session.CreateQuery("from Customer c").SetCacheable(true);
See Also
NHibernate Overview | Entity Framework Caching Integration | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features


Topic: NCache Event Notifications

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Event Notifications

NCache provides the following level of events:
  • Cache Level Events
  • Item Level Events:
  • Continuous Query Events
  • Application Initiated Custom Events
This section explains how to use event notifications at these three levels.
In This Section
Cache Level Data Event Notifications
Explains how to use notification mechanism for events occurring at cache level.
Item Level Data Event Notifications
Explains how to use notification mechanism for events occurring at item level.
Custom Event Notifications
Explains how to use custom events and notification mechanism provided by NCachel.


Topic: What is NCache Java Client?

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

What is NCache Java Client?

NCache Java Client is an NCache client written in Java that makes sharing and managing data in a cluster as simple as on a single server. It accomplishes this by coordinating updates to the data using cluster-wide concurrency control, and replicating and distributing data modifications across the cluster using the highest performing clustered protocol available. The primary purpose of NCache Java Client is to help improve performance of Java/J2EE & JSP applications that would
otherwise make expensive trips to database systems, web services, mainframes, or other systems across the network.
Connecting with NCache Java Clients
Accessing NCache Java Client Resources: You can subscribe to a variety of NCache Java Client resources including newsletters, webinars etc. Please visit Alachisoft Website .
  • Accessing NCache Java Client Documentation: You can access all NCache Java Client documentation at
Online Documentation .
  • Contacting NCache Java Client Support: For comments/feedback and any problems related to NCache Java Client or this manual you can contact NCache support. Simply send an email to support@alachisoft.com or visit Alachisoft Support Page .
See Also
Getting Started | Installation Steps for UNIXl | Post Installation License Management for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX


Topic: NCache Java Client Installation Guide for UNIX

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Java Client Installation Guide for UNIX

This section provides you information about installing NCache Java Client in UNIX environment. It provides the system and software requirements, along with information about the administrative privileges you need in order to install NCache Java client.
In This Section
What is NCache Java Client?
Explains what is NCache Java Client and its primary purpose.
Getting Started
Describes the prerequisites for NCache Java Client installation.
Installation Steps for UNIX
Describes Includes step by step instruction for NCache Java Client installation in UNIX.
Post Installation License Management for UNIX
Explains the steps to extend the evaluation period and activate NCache license.
Post Installation Client/Server Configuration for UNIX
Explains the configuration of NCache for client/server communication in UNIX.
Uninstall NCache Java Client from UNIX
Includes step by step instructions on how to uninstall NCache Java Client from UNIX.
Troubleshooting Common Install/Uninstall Problems
Explains how to deal with commonly occurring exception while running some command tool.


Topic: NCache Language Integrated Query (LINQ)

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Language Integrated Query (LINQ)

LINQ allows fetching data of any type through a set of pre-defined standard rules. This helps in setting a common standard through which data can be accessed. It simply joins the application's object layer to data layer. Data can be retrieved in collection of any possible data structure like objects, XML tree, lists etc but there will be no change in the retrieval format of code. If the model is created through LINQ, then there is no need to worry about inner details.
NCache allows using LINQ with cache to improve the application’s performance through caching without changing the LINQ object model. The cache handle should be given to the NCache LINQ provider after creating its instance. NCache LINQ provider converts LINQ related query into NQL format and returns the result accordingly after transforming it in LINQ format. Because of using NQL under the wrapper of NCache LINQ provider, indexes should be configured for using LINQ too.
Here is a sample query in LINQ
var result = from product in products
where product.ProductID > 10
select product;
In this query, all those products which have Product ID greater than 10 will be fetched from the cache. The query format is the same as when normal LINQ is used without NCache LINQ provider. Here ProductID and other required attributes need to be indexed before using this query with NCache.
There are some LINQ operators which are not supported by NCache LINQ Provider. These are:
  • NCache LINQ Provider does not support nested queries.
  • LINQ operator ORDERBY is not supported by NCache LINQ Provider.
  • LINQ operator GROUPBY is not supported by NCache LINQ Provider.
  • Join operations are not supported by NCache LINQ Provider.
Runtime indexing is not supported in NCache LINQ integration now.
To provide LINQ benefits, LINQ is integrated with NCache by implementing a class named NCacheQuery, which further implements the interface called IQueryable provided by .NET framework. This integration allows the user to run LINQ queries on cached items. For executing LINQ queries on cached items, an object implementing IQueryable interface should be defined and passed as an instance of cache which contains the object as shown below:
IQueryable<Product> products = new NCacheQuery<Product>(cache);
Defining Indexes
NCache requires all searchable attributes to be indexed. NCache provides its own indexing mechanism through which the users can identify objects in .NET assemblies that they want to index. See the section Indexing for details.
NCache only support single entity search, multiple entities or joins are not supported.
Using LINQ
No code change is required for using NCache with LINQ except that a new assembly reference and namespace should be added in application. Rest of the code will work without any change in application.
The namespace to be added in application for LINQ support is as follows:
using Alachisoft.NCache.Linq;
The following code shows how to implement the NCacheQuery class which further implements IQueryable interface. The code also shows the LINQ query based on NCache Query Language running on a cached data.
//create your custom class LINQ object by giving handle of your cache.
IQueryable<Product> products = new NCacheQuery<Product>(cache);
try
{
var result = from product in products
where product.ProductID > 1010
select product;
if (result != null)
{
foreach (Product product in result)
{
//put your code here for modification of products.
}
}
else
{
//if there is no result in the cache related to your query
}
}
catch (Exception)
{
// can be operation failed due to server lost, state transfer or invalid query format of LINQ
}
See Also
OQL in NCache Overview | Object Query Language (OQL) Syntax | Querying Data in NCache | Continuous Query | Indexing | Configuring Query Indexes


Topic: NCache Management API

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Management API

NCache management API is a set of programmable method calls that enables the user to perform basic management operations on out-proc caches without using either NCache Manager or NCache tools. Management API in some cases relies on the client configuration files to perform an operation, whereas in some cases it is self-sufficient to execute a request.
Include following namespace in project
using Alachisoft.NCache.Web.Management;
Starting Cache Using API Calls
Start Cache methods enable the user to start an out-proc cache on the specified server. In case of failure Management Exception is thrown by the cache. In this example, the user need to specify cache and server name to start a node.
//precondition: Cache has been registered but not initialized.
string cacheName="mycache";
string serverName="...."; // specify the server where cache is registered
try
{
CacheManager.StartCache(cacheName, serverName);
}
catch (ManagementException ex)
{
//thrown if no cache exists or server name is invalid
}
Stopping Cache Using API Calls
Stop Cache methods are used to stop a cache on a particular server. If no server is specified the method would read information from client configuration file. If the method fails to stop the cache or fails to find information regarding the cache, Management Exception is thrown. If called from the client node, the first server listed in the client configuration file associated with the cache will be stopped.
This example stops cache on an already started node. Cache and server name to stop cache on given node need to be specified.
try
{
CacheManager.StopCache(cacheName, serverName);
}
catch (ManagementException ex)
{
// handle exception
}
Viewing Cache Status Using API Calls
GetCacheHealth method enables the user to view the status of cache server nodes. This method call returns a CacheHealth object against every call. The user will need to include the following namespace in his/her project for CacheHealth class.
Alachisoft.NCache.Runtime.CacheManagement
In this example the user only needs to specify the cache name, the API uses client configuration file to connect to the server nodes and collect information; the initial node can also be specified. In case of failure of connection or incorrect cache name, the NCache would throw Management Exception.
try
{
CacheHealth cacheHealth = CacheManager.GetCacheHealth(cacheName);
}
catch (ManagementException)
{
// handle exception
}
Viewing List of Clients Connected with a Cache
GetCacheClient method enables the user to get a list of all connected clients on a server node at a given time. This method returns a dictionary containing server names and list of all client nodes connected at that given time. The user should include “Alachisoft.NCache.Runtime.CacheManagement” namespace in his/her project for the resultant dictionary of this method call.
In this example only the cache name needs to be specified, the API uses client configuration file to connect to the server nodes and collects information;the initial node can also be specified. In case of failure of connection or incorrect cache name, NCache would throw Management Exception.
try
{
//Returns list of all clients connected with cache servers
Dictionary<ServerNode, List<CacheClient>> clientList = CacheManager.GetCacheClients(cacheName);
}
catch (ManagementException ex)
{
// handle exception
}
See Also
Management Operations | Using Basic Cache Operations | Cluster Health | Server Side API Programming


Topic: NCache Memcached Gateway Approach

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Memcached Gateway Approach

NCache provides Memcached gateway server to use NCache without any application code changes or recompilation.
NCache Memcached gateway is implemented based on Memcached socket protocol and acts as Memcached server for Memcached applications. It understands all Memcached clients request and send responses accordingly.
However, it only serves as a proxy and in fact connects to the NCache cluster. Gateway intercepts Memcached commands and then in turn executes NCache APIs equivalent to these commands on NCache distributed cache. This gives the user NCache support for any type of Memcached client regardless of which programming language it is developed in.
There are two deployments of NCache Memcached gateway.
Memcached Client Side Gateway
NCache gateway server is installed on the application servers. Applications talk to local gateway severs and then gateway servers act as NCache client and execute the requested commands on NCache.
The following diagram illustrates this deployment.
Gateway server is an intelligent NCache client that keeps record of all NCache servers in the cluster. Thus if any of the node in NCache cluster gets down, gateway starts communicating with other available NCache servers. This avoids a single point of failure for application. While using gateway, it is recommended to use NCache remote client configuration for using NCache in memcached applications.
Memcached Server Side Gateway
NCache gateway server is installed on the NCache servers. Applications talk to gateway severs running on cache servers and then gateway server talks to cache and sends response back to client.
The following diagram illustrates this deployment.
In the above diagram, it can be seen that the Memcached gateway server (also called Memcached Client Wrapper) runs on NCache cache servers. The Memcached client application talks to this gateway as if it is a Memcached server. And, this in turn talks to the NCache cluster using NCache API calls.
In this configuration when gateway server is running on one of the server nodes in the cluster, memcahed application communicates with only that server node. This produces a single point of failure risk for memcached client application. However in this configuration memcahed socket protocol messages that are more compact and less in size than NCache protocol messages will be communicated over network Memcached Client Plug-In for .NET.
See Also
Memcached Client Plug-in for .NET | NHibernate | Entity Framework Caching Integration | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features


Topic: NCache Monitor Logging

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NCache Monitor Logging

NCache Monitor also provides the logging functionality for different server and client counters with the help of Report View dashboard. Server counters of 'Server Report View' and Client counters of 'Client Report View' can be logged independently.
NCache Monitor Report view also provides the functionality to schedule logging, where the start and stop timings of logging counters can be specified.
Run-time statistics of all counters specified in the specific report view panel, are logged in files of .csv format. Default path of these files is different for server and client counters as:
  • 'Server Report View' panel counters are logged in :
%InstalledDirectory%\log-files\NCacheMonitor\Server\
  • 'Client Report View' panel counters are logged in :
%InstalledDirectory%\log-files\NCacheMonitor\Client\
This logged data can be used for later evaluation of cache cluster and clients performance and health.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | Windows Event Logging


Topic: Using NCache Session State Store Provider

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using NCache Session State Store Provider

NCache Session State Provider is a custom SessionStateStoreProviderBase implementation for an ASP.NET application.
How to Configure NCache Session State Provider
  • Modify Assemblies Tag
Modify <assemblies> section in the application's web.config and add following assembly.
For Enterprise and Professional Editions:-
<assemblies>
<add assembly ="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
For Open Source Edition:-
<assemblies>
<add assembly ="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
  • Replace version "x.x.x.x" with the actual NCache version that you have.
  • Refer Alachisoft.NCache.SessionStoreProvider in your project from "$NCache-install/bin/assembly/[2.0 or 4.0] folder.
  • Modify sessionState Tag
Edit your application's web.config file and modify the <sessionState> section as given below. Place the following code under <system.web> tag.
<sessionState cookieless ="false" regenerateExpiredSessionId ="true" mode ="Custom" customProvider ="NCacheSessionProvider" timeout ="10">
<providers>
<add name ="NCacheSessionProvider" type ="Alachisoft.NCache.Web.SessionState.NSessionStoreProvider" sessionAppId ="1234" cacheName ="myCache" enableSessionLocking ="false" sessionLockingRetry ="-1" writeExceptionsToEventLog ="false" enableLogs ="false" enableDetailLogs ="false" exceptionsEnabled ="false" operationRetry ="0" operationRetryInterval ="0"/>
</providers>
</sessionState>
Following is the description of different key-value pairs specified above:
Member | Description
sessionAppId | Optional string attribute. Specifies an identifier to make sure that session ID remains unique in case multiple applications are using the same cache. Application ID should be the same for an application in a web farm. If no app ID is specified, nothing will be concatenated with session ID.
cacheName | Required string attribute. Specifies the name of the cache to be used for caching session. If no cache name is specified, a configuration exception will be thrown.
enableSessionLocking | Optional Boolean attribute. If this flag is set, NCache Session Store Provider exclusively locks the session-store item for which multiple concurrent requests are made. The default is false. Read Session Locking in NCache Session Store Provider
sessionLockingRetry | Optional Integer attribute. If enableSessionLocking is true and this integer is not less than 0, NCache Session Store Provider will return empty session after sessionLockingRetry, which specify the number of retries to acquire a lock. The default is -1. Read Session Locking in NCache Session Store Provider
writeExceptionsToEventLog | Optional Boolean attribute. If this flag is set, all the exceptions from cache API are written to event logs. The default is false.
enableLogs | Optional Boolean attribute. When this flag is set, store provider logs all error information. The log files are created in "$NCache-install/log-files/SessionStoreProvider/". The default is false.
enableDetailLogs | Optional Boolean attribute. When this flag is set, store provider logs all debugging information. The log files are created in "$NCache-install/log-files/SessionStoreProvider/". The default is false.
exceptionsEnabled | Optional Boolean attribute. Specifies whether exceptions from cache API are propagated to the page output. Setting this flag is especially helpful during development phase of application since exceptions provide more information about the specific causes of failure. The default is false.
operationRetry | It specifies the number of times server will retry the operation, in case connection is lost with a server while an operation is executing. Its default is zero.
operationRetryInterval | It specifies the time interval between each operation retry, in case connection is lost with the server. Its default value is zero.
  • Modify MachineKey Tag
Add <machineKey> entry under <system.web> section. It is required to generate ASP.NET session IDs in the same manner on all nodes. You can use the genmackeys utility available with NCache installation to generate the keys.
<machineKey validationKey ="A01D6E0D1A5D2A22E0854CA612FE5C5EC4AECF24" decryptionKey ="ACD8EBF87C4C8937" validation ="SHA1"/>
How to Fetch Session Data
NCache version 4.3 and later allow viewing all session data stored in clustered cache via NCache Session State Module. All session data is added in the specified cache as a tagged cache item with tag:"NC_ASP.net_session_data".
In order to retrieve previously stored session data, data can be fetched by GetByTag API, which returns Hashtable populated with session ids and associated session data stored in the cache.
Hashtable allSessionData = cache.GetByTag(
new Alachisoft.NCache.Runtime.Caching.Tag("NC_ASP.net_session_data"));
Enabling Location Affinity for SessionStoreProvider
  • Add New Section for Session State Management
Modify <configSections> section in the application's web.config and add following section.
For Enterprise and Professional Editions:-
<configSections>
<section name="ncache" type="Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</configSections>
For Open Source Edition:-
<configSections>
<section name="ncache" type="Alachisoft.NCache.Web.SessionStateManagement.NCacheSection,
Alachisoft.NCache.SessionStateManagement, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</configSections>
  • Replace version "x.x.x.x" with the actual NCache version that you have.
  • Refer Alachisoft.NCache.SessionStateManagement in your project from "$NCache-install/bin/assembly/[2.0 or 4.0] folder.
Add a section with the section name specified above (<ncache> in this case), under <configuration> tag in your application's web.config.
<ncache>
<sessionLocation>
<primaryCache id="London_Cache" sid-prefix="LDC"/>
<secondaryCache id="NewYork_Cache" sid-prefix="NYC"/>
<secondaryCache id="Tokyo_Cache" sid-prefix="TKC"/>
</sessionLocation>
</ncache>
The sid-prefix is a unique identifier that is appended by custom session-ID manager in the beginning of session-ID. sid-prefix length must be equal to 4.
  • Modify sessionState Tag
Enable custom sessionID manager using the sessionIDManagerType attribute of the sessionState element in web.config and add custom provider.
Member | Description
sessionIDManagerType | Optional string attribute. Specifies an identifier to make sure that session ID remains unique in case multiple applications are using the same cache. Application ID should be same for an application in a web farm. If no app ID is specified, nothing will be concatenated with session ID.
  • When Location Affinity is enabled, cacheName specified in <providers> section of web.config will be ignored.
  • Cookieless sessions are not supported.
See Also
ASP.NET Sessions Overview | View State Caching | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations


Topic: How to do NCache Version Upgrades?

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

How to do NCache Version Upgrades?

NCache major version can be upgraded by few simple steps given below:
1. Create Backup of config.ncconf (Optional)
If you are upgrading major version of the NCache then in order to restore old configurations you need to create a backup of config.ncconf file but it is recommended to use new configuration settings in case of major version upgrade. Also refer back to the backup config.ncconf file to see what options you have already configured in order to have exactly same configuration settings again. Backup of log files can also be kept for history purpose.
2. Uninstall NCache
Uninstall current version of NCache. If any application is using NCache and you uninstall NCache, an error message will be displayed as shown below.
Here you have to remove assemblies by yourself
  1. Remove .NET Framework 2.0 assemblies manually from [System Drive]:\Windows\assembly
  2. Remove .NET Framework 4.0 assemblies from [SystemDrive]:\Windows\Microsoft.NET\assembly
  1. For NCache 3.8 remove assemblies manually e.g.
1. [SystemDrive]:\Windows\Microsoft.NET\assembly\GAC_32\Alachisoft.NCache.Web\ v4.0_3.8.0.0__cff5926ed6a53769\Alachisoft.NCache.Web.dll
2. [SystemDrive]:\Windows\Microsoft.NET\Assembly\GAC_64\Alachisoft.NCache.Web\v4.0_3.8.0.0__cff5926ed6a53769\Alachisoft.NCache.Web.dll
b. For NCache 4.3 and above remove assemblies manually from [SystemDrive]:\Windows\Microsoft.NET\assembly\GAC_MSIL e.g.
1. [SystemDrive]:\Windows\Microsoft.NET\Assembly\GAC_MSIL\Alachisoft.NCache.Web\v4.0_4.3.0.0__cff5926ed6a53769\Alachisoft.NCache.Web.dll
3. Install New Version
Install new version of NCache. For complete step by step installation process see installation guide .
4. Verification
After installation you can verify whether NCache has been installed correctly or not by using some command line tools such as:
Startcache mycache It will start default shipped cache ‘mycache’.
Addtestdata mycache It will add 10 items in the cache ‘mycache’, if cache is already started.
Getcachecount mycache It will return the number of total item exist in cache i.e. ‘mycache’.
Listcaches It will show all the created caches on current machine.
5. Upgradeconfiguration Tool (Optional)
For restoring previous configuration settings use command line tool upgradeconfiguration.exe. Use of this tool is useful only when you want to use previous configuration settings otherwise it is not required.
You can also bind NCache service to specific IP that is publicly available to other nodes in the cluster. For details see Select Network Interface Card .
6. Recompile Application
If you are using object caching then you have to recompile your application. And if you are using view state caching or session state caching then you may have to change version manually from web.config file, generally their versions are not changed. But still it can be changed from web.config file For Example:
For Enterprise and Professional Editions:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
For Open Source Edition:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
Replace Version “x.x.x.x” with the NCache version that you have just installed.
Similarly, if you are using NCache SessionStore provider module or content optimization feature then you need to follow the same process. Find “Alachisoft.NCache.*” and change “version=x.x.x.x” with the current version of the NCache module in use.
Note: NCache module version can be different from the NCache version e.g. NCache current release version is “4.4.0.0” but its ContentOptimization module version is “1.0.0.0”.
See Also
Installation Guide | Upgrading NCache | Configuring NCache | NCache Activation Problem


Topic: Support for .NET & ASP.NET Apps

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Support for .NET & ASP.NET Apps

NCache has been developed completely in .NET with C#. Therefore, unlike other products that are either developed in Java or C/C++ and only provide a .NET client API, NCache is a 100% native .NET product that fits very nicely in your .NET application environments.
You can use NCache from any .NET application including ASP.NET, WCF and web services, Grid Computing applications, and any other server-type applications with high transactions. So, whether you're making client-side API calls to NCache or developing server-side code for Read-through/Write-through, rest assured that you will always be in native .NET environment.
NCache provides support for the following:
  • ASP.NET Session State Storage for web farms
  • ASP.NET Content Acceleration: This includes caching View State and Minify and Merge of JavaScript.
  • ADO.NET Entity Framework 4.0 Cache
  • NHibernate second level Cache
  • EntLib Caching Block Provider
  • .NET 4.0 Cache Provider
Please visit our website for more detail on Support for .NET .
See Also
Support for Java & JSP


Topic: NHibernate

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

NHibernate

This section explains what is NHibernate and the ways to configure and use NCache as NHibernate Second Level Cache.
In This Section
Overview
Explains NHibernate and the features of NCache as NHibernate's second level cache provider .
Using NCache as NHibernate Second Level Cache
Explains how to configure and use NCache as NHibernate Second Level Cache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

NHibernate is an open source Object-Relational Mapping solution which provides a framework for mapping relational database on object oriented representation of data. This reduces significant developer's efforts for retrieving data from database. Furthermore to improve applications performance and reduce load on database, NHibernate provides feature of caching to reduce repetitive database calls.
NHibernate First Level Cache
NHibernate First level caching module provides session level in process caching. Whenever a session is created, a session cache is associated with it. When an object is loaded from the database, a copy of object is maintained in the session cache. If the object is to be fetched again in the same session, cached copy of object is returned. In a particular transaction, if the same object is updated multiple times, it is only updated in session cache. At committing transaction, only the final state of object is persisted in database, thus avoiding repetitive update calls.
NCache as NHibernate Second Level Cache
NCache provides NHibernate second level cache provider. NCache provider can be configured as NHibernate second level cache without any code change. Using NCache as second level cache for NHibernate enable application to use NCache's distributed caching features.
NCache provides the following features with second level cache provider:
  • Specify Multiple Regions: Multiple NHibernate regions can be specified and configured in NCache configuration file for NHibernate. These regions are identified using region names and can be configured with multiple NCache features.
  • NCache Cache for Region: NCache allows to specify NCache cache instance for each region separately. Each region can be configured on separate NCache cache instance or one instance can also be used for multiple regions.
  • Cache Item Priority: Data in each region can be configured to have a priority in cache. This priority is then used for data eviction policies.
  • Absolute Expiration: NCache's configurable absolute expiration feature keeps data in cache up to date by expiring old data after configured time interval.
  • Sliding Expiration: Cache region can also be configured to have an absolute expirations for items in cache. Using sliding expiration data not used since the configured interval will be removed automatically by NCache.
  • Configure Multiple Regions even on a Single NCache Cache Instance: NCache provider for NHibernate allows using single NCache instance for multiple NHibernate cache instances. NCache keeps the record of data and its associated NHibernate region.
  • Database Dependencies: To ensure data consistency with database, NCache provides database dependency feature for NHibernate applications that can be configured on entity bases. Database dependency synchronizes cache data with the database such that any change in database record invalidates respective entity in cache. Thus NHibernate retrieves up to date record even if database is updated by an application other than NHibernate application.
  • Query Caching Feature to Cache Large Queries' Results: Complex and large queries if executed repeatedly with no result changed can put a huge load on database. To avoid multiple times execution of such queries NCache allows to cache such queries using NHibernate's query cache feature. So that such query and its results executed for one NHibernate application become available to all NHibernate applications using that database without querying the database.
  • No Code Change Required: NCache allows using all features through configuration files with no code change required.
See Also
Using NCache as NHibernate Second Level Cache | Entity Framework Caching Integration | Memcached | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features


Topic: java.lang.NoClassDefFoundError

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

java.lang.NoClassDefFoundError

The "java.lang.NoClassDefFoundError : com/alachisoft/ncache/licensing/LicenseManager" occurs when the required jar files are not available at their appropriate location. NCache Client API for Java is shipped with the following jar files:
  • NCClient.jar: The Main NCache Client API file.
  • NCActivate.jar: The file is responsible for the Activation of NCache. The user may extend his/her evaluation period by running this file. This file can be run by executing the "activate.bat" file.
  • installer.jar: This file is only for Unix environment and is responsible for NCache client installation on Unix machines.
  • NCRuntime.jar: The file is responsible for Read-through/Write-through caching and Cache Startup operations.
  • NCSerialization.jar: This file is responsible for dynamic compact serialization and object sharing operations.
  • NCacheSessionProvider.jar: This file is responsible for providing JSP session caching support.
  • NCUtil.jar: This file contains the methods required by NCache Manager and Service.
  • swing-layout-1.0.4.jar: This file is providing Java library for GUI.
  • javassist.jar: This file is the 3rd party library responsible for runtime code generation.
Workaround
Copy all three jar files at the same location and mention location in class-path.


Topic: No server available to process request

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

No server available to process request

You may get this exception if the cache you are trying to connect is not running or the cache does not exist on the target machine.
Workaround
To workaround this problem, do the following:
  • See if the Servers specified in the client.ncconf are stopped. If so, then start them using NCache Manager. See Start a Server Node for further details .
  • Another situation can be that NCache Server is running but the cache that you are trying to use is not running. See Start a Cluster for more information.
  • Verify that you are using correct version of NCache Client API. Note that the Developer Edition does not allow you to connect to the remote NCache Server; however you can connect to NCache Server running on the same machine, using "localhost" as the server name in the client configuration file. Enterprise Edition does not have any such restriction. You can check NCache Edition from Help->About menu option in NCache Manager.
  • NCache Client API also throws this exception if it does not find the client.ncconf file or if there is any error reading NCache Server information from it.
  • And same error occurs if user tries to initialize a cache which does not exist or that cache is not listed in the "client.ncconf".
See Also
Start the Cluster | Start NCache Service | Configuring Clients


Topic: Nodes not Joining

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Nodes in a clustered cache are not joining

Some times it may be the case when you start a clustered cache, but nodes do not join with each other. It means that cluster is not formed and cache runs on each node as a standalone cache. You can use listcaches utility to confirm if the cluster is formed properly or not. When listcaches utility is used with '/a' switch, it lists all the nodes that have successfully joined the cluster. You can also use the NCache Manager "View Cluster Connectivity" GUI tool to check the node connectivity. "View Cluster Connectivity" option is available in a cluster properties and also located at NCache Manager tool bar.
Workaround
To resolve this problem:
  • See that every node can be accessed from every other node participating in the clustered cache. For this you can use the 'ping' utility. If nodes are not accessible then there is some network problem and must be resolved before starting the cache.
  • Please see that the cache configuration on each node contains the correct initial hosts list. Every node participating in the clustered cache must be listed there.
  • If the initial hosts list is not correct then update the initial hosts list and restart NCache service on all nodes.
  • Restart the clustered cache.
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Both nodes in a mirror cache appear as active nodes in NCache Manager


Topic: Operation Timeout

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Operation Timeout

Operation Timeout is the maximum time in seconds during which a clustered operation must be completed, otherwise the operation will fail. Default Timeout value is 60 seconds and can not be less than that. To specify Timeout for a Clustered Cache operation, do one of the following two.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Change the Operation timeout (sec.).
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through Config.ncconf:
You can specify the operation timeout through Config.ncconf as follows.
<cluster topology="partition-replica" op-timeout="120sec" stats-repl-interval="60sec" use-heart-beat="False">
</cluster>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Operations

You can Create Clustered Cache, Local Cache, add/remove server node(s), add/remove client node(s), configure basic cache-settings, perform Management Operations (Start a cache, Stop a cache and etc.), configure and view statistics in Visual Studio using NCache Manager for Visual Studio.


Topic: Object Query Language (OQL) in NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Object Query Language (OQL) in NCache

Locking prevents multiple clients from updating the same data simultaneously and also ensures data consistency. A proper locking mechanism is necessary to ensure data consistency when there is a possibility of multiple clients accessing and possibly modifying the same data at the same time. This section the locking feature provided by NCache.
In This Section
Overview
Explains the basic concept of OQL provided by NCache
Object Query Language (OQL) Syntax
Explains the syntax of OQL provided by NCache.
NCache Language Integrated NCache Query (LINQ)
Explains how LINQ can be used in NCache for querying.
Querying Data in NCache
Explains how to query data in NCache using indexing mechanism.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

Most of the applications use cache for storing key-value pair type of data. Every data item can be retrieved through keys like primary keys are used to find data in any relational database. This approach seems good when it is known that which key is associated with what kind of data but in large and complex applications, items can’t be retrieved through keys only. There might be a need to search relative data for any specific attribute value because a lot of live data is stored in the cache. A very basic example can be of e a web e-commerce application where there might be a need for fetching all products related to specific category etc. In such a case, category based keys cannot be specified for all the products and hence keys lists cannot be used for retrieval.
For searching purpose, NCache provides a powerful searching mechanism where cache keys/data can be fetched using SQL like query syntax. NCache provides with NQL (NCache Query Language) which is the subset of SQL. NQL facilitates searching the cache against criteria on which data is required. For the e commerce web application, if all the products related to a particular category are to be retrieved, then a sample query in NQL would be something like follows:
Sample query: "SELECT Product WHERE this.Category = ?"
By specifying a particular category in this query, all product keys and cached items that have the specified category can be searched.
NCache allows searching and deleting result set according to a query criteria. It means that cache can be updated through queries at runtime when needed.
NCache requires all searchable attributes to be indexed before using those indexes. These settings are not hot applicable so they should be defined before cache start. See Indexing in NCache for details on indexing.
See Also
Object Query Language (OQL) Syntax | NCache Language Integrated NCache Query (LINQ) | Querying Data in NCache | Continuous Query | Indexing | Configuring Query Indexes


Topic: Object Query Language (OQL) Syntax

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Object Query Language (OQL) Syntax
This feature is not available in NCache Express and Professional edition.
NCache supports SQL-like language called Object Query Language (OQL). A rich set of operators are provided by NCache according to required query criteria to fetch the desired result set from cache.
OQL is not case sensitive.
The following operator categories are supported in NCache queries:
Category | Operator
<Query> | = , == , != , <> , < , > , <=, >=, IN, LIKE , NOT LIKE
Logical Operators | AND , OR , NOT
Aggregate Functions | Sum, Count, AVG, Min, Max
Miscellaneous | DateTime.Now , DateTime ("any date time compatible string")
Syntax of the language is explained with the help of examples below:
Basic Query Operators
Operator | Description | Example
= OR == | Equals to | "SELECT Product WHERE this.ProductID == ?"
!= OR <> | Not equals to | "SELECT Product WHERE this.ProductID <> ?"
< | Less than | "SELECT Product WHERE this.ProductID < ?"
> | Greater than | "SELECT Product WHERE this.ProductID > ?"
<= | Less than equal to | "SELECT Product WHERE this.ProductID <= ?"
>= | Greater than equal to | "SELECT Product WHERE this.ProductID >= ?"
IN | In a range | "SELECT Product this.UnitsAvailable IN (?,?,?,?))"
LIKE | Pattern like. Mostly used for wild card base searching. Use "*" for one or many occurrence of character. Use "." for single occurrence of character. | "SELECT Product WHERE this.ProductName LIKE ? AND this.Category LIKE ?"
NOT LIKE | Not like pattern | "SELECT Product WHERE this.ProductID NOT LIKE ?"
Logical Query Operators
Operator | Description | Example
AND | Retrieve merged result set for two or more conditions. | "SELECT Product WHERE this.ProductName LIKE ? AND this.Category LIKE ?"
OR | Retrieve result set whichfulfills any one condition. | "SELECT Product WHERE this.ProductName NOT LIKE ? OR this.Category NOT LIKE ?";
NOT | Retrieve result set which doesn't match the given criteria. | "SELECT Product WHERE this.ProductID NOT LIKE ?"
Aggregate Function
Operator | Description | Example
Sum | Calculate sum of result set of specified criteria. | "SELECT SUM(Product.UnitsAvailable) WHERE this.ProductID <= 10"
Count | Calculates count of the result set for a specified criteria. | "SELECT count(Product) WHERE this.ProductID < ?"
Avg | Calculates average of the result set for specified criteria. | "SELECT AVG(Product.UnitsAvailable) WHERE this.ProductID < ?"
Min | Returns minimum of the result set for specified criteria. | "SELECT MIN(Product.UnitsAvailable) WHERE this.Category = ?"
Max | Returns maximum of the result set for specified criteria. | "SELECT MAX(Product.UnitsAvailable) WHERE this.Category = ?
Miscellaneous
Operator | Description | Example
DateTime.Now | Retrieve result set with respect to current date time. | "SELECT Order WHERE this.OrderDate = ?"
DateTime ("any date time compatible string") | Retrieve result set with respect to specified date time. | "SELECT Order WHERE this.OrderDate = ?"
See Also
OQL in NCache Overview | NCache Language Integrated NCache Query (LINQ) | Querying Data in NCache | Continuous Query | Indexing | Configuring Query Indexes


Topic: Using Oracle Dependency

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Oracle Dependency

Oracle Dependency is provided by NCache for synchronizing cache with Oracle database. Item expires if result of the command (based on command text) changes. Oracle Dependency is only available for Oracle database 10g release 2 or later. Also make sure that Oracle Data Providers for .NET (version 10.1.0.2.0 or later) is installed.
i. Configuring Notification on Oracle server
NCache tracks changes in database using notifications received from Oracle server. For this purpose NCache registers Change Notification with oracle server. NCache server should have Change Notification privileges to create notification registration. Grants the Change Notification privilege to the user by following statement.
[SQL]
"grant change notification to scott"
ii. Adding Data with Oracle Dependency
Following code shows how to add data with Oracle Dependency. Altering data after addition with Oracle Dependency will remove it from cache.
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
try
{
//Creating OracleCacheDependency
String connectionString = "User Id=scott;Password=tiger;Data Source=oracle";
string query = "SELECT rowID, productID FROM dbo.Products WHERE productID = 1001";
OracleCacheDependency oracleDependency = new OracleCacheDependency(connectionString, query);
//Adding cache item "Product:1001" with SqlDependency
cache.Insert(key, product, oracleDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
//Modifying Product record in database will automatically remove Product from cache
}
catch (OperationFailedException e)
{
// handle exception
}
In Oracle 10g, database change notifications are only object based. This means that change notifications will be fired if any row is modified in object. Therefore rowID needs to be checked to confirm if the row changed is the one for which the event is registered. RowID's cannot be retrieved unless explicitly included in query. Therefore customer has to include rowID in query that they are registering with OracleDependecy, otherwise change notification will be fired if any row is modified in table.
When rowID is included in query like: "select rowID, productID, productname, unitprice from Products where ProductID = 220"; NCache will save the rowID of rows for which change notification is registered. When it receives any change notification, NCache will compare the rowIDs to determine whether the row changed is the one for which the rowID is registered. Otherwise NCache will have no way to check this and items for which change notification is registered will be removed after any row in table changes.
In Oracle 11g both object based and query based (default) notifications are provided. In query based notifications; change of the modified row will be notified only if the change notification is registered for it.
See Also
Cache Dependencies Overview | Using SQL Dependency | Using Polling Based Dependency | Using CLR Procedures to Call NCache | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

NCache supports both synchronous and asynchronous (async) development. There are situations when the user would like to perform some operations in the background, while working on more critical operations. Suppose that an application updates a batch of keys to cache. It also needs to carry other operations such as receiving data from cache. Here the actual need of asynchronous operations is evolved.
Need of Asynchronous Operations: These operations are used when an application has important tasks to execute right away instead of blocking updates that are not important. As asynchronous operations cause delayed updates, these delays are expected.
Performance Improvement: It increases the performance of application in term of faster response time and enhances the overall responsiveness. This means that an application regains control while performing long-running tasks in background.
NCache provides asynchronous counterpart for almost every synchronous operations. As asynchronous operations do not notify upon the failure or success of the operations themselves, so NCache provides a Callback feature for asynchronous operations.
Callback Method: NCache provides optional Callback Methods for asynchronous operations. Callbacks are responsible for providing acknowledgment to application about the operations status.
Working of Asynchronous Operations
When an application issues request for adding/updating data to the cache or removing it from cache with asynchronous API call, NCache uses a thread pool on the server side to facilitate these operations. Whereas in case of any callback registered with asynchronous operations, NCache triggers appropriate events only for interested clients upon operation completion.
See Also
Using Asynchronous Operations | Bulk Operations | Server Side API Programming


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

In IT industry, one has to deal with large scale applications which should be live for 24/7. Proper management of your application and millions of customers with high risk of internal or external failure is important. For critical applications, the disaster risk of any kind can’t be ignored and its recovery plans must be considered very carefully. Disaster can be of any type like natural disasters or internal hardware or software failure.
For large scale applications, distributed caches are used to improve their performance, reliability and runtime scalability. So distributed caches can be a very important part of disaster recovery plan. The best and most frequently used disaster recovery plan is live data replication to other backup site. So that when needed, the live users can be redirected to backup site without any error. For that purpose, the active and backup caches should always be in synchronized states. If they are not synchronized, then it can affect the application's cache clients.
Data replication also solves the problem if along with disaster recovery plans the application needs to be deployed on geographically separated regions for widely spread customers. In such a case, there will be two or more active sites which will deal with users of related regions and can also be used as backup of other region sites.
Data replication can be done in two ways, synchronously and asynchronously. But for WAN replication, asynchronous replication is mostly preferred.
NCache provides WAN replication through Bridge feature. A bridge is created between two cluster caches and data is replicated from source to other site through that bridge.
Pluggable Caching Architecture: Caches are not aware of each other they just know about bridge and replicate their data to bridge. Due to this loose coupling, the bridge can be configured between any two caches irrespective of their cache topology. Also caches configured with bridge can be freely removed.
Data Integrity: Operations performed at source cache are en-queued by the bridge maintaining the actual order in which they were performed at source cache. Bridge performs operations on target cache in the same order. Conflicts are resolved on target cache. In this way, caches becomes eventually consistent.
Dedicated Bridge Service: Bridge is also a stand-alone and dedicated service like cache service so cache operations will not be affected if any bridge operation is delayed due to latency in network.
Configuring Bridge: The bridge can be configured either on the same server where the cluster cache resides or on a separate server node. When both cluster caches are added into bridge, data is replicated between them.
Disaster Recovery: Bridge can be configured between an active and passive data center for disaster recovery.
Dealing Geographically Spread Customer: There can be two active sites which will deal with users of related regions and can also be used as backup of other region sites.
Asynchronous Replication: For WAN replication, asynchronous replication is used so that cache operations will not suffer in case of delays in bridge operations.
Queue Backup: Bridge is basically a two node clustered queue in which one node is active and the other is passive having backup of active queue to avoid data loss on bridge.
Connection Retries: Bridge also tries to replicate all operations by retrying when any connection failure occurs.
Configurable Queue Size: Bridge and target replicator queue size is configurable. The size of bridge queue can be configured by analyzing the cache load because every update will be replicated to bridge queue and if its size is small, then queue will become full resulting in data loss.
Bridge caches : Any topology can be used for cluster caches that will be part of the bridge. Even two different topology caches on each site in one bridge can exist too. The convention, however, is to use the same topology on both sites.
It is recommended that bridge caches have same configurations other than topology to avoid issues. For example if data source is configured on one cache you should configure it on other cache too. Because same operation specifications from one site cache will be replicated to other site.
See Also
Bridge Configurations | Bridge Conflict Resolver | Configuring Bridge for WAN Replication | Creating Caches | Configuring Cache Cluster Settings | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Partitioned Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Partitioned Cache

Multiple Server Nodes: This topology has two or more servers. When any cache item is added in the cache it is saved
only to the relevant server node which means that every server node has a unique set of data.
Data Distribution: Data is distributed/partitioned among all server nodes on the basis of the hash code of cache key. A hash based distribution map is generated which is then distributed to all server nodes.
Clients Connections: Cache clients establish connections with every server node of the cluster. Data distribution maps are also shared with cache clients and cache clients are aware of the actual data distribution. When a cache client wants to send a request to cache servers, it first determines to which server node that key belongs to and sends the request accordingly on the basis of the distribution map.
One Hop Reads and Writes: Based on the distribution map, cache client adds/fetches cached item to/from the exact server node. In this manner cache reads and writes both become one hop operation and there are no delays.
No Backups/Fault Tolerance: When any server node leaves the cluster, then data residing on that node is lost because there is no replica for any node. That's why there is no fault tolerance in terms of cached data.
Runtime Scalability: Server nodes can be added or removed at runtime whenever needed.
High Performance: Scaling the cache will not affect the performance of cluster cache for both reference and transactional data because read/write is one hop operation in this topology. It will result in high performance in reads/writes without affecting the performance of cluster cache.
Storage Scalability: When more nodes are added in partitioned cache, storage capacity is increased because each partition in the cluster has a unique set of data.
Reliability: This topology is not fault tolerant because there is no backup of data and if any server node goes down, then data belonging to that partition is permanently lost.
State Transfer: When a node joins the cache cluster in Partitioned topology, existing nodes sacrifice a portion of their data, according to hash based distribution, for the newly joined node. Newly joined node transfers its data share from existing nodes which results in an even distribution of the cached data among all cluster nodes. State transfer occurs in background. Therefore during state transfer, user cache operation does not suffer.
See Also
Mirror Cache | Replicated Cache | Partitioned-Replica Cache


Topic: Partitioned-Replica Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Partitioned-Replica Cache

Multiple Server Nodes: This topology has two or more servers. When any cache item is added in the cache it is saved
only to the relevant server node which means that every server node has a unique set of data.
Data Distribution: Data is distributed/partitioned among all server nodes on the basis of the hash code of cache key. A hash base distribution map is generated which is then distributed to every server node.
Fault Tolerance: It provides fault tolerance up to one node replica. Each server node in the cluster has one active partition and its passive/mirror replica on the other node. Thus when one node is down data can be restored from its replica.
Double Memory Consumption: Each server node consumes double memory than the configured size because that node contains one active partition and one replica. Both active and replica has the same size as configured for cache.
Clients Connections: Cache clients are connected to all server nodes in this topology. Data distribution maps are also shared with cache clients and cache clients are aware of the actual data distribution. Operations are directly sent to the node containing data with the help of distribution map on the basis of cache key.
Runtime Scalability: Server nodes can be added or removed at runtime when ever needed.
Storage Scalability: When more nodes are added in partitioned-replica cache, storage capacity is increased because each partition in the cluster has a unique set of data.
High Performance: Scaling the cache will not affect the performance of cluster cache for both reference and transactional data because read/write is one hop operation in this topology. It will give high performance in reads/writes without affecting the performance of cluster cache. Addition of new nodes to the cache cluster results in load distribution of existing members resulting in more throughput.
State Transfer: When a node joins the cache cluster in partitioned-replica topology, existing nodes sacrifice a portion of their data, according to hash based distribution, for the newly joined node. Newly joined node gets its data share transfered from existing nodes which results in an even distribution of the cached data among all cluster nodes. Similarly when a node leaves the cache cluster, data from its backup node is distributed among existing partitions. State transfer also occur between active and passive nodes. State transfer occurs in background. Therefore during state transfer, user cache operation does not suffer.
Replication strategy/modes: Following are the data replication modes provided in this topology.
  • Synchronous Replication
Cache clients have to wait for replication to the backup partition as part of the cache operation. Due to synchronous replication it can be assured that if cache client request is executed successfully, then data is already stored to the backup node.
  • Asynchronous Replication
Cache clients request returns immediately after operation is performed on active partition node. Operations are replicated asynchronously to the replica node. If any node goes down disgracefully, then operations that remain in the replicator queue could be lost.
See Also
Mirror Cache | Replicated Cache | Partitioned Cache


Topic: Making Passive Cache as Active Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Making Passive Cache as Active Cache

NCache Manager provides the facility to convert a passive cache in a bridge to an active cache using the following steps:
Using NCache Manager
  • Right click on the passive cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Make Active option in the right click context menu.
See Also
Making Active Cache as Passive Cache | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring NCache


Topic: No READ Access to Perflib Subkeys

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

No READ Access to Perflib Subkeys

After the Performance Monitor (PerfMon) account connects to the Registry of the monitored computer, the account on the monitored computer needs READ access to the subkeys that PerfMon uses. The computer uses the ACL for the Perflib/LanguageID subkey to determine who has access to PerfMon data in the Registry, where LanguageID is the numeric code for the spoken language installed with Windows NT. The Perflib/LanguageID subkey is located in the following Registry path:
HKEY_LOCAL_MACHINE/Software/Microsoft/Windows NT /CurrentVersion/Perflib
By default, EVERYONE, LOCAL SERVICE group has READ access to the Perflib key. You need to give full control to these accounts on Perflib key.
Workaround
Here is how you can enable permissions on CurrentVersion/Perflib key:
  • On the computer to be monitored, start regedit.
  • Right-click Perflib and go to permissions.
  • Give full control to Local Service and Everyone users. You may have to add these users if they are not already in the list.
  • Go to Control Panel -> Services and restart 'Remote Registry' service.
Now you'll be able to monitor this machine remotely.
See Also
Diskperf Not Installed | Troubleshooting Counters | Unable to Connect to Server Node


Topic: Performance Counters Logging

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Performance Counters Logging

Using Report-View you can instantly monitor performance but you can also log these counters in a csv file. All the counter values which are currently in dashboard will be logged into a .CSV file after each second. You can start the performance counters logging instantly or you can schedule the logging on a specific time.
Manual Logging
Follow the below given steps to log the counters using NCache Monitor:
  • Go to the Report-View Dashboard (built-in Report-View dashboard or your created dashboard).
  • Click on the Start Logging button icon exist on the report view control. This starts the logging.
  • Log file can be found under %NCHOME%/log-files/NCacheMonitor
  • You can stop the performance counter logging on clicking on the Stop Logging icon in the Report-View Dashboard.
Schedule Logging
Rather than manually starting and stopping logging you can also schedule logging. This way you can obtain logging data for a particular period of time.
  • Click on the Schedule Logging icon in Report-View dashboard.
  • Schedule Logging dialog box appears. Check the Log counters at the following schedule check box and configure the Start Time and Stop Time.
  • Click OK. Logging will start at the specified time automatically. Schedule logging only works if NCache Monitor is started during specified schedule time.
See Also
Monitoring Caches using NCache Monitor | NCache Monitor Logging | Windows Event Logging


Topic: Using Polling Based Dependency

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Polling Based Dependency

Polling based dependency enables you to keep the cache items synchronized with any of the database. SQL and Oracle dependencies explained earlier need SQL/Oracle databases to notify NCache about any change in the database, however if database does not provides Change Notifications feature, NCache provides the facility to synchronize cache with database using polling based dependency.
i. How to Prepare Database for Polling Dependency
Since polling based dependency works as NCache polls database for changes, database has to be configured to keep record of changes in database. This includes creating a table named "ncache_db_sync" and creating a trigger to update this table according to changes in database.
Follow these steps to configure database:
  • Create a table 'ncache_db_sync' having four fields (cache_key VARCHAR, cache_id VARCHAR, modified BIT and work_in_progress BIT). Script to create the table is as follows:
//Create table'ncache_db_sync'
CREATE TABLE ncache_db_sync(
cache_key VARCHAR(256),
cache_id VARCHAR(256),
modified BIT DEFAULT(0),
work_in_progress BIT DEFAULT(0),
PRIMARY KEY(cache_key, cache_id) );
  • Create UPDATE and DELETE triggers, for every table on which notification is required. They set the 'modified' field of corresponding row in the ncache_db_sync table to 1.To carry out the task, see the following sample script that creates trigger on 'Products' table:
//create trigger
CREATE TRIGGER myTrigger
ON dbo.Products
FOR DELETE, UPDATE
AS
UPDATE ncdbs
SET modified = 1
fromncache_db_syncncdbs
inner join Deleted old on cache_key = (Cast((old.ProductID) as VarChar)
+ ':dbo.Products' );
The syntax of SQL scripts specified here are for SQL server database. Change the syntax according to the database.
Now as soon as an item is added to the cache with dependency, a row will be created in table 'ncache_db_sync' for this cache key. The format of cache key while adding into cache should exactly be the exactly same as defined in the corresponding trigger, e.g., for trigger explained above, cache key for product id 10 should be, "10:dbo.Products".
ii. Adding Data with Polling Based Dependency
The following code shows the use of polling based dependency with SQL server database, where database has been already configured to use polling based dependency.
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
try
{
//Creating Polling based dependency
string connectionString = "Provider=SQLOLEDB;Data Source=localhost;Database=northwind;User Id=sa;Password=;";
DBCacheDependency oledbDependency = DBDependencyFactory.CreateOleDbCacheDependency(connectionString, product.ProductID + ":dbo.Products");
//cache key for product id 1 will be "1:dbo.Products"
cache.Insert(product.ProductID + ":dbo.Products", product, oledbDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, Alachisoft.NCache.Runtime.CacheItemPriority.Default);
}
catch (OperationFailedException e)
{
// handle exception
}
//Modifying Product record in database will automatically remove Product from cache
See Also
Cache Dependencies Overview | Using SQL Dependency | Using Oracle Dependency | Using CLR Procedures to Call NCache | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency


Topic: Port Range

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Port Range

Sets the port range for each node in the cluster. If the current port is unavailable, then the server will automatically pick the next available port in the pool. Port Range of a cluster can be changed in the following two ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Set the Port Range as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
The value of port range can also be set using config.ncconf as follows;
<cluster-connection-settings cluster-port="8706" port-range="2"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Cluster Port | Server Port


Topic: Portable Data Types (.NET & Java)

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Portable Data Types (.NET & Java)

To share data among heterogeneous applications, most messaging solutions require building application based on message text which is self-descriptive. It becomes the responsibility of the application to use a format for the data so that it can be decoded by the receiving application coding. If XML data format is used, it encounters performance problems.
In addition, a highly concurrent application environment with several publishers has a greater chance of race conditions causing problems with data integrity. Messaging systems have no inherent relationship between process control messages or messages to multiple destinations messaging (queues or topics) capabilities.
Most messaging solutions are actually designed to support multiple protocols, flexibility in terms of message reliability, and more. But when it comes to opposing applications like .NET wishing to share data with Java, heavy heads or interpretation of payloads based message encoding / decoding / text message delivery settings, message correlation, research data bases related background information can be build before acting.
NCache provides with the feature of data types portability for heterogeneous applications through cache, with binary protocol which boost the performance by reducing traffic and data size with help of compact serialization. To explain this feature, let’s take example of product entity having attributes as ID, name, quantity, category etc.
The Data type portability feature will allow .NET client applications to fetch objects of product class from cache which is inserted by Java client applications and will successfully deserialize to .NET product class and vice versa. The only thing to do is to configure both product classes as shared types from administrative tools of NCache and map one or more attributes of class to other which we want to be shared across platform, non-mapped attributes will contain default value while receiving on other side.
The underlying architecture of this feature use compact serialization framework which create dynamic serialization code for product class on both side. Query Indexes are also shared among shared data types if added in query index list.
Class Attributes Mapping
Product Class (C#) | Product Class (Java)
ID | _ID
name | _name
price | _price
quantity |
 | _category
In above mentioned table attributes of class has been mapped with each other, quantity and category has no mapping attribute in target class so they are left unmapped.
Query Indexes are also shared among shared data types if added in query index list.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction | Runtime Data Sharing | Class Versioning


Topic: Ports

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Ports

NCache uses TCP ports for communication. Default TCP port is 8250. These ports can be changed, if required, by changing the values of the registry key (TCP.PORT) written upon the installation of NCache.
This key can be found under the following path:
HKEY_LOCAL_MACHINE/SOFTWARE/ALACHISOFT/NCACHE
Please note that NCache Manager application assumes the default port. Therefore, upon changing the values of this port, LocalCache/Cluster can not be administered through NCache Manager application. However, NCache command line utilities and tools provide the option to address the LocalCaches/Clusters on other ports
In This Section
Cluster Port
Explains cluster port and how to change its value.
Port Range
Explains how to change the range of cluster port.
Server Port
Describes server port and ways to customize it.


Topic: Programmer's Guide

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Programmer's Guide

This section provides a practical guide for programmers who want to use various features of NCache in .NET to develop high performance and scalable applications. It provides four different sets of features for programming with NCache. In order to use NCache API in .NET applications, following things are required to be done:
  • For .NET applications, you must add reference to the 'Alachisoft.NCache.Web.Caching.dll' in your application. This assembly contains all the APIs which are required to connect to the server and use cache. This assembly is copied into the install directory of NCache, by default it is in "%INSTALL_DIR%/NCache/bin/assembly/
  • Client API also requires the server list generated from NCache Manager. For this purpose, client configuration file must be placed in NCache install directory. The Client Configuration file is updated whenever you apply configurations to the cache. Information for compact data types is also generated as part of ( config.ncconf ), if the cache is registered with any Compact Serializable data type.
In This Section
Client Side API Programming
Provides a practical guide for client side features.
Server Side API Programming
Provides a practical guide for server side features.
Client Side ASP.NET Features
Demonstrates the use and capabilities of client side ASP.NET features.
Client Side Third Party Integrations
Demonstrates the use and capabilities of client side Third Party Integration tools.


Topic: Querying Data in NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Querying Data in NCache

NCache provides the ability to query the indexed cache data. NCache provides its own indexing mechanism. Indexing for searchable objects and their attributes need to be configured first as explained in earlier sections.
Using API for Querying
The following API is available for using NCache query feature:
public ICollection Search(string query, IDictionary searchValues)
public IDictionary SearchEntries(string query, IDictionary searchValues)
public ICacheReader ExecuteReader(string query, IDictionary searchValues)
Methods
Name | Return Type | Description
Search | ICollection | Only return list of keys in result set which fulfill the query criteria.
SearchEntries | IDictionary | Return list of key-value pairs in result set which fulfill the query criteria. This key value pair have cache key and their respective value.
ExecuteReader | ICacheReader | Return result set for GROUP BY clause in the form of columns which fulfill the query criteria. NOTE: ExecuteReader is only used with 'GROUP BY' clause and with aggregate queries.
Parameters
Name | Type | Description
Query | String | Query string but instead of values '?' will be specified by user, e.g., "SELECT Product WHERE this.ProductID == ?"
searchValues | IDictionary | Key-value pairs of attribute-names and their values on which your search criteria is based on. Hashtable searchValues = new Hashtable(); searchValues.Add("ProductID", 1);
Adding and Updating Indexed Items
Before searching, items need to be indexed and added in cache. For adding indexed items, the basic APIs of add and insert as mentioned in NCache Basic Operations should be used.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, product);
}
catch (OperationFailedException ex)
{
// handle exception
}
Cache Search Returning Keys
The following code searches the cache and returns a collection of keys. Then, it iterates over all the returned keys and individually fetches the corresponding cached items from the cache.
Hashtable values = new Hashtable();
values.Add("ProductName", "Chai");
values.Add("UnitsInStock", 250);
try
{
// Instead of Product, specify fully qualified name of your custom class.
string query = "SELECT Product where this.ProductName = ?";
ICollection result = cache.Search(query, values);
query = "SELECT Product WHERE this.UnitsInStock > ?";
result = cache.Search(query, values);
query = "SELECT Product WHERE this.ProductName = ? and this.UnitsInStock > ?";
result = cache.Search(query, values);
query = "SELECT Product WHERE Not(this.ProductName = ? and this.UnitsInStock > ?)";
result = cache.Search(query, values);
}
catch (OperationFailedException ex)
{
// handle exception
}
The benefit of this approach is that the query returns keys only. Then, the client application can determine which key it wants to fetch. The drawback of this approach is increased number of trips to cache as most of the items are fetched from cache anyway. And, if the cache is distributed, this may eventually become costly.
Cache Search Returning Items
In some situations when the intention is to fetch all or most of the cached items associated with cache keys, it is better to fetch all the keys and items in one call. Below is an example of such a scenario. It searches the cache and returns a dictionary containing both keys and values. This way, all the data based on the search criteria is fetched in one call to NCache. This is much more efficient way of fetching all the data from the cache. Example is mentioned below.
string queryString = " SELECT Product where this.ProductID = ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 1001);
IDictionary items;
try
{
//Call SearchEntries for fetching result set in key value pairs.
items = cache.SearchEntries(queryString, values);
}
catch (OperationFailedException ex)
{
// handle exception
}
if (items.Count > 0)
{
IDictionaryEnumerator ide = items.GetEnumerator();
while (ide.MoveNext())
{
String key = (String)ide.Key;
Product product = (Product)ide.Value;
// use cache keys and values in your application code here.
}
}
Cache Search with Execute Reader (Group by)
For grouping the result set of aggregate functions on the basis of one or more columns, GROUP BY clause is used in queries. For executing queries with GROUP BY in NCache, ExecuteReader() function is used. It returns result set in tabular form in ICacheReader type of instance. Result of GROUP BY query is not sorted. Columns count and attribute values can be fetched through their names from ICacheReader. Example is as follows:
string queryString = "SELECT this.Category MAX(Product.ProductID) GROUP BY this.Category where this.Category = ?";
Hashtable values = new Hashtable();
values.Add("Category", 4);
ICacheReader result = cache.ExecuteReader(queryString, values);
if (result.ColumnCount > 0)
{
while (result.Read())
{
String category = (String)result.GetValue("Category");
//use other values in your code if needed.
}
}
Here is the complete code sample which uses all search APIs:
try
{
string queryString = "SELECT Product where this.ProductID = ?";
//Query for GROUP BY
string queryString2 = "SELECT this.Category,this.Supplier COUNT(Product.ProductID) GROUP BY this.Category,this.Supplier where this.Category = ?";
Hashtable values = new Hashtable();
values.Add("ProductID",1001);
values.Add("Category", 4);
//Call Search for fetching result set related keys only.
ICollection keys = cache.Search(queryString, values);
//Call SearchEntries for fetching result set in key value pairs.
IDictionary items = cache.SearchEntries(queryString, values);
// Call ExecuteReader for fetching result columns of any query with GROUP BY
ICacheReader result = cache.ExecuteReader(queryString2, values);
if (items.Count > 0)
{
IDictionaryEnumerator ide = items.GetEnumerator();
while (ide.MoveNext())
{
String key = (String)ide.Key;
Product product = (Product)ide.Value;
// use cache keys and values in your application code here.
}
}
}
catch (Exception ex)
{
// can be operation failed due to server lost, state transfer or invalid query format.
//Index not defined exception when attributes are not indexed.
//...
}
Querying Samples for Operators
Some code samples for different queries are given below:
Using Equal Operator
string queryString = "SELECT Product where this.ProductID = ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 1001);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using Multiple Operators
string queryString = "SELECT Product where this.ProductID < ? AND this.Category = ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 1001);
values.Add("Category", 4);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using IN Operator
string queryString = "SELECT Product where this.ProductID IN (?,?,?)";
ArrayList idList = new ArrayList();
idList.Add(10);
idList.Add(4);
idList.Add(7);
Hashtable values = new Hashtable();
values.Add("ProductID", idList);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using LIKE Operator
string queryString = "SELECT Product where this.ProductName LIKE ?";
ArrayList list = new ArrayList();
list.Add("Ch*");
Hashtable values = new Hashtable();
values.Add("ProductName", list);
try
{
ICollection keys = cache.Search(queryString, values);
IDictionary items = cache.SearchEntries(queryString, values);
}
catch(Exception ex)
{
// handle exception
}
Using GROUP BY Clause
For using 'GROUP BY' clause, any aggregate function should be used in query and to get thequery result, ExecuteReader function should be used. GROUP BY clause cannot be used without aggregate function.
string queryString = "SELECT this.Category, COUNT(Product) WHERE this.ProductID > ? GROUP BY this.Category";
Hashtable values = new Hashtable();
values.Add("ProductID", 5);
try
{
ICacheReader reader = cache.ExecuteReader(queryString, values);
while (reader.Read())
{
string category = (string)reader.GetValue(0);
decimal countVal = (decimal)reader.GetValue(1);
}
}
catch(Exception ex)
{
// handle exception
}
Using DELETE Statement
For the delete statement, ExecuteNonQuery function should be used.
string queryString = "DELETE Product WHERE this.ProductID > ?";
Hashtable values = new Hashtable();
values.Add("ProductID", 5);
try
{
int result = cache.ExecuteNonQuery(queryString, values);
//return number of effected rows.
}
catch(Exception ex)
{
// handle exception
}
See Also
OQL in NCache Overview | Object Query Language (OQL) Syntax | NCache Language Integrated NCache Query (LINQ) | Continuous Query | Indexing | Configuring Query Indexes


Topic: Enable the Queue Optimization

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Enable the Queue Optimization

NCache provides the optimized queue to eliminate the redundant operation replication to the bridge and other caches. It can be enabled as follows:
Using NCache Manager
  • Click on the bridge name in Cache Explorer to open bridge settings.
  • Go to the Main tab.
  • Check the Enable Queue Optimization check box on this tab.
  • Right click on the bridge name in Cache Explorer and select Apply Configuration option.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Configuring Conflict Resolver | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Remove a Cache from Bridge | Bridge Management | Configuring Caches


Topic: Quickly use Cache API in .NET

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Quickly use Cache API in .NET

In this section, you will learn to utilize NCache API designed to provide a super rich set of caching features that facilitate you to store/retrieve data for faster access.
In This Section
Initialize Cache
Describes initializing a cache to start working with it.
Adding Items
Explains adding items to the cache.
Finding items
Explains using Cache API to find items from the cache.
Removing Items
Gives procedure to remove items from the cache.
Deleting Items
Gives procedure to delete items from the cache.
Dispose Cache
Illustrates procedure of disposing cache once you are done using it.
Start Cache
Describes starting cache from your application through API.
Stop Cache
Instructs you about stopping cache using Cache API.


Topic: Use Dynamic Compact Serialization

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Quick Start with Compact Serialization
This feature is not available in NCache Express and Professional edition.
This quick start allows you to get start with NCache using Compact Serializable Objects.
Step 1: Register your Compact types with NCache
Step 2: Run your Application


Topic: Quick Start Guide for .NET

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Quick Start Guide for .NET

In this section, you will see quick start guides to use NCache.
In This Section
Store ASP.NET 1.1 Sessions
Gives quick steps to use Session State Module.
Store ASP.NET 2.0+ Sessions
Presents a step by step guide to use Session State Store Provider.
Use as ASP.NET Output Cache
Lets you start quickly with Output Caching.
Use as NHibernate Second Level Cache
Instructions to setup NCache to work seamlessly with NHibernate.
Use Dynamic Compact Serialization
Lets you get start with Compact Serialization.


Topic: Use as NHibernate Second Level Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Quick Start with NHibernate

NCache provides a second level or process level distributed cache for NHibernate by implementing ICacheProvider and ICache interfaces. You can plug-in NCache to your existing NHibernate application without any code change. Just change your NHibernate configuration file to plug-in NCache as your cache provider and you're all set to start using distributed caching.
This section allows you to get start with NHibernate.
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application


Topic: Use as ASP.NET Output Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Quick Start with Output Caching
This feature is not available in NCache Express and Professional edition.
NCache provides extremely fast and reliable output caching feature for ASP.NET applications running in web farm environment, where regular output caching fails. Once a page is rendered by any of the web server in the web farm, it is available to the all other servers due to cluster cache created by NCache. Your cached pages are highly available because clustered cache allows no single point of failure. The steps below are to ensure that you quickly start using Output Caching.
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application


Topic: Store ASP .NET 1.1 Sessions

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Quick Start with Session State HTTP Module

NCache Session State Module allows you to transparently save and retrieve ASP.NET session-state objects within a web farm. As compared to ASP.NET Session State Module which is centralized in nature, NCache Session State Module is truly distributed. It benefits from clustered caching and thus, implicitly avoids single point of failure. Also, when running cache as InProc, no extra cost is involved in retrieving session-state objects. The steps below ensure that you easily start using clustered session HTTP Module in your ASP.NET applications.
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application


Topic: Store ASP .NET 2.0+ Sessions

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Session State Store Provider

NCache Session State Provider is a custom SessionStateStoreProviderBase implementation for an ASP.NET application. This implementation reads and writes ASP.NET session data from and to the cache. This allows you to transparently save and retrieve ASP.NET session-state objects within a webfarm NCache also provides the Session State Module which can be used for applications that are intended to run on older .NET frameworks like 1.1.
The steps below are to ensure that you quickly start using Custom Session Store Provider with ease.
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET App


Topic: Read-Through Caching

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Read-Through Caching

Read-through caching facilitates in case client application wants to acquire an item from cache, which is not currently present in cache store, instead it is present in master data source only. In such a case if read-through is enabled, item will be transparently fetched from data source and stored in cache to fulfill future requests.
For read-through, IReadThruProvider interface needs to be implemented NCache framework uses this custom read-through provider to communicate with backend data source. In this case, custom logic needs to be implemented to load data from configured data source. NCache will call your provider to load data from data source behind Get call in case of cache miss.
NCache provides a performance counter for read-through operations per sec.
In clustered caches, where multiple servers are involved, read-through provider will be active (initialized) on all cache server nodes but read through operation will be performed by the node which receive Get operation according to topology.
See Also
Data Source Providers Overview | Write-Through Caching | Configuring Read-Through Provider | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Read-Through Provider

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Read-Through Provider

A requested value not present in the cache can be automatically obtained from the main data source by the cache and provided to the user in such a manner that it seems to the caller that it came from the cache. This is known as Read Through Cache. The gain from it is that the application can depend on the cache for both cached data as well as for transparent data loading instead of adding data loading logic at the point where it requires the data. Read-through caching can be configured using the following methods.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Baking Source tab.
  • Check Enable Read-Through on this cache check box to enable it. After enabling it, other options will get enabled as well.
  • Cllick Add to select assembly that has IReadThruProvider implementation.
  • A new dialog box Add New Provider will open. Enter Provider Name and click on ‘…’ button to browse for assembly implementing IReadThruProvider interface.
  • Browse for the required assembly and select Open. Name of selected assembly will be appeared in Assembly Name and its classes implementing the interface will be listed down in Class Name list box.
  • Select the required read-through provider. You can also provide the values to your read-through provider class, if required. Just write the parameter name in Parameter field and its value against it under the Value field. Click OK.
  • Selected provider class will be listed in Read-Through provider list at Backing Source tab.
  • Now deploy the read-through provider assembly along with its dependency assemblies, if any. Click on the Deploy Provider button at the left bottom of the Backing Source tab. Browse for required assemblies. Select all the required assemblies and click Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addbackingsource.exe tool, provide the required information as:
addbackingsource.exe demoLocalCache /path C:\Users\Administrator\Downloads\Providers\Providers.dll/cNCache.Sample.Providers.Readers.Reader1 /pnreader1/R
  • Hit ENTER key, it will configure Reader1 read-through provider on demoLocalcache.
  • Now depoly all of the required assemblies (assembly in which you have implemented the read-through provider and all of its dependency assemblies) using deployprovider.exe. Use following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Write-Through Provider | Write-Through Provider for Write-Behind Operations


Topic: Step 2: Register NCache with NHibernate

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 2: Register NCache with NHibernate

To register NCache with NHibernate, edit app.config or web.config as follows:
  1. Register 'nhibernate' configuration sections in the <configSections> of the web.config or app.config as follows:
    <configSections>
<section name="hibernate-configuration" type="NHibernate.Cfg.ConfigurationSectionHandler,
NHibernate"/>
</configSections>
2. Define section details for <nhibernate> as follows:
<hibernate-configuration xmlns = "urn:nhibernate-configuration-2.2">
<bytecode-provider type="lcg"/>
<reflection-optimizer use="true"/>
<session-factory>
<property name="connection.provider"> NHibernate.Connection.DriverConnectionProvider
</property>
<property name="connection.isolation">ReadCommitted</property>
<property name="dialect">NHibernate.Dialect.MsSql2008Dialect</property>
<property name="connection.driver_class">NHibernate.Driver.OleDbDriver</property>
<property name="connection.connection_string">Provider=SQLOLEDB; Data Source=20.200.20.54;
Initial Catalog=Northwind;User ID=sp; Password=4Islamabad</property>
<property name="cache.provider_class">
Alachisoft.NCache.Integrations.NHibernate.Cache.NCacheProvider,
Alachisoft.NCache.Integrations.NHibernate.Cache </property>
<property name="proxyfactory.factory_class">
NHibernate.Bytecode.DefaultProxyFactoryFactory, NHibernate </property>
<property name="cache.use_second_level_cache">true</property>
<property name="cache.use_query_cache" >true</property>
<property name="show_sql">true</property>
</session-factory>
</hibernate-configuration>
3. Add following section in NCacheNHibernate.xml file you can place this file in the config folder of NCache or in bin folder of your application:
<configuration>
<application-config application-id="myapp" enable-cache-exception="true" default-region-name="default"
key-case-sensitivity="false">
<cache-regions>
<region name="AbsoluteExpirationRegion" cache-name="myCache" priority="Default" expiration-type="sliding"
expiration-period="180" />
<region name="default" cache-name="myCache" priority="default" expiration-type="none"
expiration-period="0" />
</cache-regions>
</application-config>
</configuration>
The above example of app.config or web.config contains the following options for you to configure. Each of them is explained below as well.
cache.provider_class: This option lets you specify that NCache is your second level cache provider. You need to mention two classes which implement NHibernate.Cache.ICacheProvider and NHibernate.Cache.ICache interfaces respectively. This is how NHibernate knows how to call this second level cache.
ncache.application_id: This option lets you specify application id of current NHibernate application for NCache. This id will be than used to select configurations for current application from NCacheNhibernate.xml.
NCacheNHibernate.xml contains all the configurations used by NCache provider for NHibernate. NCacheNHibernate.xml contains following configurable options:
application-config:
This section lets you specify configuration for NCache use for a particular application.
Multiple application configurations can be specified in NCacheNHibernate.xml. Any NHibernate application will use one of the specified configuration based on the application-id specified in applications app.config/web.config file.
Following are the configurable options in application-config section.
application-id: This options let you specify the unique id for current application-config. This id is used to select appropriate configuration for a particular application.
enable-cache-exception: Identifies whether the exceptions if occurred in NCache will be propagated to NHibernate provider.
default-region-name: Allows to specify a default region for the application. If a particular region's configurations are not fount default region's configurations will be used. Specified default region's configuration must exist in cache-regions section.
key-case-sensitivity: This option allows to specify whether cache keys will be case sensitive or not. This option has to be configured according to database used. If database is case-sensitive set this option true, otherwise false.
cache-regions:
This sections lets you configure multiple cache regions for NHibernate application. Each region's configuration is specified in region tag.
region:
This tag contains the configurations for one particular region. Following options can be configured for any particular region.
name: Each region is identified by its name. Name of the region should be unique.
cache-name: This option allows to specify NCache's cache name to be used for this region.
priority: The priority you want to use for items cached. The possible values are :
  • Default
  • Low
  • BelowNormal
  • Normal
  • AboveNormal
  • High
  • NotRemovable
expiration-type: This options allows to specify type of expiration for any item in this region. Possible values are absolute/sliding/none.
expiraion-period: Allows to specify expiration period if absolute/sliding expiration is configured. Its value should be greater than 0.
database-dependencies:
This section lets you specify database dependencies for current NHibernate application.
dependency: Each dependency is configured in dependency tag. Multiple tags can be configured for multiple dependencies. Following options can be configured for each dependency.
entity-name: Dependencies are added based on the fully qualified name of classes. This option allows to specify name of class for which current dependency is to be added.
type: Allows to specify database dependency type. Possible values are sql/oracle/oledb.
sql-statement: Allows to specify sql statement to be used for building NCache's database dependency.
cache-key-format: This option is used to configure cache key format for any item of current entity type. Cache key format should include "[pk]" in it, which will be replaced with the primary key of record. cache-key-format may also include "[en]" which will be replaced with entity name. Default value of cache key format is "NHibernateNCache:[en] #[pk]".
composite-key-separator: If the records of current entity have composite key as primary key, cache-key can be formed by combining all keys separated by this composite-key-separator. composite-key-separator must be of one character length. Its default value is "$".
Note:
  • Calling new Configuration() only reads the <nhibernate> section.
  • Calling no-parameter version of cfg.Configure() configures NHibernate from app.config if it contains <nhibernate-configuration>, otherwise hibernate.cfg.xml is used.
See Also
Configure the Cache | Enable DBCacheDependency in NHibernate | Run your NHibernate based Application


Topic: Registering Classes for Compact Serialization

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Registering Classes for Compact Serialization

Each custom class must be serialized before adding any of its objects into cache. NCache compact serialization is used to dynamically serialize classes on the fly.
These classes can be
  • Generic
  • Non-Generic
In This Section
Registering Non-Generic Classes
Explains how to register non-generic classes for compact serialization.
Registering Generic Classes
Explains how to register generic classes for compact serialization.
Registering Generic Classes using Generic Type Handler
Explains how to register generic classes for compact serialization using generic type handler.


Topic: Registering Classes for Portable Data Sharing

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Registering Classes for Portable Data Sharing

There are situations when applications form the same/different platforms are interested to share cached data among them. For this purpose, dynamic data sharing can be used. It shares the data between various versions of an object, either from the same platforms or different platforms at runtime. Classes for portable data sharing can be registered in following ways:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Data Sharing tab.
  • Click the Add Shared Types button.
  • Select Data Sharing Classes dialog will open. Specify the name of data sharing type.
  • Click Browse to browse for required assembly (.exe, .dll or .jar file).
  • Selected Assembly and all its classes will appear in Loaded Classes section. Select the required class and add it in List of selected Classes section using Add Class button.
  • Repeat step 5 and 6 to select jar file and Java class.
  • Click OK after adding classes of .NET and Java. The opened wizard will close and selected classes of both platforms will appear in Shared Types section under your given data type name.
  • Now map the attributes of both platforms classes. Click on the added data share type ‘Customer’, all of its attributes will be listed in Common Attributes section.
  • Click on a class listed under ‘Customer’ data type. Its attributes will be listed down in Selected Class Attributes section.
  • A drop down will appear in the Selected Class Attributes section in front of each attribute of common attributes list. If .NET class is selected, select the required Java attribute of the Java class to map it against .NET attribute. Data types of attributes to be mapped should be same or compatible. The compatible .NET and Java data types mapping tables are given below:
  • Map all the attributes using the drop down list.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Import/Export Data Share Configuration


Topic: Step 1: Register Compact Types with NCache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 1: Register Compact Types with NCache
This feature is not available in NCache Express and Professional edition.
Configure the Cache
Create a Local Cache named "myCache" as follows:
  • Run NCache Manager.
  • Create a new project.
  • Create a new cache . Select following options from New Cache Wizard:
  • Cache Node: It may be the current computer and may be some other if you want.
  • Cache name: myCache
  • Operation Timeout: 60 sec's (default)
  • Statistics Replication Interval: 600 sec (default)
  • Cluster Port: 8714
  • Maximum Size: 250 MB (default)
  • Eviction Policy: Priority based
  • Default Priority: Normal
  • Eviction Percentage: 5 (default) (In case of session it is recommended that turn off eviction)
  • Clean interval (sec.): 15
  • Start the cache.
  • Verify that cache is running. For this, determine cache behavior by adding and removing objects from Statistics Window. You can go to the statistics window by right clicking the cluster and selecting Statistics in Manager.
  • Clear the cache to make it ready for your application.
Registering Compact Serializable Types
You can register types one by one through 'add types' button. Perform following steps to register types with the configured cache:
  • Stop the Cache if it is running.
  • Click on the 'Compact Serialization' tab which will open up the following screen.
  • Click 'Add Types' button. A 'Select Compact Classes' dialog box will appear.
  • Browse for the assembly file that contains the compact types by clicking 'Browse' button as shown in the figure.
  • Select the classes you want to register with the cache from the loaded classes list.
  • Press 'Add Class' button to add classes in selected classes list.
  • Click 'OK'.
  • Newly added types will start appearing in the list box under the 'Compact Serialization' tab having Compact Type and Platform information.
  • 'Remove' will delete the selected type from the registered types list.
  • This shows all the added types. Now arguments can be added with generic types by clicking on 'Add <T>' button.
Registering Generic Compact Types Through Generic Type Handler
There is another way for registering generic compact types through Generic Type Handler. With Generic Type Handler user can add all the Generic types at once by implementing our interface. This is time saving, convenient and gives you option of re-usability. Here is a sample code for this.
public class CustomGenericType<T,K,V>
{
}
public class SetGenerics: IGenericTypeProvider
{
Type[] types = new Type[6];
#region IGenericTypeProvider Members
Type[] IGenericTypeProvider.GetGenericTypes()
{
types[0]=typeof(Dictionary<string, Customer>);
types[1]=typeof(List<int>);
types[2]=typeof(CustomGenericType<Employee, Product, Customer>);
types[3]=typeof(CustomGenericType<Employee, Product, int>);
types[4]=typeof(CustomGenericType<Employee, string, byte>);
types[5]=typeof(CustomGenericType<string, Customer, bool>);
return types;
}
#endregion
}
For registering types follow steps given below.
  • Click on 'Generic Type Handler' button. A 'Select Compact Classes' dialog box will appear.
  • Browse for the assembly file that contains the compact types by clicking the 'Browse' button as shown in the figure.
  • Click 'OK' button.
  • Apply changes to the cache.
Specifying InProc or OutProc Access Mode
Please note that this cache has been configured to be used as OutProc. You can verify this by looking at the 'Isolation Level' property on the Main tab of the Cache details window. If you want to change Isolation Level, do the following:
  • Stop the cache .
  • Go to the Main tab.
  • Change Isolation Level to 'Low'. This sets it for InProc. 'High' means OutProc.
  • Apply configuration changes to the cache . You will notice that you no longer have the 'myCSCache node->Start' menu enabled. This is because, the cache is now supposed to start as part of your application process.
See Also
Run your Application


Topic: Registering Generic Classes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Registering Generic Classes

NCache also supports generic classes to be compact serialized. Generic classes are configured in the same way as other
classes. In addition we also need to specify <T> types for each Generic class. Generic classes can be configured as folows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Compact Serialization tab.
  • Click on the Add Type button. Select Compact Classes dialog appears.
  • Click on the Show Default Generics button. It lists default generic types. Select the desired type and click Add Class.
  • It adds selected classes in the lower pane. Click OK to add classes for compact serialization.
  • All of the selected classes are now listed at Compact Serialization tab in NCache Manager.
  • Now you need to specify the classes which you expect to be assigned to the selected generic classes. When you select any of the added generic class, the Add<T> button becomes enabled. Click Add<T>.
  • Select Compact Cllasses dialog appears. Click Browse to select assembly. All classes will be loaded in Loaded Classes list box. Select your class and click Add Class.
  • Click OK. It adds generic <T> type under the select generic class.
  • This way you can specify as many <T> types for a generic class as needed.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Non-Generic Classes | Registering Generic Classes using Generic Type Handler


Topic: Registering Non-Generic Classes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Registering Non-Generic Classes

You can use either of the two ways described below to register your generic classes for compact serialization.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Compact Serialization tab.
  • Click Add Types button. A new Select Compact Classes dialogue box will open up.
  • Click on Browse button. It will open a windows Open dialog. Using this dialog you can select .exe, .dll or .jar file.
  • Select your required file (.exe, .dll or .jar) and click on Open. It lists classes from the selected assembly in Loaded Class list box. Select desired classes which you want to register with NCache for compact serialization and click Add Class.
  • Compact Serialization works on attribute level. In the lower pane, attributes of all your selected classes get listed; from
here you can select attributes which you do not want to be compact serialized.
  • Click OK to add classes. It lists fully qualified names of all selected classes in Compact Serialization tab.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addcompacttype.exe, provide the required information:
addcompacttype.exe /id demoLocalCache /a C:\Data.dll /c NCache.Sample.Data.Compact.Engineer
addcompacttype.exe /id demoLocalCache /a C:\Data.dll /c NCache.Sample.Data.Compact.Manager /al hireDate
  • Hit ENTER key, it defines a compact type for demoLocalCache. You can define further types one by one repeating the step
for other types.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Registering Generic Classes | Registering Generic Classes using Generic Type Handler


Topic: Removing Items

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Removing Items

You can remove items from the cache from anywhere in your application using Remove and RemoveAsync methods. Include the following namespace in your project:
using Alachisoft.NCache.Web.Caching;
Using Remove Method
  1. Create a new Class named 'Customer' in your already created Test Application.
  2. Insert the following code in the 'Customer' class.
    [Serializable]
    class Customer
    {
    ...
    }
  3. Now insert the following code in the 'Main' of the project:
    Cache _cache = NCache.InitializeCache("myCache");
    _cache.Clear();
    Customer customer = new Customer ();
    customer.name = "David" ;
    customer.customerID = 1001;
    customer.City = "London" ;
    customer.ContactNumber = "+44-xxx-xxxx-xxxx" ;
    customer.IsOrderInProcess = true ;
    // Add Item to Cache
    _cache.Add("Customer:David:1001" , customer);
    // Removes key from Cache and returns the attached object with it
    Object removedObject = _cache.Remove("Customer:David:1001");
    Customer customerInformation = (Customer)removedObject;
    Console.WriteLine("Customer ID: " + customerInformation.customerID);
    Console.WriteLine("Name: " + customerInformation.name);
    Console.WriteLine("City: " + customerInformation.City);
    Console.WriteLine("Contact Number: " + customerInformation.ContactNumber);
    Console.WriteLine("Order placed: " + customerInformation.IsOrderInProcess);
  4. Start the Local Cache 'myCache'.
  5. Run the project.
See Also
Initialize Cache | Adding Items | Finding items | Dispose Cache | Start Cache | Stop Cache


Topic: Remove Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Remove Bridge

A particular bridge can be removed by following the methods given below:
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Remove Bridge option in the right click context menu.
  • A dialogue box will appear. Click Yes to delete the bridge.
  • The bridge will be removed when Yes is clicked.
See Also
Start Bridge | Stop Bridge | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Remove a Bridge Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Remove a Bridge Node

NCache manager also lets the user remove a node from the bridge. This can be done as follows:
Using NCache Manager
  • Right click on the bridge node under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Remove option in the right click context menu.
  • A message box appears asking to confirm the bridge node removal. If you are sure to remove this node, then click on Yes button.
  • The node will be removed from the bridge on clicking Yes.
  • Right click on the name of the bridge and select Apply Configuration.
See Also
Add a Bridge Node | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Remove a Cache from Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Remove a Cache from Bridge

You can remove a cache from bridge after the bridge stops. This can be done as follows:
Using NCache Manager
  • Right click on the cache name under Caches tree node of a bridge in the Cache Explorer.
  • Click on the Remove option in the right click context menu.
See Also
Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Bridge Management | Configuring Caches


Topic: Remove Data from Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Remove Data from Cache

Deleting item(s) from the cache is also considered as one of the basic operations. NCache primarily provides two methods to delete an item from cache. These are:
  • Delete
  • Remove
Difference between Delete and Remove methods
delete | remove
Returns nothing after deletion. | Deletes data from the cache and returns deleted data to the application.
Using Remove Method
A remove method is a basic method which removes the key from the cache and returns the removed object to the cache.
string key = "Product:1001";
Product product = null;
try
{
// null is returned if key does not exist in cache
object result = cache.Remove(key);
if (result != null)
{
if (result is Product)
{
product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Using Delete Method
A delete method is a basic method which deletes the key from the cache.
string key = "Product:1001";
try
{
cache.Delete(key);
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Creating Caches | Initialize Cache | Fetch Data from Cache | Add/Update Data to Cache | Dispose Cache | Bulk Operations | Start Cache | Stop Cache


Topic: Removing NCache assemblies from GAC

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Unable to Remove Assembly from the GAC Machine

You may be unable to uninstall assemblies using select and delete mechanism from GAC. You will need to delete them using command prompt (manually). You will get following message:
Error: "Assembly Alachisoft.NCache.* could not be uninstalled because it is required by other application."
Workaround
Do the following to delete assemblies from GAC:
  • Go to command prompt.
  • Go to folder %windir%/assembly/GAC_MSIL/
  • Go to the respective assembly folder and remove the assembly.
See Also
Installation Ends Prematurely


Topic: Removing Server Node from Clustered Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Removing Server Node from Clustered Cache

You can remove a Server Node from a cache cluster at any time in the following ways.
Using NCache Manager
  • To remove a Server Node, right click on the Node in the 'NCache Management' tree and select 'Remove' from the context menu.
l
  • A dialog box will appear asking to confirm the removal of node. Press Yes to continue. The server node will be removed.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use removenode.exe, provide the required information:
removenode.exe demoClusteredCache /s 20.200.20.107
  • Hit ENTER key, it will remove node 20.200.20.107 from demoClusteredCache.
See Also
Creating Cache Clusters | Configuring Basic Cache Settings | Cache Management operations | Monitoring Cache Operations


Topic: Removing Client Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Removing Client Node

A client node from the cache can be removed in the following way:
1. Expand the cache and in Client Nodes section, right click on the node which you want to remove from cache.
2. Select the Remove Node option.
This will remove the client node from cache


Topic: Removing Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Removing Server Node

A server node from the cache can be removed in the following way:
1. Expand the cache and in Server Nodes section, right click on the node which you want to remove from cache.
2. Select the Remove option/ Select Remove Server Node from the toolbar.
This will remove the server node from the cache.


Topic: Replicated Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Replicated Cache

Multiple Server Nodes: In replicated cache, there can be two or more server nodes. Each node is replica of the cache, i.e., all server nodes contain the same set of cached data.
More than One Backups: It has more than one backup of the cached data. With an increase of server nodes in cluster, the number of backups also increase.
Replication Mode: Replications are performed synchronously on all other nodes of the cache. In synchronous parallel replication, there is a chance that two parallel requests for updating the same data may result in different state on different replica nodes. But using a global token performs updates on all nodes in a sequenced fashion to avoid data integrity issues.
Clients Load Balancing: Cache clients are load balanced automatically by the cluster for an even distribution of load
on the cache nodes. This ensures that any one node is not overwhelmed by the cache client requests. Client load balancing is configurable and can be turned off.
High Performance in Reference Data: Replicated cache is suitable when data read are more than data writes. For any cache client, reads are local to the server which means that cache client have direct access to all data.
Runtime Scalability: Server nodes can be added or removed in replicated cache like other topologies at run time.
Low Performance in Transactional Data: As more server nodes are added to scale the replicated cache, write overhead increases. So this topology is not suitable for applications having transactional type of data.
Storage Limitation to Each Server Node: Adding more nodes does not increase the storage capacity because every node has same data set.
High Availability: Replicated topology is best for applications where high availability and reliability with zero down time is the priority. This is because this topology contains multiple backups of cached data set.
State Transfer: Every server node replicates the state from the coordinator node (the senior most node in terms of cluster joining) when it joins the cache cluster.
See Also
Mirror Cache | Partitioned Cache | Partitioned-Replica Cache


Topic: Reset Configuration

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Reset Configuration

Resetting configuration will change all configuration changes to the last saved configuration values for the current cache. This can be done as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to reset the configuration settings.
  • Click on the Reset Configuration option in the right click context menu.
Cache settings are reset to the last saved configuration for this cache.
  • You can also apply configuration using tool bar buttons in the manager.
See Also
Configuring NCache | Create Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Stop Cache | Start Cache | Hot Apply Configuration | Reset Configuration | Data Load Balancing


Topic: Restart Bridge Service

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Restart Bridge Service

Bridge service can be restarted on a particular node following the methods given below:
Using NCache Manager
  • Right click on the node under Bridge Nodes tree node of a bridge in the Cache Explorer.
  • Click on the Restart Bridge Service option in the right click context menu.
  • This stops the bridge on the given server and then starts it automatically on the same server.
See Also
Stop Bridge Service | Start Bridge Service | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Restart Cache Service on a Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Restart Cache Service on a Server Node

A cache service can be can be restarted on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to restart the cache service.
  • Click on the Restart Cache Service option in the right click context menu.
This will restart the NCache service on the selected node.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing | Start Cache Service on a Server Node | Start Cache Service on a Server Node


Topic: Retry Interval

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Retry Interval

Retry Interval specifues the time between two successive connection retries.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Change the Retry Interval (sec.) as required.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf
Connection retries can also be configured in config.ncconf file as follows.
<ncache-server port="9800" connection-retries="60" retry-interval="1"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Step 2: Run Your Application

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 2: Run Your Application
This feature is not available in NCache Express and Professional edition.
Before running your application, make it sure that you have deployed the assembly containing compact types. Also, make sure compact types are registered with the cache and cache is running if it is configured as OutProc cache. You may see the statistics of the cache through statistics window.
See Also
Register Compact Types with NCache


Topic: Step 4: Run your NHibernate based Application

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 4: Run your NHibernate based Application

Before running your application make sure that the cache is running if it is configured as OutProc cache. You may see the statistics of the cache through statistics window.
See Also
Configure the Cache | Register NCache with NHibernate | Enable DBCacheDependency in NHibernate


Topic: Step 3: Start/Restart ASP.NET Application

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 3: Start/Restart ASP.NET Application
This feature is not available in NCache Express and Professional edition.
Now that you have configured a cache through NCache Manager and have edited web.config to add NCache Output Caching, you're ready to start or restart your ASP.NET application. To restart your ASP.NET application, kill your ASP.NET process through Task Manager first.
See Also
Configure the Cache | Edit Web.Config or Machine.Config


Topic: Step 3: Start/Restart ASP.NET Application

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 3: Start/Restart ASP.NET Application

Now that you have configured a clustered cache through NCache Manager and have edited web.config to add NCache Session Store Provider, you're ready to start or restart your ASP.NET application. To restart your ASP.NET application, unload App domain first. This can be done by saving web.config.
See Also
Configure the Cache | Edit Web.Config or Machine.Config


Topic: Step 3: Start/Restart ASP.NET Application

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Step 3: Start/Restart ASP.NET Application

Now that you have configured a Replicated Cluster through NCache Manager and have edited web.config to add NCache Clustered Session HTTP Module, you're ready to start or restart your ASP.NET application. To restart your ASP.NET application, unload App domain first. This can be done by saving web.config.
See Also
Configure the Cache | Edit Web.Config or Machine.Config


Topic: Runtime Data Sharing

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Runtime Data Sharing

Runtime data sharing has become an important use for distributed caches. More and more applications today need to share data with other applications at runtime in an asynchronous fashion.
Previously, relational databases were used to share data among multiple applications but that required constant polling by the applications wanting to consume data. Then, message queues became popular because of their asynchronous features and their persistence of events. And although message queues are great, they lack performance and scalability as required by applications nowadays.
As a result, more and more applications are using in-memory distributed caches for event driven runtime data sharing. This data sharing should be between multiple .NET applications or between .NET and Java applications. NCache provides very powerful features to facilitate runtime data sharing that make use of notifications to keep cache clients updated about cache status.
See Also
Configuring Eviction Policy | Cache Topologies | Cache Cluster | Local Cache | Cache Client | Client Cache | Data Load Balancing in Partitioned and Partitioned-Replica Topologies | Client Backward Compatibility | Indexing | Eviction


Topic: Security and Encryption

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Security and Encryption

NCache provides a customizable security feature for securing distributed cache access. Any unwanted or unauthorized access to the NCache cluster and to the data that resides in the cluster can be avoided by simply configuring NCache security. Moreover, the data being transmitted over network between cache servers and the application can be secured by configuring NCache data encryption mechanism. No code changes are required for NCache security and encryption customizations. This section explains how to use security and encryption in NCache.
In This Section
Overview
Explains different levels of security and types of encryption provided by NCache.
Using Security
Explains how to use security in cache using NCache API.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

Security
Distributed cache operates in an environment having access to many different users, where any user can change cache configuration, perform any management operation or can have access to cache data without any restriction. The concern of cache security arises when the data being dealt with is critical or the administrative access to the cache should be granted to only a list of authenticated users. This is where NCache security comes in handy for providing different cache access levels and fulfilling the need to ensure a secure distributive caching system.
NCache provides a security feature with different level of granularity that can be implemented as per requirements.
NCache security feature incorporates security at two distinct access levels
  • Administrative/Management Level
  • Cache API Level
These levels of security are intended to secure both management and client level access to your cache. By default, security feature is disabled for both the access levels.
i. Administrative/Management Level Security
Management level security in NCache ensures that a remote cluster node is protected from any unauthorized user access. It is used to validate authorized users that have access to perform any management operation on a cluster node. To secure overall multi-node cache cluster, the security must be enabled on each individual node of the cluster.
Please see how to configure security to learn more about security configuration.
Once management level security is configured on the server node allowing only a few users to have administrative permissions, no users other than those specified will have access to perform any management operations such as creating new cache, removing/adding existing cache, starting/stopping cache etc on that node
Privileged Windows Administrator
Users other than those configured as node administrators are not permitted to perform any management related operation on the node. But there is one exception:
"A user is also granted administrative permissions if the provided credentials are valid local system administrator credentials."
It means that a local window administrator always has administrative rights and permissions whether managerial operation is performed locally, or from any other server node, using local windows credentials. So if a node is not authorized as an administrator and that node is being used to perform an operation on a personal machine, all that is needed to perform remote management operation on the system is to provide valid system credentials.
ii. Cache API level Security
Cache level security in NCache ensures that cache data is protected from any unauthorized user access. Cache API level security is used to validate authorized users who try to establish a connection with cache via NCache API. By enabling cache level security, the clients’ access to cluster cache data for either reading or writing can be controlled. Only those clients who are verified as valid and authenticated users, are allowed to perform cache level operations.
Once, cache level security is configured on a cache allowing only a few users to have cache API authorization, no users other than those specified will have access to perform any cache operations on the cache such as initializing cache, adding/ updating in cache, removing/fetching any data etc.
If security is enabled on a cache, then credentials must be provided along with initialize cache call to establish a connection.
Authentication and Authorization
NCache security ensures that only authenticated and authorized connections to the cache are accepted either for cache usage or for administration. All other connections are rejected.
  • Authentication
NCache uses system level and Active Directory authentication to verify connection identity. When NCache security is enabled, all connections to the cache cluster must first be authenticated against Active Directory at the cache server. If Active Directory authentication is failed, then system authentication is carried out only if management operation is requested on cache.
Credentials must be provided at the time of establishing a connection to the cache. And, if these credentials are not authenticated, the connection request is denied. User credentials can be specified at the following places:
  • NCache client configuration files.
  • When calling NCache.InitializeCache(…) API from client’s application.
  • In NCache Manager for administering the cache.
  • Authorization
After NCache authenticates a connection to the cache successfully, it checks NCache security configuration files at the cache server in order to authorize this connection.
Each connection to the cache can be categorized as one of the followings:
  • User: The user can access the cache for read/write but cannot administer it. A user is defined at cache level.
  • Admin: The admin can access the cache for read/write and can also administer it. An “admin” is defined at cache server level.
If an Admin connection is authenticated as local system administrator, then it is considered as an authorized connection without looking up the configuration files.
Data Encryption
As in distributive environment, caching systems mostly interact via network channels for transferring data between clients and remote servers. The data travels and resides in the cache in its original form, and anyone eavesdropping on a connection can intercept its data easily, if it is not encrypted. Data encryption feature provided by NCache is very important to secure sensitive data by reducing the security risk if data travels through network or is stored in the cache unprotected.
NCache provides a rich set of encryption algorithms that are nearly impossible to break. This ensures that the sensitive data is really protected well. NCache provides the following encryption algorithms to choose from:
  • 3DES: very strong 168-bit encryption
  • AES-128: very strong 128-bit encryption
  • AES-192: very strong 192-bit encryption
  • AES-256: very strong 256-bit encryption
NCache data encryption and decryption occurs inside the NCache client application process. This means that data traveling over the network between the application and the cache cluster is already encrypted. Similarly, only encrypted data is stored in cache store.
Encryption can be enabled through NCache management tools without any programming effort. To learn how to enable encryption, please see configuring encryption for cache .
Once encryption is enabled, NCache client automatically starts encrypting objects before sending them to the cache cluster. And, it automatically decrypts objects fetched from the cache before delivering them to the application.
If NCache encryption is enabled, data associated with all of the following operations is encrypted:
  • Data being transacted.
  • Data traveling via network.
  • Data being loaded via cache startup loader.
  • Data in cache queues buffer etc.
NCache uses an encryption key which is kept inside NCache security configuration files at each cache server in an encrypted manner. Encryption key is automatically sent to clients to be used in memory upon a successful connection.
See Also
Using Security | Configuring Security | Using Basic Cache Operations | Server Side API Programming


Topic: Configuring Security

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Security
This feature is not available in NCache Express and Professional edition.
Every Server node keeps security information that it has to provide to calling clients. Alachisoft.NCache.NCSecurity.dll at server node is required to provide security services to all clients. Whatever information is required by this assembly, for managing security related issues, is present in security.ncconf file. security.ncconf file helps enabling NCache security as well as to manage Node and API level security. You will find security.ncconf file at "%Install Directory%/NCache/config".
Security.ncconf file is explained below:
<!-- Security Configuration file for NCache 4.4 and later versions -->
<cache-security>
<!-- Change the value true/false to enable or disable security
feature in NCache -->
<enabled>false</enabled>
<!-- LDAP path is required to log-on to domain. -->
<ldap>LDAP://Pdc-america</ldap>
<!-- Following users are Administrators and are allowed to add 'THIS' node
into their clusters and also allowed to perform Cache operations at
API level for all Caches. -->
<ncache-administrators>
<uid>Administrator</uid>
</ncache-administrators>
</cache-security>
  • <enabled> tells users if security is enabled or not (true/false)
  • <ldap> specifies ldap path for active directory server provider. It is the domain controller. NCache uses Microsoft Active Directory Service for authentication of user. User should exist under given domain in LDAP. For more information, see https://msdn.microsoft.com/en-us/library/aa746384.aspx
  • <ncache-administrators> keeps list of users having rights on all node-based and API-based operations.
See Also
Cache Config | Configuring Bridge | Client Side Configuration Files | Configure Basic Cache Settings | Configure Security Using NCache Manager


Topic: Using Security

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Security

This section provides solutions for some common troubles in using NCache security.
In This Section
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Different situations are explained when this exception is thrown by NCache.


Topic: Alachisoft.NCache.Runtime.Exceptions.SecurityException

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Alachisoft.NCache.Runtime.Exceptions.SecurityException

This exception is raised if an unauthorized user tries to perform cache operations, or wrong credential information is given in the InitializeCache() overload given below or in client.ncconf file.
Workaround
To avoid security exception, do the following :
  • Check if you have given correct credential information through API or in client.ncconf. A typing mistake can be the result of this exception.
  • See if the user which you have specified exists under given domain in LDAP. Login credentials are required to belong to any WINDOWS Server hosting the user login and running Active Directory services.
  • Check if you have given a double slash '//' to separate domain name and User ID when passing them as a string through API. Sometimes a single slash is given, which is recognized as an escape sequence. In that case, no compile time error arises, rather it results in a security exception. Correct way to pass security information through API is shown below:
    // Initialize the cache
    NCache.InitializeCache("myQSReplicatedCache", primaryUserCredentials, secondaryUserCredentials);
See Also
Configuring Security


Topic: Configuring Security for Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Security for Cache

Security can also be configured on cache itself. This can be done as follow:
Using NCache Manager
  • Open NCache Manager.
  • Go to Security menu option and select Security Credentials option.
  • Security Credentials dialog will open.
  • Provide the valid credentials for your active directory like name of Domain Controller, Port (optional), User Name and Password.
  • Click on the Verify Credentials button. It will prompt success or failure messages. If provided security credentials are correct then it will display the success message like this:
  • Click OK.
  • Click the cache name for which you want to configure the security. Cache settings open in the right pane inside the NCache Manager.
  • Go to the Security tab in cache settings.
  • Expand the domain users under the Available Domain Users section.
  • Add required users to Selected Users section using ‘>’ button. These users will have access for cache operations.
  • Check Enable Security check box.
  • Select users from the users list and then add the required users using ‘>’ button. These users will be allowed to manage the caches.
  • Check the Enable Security checkbox to enable the security.
  • Right click on the cache name in Cache Explorer and select Apply Configuration option.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use configurecachesecurity.exe, provide the required information:
configurecachesecurity demoClusteredCache /E /s 20.200.21.95 /U james_tredwell /P yourpassword /C yourdomain.org
  • Hit ENTER key, it will enable security for demoClusteredCache on server 20.200.21.95 and add the user james_tredwell.
  • If you want to add more users, use the following command after step 2:
configurecachesecurity demoClusteredCache /A /N aaron_finch /s 20.200.21.95 /U administrator /P yourpassword /C yourdomain.org
  • Hit ENTER key. It will add the user aaron_finch to the secured users list of demoClusteredCache.
How to pass Security Credentials to API:
User can also pass security credentials to API from the application using the following code:
NCache.InitializeCache("cacheId", new Alachisoft.NCache.Web.Security.SecurityParams("Username", "Password"), null);
See Also
Configuring Security for Cache Management | Configuring Encryption for Cache | Configuring Caches | Configuring Client Cache Settings | Cache Management operations | Configuring Bridge | Monitoring Caches


Topic: Configuring Security for Cache Management

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Configuring Security for Cache Management

After you have created cache, security for management operations can be configured in following ways:
Using NCache Manager
  • Open NCache Manager.
  • Go to Security menu option and select Security Credentials option.
  • Security Credentials dialog will open.
  • Provide the valid credentials for your active directory like name of Domain Controller, Port (optional), User Name and Password.
  • Click on the Verify Credentials button. It will prompt success or failure messages. If provided security credentials are correct then it will display the success message like this:
  • Click OK.
  • Now go to the NCache Manager ->Security menu option again and select Configure Security option.
  • Security Configuration Wizard will open. Specify the server IP address for which you want to configure the security and click Next.
  • Security Configurations Wizard will open. Expand the Available Domain Users. It will list down all of the active directory users.
  • Select users from the users list and then add the required users using ‘>’ button. These users will be allowed to manage the caches.
  • Check the Enable Security checkbox to enable the security.
  • Click Finish.
See Also
Configuring Security for Cache | Configuring Encryption for Cache | Configuring Caches | Configuring Client Cache Settings | Cache Management Operations | Configuring Bridge for WAN Replication | Monitoring Caches


Topic: Cache Server Configuration

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Server Configuration

This section explains various cache server configuration in "Alachisoft.NCache.Service.exe.config" file. All configurations in Alachisoft.NCache.Service.exe file will be needed at the start of NCache service.
In This Section
Overview
Gives you and overview of NCache.Service.exe.config file.
Cache Server Configurations in Service Config File
Explains how to configure different cache settings in NCache.Service.exe.config file. These settings are:
Bind Multiple NIC's
Explains Bind Multiple NIC's, its uses and its default values.
Auto Start Cache on Reboot
Explains Auto Start Cache, its uses and its default values.
Client/Server TCP Port
Explains Client/Server TCP Port its default values.
Configure Windows Events Logging
Explains Windows Events Logging, its uses and its default values.
Configure .NET Garbage Collection
Explains .NET Garbage Collection, its uses and its default values.
Configure Expiration Cleanup
Explains Expiration Cleanup, its uses and its default values.
Configure Eviction Cleanup
Explains Eviction Cleanup, its uses and its default values.
Enable Debug PerfMon Counters
Explains Debug PerfMon Counters, its uses and its default values.
Enable License Logging
Explains License Logging, its uses and its default values.
Configure SQL Dependency
Explains SQL Dependency and its modes.
Configure Response Data Size
Explains the Response Data Size and its various parameters.
Configure Max Response Length
Explains the Response Data Size and its various parameters.
Configure Enumeration
Explains the process of Enumeration and its various parameters.
Cache Startup Loader Delay
Explains how to introduce delay in Cache Startup Loader.


Topic: Cache Server Logging

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Cache Server Logging

Another feature provided by NCache is logging different states of clustered, client, bridge caches into different log files. These log files are created whenever cache starts and are locked until cache changes its status to stop or whenever the service stops. Log files encapsulate different level of information based on logging status.
NCache creates each log file for particular cache with different time span. This time initializes as cache starts and continues until cache status changes from running to stopped. NCache writes log file with default format that gives user a readable format. It also logs thread name whenever an operation is performed by any running thread. NCache presents different stages of logging. These logging level are configurable and are described as follows:
  • Info Level: Info level describes some useful information about any operation performed on cache, such as log starting and stopping state of state transfer operations. Info level is disabled by default.
  • Error Level: This log flag gives the cause of errors that are raised during operation execution. This status log is useful in most of troubleshooting scenarios such as during start of cache exception which occurs for joining with its own replica.
  • Critical Level: This flag logs the critical status of any action or operation on cache, such as “cache exceeds its memory limits”. This log information is useful to optimize cache performance and is the most high priority logs among all log-file information.
  • Detail Debug Level: This flag is disabled by default but the user can configure it. This log option prints detailed information about any operations in cache such as information of each operation like key, cache items during state transfer. This log information is useful to analysis cache issues in details whenever normal debugging is not possible and drilling any hidden issue. But this cause performance degradations for cache operations.
NCache also provides logging for client application and socket level by configurations options. These options are disable by defaults, but they can be enabled changing settings of app/web files. These logs are created into defaults location where NCache logs are saved. These logs contain information of client operations and also usage data of operations propagate through socket server to communicate with remote server.
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging | Cache Server Logging | Client Side API Logging


Topic: Server Port

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Server Port

At the NCache Server Port, NCache Server starts and accepts different client connections. Default value of this port is "9800". You can change the default value through Alachisoft.NCache.Service.exe.config file as follows:
<add key="NCacheServer.Port" value="9800" />
This will change the value at Server side. This change must also be made in client.nconf to make client aware of this change, as follows:
<ncache-server port="9800" connection-retries="60" retry-interval="1"/>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Port Range | Cluster Port


Topic: Server Side API Programming

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Server Side API Programming

This section is a practical guide for programmers who want to utilize powerful features of Server side NCache to create high performance and scalable .NET applications. This includes working examples and code snippets to utilize various features of NCache efficiently.
In This Section
Cache Startup Loader
Explains how to use Cache Startup Loader.
Data Source Provider (Backing Source)
Shows how to transparently fetch the required data from the master datasource if it is not available in the cache and vice versa.
Dynamic Compact Serialization
Explains making application data types Compact Serializable and use them in your application with NCache.
WAN Replication Through Bridge
Explains how to use Conflict Resolver.
Custom Cache Dependency
Depicts how you can use custom dependencies by defining your own expiration logics.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

"Alachisoft.NCache.Service.exe.config " file hosts all cache related configurations. For any change in cache configuration, you can either manually update this file or use NCache Manager to update it. This file updates with every change made at NCache Manager. Here you can specify the port at which cache server will listen for the incoming connection requests. Send/receive buffer size of connected client sockets is also given here. You can also identify cache (es) that you want to start at boot in Alachisoft.NCache.Service.exe.config file. This file is located at "%Install Directory%/NCache/bin/service".
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Cache Server Configurations in Service Config File | Configuration Files


Topic: SessionStoreProvider not found

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

SessionStoreProvider not found

You may get following error message when using Session Store Provider.
Error: Could not load type 'Alachisoft.NCache.Web.SessionState.NSessionStoreProvider'.
Workaround
Please make sure the following also exists in your web.config:
For Enterprise and Professional Editions:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
For Open Source Edition:-
<assemblies>
<add assembly="Alachisoft.NCache.SessionStoreProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
Replace version “x.x.x.x” with the actual NCache version that you have.
See Also
Using Session State Store Provider


Topic: Setting Up Development Environment

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Setting Up Development Environment

  1. Open File-> New -> Project.
  2. Select a Console Application from range of generic templates.
  3. Specify the Name for the Application.
  4. Specify the appropriate Location to save a project.
  5. Click OK button to create a new project.
  6. Add the following reference in your application to start working with NCache, as shown in the figure below: Alachisoft.NCache.Web.
  7. Select the reference from the list of references as shown below:
  8. Add the following namespace in your application:
using Alachisoft.NCache.Web.Caching;
See Also
Caching Concepts | Client Side API Programming | Server Side API Programming | Client Side ASP.NET Features | Client Side Third Party Integrations


Topic: Using SQL Dependency

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using SQL Dependency

NCache provides feature of SQL dependency for the purpose of synchronizing cache with Microsoft SQL Server 2005/2008. An item is added with SQL dependency, specifying SQL statement representing one or more rows (query result set) in database. Then NCache establishes a link with the database against these rows. If data is updated in the database by any application, SQL Server fires a .NET event notification which NCache catches and removes the corresponding item from the distributed cache.
i. Configuring Notification on SQL Server
NCache tracks changes in database using notifications received from SQL server about changes in database. Internally NCache registers for these data change notification and receives notification from database in case of any change in the registered query result set. On the basis of these received notification, cache invalidates the corresponding data and removes it from cache.
Notifications must be enabled in SQL server database for NCache. Unlike time based expirations where data is invalidated by cache clean up thread on a configurable interval, NCache removes the corresponding data as soon it receives notification from the database.
For this purpose, enable the service broker in SQL Server 2005 or above before NCache can use SqlCacheDependency. This allows SQL Server 2005 to send event notifications to NCache to let it know that data has changed in the database.
[SQL]
ALTER DATABASE Northwind SET ENABLE_BROKER;
GO
To verify that the broker is running, properties in the databaseserver can be checked using SQL Management studio or run the following query:
select is_broker_enabled from sys.databases where name = '<dbname>'
If the result is “1” it means broker has been enabled.
For further details, refer to MSDN article on Enabling Event Notifications for SQL Server .
ii. Database Permissions
The following permissions need to be enabled in order to use NCache SQL cache dependency if the user does not have database permissions. Database permissions are defined for two different modes: Default mode and Custom mode.
For Default Mode
GRANT SUBSCRIBE QUERY NOTIFICATIONS TO <database_principal>
GRANT CREATE QUEUE TO <database_principal>
GRANT CREATE SERVICE TO <database_principal>
GRANT CREATE PROCEDURE TO <database_principal>
For Custom Mode
CREATE QUEUE "NCacheSQLQueue-[IP-Address]";
CREATE SERVICE "NCacheSQLService-[IP-Address]"
ON QUEUE "NCacheSQLQueue-[IP-Address]"
([http://schemas.microsoft.com/SQL/Notifications/PostQueryNotification]);
GRANT SUBSCRIBE QUERY NOTIFICATIONS TO [User Name];
GRANT RECEIVE ON "NCacheSQLQueue-[IP-Address]" TO [User Name];
GRANT RECEIVE ON QueryNotificationErrorsQueue TO [User Name] ;
GRANT SEND ON SERVICE :: "NCacheSQLService-[IP-Address]" to [User Name] ;
  • IReplace [IP-Address] with node IP address and [User Name] with database user name.
  • In a clustered environment, users are supposed to create SQL Service and Queue per NCache process.
  • You can also create required SQL Service and Queue using script "NCacheServiceQueue.sql" located at:
"%Install Directory%/NCache/bin/resources"
iii. Adding Data with SQL Dependency
To add data with Sql dependency, create SqlCacheDependency object, and use Add/Insert API to add item with SqlCacheDependency.
//Create object to be added with dependency
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
try
{
//Creating SqlCacheDependency
string connectionString = "Data Source=localhost;Initial Catalog=Northwind;Integrated Security=SSPI;";
string query="SELECT ProductID FROM dbo.Products WHERE ProductID = 1001";
SqlCacheDependency sqlDependency = new SqlCacheDependency(connectionString,query);
//Adding cache item "Product:1001" with SqlCacheDependency
cache.Insert(key, product, sqlDependency, Cache.NoAbsoluteExpiration, Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch (OperationFailedException e)
{
Console.WriteLine(e.ToString());
}
//Modifying Product record in database will automatically remove Product from cache
See Also
Cache Dependencies Overview | Using Oracle Dependency | Using Polling Based Dependency | Using CLR Procedures to Call NCache | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency


Topic: Start Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Bridge

A particular bridge can be started by following the methods given below:
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Start option in the right click context menu.
  • The color of the Bridge name’s icon and the bridge nodes’ icon change when it is started successfully, like this:
  • Right click on the name of the bridge and select Apply Configuration.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use startBridge.exe, provide the required information:
startBridge.exe demoBridge /s 20.200.21.95
  • Hit ENTER key, it will start demoBridge on server node 20.200.21.95 .
See Also
Stop Bridge | Remove Bridge | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Start Bridge Service

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Bridge Service

Bridge service can be started on a particular node following the methods given below:
Using NCache Manager
  • Right click on the node under Bridge Nodes tree node of a bridge in the Cache Explorer.
  • Click on the Start Bridge Service option in the right click context menu.
  • Bridge service will be started on the selected node.
See Also
Stop Bridge Service | Restart Bridge Service | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Start Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Cache

A cache can be started either on a particular server node or on all server nodes of a cluster. This section includes the step by step procedure of starting cache using both the NCache manager and command tools.
In This Section
Start Cache on all Server Nodes
This section explains how to start cache on all server nodes of a clustered cache.
Start Cache on a Particular Server Node
This section explains how to start cache on a specific server node.


Topic: Start Cache on all Server Nodes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Cache on all Server Nodes

A cache can be started on all server nodes of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the cache name which you want to start.
  • Click on the Start option in the right click context menu.
  • This starts the demoClusteredCache on all the server nodes listed under the Server Nodes tree view. Server node icon color turns to sky blue if cache is started successfully.
See Also
Create Caches | Configuring Basic Cache Settings | Start Cache on a Particular Server Node | Stop Cache | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing


Topic: Start Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Cache

You need to include following namespace in your application to start the cache using Cache API.
using Alachisoft.NCache.Web.Management;
Starting a local cache
//start the local cache
CacheManager.StartCache("CacheID","Server_Name");
Starting a remote cache
//start the remote cache
CacheManager.StartCache("CacheID","Server_Name");
See Also
Initialize Cache | Adding Items | Finding items | Removing Items | Dispose Cache | Stop Cache


Topic: Start Cache on a Particular Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Cache on a Particular Server Node

A cache can be started on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to start the cache on.
  • Click on the Start option in the right click context menu.
  • This starts the demoClusteredCache on the selected server node. Server node icon color turns to sky blue if cache is started successfully.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use startcache.exe, provide the required information:
startcache.exe demoClusteredCache /s 20.200.21.95 /p 8250
  • Hit ENTER key, it starts the demoClusteredCache on server node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Start Cache on all Server Nodes | Stop Cache | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing


Topic: Stop Cache on a Particular Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Cache on a Particular Server Node

A cache can be stopped on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to stop the cache.
  • Click on the Stop option in the right click context menu.
  • This stops the demoClusteredCache on the selected server node. Server node icon color turns to black if cache is stopped successfully.
You can stop a node gracefully using Graceful Stop option. The graceful stop option makes sure that all of the queued operations are performed before cache is stopped.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use stopcache.exe, provide the required information:
stopcache.exe demoClusteredCache /s 20.200.21.95 /p 8250
  • Hit ENTER key, it stops the demoClusteredCache on server node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache on all Server Nodes | Start Cache | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing


Topic: Start Cache Service on a Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Cache Service on a Server Node

A cache service can be can be started on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to start the cache service.
  • Click on the Start Cache Service option in the right click context menu.
This will start the cache service on node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing | Stop Cache Service on a Server Node | Restart Cache Service on a Server Node


Topic: Start/Stop Service on a Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start/Stop Service on a Server Node

You can start/stop/restart NCache service on a server node added to a clustered cache by following the steps given below:
1. Start Cache Service on a Server Node
I. In NCache Explorer view, right click the server node on which you want to.
II. Click on the Start Cache Service option in the right click context menu.
This will start the NCache service on this node.
2. Stop Cache Service on a Server Node
I. In NCache Explorer view, right click on the server node on which you want to stop the service.
II. Click on the Stop Cache Service option in the right click context menu.
This will stop the NCache service on this selected node


Topic: Start Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Start Cache

You can start a clustered cache on all the server nodes altogether or start it on a specific node. Please follow these steps to start the clustered cache:
1. Starting Cache on All Server Nodes
I. From the NCache Explorer view, right click on the cache name which you want to start.
II. Click on the Start option in the right click context menu.
2. Starting Cache on a Particular Server Node
I. From the NCache Explorer view, right click on the server name under Server Nodes tree node, on which you want to start the cache.
II. Click on the Start option in the right click menu, in order to start the cache.
This starts the ClusteredCache on the selected server node.
Server node icons turn to sky blue if cache is started on it.
III. This starts the ClusteredCache on all the server nodes listed under the Server Nodes tree view. Server node color turns to sky blue if cache is started successfully.


Topic: Statistic Replication Interval

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Statistic Replication Interval

This option is available for Clustered Cache only. Statistics replication interval is the time interval in seconds after which a node sends its statistics to all other nodes in a cluster. Replication Interval for Statistics can be specified by one of the following ways.
Using NCache Manager:
  • Click on the cache name in Cache Explorer to open cache settings
  • Go to the Cluster Settings tab.
  • Set the Statistic replication interval (sec.) as per your requirement.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Through config.ncconf:
You can specify the statistics replication interval through Config.ncconf as follows.
<cluster topology="partition-replica" op-timeout="120sec" stats-repl-interval="60sec" use-heart-beat="False">
</cluster>
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations


Topic: Viewing Statistics of a Remote Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Viewing Statistics of a Remote Server Node

This section will help you in resolving problems that can occur while monitoring remote server nodes (Windows computers).
In this Section
Computer Name Not Found
Describes the reason of this error and provides solutions to resolve it.
Diskperf Not Installed
Describes the cause and provides steps to run Diskperf to avoid this error on monitored server node.
No READ Access to the Perflib Subkeys
Explains how to grant account READ permission to the Perflib sub key to avoid error while monitoring performance of a remote sever node.
Unable to Connect to Remote Server (Windows XP Machine)
Discusses the causes of this error and offers solutions.
See Also
Implementing Clusters
Provides help to troubleshoot the problems related to cluster implementation.
Using NCacheAPI
Provides help to troubleshoot the problems related to NCache API.
Using Security
This section provides solutions for some common troubles in using NCache security.
Installing NCache
Provides quick reference for error codes, messages, and symptoms generated by NCache during installation


Topic: Stop Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Cache

To stop a cache using Cache API, you need to include the following namespace in your application.
using Alachisoft.NCache.Web.Management;
Stopping a local cache
//stop the local cache
CacheManager.StopCache("CacheID","Server_Name");
Stopping a remote cache
//stop the remote cache
CacheManager.StopCache("CacheID","Server_Name");
See Also
Initialize Cache | Adding Items | Finding items | Removing Items | Dispose Cache | Start Cache


Topic: Stop Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Bridge

A particular bridge can be stopped by following the methods given below:
Using NCache Manager
  • Right click on the bridge name under Bridges tree node of a bridge in the Cache Explorer.
  • Click on the Stop option in the right click context menu.
  • The color of the Bridge name’s icon and the bridge nodes’ icon change when it is stopped successfully, like this:
  • Right click on the name of the bridge and select Apply Configuration.
Using Command Line Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use stopBridge.exe, provide the required information:
stopBridge.exe demoBridge /s 20.200.21.95
  • Hit ENTER key, it will stop demoBridge on server node 20.200.21.95 .
See Also
Start Bridge | Remove Bridge | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Stop Bridge Service

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Bridge Service

Bridge service can be stopped on a particular node following the methods given below:
Using NCache Manager
  • Right click on the node under Bridge Nodes tree node of a bridge in the Cache Explorer.
  • Click on the Stop Bridge Service option in the right click context menu.
  • Bridge service will be stopped on the selected node.
See Also
Start Bridge Service | Restart Bridge Service | Overview of Bridge | Creating Clustered Bridge | Configuring Bridge Settings | Changing Cache Synchronization Modes | Changing Cache Synchronization Modes | Configuring Master Cache | Force State Transfer | Connect/Disconnect a Cache | Configuring Caches


Topic: Stop Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Cache

A cache can be stopped either on a particular server node or on all server nodes of a cluster. This section explains how to stop cache using both the NCache manager and command tools.
In This Section
Stop Cache on all Server Nodes
This section explains how to start cache on all server nodes of a clustered cache.
Stop Cache on a Particular Server Node
This section explains how to start cache on a specific server node.


Topic: Stop Cache on all Server Nodes

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Cache on all Server Nodes

A cache can be stopped on all server nodes of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the clustered cache that you want to stop.
  • Click on the Stop option in the right click context menu.
  • This stops the demoClusteredCache on all the server nodes listed under the Server Nodes tree view. The coloe of all the server nodes icons turns to black if cache is stopped successfully.
See Also
Create Caches | Configuring Basic Cache Settings | Start Cache | Stop Cache on a Particular Server Node | Manage Cache Service on a Server Node | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing


Topic: Stop Cache Service on a Server Node

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Cache Service on a Server Node

A cache service can be can be stopped on a particular server of a clustered cache as follows:
Using NCache Manager
  • From the Cache Explorer view, right click on the node on which you want to stop the cache service.
  • Click on the Stop Cache Service option in the right click context menu.
This will start the NCache service on node 20.200.21.95.
See Also
Create Caches | Configuring Basic Cache Settings | Stop Cache | Start Cache | Apply Configuration | Hot Apply Configuration | Reset Configuration | Data Load Balancing | Start Cache Service on a Server Node | Restart Cache Service on a Server Node


Topic: Stop Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Stop Cache

You can stop a clustered cache on all the nodes altogether or stop it on a specific node.
1. Stop Cache on all Server Nodes
I. From the NCache Explorer view, right click the clustered cache on which you want to stop the cache.
II. Click on the Stop Cache option.
III. This will stop the ClusteredCache on all the server nodes added in this cache. If cache is stopped successfully, then the color all of the server nodes change to black, like this:
2. Stopping Cache on a Particular Server Node
I. From the NCache Explorer view, right click on the server name under Server Nodes tree node, on which you want to start the cache.
II. Click on the Stop option in the right click menu.
III. This will stop the ClusteredCache on the selected node. Icon color of the selected node changes to black if cache is stopped successfully on it, like this:


Topic: Streaming

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Streaming

NCache also allows data to be read and write in cache using streams. This section explains how to use streams using NCache API.
In This Section
Overview
Explains the concept of streams, stream buffers and stream modes provided by NCache.
Using Streams
Explains how to use streams to read and write data in cache using NCache API.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

Storing large binary data for, e.g., media files, large PDF documents, into the cache using cache API is inefficient. This will require loading the entire file into the application memory and then putting it into the cache as a single object. To overcome this, NCache provides Streaming API for reading/writing large binary data into the cache. Multiple parallel streams can be opened simultaneously into the cache.
When is it Useful
Suppose there is a high traffic application which has large media files that can be viewed by the user. For fast access, highly viewed media files are kept in cache. Adding and fetching large media files even in cache can take high processing and time if they are added and fetched at once, even if it is done asynchronously. Applications like these require high performance and the slow loading time can annoy the user. For resolving this issue, streams are used to write and read high object files in chunks like format. The files can be added and retrieved in stream chunks because those small chunks will take less time as compare to the whole large object.
In NCache serialization/deserialization, compression/decompression or encryption/decryption is not applied on data that is added in stream to avoid the chances of data corruption.
Stream Buffers
Streams are directly fetched/inserted from specified storage (here in cache) in general. However, a buffer can be added in between storage and stream. The stream will be added to that buffer and when that buffer is full, it writes the stream in cache or load it where needed. For using buffer in streaming, just the size of buffer needs to be specified. This is basically used to prevent delays in loading the data, e.g., to load a media file quickly.
NCache Stream does not support Seek operation.
Stream Modes
A cache stream can be opened in any of these modes:
  • Read
  • Read without Lock
  • Write
Stream Read
In read mode, multiple read operations can be performed simultaneously on a stream but no write operation is allowed.
Stream Read without Lock
In read without lock mode, write operations can be done in parallel to read operations because read operation does not acquire any lock to stop writing.
Stream Write
In write mode, only a single write operation can be performed on a stream. No read operation is allowed in this mode. Even thread having write lock cannot read that stream
Properly closing a stream after reading and writing is very important. The reason being that more threads might be waiting for that stream’s availability and until it is closed properly, the lock is not released which will give exception to other threads wanting to acquire the stream.
See Also
Using Streams | Data Compression | Security and Encryption | Server Side API Programming


Topic: Synchronizing Cache with Custom Data Sources

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Synchronizing Cache with Custom Data Sources

In custom dependency, the user can have his own dependencies scenarios. In this way, items can be be expired from cache in a number of flexible ways where expiration logic meets the user’s business requirements. NCache provides an abstract class ExtensibleDependency that is base for all dependencies. For defining his own dependency, the user's dependency class needs to inherit ExtensibleDependency class and change the definition of abstract function HasChanged(). Once implemented, place the assembly or executable file of class overriding ExtensibleDependency in NCache service folder and restart the NCache service.
For more details, please read Custom Cache Dependency in section Server Side API Programming .
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronize Data across Multiple Caches | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency


Topic: Synchronize Data across Multiple Caches

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Synchronize Data across Multiple Caches

NCache cache sync dependency provides a way to synchronize two caches, so that an item updated or removed from one cache have the same effect on the synchronized cache.
Adding Data with Cache Sync Dependency
The following code explains the use of cache synch dependency. An item in clustered cache 'myreplicatedcache' is replicated in local cache 'mycache' with cache sync dependency. Any change in clustered cache will automatically remove dependent item in local cache.
Note that for cache sync dependency, item must exist in cache before another item can be added with dependency on it.
try
{
Cache cache1 = NCache.InitializeCache("mycache");
Cache cache2 = NCache.InitializeCache("myreplicatedcache");
Product product=new Product();
product.ProductID=1001;
product.ProductName="Chai";
string key="Product:"+product.ProductID;
cache1.Insert(key,product);
CacheSyncDependency dependency = new CacheSyncDependency("mycache",key);
CacheItem cacheItem = new CacheItem(cache1.Get(key));
cacheItem.SyncDependency = dependency;
cache2.Insert(key, cacheItem);
//Removing/Deleting item from cache1 will expire it from cache2 as well
catch (OperationFailedException e)
{
// handle exception if any cache operation fails
}
See Also
Cache Dependencies Overview | Custom Dependency | Synchronizing Cache with Relational Database | Adding Data with File and Key Dependencies | Synchronizing Cache with Custom Data Sources | Add Dependency to the Existing Cached Item | Aggregate Cache Dependency


Topic: Synchronizing Cache with Relational Database

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Synchronizing Cache with Relational Database

NCache provides feature of database dependency for the purpose of synchronizing cache with database. When using cache with the database, data in cache has to always be synchronized with the database. This is because the cache is keeping a copy of the data that already exists in the database.
In This Section
Using SQL Dependency
Explains how to use SQL dependency feature for the purpose of synchronizing cache with Microsoft SQL Server 2005/2008.
Using Oracle Dependency
Explains how to use Oracle dependency feature for the purpose of synchronizing cache with Oracle database.
Using Polling Based Dependency
Explains how to use polling based dependency to synchronize cache with databases who don't provide notifications feature.
Using CLR Procedures to Call NCache
Explains how to write CLR stored procedures for database to synchronize cache with the database.


Topic: Synchronization Mode

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Synchronization Mode

There are two synchronization modes for a client cahe.
  • Optimistic
  • Pessimistic
Optimistic Synchronization
In optimistic mode, application fetches data from client cache despite the fact that data is updated or not. It assumes that data is newer in client cache. In optimistic synchronization, updates are propagated to the client cache using event notifications.
Pessimistic Synchronization
Pessimistic mode is used when applications are handling sensitive data. On data fetch request, if data is found in client cache, its version is matched with item on remote cache. If both versions are same, then item is returned otherwise updated item is fetched from remote cache and is updated back to client cache.
These modes can be configured as follows:
Using NCache Manager
  • Click client node IP under Client Nodes in Cache Explorer. Client specific settings in tabbed view shown in right pane.
  • Go to Settings tab and select any one option Optimistic or Pessimistic from Sync Mode Drop Down list.
  • Click on Enable Client Cache option in the right click menu. Client cache becomes disabled for all the client nodes, currently listed under Client nodes in Cache Explorer. Grey square sign on client node indicates a disabled client cache.
  • Right click on cache name in Cache Explorer and select Apply Configuration option.
See Also
Configuring Caches | Create Caches | Adding Client Node in a Cache Cluster | Configuring Client Node Settings | Client Cache Size | Isolation Level | Creating Client Cache | Enable Client Cache


Topic: Tagging Cached Data

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Tagging Cached Data

NCache provides with the facility of Tags which act as identifying marks for the cache items. Through tags, the user can associate string keywords(s) with cache items. You can also search and remove items from the cache by specifying tags.
Creating Tags
Tag is a class provided by NCache. This class can be used to associate tags with a particular data.
Tags are case sensitive.
// Create a Tag array and specify tags.
Tag[] productTags= new Tag[2];
productTags[0] = new Tag("Product");
productTags[1] = new Tag("Beverages");
Adding Items to Cache with Tags
In this example Add Operation overload is used to associate tags that were previously created.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" + product.ProductID;
try
{
cache.Add(key, product, productTags);
}
catch (OperationFailedException ex)
{
// handle exception
}
Tagging Data through CacheItem
In this example tags are set by assigning them as a property of CacheItem.
CacheItem cacheItem = new CacheItem(product);
cacheItem.Tags = productTags;
try
{
cache.Add(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving Previously Tagged Data
  • Retrieving Keys Associated with a Tag
//For finding keys related to one tags
ICollection keys = cache.GetKeysByTag(productTags[0]);
//For Finding keys containing at least any one tag from tag list.
ICollection keys = cache.GetKeysByAnyTag(productTags);
//For finding keys containing all tags from tag list.
ICollection keys = cache.GetKeysByAllTags(productTags);
  • Retrieving Keys from Cache Containing Tag
//For finding keys and values related to one tag.
Hashtable result = cache.GetByTag(productTags[0]);
//For finding keys and values containing at least any one tag in the tag list
Hashtable result = cache.GetByAnyTag(productTags);
//For finding keys and values related to all tags from the tag list
Hashtable result = cache.GetByAllTags(productTags);
  • Querying Cached Items with respect to Tags
Hashtable queryValue = new Hashtable();
//Add items to cache containing tags in ArrayList if multiple tags value is required.
ArrayList queryTagList = new ArrayList();
queryTagList.Add("Product");
queryTagList.Add("Beverages");
// Add tag list to Hashtable for query searching values.
queryValue.Add("$Tag$", queryTagList);
try
{
//Query string, for searching Cache items with respect to Tags.
ICollection keysResultSet = cache.Search("SELECT Product WHERE this.$Tag$=? AND this.$Tag$=?", queryValue);
// keysResultSet contains all keys related to both tags.
}
catch (OperationFailedException ex)
{
// handle exception
}
Here the user needs to specify the fully qualified name of custom class instead of 'Product' in the query string. Only .NET clients can use System.String or System.Int32 etc related to cache value types.
  • Removing Items from Cache Containing Tag
//For removing keys containing specified tag
cache.RemoveByTag(productTags[0]);
//For removing keys containing at least one tag from tags list.
cache.RemoveByAnyTag(productTags);
//For removing keys containing all tags from list
cache.RemoveByAllTags(productTags);
See Also
Tags Overview | Named Tags | Group/Subgroup | Object Query Language (OQL) in NCache | Server Side API Programming


Topic: Tags

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Tags

NCache provides a feature known as Tags to associate keyword with data stored in cache. This section describes what are tags and how can they be used in NCache.
In This Section
Overview
Explains the basic concept and do's and dont's of tags in NCache
Tagging Cached Data
Explains how to use tagging feature in NCache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

Using Tags, keywords(s) can be associated with cache items. Data can be marked with tags which act as identifiers for cache items. For instance in an online library there are different genres of books, for each different category a tag identifier can be added. Tags for authors, year of publication etc. can also be added. Note here that a single author can have two books written under two different categories. And also multiple different authors may have publications in the same year, thus cache search can be made for each tag filter separately i.e. for all publications in year 2000 or for all publications of JohnKeats, etc. These filter tags can be used in combination with each other like all publications of John Keats in year 2000.
Retrieve/Remove using Tags: These identifying marks can help the user in finding and/or removing items from the cache.
Support for Multiple Tags: More than one keyword with any cache item.
Many-to-Many Grouping: Tags provide a many-to-many grouping where one tag can contain multiple cached items and one cached item can belong to multiple tags. NCache provides a Tag class in which the user can specify one or more tags associated with cached items.
Case Sensitive: Tags are case sensitive.
Query using Tags: NCache also supports tags in queries.
For example if the user tags your cache item with a list of tags i.e. “bookinformation” having tags like author, yearofpublication category, the items can be fetched through API which matches with any one tag (e.g., Book where author or yearofpublication or category is matched) from the list or the items can be fetched where all tags (e.g., book where author and yearofpublication and category are matched) in list match. Furthermore, the cache can also be searched on the basis of only one tag (i.e. only author is a match). Items can also be removed from cache on the basis of these marks of identification. The same filters of tags can be used for removal of items. These different filters can be used according to specific business needs.
See Also
Tagging Cached Data | Group/Subgroup | Named Tags | Object Query Language (OQL) in NCache | Server Side API Programming


Topic: Troubleshooting Client Socket Deadlock

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Troubleshooting Client Socket Deadlock

You may experience a deadlock situation on your client socket because of a long wait for a response from the cache server. This may also result in a lot of waiting threads that may cause performance issues. To resolve this problem, please follow these steps:
Step1: Changes on Server Side
  • Go to Alachisoft.NCache.Service.exe.config located at
    %INSTALLATION_PATH%/NCache/bin/service/Alachisoft.NCache.Service.exe.config
  • Add the following lines in the configuration file:
<add key = "NCacheServer.EnableBadClientDetection" value = "true" />
The value "true" indicates that BadClientDetection is enabled on your client socket. This means that now if a deadlock situation arises on your client socket, the socket will be reset. The default value of this property is "false".
<add key = "NCacheServer.ClientSocketSendTimeout" value = "10" />
When you have enabled BadClientDetection, you can specify the time interval after which the socket is reset in case of a deadlock. The default value of this property is "10" and this value can not be less than 1.
A few other properties have also been introduced in Alachisoft.NCache.Service.exe.config to help with this issue. Please configure these properties as follows:
<add key ="NCacheServer.EventPriorityRatio" value="30"/>
On the server-side a priority queue is used for events and cache operations. You can configure a ratio of events and cache operations for this queue through the property called EventPriorityRatio. The default value of this property is 30 which indicates a ratio 30:70 for events and cache operations. The value of this property can not be less than 1.
<add key ="NCacheServer.EventBulkCount" value="50"/>
The cache server now sends events to clients in bulk. Through this property you can set the number of items to be sent in bulk. By default this value is 50 and the value can not be less than 1. This is available in client version 4124 and above.
<add key ="NCacheServer.EventBulkCollectionInterval" value="2"/>
This property is used to set the time interval, in seconds, after which bulk of events is fired even in case the bulk count does not reach the EventBulkCount that the user has specified. Default value for this property is 2 seconds and the value can not be less than 1.
  • Restart the NCache service for these changes to take effect.
Step2: Changes on Client Side
  • Please make the following changes in your app.config/web.config file:
<configuration>
<appSettings>
<add key ="NCacheClient.AsynchronousEventNotification" value="true"/>
<add key ="NCacheClient.NumberofEventProccesingThreads" value="2"/>
</appSettings>
</configuration>
  • AsychronousEventNotification: Specifies whether events will be fired asynchronously or synchronously on client side. The default value is "true" which indicates that events will be fired asynchronously. The value "false" means that events will be fired synchronously on client side.
  • NumberofEventProcessingThreads: When the user has configured events to be fired synchronously, this flag is used to specify the number of threads which will process these events on client side. A very large value can cause performance issues.


Topic: Troubleshooting

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Troubleshooting

This section is intended as a quick reference for error codes, messages, and symptoms generated by NCache, and provides a summary of the likely problem. Refer to the following section to find details about symptoms and workarounds.
In This Section
Implementing Clusters
Provides help to troubleshoot the problems related to cluster implementation.
Using NCache Client API
Provides help to troubleshoot the problems related to NCache Client API.
Using Security
Provides help to troubleshoot the problems that may arise when using NCache security.
Viewing Statistics
Provides help to view remote server statistics.
Installing NCache
Gives workarounds of the problems that may arise during NCache installation process.


Topic: Troubleshooting Common Install/Uninstall Problems

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Troubleshooting Common Install/Uninstall Problems

While running some command line tools, you might encounter the following exception:
"NCache Java Client unable to fetch network usage: Sigar Native libraries not found, please provide java.library.path to JVM pointing to NCHOME/lib/resources/Sigar"
NCache Java Client uses some external resources such as Sigar. When the Path variable is not set to the location of Sigar, you get the above exception as the required library files cannot be found.
Workaround
You can set the path to Sigar resources through the following command:
export PATH=/opt/ncache/lib/resources/Sigar/
See Also
What is NCache Java Client? | Getting Startedl | Installation Steps for UNIX | Post Installation Client/Server Configuration UNIX | Uninstall NCache Java Client from UNIX


Topic: Troubleshooting Scripts

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Troubleshooting Scripts

The InstallNCache and UnInstallNCache scripts internally uses methods of Win32_Product class. If you got any error related to this class during script execution, it means that Win32_Product class is not installed on that machine.
On Windows 2003 the Win32_Product class some times isn't installed by default. You can install it with Add/Remove Windows Component.
Steps for Installing Win32_Product class :
Step 1:
Go to Add/Remove Windows Components.
Step 2:
Look for the "Management and Monitoring Tools". If it is uncheck, make it checked. Click on Details Button.
Step 3:
Look for the "WMI Windows Installer Provider". Make it checked. Click OK.
See Also
Configuring PowerShell Environment | Remote Installation/Uninstallation | Activate NCache


Topic: Two Active Nodes Situation

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Both Nodes in a Mirror Cache appear as Active in NCache Manager

On starting a mirror cache, situation may arise where both nodes are shown as active in NCache Manager. This means that nodes could not join with each other. It is not a mirror cache cluster instead two different mirror caches are running on each node.
Workaround
To resolve this problem see how to resolve the nodes not joining issue .
See Also
Multiple Network Cards | Compact serialization exception | Blocked node communication due to firewall | Out of memory problem | Nodes in a clustered cache are not joining with each other


Topic: Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)

This error can occur when remote monitoring is not enabled on the server nodes that are running the Windows XP operating system.
Workaround
Use the following steps to enable remote monitoring:
  • Open Windows Explorer on the target Windows XP computer.
  • Choose 'Tools' -> 'Folder Options'.
  • Click the 'View' tab.
  • Clear the 'Use Simple File Sharing' check box, and click 'OK'.
  • Verify privileges on the target Windows XP computer as described in Microsoft Knowledge Base article# Q300702 .
  • If the systemroot is on an NTFS partition, you must have at least READ access to the following two files:
  • %SystemRoot%/System32/Perfc009.dat
  • %SystemRoot%/System32/Perfh009.dat
  • You must have at least READ access to the following registry keys on the remote computer:HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/SecurePipeServers/winreg
  • HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Perflib
  • Reboot Windows XP computer.
A user that has administrator rights for the remote computer can also view remote counters.
In windows 7 if you are still unable to view counters of a remote server then enable "File, Folder and network sharing" options.
Follow steps given below
  • Go to Control panel, select "Network and Sharing center"
  • Click "Change Advanced Sharing Settings"
  • Under the Network discovery option select "Turn on network discovery"
  • Under the File and printer sharing option select "Turn on file and printer sharing"
  • Under the Public folder sharing option select "Turn on sharing so anyone with network access can read and write files in Public folders"
  • Then click Save changes, as shown in figure below.
See Also
Diskperf Not Installed | No READ Access to Perflib Subkeys | Troubleshooting Counters


Topic: Uninstall NCache Java Client from UNIX

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Uninstall NCache Java Client from UNIX

This section describes step-by-step instructions for uninstalling NCache Java Client from UNIX.
In order to uninstall NCache Java Client from your machine, you need to be logged in as root user or as an authorized user like “NCache Java Client”.
Steps
In order uninstall NCache Java Client from your UNIX machine, please follow these steps:
  • Open the terminal and navigate to the directory where you extracted NCache Java Client. Use the command:
[root@servername]# cd ~/NCache-enterprise-4.4-sp1-javaclient
  • In order to uninstall NCache Java Client, enter the following command:
[root@servername]# ./uninstall -p /opt/NCache_install_dir
NCache Java Client is successfully uninstalled from your system. You see the following output:
Stopping Service ...
Removing Service ...
NCache Java Client uninstalled.
User ‘NCache’ created at install time is not deleted. Please use userdel command to remove the user.
For support please feel free to contact support@alachisoft.com
For complete documentation visit the website <http://www.alachisoft.com/resources/docs/index.html>
See Also
What is NCache Java Client? | Getting Started | Installation Steps for UNIX | Post Installation Client/Server Configuration UNIX | Troubleshooting Common Install/Uninstall Problems


Topic: Upgrade NCache without disturbing deployed environment

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Upgrade NCache without disturbing deployed environment

When a newer version of NCache is installed, your code doesn't need to recompile with the most recent version. Now, with each installation of NCache, a publisher policy file is installed. This file redirects all the previous versions of the specified assembly to the newer version. Policy assembly files for various NCache assemblies are as follows:
NCache Assembly | Publisher Policy Assembly
Alachisoft.NCache.Web.dll | policy.<version>.Alachisoft.NCache.Web.dll
Alachisoft.NCache.Runtime.dll | policy.<version>.Alachisoft.NCache.Runtime.dll
Alachisoft.NCache.Cache.dll | policy.<version>.Alachisoft.NCache.Cache.dll
Here <version> is the newer version of NCache. For example, for NCache 4.4.0.0, publisher policy file for Alachisoft.NCache.Web.dll will be Policy.4.4.0.0.Alachisoft.NCache.Web.dll. These policy assembly files are added to the GAC with all other assemblies and are removed at uninstall.
You can also bypass the publisher policy file by specifying 'publisherpolicy' tag in the "App.config" file.
For Enterprise and Professional Editions:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
For Open Source Edition:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
Publisher Policy Assemblies are not shipped along with NCache installation package but can be made available on demand.


Topic: Upgrade NCache without Disturbing Deployed Environment

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Upgrade NCache without Disturbing Deployed Environment

When a newer version of NCache is installed, your code need no longer be recompiled with the most recent version. Now, with each installation of NCache, a publisher policy file is installed. This file redirects all the previous versions of the specified assembly to the newer version. Policy assembly files for various NCache assemblies are as follows:
NCache Assembly | Publisher Policy Assembly
Alachisoft.NCache.Web.dll | policy.<version>.Alachisoft.NCache.Web.dll
Alachisoft.NCache.Runtime.dll | policy.<version>.Alachisoft.NCache.Runtime.dll
Alachisoft.NCache.Cache.dll | policy.<version>.Alachisoft.NCache.Cache.dll
Here <version> is the newer version of NCache. For example, for NCache 4.4.0.0, publisher policy file for Alachisoft.NCache.Web.dll will be Policy.4.4.0.0.Alachisoft.NCache.Web.dll. These policy assembly files are added to the GAC with all other assemblies and are removed at uninstall.
You can also bypass the publisher policy file by specifying 'publisherpolicy' tag in the "App.config" file.
For Enterprise and Professional Editions:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="cff5926ed6a53769" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
For Open Source Edition:-
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Web" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Runtime" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Alachisoft.NCache.Cache" publicKeyToken="1448e8d1123e9096" culture="neutral"/>
<publisherpolicy apply="no"/>
</dependentAssembly>
</assemblyBinding>
</runtime>
</configuration>
See Also
NCache Installation Error 1606 | Installation Error 1721: A Required Program could not be Run | Installation Rolls Back on Windows Vista | NCache Activation Problem


Topic: Usage

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Usage

After successful installation of NCache Manager for Visual Studio extension for the selected version(s)/Edition(s) of Visual Studio, NCache Explorer can be opened by selecting VIEW>Other Windows>NCache Explorer from the Visual Studio’s menu bar.
Opening NCache Explorer:
This will open NCache Explorer tool window, which can be tabbed, docked or closed just like any common tool window of Visual Studio, which will also remember its state even if the Visual Studio gets closed.
The window contains a toolbar which will have listed available operations and a “tree”, kind of a hierarchical structure to show caches and related information. The toolbar’s operations update according to selected item in the tree, operations can also be performed from the right-click menu of an item in the tree.
The root-item NCache Explorer will have Clustered Caches and Local Caches as child-items, each of them will be a parent to the type of cache (Clustered/Local) added. Each item in the tree will have its icon updated according to its state.
A clustered cache type of item will futher have Server Nodes and Client Nodes child-items, which will represent server nodes and client nodes in the cache, where a child-item of Local Cache will represent server node hosting the cache of type Local. Image below is representing a Clustered cache named “myReplicatedCache” and a Local cache name “myCache”.
NCache Explorer tool window:


Topic: Using ASP.NET Output Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using ASP.NET Output Cache
This feature is not available in NCache Express and Professional edition.
Here if the same cache is being used for output caching and for other data, output cache data can be retrieved by "NC_ASP.net_output_data" tag. With this tag it is easy to find data specific to output caching data.
Hashtable allOutputCacheData = cache.GetByTag(new Alachisoft.NCache.Runtime.Caching.Tag("NC_ASP.net_output_data"));
Plug-in NCache Output Cache to Existing Web Applications
In web.config of your application, under the section of system.web element add NCache provider as a default provider i.e.,
For Enterprise and Professional Editions:-
<!-- caching section group -->
<caching>
<outputCache defaultProvider ="NOutputCacheProvider">
<providers>
<add name="NOutputCacheProvider" type= "Alachisoft.NCache.OutputCacheProvider.NOutputCacheProvider, Alachisoft.NCache.OutputCacheProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=cff5926ed6a53769" cacheName="mypartitionofReplicaCache" exceptionsEnabled="false" enableDetailLogs="false" enableLogs="true" writeExceptionsToEventLog="false"/>"
</providers>
</outputCache>
</caching>
For Open Source Edition:-
<!-- caching section group -->
<caching>
<outputCache defaultProvider ="NOutputCacheProvider">
<providers>
<add name="NOutputCacheProvider" type= "Alachisoft.NCache.OutputCacheProvider.NOutputCacheProvider, Alachisoft.NCache.OutputCacheProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=1448e8d1123e9096" cacheName="mypartitionofReplicaCache" exceptionsEnabled="false" enableDetailLogs="false" enableLogs="true" writeExceptionsToEventLog="false"/>"
</providers>
</outputCache>
</caching>
Replace version “x.x.x.x” with the actual NCache version that you have.
Configuration Members
Members | Description
cacheName | Requires string parameter. Specifies the name of the cache that have been configured through NCache Manager. The application will use this cache for caching specified pages. If no cache name is specified, a configuration exception will be thrown.
exceptionsEnabled | Optional Boolean attribute. Specifies whether exceptions from cache API are propagated to the page output. Setting this flag is especially helpful during development phase of application since exceptions provide more information about the specific causes of failure. The default value is false.
enableLogs | Optional Boolean attribute. When this flag is set, all important events are logged including exceptions, cache initialized, disposed, and session not found etc. The default value is false.
enableDetailLogs | Optional Boolean attribute. When this flag is set, the information that is useful for debugging purposes will be included in logs. The default value is false.
Using Output Cache with Custom Hooks
Using NCache output provide,r output of pages and controls is stored in cache.In some scenarios it can be very helpful if the page/control output can be grouped according to some x.y.z criteria before insertion into cache.Here to provide end user with further more control, NCache provides a concept of “hooks”. Hooks allow users to group output of pages/controls before its insertion into cache.
Following configuration changes are required:
<!-- caching section group -->
<caching>
<outputCache defaultProvider="NOutputCacheProvider">
<providers>
<add name="NOutputCacheProvider" type="Alachisoft.NCache.OutputCacheProvider.NOutputCacheProvider, Alachisoft.NCache.OutputCacheProvider, Version=x.x.x.x, Culture=neutral, PublicKeyToken=null" exceptionsEnabled="false" enableLogs="true" cacheName="mypartitionofReplicaCache" writeExceptionsToEventLog="false" hookAssemblyName="OutputCache, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" hookClassName="Sample.OutputCacheProvider.OutputCacheHook.OutputCacheHookSample"/>
</providers>
</outputCache>
</caching>
Replace version “x.x.x.x” with the actual NCache version that you have.
How to Implement IOutputCacheHook
Output Cache with custom hooks allows grouping data before storing into cache.To implement IOutputCacheHook, create a class which extends IOutputCacheHook. The following tables list the properties and methods that must be implemented.
Methods
Description
Initialize
Initializes required elements of Output Cache hook.
OnCachingOutput
Takes as input the HttpContext instance for the current request,string key and object value generated by framework for output are passed as is as input parameter. Input parameter CacheOperation type can be added or set, with respect to Output Cache Provider operations of add and set. DateTime utcExpiry is passed as a reference parameter which allows end user code to reset expiration for particular key value pair. If the value for expiration is not set, the default value provided by framework is used.
This method returns CacheMetadata which can have additional information about group, sub group, tag, named tag and dependency settings.
This method functions as a hook between OutputCache Provider and user code, it is called when output is generated by framework but before insertion into Cache thus allowing intermediate hook for user, where additional information can be added with CacheMetadata.
Dispose
It releases resources which are no longer in use by Output Cache hook.
Sample OutputCacheHook
public class OutputCacheHookSample : IOutputCacheHook
{
public void Initialize()
{
// initialize required elements here, according to business logic.
}
public CacheMetadata OnCachingOutput(System.Web.HttpContext context, string key, object value, CacheOperation operation, ref DateTime utcExpiry)
{
CacheMetadata cacheMetaData = null;
if(context != null)
{
cacheMetaData = new CacheMetadata();
// put required business logic to categorize input parameter key in //desired group. Groups, sub groups, tags, named tags and dependencies //can be assigned to object of cacheMetaDatawhich then is returned to be //inserted into cache.
cacheMetaData.GroupName = "vendorState";
cacheMetaData.Dependency = new KeyDependency(key);
utcExpiry = DateTime.Now.AddMinutes(5);
}
return cacheMetaData;
}
public void Dispose()
{
}
}
Add Alachisoft.NCache.OutputCacheProvider.OutputCacheHook.dll in the project from %NCache installed dir% \integration\OutputCacheProvider
See Also
ASP.NET Output Cache Overview | ASP.NET Sessions | ASP.NET Sessions | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations


Topic: Using Asynchronous Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Asynchronous Operations
In case of failure for asynchronous operation, server will not throw any exception.
Basic Asynchronous Operations
  • Adding Data to Cache Asynchronously
Data can be added to NCache asynchronously using AddAsync method.
In this example an object is added to the cache asynchronously.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" + product.ProductID;
try
{
cache.AddAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
  • Updating Data to Cache Asynchronously
An InsertAsync method enables the user to update existing data in the cache in an asynchronous manner.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.Category = 5; // updated category
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
try
{
cache.InsertAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
  • Removing Data from Cache Asynchronously
In case a user wants to perform a remove operation in the background, a RemoveAsync operation can be used to perform that operation. In this example, the key for the data that needs to be removed must be specified.
String key= "Product:1001";
try
{
cache.RemoveAsync(key, null, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
  • Clearing the Cache Asynchronously
To clear cache completely in background, ClearAsync method needs to be called.
try
{
cache.ClearAsync(null);
}
catch (Exception ex)
{
// handle exception
}
Using Asynchronous Callback Method
Since asynchronous operations do not notify upon the failure or success of the operation themselves, NCache provides a callback mechanism which can be registered while making operation call. These callbacks are triggered upon completion of the operation. Callbacks are integral in tracking operations.
In case of failure for asynchronous operation, server will not throw any exception but, with Async callback, user can know the status.
  • Adding Data with Registered Callback Method
AsyncItemAddedCallback are provided by NCache which can be registered with an asynchronous addition method. It allows the user to perform appropriate functions upon completion of the operation.
In this example, an ItemAddedCallback provided by NCache needs to be registered with an AddAsync call.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
cacheItem.AsyncItemAddCallback += new AsyncItemAddedCallback(OnItemAdded);
string key = "Product:" +product.ProductID ;
try
{
cache.AddAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
public void OnItemAdded(string key, object status)
{
if (status.ToString().Equals("Success"))
{ //do something
}
if (status.ToString().Equals("Failure"))
{ //do something
}
if (status is Exception)
{ //do something
}
}
  • Updating Data with Registered Callback Method
AsyncItemAddedCallback are provided by NCache which can be registered with an asynchronous addition method. It allows the user to perform appropriate functions upon completion of the operation.
In order to get a notification upon execution of an update operation, AsyncItemUpdatedCallback need to be registered with InsertAsync operation. It is demonstrated in the example below.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.Category = 5; // updated category
CacheItem cacheItem = new CacheItem(product);
cacheItem.AsyncItemUpdateCallback += new AsyncItemUpdatedCallback(OnItemUpdated);
string key = "Product:" +product.ProductID ;
try
{
cache.InsertAsync(key, cacheItem, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
public void OnItemUpdate(string key, object status)
{
if (status.ToString().Equals("Success"))
{ //do something
}
if (status.ToString().Equals("Failure"))
{ //do something
}
if (status is Exception)
{ //do something
}
}
  • Removing Data with Registered Callback Method
NCache provides AsyncItemRemovedCallback to be used in order to receive notification upon completion of item removal. In this example you need to register the above mentioned callback with NCache to receive a notification.
string key= "Product:1001";
try
{
cache.RemoveAsync(key, new AsyncItemRemovedCallback(OnItemRemoved), DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
public void OnItemRemove(string key, object status)
{
if (status.ToString().Equals("Success"))
{ //do something
}
if (status.ToString().Equals("Failure"))
{ //do something
}
if (status is Exception)
{ //do something
}
}
  • Clearing Cache with Registered Callback Method
AsynccacheClearedCallback if registered with NCache is triggered whenever a ClearAsync operation is performed successfully. In this example, the user needs to register the callback when calling the method.
try
{
cache.ClearAsync(new AsyncCacheClearedCallback(OnCacheCleared));
}
catch (OperationFailedException ex)
{
// handle exception
}
// Create a callback
void OnCacheCleared(object result)
{
if (result.ToString().Equals("Success"))
{ //do something
}
if (result.ToString().Equals("Failure"))
{ //do something
}
if (result is Exception)
{ //do something
}
}
See Also
Asynchronous Operations Overview | Bulk Operations | Server Side API Programming


Topic: Using Bulk Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Bulk Operations

Using bulk operations is handy if the user wants to work with collection of items.
This feature is not available in NCache Express and Professional edition.
NCache has multiple bulk API operations. The following operations can be performed in bulk:
  • Add
  • Insert
  • Get
  • Remove
  • Delete
Here users are supposed to provide unique keys for all bulk operations. Keys[] count has to be equal to items[] count.
Adding a Collection to Cache
A collection of items can be added in cache using AddBulk method. This method returns a dictionary of all the keys that failed to be added along with the exception.
Product product1 = new Product();
product1.ProductID = 1001;
product1.ProductName = "Chai";
product1.UnitsInStock = 15;
string key1="Product:"+product1.ProductID;
Product product2= new Product();
product2.ProductID = 1002;
product2.ProductName = "Chang";
product2.UnitsInStock = 25;
string key2="Product:"+product2.ProductID;
string[] keys = { key1, key2 };
CacheItem[] items = new CacheItem[2];
items[0] = new CacheItem(product1);
items[1] = new CacheItem(product2);
try
{
IDictionary result = cache.AddBulk(keys, items, DSWriteOption.None, null);
}
catch (Exception ex)
{
// handle exception
}
Updating a Collection to Cache
An existing collection of items can be updated with the help of InsertBulk method.
Product product1 = new Product();
product1.ProductID = 1001;
product1.ProductName = "Chai";
product1.UnitsInStock = 5; //updated units
string key1="Product:"+product1.ProductID;
Product product2= new Product();
product2.ProductID = 1002;
product2.ProductName = "Chang";
product2.UnitsInStock = 6; //updated units
string key2="Product:"+product2.ProductID;
string[] keys = { key1, key2 };
CacheItem[] items = new CacheItem[2];
items[0] = new CacheItem(product1);
items[1] = new CacheItem(product2);
try
{
cache.InsertBulk(keys, items, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving a Collection from Cache
For fetching a collection from cache, use the GetBulk method. This method returns the collection of items.
string[] keys = { "Product:1001", "Product:1002" };
try
{
IDictionary items = cache.GetBulk(keys, DSReadOption.ReadThru);
if (items.Count > 0)
{
IEnumerator iter = items.Values.GetEnumerator();
while (iter.MoveNext())
{
Product info = (Product)iter.Current;
// do something
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Removing a Collection from Cache
Just like atomic remove operation, RemoveBulk also removes all cached items in list and returns removed items. Here it is returned in the form of a dictionary. Following is a code example for remove bulk operation:
string[] keys = { "Product:1001", "Product:1002" };
try
{
IDictionary removedItems = cache.RemoveBulk(keys, DSWriteOption.None, null);
foreach (DictionaryEntry entry in removedItems)
{
if (entry.Value is Product)
{
// do something
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Deleting a Collection from Cache
Following is a code snippet for DeleteBulk. This method can be used to delete multiple items from cache in a single bulk call.
string[] keys = { "Product:1001", "Product:1002" };
try
{
cache.DeleteBulk(keys, DSWriteOption.None, null);
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Bulk Operations Overview | Add/Update Data to Cache | Fetch Data from Cache | Remove Data from Cache | Asynchronous Operations | Cache Topologies


Topic: Using Cache Dependencies

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Cache Dependencies

This section explains in detail how to use different cache dependencies using NCache Client API.
In This Section
Adding Data with File and Key Dependencies
Explains how to add data using file and key dependency.
Synchronizing Cache with Relational Database
Explains how to use database dependency for the purpose of synchronizing cache with database.
Synchronizing Cache with Custom Data Sources
Explains how the user can write his own dependency scenarios and use the feature of custom dependency.
Synchronize Data across Multiple Caches
Explains how to synchronize data among different caches to ensure data integrity.
Add Dependency to the Existing Cached Item
Explains how cache dependency can be added to an existing item without any need to update it.
Aggregate Cache Dependency
Explains how to add multiple dependencies with a single cache item.


Topic: Using Cache Item Versioning

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Cache Item Versioning

CacheItemVersion adds an additional dimension to the development of application using NCache. Optimistic Concurrency can be achieved in applications by NCache Item Versioning.
When any item is added in cache, cache item version is returned to the cache client. This value denotes the number of updates performed on a particular data. With every update, item version value is incremented.
Saving Item Version for the First Time
An add operation returns CacheItemVersion. If the item is added for the first time ‘1’ is returned. This version will be used in future operations on this key.
In this example a custom data with key “Product:1001” is added in cache and its item version is saved. However, it should be ensured that the object is either .NET serialized or registered with NCache Compact serialization framework.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
CacheItemVersion itemVersion = cache.Add(key, product);
//Save this item Version for future utilization
}
catch (OperationFailedException ex)
{
// handle exception
}
Updating Item with Specific Version
In environments where multiple applications work on a single cache, item version can be used to ensure that the data which is updated is the same as in cache and is not updated priorily by any other cache client.
In this example, a previously cached item is upated by specifying item version. If the specified version is equal to the one in the cache, then it will be updated else OperationFailedException will be thrown by NCache.
//precondition: itemVersion is saved when item was added in cache
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
product.Category = 5; // updated category
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
//saved itemVersion from add item call
cacheItem.Version=itemVersion;
try
{
CacheItemVersion newVersion = cache.Insert(key, cacheItem);
//save new version for future usage
//verify the updated version and value in cache
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving Cached Item with Specific Version
A cached item can be retrieved by specifing version. In case of a mismatch of version, null is returned.
In this example, key and the previously saved item version of that key needs to be specified to fetch the cached object.
//precondition: itemVersion is saved when item was added or inserted in cache
try
{
string key="Product:1001";
//saved itemVersion from add or insert item call
CacheItem result = cache.GetCacheItem (key,ref itemVersion);
if (result.Value != null)
{
if (result.Value is Product)
{
Product product = (Product)result.Value;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Retrieving Item if a Newer Version Exists in Cache
GetIfNewer method can be used to fetch the existing item if a newer version is available in cache. By specifying the current version as an argument of the method, cache returns the appropriate result.
If the version specified is less than the one in cache, only then the method returns a new Item else null would be returned.
//precondition: itemVersion is saved when item was added or inserted in cache
string key="Product:1001";
try
{
//saved itemVersion from add or insert item call
object result = cache.GetIfNewer(key,ref itemVersion);
if (result != null)
{
if (result is Product)
{
Product product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Removing an Item with a Specific Item Version
A remove method is a basic method which removes the key from cache and returns the removed object to cache. If custom object is added to cache, remove method will return Object.
If the item version is different from the one in cache or if the key does not exist an OperationFailedException will be thrown by NCache.
//precondition: itemVersion is saved when item was added or inserted in cache
string key="Product:1001";
try
{
//saved itemVersion from add or insert item call
object result = cache.Remove(key,itemVersion);
if (result != null)
{
if (result is Product)
{
Product product = (Product)result;
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Deleting an Item with Item Version
A delete method is a basic method which deletes the key from cache. If the item version is different from the one in cache or if the key does not exist, an OperationFailedException will be thrown by NCache.
//precondition: itemVersion is saved when item was added or inserted in cache
string key="Product:1001";
try
{
//saved itemVersion from add or insert item call
cache.Delete(key,itemVersion);
}
catch (OperationFailedException ex)
{
// handle exception
}
See Also
Locking Overview | Locking Items in Cache | Data Invalidation Strategies | Cache Dependencies | Server Side API Programming


Topic: Using Cache Startup Loader

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Cache Startup Loader
This feature is not available in NCache Express and Professional edition.
Namespace
For enabling Cache Startup Loader, your program needs a reference of the assembly Alachisoft.NCache.Runtime.dll that contains interface Alachisoft.NCache.Runtime.CacheLoader.ICacheLoader provided by NCache. The class implementing this interface allows framework to load data from the master datasource in the cache. Thus, the class needs to include the logic for loading the data from the datasource.
Following namespaces are required in your project for using ICacheLoader:
using Alachisoft.NCache.Runtime.CacheLoader;
using Alachisoft.NCache.Runtime.Caching;
ICacheLoader Interface:
In order to use ICacheLoader in your application, implement the following interface:
public void Init(System.Collections.IDictionary parameters);
public bool LoadNext(ref System.Collections.Specialized.OrderedDictionary data, ref object index);
public void Dispose();
Member | Description
Init | This method is called by NCache framework on cache startup.This method takes as input a dictionary of parameters which can be passed while configuring cache loader through NCache Manager. Please refer to how to configure cache loader section for details. Through this input parameter, runtime parameters to your deployed provider like connection strings etc can be specified. In this method tasks such as allocating resources, acquiring connections etc can be performed. The main concept of this method is to provide user with a starting point where he/she can initialize the data source settings before loading the data from it.
Dispose | This method is called by NCache framework on cache stop.The purpose of this method is to release resources that may be in use during loading data from data source to the cache.For example, when cache is stopped or LoadNext returns false, then this method can be implemented to close its connection with the datasource and dispose all resources in use.
LoadNext | This method is called by NCache framework on cache startup after init method. This method should contain the logic to load object(s) from the master data source. This method accepts a System.Collections.Specialized.OrderedDictionary which is to be populated bythe data being collected from the data source and an object which indicates the index. Both these parameters are passed by reference. The data loaded in the dictionary would be loaded in the cache and the index can be used to track the index if data is added in chunks. Please note that this method can contain the logic for returning one item at a time or multiple items in a chunk as it is called iteratively by NCache until it keeps returning false. Index can be used to control the size of the chunks being extracted from the data source. The user needs to make sure that the method returns true when the all the data has been added into the dictionary or else it will form an infinite loop.
Enabling Cache Startup Loader
To enable startup loader, please see Configuring Cache Startup Loader
Implementing Cache Startup Loader
public class CacheLoader : ICacheLoader
{
private SqlConnection connection;
//initialize your data source setting here
public void Init(System.Collections.IDictionary parameters)
{
string connString = parameters["connectionString"].ToString();
connection = new SqlConnection(connString);
connection.Open();
}
//Load data from source
public bool LoadNext(ref System.Collections.Specialized.OrderedDictionary data, ref object index)
{
int nextIndex = 0;
if (index != null)
{
nextIndex = (int)index;
}
SqlCommand command = new SqlCommand("SELECT * FROM Products WHERE ProductID > " + nextIndex.ToString() + " AND ProductID< " + (nextIndex + 10).ToString());
SqlDataReader reader = command.ExecuteReader();
if (!reader.HasRows)
return true;
while (reader.Read())
{
Product product = new Product();
product.ProductID = Convert.ToInt32(reader["ProductID"].ToString());
product.ProductName = reader["ProductName"].ToString();
product.Category = reader["Category"].ToString();
ProviderCacheItem provideritem = new ProviderCacheItem(product);
data.Add("Product:" + product.ProductID, provideritem);
}
index = nextIndex + 10;
reader.Close();
return false;
}
//Dispose your data source resources here
public void Dispose()
{
if (connection != null)
connection.Close();
}
}
See Also
Cache Startup Loader Overview | Configuring Cache Startup Loader | Data Source Provider (Backing Source) | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Using Compact Serialization

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Compact Serialization

To use compact serialization, object types that are to be compact serialized need to be configured through NCManager. NCache internally handles serialization/deserialization of registered classes and the user doesn’t need to explicitly code for it.
However, NCache also allows to explicitly implement ICompactSerializable interface provided in
Alachisoft.NCache.Runtime.Serialization.ICompactSerializable
To implement this interface, the custom object class needs to implement Serialize/Deserialize methods which will be called by NCache while serializing/deserializing this object. Sample code for implent this interface is given below:
//Sample code for custom ICompactSerializable class
public class CustomObject : ICompactSerializable
{
private string _attribute1;
private int _attribute2;
private bool _attribute3;
public CustomObject()
{ }
public CustomObject(string attrib1, int attrib2, bool attrib3)
{
_attribute1 = attrib1;
_attribute2 = attrib2;
_attribute3 = attrib3;
}
#region ICompactSerializable Members
public void Deserialize(Runtime.Serialization.IO.CompactReader reader)
{
_attribute1 = reader.ReadObject() as string;
_attribute2 = reader.ReadInt32();
_attribute3 = reader.ReadBoolean();
}
public void Serialize(Runtime.Serialization.IO.CompactWriter writer)
{
writer.WriteObject(_attribute1);
writer.Write(_attribute2);
writer.Write(_attribute3);
}
#endregion
}
Care should be taken that class attributes are deserialized in the same order in which they are serialized otherwise serialized stream won’t be deserialized.
Implementing a Generic Type Handler
NCache also allows registering generic types in compact serialization. For this, each type needs to be registered through NCManager. There is another way for registering generic compact types through "Generic Type Handler". With Generic Type Handler, the user can add all the generic types at once by implementing the IGenericTypeProvider interface from Alachisoft.NCache.Runtime.GenericTypesProvider. This saves a lot of time and effort in case the user wants to register a large number of types.
To implement this, the user needs to implement GetGenericTypes method and return the desired generic types in Type array. After this, deploy this class assembly to NCManager. NCManger will register all types populated in Type array. Sample code is given below:
using Alachisoft.NCache.Runtime.GenericTypesProvider;
namespace CompactSerialization
{
public class CustomGenericType<T,K,V>
{
}
public class SetGenerics : IGenericTypeProvider
{
Type[] allowedGenericTypes = new Type[5];
Type[] IGenericTypeProvider.GetGenericTypes()
{
allowedGenericTypes[0] = typeof(Dictionary<string, Customer>);
allowedGenericTypes[1] = typeof(List<int>);
allowedGenericTypes[2] = typeof(CustomGenericType<Employee, Product, Customer>);
allowedGenericTypes[3] = typeof(CustomGenericType<Employee, Product, int>);
allowedGenericTypes[4] = typeof(CustomGenericType<Employee, string, byte>);
return allowedGenericTypes;
}
}
}
As can be seen in the above example, a list of types are specified which are to be allowed in the generic types for compact serialization.
See Also
Compact Serialization Overview | Registering Classes for Compact Serialization | Cache Startup Loader | Data Source Provider (Backing Source) | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Using Continuous Query

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Continuous Query

Assuming that the searchable attributes are already indexed, the user then needs to implement continous query in his/her application. The first step is to define all the call backs that the user needs to be executed if the result set of the query is changed in any way. Following are the main methods which are provided by NCache and are associated with the implementation of continuous queries.
Methods | Description
RegisterCQ | The main purpose of this method is to activate the user’s continuous query with the cache server. This method can be used multiple times in an application depending on its need to receive the notifications for a change in the dataset of your query. This method takes as argument an object ofContinuousQuery which has the query and the callbacks registered to it.
UnRegisterCQ | UnregisterCQ is used by the application after the user has registered a continuous query to deactivate it on the cache server. Like RecgisterCQ, it takes as argument an object of ContinuousQuery to unregister the callbacks which are no more fired after this call. It is used when the user is no more interested in notifications for changes in a query result set.
SearchCQ | Sometimes the user requires not only to register the continuous query, but also to fetchthe result set associated with that continuous query. For this purpose, one of the methods provided by NCache is SearchCQ.This method takes the object of ContinuousQuery as its argument and returns a collection of keys to your application. These are the keys of objects which are in the result set of the query the CQ is registered to. It also registers the continuous query if it is not already registered. As this method only returns the keys, NCache API calls can be used to fetch the data of the keys which the user wishes to manipulate from the result set. If the result set of user’s query contains the majority items of cache, this approach can result in a large number of network trip, therefore, affecting the performance.
SearchEntriesCQ | The main reason to provide this method is the same as that of SearchCQ, that is, if the user wishes to fetch the result set when registering the continuous query. This method takes the object of ContinuousQuery as argument but, unlike SearchCQ, returns an IDictionary which contains keys as well as the data of the result set of that query. In this case, it is no longer required to fetch data using the keys explicitly, but the data of result set is returned from this call. In situations where the result set of the query is large, this option is better than SearchCQ as it takes only a single network trip to fetch the data set from the cache rather than fetching data against each key separately, as in the case of SearchCQ.
Example Code
class Program
{
static void Main(string[] args)
{
Cache cache = NCache.InitializeCache("mycache");
string queryString = "Select ClassLibrary.Product WHERE this.supplier=?";
Hashtable values = new Hashtable();
values.Add("supplier", "Carlos Diaz");
ContinuousQuery continuousQuery = new ContinuousQuery(queryString, values);
continuousQuery.RegisterNotification(new QueryDataNotificationCallback(ItemAddedCallBack), EventType.ItemAdded, EventDataFilter.None); // register notification for add operation.
continuousQuery.RegisterNotification(new QueryDataNotificationCallback(QueryItemCallBack), EventType.ItemUpdated | EventType.ItemRemoved , EventDataFilter.None); // register notification for update and remove operation.
continuousQuery.RegisterClearNotification(new ContinuousQueryClearCallback(CacheClear)); // register cache clear notification
cache.RegisterCQ(continuousQuery);
Product product = new Product();
product.ProductName = " Chai";
product.Supplier = "Carlos Diaz";
product.Categories = " Beverages";
cache.Add("key", new CacheItem(product)); //this operation trigger add notification.
product.Supplier = "Elio Rossi";
cache.Insert("key", new CacheItem(product)); //trigger remove notification because that key will be removed from the query result set by changing supplier name.
cache.Clear(); //trigger cache clear notification.
cache.Dispose();
}
// Create target methods
static void ItemAddedCallBack(string key, CQEventArg arg)
{
EventCacheItem item = eventArg.Item;
// do something
}
static void QueryItemCallBack(string key, CQEventArg arg)
{
switch (arg.EventType)
{
case EventType.ItemRemoved:
// do someting
break;
case EventType.ItemUpdated:
// do someting
break;
}
}
See Also
Continuous Query Overview | Object Query Language (OQL) in NCache | Configuring Query Indexes | Server Side API Programming


Topic: Using Expirations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Expirations

1. Absolute Expiration
In absolute expiration cached item is removed after absolute interval. This interval starts when an item is added into the cache, and its duration is specified in parameters provided on cache insertion.
If Absolute Expiration is being used, then sliding expiration should be turned off by specifying NoSlidingExpiration parameter.
  • Adding New Data with Absolute Expiration
In this example Add Operation provided by NCache is used to add absolute expiration to item. The expiration is set by using DateTime class. Also if Absolute expiration is used, NoSlidingExpiration is to be specified.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
// adding absolute expiration of 5 min through Add API.
cache.Add(key, product, null, System.DateTime.Now.AddMinutes(5), Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Updating Data with Absolute Expiration
In this example, Insert Operation provided by NCache is used to add/update absolute expiration to item added to the key. The expiration is set by using DateTime class. Also as absolute expiration is being used, NoSlidingExpiration is used for sliding expiration.
try
{
// adding absolute expiration of 5 min through Add API.
cache.Insert(key, product, null, System.DateTime.Now.AddMinutes(5), Cache.NoSlidingExpiration, CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Setting Absolute Expiration with CacheItem
In this example expiration is set by assigning it as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
string key = "Product:" +product.ProductID ;
// Setting Absolute expiration of 10 minutes.
cacheItem.AbsoluteExpiration = System.DateTime.Now.AddMinutes(10);
try
{
cache.Add(key, cacheItem, DSWriteOption.None, null);
}
catch(OperationFailedException ex)
{
// handle exception
}
2. Sliding Expiration
In Sliding expiration, time for item expiration is not fixed. It is an interval between last access time of item and current
time. If this elapsed time interval is equal to defined sliding expiration settings then this item is removed from cache.
As sliding expiration means expire after a period of inactivity and is good for session and other temporary data that
must be removed if not used.
If sliding expiration is being used, the absolute Expiration should be turned off by specifying
NoAbsoluteExpiration .
  • Adding New Item with Sliding Expiration
In this example, Add operation provided by NCache is used to add absolute expiration to item. The expiration is set by using TimeSpan class. Also while using sliding expiration, NoAbsoluteExpiration is used for absolute expiration.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
// adding sliding expiration of 5 sec through Add API.
cache.Add(key, product, null, Cache.NoAbsoluteExpiration,new TimeSpan(0, 0, 5), CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Updating New Item with Sliding Expiration
In this example, Insert operation provided by NCache is used to add/update sliding expiration to item added to the cache. The expiration is set by using TimeSpan class. Also sliding expiration is the selected mode of expiration, NoAbsoluteExpiration is used for absolute expiration.
try
{
// adding sliding expiration of 5 sec through Insert API.
cache.Insert(key, product, null, Cache.NoAbsoluteExpiration,new TimeSpan(0, 0, 5), CacheItemPriority.Normal);
}
catch(OperationFailedException ex)
{
// handle exception
}
  • Setting Sliding Expiration with CacheItem
In this example expiration is set by assigning it as a property of CacheItem.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
CacheItem cacheItem = new CacheItem(product);
// Setting sliding expiration of 10 seconds.
cacheItem.SlidingExpiration = new TimeSpan(0, 0, 10);
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, cacheItem, DSWriteOption.None, null);
}
catch(OperationFailedException ex)
{
// handle exception
}
See Also
Expirations Overview | Eviction | Configuring Expiration Clean Up Interval | Configuring Eviction Policy | Server Side API Programming


Topic: Using Named Tags

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Named Tags

NamedTagsDictionary class will be used to define Named Tags which will be added with the cache items for further use. Only string is allowed as a Named Tag “keys” and primitive data types are allowed as valid Named Tag “values”.
To use the Named Tags,the following namespace should be added in project:
using Alachisoft.NCache.Runtime.Caching;
Creating Named Tags
A NameTagsDictionary is a class provided by NCache so that these tags can be associated with a particular data.
// Creating NameTagsDictionary and adding custom named tags.
NamedTagsDictionary productNamedTag = new NamedTagsDictionary();
productNamedTag.Add("UnitsAvailable", 4);
productNamedTag.Add("Category", 25);
productNamedTag.Add("Supplier", "Alex");
Adding Items to Cache with Named Tags
In this example, Add Operation overload is used to associate named tags previously created.
Product product = new Product();
product.ProductID = 1001;
product.ProductName = "Chai";
string key = "Product:" +product.ProductID ;
try
{
cache.Add(key, product, productNamedTag);
}
catch (OperationFailedException ex)
{
// handle exception
}
Adding Named Tags through CacheItem
In this example, named tags are set by assigning them as a property of CacheItem.
CacheItem cacheItem = new CacheItem(product);
cacheItem.NamedTags = productNamedTag;
try
{
cache.Add(key, cacheItem);
}
catch (OperationFailedException ex)
{
// handle exception
}
Querying Cached Items with respect to Named Tags
string queryString = "SELECT Product WHERE this.UnitsAvailable = ? AND this.Supplier = ?";
Hashtable values = new Hashtable();
values.Add("UnitsAvailable", 4);
values.Add("Supplier", "Alex");
try
{
//if only related cache keys are required than use Search
ICollection keysResultSet = cache.Search(queryString, values);
// if both keys and values are required than use SearchEntries
IDictionary resultSet = cache.SearchEntries(queryString, values);
if (resultSet.Count> 0)
{
//Iterate through list of all products having UnitsAvailable as 4 and Supplier name is "Alex"
IDictionaryEnumerator ide = resultSet.GetEnumerator();
while (ide.MoveNext())
{
String key = (String)ide.Key;
String value = (String)ide.Value;
//...
}
}
}
catch (OperationFailedException ex)
{
// handle exception
}
Here, the fully qualified name of the custom class should be specified instead of 'Product' in query string. If Named Tags are associated with “int” or any other data type then specific syntax to that type will be used. For example, for values of "int" data type "SELECT System.int32 WHERE this.UnitsAvailable = ?" will be used to query Named Tags.
If you have multiple applications that are sharing same cache and all of them are supposed to add named tags than make sure that same named tags have homogenous data types, e.g., if one client is adding named tag "ProductID" with String data type than all other clients should add values of "ProductID" in String format not in Integer or other for same cache.
See Also
Named Tags Overview | Tags | Group/Subgroup | Object Query Language (OQL) in NCache | Server Side API Programming


Topic: Using Security

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Security

For using security after configuring security, security credentials need to be mentioned for initializing cache.
try
{
Cache cache = NCache.InitializeCache("mycache", new Alachisoft.NCache.Web.Security.SecurityParams("Admin", "password"), null);
}
catch (Exception ex)
{
// handle exception
}
Or CacheInitParam can be used to set security credentials as follows:
try
{
CacheInitParams ciParam = new CacheInitParams();
ciParam.PrimaryUserCredentials = new SecurityParams("primaryUserId", "primaryUserPassword");
ciParam.SecondaryUserCredentials = new SecurityParams("secondaryUserId", "secondaryUserPassword");
cache = Alachisoft.NCache.Web.Caching.NCache.InitializeCache("cacheId", "server", port, ciParam.PrimaryUserCredentials, ciParam.SecondaryUserCredentials);
}
catch (Exception exp)
{
// handle exception
}
Or security credentials can be mentioned in app.config file of the application.
try
{
string userName = String.Empty;
string password = String.Empty;
if(System.Configuration.ConfigurationManager.AppSettings["Username "]!=null)
{
userName=System.Configuration.ConfigurationManager.AppSettings["Username"].ToString();
}
if(System.Configuration.ConfigurationManager.AppSettings["Password"]!=null)
{
password=System.Configuration.ConfigurationManager.AppSettings["Password"].ToString();
}
// Initializing cache with security credential provided in web/app .config file
Cache cache = NCache.InitializeCache("mycache", new Alachisoft.NCache.Web.Security.SecurityParams(userName, password), null);
}
catch (Exception ex)
{
// handle exception
}
See Also
Security and Encryption Overview | Configuring Security | Using Basic Cache Operations | Server Side API Programming


Topic: Using Streams

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using Streams

Opening with Stream Modes
GetCacheStream API with different overloads is used to open a stream. GetCacheStream API opens the stream of specified key with provided streaming mode. It returns the handle of the opened stream as an object of CacheStream class.
CacheStream is derived from System.IO.Stream. It is designed to read/write BLOB using standard Stream interface. However, it does not support 'seeking' which is the querying and modifying the current position within a stream.
  • Reading from Stream
This mode is used for acquiring read-only access to the stream. With the help of example given below, a stream can be opened with read-only property on provided key.
string key = "key:ncache-manual";
CacheStream cacheStream = null;
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.Read);
}
catch (StreamException ex)
{
// handle exception
}
Now data can be read from this CacheStream object. GetCacheStream with Read mode throws StreamException if no data exists in the cache with the specified key.
  • Reading from Stream without Lock
This mode is useful when write and read operations are to be performed in parallel. The following example explains how to get stream object with read-without-lock property.
string key = "key:ncache-manual";
CacheStream cacheStream = null;
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.ReadWithoutLock);
}
catch (StreamException ex)
{
// handle exception
}
Data can be read from this CacheStream object. GetCacheStream with ReadWithoutLock mode throws StreamException if no data exists in the cache with the specified key.
  • Writing to a Stream
In write mode only single write operation can be performed on a stream. It will throw an exception if stream is already in use by another application.
string key = "key:ncache-manual";
CacheStream cacheStream = null;
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.Write);
}
catch (OperationFailedException ex)
{
// handle exception
}
Now data can be written to this CacheStream object.
Using GetBufferedStream
Buffered stream is the set of bytes used for storing the data up to the certain limit before reading or writing it to the cache. The following code shows how to use GetBufferedStream:
string key = "key:ncache-manual";
byte[] writeBuffer = System.IO.File.ReadAllBytes("C:\\ncache-manual.pdf");
int length = writeBuffer.Length;
try
{
System.IO.Stream wstream = _cache.GetCacheStream(key, StreamMode.Write).GetBufferedStream(length);
wstream.Write(writeBuffer, 0, length/2);//...No data is written in cache as buffer is not full
wstream.Write(writeBuffer, length/2, length/2);//...Data is written in cache because buffer is full now
////...Close the stream
}
catch (StreamException ex)
{
// handle exception }
26.2.3. Adding or Updating Data with Streams
string key="key:ncache-manual";
byte[] dataToWrite = System.IO.File.ReadAllBytes("C:\\ncache-manual.pdf");
try
{
cacheStream = cache.GetCacheStream(key, StreamMode.Write);
cacheStream.Write(dataToWrite, 0, dataToWrite.Length);
//...Close stream
}
catch (StreamException ex)
{
// handle exception
}
The same method is used for adding and updating the data with stream. If the key provided with GetCacheStream API does not exist in the cache, the data written on the stream is added in cache. If an item already exists in cache with the provided key, binary data written on the stream appends with the existing data against the specified key.
Retrieving Data from Streams
To read data from streams, open stream in any read mode as explained above, and simply read data from it.
string key = "key:ncache-manual";
try
{
CacheStream cacheStream = cache.GetCacheStream(key, StreamMode.Read);
int dataSize = Convert.ToInt32(cacheStream.Length);
byte[] dataToRead = newbyte[dataSize];
cacheStream.Read(dataToRead, 0, dataSize);
//...Close stream
}
catch (StreamException e)
{
// handle exception
}
Read mode can be acquired either with lock or without lock. In read with lock mode, multiple read operations can be performed simultaneously on a stream but no write operation is allowed in this mode. While in read without lock, write operations can be done parallel to read operations.
Closing a Stream
The stream should be closed after being used in any mode in order to release the lock.
string key = "key:ncache-manual";
try
{
CacheStream cacheStream = cache.GetCacheStream(key, StreamMode.Read);
int dataSize = Convert.ToInt32(cacheStream.Length);
byte[] dataToRead = newbyte[dataSize];
cacheStream.Read(dataToRead, 0, dataSize);
// your logic here
cacheStream.Close();
}
catch (StreamException e)
{
// handle exception
}
Reading or writing a stream that was previously in use throws exception i.e. StreamAlreadyLockedException, if it was not closed properly.
Close the stream after all operations are done to the stream.
See Also
Streaming Overview | Data Compression | Security and Encryption | Server Side API Programming


Topic: Using NCache View State Caching

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Using NCache View State Caching

Content Optimization Feature of NCache
Following are the two steps that need to be performed in order to use content optimization feature of NCache:
Step 1: Update/Configure App Browser File
  • Create an App browser file in the ASP.NET application. It will be created under the directory of App_browsers.
  • Now plug page adapters in the app browser file as following:
<browsers>
<!-- NCache Plug page adapters in the app browser file as following:. -->
<browser refID="Default">
<controlAdapters>
<adapter controlType="System.Web.UI.Page"
adapterType="Alachisoft.NCache.Adapters.PageAdapter" />
</controlAdapters>
</browser>
</browsers>
This is an example of page adapter plugged at page level. You can also plug it at any control level for which you want to cache the view state.
Step 2: Update/Configure Web.config File
  • Add the following assembly reference in compilation section of web.config file
For Enterprise and Professional Editions:-
<compilation defaultLanguage="c#" debug="true" targetFramework= "4.0">
<assemblies>
<add assembly="Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=CFF5926ED6A53769"/>
</assemblies>
</compilation>
For Open Source Edition:-
<compilation defaultLanguage="c#" debug="true" targetFramework= "4.0">
<assemblies>
<add assembly="Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=1448e8d1123e9096"/>
</assemblies>
</compilation>
  • A web config section needs to be registered which contains the following settings/properties in web.config file.
<configSections>
<!--NCache Register config section first. -->
<sectionGroup name="ncContentOptimization">
<section name= "settings" type= "Alachisoft.NCache.ContentOptimization.Configurations.ContentSettings" allowLocation="true" allowDefinition= "Everywhere"/>
</sectionGroup>
</configSections>
  • Add the actual setting/configuration section as follows:
<!--NCache actual setting/ configuration for view state
<ncContentOptimization>
<settings enableViewstateCaching="true" viewstateThreshold="1" cacheUriMapping="true" enableTrace="false" >
<cacheSettings cacheName="mycache” connectionRetryInterval="300">
<expiration type="Absolute" duration="1" />
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Member | Description
enableViewstateCaching | Boolean value to enable /disable the ViewState caching.
viewstateThreshold | Sets the minimum threshold size of viewstate in bytes. Viewstates which are smaller than threshold value will not be cached.
cacheUriMapping | Cache URL mapping, Default is true.
enableTrace | Enable/disable traces.
cacheName | Name of the Cache.
connectionRetyInterval | Retry Connection to Cache interval. Default is 300 seconds.
Expiration | Sets the expiration type which can either be Sliding, Absolute or None. And also expiration interval in minutes.
Duration | Sets expiration interval in minutes.
  • In the end, register the HTTP handler in the HttpHandlers section of web.config as following:
For Enterprise and Professional Editions:-
<add verb="GET,HEAD" path="NCResource.axd" validate="false" type="Alachisoft.NCache.Adapters.ContentOptimization.ResourceHandler, Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=cff5926ed6a53769"/>
For Open Source Edition:-
<add verb="GET,HEAD" path="NCResource.axd" validate="false" type="Alachisoft.NCache.Adapters.ContentOptimization.ResourceHandler, Alachisoft.NCache.Adapters, Version=1.0.0.0, Culture=neutral, PublicKeyToken=144
8e8d1123e9096"/>
If the same cache is being used for View State caching and other data, viewstate data can be retrieved by NC_ASP.net_viewstate_data tag. With this tag it is easy to find the data specific to viewstate.
Hashtable allViewStateData = cache.GetByTag(new Alachisoft.NCache.Runtime.Caching.Tag("NC_ASP.net_viewstate_data"));
The view state of a particular session can easily be retrieved from cache based on sessionId.
How to Group View State with Session
NCache provides a feature that allows to group view state with a particular session. Due to this dependency, as the session is expired, the view state associated with it expires too. The view state and session can reside either on two different caches or on a single cache. To enable this feature, expireViewstateWithSession should be set as true in ncContentOptimization tag.
<ncContentOptimization>
<settings enableMinification="false" enableViewstateCaching="true" groupedViewStateWithSessions="true" viewstateThreshold="1" cacheUriMapping="true" enableTrace="true" expireViewstateWithSession="true" sessionCacheName="vscache" sessionAppId="SSP">
<cacheSettings cacheName="vscache2">
<expiration type="None" duration="0" />
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Member | Description
groupedViewStateWithSessions | Through this property session can be grouped with view state. All the viewstate for a session is grouped with sessionId. This allows to retrieve all viewstate grouped with a sessionId from the cache with group information. Set this property to "true" in order to enable viewstate grouping with sessions. By default, its value is false.
expireViewstateWithSession | By setting this property as true, it is made sure that when a session expires, its associated view state expires too.
sessionAppId | Specifies an identifier to make sure that session ID remains unique in case multiple applications are using the same cache. Its value should be the same as the sessionAppId in sessionState tag.
sessionCacheName | The name of the cache on which the session data is residing. Its value should be the same as the cacheName property in sessionState tag.
How to Limit View State Caching
Following are the configuration changes:
<ncContentOptimization>
<settings enableViewstateCaching="true" viewstateThreshold="0" cacheUriMapping="true" enableTrace="true" groupedViewStateWithSessions="true" maxViewStatesPerSession="5" enableMetadataLocking="false" releaseLockInterval="5000">
<cacheSettings cacheName="mycache">
<expiration type="None"duration="0" />
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Members | Description
MaxViewStatesPerSession | To enable this feature specify any value greater than zero, if zero or lesser value is configured all view state will be cached. If a tag is skipped, all view state will be cached.
EnableMetadataLocking | Defines whether internal metadata manipulation is a locking operation or not. Its default value is true. It comes into play if MaxViewStatesPerSession is enabled.
ReleaseLockInterval | Defines interval after which lock is released. Its value is in milliseconds. Its default value is 5000ms. It comes into play if MaxViewStatesPerSession is enabled.
How to Perform Page level Grouping for View State
The following configurations should be made in web.config file. Also add the property webAppId in settings as follows:
<ncContentOptimization>
<settings webAppId="WebApp_1" enableViewstateCaching="true" groupedViewStateWithSessions="true" viewstateThreshold="12" enableTrace="true" maxViewStatesPerSession="10">
<cacheSettings cacheName = "mycache">
<expiration type="Sliding" duration = "300"/>
</cacheSettings>
</settings>
</ncContentOptimization>
Configuration Members
Members | Description
webAppId | Specifies the web application Id where the application is currently running. When webappId is specified, NCache looks up for ViewState.xml file to read configurations. If webAppId is not specified, view states will not be grouped and the default settings from web.config will be used.
ViewState.xml
ViewState.xml is required for this feature. This view state configuration file (ViewState.xml) can be placed at NCache installation config directory C:\Program Files\NCache\config or at web application bin path,e.g., C:\\ASP App\bin.
The web application id provided in web.config is matched with web application id in ViewState.xml file. From ViewState.xml detailed configurations for each group are then loaded.
The configurations provided in the web.config file are loaded as default settings. The configurations in this xml file are loaded per group. Here is a sample ViewState.xml file:
<configuration>
<viewstateConfig>
<webApp webAppId="aspViewState_A ">
<viewstateGroup groupId="Group_A" cacheUriMapping="false" enableViewstateCaching="True" viewstateThreshold="12" groupedViewStateWithSessions="false" maxViewStatePerSession="20">
<cacheSettings cacheName="myCache" connectionRetryInterval="300">
<expiration type="Sliding"duration="5"/>
</cacheSettings>
<pages>
<page url=”…/leftmenu.aspx"/><!—Relative url of a page-->
</pages>
</viewstateGroup>
<viewstateGroup groupId="Group_B" cacheUriMapping="false" enableViewstateCaching="true" viewstateThreshold="23" groupedViewStateWithSessions="false" maxViewStatePerSession="5" enableMetadataLocking="True" releaseLockInterval="5">
<cacheSettings cacheName="replicatedCache" connectionRetryInterval="300">
<expiration type="Sliding" duration="20"/>
</cacheSettings>
<pages>
<page url="…/testcaselist.aspx"/>
<page url="…/ViewState/ViewState_SessionGroup.aspx"/>
</pages>
</viewstateGroup>
</webApp>
<webApp webAppId="aspViewState_B">
<viewstateGroup groupId="Group_A" enableViewstateCaching="True" viewstateThreshold="2" groupedViewStateWithSessions="false" maxViewStatePerSession="200”>
<cacheSettings cacheName="cache">
<expiration type="Sliding" duration="20"/>
</cacheSettings>
<pages>
<page url="…/menu/viewstate.aspx"/>
</pages>
</viewstateGroup>
</webApp>
</viewstateConfig>
</configuration>
Configuration Members
Members | Description
webAppId | Used to distinguish multiple web app sections.(compulsory)
GroupId | Used to distinguish multiple groups. (compulsory)
page url | Relative URL for a page. (compulsory)
Please keep the following important points in mind.
  • The XML file can have multiple web app configurations. In each web app configuration, there can be one or more group configurations.
  • All the web pages for a certain group are provided in <pages> section and page url is the relative url of a page.
  • If a page configuration is not found in view state configuration file, default settings provided in web.config will be used.
  • If any property is missing for any group, default property value provided in web.config will be used.
  • Different caches can also be configured for different groups.
Default and Group Setting Usage:
If web.config provides a web app id, NCache will look for viewstate.xml file to read configuration. In this case, default settings will only be used if configuration for a page is not found in viewstate.xml or if some optional property is missing in viewstate.xml. But if web.config settings does not include web app ID, default settings will be used for all view state caching.
See Also
View State Caching Overview | ASP.NET Sessions | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations


Topic: View State Caching

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

View State Caching

ASP.NET View State is a very powerful mechanism that stores pages, controls and custom values between multiple HTTP requests across client and the web server. This section explains the View State caching feature provided by NCache.
In This Section
Overview
Explains the concept of ASP.NET View State caching, the downsides of using it and how NCache's View State caching resolves these issues.
Using NCache View State Caching
Explains Content Optimization and View State caching feature of NCache.


Topic: Overview

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Overview

ASP.NET today is widely used for high traffic web applications that need to handle millions of users and are deployed in load balanced web farms. ASP.NET View State is a very powerful mechanism that stores pages, controls and custom values between multiple HTTP requests across client and the web server. View State is ASP.NET method for persisting page and control states during post-backs. All ASP.NET applications have to deal with view state which is becoming a performance overhead. View State caching helps caching view state on web servers and send a much smaller payload to the user's browser containing only a unique ID for this view state. As a result, the page uses lesser bandwidth which improves performance and the ASP.NET application also scales much better.
Why Cache View State?
There are multiple downsides to View State. As it is known View State is an encrypted text string containing the state of web form controls and widgets and is sent to the user's browser to preserve the state across post-backs. For forms with lot of controls, DataGrid control, or some other complex controls, the View State can become quite large.
Another reason can be of heavy ASP.NET View State where the increased bandwidth usage increases the bandwidth cost considerably. For example, if for each HTTP requests, about 60-100k of additional ASP.NET View State data is appended, this multiplied by the total number of transactions and it is clear that bandwidth consumption becomes very high.
Also, in some situations, there is a security risk with sending confidential data as part of ASP.NET View State. And, encrypting it before sending is also costly.
Here are some reasons why it should be considered to cache the View State.
  • View State is large (tens of KB) on large forms and DataGrid.
  • Large View State slows down page download time.
  • Large View State slows down post-back request time.
  • Cache View State on web servers & send only a token to user.
  • View State cache is distributed to all web servers in the farm; there is no single point of failure.
NCache's View State Caching resolves these issues, following are some of its features:
  • Increased Performance: NCache reduces the request/response payload which improves the overall request time.
  • Availability and Reliability: NCache is in-memory cache, it is distributed and synchronized across all web servers, even if the post-back request goes to a different web server in the farm than the original server where the viewstate was created, NCache is able to find the viewstate value in the cache.
  • View State with its Session: NCache allows view state to be categorized with respect to its respective session.
  • Limit View State Caching: For longer sessions with abundant amount of viewstates it is now possible to limit viewstate per session to a configurable number. Metadata is used for limiting, meta data is also cached. It is also possible to lock metadata. Locking can be configured via web.config.
  • Page level Grouping for View State: NCache allows grouping on page level, multiple pages can be coupled to define a group. For each group, different configurations can be set.
  • ViewState.xml is required for view state grouping feature. This xml can have multiple web app configurations. In each web app configuration, there can be one or more group configurations. And different caches can be configured for different groups.
See Also
Using NCache View State Caching | ASP.NET Sessions | ASP.NET Output Cache | Client Side API Programming | Server Side API Programming | Client Side Third Party Integrations


Topic: Viewing Statistics of a Cache

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page

Viewing Statistics of a Cache

NCache Manager for Visual Studio also lets you monitor statistics of a cache; following is the way to view it.
1. Right click any running cache, and select Statistic menu item/Select any running cache and click Show Statistics item from top toolbar menu.
2. This will open a new tool window which will contain statistics for the cache.
A Local Cache’s (cache) statistics.
A Clustered Cache’s(ClusteredCache2) Statistics.


Topic: Add Reference issue of Visual Studio 2010

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Add Reference issue of Visual Studio 2010

If your development environment is Visual Studio 2010, you may not be able to see NCache .NET assemblies in the Add Reference dialog box under .NET tab. However, you can add reference to the NCache assemblies by using the Browse tab. You can find all these assembly files in NCache Installed folder/bin/assembly/.
See Also
Installing NCache


Topic: WAN Replication Through Bridge

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

WAN Replication Through Bridge

NCache provides WAN replication through Bridge feature. A bridge is created between two cluster caches and data is replicated from source to other site through that bridge. This section explains the concept of a bridge and describes the bridge configurations and implementation of a Bridge Conflict Resolver in NCache.
In this section
Overview
Explains the concept of Bridge in NCache.
Bridge Configurations
Explains the two kinds of Bridge configurations provided in NCache.
Bridge Conflict Resolver
Explains how to implement and use Bridge Conflict Resolver in NCache.


Topic: What's New in NCache 4.4?

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

What's New in NCache 4.4?

NCache 4.4 brings many new features and enhances graphical user interface to the next level. Here is a brief overview of what's new in NCache 4.4:
Visual Studio Integration
NCache can now be integrated with Visual Studio 2010/2012/2013 (Enterprise & Community). Basic management and configuration operations can now be performed within the Visual Studio. NCache 4.4 SP1 Developer installation now comes with an ‘NCache Manager’ extension which helps developers manage NCache from Visual Studio.
Entity Framework 6.0 Support
Entity Framework 6.0 and 6.1 integration is provided in NCache 4.4 Service Pack 1 (SP1). In SP1, NCache also provides caching extensions for Entity Framework 6.0 which allows developers more control over which entities to cache. This is available for developers who want greater control over the entities being cached, as an alternate to the ‘no-code-change configuration’ option.
Windows Server 2012 R2 Certification
NCache 4.4 SP1 is certified for Windows Server 2012 R2. It has been tested by Microsoft’s approved tester and passed all compatibility tests. Microsoft validated that NCache works in accordance with Microsoft’s standards.
NCache SDK NuGet Package
NuGet is a package manager for Microsoft Visual Studio development in .NET. The NuGet Gallery is a central repository of all NuGet packages.
A NuGet package is provided for developers to build applications using NCache without installing NCache on their machines. With this package, developers can write their applications using an NCache API and test them with InProc cache. This gives you full control to use NCache SDK without installing it.
NCache in Azure Marketplace
NCache can be deployed in Microsoft Azure Virtual Machines with all its features. Additionally, the following features are available in Microsoft’s Azure environment exclusively for NCache and not provided by any other caching solution:
  1. Sharing ASP.NET Sessions across regions
  2. WAN replication of cache across regions
  3. Memcached Wrapper for NCache
NCache is available in Azure Marketplace.
NCache in Amazon Web Services (AWS)
NCache can be deployed in Amazon Web Services (AWS) as Virtual Machines with all its features. In AWS, NCache can either reside on the same Virtual Machine as the applications that are using it, or on separate Virtual Machines. The following caching features are available in AWS:
  1. Sharing ASP.NET Sessions across regions
  2. WAN replication of cache across regions
  3. Memcached Wrapper for NCache
NCache is available at AWS.
NCache is Now Open Source
NCache is also available as Open Source. NCache Open Source is released under the Apache 2.0 Open Source license. This provides the .NET developer community with unrestricted access to a truly elastic native .NET Distributed Cache. For more details please refer to the Edition Comparison page.
NCache Switching to an Annual Subscription Based Pricing Model
In Version 4.4 NCache will be switching to an annual subscription based pricing model. Upon expiration the customer will need to renew the subscription to continue using NCache. Provision will also be provided for the purchase of a multi-year subscription. For more details please refer to the Pricing page.
Memcached Wrapper for NCache
Memcached Wrapper for NCache provides a no-code-change way for migrating Memcached applications to a powerful elastic distributed cache. See more details on the NCache vs. Memcached comparison page.
The Memcached Wrapper for NCache can be used in the following two ways:
  1. Memcached Plug-In (for .NET apps)
  2. Memcached Gateway
The Memcached plug-in option is for .NET applications. Alachisoft has taken all the popular Open Source Memcached client libraries and implemented them for NCache. These libraries for .NET are:
  1. enyim
  2. BeIT
  3. More…
The Memcached Gateway implements Memcached Protocols and supports all types of Memcached applications. Applications are directed to the Memcached Gateway and they start using NCache behind the scenes.
Read-Through and Write-Through Providers
Develop multiple Read-Through/Write-Through providers and register it with NCache. You can use a specific provider from each of your Java application. You are also facilitated to use NCache Manager to deploy your Read-Through/Write-Through handlers even at runtime. Your assemblies are automatically copied to all the cache servers.
Data Sharing between .NET and Java
With Data Sharing you can share cache content among NCache .NET and NCache Java editions. This sharing can be achieved through binary compact serialization. To use this feature user must have both NCache .NET and NCache Java editions installed.
Class Versioning in Same Platform
Using Class Versioning you can share class data among various versions of a class with in a same platform. Here mapping of attributes is done at run time.
Support for Dynamic Compact Serialization
Use a faster and more compact serialization than regular Java serialization and without writing any custom code for it. NCache generated serialization code at runtime and even lets you serialize objects that are otherwise not serializable.
Support for Named Tags in .NET
NCache can associate a dictionary of named tags with cache items. Items can be objects or text data. Named Tags helps in indexing the data on the basis of tags and you can query indexed data using tags.
Cache Startup Option
Using Cache Startup option if the cache is specified to be a startup cache, it will get started automatically on service startup. No manual start is required for the cache.
Support for Continuous Query in .NET
NCache provides Continuous Query support for both .Net and Java clients. It notifies about the changes occur in query result set and therefore client applications need not to re-query the data for updates.
Bridge (Enhanced):
An enhanced bridge feature is introduced having support for multiple topologies. It performs an asynchronous replication of data from one on-site cache to one/multiple on-site/off-site disaster recovery cache(s) across the WAN.
Bridge Conflict Resolver for .NET
Bridge Conflict Resolver resolves the conflict occur while replicating the data from bridge to cache.
See Also
Dynamic Clustering | Caching Topologies | Copyright ©


Topic: What is the Recommended Way to Apply Windows Patches on NCache Server?

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

What is the Recommended Way to Apply Windows Patches on NCache Server?

Recommended way for applying windows patches on NCache Server is windows standard procedure.
Required steps are:
1. Stop the Cache
Stop the cache by right click on IP address of the node in NCache Manager under your cache cluster. If this node is part of multiple cache clusters then you need to stop this node/cache from all cache clusters. This will start state transfer process and data will be re-adjusted on other nodes available in the cluster.
2. Stop NCache Service
Stop NCache service on this server and also change the service startup type from “Automatic” to “Manual”, so that you can manually start NCache service after reboot.
3. Apply Patch
Apply required patches/updates. Complete all the maintenance tasks running on this machine and then reboot the servers.
4. Restart NCache service
After successful completion of step 3 now restart NCache service and also change service start up type back to “Automatic” for normal usage.
5. Start the cache
Now start the cache manually from NCache manager if auto-start is not enabled. Refresh cache cluster from NCache manger to view this node as active node in the cluster. Furthermore, you can see data being transferred to this lately added cache node.
Perform same steps for other nodes in your environment. The main reason of starting NCache service manually is that some of the patches complete their operations after some time of system startup and it is a good practice to start NCache service manually once all the patches are fully applied and maintenance work is complete on your server.
See Also
Installation Guide | Upgrading NCache | Unable to Connect to Remote Server (Windows XP Machine) | How to do NCache version upgrades


Topic: Windows Event Logging

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Windows Event Logging

NCache provides support to view events in Windows Event Log. NCache logs its important events in Window Event Logs. This allows monitoring all such events through Windows Event Viewer or with any other tool that support Window Event Logger. Some of the events that are logged include:
  • All NCache installation events. These events are combination of successful or aborted installation.
  • All errors encountered by NCache, Bridge and Memcache services.
  • Service start and stop events
  • Cache start and stop
  • Cache server joining or leaving a cache cluster
  • Cache size going above a configurable 80% threshold
See Also
Monitoring Caches using NCache Monitor | Performance Counters Logging | NCache Monitor Logging


Topic: Write-Through Provider for Write-Behind Operations

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Write-Through Provider for Write-Behind Operations

If write-behind option is enabled, then all of the data source operations are queued up and performed in the background.
There are multiple settings which can be used to optimize the write-through provider to fulfill the user requirements. These settings can be configured as follows:
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Baking Source tab.
  • Configure Write-Through provider for the cache.
  • Batching, Throttling and Re-Queue Operations settings are given below the Write-Through list box.
  • Change the settings as per your application requirements.
  • Check the Enable Batching checkbox to perform all write-behind operations on data source in bulk/batches.You can also configure the Batch-interval(s) and Operation-delay (ms) for the batching mode.
  • Change the value for Operations per second, to control how many write-behind operations will be performed on data source in a second.
  • You can also configure the Failed operations queue limit. This queue is used to re-queue the failed oprations and will be retired on data source.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addbackingsource.exe tool, provide the required information as:
addbackingsource.exe demoLocalCache /path C:\Users\Administrator\Downloads\Providers.dll /cNCache.Sample.Providers.Writers.Writer1 /pnwriter1/W /b true /ops 500
  • Hit ENTER key, it will configure Writer1 write-through provider on demoLocalcache with write-behind enabled and with throttling limit of 500 operations per second.
Deploy required assemblies using deployprovider.exe. Use the following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Read-Through Provider | Write-Through Provider


Topic: Write-Through Caching

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Write-Through Caching

NCache supports write-through caching which allows write operations to backend data source. In this way, cache and master data source can be synchronized. In write-through caching, NCache updates cache store first and then apply that operation to configure data source. For example, if client application updates an entry in cache, then NCache will also update the configured data source (if write-through is enabled).
Similarly for write-through, IWriteThruProvider interface needs to be implemented. NCache framework will internally use this custom provider to perform write operation on back-end data source. Here, custom logic for write operations on back-end data source needs to be implemented. NCache will call the provider behind write operations (Add, Insert, Remove/Delete) API calls with write-through. Currently NCache provides two modes for write-through caching.
  • Write-Through (Updates data source synchronously)
  • Write-Behind (Updates data source asynchronously)
NCache provides performance counter for write-through operations performed per sec.
Write-Through
In Write-through caching, an operation first applies on cache store and then synchronously updates the configured data source. In write-through mode, operation will be completed after NCache applies that operation on back-end data source. Write-through caching can be used if immediate database updates are critical and data source needs to be updated as soon as cache is updated.
Write-Behind
In Write-through, due to synchronous operations on data source, rate of operations on data source will be the same as rate of user operations on cache. For applications with high user traffic, rate of user operation on cache can be very high which can resultantly over whelm the data source. Also synchronous data source operation may affect response time of user operation.
To overcome these problem, write-behind can use instead of write through. In write-behind, data source operations are performed asynchronously after NCache performs operation on cache store. After updating cache store, these operations are queued up and later applied to configured data source asynchronously. Thus write-behind mode will enhance response time of operations. NCache provides different configurations settings in write-behind to control operations flow on data source. For instance, through Throttling, the rate at which NCache will apply write behind operations on data source can be specified. It indicates the number of operations applied on data source in a second. Default value for throttling is 500 ops/sec .This value can be changed through NCManager Backing Source settings.
NCache provides performance counter for write-behind operations performed per sec.
Write-Behind Modes
NCache allows write-behind operations to be applied either individually or in batch. A write-behind queue is maintained for write-behind operations. All write-behind operations will be en queued in this queue and later on applied to data source according to the configured batched or non-batched mode. These two modes are explained below:
  • Non Batch Mode
By default, non-batch mode will be configured for write-behind operations. In this mode, operations in write behind queue will be applied one by one on data source according to configured throttling rate. For example, if throttling rate is 500 operations per second, NCache will apply write behind operation one at a time to data source and their applying rate will not exceed from 500 operations per second.
  • Batch Mode
In Batch-mode, operation delay can be configured for write behind operations, which indicates the time in milliseconds that each operation must wait in write-behind queue before applying it on data source. By default, its value is zero. In this mode, a batch/bulk of operations is selected according to their operation delay. A dedicated thread periodically collects all those operations which complete their delay interval after a configurable interval called "batch-interval". Thus Batch-interval is the configurable interval according to which NCache periodically checks for operation delay timed out operations in write-behind queue. In short, a bulk of ready operations (that completed their delay interval) is selected at every batch interval.
For example, if operation delay is configured as 1000ms and batch interval as 5s then NCache checks the operations in write-behind queue after every 5s (batch-interval) and select all operations whom operation delays are expired (all operations which are in queue for the last 1000 milliseconds).
After selection of operation bulk, these operations are then applied to data source according to configured throttling rate. Let's say a bulk of 1000 operations are selected from write-behind queue, these operations are then applied to data source in a batch of 500 operations (if throttling rate is 500ops/sec) as the maximum operation applied to data source per second can't exceed the given throttling value.
Operation delay time can range from seconds to days and months. In this way, operations on data source can be paused by configurable amount of time.
NCache also provides performance counters for write-behind queue operations count and current batch operation count. Current batch operation count displays the number of operations selected in current batch interval for execution. For write-behind, if batching is enabled, operations ready to be executed on data source are de queued from write behind queue. Number of operation de queued in current batch interval will be displayed by current batch operation count counter.
Write-Through Caching Operation Result
NCache provides a flexible way to synchronize write-through operation in cache on the basis of its operation result. After applying an operation (Add/ Insert) on data source, operation status can be specified on the basis of which NCache will synchronize cache store. For example, in case of data source operation failure, that item can either be removed from cache or kept in it. The operation can even be retried on data source. For this, Success/Failure/FailureRetry/FailureDontRemove has to be specified as DSOperationStatus of OperationResult. This is provided in both modes of write-through caching i.e. write-through and write-behind. Data source operation statuses and their corresponding actions by NCache are described below:
  • Success: This means that data source operation is successful and item was added to the data source so NCache will keep it in the cache as well.
  • Failure:  This means that data source operation is failed and item could not be added to database, so NCache will remove it from the cache as well.
  • FailureDontRemove: This means that data source operation is failed and item could not be added to the database, but NCache will keep it in the cache.
  • FailureRetry: This means that data source operation is failed and item could not be added to the database, so NCache will keep the item in cache and retry. Retries will be done as write behind operations.
Retrying Failed Operations
NCache allows retrying operations in write-through/write-behind in case they are failed on data source. For this purpose, if operation retrying is enabled and specifications about retrying certain operations through provider are given, then NCache will retry that operation on data source. In case of write-through or write –behind, all retry operations will be re-queued to write behind queue. It means that a write-through retry operation will be retried asynchronously as a write behind operation.
NCache also provides performance counter for data source failed operations/sec. Write operations performed on data source returning Failure/ FailureRetry/ FailureDontRemove as DSOperationtatus of OperationResult are counted per second by this counter.
NCache allows limiting the number of failed operations to be retried. In such a situation, Failed operation queue limit through NCache Manger should be mentioned, and if that limit exceeds, failed operations can be evicted through a configurable eviction ratio. Here NCache will evict the most retried operations when retried queue is full. Each operation has associated RetryCount property which is incremented on each operation retry on data source.
For this, NCache provides performance counter for write-behind failure retry count and write-behind eviction/sec. Write-behind failure retry counter will show the number of operation re queued for retry. Data source write operation returning FailureRetry as status in OperationResult will be re queued for retry. Whereas write-behind eviction/sec counter will display the number of retry operations evicted per second.
Updating Cache after Data Source Operation
As stated earlier, in write-through caching, operation is first performed on cache store and then to data source. There may exist scenarios in which after performing operation on data source, an item’s value is modified, e.g., in case of identity columns, its value will be modified by data source operation. In such a situation, data may become inconsistent in cache and data source. To handle this, NCache allows specifying whether to update data in cache after data source operation or not. The flag UpdateInCache can be set to again perform the operation (Add/Insert) on cache store to make it synchronized with data source.
NCache updates operation in cache store, if specified, synchronously or asynchronously depending on the write-through caching mode. In write-through, synchronous updates will be applied and asynchronous in case of write-behind.
NCache also provides performance counter for data source updates/sec. It displays the number of update operations per second in cache after data source write operations. Data source write operations with UpdateInCache flag set to true in OperationResult are then performed on cache. This counter displays the number of these update operations performed on cache per second.
Monitor Write-Through Caching Using Counters
In write-through caching, NCache provides the following counters to monitor cache activity on data source:
  • Write-through/sec: Displays the number of write-through operations per second.
  • Write-behind/sec: Displays the number of write-behind operations per second.
  • Write-behind queue count: Displays the number of operations in write-behind queue.
  • Write-behind failure retry count: Displays the number of operations failed and re-queued for retry. Data source write operation returning FailureRetry will be re-queue. This counter displays re-queued operation count.
  • Average Write-Behind Updates: Average time, in milliseconds, taken to complete one data source update cache operation. Data source write operations with UpdateInCache flag set to true in OperationResult are then performed on cache. This counter displays the average time taken by these update operations on cache.
  • Write-behind evictions/sec: Displays the number of retried operations evicted per second. Data source write operation returning FailureRetry are re queued for retry. This counter displays number of such operations evicted per second.
  • Data source updates/sec: Displays the number of update operations per second in cache after data source write operations. Data source write operations with UpdateInCache flag set to true in operation result are then performed on cache. This counter displays number of these update operations performed on cache per second.
  • Data source failed operations/sec: Displays the number of data source write operations failed per second. Write operations performed on data source returning Failure/FailureRetry/FailureDontRemove as DSOperationtatus of OperationResult are counted per second by this counter.
  • Current batch operations count: Displays current batch operation count i.e. thenumber of operations selected in current batch interval for execution. For write-behind, if batching is enabled, operations ready to be executed on data source are de queued from write behind queue. The number of operations de queued in current batch interval will be displayed by current batch operation count counter.
Hot Apply Support for Write-Behind Configuration
NCache supports hot apply for write-behind settings which allow changing the write behind configuration at runtime without stopping the cache. Almost all write behind configurable attributes can be changed through NCache Manager and NCache will incorporate those changes dynamically.
In this hot apply support, write-behind mode can be changed from batch to non-batch and vice versa. For instance, if the batch mode is changed to non-batch, then NCache will ignore the operation delay value and start executing operations individually. The throttling rate can also be changed at runtime. Similarly operation delay, batch-interval, failed operation queue limit and eviction ratio can also be changed at runtime.
The failed operation queue limit can only be changed in increasing fashion; otherwise NCache will use its default value for further operations.
Write Behind in Clustered Environment
As a write-behind queue is maintained for write-behind operations, a separate dedicated thread monitors and executes these operations. Topology level details for write-behind are mentioned below:
  • In Replicated Cache topology, write-behind queue will be maintained on all nodes, but write-behind async processor will be present on coordinator node only. This means that all write-behind operations will be performed through this node and replicated to other node queues cluster wide. In this way, if a node is down, then the next coordinator will perform the remaining write behind operations.
  • In Partitioned-Replica topology, write-behind queue is maintained on each active node and also replicated to its corresponding replica. Each node will be responsible for its write-behind operation on data source.
  • In Mirrored Cache, write behind queue will be maintained on both active and passive node, but only active node will be responsible to perform write-behind operations. Similarly, if active node is down, then passive will become active and perform the remaining write behind operations.
  • In Partitioned Cache topology, write-behind queue is maintained on each partition and every node will be responsible for its write-behind operation on data source.
See Also
Data Source Providers Overview | Read-Through Caching | Configuring Read-Through Provider | Configuring Write-Through Provider | Configuring Data Source Providers | Dynamic Compact Serialization | WAN Replication Through Bridge | Custom Dependency | Client Side API Programming


Topic: Write-Through Provider

What's New in NCache 4.4?
Self Healing Dynamic Clustering
Caching Topologies
Features Highlights
Support for .NET & ASP.NET Apps
Support for Java/J2EE & JSP Apps
Cache Server Backward Compatibility
Copyright ©
Caching Concepts
Cache Topologies
Mirror Cache
Replicated Cache
Partitioned Cache
Partitioned-Replica Cache
Cache Cluster
Local Cache
Cache Client
Client Cache
Data Load Balancing in Partitioned and Partitioned-Replica Topologies
Client Backward Compatibility
Eviction
Indexing
Runtime Data Sharing
Portable Data Types (.NET & Java)
Class Versioning (Same Platform)
Graceful Node Down
IP Binding
Installation Guide
.NET Installation Guide
Getting Started
Command Line Install
Network Install with PowerShell
Configuring PowerShell Environment
Remote Installation/Uninstallation
Activate NCache Purchased License
Interactive Windows Installation
Evaluation Period Expiration & Extension
Activate NCache Purchased License
Command Line Activation
Deactivate NCache Purchased License
NCache Java Client Installation Guide for UNIX
What is NCache Java Client?
Getting Started
Installation Steps for UNIX
Post Installation License Management for UNIX
Post Installation Client/Server Configuration for UNIX
Uninstall NCache Java Client from UNIX
Troubleshooting Common Install/Uninstall Problems
Getting Started
Quickly Configure and use NCache
Quickly use Cache API in .NET
Initialize Cache
Start Cache
Adding Items
Removing Items
Deleting Items
Finding Items
Dispose Cache
Stop Cache
Quick Start Guide for .NET
Store ASP .NET 1.1 Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Store ASP .NET 2.0+ Sessions
Step 1: Configure the Cache
Step 2: Edit web.config or machine.config
Step 3: Start/Restart ASP.NET Application
Use as ASP.NET Output Cache
Step 1: Configure the Cache
Step 2: Edit Web.Config or Machine.Config
Step 3: Start/Restart ASP.NET Application
Use as NHibernate Second Level Cache
Step 1: Configure the Cache
Step 2: Register NCache with NHibernate
Step 3: Enable DBCacheDependency in NHibernate
Step 4: Run your NHibernate based Application
Use Dynamic Compact Serialization
Step 1: Register Compact Types with NCache
Step 2: Run Your Application
Administrator's Guide
Configuring Caches
Creating Caches
Creating Local Cache
Creating Cache Clusters
Creating a New Cache Cluster
Adding an Existing Cache Cluster
Adding Server Node in a Cache Cluster
Removing Server Node from Clustered Cache
Configuring Basic Cache Settings
Cache Size
Isolation Levels
Expiration Clean Up Interval
Configuring Cache Cluster Settings
Ports
Cluster Port
Port Range
Server Port
Operation Timeout
Statistic Replication Interval
Connection Retries
Retry Interval
Configuring Query Indexes
Registering Classes for Compact Serialization
Registering Non-Generic Classes
Registering Generic Classes
Registering Generic Classes using Generic Type Handler
Registering Classes for Portable Data Sharing
Import/Export Data Share Configuration
Configuring Data Source Providers
Read-Through Provider
Write-Through Provider
Write-Through Provider for Write-Behind Operations
Configuring Cache Start-Up Loader
Configuring Cache Level Events
Configuring Eviction Policy
Configuring Compression
Configuring Email Notifications
Binding Cluster and Client/Server with a Dedicated IP for Performance
Binding Cluster with a Dedicated IP
Binding Client/Server with a Dedicated IP
Configuring Heart Beat
Auto Start Cache at Boot
Nagling
Dual Socket
Error Logging
Configuration Files
Overview
Client Side
Client Config
EFCaching Config
Server Side
Cache Config
Configuring Bridge
Configuring Security
Cache Server Configuration
Overview
Cache Server Configurations in Service Config File
Management Operations
Start Cache
Start Cache on all Server Nodes
Start Cache on a Particular Server Node
Stop Cache
Stop Cache on all Server Nodes
Stop Cache on a Particular Server Node
Manage Cache Service on a Server Node
Start Cache Service on a Server Node
Stop Cache Service on a Server Node
Restart Cache Service on a Server Node
Apply Configuration
Hot Apply Configuration
Reset Configuration
Data Load Balancing
Configuring Cache Clients
Adding Client Node in a Cache Cluster
Configuring Client Node Settings
Creating Client Cache
Disable Client Cache on Client Nodes
Enable Client Cache on Client Nodes
Configuring Client Cache Settings
Synchronization Mode
Client Cache Size
Isolation Level
Configuring Security
Configuring Security for Cache Management
Configuring Security for Cache
Configuring Encryption for Cache
Configuring Bridge for WAN Replication
Overview of Bridge
Active-Passive
Active-Active
Creating Clustered Bridge
Configuring Bridge Settings
Bridge Queue Size
Bridge Connection Settings
Enable the Queue Optimization
Performance Counters
Bulk Size for Operation Replications
Configuring Conflict Resolver
Changing Cache Synchronization Modes
Making Passive Cache as Active Cache
Making Active Cache as Passive Cache
Configuring Master Cache
Force State Transfer
Connect/Disconnect a Cache
Remove a Cache from Bridge
Bridge Management
Add a Bridge Node
Apply and Reset Configuration
Remove a Bridge Node
Start Bridge
Stop Bridge
Remove Bridge
Stop Bridge Service
Start Bridge Service
Restart Bridge Service
Monitoring NCache
Cache Counters
Performance Counters
Debugging Counters
Monitoring Caches using NCache Manager
Changing Management Port of a Cache Node
Configuring Counters to Display
Fetching the Statistics using Server IP or Server Name
Cluster Health
Monitoring Cache Clusters using NCache Email Alerts
Monitoring Caches using NCache Monitor
Monitoring Cache Server Counters Using Built-In Dashboard
Monitoring Cache Client Counters Using Built-In Client Dashboard
Monitoring Cache Cluster Counters Using Custom Dashboard
Monitoring Perfmon Counters Using Custom Dashboard
Monitoring Cache Event Logs Using Custom Dashboard
Monitoring Client Process of a Cache Cluster Using Custom Dashboard
ASP.NET Session Monitoring Using Custom Dashboard
Monitoring Bridge Using NCache Manager
Configuring Bridge Counters to Display
Browse Bridge Statistics
Monitoring NCache Using Windows Perfmon Tool
Monitoring Cache Server Counters Using Perfmon Tool
Monitoring Cache Client Counters Using Perfmon Tool
Monitoring Bridge Counters Using Perfmon Tool
Logging
NCache Monitor Logging
Performance Counters Logging
Windows Event Logging
Email Notifications on NCache Events
Cache Server Logging
Client Side API Logging
Programmer's Guide
Client Side API Programming
Setting Up Development Environment
Using Basic Cache Operations
Initialize Cache
Add/Update Data to Cache
Fetch Data from Cache
Remove Data from Cache
Dispose Cache
Bulk Operations
Overview
Using Bulk Operations
Asynchronous Operations
Overview
Using Asynchronous Operations
Group/Subgroup
Overview
Grouping Cached Data
Tags
Overview
Tagging Cached Data
Named Tags
Overview
Using Named Tags
Data Invalidation Strategies
Overview
Using Expirations
Cache Dependencies
Overview
Using Cache Dependencies
Adding Data with File and Key Dependencies
Synchronizing Cache with Relational Database
Using SQL Dependency
Using Oracle Dependency
Using Polling Based Dependency
Using CLR Procedures to Call NCache
Synchronizing Cache with Custom Data Sources
Synchronize Data across Multiple Caches
Add Dependency to the Existing Cached Item
Aggregate Cache Dependency
Locking
Overview
Locking Items in Cache
Using Cache Item Versioning
Object Query Language (OQL) in NCache
Overview
Object Query Language (OQL) Syntax
NCache Language Integrated Query (LINQ)
Querying Data in NCache
Event Notifications
Overview
NCache Event Notifications
Cache Level Data Event Notifications
Item Level Data Event Notifications
Custom Events Notifications
Continuous Query
Overview
Using Continuous Query
Streaming
Overview
Using Streams
Security and Encryption
Overview
Using Security
Data Compression
NCache Management API
Server Side API Programming
Cache Startup Loader
Overview
Using Cache Startup Loader
Data Source Provider (Backing Source)
Overview
Read-Through Caching
Write-Through Caching
Configuring Read-Through Provider
Configuring Write-Through Provider
Dynamic Compact Serialization
Overview
Using Compact Serialization
WAN Replication Through Bridge
Overview
Bridge Configurations
Bridge Conflict Resolver
Custom Dependency
Client Side ASP.NET Features
ASP.NET Sessions
Overview
Using NCache Session State Store Provider
View State Caching
Overview
Using NCache View State Caching
ASP.NET Output Cache
Overview
Using ASP.NET Output Cache
Client Side Third Party Integrations
NHibernate
Overview
Using NCache as NHibernate Second Level Cache
Entity Framework Caching Integration
Overview
Using NCache as Entity Framework Second Level Cache
Memcached
NCache Memcached Gateway Approach
Memcached Client Plug-in for .NET
Troubleshooting
Add Reference issue of Visual Studio 2010
Upgrade NCache without disturbing deployed environment
Troubleshooting Scripts
Viewing Statistics of a Remote Server Node
Troubleshooting Counters
Diskperf Not Installed
No READ Access to Perflib Subkeys
Unable to Connect to Server Node (Windows XP/ Windows 7 Machine)
NCache API
GeneralFailureException
java.lang.NoClassDefFoundError
No server available to process request
SessionStoreProvider not found
IndexNotDefinedException
Implementing Clusters
Compact Serialization Exception
Disabled Netwrok Card
Out of Memory Problem
Maximum Size
Multiple Network Cards
Nodes not Joining
Blocked Node Communication due to Firewall
Two Active Nodes Situation
Installing NCache
NCache Activation Error
Error 1721: A Required Program could not be Run
Upgrade NCache without Disturbing Deployed Environment
Installation Ended Prematurely
Removing NCache assemblies from GAC
NCache Installation Error 1606
Installation Roll Backs on Windows Vista
Using Security
Alachisoft.NCache.Runtime.Exceptions.SecurityException
Cache Event IDs
Troubleshooting Client Socket Deadlock
How to's
How to do NCache Version Upgrades?
What is the Recommended Way to Apply Windows Patches on NCache Server?
How to Debug Providers?
How to Configure and Use NCache Manager for Visual Studio
Installation
Usage
Operations
Creating Clustered Cache
Creating Local Cache
Adding/Removing Server Node to/from Existing Clustered Cache
Adding Server Node
Removing Server Node
Adding/Removing Client Node to/from Existing Clustered Cache
Adding Client Node
Removing Client Node
Configuring Basic Cache Settings
Management Operations
Start Cache
Stop Cache
Start/Stop Service on a Server Node
Configuring Statistics Counters to Display Management Port
Viewing Statistics of a Cache
< Previous page Next page >

Write-Through Provider

NCache supports write-through caching. The idea behind write-through cache is that when an application updates a piece of data in the cache, the operation is not completed until the changed data has been successfully stored in the underlying data source. Though this enhances data integrity but affects the performance negatively in terms of the latency involved in writing to the data store. This latency can be overcomed by write-behind caching.
Using NCache Manager
  • Click on the cache name in Cache Explorer to open cache settings.
  • Go to the Baking Source tab.
  • Check Enable Write-Through on this cache check box to enable it. After enabling it, other options will get enabled as well.
  • Cllick Add to select assembly that has IWriteThruProvider implementation.
  • A new dialog box Add New Provider will open. Enter Provider Name and click on ‘…’ button to browse for assembly implementing IWriteThruProvider interface.
  • Browse for the required assembly and select Open. Name of selected assembly will be appeared in Assembly Name and its classes implementing interface will be listed down in Class Name list box.
  • Select the required read-through provider. You can also provide the values to your read-through provider class, if required. Just write the parameter name in Parameter field and its value against it under the Value field. Click OK.
  • Selected provider class will be listed in Write-Through provider list at Backing Source tab.
  • Now deploy the write-through provider assembly along with its dependency assemblies, if any. Click on the Deploy Provider button at the left bottom of the Backing Source tab. Browse for required assemblies. Select all the required assemblies and click Open.
  • Right click the cache in Cache Explorer and select Apply Configuration option.
Using Command Tool
  • Open command prompt
  • Go to the NCache tools directory: cd %NCHOME%/bin/tools
  • Use addbackingsource.exe tool, provide the required information as:
addbackingsource.exe demoLocalCache /path C:\Downloads\Providers.dll /cNCache.Sample.Providers.Writers.Writer1 /pnwriter1/W
  • Hit ENTER key, it will configure Writer1 write-through provider on demoLocalcache.
  • Now depoly all of the required assemblies (assembly in which you have implemented the write-through provider and all of its dependency assemblies) using deployprovider.exe. Use following command on command prompt:
deployprovider demoLocalCache /T C:\Users\Administrator\Downloads\Providers\
  • Hit ENTER key, it will deploy all of the assemblies from the given path to NCache deploy folder.
See Also
Creating Caches | Configuring Basic Cache Settings | Configuring Cache Cluster Settings | Cache Management Operations | Monitoring Cache Operations | Read-Through Provider | Write-Through Provider for Write-Behind Operations